EZ5 MIB Catalog

ADSL-LINE-EXT-MIB

2002-12-10

Download ADSL-LINE-EXT-MIB.txt Open ADSL-LINE-EXT-MIB.txt in a new tab

Copyright (C) The Internet Society (2002). This version of this MIB module is part of RFC 3440; see the RFC itself for full legal notices. This MIB Module is a supplement to the ADSL-LINE-MIB [RFC2662].

TABLES (7) · TRAPS (5)

Tables (7)

NameOID
adslLineExtTableaugments adslLineTable (ADSL-LINE-MIB)1.3.6.1.2.1.10.94.3.1.17
adslAtucPerfDataExtTableaugments adslAtucPerfDataTable (ADSL-LINE-MIB)1.3.6.1.2.1.10.94.3.1.18
adslAtucIntervalExtTableaugments adslAtucIntervalTable (ADSL-LINE-MIB)1.3.6.1.2.1.10.94.3.1.19
adslAturPerfDataExtTableaugments adslAturPerfDataTable (ADSL-LINE-MIB)1.3.6.1.2.1.10.94.3.1.20
adslAturIntervalExtTableaugments adslAturIntervalTable (ADSL-LINE-MIB)1.3.6.1.2.1.10.94.3.1.21
adslConfProfileExtTableaugments adslLineConfProfileTable (ADSL-LINE-MIB)1.3.6.1.2.1.10.94.3.1.22
adslAlarmConfProfileExtTableaugments adslLineAlarmConfProfileTable (ADSL-LINE-MIB)1.3.6.1.2.1.10.94.3.1.23

Traps (5)

NameOID
adslAtucFailedFastRThreshTrap1.3.6.1.2.1.10.94.3.1.24.1.0.1
adslAtucSesLThreshTrap1.3.6.1.2.1.10.94.3.1.24.1.0.2
adslAtucUasLThreshTrap1.3.6.1.2.1.10.94.3.1.24.1.0.3
adslAturSesLThreshTrap1.3.6.1.2.1.10.94.3.1.24.2.0.1
adslAturUasLThreshTrap1.3.6.1.2.1.10.94.3.1.24.2.0.2

END OF TOC

Table details

adslLineExtTable

1.3.6.1.2.1.10.94.3.1.17

augments adslLineTable (ADSL-LINE-MIB)

Index: ifIndex

This table is an extension of RFC 2662. It contains ADSL line configuration and monitoring information. This includes the ADSL line's capabilities and actual ADSL transmission system.

from IF-MIB

ifIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

adslLineTransAtucCap

1.3.6.1.2.1.10.94.3.1.17.1.1

AdslTransmissionModeTypeA set of ADSL line transmission modes, with one bit per mode. The notes (F) and (L) denote Full-Rate and G.Lite respectively: Bit 00 : Regional Std. (ANSI T1.413) (F) Bit 01 : Regional Std. (ETSI DTS/TM06006) (F) Bit 02 : G.992.1 POTS non-overlapped (F) Bit 03 : G.992.1 POTS overlapped (F) Bit 04 : G.992.1 ISDN non-overlapped (F) Bit 05 : G.992.1 ISDN overlapped (F) Bit 06 : G.992.1 TCM-ISDN non-overlapped (F) Bit 07 : G.992.1 TCM-ISDN overlapped (F) Bit 08 : G.992.2 POTS non-overlapped (L) Bit 09 : G.992.2 POTS overlapped (L) Bit 10 : G.992.2 with TCM-ISDN non-overlapped (L) Bit 11 : G.992.2 with TCM-ISDN overlapped (L) Bit 12 : G.992.1 TCM-ISDN symmetric (F) · BITS

The transmission modes, represented by a bitmask that the ATU-C is capable of supporting. The modes available are limited by the design of the equipment.

adslLineTransAtucConfig

1.3.6.1.2.1.10.94.3.1.17.1.2

AdslTransmissionModeTypeA set of ADSL line transmission modes, with one bit per mode. The notes (F) and (L) denote Full-Rate and G.Lite respectively: Bit 00 : Regional Std. (ANSI T1.413) (F) Bit 01 : Regional Std. (ETSI DTS/TM06006) (F) Bit 02 : G.992.1 POTS non-overlapped (F) Bit 03 : G.992.1 POTS overlapped (F) Bit 04 : G.992.1 ISDN non-overlapped (F) Bit 05 : G.992.1 ISDN overlapped (F) Bit 06 : G.992.1 TCM-ISDN non-overlapped (F) Bit 07 : G.992.1 TCM-ISDN overlapped (F) Bit 08 : G.992.2 POTS non-overlapped (L) Bit 09 : G.992.2 POTS overlapped (L) Bit 10 : G.992.2 with TCM-ISDN non-overlapped (L) Bit 11 : G.992.2 with TCM-ISDN overlapped (L) Bit 12 : G.992.1 TCM-ISDN symmetric (F) · BITS

The transmission modes, represented by a bitmask, currently enabled by the ATU-C. The manager can only set those modes that are supported by the ATU-C. An ATU-C's supported modes are provided by AdslLineTransAtucCap.

adslLineTransAtucActual

1.3.6.1.2.1.10.94.3.1.17.1.3

AdslTransmissionModeTypeA set of ADSL line transmission modes, with one bit per mode. The notes (F) and (L) denote Full-Rate and G.Lite respectively: Bit 00 : Regional Std. (ANSI T1.413) (F) Bit 01 : Regional Std. (ETSI DTS/TM06006) (F) Bit 02 : G.992.1 POTS non-overlapped (F) Bit 03 : G.992.1 POTS overlapped (F) Bit 04 : G.992.1 ISDN non-overlapped (F) Bit 05 : G.992.1 ISDN overlapped (F) Bit 06 : G.992.1 TCM-ISDN non-overlapped (F) Bit 07 : G.992.1 TCM-ISDN overlapped (F) Bit 08 : G.992.2 POTS non-overlapped (L) Bit 09 : G.992.2 POTS overlapped (L) Bit 10 : G.992.2 with TCM-ISDN non-overlapped (L) Bit 11 : G.992.2 with TCM-ISDN overlapped (L) Bit 12 : G.992.1 TCM-ISDN symmetric (F) · BITS

The actual transmission mode of the ATU-C. During ADSL line initialization, the ADSL Transceiver Unit - Remote terminal end (ATU-R) will determine the mode used for the link. This value will be limited a single transmission mode that is a subset of those modes enabled by the ATU-C and denoted by adslLineTransAtucConfig. After an initialization has occurred, its mode is saved as the 'Current' mode and is persistence should the link go down. This object returns 0 (i.e. BITS with no mode bit set) if the mode is not known.

adslLineGlitePowerState

1.3.6.1.2.1.10.94.3.1.17.1.4

INTEGER1 = none2 = l03 = l14 = l3 · Integer32

The value of this object specifies the power state of this interface. L0 is power on, L1 is power on but reduced and L3 is power off. Power state cannot be configured by an operator but it can be viewed via the ifOperStatus object for the managed ADSL interface. The value of the object ifOperStatus is set to down(2) if the ADSL interface is in power state L3 and is set to up(1) if the ADSL line interface is in power state L0 or L1. If the object adslLineTransAtucActual is set to a G.992.2 (G.Lite)-type transmission mode, the value of this object will be one of the valid power states: L0(2), L1(3), or L3(4). Otherwise, its value will be none(1).

adslLineConfProfileDualLite

1.3.6.1.2.1.10.94.3.1.17.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object extends the definition an ADSL line and associated channels (when applicable) for cases when it is configured in dual mode, and operating in a G.Lite-type mode as denoted by adslLineTransAtucActual. Dual mode exists when the object, adslLineTransAtucConfig, is configured with one or more full-rate modes and one or more G.Lite modes simultaneously. When 'dynamic' profiles are implemented, the value of object is equal to the index of the applicable row in the ADSL Line Configuration Profile Table, AdslLineConfProfileTable defined in ADSL-MIB [RFC2662]. In the case when dual-mode has not been enabled, the value of the object will be equal to the value of the object adslLineConfProfile [RFC2662]. When `static' profiles are implemented, in much like the case of the object, adslLineConfProfileName [RFC2662], this object's value will need to algorithmically represent the characteristics of the line. In this case, the value of the line's ifIndex plus a value indicating the line mode type (e.g., G.Lite, Full-rate) will be used. Therefore, the profile's name is a string concatenating the ifIndex and one of the follow values: Full or Lite. This string will be fixed-length (i.e., 14) with leading zero(s). For example, the profile name for ifIndex that equals '15' and is a full rate line, it will be '0000000015Full'.

adslAtucPerfDataExtTable

1.3.6.1.2.1.10.94.3.1.18

augments adslAtucPerfDataTable (ADSL-LINE-MIB)

Index: ifIndex

This table extends adslAtucPerfDataTable [RFC2662] with additional ADSL physical line counter information such as unavailable seconds-line and severely errored seconds-line.

from IF-MIB

ifIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

adslAtucPerfStatFastR

1.3.6.1.2.1.10.94.3.1.18.1.1

Counter32 · line retrains

The value of this object reports the count of the number of fast line bs since last agent reset.

adslAtucPerfStatFailedFastR

1.3.6.1.2.1.10.94.3.1.18.1.2

Counter32 · line retrains

The value of this object reports the count of the number of failed fast line retrains since last agent reset.

adslAtucPerfStatSesL

1.3.6.1.2.1.10.94.3.1.18.1.3

Counter32 · seconds

The value of this object reports the count of the number of severely errored seconds-line since last agent reset.

adslAtucPerfStatUasL

1.3.6.1.2.1.10.94.3.1.18.1.4

Counter32 · seconds

The value of this object reports the count of the number of unavailable seconds-line since last agent reset.

adslAtucPerfCurr15MinFastR

1.3.6.1.2.1.10.94.3.1.18.1.5

PerfCurrentCountA counter associated with a performance measurement in a current 15 minute measurement interval. The value of this counter starts from zero and is increased when associated events occur, until the end of the 15 minute interval. At that time the value of the counter is stored in the first 15 minute history interval, and the CurrentCount is restarted at zero. In the case where the agent has no valid data available for the current interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current 15-minute interval, adslAtucPerfCurr15MinFastR reports the current number of seconds during which there have been fast retrains.

adslAtucPerfCurr15MinFailedFastR

1.3.6.1.2.1.10.94.3.1.18.1.6

PerfCurrentCountA counter associated with a performance measurement in a current 15 minute measurement interval. The value of this counter starts from zero and is increased when associated events occur, until the end of the 15 minute interval. At that time the value of the counter is stored in the first 15 minute history interval, and the CurrentCount is restarted at zero. In the case where the agent has no valid data available for the current interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current 15-minute interval, adslAtucPerfCurr15MinFailedFastR reports the current number of seconds during which there have been failed fast retrains.

adslAtucPerfCurr15MinSesL

1.3.6.1.2.1.10.94.3.1.18.1.7

PerfCurrentCountA counter associated with a performance measurement in a current 15 minute measurement interval. The value of this counter starts from zero and is increased when associated events occur, until the end of the 15 minute interval. At that time the value of the counter is stored in the first 15 minute history interval, and the CurrentCount is restarted at zero. In the case where the agent has no valid data available for the current interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current 15-minute interval, adslAtucPerfCurr15MinSesL reports the current number of seconds during which there have been severely errored seconds-line.

adslAtucPerfCurr15MinUasL

1.3.6.1.2.1.10.94.3.1.18.1.8

PerfCurrentCountA counter associated with a performance measurement in a current 15 minute measurement interval. The value of this counter starts from zero and is increased when associated events occur, until the end of the 15 minute interval. At that time the value of the counter is stored in the first 15 minute history interval, and the CurrentCount is restarted at zero. In the case where the agent has no valid data available for the current interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current 15-minute interval, adslAtucPerfCurr15MinUasL reports the current number of seconds during which there have been unavailable seconds-line.

adslAtucPerfCurr1DayFastR

1.3.6.1.2.1.10.94.3.1.18.1.9

AdslPerfCurrDayCountA counter associated with interface performance measurements in a current 1-day (24 hour) measurement interval. The value of this counter starts at zero at the beginning of an interval and is increased when associated events occur, until the end of the 1-day interval. At that time the value of the counter is stored in the previous 1-day history interval, if available, and the current interval counter is restarted at zero. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current day as measured by adslAtucPerfCurr1DayTimeElapsed [RFC2662], adslAtucPerfCurr1DayFastR reports the number of seconds during which there have been fast retrains.

adslAtucPerfCurr1DayFailedFastR

1.3.6.1.2.1.10.94.3.1.18.1.10

AdslPerfCurrDayCountA counter associated with interface performance measurements in a current 1-day (24 hour) measurement interval. The value of this counter starts at zero at the beginning of an interval and is increased when associated events occur, until the end of the 1-day interval. At that time the value of the counter is stored in the previous 1-day history interval, if available, and the current interval counter is restarted at zero. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current day as measured by adslAtucPerfCurr1DayTimeElapsed [RFC2662], adslAtucPerfCurr1DayFailedFastR reports the number of seconds during which there have been failed fast retrains.

adslAtucPerfCurr1DaySesL

1.3.6.1.2.1.10.94.3.1.18.1.11

AdslPerfCurrDayCountA counter associated with interface performance measurements in a current 1-day (24 hour) measurement interval. The value of this counter starts at zero at the beginning of an interval and is increased when associated events occur, until the end of the 1-day interval. At that time the value of the counter is stored in the previous 1-day history interval, if available, and the current interval counter is restarted at zero. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current day as measured by adslAtucPerfCurr1DayTimeElapsed [RFC2662], adslAtucPerfCurr1DaySesL reports the number of seconds during which there have been severely errored seconds-line.

adslAtucPerfCurr1DayUasL

1.3.6.1.2.1.10.94.3.1.18.1.12

AdslPerfCurrDayCountA counter associated with interface performance measurements in a current 1-day (24 hour) measurement interval. The value of this counter starts at zero at the beginning of an interval and is increased when associated events occur, until the end of the 1-day interval. At that time the value of the counter is stored in the previous 1-day history interval, if available, and the current interval counter is restarted at zero. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current day as measured by adslAtucPerfCurr1DayTimeElapsed [RFC2662], adslAtucPerfCurr1DayUasL reports the number of seconds during which there have been unavailable seconds-line.

adslAtucPerfPrev1DayFastR

1.3.6.1.2.1.10.94.3.1.18.1.13

AdslPerfPrevDayCountA counter associated with interface performance measurements during the most previous 1-day (24 hour) measurement interval. The value of this counter is equal to the value of the current day counter at the end of its most recent interval. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the previous day, adslAtucPerfPrev1DayFastR reports the number of seconds during which there were fast retrains.

adslAtucPerfPrev1DayFailedFastR

1.3.6.1.2.1.10.94.3.1.18.1.14

AdslPerfPrevDayCountA counter associated with interface performance measurements during the most previous 1-day (24 hour) measurement interval. The value of this counter is equal to the value of the current day counter at the end of its most recent interval. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the previous day, adslAtucPerfPrev1DayFailedFastR reports the number of seconds during which there were failed fast retrains.

adslAtucPerfPrev1DaySesL

1.3.6.1.2.1.10.94.3.1.18.1.15

AdslPerfPrevDayCountA counter associated with interface performance measurements during the most previous 1-day (24 hour) measurement interval. The value of this counter is equal to the value of the current day counter at the end of its most recent interval. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the previous day, adslAtucPerfPrev1DaySesL reports the number of seconds during which there were severely errored seconds-line.

adslAtucPerfPrev1DayUasL

1.3.6.1.2.1.10.94.3.1.18.1.16

AdslPerfPrevDayCountA counter associated with interface performance measurements during the most previous 1-day (24 hour) measurement interval. The value of this counter is equal to the value of the current day counter at the end of its most recent interval. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the previous day, adslAtucPerfPrev1DayUasL reports the number of seconds during which there were unavailable seconds-line.

adslAtucIntervalExtTable

1.3.6.1.2.1.10.94.3.1.19

augments adslAtucIntervalTable (ADSL-LINE-MIB)

Index: ifIndex · adslAtucIntervalNumber

This table provides one row for each ATU-C performance data collection interval for ADSL physical interfaces whose IfEntries' ifType is equal to adsl(94).

from IF-MIB

ifIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

from ADSL-LINE-MIB

adslAtucIntervalNumber

INTEGER (1..96) · Integer32

Performance Data Interval number 1 is the the most recent previous interval; interval 96 is 24 hours ago. Intervals 2..96 are optional.

adslAtucIntervalFastR

1.3.6.1.2.1.10.94.3.1.19.1.1

PerfIntervalCountA counter associated with a performance measurement in a previous 15 minute measurement interval. In the case where the agent has no valid data available for a particular interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). In a system supporting a history of n intervals with IntervalCount(1) and IntervalCount(n) the most and least recent intervals respectively, the following applies at the end of a 15 minute interval: - discard the value of IntervalCount(n) - the value of IntervalCount(i) becomes that of IntervalCount(i-1) for n >= i > 1 - the value of IntervalCount(1) becomes that of CurrentCount - the TotalCount, if supported, is adjusted. · Gauge32 · seconds

For the current interval, adslAtucIntervalFastR reports the current number of seconds during which there have been fast retrains.

adslAtucIntervalFailedFastR

1.3.6.1.2.1.10.94.3.1.19.1.2

PerfIntervalCountA counter associated with a performance measurement in a previous 15 minute measurement interval. In the case where the agent has no valid data available for a particular interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). In a system supporting a history of n intervals with IntervalCount(1) and IntervalCount(n) the most and least recent intervals respectively, the following applies at the end of a 15 minute interval: - discard the value of IntervalCount(n) - the value of IntervalCount(i) becomes that of IntervalCount(i-1) for n >= i > 1 - the value of IntervalCount(1) becomes that of CurrentCount - the TotalCount, if supported, is adjusted. · Gauge32 · seconds

For the each interval, adslAtucIntervalFailedFastR reports the number of seconds during which there have been failed fast retrains.

adslAtucIntervalSesL

1.3.6.1.2.1.10.94.3.1.19.1.3

PerfIntervalCountA counter associated with a performance measurement in a previous 15 minute measurement interval. In the case where the agent has no valid data available for a particular interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). In a system supporting a history of n intervals with IntervalCount(1) and IntervalCount(n) the most and least recent intervals respectively, the following applies at the end of a 15 minute interval: - discard the value of IntervalCount(n) - the value of IntervalCount(i) becomes that of IntervalCount(i-1) for n >= i > 1 - the value of IntervalCount(1) becomes that of CurrentCount - the TotalCount, if supported, is adjusted. · Gauge32 · seconds

For the each interval, adslAtucIntervalSesL reports the number of seconds during which there have been severely errored seconds-line.

adslAtucIntervalUasL

1.3.6.1.2.1.10.94.3.1.19.1.4

PerfIntervalCountA counter associated with a performance measurement in a previous 15 minute measurement interval. In the case where the agent has no valid data available for a particular interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). In a system supporting a history of n intervals with IntervalCount(1) and IntervalCount(n) the most and least recent intervals respectively, the following applies at the end of a 15 minute interval: - discard the value of IntervalCount(n) - the value of IntervalCount(i) becomes that of IntervalCount(i-1) for n >= i > 1 - the value of IntervalCount(1) becomes that of CurrentCount - the TotalCount, if supported, is adjusted. · Gauge32 · seconds

For the each interval, adslAtucIntervalUasL reports the number of seconds during which there have been unavailable seconds-line.

adslAturPerfDataExtTable

1.3.6.1.2.1.10.94.3.1.20

augments adslAturPerfDataTable (ADSL-LINE-MIB)

Index: ifIndex

This table contains ADSL physical line counters not defined in the adslAturPerfDataTable from the ADSL-LINE-MIB [RFC2662].

from IF-MIB

ifIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

adslAturPerfStatSesL

1.3.6.1.2.1.10.94.3.1.20.1.1

Counter32 · seconds

The value of this object reports the count of severely errored second-line since the last agent reset.

adslAturPerfStatUasL

1.3.6.1.2.1.10.94.3.1.20.1.2

Counter32 · seconds

The value of this object reports the count of unavailable seconds-line since the last agent reset.

adslAturPerfCurr15MinSesL

1.3.6.1.2.1.10.94.3.1.20.1.3

PerfCurrentCountA counter associated with a performance measurement in a current 15 minute measurement interval. The value of this counter starts from zero and is increased when associated events occur, until the end of the 15 minute interval. At that time the value of the counter is stored in the first 15 minute history interval, and the CurrentCount is restarted at zero. In the case where the agent has no valid data available for the current interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current 15-minute interval, adslAturPerfCurr15MinSesL reports the current number of seconds during which there have been severely errored seconds-line.

adslAturPerfCurr15MinUasL

1.3.6.1.2.1.10.94.3.1.20.1.4

PerfCurrentCountA counter associated with a performance measurement in a current 15 minute measurement interval. The value of this counter starts from zero and is increased when associated events occur, until the end of the 15 minute interval. At that time the value of the counter is stored in the first 15 minute history interval, and the CurrentCount is restarted at zero. In the case where the agent has no valid data available for the current interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current 15-minute interval, adslAturPerfCurr15MinUasL reports the current number of seconds during which there have been available seconds-line.

adslAturPerfCurr1DaySesL

1.3.6.1.2.1.10.94.3.1.20.1.5

AdslPerfCurrDayCountA counter associated with interface performance measurements in a current 1-day (24 hour) measurement interval. The value of this counter starts at zero at the beginning of an interval and is increased when associated events occur, until the end of the 1-day interval. At that time the value of the counter is stored in the previous 1-day history interval, if available, and the current interval counter is restarted at zero. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current day as measured by adslAturPerfCurr1DayTimeElapsed [RFC2662], adslAturPerfCurr1DaySesL reports the number of seconds during which there have been severely errored seconds-line.

adslAturPerfCurr1DayUasL

1.3.6.1.2.1.10.94.3.1.20.1.6

AdslPerfCurrDayCountA counter associated with interface performance measurements in a current 1-day (24 hour) measurement interval. The value of this counter starts at zero at the beginning of an interval and is increased when associated events occur, until the end of the 1-day interval. At that time the value of the counter is stored in the previous 1-day history interval, if available, and the current interval counter is restarted at zero. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current day as measured by adslAturPerfCurr1DayTimeElapsed [RFC2662], adslAturPerfCurr1DayUasL reports the number of seconds during which there have been unavailable seconds-line.

adslAturPerfPrev1DaySesL

1.3.6.1.2.1.10.94.3.1.20.1.7

AdslPerfPrevDayCountA counter associated with interface performance measurements during the most previous 1-day (24 hour) measurement interval. The value of this counter is equal to the value of the current day counter at the end of its most recent interval. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the previous day, adslAturPerfPrev1DaySesL reports the number of seconds during which there were severely errored seconds-line.

adslAturPerfPrev1DayUasL

1.3.6.1.2.1.10.94.3.1.20.1.8

AdslPerfPrevDayCountA counter associated with interface performance measurements during the most previous 1-day (24 hour) measurement interval. The value of this counter is equal to the value of the current day counter at the end of its most recent interval. In the case where the agent has no valid data available for this interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the previous day, adslAturPerfPrev1DayUasL reports the number of seconds during which there were severely errored seconds-line.

adslAturIntervalExtTable

1.3.6.1.2.1.10.94.3.1.21

augments adslAturIntervalTable (ADSL-LINE-MIB)

Index: ifIndex · adslAturIntervalNumber

This table provides one row for each ATU-R performance data collection interval for ADSL physical interfaces whose IfEntries' ifType is equal to adsl(94).

from IF-MIB

ifIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

from ADSL-LINE-MIB

adslAturIntervalNumber

INTEGER (1..96) · Integer32

Performance Data Interval number 1 is the the most recent previous interval; interval 96 is 24 hours ago. Intervals 2..96 are optional.

adslAturIntervalSesL

1.3.6.1.2.1.10.94.3.1.21.1.1

PerfIntervalCountA counter associated with a performance measurement in a previous 15 minute measurement interval. In the case where the agent has no valid data available for a particular interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). In a system supporting a history of n intervals with IntervalCount(1) and IntervalCount(n) the most and least recent intervals respectively, the following applies at the end of a 15 minute interval: - discard the value of IntervalCount(n) - the value of IntervalCount(i) becomes that of IntervalCount(i-1) for n >= i > 1 - the value of IntervalCount(1) becomes that of CurrentCount - the TotalCount, if supported, is adjusted. · Gauge32 · seconds

For the each interval, adslAturIntervalSesL reports the number of seconds during which there have been severely errored seconds-line.

adslAturIntervalUasL

1.3.6.1.2.1.10.94.3.1.21.1.2

PerfIntervalCountA counter associated with a performance measurement in a previous 15 minute measurement interval. In the case where the agent has no valid data available for a particular interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). In a system supporting a history of n intervals with IntervalCount(1) and IntervalCount(n) the most and least recent intervals respectively, the following applies at the end of a 15 minute interval: - discard the value of IntervalCount(n) - the value of IntervalCount(i) becomes that of IntervalCount(i-1) for n >= i > 1 - the value of IntervalCount(1) becomes that of CurrentCount - the TotalCount, if supported, is adjusted. · Gauge32 · seconds

For the each interval, adslAturIntervalUasL reports the number of seconds during which there have been unavailable seconds-line.

adslConfProfileExtTable

1.3.6.1.2.1.10.94.3.1.22

augments adslLineConfProfileTable (ADSL-LINE-MIB)

Index: IMPLIED adslLineConfProfileName

The adslConfProfileExtTable extends the ADSL line profile configuration information in the adslLineConfProfileTable from the ADSL-LINE-MIB [RFC2662] by adding the ability to configure the ADSL physical line mode.

from ADSL-LINE-MIB

adslLineConfProfileName

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..32) · OCTET STRING · hint 255t

This object is used by the line configuration table in order to identify a row of this table. When `dynamic' profiles are implemented, the profile name is user specified. Also, the system will always provide a default profile whose name is `DEFVAL'. When `static' profiles are implemented, there is an one-to-one relationship between each line and its profile. In which case, the profile name will need to algorithmicly represent the Line's ifIndex. Therefore, the profile's name is a decimalized string of the ifIndex that is fixed-length (i.e., 10) with leading zero(s). For example, the profile name for ifIndex which equals '15' will be '0000000015'.

adslConfProfileLineType

1.3.6.1.2.1.10.94.3.1.22.1.1

INTEGER1 = noChannel2 = fastOnly3 = interleavedOnly4 = fastOrInterleaved5 = fastAndInterleaved · Integer32

This object is used to configure the ADSL physical line mode. It has following valid values: noChannel(1), when no channels exist. fastOnly(2), when only fast channel exists. interleavedOnly(3), when only interleaved channel exist. fastOrInterleaved(4), when either fast or interleaved channels can exist, but only one at any time. fastAndInterleaved(5), when both the fast channel and the interleaved channel exist. In the case when no value has been set, the default Value is noChannel(1).

adslAlarmConfProfileExtTable

1.3.6.1.2.1.10.94.3.1.23

augments adslLineAlarmConfProfileTable (ADSL-LINE-MIB)

Index: IMPLIED adslLineAlarmConfProfileName

This table extends the adslLineAlarmConfProfileTable and provides threshold parameters for all the counters defined in this MIB module.

from ADSL-LINE-MIB

adslLineAlarmConfProfileName

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..32) · OCTET STRING · hint 255t

This object is used by the line alarm configuration table in order to identify a row of this table. When `dynamic' profiles are implemented, the profile name is user specified. Also, the system will always provide a default profile whose name is `DEFVAL'. When `static' profiles are implemented, there is an one-to-one relationship between each line and its profile. In which case, the profile name will need to algorithmicly represent the Line's ifIndex. Therefore, the profile's name is a decimalized string of the ifIndex that is fixed-length (i.e., 10) with leading zero(s). For example, the profile name for ifIndex which equals '15' will be '0000000015'.

adslAtucThreshold15MinFailedFastR

1.3.6.1.2.1.10.94.3.1.23.1.1

Integer32 (0..900) · seconds

The first time the value of the corresponding instance of adslAtucPerfCurr15MinFailedFastR reaches or exceeds this value within a given 15-minute performance data collection period, an adslAtucFailedFastRThreshTrap notification will be generated. The value '0' will disable the notification. The default value of this object is '0'.

adslAtucThreshold15MinSesL

1.3.6.1.2.1.10.94.3.1.23.1.2

Integer32 (0..900) · seconds

The first time the value of the corresponding instance of adslAtucPerf15MinSesL reaches or exceeds this value within a given 15-minute performance data collection period, an adslAtucSesLThreshTrap notification will be generated. The value '0' will disable the notification. The default value of this object is '0'.

adslAtucThreshold15MinUasL

1.3.6.1.2.1.10.94.3.1.23.1.3

Integer32 (0..900) · seconds

The first time the value of the corresponding instance of adslAtucPerf15MinUasL reaches or exceeds this value within a given 15-minute performance data collection period, an adslAtucUasLThreshTrap notification will be generated. The value '0' will disable the notification. The default value of this object is '0'.

adslAturThreshold15MinSesL

1.3.6.1.2.1.10.94.3.1.23.1.4

Integer32 (0..900) · seconds

The first time the value of the corresponding instance of adslAturPerf15MinSesL reaches or exceeds this value within a given 15-minute performance data collection period, an adslAturSesLThreshTrap notification will be generated. The value '0' will disable the notification. The default value of this object is '0'.

adslAturThreshold15MinUasL

1.3.6.1.2.1.10.94.3.1.23.1.5

Integer32 (0..900) · seconds

The first time the value of the corresponding instance of adslAturPerf15MinUasL reaches or exceeds this value within a given 15-minute performance data collection period, an adslAturUasLThreshTrap notification will be generated. The value '0' will disable the notification. The default value of this object is '0'.

Trap details

adslAtucFailedFastRThreshTrap

1.3.6.1.2.1.10.94.3.1.24.1.0.1

Failed Fast Retrains 15-minute threshold reached.

adslAtucPerfCurr15MinFailedFastR

1.3.6.1.2.1.10.94.3.1.18.1.6

PerfCurrentCountA counter associated with a performance measurement in a current 15 minute measurement interval. The value of this counter starts from zero and is increased when associated events occur, until the end of the 15 minute interval. At that time the value of the counter is stored in the first 15 minute history interval, and the CurrentCount is restarted at zero. In the case where the agent has no valid data available for the current interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current 15-minute interval, adslAtucPerfCurr15MinFailedFastR reports the current number of seconds during which there have been failed fast retrains.

adslAtucSesLThreshTrap

1.3.6.1.2.1.10.94.3.1.24.1.0.2

Severely errored seconds-line 15-minute threshold reached.

adslAtucPerfCurr15MinSesL

1.3.6.1.2.1.10.94.3.1.18.1.7

PerfCurrentCountA counter associated with a performance measurement in a current 15 minute measurement interval. The value of this counter starts from zero and is increased when associated events occur, until the end of the 15 minute interval. At that time the value of the counter is stored in the first 15 minute history interval, and the CurrentCount is restarted at zero. In the case where the agent has no valid data available for the current interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current 15-minute interval, adslAtucPerfCurr15MinSesL reports the current number of seconds during which there have been severely errored seconds-line.

adslAtucUasLThreshTrap

1.3.6.1.2.1.10.94.3.1.24.1.0.3

Unavailable seconds-line 15-minute threshold reached.

adslAtucPerfCurr15MinUasL

1.3.6.1.2.1.10.94.3.1.18.1.8

PerfCurrentCountA counter associated with a performance measurement in a current 15 minute measurement interval. The value of this counter starts from zero and is increased when associated events occur, until the end of the 15 minute interval. At that time the value of the counter is stored in the first 15 minute history interval, and the CurrentCount is restarted at zero. In the case where the agent has no valid data available for the current interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current 15-minute interval, adslAtucPerfCurr15MinUasL reports the current number of seconds during which there have been unavailable seconds-line.

adslAturSesLThreshTrap

1.3.6.1.2.1.10.94.3.1.24.2.0.1

Severely errored seconds-line 15-minute threshold reached.

adslAturPerfCurr15MinSesL

1.3.6.1.2.1.10.94.3.1.20.1.3

PerfCurrentCountA counter associated with a performance measurement in a current 15 minute measurement interval. The value of this counter starts from zero and is increased when associated events occur, until the end of the 15 minute interval. At that time the value of the counter is stored in the first 15 minute history interval, and the CurrentCount is restarted at zero. In the case where the agent has no valid data available for the current interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current 15-minute interval, adslAturPerfCurr15MinSesL reports the current number of seconds during which there have been severely errored seconds-line.

adslAturUasLThreshTrap

1.3.6.1.2.1.10.94.3.1.24.2.0.2

Unavailable seconds-line 15-minute threshold reached.

adslAturPerfCurr15MinUasL

1.3.6.1.2.1.10.94.3.1.20.1.4

PerfCurrentCountA counter associated with a performance measurement in a current 15 minute measurement interval. The value of this counter starts from zero and is increased when associated events occur, until the end of the 15 minute interval. At that time the value of the counter is stored in the first 15 minute history interval, and the CurrentCount is restarted at zero. In the case where the agent has no valid data available for the current interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchName error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). · Gauge32 · seconds

For the current 15-minute interval, adslAturPerfCurr15MinUasL reports the current number of seconds during which there have been available seconds-line.

↑ To TOC