EZ5 MIB Catalog

APPLICATION-MIB

1998-11-17

Download APPLICATION-MIB.txt Open APPLICATION-MIB.txt in a new tab

This MIB defines objects representing generic aspects of applications that are of interest to management but typically require instrumentation within managed application elements.

TABLES (19)

Tables (19)

NameOID
applSrvNameToSrvInstTable1.3.6.1.2.1.62.1.1.1
applSrvInstToSrvNameTable1.3.6.1.2.1.62.1.1.2
applSrvInstToRunApplElmtTable1.3.6.1.2.1.62.1.1.3
applRunApplElmtToSrvInstTable1.3.6.1.2.1.62.1.1.4
applOpenChannelTable1.3.6.1.2.1.62.1.2.1
applOpenFileTable1.3.6.1.2.1.62.1.2.2
applOpenConnectionTable1.3.6.1.2.1.62.1.2.3
applTransactionStreamTable1.3.6.1.2.1.62.1.2.4
applTransactFlowTable1.3.6.1.2.1.62.1.2.5
applTransactKindTable1.3.6.1.2.1.62.1.2.6
applPastChannelControlTable1.3.6.1.2.1.62.1.3.1
applPastChannelTable1.3.6.1.2.1.62.1.3.2
applPastFileTable1.3.6.1.2.1.62.1.3.3
applPastConTable1.3.6.1.2.1.62.1.3.4
applPastTransStreamTable1.3.6.1.2.1.62.1.3.5
applPastTransFlowTable1.3.6.1.2.1.62.1.3.6
applPastTransKindTable1.3.6.1.2.1.62.1.3.7
applElmtRunStatusTable1.3.6.1.2.1.62.1.4.1
applElmtRunControlTable1.3.6.1.2.1.62.1.4.2

END OF TOC

Table details

applSrvNameToSrvInstTable

1.3.6.1.2.1.62.1.1.1

Index: applSrvName · applSrvIndex

The service name to service instance table uses service name as its primary key, and service instance identifier as its secondary key. It facilitates the identification and lookup of the instances of a given service in a system.

applSrvInstQual

1.3.6.1.2.1.62.1.1.1.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The value of applSrcInstQual provides additional information about this particular instance of this service. Although not used for indexing purposes, the value of this attribute should be sufficiently unique to be helpful to an administrator in distinguishing among service instances.

applSrvInstToSrvNameTable

1.3.6.1.2.1.62.1.1.2

Index: applSrvIndex · applSrvName

The service instance to service name table uses service instance identifier as its primary key, and service name as its secondary key. Given a service instance identifier, it facilitates the lookup of the name of the service being provided.

applSrvName

1.3.6.1.2.1.62.1.1.2.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The human-readable name of a service. Where appropriate, as in the case where a service can be identified in terms of a single protocol, the strings should be established names such as those assigned by IANA and found in STD 2 [13], or defined by some other authority. In some cases private conventions apply and the string should in these cases be consistent with these non-standard conventions. An applicability statement may specify the service name(s) to be used.

applSrvInstToRunApplElmtTable

1.3.6.1.2.1.62.1.1.3

Index: applSrvIndex · sysApplElmtRunIndex

The service instance to running application element table uses the service instance identifier as its primary key, and the running application element index as its secondary key. This facilitates the identification of the set of running application elements providing a given instance of a service.

from SYSAPPL-MIB

sysApplElmtRunIndex

Unsigned32

Part of the index for this table. A unique value for each process running on the host. Wherever possible, this should be the system's native, unique identification number.

applSrvIndex

1.3.6.1.2.1.62.1.1.3.1.1

Unsigned32 (1..4294967295)

An applSrvIndex is the system-unique identifier of an instance of a service. The value is unique not only across all instances of a given service, but also across all services in a system. Re-use of values for this index should be avoided. No two service instances in a given system shall concurrently have the same value for this index. The value zero is excluded from the set of permitted values for this index. This allows other tables to potentially represent things which cannot be associated with a specific service instance.

applRunApplElmtToSrvInstTable

1.3.6.1.2.1.62.1.1.4

Index: sysApplElmtRunIndex · applSrvInstance

The running application element to service instance table uses the running application element index as its primary key and the service instance identifier as its secondary key. It identifies the set of services provided by a given running application element.

from SYSAPPL-MIB

sysApplElmtRunIndex

Unsigned32

Part of the index for this table. A unique value for each process running on the host. Wherever possible, this should be the system's native, unique identification number.

applSrvInstance

1.3.6.1.2.1.62.1.1.4.1.1

Unsigned32 (1..4294967295)

An applSrvInstance is the system-unique identifier of an instance of a service. The value is unique not only across all instances of a given service, but also across all services. Re-use of values for this index should be avoided. No two service instances in a given system shall concurrently have the same value for this index. The value zero is excluded from the set of permitted values for this index. This allows other tables to potentially represent things which cannot be associated with a specific service instance. This attribute is semantically identical to applSrvIndex.

applOpenChannelTable

1.3.6.1.2.1.62.1.2.1

Index: applElmtOrSvc · applElmtOrSvcId · applOpenChannelIndex

The applOpenChannelTable reports information on open channels for running application elements and for service instances. This table is indexed by applElmtOrSvc, applElmtOrSvcId, and applOpenChannelIndex. This effectively groups all entries for a given running application element or service instance together. ApplChannelIndex uniquely identifies an open channel (and, consequently, a file or connection) within the context of a particular running application element or service instance. Some of the information in this table is available through both sixty-four and thirty-two bit counters. The sixty-four bit counters are not accessible in protocols that do not support this data type.

applElmtOrSvc

1.3.6.1.2.1.62.1.2.1.1.1

INTEGER1 = service2 = element · Integer32

The applElmtOrSvc attribute serves as an index for tables that can hold information both for individual running application elements as well as for service instances. If the value is service(1), the row contains information gathered at the level of a service. If the value is element(2), the row contains information for an individual running application element.

applElmtOrSvcId

1.3.6.1.2.1.62.1.2.1.1.2

Unsigned32 (1..4294967295)

The applElmtOrSvcId attribute is used as an index in conjunction with the applElmtOrSvc attribute. When the value of applElmtOrSvc is service(1), this attribute's value corresponds to that of applSrvIndex, when the value of applElmtOrSvc is element(2), this attribute's value corresponds to sysApplElmtRunIndex.

applOpenChannelIndex

1.3.6.1.2.1.62.1.2.1.1.3

Unsigned32

This attribute serves to uniquely identify this open connection in the context of the running application element or service instance. Where suitable, the application's native descriptor number should be used.

applOpenChannelOpenTime

1.3.6.1.2.1.62.1.2.1.1.4

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

This attribute records the value of sysUpTime.0 when this channel was opened and this entry was added to this table. This attribute serves as a discontinuity indicator for the counter attributes in this entry and for any corresponding entries in the applOpenConnectionTable, applOpenFileTable, and the applTransactionStreamTable.

applOpenChannelReadRequests

1.3.6.1.2.1.62.1.2.1.1.5

Counter64 (0..18446744073709551615) · read requests

This attribute reports the number of read requests for this channel. All read requests for this channel by this entity, regardless of completion status, are included in this count. Read requests are counted in terms of system calls, rather than API calls. Discontinuities in this counter can be detected by monitoring the applOpenChannelOpenTime value for this entry.

applOpenChannelReadRequestsLow

1.3.6.1.2.1.62.1.2.1.1.6

Counter32 · read requests

This attribute reports the low thirty-two bits of applOpenChannelReadRequests. Discontinuities in this counter can be detected by monitoring the applOpenChannelOpenTime value for this entry.

applOpenChannelReadFailures

1.3.6.1.2.1.62.1.2.1.1.7

Counter32 · failed read requests

This attribute reports the number of failed read requests. Discontinuities in this counter can be detected by monitoring the applOpenChannelOpenTime value for this entry.

applOpenChannelBytesRead

1.3.6.1.2.1.62.1.2.1.1.8

Counter64 (0..18446744073709551615) · bytes

This attribute reports the number of bytes read from this channel. Only bytes successfully read are included in this count. Discontinuities in this counter can be detected by monitoring the applOpenChannelOpenTime value for this entry.

applOpenChannelBytesReadLow

1.3.6.1.2.1.62.1.2.1.1.9

Counter32 · bytes

This attribute corresponds to the low thirty-two bits of applOpenChannelBytesRead. Discontinuities in this counter can be detected by monitoring the applOpenChannelOpenTime value for this entry.

applOpenChannelLastReadTime

1.3.6.1.2.1.62.1.2.1.1.10

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This attribute reports the time of the most recent read request made by this entity, regardless of completion status, for this open channel. If no read requests have been made the value of this attribute shall be '0000000000000000'H

applOpenChannelWriteRequests

1.3.6.1.2.1.62.1.2.1.1.11

Counter64 (0..18446744073709551615) · write requests

This attribute reports the number of write requests for this channel made by this entity. All write requests for this channel, regardless of completion status, are included in this count. Write requests are counted in terms of system calls, rather than API calls. Discontinuities in this counter can be detected by monitoring the applOpenChannelOpenTime value for this entry.

applOpenChannelWriteRequestsLow

1.3.6.1.2.1.62.1.2.1.1.12

Counter32 · write requests

This attribute corresponds to the low thirty-two bits of applOpenChannelWriteRequests. Discontinuities in this counter can be detected by monitoring the applOpenChannelOpenTime value for this entry.

applOpenChannelWriteFailures

1.3.6.1.2.1.62.1.2.1.1.13

Counter32 · failed write requests

This attribute reports the number of failed write requests. Discontinuities in this counter can be detected by monitoring the applOpenChannelOpenTime value for this entry.

applOpenChannelBytesWritten

1.3.6.1.2.1.62.1.2.1.1.14

Counter64 (0..18446744073709551615) · bytes

This attribute reports the number of bytes written to this channel. Only bytes successfully written (without errors reported by the system to the API in use by the application) are included in this count. Discontinuities in this counter can be detected by monitoring the applOpenChannelOpenTime value for this entry.

applOpenChannelBytesWrittenLow

1.3.6.1.2.1.62.1.2.1.1.15

Counter32 · bytes

This attribute corresponds to the low thirty-two bits of applOpenChannelBytesWritten. Discontinuities in this counter can be detected by monitoring the applOpenChannelOpenTime value for this entry.

applOpenChannelLastWriteTime

1.3.6.1.2.1.62.1.2.1.1.16

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This attribute reports the time of the most recent write request made by this running application element or service instance, regardless of completion status, for this open channel. If no write requests have been made, the value of this attribute shall be '0000000000000000'H

applOpenFileTable

1.3.6.1.2.1.62.1.2.2

Index: applElmtOrSvc · applElmtOrSvcId · applOpenChannelIndex

The applOpenFileTable reports information on open files for service instances or application elements. This table is indexed by applElmtOrSvc and applElmtOrSvcId, effectively grouping all entries for a given running service instance or application element together, and by applOpenChannelIndex, uniquely identifying an open channel (and, consequently, a file) within the context of a particular service instance or application element. Elements in this table correspond to elements in the applOpenChannelTable that represent files. For rows in the applOpenChannelTable that do not represent files, corresponding rows in this table will not exist.

applOpenFileName

1.3.6.1.2.1.62.1.2.2.1.1

LongUtf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..1024) · OCTET STRING · hint 1024a

This attribute reports the name of this open file. Wherever practical, a fully qualified path name should be reported. The values 'stdin', 'stdout', and 'stderr' are reserved in accordance with common usage when the fully qualified path name cannot be determined.

applOpenFileSizeHigh

1.3.6.1.2.1.62.1.2.2.1.2

Unsigned32 · 2^32 byte blocks

This file's current size in 2^32 byte blocks. For example, for a file with a total size of 4,294,967,296 bytes, this attribute would have a value of 1; for a file with a total size of 4,294,967,295 bytes this attribute's value would be 0.

applOpenFileSizeLow

1.3.6.1.2.1.62.1.2.2.1.3

Unsigned32 · bytes

This file's current size modulo 2^32 bytes. For example, for a file with a total size of 4,294,967,296 bytes this attribute would have a value of 0; for a file with a total size of 4,294,967,295 bytes this attribute's value would be 4,294,967,295.

applOpenFileMode

1.3.6.1.2.1.62.1.2.2.1.4

INTEGER1 = read2 = write3 = readWrite · Integer32

This attribute reports the current mode of this file from the perspective of this running application element. These values have the following meanings: read(1) - file opened for reading only write(2) - file opened for writing only readWrite(3) - file opened for read and write. These values correspond to the POSIX/ANSI C library function fopen() 'type' parameter, using the following mappings: r -> read(1) w -> write(2) a -> write(2) + -> readWrite(3)

applOpenConnectionTable

1.3.6.1.2.1.62.1.2.3

Index: applElmtOrSvc · applElmtOrSvcId · applOpenChannelIndex

The applOpenConnectionTable provides information about open and listening connections from the perspective of a running application element or service instance. Entries in this table are indexed by applElmtOrSvc, applElmtOrSvcID, and by applOpenChannelIndex, which serves to uniquely identify each connection in the context of a service instance or running application element. For each row in this table, a corresponding row will exist in the applOpenChannel table. For rows in the applOpenChannelTable which do not represent open or listening connections, no corresponding rows will exist in this table.

applOpenConnectionTransport

1.3.6.1.2.1.62.1.2.3.1.1

TDomainDenotes a kind of transport service. Some possible values, such as snmpUDPDomain, are defined in the SNMPv2-TM MIB module. Other possible values are defined in other MIB modules.Reference: The SNMPv2-TM MIB module is defined in RFC 1906. · OBJECT IDENTIFIER

The applOpenConnectionTransport attribute identifies the transport protocol in use for this connection. If it is not practical to determine the underlying transport, this attribute's value shall have a value of {0 0}.

applOpenConnectionNearEndAddr

1.3.6.1.2.1.62.1.2.3.1.2

ApplTAddressDenotes a transport service address. For snmpUDPDomain, an ApplTAddress is 6 octets long, the initial 4 octets containing the IP-address in network-byte order and the last 2 containing the UDP port in network-byte order. Consult 'Transport Mappings for Version 2 of the Simple Network Management Protocol (SNMPv2)' for further information on snmpUDPDomain. SIZE (0..255) · OCTET STRING

The applOpenConnectionNearEndAddr attribute reports the transport address and port information for the near end of this connection. If the value is not known, the value has a length of zero.

applOpenConnectionNearEndpoint

1.3.6.1.2.1.62.1.2.3.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The applOpenConnectionNearEndpoint attribute reports the fully-qualified domain name and port information for the near end of this connection. The format of this attribute for TCP and UDP-based protocols is the fully-qualified domain name immediately followed by a colon which is immediately followed by the decimal representation of the port number. If the value is not known, the value has a length of zero.

applOpenConnectionFarEndAddr

1.3.6.1.2.1.62.1.2.3.1.4

ApplTAddressDenotes a transport service address. For snmpUDPDomain, an ApplTAddress is 6 octets long, the initial 4 octets containing the IP-address in network-byte order and the last 2 containing the UDP port in network-byte order. Consult 'Transport Mappings for Version 2 of the Simple Network Management Protocol (SNMPv2)' for further information on snmpUDPDomain. SIZE (0..255) · OCTET STRING

The applOpenConnectionFarEndAddr attribute reports the transport address and port information for the far end of this connection. If not known, as in the case of a connectionless transport, the value of this attribute shall be a zero-length string.

applOpenConnectionFarEndpoint

1.3.6.1.2.1.62.1.2.3.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The applOpenConnectionFarEndpoint attribute reports the fully-qualified domain name and port information for the far end of this connection. The format of this attribute for TCP and UDP-based protocols is the fully-qualified domain name immediately followed by a colon which is immediately followed by the decimal representation of the port number. If not known, as in the case of a connectionless transport, the value of this attribute shall be a zero-length string.

applOpenConnectionApplication

1.3.6.1.2.1.62.1.2.3.1.6

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The applOpenConnectionApplication attribute identifies the application layer protocol in use. If not known, the value of this attribute shall be a zero-length string. When possible, protocol names should be those used in the 'ASSIGNED NUMBERS' [13]. For example, an SMTP mail server would use 'SMTP'.

applTransactionStreamTable

1.3.6.1.2.1.62.1.2.4

Index: applElmtOrSvc · applElmtOrSvcId · applOpenChannelIndex

The applTransactionStreamTable contains common information for transaction statistic accumulation.

applTransactStreamDescr

1.3.6.1.2.1.62.1.2.4.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The applTransactStreamDescr attribute provides a human-readable description of this transaction stream. If no descriptive information is available, this attribute's value shall be a zero-length string.

applTransactStreamUnitOfWork

1.3.6.1.2.1.62.1.2.4.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The applTransactStreamUnitOfWork attribute provides a human-readable definition of what the unit of work is for this transaction stream. If no descriptive information is available, this attribute's value shall be a zero-length string.

applTransactStreamInvokes

1.3.6.1.2.1.62.1.2.4.1.3

Counter64 (0..18446744073709551615) · transactions

Cumulative count of requests / invocations issued. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactStreamInvokesLow

1.3.6.1.2.1.62.1.2.4.1.4

Counter32 · transactions

This counter corresponds to the low thirty-two bits of applTransactStreamInvokes. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactStreamInvCumTimes

1.3.6.1.2.1.62.1.2.4.1.5

Counter32 · milliseconds

The applTransactStreamInvCumTimes attribute reports the cumulative sum of the lengths of the intervals measured between the transmission of requests and the receipt of (the first of) the corresponding response(s). Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactStreamInvRspTimes

1.3.6.1.2.1.62.1.2.4.1.6

Counter32 · milliseconds

The applTransactStreamInvRspTimes attribute reports the cumulative sum of the lengths of the intervals measured between the receipt of the first and last of multiple responses to a request. For transaction streams which do not permit multiple responses to a single request, this attribute will be constant. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactStreamPerforms

1.3.6.1.2.1.62.1.2.4.1.7

Counter64 (0..18446744073709551615) · transactions

Cumulative count of transactions performed. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactStreamPerformsLow

1.3.6.1.2.1.62.1.2.4.1.8

Counter32 · transactions

This counter reports the low thirty-two bits of applTransactStreamPerforms. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactStreamPrfCumTimes

1.3.6.1.2.1.62.1.2.4.1.9

Counter32 · milliseconds

The applTransactStreamPrfCumTimes attribute reports the cumulative sum of the interval lengths measured between receipt of requests and the transmission of the corresponding responses. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactStreamPrfRspTimes

1.3.6.1.2.1.62.1.2.4.1.10

Counter32 · milliseconds

For each transaction performed, the elapsed time between when the first response is enqueued and when the last response is enqueued is added to this cumulative sum. For single-response protocols, the value of applTransactStreamPrfRspTimes will be constant. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactFlowTable

1.3.6.1.2.1.62.1.2.5

Index: applElmtOrSvc · applElmtOrSvcId · applOpenChannelIndex · applTransactFlowDirection · applTransactFlowReqRsp

The applTransactFlowTable contains entries, organized by application instance or running application element, direction of flow, and type (request/response) for each open transaction stream. The simple model of a transaction used here looks like this: invoker | Request | performer | - - - - - - > | | | | Response | | < - - - - - - | | | Since in some protocols it is possible for an entity to take on both the invoker and performer roles, information here is accumulated for transmitted and received requests, as well as for transmitted and received responses. Counts are maintained for both transactions and bytes transferred.

applTransactFlowDirection

1.3.6.1.2.1.62.1.2.5.1.1

INTEGER1 = transmit2 = receive · Integer32

The applTransactFlowDirection index serves to identify an entry as containing information pertaining to the transmit (1) or receive (2) flow of a transaction stream.

applTransactFlowReqRsp

1.3.6.1.2.1.62.1.2.5.1.2

INTEGER1 = request2 = response · Integer32

The value of the applTransactFlowReqRsp index indicates whether this entry contains information on requests (1), or responses (2).

applTransactFlowTrans

1.3.6.1.2.1.62.1.2.5.1.3

Counter64 (0..18446744073709551615) · transactions

The applTransactFlowTrans attribute reports the number of request/response transactions (as indicated by the applTransactFlowReqRsp index) received/generated (as indicated by the applTransactFlowDirection index) that this service instance or running application element has processed for this transaction stream. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactFlowTransLow

1.3.6.1.2.1.62.1.2.5.1.4

Counter32 · transactions

This attribute corresponds to the low thirty-two bits of applTransactFlowTrans. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactFlowBytes

1.3.6.1.2.1.62.1.2.5.1.5

Counter64 (0..18446744073709551615) · bytes

The applTransactFlowBytes attribute reports the number of request/response (as indicated by the applTransactFlowReqRsp index) bytes received/generated (as indicated by the applTransactFlowDirection index) handled by this application element or service instance on this transaction stream. All application layer bytes are included in this count, including any application layer wrappers, headers, or other overhead. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactFlowBytesLow

1.3.6.1.2.1.62.1.2.5.1.6

Counter32 · bytes

This attribute corresponds to the low thirty-two bits of applTransactFlowBytes. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactFlowTime

1.3.6.1.2.1.62.1.2.5.1.7

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The applTransactFlowTime attribute records the time of the processing (receipt or transmission as indicated by the applTransactFlowDirection index) by this running application element or service instance of the most recent request/response (as indicated by the applTransactFlowReqRsp index) on this transaction stream. If no requests/responses been received/transmitted by this entity over this transaction stream, the value of this attribute shall be '0000000000000000'H

applTransactKindTable

1.3.6.1.2.1.62.1.2.6

Index: applElmtOrSvc · applElmtOrSvcId · applOpenChannelIndex · applTransactFlowDirection · applTransactFlowReqRsp · applTransactKind

The applTransactKindTable provides transaction statistics broken down by kinds of transaction. The definition of the kinds of transactions is specific to the application protocol in use, and may be documented in the form of an applicability statement.

applTransactKind

1.3.6.1.2.1.62.1.2.6.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..32) · OCTET STRING · hint 255t

The applTransactKind index is the human-readable identifier for a particular transaction kind within the context of an application protocol. The values to be used for a particular protocol may be identified in an applicability statement.

applTransactKindTrans

1.3.6.1.2.1.62.1.2.6.1.2

Counter64 (0..18446744073709551615) · transactions

The applTransactKindTrans attribute reports the number of request/response (as indicated by the applTransactFlowReqRsp index) transactions received/generated (as indicated by the applTransactFlowDirection index) handled by this application instance or application element on this transaction stream for this transaction kind. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactKindTransLow

1.3.6.1.2.1.62.1.2.6.1.3

Counter32 · transactions

The applTransactKindTransLow attribute reports the low thirty-two bits of applTransactKindTrans. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactKindBytes

1.3.6.1.2.1.62.1.2.6.1.4

Counter64 (0..18446744073709551615) · bytes

The applTransactKindBytes attribute reports the number of request/response (as indicated by the applTransactFlowReqRsp index) bytes received/generated (as indicated by the applTransactFlowDirection index) handled by this application element on this transaction stream for this transaction kind. All application layer bytes are included in this count, including any application layer wrappers, headers, or other overhead. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactKindBytesLow

1.3.6.1.2.1.62.1.2.6.1.5

Counter32 · bytes

The applTransactKindBytesLow attribute corresponds to the low thirty-two bits of applTransactKindBytes. Discontinuities in this counter can be detected by monitoring the corresponding instance of applOpenChannelOpenTime.

applTransactKindTime

1.3.6.1.2.1.62.1.2.6.1.6

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The applTransactKindTime attribute records the time of the processing (receipt or transmission as indicated by the applTransactFlowDirection index) by this running application element or service instance of the most recent request/response (as indicated by the applTransactFlowReqRsp index) of this kind of transaction on this transaction stream. If no requests/responses of this kind been received/transmitted by this running application element or service instance over this transaction stream, the value of this attribute shall be '0000000000000000'H

applPastChannelControlTable

1.3.6.1.2.1.62.1.3.1

Index: applElmtOrSvc · applElmtOrSvcId

The applPastChannelControlTable controls the accumulation of history information about channels from the perspective of service instances and running application elements. Entries in this table are indexed by applElmtOrSvc and applElmtOrSvcId, giving control of channel history accumulation at the level of each service instance and running application element.

applPastChannelControlCollect

1.3.6.1.2.1.62.1.3.1.1.1

INTEGER1 = enabled2 = frozen3 = disabled · Integer32

When the value of applPastChannelControlCollect is 'enabled', each time the corresponding running application element or service instance closes an open channel a new entry will be added to the applPastChannelTable. When the value of applPastChannelControlCollect is 'frozen', no new entries are added to the applPastChannelTable for this running application element or service instance, and old entries are not aged out. When the value of applPastChannelControlCollect is 'disabled', all entries are removed from applPastChannelTable for this running application or service instance, and no new entries are added.

applPastChannelControlMaxRows

1.3.6.1.2.1.62.1.3.1.1.2

Unsigned32 · channel history entries

The maximum number of entries allowed in the applPastChannelTable for this running application element or service instance. Once the number of rows for this running application element or service instance in the applPastChannelTable reaches this value, when new entries are to be added the management subsystem will make room for them by removing the oldest entries. Entries will be removed on the basis of oldest applPastChannelCloseTime value first.

applPastChannelControlTimeLimit

1.3.6.1.2.1.62.1.3.1.1.3

Unsigned32 · seconds

The maximum time in seconds which an entry for this running application element or service instance may exist in the applPastChannelTable before it is removed. Any entry that is older than this value will be removed (aged out) from the table, unless the applPastChannelControlCollect is set to 'frozen'. Note that an entry may be aged out prior to reaching this time limit if it is the oldest entry in the table and must be removed to make space for a new entry so as to not exceed applPastChannelControlMaxRows, or if the applPastChannelControlCollect is set to 'disabled'.

applPastChannelControlRemItems

1.3.6.1.2.1.62.1.3.1.1.4

Counter32 · channel history entries

The applPastChannelControlRemItems attribute reports the number of applPastChannelControlTable entries for this running application element or service instance that were deleted in order to make room for new history entries. This count does NOT include entries deleted for the following reasons: - the corresponding applPastChannelControlCollect attribute has been set to 'disabled' - the entry has been in the table longer that the time limit indicated by the corresponding applPastChannelControlTimeLimit.

applPastChannelTable

1.3.6.1.2.1.62.1.3.2

Index: applElmtOrSvc · applElmtOrSvcId · applPastChannelIndex

The applPastChannelTable provides history information about channels from the perspective of running application elements and service instances. Entries in this table are indexed by applElmtOrSvc, applElmtOrSvcId, and by applPastChannelIndex, which serves to uniquely identify each former channel in the context of a running application element or service instance. Note that the value of applPastChannelIndex is independent of the value applOpenChannelIndex had when this channel was open. Entries for closed channels for a given running application element or service instance can be added to this table only if its entry in the applPastChannelControlTable has the value 'enabled' for the attribute applPastChannelControlCollect. Entries for closed channels are removed under the following circumstances: - the running application element or service instance no longer exists - the corresponding applPastChannelControlCollect attribute has been set to 'disabled' - the entry has been in the table longer that the time limit indicated by the corresponding applPastChannelControlTimeLimit and the value of applPastChannelControlCollect is not 'frozen' - this is the oldest entry for the running application element or service instance in question and the addition of a new element would otherwise cause applPastChannelControlMaxRows to be exceeded for this running application element or service instance. - a value of applPastChannelIndex has been re-used. Note that under normal circumstances, this is unlikely. Removal/replacement of an entry under the last two conditions causes the corresponding applPastChannelControlRemItems to be incremented.

applPastChannelIndex

1.3.6.1.2.1.62.1.3.2.1.1

Unsigned32 (1..4294967295)

This attribute serves to uniquely identify this closed channel in the context of the running application element or service instance. This attribute has no other semantics. Note that the value of applPastChannelIndex is independent of the value applOpenChannelIndex had when this channel was active. In issuing this index value, the implementation must avoid re-issuing an index value which has already been assigned to an entry which has not yet been deleted due to age or space considerations. The value zero is excluded from the set of permitted values for this index in order to permit other tables to possibly represent information that cannot be associated with a specific entry in this table.

applPastChannelOpenTime

1.3.6.1.2.1.62.1.3.2.1.2

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This attribute records the time when this channel was originally opened. Note that this information is quite different from applOpenChannelOpenTime, which is used for the detection of counter discontinuities.

applPastChannelCloseTime

1.3.6.1.2.1.62.1.3.2.1.3

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This attribute records the time when this channel was closed.

applPastChannelReadRequests

1.3.6.1.2.1.62.1.3.2.1.4

Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64 · read requests

This attribute records the number of read requests for this channel made by this running application element or service instance. All read requests for this channel by this running application element or service instance, regardless of completion status, are included in this count. Read requests are counted in terms of system calls, rather than API calls.

applPastChannelReadReqsLow

1.3.6.1.2.1.62.1.3.2.1.5

Unsigned32 · read requests

This attribute corresponds to the low thirty-two bits of applPastChannelReadRequests.

applPastChannelReadFailures

1.3.6.1.2.1.62.1.3.2.1.6

Unsigned32 · failed read requests

This attribute reports the number of failed read requests.

applPastChannelBytesRead

1.3.6.1.2.1.62.1.3.2.1.7

Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64 · bytes

This attribute reports the number of bytes read from this channel by this running application element or service instance. Only bytes successfully read are included in this count.

applPastChannelBytesReadLow

1.3.6.1.2.1.62.1.3.2.1.8

Unsigned32 · bytes

This attribute corresponds to the low thirty-two bits of applPastChannelBytesRead.

applPastChannelLastReadTime

1.3.6.1.2.1.62.1.3.2.1.9

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This attribute reports the time of the most recent read request made by this running application element or service instance regardless of completion status, for this former channel. If no read requests have been made , the value of this attribute shall be '0000000000000000'H

applPastChannelWriteRequests

1.3.6.1.2.1.62.1.3.2.1.10

Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64 · write requests

The applPastChannelWriteRequests attribute reports the number of write requests, regardless of completion status, made by this running application element or service instance for this former channel. Write requests are counted in terms of system calls, rather than API calls.

applPastChannelWriteReqsLow

1.3.6.1.2.1.62.1.3.2.1.11

Unsigned32 · write requests

This attribute corresponds to the low thirty-two bits of applPastChannelWriteRequests.

applPastChannelWriteFailures

1.3.6.1.2.1.62.1.3.2.1.12

Unsigned32 · failed write requests

This attribute reports the number of failed write requests.

applPastChannelBytesWritten

1.3.6.1.2.1.62.1.3.2.1.13

Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64 · bytes

This attribute reports the number of bytes written to this former channel by this running application element or service instance. Only bytes successfully written (no errors reported by the API in use by the application) are included in this count.

applPastChannelBytesWritLow

1.3.6.1.2.1.62.1.3.2.1.14

Unsigned32 · bytes

This attribute corresponds to the low thirty-two bits of applPastChannelBytesWritten.

applPastChannelLastWriteTime

1.3.6.1.2.1.62.1.3.2.1.15

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The applPastChannelLastWriteTime attribute reports the time of the most recent write request made by this running application element or service instance, regardless of completion status, for this former channel. If no write requests have been made the value of this attribute shall be '0000000000000000'H

applPastFileTable

1.3.6.1.2.1.62.1.3.3

Index: applElmtOrSvc · applElmtOrSvcId · applPastChannelIndex

The applPastFileTable supplements the applPastChannelTable for entries corresponding to channels which were files. The indexing structure is identical to applPastChannelTable. An entry exists in the applPastFileTable only if there is a corresponding (same index values) entry in the applPastChannelTable and if the channel was a file. Entries for closed files are removed when the corresponding entries are removed from the applPastChannelTable.

applPastFileName

1.3.6.1.2.1.62.1.3.3.1.1

LongUtf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..1024) · OCTET STRING · hint 1024a

This attribute records the last known value of applOpenFileName before the channel was closed.

applPastFileSizeHigh

1.3.6.1.2.1.62.1.3.3.1.2

Unsigned32 · 2^32 byte blocks

This attribute records the value of applOpenFileSizeHigh at the time this channel was closed. For example, for a file with a total size of 4,294,967,296 bytes, this attribute would have a value of 1; for a file with a total size of 4,294,967,295 bytes this attribute's value would be 0.

applPastFileSizeLow

1.3.6.1.2.1.62.1.3.3.1.3

Unsigned32 · bytes

This attribute records the value of applOpenFileSizeLow at the time this channel was closed. For example, for a file with a total size of 4,294,967,296 bytes this attribute would have a value of 0; for a file with a total size of 4,294,967,295 bytes this attribute's value would be 4,294,967,295.

applPastFileMode

1.3.6.1.2.1.62.1.3.3.1.4

INTEGER1 = read2 = write3 = readWrite · Integer32

This attribute records the value of applOpenFileMode at the time this channel was closed.

applPastConTable

1.3.6.1.2.1.62.1.3.4

Index: applElmtOrSvc · applElmtOrSvcId · applPastChannelIndex

The applPastConTable supplements the applPastChannelTable for entries corresponding to channels which were connections. The indexing structure is identical to applPastChannelTable. An entry exists in the applPastConTable only if there is a corresponding (same index values) entry in the applPastChannelTable and if the channel was a connection. Entries for closed connections are removed when the corresponding entries are removed from the applPastChannelTable.

applPastConTransport

1.3.6.1.2.1.62.1.3.4.1.1

TDomainDenotes a kind of transport service. Some possible values, such as snmpUDPDomain, are defined in the SNMPv2-TM MIB module. Other possible values are defined in other MIB modules.Reference: The SNMPv2-TM MIB module is defined in RFC 1906. · OBJECT IDENTIFIER

The applPastConTransport attribute identifies the transport protocol that was in use for this former connection. If the transport protocol could not be determined, the value { 0 0 } shall be used.

applPastConNearEndAddr

1.3.6.1.2.1.62.1.3.4.1.2

ApplTAddressDenotes a transport service address. For snmpUDPDomain, an ApplTAddress is 6 octets long, the initial 4 octets containing the IP-address in network-byte order and the last 2 containing the UDP port in network-byte order. Consult 'Transport Mappings for Version 2 of the Simple Network Management Protocol (SNMPv2)' for further information on snmpUDPDomain. SIZE (0..255) · OCTET STRING

The applPastConNearEndAddr attribute reports the transport address and port information for the near end of this former connection. If the information could not be determined, the value shall be a zero-length string.

applPastConNearEndpoint

1.3.6.1.2.1.62.1.3.4.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The applPastConNearEndpoint attribute reports the fully-qualified domain name and port information for the near end of this former connection. The format of this attribute for TCP and UDP-based protocols is the fully-qualified domain name immediately followed by a colon which is immediately followed by the decimal representation of the port number. If the information could not be determined, the value shall be a zero-length string.

applPastConFarEndAddr

1.3.6.1.2.1.62.1.3.4.1.4

ApplTAddressDenotes a transport service address. For snmpUDPDomain, an ApplTAddress is 6 octets long, the initial 4 octets containing the IP-address in network-byte order and the last 2 containing the UDP port in network-byte order. Consult 'Transport Mappings for Version 2 of the Simple Network Management Protocol (SNMPv2)' for further information on snmpUDPDomain. SIZE (0..255) · OCTET STRING

The applPastConFarEnd attribute reports the transport address and port information for the far end of this former connection. If not known, as in the case of a connectionless transport, the value of this attribute shall be a zero-length string.

applPastConFarEndpoint

1.3.6.1.2.1.62.1.3.4.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The applPastConFarEndpoint attribute reports the transport address and port information for the far end of this former connection. The format of this attribute for TCP and UDP-based protocols is the fully-qualified domain name immediately followed by a colon which is immediately followed by the decimal representation of the port number. If not known, as in the case of a connectionless transport, the value of this attribute shall be a zero-length string.

applPastConApplication

1.3.6.1.2.1.62.1.3.4.1.6

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The applPastConApplication attribute identifies the application layer protocol that was in use. Where possible, the values defined in [13] shall be used. If not known, the value of this attribute shall be a zero-length string.

applPastTransStreamTable

1.3.6.1.2.1.62.1.3.5

Index: applElmtOrSvc · applElmtOrSvcId · applPastChannelIndex

The applPastTransStreamTable contains common information for historical transaction statistics.

applPastTransStreamDescr

1.3.6.1.2.1.62.1.3.5.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The applPastTransStreamDescr attribute provides a human-readable description of this transaction stream. If no descriptive information is available, this attribute's value shall be a zero-length string.

applPastTransStreamUnitOfWork

1.3.6.1.2.1.62.1.3.5.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The applPastTransStreamUnitOfWork attribute provides a human-readable definition of what the unit of work is for this transaction stream. If no descriptive information is available, this attribute's value shall be a zero-length string.

applPastTransStreamInvokes

1.3.6.1.2.1.62.1.3.5.1.3

Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64 · transactions

Cumulative count of requests / invocations issued for this transaction stream when it was active.

applPastTransStreamInvokesLow

1.3.6.1.2.1.62.1.3.5.1.4

Unsigned32 · transactions

This object corresponds to the low thirty-two bits of applPastTransStreamInvokes.

applPastTransStreamInvCumTimes

1.3.6.1.2.1.62.1.3.5.1.5

Unsigned32 · milliseconds

The applPastTransStreamInvCumTimes attribute reports the cumulative sum of the lengths of the intervals times measured between the transmission of requests and the receipt of (the first of) the corresponding response(s).

applPastTransStreamInvRspTimes

1.3.6.1.2.1.62.1.3.5.1.6

Unsigned32 · milliseconds

The applPastTransStreamInvRspTimes attribute reports the cumulative sum of the lengths of the intervals measured between the receipt of the first and last of multiple responses to a request. For transaction streams which do not permit multiple responses to a single request, this attribute will be zero.

applPastTransStreamPerforms

1.3.6.1.2.1.62.1.3.5.1.7

Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64 · transactions

Total number of transactions performed.

applPastTransStreamPerformsLow

1.3.6.1.2.1.62.1.3.5.1.8

Unsigned32 · transactions

This objecy reports the low thirty-two bits of applPastTransStreamPerforms.

applPastTransStreamPrfCumTimes

1.3.6.1.2.1.62.1.3.5.1.9

Unsigned32 · milliseconds

The applPastTransStreamPrfCumTimes attribute reports the cumulative sum of the lengths of the intervals measured between receipt of requests and the transmission of the corresponding responses.

applPastTransStreamPrfRspTimes

1.3.6.1.2.1.62.1.3.5.1.10

Unsigned32 · milliseconds

For each transaction performed, the elapsed time between when the first response is enqueued and when the last response is enqueued is added to this cumulative sum. For single-response protocols, the value of applPastTransStreamPrfRspTimes will be zero.

applPastTransFlowTable

1.3.6.1.2.1.62.1.3.6

Index: applElmtOrSvc · applElmtOrSvcId · applPastChannelIndex · applPastTransFlowDirection · applPastTransFlowReqRsp

The applPastTransFlowTable contains entries, organized by application instance or running application element, direction of flow, and type (request/response) for each former transaction stream. The simple model of a transaction used here looks like this: invoker | Request | performer | - - - - - - > | | | | Response | | < - - - - - - | | | Since in some protocols it is possible for an entity to take on both the invoker and performer roles, information here is accumulated for transmitted and received requests, as well as for transmitted and received responses. Counts are maintained for both transactions and bytes transferred.

applPastTransFlowDirection

1.3.6.1.2.1.62.1.3.6.1.1

INTEGER1 = transmit2 = receive · Integer32

The applPastTransFlowDirection index serves to identify an entry as containing information pertaining to the transmit (1) or receive (2) flow of a past transaction stream. This index corresponds to applTransactFlowDirection.

applPastTransFlowReqRsp

1.3.6.1.2.1.62.1.3.6.1.2

INTEGER1 = request2 = response · Integer32

The value of the applPastTransFlowReqRsp index indicates whether this entry contains information on requests (1), or responses (2). This index corresponds to applTransactFlowReqRsp.

applPastTransFlowTrans

1.3.6.1.2.1.62.1.3.6.1.3

Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64 · transactions

The applPastTransFlowTrans attribute reports the number of request/response (as indicated by the applPastTransFlowReqRsp index) transactions received/generated (as indicated by the applPastTransFlowDirection index) handled on this transaction stream.

applPastTransFlowTransLow

1.3.6.1.2.1.62.1.3.6.1.4

Unsigned32 · transactions

This attribute corresponds to the low thirty-two bits of applPastTransFlowTrans.

applPastTransFlowBytes

1.3.6.1.2.1.62.1.3.6.1.5

Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64 · bytes

The applPastTransFlowBytes attribute reports the number of request/response (as indicated by the applPastTransFlowReqRsp index) bytes received/generated (as indicated by the applPastTransFlowDirection index) handled on this transaction stream. All application layer bytes are included in this count, including any application layer wrappers, headers, or other overhead.

applPastTransFlowBytesLow

1.3.6.1.2.1.62.1.3.6.1.6

Unsigned32 · bytes

This attribute corresponds to the low thirty-two bits of applPastTransFlowBytes.

applPastTransFlowTime

1.3.6.1.2.1.62.1.3.6.1.7

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The applPastTransFlowTime attribute records the time of the processing (receipt or transmission as indicated by the applPastTransFlowDirection index) of the last request/response (as indicated by the applPastTransFlowReqRsp index) on this transaction stream. If no requests/responses been received/transmitted by this entity over this transaction stream, the value of this attribute shall be '0000000000000000'H

applPastTransKindTable

1.3.6.1.2.1.62.1.3.7

Index: applElmtOrSvc · applElmtOrSvcId · applPastChannelIndex · applPastTransFlowDirection · applPastTransFlowReqRsp · applPastTransKind

The applPastTransKindTable provides transaction statistics broken down by kinds of transaction. The definition of the kinds of transactions is specific to the application protocol in use, and may be documented in the form of an applicability statement.

applPastTransKind

1.3.6.1.2.1.62.1.3.7.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..32) · OCTET STRING · hint 255t

The applPastTransKind index is the human-readable identifier for a particular transaction kind within the context of an application protocol. The values to be used for a particular protocol may be identified in an applicability statement. This index corresponds to applTransactKind.

applPastTransKindTrans

1.3.6.1.2.1.62.1.3.7.1.2

Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64 · transactions

For this transaction stream, this attribute records the total number of transactions of the type identified by the indexes. The type is characterized according to the receive/transmit direction (applPastTransFlowDirecton), whether it was a request or a response (applPastTransFlowReqRsp), and the protocol-specific transaction kind (applPastTransKind). stream for this transaction kind.

applPastTransKindTransLow

1.3.6.1.2.1.62.1.3.7.1.3

Unsigned32 · transactions

The applPastTransKindTransLow attribute reports the low thirty-two bits of applPastTransKindTrans.

applPastTransKindBytes

1.3.6.1.2.1.62.1.3.7.1.4

Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64 · bytes

For this transaction stream and transaction kind, the applPastTransKindBytes attribute reports the number of bytes received or generated (as indicated by the applPastTransFlowDirection index) in requests or responses (as indicated by the applPastTransFlowReqRsp index). All application layer bytes are included in this count, including any application layer wrappers, headers, or other overhead.

applPastTransKindBytesLow

1.3.6.1.2.1.62.1.3.7.1.5

Unsigned32 · bytes

The applPastTransKindBytesLow attribute corresponds to the low thirty-two bits of applPastTransKindBytes.

applPastTransKindTime

1.3.6.1.2.1.62.1.3.7.1.6

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The applPastTransKindTime attribute records the time of the processing (receipt or transmission as indicated by the applPastTransFlowDirection index) of the last request/response (as indicated by the applPastTransFlowReqRsp index) of this kind of transaction on this transaction stream. If no requests/responses of this kind were received/transmitted over this transaction stream, the value of this attribute shall be '0000000000000000'H

applElmtRunStatusTable

1.3.6.1.2.1.62.1.4.1

Index: sysApplElmtRunIndex

This table provides information on running application elements, complementing information available in the correspondingly indexed sysApplElmtRunTable [31].

from SYSAPPL-MIB

sysApplElmtRunIndex

Unsigned32

Part of the index for this table. A unique value for each process running on the host. Wherever possible, this should be the system's native, unique identification number.

applElmtRunStatusSuspended

1.3.6.1.2.1.62.1.4.1.1.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

The applElmtRunStatusSuspended attribute reports whether processing by this running application element has been suspended, whether by management request or by other means.

applElmtRunStatusHeapUsage

1.3.6.1.2.1.62.1.4.1.1.2

Unsigned32 · bytes

The applElmtRunStatusHeapUsage reports the current approximate heap usage by this running application element.

applElmtRunStatusOpenConnections

1.3.6.1.2.1.62.1.4.1.1.3

Unsigned32 · connections

The applElmtRunStatusOpenConnections attribute reports the current number of open connections in use by this running application element.

applElmtRunStatusOpenFiles

1.3.6.1.2.1.62.1.4.1.1.4

Gauge32 · files

The applElmtRunStatusOpenFiles attribute reports the current number of open files in use by this running application element.

applElmtRunStatusLastErrorMsg

1.3.6.1.2.1.62.1.4.1.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The applElmtRunStatusLastErrorMessage attribute reports the most recent error message (typically written to stderr or a system error logging facility) from this running application element. If no such message has yet been generated, the value of this attribute shall be a zero-length string.

applElmtRunStatusLastErrorTime

1.3.6.1.2.1.62.1.4.1.1.6

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The applElmtRunStatusLastErrorTime attribute reports the time of the most recent error message in applElmtRunStatusLastErrorMsg. If no such message has yet been generated, the value of this attribute shall be '0000000000000000'H

applElmtRunControlTable

1.3.6.1.2.1.62.1.4.2

Index: sysApplElmtRunIndex

This table provides the ability to control application elements, complementing information available in the correspondingly indexed sysApplElmtRunTable [31].

from SYSAPPL-MIB

sysApplElmtRunIndex

Unsigned32

Part of the index for this table. A unique value for each process running on the host. Wherever possible, this should be the system's native, unique identification number.

applElmtRunControlSuspend

1.3.6.1.2.1.62.1.4.2.1.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Setting this variable to 'true' requests the suspension of processing by this running application element. Setting this variable to 'false' requests that processing be resumed. The effect, if any, will be reported by the applElmtRunStatusSuspended attribute.

applElmtRunControlReconfigure

1.3.6.1.2.1.62.1.4.2.1.2

TestAndIncrRepresents integer-valued information used for atomic operations. When the management protocol is used to specify that an object instance having this syntax is to be modified, the new value supplied via the management protocol must precisely match the value presently held by the instance. If not, the management protocol set operation fails with an error of `inconsistentValue'. Otherwise, if the current value is the maximum value of 2^31-1 (2147483647 decimal), then the value held by the instance is wrapped to zero; otherwise, the value held by the instance is incremented by one. (Note that regardless of whether the management protocol set operation succeeds, the variable- binding in the request and response PDUs are identical.) The value of the ACCESS clause for objects having this syntax is either `read-write' or `read-create'. When an instance of a columnar object having this syntax is created, any value may be supplied via the management protocol. When the network management portion of the system is re- initialized, the value of every object instance having this syntax must either be incremented from its value prior to the re-initialization, or (if the value prior to the re- initialization is unknown) be set to a pseudo-randomly generated value. (0..2147483647) · Integer32

Changing the value of this variable requests that the running application element re-load its configuration (like SIGHUP for many UNIX-based daemons). Note that completion of a SET on this object only implies that configuration reload was initiated, not necessarily that the reload has been completed.

applElmtRunControlTerminate

1.3.6.1.2.1.62.1.4.2.1.3

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Setting the value of applElmtRunControlTerminate to 'true' requests that the running application element terminate processing and exit in an orderly manner. This is a 'polite' shutdown request. When read, this object's value will be 'false' except when orderly termination is in progress. Note that completion of a SET on this object only implies that termination was initiated, not necessarily that the termination has been completed.

↑ To TOC