mvpnMvrfs
1.3.6.1.2.1.243.1.1.1
Gauge32
The total number of Multicast Virtual Routing and Forwarding (MVRF) tables that are present on this Provider Edge (PE) router. This includes MVRFs for IPv4, IPv6, and Multipoint LDP (mLDP) C-multicast.
2018-12-14
Download BGP-MPLS-LAYER3-VPN-MULTICAST-MIB.txt Open BGP-MPLS-LAYER3-VPN-MULTICAST-MIB.txt in a new tab
This MIB module contains managed object definitions to configure and/or monitor Multicast communication over IP Virtual Private Networks (VPNs) supported by the Multiprotocol Label Switching/Border Gateway Protocol (MPLS/BGP) on a Provider Edge (PE) router. Copyright (c) 2018 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).
SCALARS (11) · TABLES (7) · TRAPS (1)
| Name | OID |
|---|---|
| mvpnMvrfActionTaken | 1.3.6.1.2.1.243.0.1 |
END OF TOC
1.3.6.1.2.1.243.1.1.1
Gauge32
The total number of Multicast Virtual Routing and Forwarding (MVRF) tables that are present on this Provider Edge (PE) router. This includes MVRFs for IPv4, IPv6, and Multipoint LDP (mLDP) C-multicast.
1.3.6.1.2.1.243.1.1.2
Gauge32
The number of MVRFs for IPv4 C-multicast on this PE.
1.3.6.1.2.1.243.1.1.3
Gauge32
The number of MVRFs for IPv6 C-multicast on this PE.
1.3.6.1.2.1.243.1.1.4
Gauge32
The number of MVRFs on this PE that use BGP for exchanging mLDP C-multicast routing information.
1.3.6.1.2.1.243.1.1.5
Gauge32
The number of MVRFs on this PE that use Provider Independent Multicast (PIM) for exchanging IPv4 C-multicast routing information.
1.3.6.1.2.1.243.1.1.6
Gauge32
The number of MVRFs on this PE that use PIM for exchanging IPv6 C-multicast routing information.
1.3.6.1.2.1.243.1.1.7
Gauge32
The number of MVRFs on this PE that use BGP for exchanging IPv4 C-multicast routing information.
1.3.6.1.2.1.243.1.1.8
Gauge32
The number of MVRFs on this PE that use BGP for exchanging IPv6 C-multicast routing information.
1.3.6.1.2.1.243.1.1.9
Unsigned32 (1..4294967295)
The maximum number of selective provider tunnels that are allowed for a particular MVPN on this PE. Reference: RFC 6513, Section 13
1.3.6.1.2.1.243.1.1.10
Unsigned32 · milliseconds
A configurable timer to control the delay of C-multicast route withdrawal advertisements. Reference: RFC 6514, Section 16.1.1
1.3.6.1.2.1.243.1.1.11
Unsigned32 · milliseconds
A configurable timer to control the delay of Source/Shared Tree Join C-multicast route advertisements. Reference: RFC 6514, Section 16.1.2
1.3.6.1.2.1.243.1.2
Index: mplsL3VpnVrfName
A conceptual table containing generic information about MVPNs on this PE.
from MPLS-L3VPN-STD-MIB
MplsL3VpnNameAn identifier that is assigned to each MPLS/BGP VPN and is used to uniquely identify it. This is assigned by the system operator or NMS and SHOULD be unique throughout the MPLS domain. If this is the case, then this identifier can then be used at any LSR within a specific MPLS domain to identify this MPLS/BGP VPN. It may also be possible to preserve the uniqueness of this identifier across MPLS domain boundaries, in which case this identifier can then be used to uniquely identify MPLS/BGP VPNs on a more global basis. This object MAY be set to the VPN ID as defined in RFC 2685.Reference: RFC 2685 Fox B., et al, 'Virtual Private Networks Identifier', September 1999. SIZE (0..31) · OCTET STRING
The human-readable name of this VPN. This MAY be equivalent to the [RFC2685] VPN-ID, but may also vary. If it is set to the VPN ID, it MUST be equivalent to the value of mplsL3VpnVrfVpnId. It is strongly recommended that all sites supporting VRFs that are part of the same VPN use the same naming convention for VRFs as well as the same VPN ID. Reference: [RFC2685]
1.3.6.1.2.1.243.1.2.1.2
INTEGER1 = createdMvrf2 = deletedMvrf3 = modifiedMvrfIpmsiConfig4 = modifiedMvrfSpmsiConfig · Integer32
This object describes the last action pertaining to the MVPN represented by this entry. The enumerated action types and the corresponding descriptions are as follows: createdMvrf: MVRF was created for this MVPN on the PE. deletedMvrf: MVRF for this MVPN was deleted from the PE. A conceptual row in this table will never have mvpnGenMvrfLastAction equal to deletedMvrf, because in that case, the row itself will not exist in the table. This value for mvpnGenMvrfLastAction is defined solely for use in the mvpnMvrfActionChange notification. modifiedMvrfIpmsiConfig: An I-PMSI for this MVPN was configured, deleted, or changed. modifiedMvrfSpmsiConfig: An S-PMSI for this MVPN was configured, deleted, or changed.
1.3.6.1.2.1.243.1.2.1.3
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The timestamp when the last action, given in the corresponding mvpnGenMvrfLastAction object, was carried out.
1.3.6.1.2.1.243.1.2.1.4
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The timestamp when the MVRF was created for the MVPN represented by this entry.
1.3.6.1.2.1.243.1.2.1.5
INTEGER1 = pim2 = bgp · Integer32
The protocol used to signal C-multicast routing information across the provider core for the MVPN represented by this entry. The enumerated protocols and the corresponding descriptions are as follows: pim : PIM (PIM-MVPN) bgp : BGP (BGP-MVPN) Reference: RFC 6513, Section 5
1.3.6.1.2.1.243.1.2.1.6
RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER
A pointer to a conceptual row representing the corresponding I-PMSI in mvpnPmsiTable. If there is no I-PMSI for the MVPN represented by this entry, the value of this object will be zeroDotZero.
1.3.6.1.2.1.243.1.2.1.7
RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER
A pointer to a conceptual row representing the corresponding segmented Inter-AS I-PMSI in mvpnPmsiTable. If there is no segmented Inter-AS I-PMSI for the MVPN, the value of this object will be zeroDotZero.
1.3.6.1.2.1.243.1.2.1.8
INTEGER1 = highestPeAddress2 = cRootGroupHashing3 = ucastUmhRoute · Integer32
The Upstream Multicast Hop (UMH) selection method for the MVPN represented by this entry. The enumerated methods and the corresponding descriptions are as follows: highestPeAddress : PE with the highest address (see RFC 6513, Section 5.1.3) cRootGroupHashing : hashing based on (c-root, c-group) ucastUmhRoute : per-unicast route towards c-root Reference: RFC 6513, Section 5.1
1.3.6.1.2.1.243.1.2.1.9
INTEGER1 = senderReceiver2 = receiverOnly3 = senderOnly · Integer32
The type of the customer site, connected to the MVPN represented by this entry. The enumerated types and the corresponding descriptions are as follows: senderReceiver : Site is both sender and receiver receiverOnly : Site is receiver only senderOnly : Site is sender only Reference: RFC 6513, Section 2.3
1.3.6.1.2.1.243.1.3
Index: mplsL3VpnVrfName
A conceptual table that supplements mvpnGenericTable with BGP-MVPN-specific information for BGP-MVPNs on this PE.
from MPLS-L3VPN-STD-MIB
MplsL3VpnNameAn identifier that is assigned to each MPLS/BGP VPN and is used to uniquely identify it. This is assigned by the system operator or NMS and SHOULD be unique throughout the MPLS domain. If this is the case, then this identifier can then be used at any LSR within a specific MPLS domain to identify this MPLS/BGP VPN. It may also be possible to preserve the uniqueness of this identifier across MPLS domain boundaries, in which case this identifier can then be used to uniquely identify MPLS/BGP VPNs on a more global basis. This object MAY be set to the VPN ID as defined in RFC 2685.Reference: RFC 2685 Fox B., et al, 'Virtual Private Networks Identifier', September 1999. SIZE (0..31) · OCTET STRING
The human-readable name of this VPN. This MAY be equivalent to the [RFC2685] VPN-ID, but may also vary. If it is set to the VPN ID, it MUST be equivalent to the value of mplsL3VpnVrfVpnId. It is strongly recommended that all sites supporting VRFs that are part of the same VPN use the same naming convention for VRFs as well as the same VPN ID. Reference: [RFC2685]
1.3.6.1.2.1.243.1.3.1.1
INTEGER0 = other1 = rptSpt2 = sptOnly · Integer32
The inter-site C-tree mode used by the BGP-MVPN represented by this entry. other : none of the following rptSpt : inter-site shared tree mode (Rendezvous Point Tree (RPT) and source-specific shortest-path tree (SPT)) sptOnly : inter-site source-only tree mode Reference: RFC 6513, Section 9.3.1
1.3.6.1.2.1.243.1.3.1.2
MplsL3VpnRouteDistinguisherSyntax for a route distinguisher and route target as defined in [RFC4364].Reference: [RFC4364] SIZE (0..256) · OCTET STRING
The VRF Route Import Extended Community added by this PE to unicast VPN routes that it advertises for the BGP-MVPN corresponding to this entry. Reference: RFC 6514, Section 7
1.3.6.1.2.1.243.1.3.1.3
Unsigned32
The Source AS Extended Community added by this PE to the unicast VPN routes that it advertises for the BGP-MVPN represented by this entry. Reference: RFC 6514, Section 6
1.3.6.1.2.1.243.1.3.1.4
Unsigned32 · messages per second
The configurable upper bound for the rate of the BGP C-multicast routing information message exchange between this PE and other PEs in the BGP-MVPN corresponding to this entry. Reference: RFC 6514, Section 17
1.3.6.1.2.1.243.1.3.1.5
Unsigned32
The configurable upper bound for the number of S-PMSI auto-discovery (A-D) routes for the BGP-MVPN corresponding to this entry. Reference: RFC 6514, Section 17
1.3.6.1.2.1.243.1.3.1.6
Unsigned32 · routes per second
The configurable upper bound for the frequency of S-PMSI A-D route generation for the BGP-MVPN corresponding to this entry. Reference: RFC 6514, Section 17
1.3.6.1.2.1.243.1.3.1.7
Unsigned32
The configurable upper bound for the number of Source Active A-D routes for the BGP-MVPN corresponding to this entry. Reference: RFC 6514, Section 17
1.3.6.1.2.1.243.1.3.1.8
Unsigned32 · routes per second
The configurable upper bound for the frequency of Source Active A-D route generation for the BGP-MVPN corresponding to this entry. Reference: RFC 6514, Section 17
1.3.6.1.2.1.243.1.4
Index: mvpnPmsiTunnelIfIndex
A conceptual table containing information related to PMSIs on this PE.
1.3.6.1.2.1.243.1.4.1.1
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
A unique value for this conceptual row. Its value will be the same as that of the ifIndex object instance for the corresponding PMSI in ifTable. Reference: RFC 2863, Section 3.1.5
1.3.6.1.2.1.243.1.4.1.3
MplsL3VpnRouteDistinguisherSyntax for a route distinguisher and route target as defined in [RFC4364].Reference: [RFC4364] SIZE (0..256) · OCTET STRING
The Route Distinguisher for this I-PMSI.
1.3.6.1.2.1.243.1.4.1.4
L2L3VpnMcastProviderTunnelType0 = noTunnelInfo1 = rsvpP2mp2 = ldpP2mp3 = pimSsm4 = pimAsm5 = pimBidir6 = ingressReplication7 = ldpMp2mp8 = transportTunnelThis textual convention enumerates values representing the type of a provider tunnel (P-tunnel) used for L2L3VpnMCast networks. These labeled numbers are aligned with the definition of Tunnel Types in Section 5 of RFC 6514 and Section 14.1 of RFC 7524. The enumerated values and the corresponding P-tunnel types are as follows: noTunnelInfo (0) : No tunnel information RFC 6514 rsvpP2mp (1) : RSVP-TE P2MP LSP RFC 4875 ldpP2mp (2) : mLDP P2MP LSP RFC 6388 pimSsm (3) : PIM-SSM Tree RFC 7761 pimAsm (4) : PIM-SM Tree RFC 7761 pimBidir (5) : BIDIR-PIM Tree RFC 5015 ingressReplication (6) : Ingress Replication RFC 6513 ldpMp2mp (7) : mLDP MP2MP LSP RFC 6388 transportTunnel (8) : Transport Tunnel RFC 7524 These numbers are registered at IANA. A current list of assignments can be found at <https://www.iana.org/assignments/bgp-parameters/>.Reference: RFC 4875 RFC 5015 RFC 6388 RFC 6513 RFC 6514, Section 5 RFC 7524, Section 14.1 RFC 7761 · Integer32
The type of tunnel used to instantiate the PMSI corresponding to this entry. Reference: RFC 6513, Section 2.6
1.3.6.1.2.1.243.1.4.1.5
RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER
A pointer to a conceptual row representing the P-tunnel used by the PMSI in l2L3VpnMcastPmsiTunnelAttributeTable.
1.3.6.1.2.1.243.1.4.1.6
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mvpnPmsiTunnelPimGroupAddr object that follows. When the PMSI corresponding to this entry does not use the PIM provider tunnel, i.e., the value of mvpnPmsiTunnelType is not one of pimSsm(3), pimAsm(4), or pimBidir(5), this object should be unknown(0).
1.3.6.1.2.1.243.1.4.1.7
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The tunnel address that is used by the PMSI corresponding to this entry. When the PMSI corresponding to this entry does not use the PIM provider tunnel, i.e., the value of mvpnPmsiTunnelType is not one of pimSsm(3), pimAsm(4), or pimBidir(5), this object should be a zero-length octet string.
1.3.6.1.2.1.243.1.4.1.8
INTEGER1 = greIp2 = ipIp3 = mpls · Integer32
The encapsulation type used for sending packets through the PMSI corresponding to this entry. The enumerated encapsulation types and the corresponding descriptions are as follows: greIp : Generic Routing Encapsulation (GRE) (RFC 2784) ipIp : IP-in-IP encapsulation (RFC 2003) mpls : MPLS encapsulation (RFC 3032) Reference: RFC 2003 RFC 2784 RFC 3032 RFC 6513, Section 12.1
1.3.6.1.2.1.243.1.5
Index: mplsL3VpnVrfName · mvpnSpmsiCmcastGroupAddrType · mvpnSpmsiCmcastGroupAddr · mvpnSpmsiCmcastGroupPrefixLen · mvpnSpmsiCmcastSourceAddrType · mvpnSpmsiCmcastSourceAddr · mvpnSpmsiCmcastSourcePrefixLen
A conceptual table containing information related to S-PMSIs on this PE. This table stores only S-PMSI-specific attribute information. Generic PMSI attribute information of S-PMSIs is stored in mvpnPmsiTable.
from MPLS-L3VPN-STD-MIB
MplsL3VpnNameAn identifier that is assigned to each MPLS/BGP VPN and is used to uniquely identify it. This is assigned by the system operator or NMS and SHOULD be unique throughout the MPLS domain. If this is the case, then this identifier can then be used at any LSR within a specific MPLS domain to identify this MPLS/BGP VPN. It may also be possible to preserve the uniqueness of this identifier across MPLS domain boundaries, in which case this identifier can then be used to uniquely identify MPLS/BGP VPNs on a more global basis. This object MAY be set to the VPN ID as defined in RFC 2685.Reference: RFC 2685 Fox B., et al, 'Virtual Private Networks Identifier', September 1999. SIZE (0..31) · OCTET STRING
The human-readable name of this VPN. This MAY be equivalent to the [RFC2685] VPN-ID, but may also vary. If it is set to the VPN ID, it MUST be equivalent to the value of mplsL3VpnVrfVpnId. It is strongly recommended that all sites supporting VRFs that are part of the same VPN use the same naming convention for VRFs as well as the same VPN ID. Reference: [RFC2685]
1.3.6.1.2.1.243.1.5.1.1
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mvpnSpmsiCmcastGroupAddr object that follows.
1.3.6.1.2.1.243.1.5.1.2
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The group address of the C-flow assigned to the S-PMSI corresponding to this entry. Reference: RFC 6513, Section 3.1
1.3.6.1.2.1.243.1.5.1.3
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The prefix length of the corresponding mvpnSpmsiCmcastGroupAddr object.
1.3.6.1.2.1.243.1.5.1.4
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mvpnSpmsiCmcastSourceAddr object that follows.
1.3.6.1.2.1.243.1.5.1.5
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The source address of the C-flow assigned to the S-PMSI corresponding to this entry.
1.3.6.1.2.1.243.1.5.1.6
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The prefix length of the corresponding mvpnSpmsiCmcastSourceAddr object.
1.3.6.1.2.1.243.1.5.1.7
RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER
A pointer to a conceptual row representing generic information of this S-PMSI in mvpnPmsiTable.
1.3.6.1.2.1.243.1.6
Index: mplsL3VpnVrfName · mvpnAdvtType · mvpnAdvtPeerAddrType · mvpnAdvtPeerAddr
A conceptual table containing statistics pertaining to I-PMSI and S-PMSI advertisements sent/received by this PE.
from MPLS-L3VPN-STD-MIB
MplsL3VpnNameAn identifier that is assigned to each MPLS/BGP VPN and is used to uniquely identify it. This is assigned by the system operator or NMS and SHOULD be unique throughout the MPLS domain. If this is the case, then this identifier can then be used at any LSR within a specific MPLS domain to identify this MPLS/BGP VPN. It may also be possible to preserve the uniqueness of this identifier across MPLS domain boundaries, in which case this identifier can then be used to uniquely identify MPLS/BGP VPNs on a more global basis. This object MAY be set to the VPN ID as defined in RFC 2685.Reference: RFC 2685 Fox B., et al, 'Virtual Private Networks Identifier', September 1999. SIZE (0..31) · OCTET STRING
The human-readable name of this VPN. This MAY be equivalent to the [RFC2685] VPN-ID, but may also vary. If it is set to the VPN ID, it MUST be equivalent to the value of mplsL3VpnVrfVpnId. It is strongly recommended that all sites supporting VRFs that are part of the same VPN use the same naming convention for VRFs as well as the same VPN ID. Reference: [RFC2685]
1.3.6.1.2.1.243.1.6.1.1
INTEGER0 = intraAsIpmsi1 = interAsIpmsi2 = sPmsi · Integer32
The PMSI type. The enumerated PMSI types and corresponding descriptions are as follows: intraAsIpmsi : Intra-AS Inclusive PMSI interAsIpmsi : Inter-AS Inclusive PMSI sPmsi : Selective PMSI Reference: RFC 6513, Sec. 3.2.1
1.3.6.1.2.1.243.1.6.1.2
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InternetAddressType of the mvpnAdvtPeerAddr object that follows.
1.3.6.1.2.1.243.1.6.1.3
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The address of a peer PE that exchanges advertisement with this PE.
1.3.6.1.2.1.243.1.6.1.4
Counter32
The number of advertisements successfully sent to the peer PE specified by the corresponding mvpnAdvtPeerAddr. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnAdvtCounterDiscontinuityTime object.
1.3.6.1.2.1.243.1.6.1.5
Counter32
The number of advertisements received from the peer PE specified by the corresponding mvpnAdvtPeerAddr object. This includes advertisements that were discarded. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnAdvtCounterDiscontinuityTime object.
1.3.6.1.2.1.243.1.6.1.6
Counter32
The total number of advertisements received from a peer PE, specified by the corresponding mvpnAdvtPeerAddr object, that were rejected due to an error(s) in the advertisement. The value of this object includes the error cases counted in the corresponding mvpnAdvtReceivedMalformedTunnelType and mvpnAdvtReceivedMalformedTunnelId objects. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnAdvtCounterDiscontinuityTime object.
1.3.6.1.2.1.243.1.6.1.7
Counter32
The total number of advertisements received from the peer PE, specified by the corresponding mvpnAdvtPeerAddr object, that were rejected due to a malformed Tunnel Type in the PMSI Tunnel attribute. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnAdvtCounterDiscontinuityTime object. Reference: RFC 6514, Section 5
1.3.6.1.2.1.243.1.6.1.8
Counter32
The total number of advertisements received from the peer PE, specified by the corresponding mvpnAdvtPeerAddr object, that were rejected due to a malformed Tunnel Identifier in the PMSI Tunnel attribute. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnAdvtCounterDiscontinuityTime object. Reference: RFC 6514, Section 5
1.3.6.1.2.1.243.1.6.1.9
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The timestamp when the last advertisement was successfully sent by this PE. If no advertisement has been sent since the last re-initialization of this PE, this object will have a zero-length string.
1.3.6.1.2.1.243.1.6.1.10
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The timestamp when the last advertisement was successfully received from the peer PE specified by the corresponding mvpnAdvtPeerAddr object and processed by this PE. If no advertisement has been received since the last re-initialization of this PE, this object will have a zero-length string.
1.3.6.1.2.1.243.1.6.1.11
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime on the most recent occasion at which any one or more of this application's counters, viz., counters with the OID prefix 'mvpnAdvtSent', 'mvpnAdvtReceived', 'mvpnAdvtReceivedError', 'mvpnAdvtReceivedMalformedTunnelType', or 'mvpnAdvtReceivedMalformedTunnelId', suffered a discontinuity. If no such discontinuities have occurred since the last re-initialization of the local management subsystem, this object will have a zero value.
1.3.6.1.2.1.243.1.7
Index: mplsL3VpnVrfName · mvpnMrouteCmcastGroupAddrType · mvpnMrouteCmcastGroupAddr · mvpnMrouteCmcastGroupPrefixLength · mvpnMrouteCmcastSourceAddrType · mvpnMrouteCmcastSourceAddrs · mvpnMrouteCmcastSourcePrefixLength
A conceptual table containing multicast routing information corresponding to the MVRFs present on the PE.
from MPLS-L3VPN-STD-MIB
MplsL3VpnNameAn identifier that is assigned to each MPLS/BGP VPN and is used to uniquely identify it. This is assigned by the system operator or NMS and SHOULD be unique throughout the MPLS domain. If this is the case, then this identifier can then be used at any LSR within a specific MPLS domain to identify this MPLS/BGP VPN. It may also be possible to preserve the uniqueness of this identifier across MPLS domain boundaries, in which case this identifier can then be used to uniquely identify MPLS/BGP VPNs on a more global basis. This object MAY be set to the VPN ID as defined in RFC 2685.Reference: RFC 2685 Fox B., et al, 'Virtual Private Networks Identifier', September 1999. SIZE (0..31) · OCTET STRING
The human-readable name of this VPN. This MAY be equivalent to the [RFC2685] VPN-ID, but may also vary. If it is set to the VPN ID, it MUST be equivalent to the value of mplsL3VpnVrfVpnId. It is strongly recommended that all sites supporting VRFs that are part of the same VPN use the same naming convention for VRFs as well as the same VPN ID. Reference: [RFC2685]
1.3.6.1.2.1.243.1.7.1.1
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mvpnMrouteCmcastGroupAddr object that follows.
1.3.6.1.2.1.243.1.7.1.2
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The IP multicast group address that, along with the corresponding mvpnMrouteCmcastGroupPrefixLength object, identifies destinations for which this entry contains multicast routing information. This address object is only significant up to mvpnMrouteCmcastGroupPrefixLength bits. The remaining address bits MUST be set to zero. For addresses of type 'ipv4z' or 'ipv6z', the appended zone index is significant even though it lies beyond the prefix length. The use of these address types indicates that this forwarding state applies only within the given zone. Zone index zero is not valid in this table.
1.3.6.1.2.1.243.1.7.1.3
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The length in bits of the mask that, along with the corresponding mvpnMrouteCmcastGroupAddr object, identifies destinations for which this entry contains multicast routing information. If the corresponding InetAddressType is 'ipv4' or 'ipv4z', this object must be in the range 4..32. If the corresponding InetAddressType is 'ipv6' or 'ipv6z', this object must be in the range 8..128.
1.3.6.1.2.1.243.1.7.1.4
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mvpnMrouteCmcastSourceAddrs object that follows. A value of unknown(0) indicates a non-source-specific entry, corresponding to all sources in the group. Otherwise, the value MUST be the same as the value of mvpnMrouteCmcastGroupAddrType.
1.3.6.1.2.1.243.1.7.1.5
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The network address that, along with the corresponding mvpnMrouteCmcastSourcePrefixLength object, identifies the sources for which this entry contains multicast routing information. This address object is only significant up to mvpnMrouteCmcastSourcePrefixLength bits. The remaining address bits MUST be set to zero. For addresses of type 'ipv4z' or 'ipv6z', the appended zone index is significant even though it lies beyond the prefix length. The use of these address types indicates that this source address applies only within the given zone. Zone index zero is not valid in this table.
1.3.6.1.2.1.243.1.7.1.6
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The length in bits of the mask that, along with the corresponding mvpnMrouteCmcastSourceAddr object, identifies the sources for which this entry contains multicast routing information. If the corresponding InetAddressType is 'ipv4' or 'ipv4z', this object must be in the range 4..32. If the corresponding InetAddressType is 'ipv6' or 'ipv6z', this object must be in the range 8..128. If the corresponding InetAddressType is 'unknown', this object must be zero.
1.3.6.1.2.1.243.1.7.1.7
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mvpnMrouteUpstreamNeighborAddr object that follows. A value of unknown(0) indicates that the upstream neighbor is unknown, for example, in Bidirectional PIM (BIDIR-PIM). Reference: RFC 5015
1.3.6.1.2.1.243.1.7.1.8
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The address of the upstream neighbor (for example, the Reverse Path Forwarding (RPF) neighbor) from which IP datagrams from these sources represented by this entry to this multicast address are received.
1.3.6.1.2.1.243.1.7.1.9
InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d
The value of ifIndex for the interface on which IP datagrams sent by these sources represented by this entry to this multicast address are received. A value of zero indicates that datagrams are not subject to an incoming interface check but may be accepted on multiple interfaces (for example, in BIDIR-PIM). Reference: RFC 5015
1.3.6.1.2.1.243.1.7.1.10
TimeTicks
The minimum amount of time remaining before this entry will be aged out. The value zero indicates that the entry is not subject to aging. If the corresponding mvpnMrouteNextHopState object is pruned(1), this object represents the remaining time for the prune to expire after which the state will return to forwarding(2). If the corresponding mvpnMrouteNextHopState object is forwarding(2), this object indicates the time after which this entry will be removed from the table.
1.3.6.1.2.1.243.1.7.1.11
IANAipMRouteProtocol1 = other2 = local3 = netmgmt4 = dvmrp5 = mospf6 = pimSparseDense7 = cbt8 = pimSparseMode9 = pimDenseMode10 = igmpOnly11 = bgmp12 = msdpThe multicast routing protocol. Inclusion of values for multicast routing protocols is not intended to imply that those protocols need be supported. · Integer32
The multicast routing protocol via which this multicast forwarding entry was learned.
1.3.6.1.2.1.243.1.7.1.12
IANAipRouteProtocol1 = other2 = local3 = netmgmt4 = icmp5 = egp6 = ggp7 = hello8 = rip9 = isIs10 = esIs11 = ciscoIgrp12 = bbnSpfIgp13 = ospf14 = bgp15 = idpr16 = ciscoEigrp17 = dvmrp18 = rpl19 = dhcp20 = ttdpA mechanism for learning routes. Inclusion of values for routing protocols is not intended to imply that those protocols need be supported. · Integer32
The routing protocol via which the route used to find the upstream or parent interface for this multicast forwarding entry was learned.
1.3.6.1.2.1.243.1.7.1.13
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mvpnMrouteRtAddr object that follows.
1.3.6.1.2.1.243.1.7.1.14
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The address portion of the route used to find the upstream or parent interface for this multicast forwarding entry. This address object is only significant up to mvpnMrouteRtPrefixLength bits. The remaining address bits MUST be set to zero. For addresses of type 'ipv4z' or 'ipv6z', the appended zone index is significant even though it lies beyond the prefix length. The use of these address types indicates that this forwarding state applies only within the given zone. Zone index zero is not valid in this table.
1.3.6.1.2.1.243.1.7.1.15
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The length in bits of the mask associated with the route used to find the upstream or parent interface for this multicast forwarding entry. If the corresponding InetAddressType is 'ipv4' or 'ipv4z', this object must be in the range 4..32. If the corresponding InetAddressType is 'ipv6' or 'ipv6z', this object must be in the range 8..128.
1.3.6.1.2.1.243.1.7.1.16
INTEGER1 = unicast2 = multicast · Integer32
The reason for placing the route in the (logical) multicast Routing Information Base (RIB). The enumerated reasons and the corresponding descriptions are as follows: unicast: The route would normally be placed only in the unicast RIB, but it was placed in the multicast RIB by local configuration, such as when running PIM over RIP. multicast: The route was explicitly added to the multicast RIB by the routing protocol, such as the Distance Vector Multicast Routing Protocol (DVMRP) or Multiprotocol BGP.
1.3.6.1.2.1.243.1.7.1.17
Counter64 (0..18446744073709551615)
The number of octets contained in IP datagrams that were received from sources represented by this entry and addressed to this multicast group address and that were forwarded by this router. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnMrouteCounterDiscontinuityTime object.
1.3.6.1.2.1.243.1.7.1.18
Counter64 (0..18446744073709551615)
The number of packets routed using this multicast route entry. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnMrouteCounterDiscontinuityTime object.
1.3.6.1.2.1.243.1.7.1.19
Counter64 (0..18446744073709551615)
The number of octets contained in IP datagrams that this router has received from sources represented by this entry and addressed to this multicast group address, which were dropped due to Time To Live (TTL) issues. TTL issues occur when the TTL (IPv4) or Hop Limit (IPv6) of the incoming packet was decremented to zero or to a value less than ipMcastInterfaceTtl of the corresponding interface. The ipMcastInterfaceTtl object is defined in IPMCAST-MIB (RFC 5132) and represents the datagram TTL threshold for the interface. Any IP multicast datagrams with a TTL (IPv4) or Hop Limit (IPv6) less than this threshold will not be forwarded out of the interface. The default value of zero means all multicast packets are forwarded out of the interface. A value of 256 means that no multicast packets are forwarded out of the interface. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnMrouteCounterDiscontinuityTime object. Reference: RFC 5132, Section 6
1.3.6.1.2.1.243.1.7.1.20
Counter64 (0..18446744073709551615)
The number of packets that this router has received from the sources represented by this entry and addressed to this multicast group address, which were dropped due to Time To Live (TTL) issues. TTL issues occur when the TTL (IPv4) or Hop Limit (IPv6) of the incoming packet was decremented to zero or to a value less than ipMcastInterfaceTtl of the corresponding interface. The ipMcastInterfaceTtl object is defined in IPMCAST-MIB (RFC 5132) and represents the datagram TTL threshold for the interface. Any IP multicast datagrams with a TTL (IPv4) or Hop Limit (IPv6) less than this threshold will not be forwarded out of the interface. The default value of zero means all multicast packets are forwarded out of the interface. A value of 256 means that no multicast packets are forwarded out of the interface. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnMrouteCounterDiscontinuityTime object. Reference: RFC 5132, Section 6
1.3.6.1.2.1.243.1.7.1.21
Counter64 (0..18446744073709551615)
The number of octets contained in IP datagrams that this router has received from sources represented by this entry and addressed to this multicast group address, which were dropped due to an error(s). The value of this object includes the octets counted in the corresponding mvpnMrouteTtlDroppedOctets object. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnMrouteCounterDiscontinuityTime object.
1.3.6.1.2.1.243.1.7.1.22
Counter64 (0..18446744073709551615)
The number of packets that this router has received from sources represented by this entry and addressed to this multicast group address, which were dropped due to an error(s). The value of this object includes the number of octets counted in the corresponding mvpnMrouteTtlDroppedPackets object. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnMrouteCounterDiscontinuityTime object.
1.3.6.1.2.1.243.1.7.1.23
RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER
A pointer to a conceptual row representing the corresponding I-PMSI in mvpnPmsiTable or S-PMSI in mvpnSpmsiTable that this C-multicast route is using.
1.3.6.1.2.1.243.1.7.1.24
Unsigned32
Number of replications for local receivers. For example, if an ingress PE needs to send traffic out of N PE-CE interfaces, then mvpnMrouteNumberOfLocalReplication is N.
1.3.6.1.2.1.243.1.7.1.25
Unsigned32
Number of local replications for remote PEs. For example, if the number of remote PEs that need to receive traffic is N, then mvpnMrouteNumberOfRemoteReplication is N in case of Ingress Replication, but it may be less than N in case of RSVP-TE or mLDP Point-to-Multipoint (P2MP) tunnels, depending on the actual number of replications the PE needs to do.
1.3.6.1.2.1.243.1.7.1.26
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime on the most recent occasion at which any one or more of this application's counters, viz., counters with the OID prefix 'mvpnMrouteOctets', 'mvpnMroutePkts', 'mvpnMrouteTtlDroppedOctets', 'mvpnMrouteTtlDroppedPackets', 'mvpnMrouteDroppedInOctets', or 'mvpnMrouteDroppedInPackets', suffered a discontinuity. If no such discontinuities have occurred since the last re-initialization of the local management subsystem, this object will have a zero value.
1.3.6.1.2.1.243.1.8
Index: mplsL3VpnVrfName · mvpnMrouteNextHopGroupAddrType · mvpnMrouteNextHopGroupAddr · mvpnMrouteNextHopGroupPrefixLength · mvpnMrouteNextHopSourceAddrType · mvpnMrouteNextHopSourceAddrs · mvpnMrouteNextHopSourcePrefixLength · mvpnMrouteNextHopIfIndex · mvpnMrouteNextHopAddrType · mvpnMrouteNextHopAddr
A conceptual table containing information on the next hops for routing IP multicast datagrams. Each entry is one of a list of next hops for a set of sources sending to a multicast group address.
from MPLS-L3VPN-STD-MIB
MplsL3VpnNameAn identifier that is assigned to each MPLS/BGP VPN and is used to uniquely identify it. This is assigned by the system operator or NMS and SHOULD be unique throughout the MPLS domain. If this is the case, then this identifier can then be used at any LSR within a specific MPLS domain to identify this MPLS/BGP VPN. It may also be possible to preserve the uniqueness of this identifier across MPLS domain boundaries, in which case this identifier can then be used to uniquely identify MPLS/BGP VPNs on a more global basis. This object MAY be set to the VPN ID as defined in RFC 2685.Reference: RFC 2685 Fox B., et al, 'Virtual Private Networks Identifier', September 1999. SIZE (0..31) · OCTET STRING
The human-readable name of this VPN. This MAY be equivalent to the [RFC2685] VPN-ID, but may also vary. If it is set to the VPN ID, it MUST be equivalent to the value of mplsL3VpnVrfVpnId. It is strongly recommended that all sites supporting VRFs that are part of the same VPN use the same naming convention for VRFs as well as the same VPN ID. Reference: [RFC2685]
1.3.6.1.2.1.243.1.8.1.1
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mvpnMrouteNextHopGroupAddr object that follows.
1.3.6.1.2.1.243.1.8.1.2
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The IP multicast group address that, along with the corresponding mvpnMrouteNextHopGroupPrefixLength object, identifies destinations for which this entry contains multicast forwarding information. This address object is only significant up to mvpnMrouteNextHopGroupPrefixLength bits. The remaining address bits MUST be set to zero. For addresses of type 'ipv4z' or 'ipv6z', the appended zone index is significant even though it lies beyond the prefix length. The use of these address types indicates that this forwarding state applies only within the given zone. Zone index zero is not valid in this table.
1.3.6.1.2.1.243.1.8.1.3
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The length in bits of the mask that, along with the corresponding mvpnMrouteGroupAddr object, identifies destinations for which this entry contains multicast routing information. If the corresponding InetAddressType is 'ipv4' or 'ipv4z', this object must be in the range 4..32. If the corresponding InetAddressType is 'ipv6' or 'ipv6z', this object must be in the range 8..128.
1.3.6.1.2.1.243.1.8.1.4
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mvpnMrouteNextHopSourceAddrs object that follows. A value of unknown(0) indicates a non-source-specific entry, corresponding to all sources in the group. Otherwise, the value MUST be the same as the value of mvpnMrouteNextHopGroupAddrType.
1.3.6.1.2.1.243.1.8.1.5
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The network address that, along with the corresponding mvpnMrouteNextHopSourcePrefixLength object, identifies the sources for which this entry specifies a next hop. This address object is only significant up to mvpnMrouteNextHopSourcePrefixLength bits. The remaining address bits MUST be set to zero. For addresses of type 'ipv4z' or 'ipv6z', the appended zone index is significant even though it lies beyond the prefix length. The use of these address types indicates that this source address applies only within the given zone. Zone index zero is not valid in this table.
1.3.6.1.2.1.243.1.8.1.6
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The length in bits of the mask that, along with the corresponding mvpnMrouteNextHopSourceAddrs object, identifies the sources for which this entry specifies a next hop. If the corresponding InetAddressType is 'ipv4' or 'ipv4z', this object must be in the range 4..32. If the corresponding InetAddressType is 'ipv6' or 'ipv6z', this object must be in the range 8..128. If the corresponding InetAddressType is 'unknown', this object must be zero.
1.3.6.1.2.1.243.1.8.1.7
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The ifIndex value of the outgoing interface for this next hop.
1.3.6.1.2.1.243.1.8.1.8
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mvpnMrouteNextHopAddr object that follows.
1.3.6.1.2.1.243.1.8.1.9
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The address of the next hop specific to this entry. For most interfaces, this is identical to mvpnMrouteNextHopGroupAddr. Non-Broadcast Multi-Access (NBMA) interfaces, however, may have multiple next-hop addresses out of a single outgoing interface.
1.3.6.1.2.1.243.1.8.1.10
INTEGER1 = pruned2 = forwarding · Integer32
An indication of whether the outgoing interface and next hop represented by this entry is currently being used to forward IP datagrams. The enumerated states and the corresponding descriptions are as follows: pruned : this entry is not currently being used. forwarding : this entry is currently being used.
1.3.6.1.2.1.243.1.8.1.11
TimeTicks
The minimum amount of time remaining before this entry will be aged out. If mvpnMrouteNextHopState is pruned(1), this object represents the remaining time for the prune to expire after which the state will return to forwarding(2). If mvpnMrouteNextHopState is forwarding(2), this object indicates the time after which this entry will be removed from the table. The value of zero indicates that the entry is not subject to aging.
1.3.6.1.2.1.243.1.8.1.12
Unsigned32 (0..256)
The minimum number of hops between this router and any member of this IP multicast group reached via this next hop on the corresponding outgoing interface. Any IP multicast datagram for the group that has a TTL (IPv4) or a Hop Count (IPv6) less than mvpnMrouteNextHopClosestMemberHops will not be forwarded through this interface. A value of zero means all multicast datagrams are forwarded out of the interface. A value of 256 means that no multicast datagrams are forwarded out of the interface. This is an optimization applied by multicast routing protocols that explicitly track hop counts to downstream listeners. Multicast protocols that are not aware of hop counts to downstream listeners set this object to zero.
1.3.6.1.2.1.243.1.8.1.13
IANAipMRouteProtocol1 = other2 = local3 = netmgmt4 = dvmrp5 = mospf6 = pimSparseDense7 = cbt8 = pimSparseMode9 = pimDenseMode10 = igmpOnly11 = bgmp12 = msdpThe multicast routing protocol. Inclusion of values for multicast routing protocols is not intended to imply that those protocols need be supported. · Integer32
The routing protocol via which this next hop was learned.
1.3.6.1.2.1.243.1.8.1.14
Counter64 (0..18446744073709551615)
The number of octets of multicast packets that have been forwarded using this route. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnMrouteNextHopCounterDiscontinuityTime object.
1.3.6.1.2.1.243.1.8.1.15
Counter64 (0..18446744073709551615)
The number of packets that have been forwarded using this route. Discontinuities in the value of this counter can occur at re-initialization of the management system and at other times as indicated by the corresponding mvpnMrouteNextHopCounterDiscontinuityTime object.
1.3.6.1.2.1.243.1.8.1.16
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime on the most recent occasion at which any one or more of this application's counters, viz., counters with the OID prefix 'mvpnMrouteNextHopOctets' or 'mvpnMrouteNextHopPackets', suffered a discontinuity. If no such discontinuities have occurred since the last re-initialization of the local management subsystem, this object will have a zero value.
1.3.6.1.2.1.243.0.1
mvpnMvrfActionTaken notifies about a change in an MVRF on the PE. The change itself will be given by mvpnGenMvrfLastAction.
1.3.6.1.2.1.243.1.2.1.4
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The timestamp when the MVRF was created for the MVPN represented by this entry.
1.3.6.1.2.1.243.1.2.1.2
INTEGER1 = createdMvrf2 = deletedMvrf3 = modifiedMvrfIpmsiConfig4 = modifiedMvrfSpmsiConfig · Integer32
This object describes the last action pertaining to the MVPN represented by this entry. The enumerated action types and the corresponding descriptions are as follows: createdMvrf: MVRF was created for this MVPN on the PE. deletedMvrf: MVRF for this MVPN was deleted from the PE. A conceptual row in this table will never have mvpnGenMvrfLastAction equal to deletedMvrf, because in that case, the row itself will not exist in the table. This value for mvpnGenMvrfLastAction is defined solely for use in the mvpnMvrfActionChange notification. modifiedMvrfIpmsiConfig: An I-PMSI for this MVPN was configured, deleted, or changed. modifiedMvrfSpmsiConfig: An S-PMSI for this MVPN was configured, deleted, or changed.
1.3.6.1.2.1.243.1.2.1.3
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The timestamp when the last action, given in the corresponding mvpnGenMvrfLastAction object, was carried out.
1.3.6.1.2.1.243.1.2.1.4
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The timestamp when the MVRF was created for the MVPN represented by this entry.
1.3.6.1.2.1.243.1.2.1.5
INTEGER1 = pim2 = bgp · Integer32
The protocol used to signal C-multicast routing information across the provider core for the MVPN represented by this entry. The enumerated protocols and the corresponding descriptions are as follows: pim : PIM (PIM-MVPN) bgp : BGP (BGP-MVPN) Reference: RFC 6513, Section 5
1.3.6.1.2.1.243.1.2.1.8
INTEGER1 = highestPeAddress2 = cRootGroupHashing3 = ucastUmhRoute · Integer32
The Upstream Multicast Hop (UMH) selection method for the MVPN represented by this entry. The enumerated methods and the corresponding descriptions are as follows: highestPeAddress : PE with the highest address (see RFC 6513, Section 5.1.3) cRootGroupHashing : hashing based on (c-root, c-group) ucastUmhRoute : per-unicast route towards c-root Reference: RFC 6513, Section 5.1
1.3.6.1.2.1.243.1.2.1.9
INTEGER1 = senderReceiver2 = receiverOnly3 = senderOnly · Integer32
The type of the customer site, connected to the MVPN represented by this entry. The enumerated types and the corresponding descriptions are as follows: senderReceiver : Site is both sender and receiver receiverOnly : Site is receiver only senderOnly : Site is sender only Reference: RFC 6513, Section 2.3