This MIB module defines managed objects that facilitate the management of AON node.
The information available through this MIB includes o AON node state i.e., whether the AON node is 'unregistered', 'registered', 'active', 'inactive'.
o Node metrics information when a node is in the 'active' state.
o The node metrics information includes the number of messages received by the node, number of PEPs deployed and number of messages received by a PEP as well as information about the end points that the messages are delivered to. The metrics are reset when the AON data plane is restarted.
The following terms are used throughout this MIB:
AON : Application Oriented Networking.
_____________
| AON |
| Management |
| Console |
|____________| | | | | ____ |____________________________
| | AON Node |
| __V_________ _________ |
| | | | | |
| | AON | | AON | |
| | Management|---->| Data | |
| | Agent | | Plane | |
| |___________ |________| |
| |
|_________________________________| Figure 1 : AON
AON data plane: This is the piece of software that runs on the AON node and is responsible for processing application message traffic.
AMC : AON Management Console. A Web-based application used to manage the AON installation, upgrade, and operation. This is also referred to as the AON Management Plane.
AMA : AON Management Agent. An agent that runs on the AON node and acts as intermediary between the AON data plane and the AMC.
AON Node : An AON node is either a single device (blade or appliance) or a virtual cluster of devices (blades or appliances) that are running the AON software.
AON Cloud : A group of AON nodes that are connected together
via NextHop configuration is referred to as an AON cloud.
_____________ _____________
| Source | | Destination |
| End point | | End point |
| Application | | Application |
| ____________| |_____________|
_____|________________________________^_____
( | AON Cloud | )
( __V______ ________ ____|___ )
( | | | | | | )
( | AON | | AON | | AON | )
( | Entry | | Inter- | | Exit | )
( | Node | | mediate| | Node | )
( | |---->| Node |---->| | )
( | | | | | | )
( | | | | | | )
( |_______ | |_______ | |________| )
( )
( )
(___________________________________________ ) Figure 2: AON Cloud
Entry Node : The first node in an AON cloud, generally the one closest to the client, is known as the Entry Node. This node is also sometimes referred to as the Client Proxy.
Exit Node : The ultimate node in an AON cloud, generally the one closest to the server, is known as the Exit Node. This node is also sometimes referred to as the Server Proxy.
Intermediate Node : Any AON node in an AON cloud that is neither directly communicating with the client or the server (i.e. neither an Entry Node nor an Exit Node) is known as an Intermediate Node.
PEP : Policy Execution Plan. A PEP is a sequence of bladelets that determine how a message is processed in AON.
MEP : Message Exchange Pattern. MEP describes the pattern of messages required by a communications protocol to establish or use a communication channel. There are two major message exchange patterns: a request response pattern, and a one way pattern.
Bladelet : A bladelet is a piece of software that performs a specific message handling function. Bladelets are combined together into PEPs.
Send Bladelet : Routing bladelet that sends a message to a selected destination.
Notify Bladelet : Bladelet for generating a custom
notification (either as SNMP trap or email) based on user specified condition.
NamedException : A NamedException is exposed by a bladelet as connection points to identify a recoverable exception. The action to handle a NamedException thrown by a bladelet can be explicitly designed in the PEP by associating a execution path which comprises of a series of bladelet.
Exception Block : It is the block in the PEP that is marked by the exception marker and which is executed in case of a bladelet exception that is not a NamedException that has an output path associated with it.
URI : Uniform Resource Identifier. A URI (Uniform Resource Identifier) is the way you identify any content in the Internet space, whether it be a page of text, a video or sound clip, a still or animated image, or a program. The most common form of URI is the Web page address, which is a particular form or subset of URI called a Uniform Resource Locator (URL). A URI typically describes: * mechanism used to access the resource * specific computer that the resource is housed in * specific name of the resource (a file name) on the computer.
URL : Uniform Resource Locator. A URL (Uniform Resource Locator) is the unique Internet address for a file. The URL contains the name of the protocol to be used to access the file resource, a domain name that identifies a specific computer on the Internet, and a pathname, a hierarchical description that specifies the location of a file in that computer.
End point: An end point is an application that is either a sender (client) or a receiver (server) of messages that communicates with AON.
This object indicates the node state.
'unregistered': Node is not yet registered with AMC.
'registered' : Node has registered with AMC but is not yet
activated.
'active' : Node has been activated from AMC and is ready
to process messages.
'inactive' : Node has been activated from AMC but AON
process is down.
caonBootTime
1.3.6.1.4.1.9.9.646.1.1.2
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
This object indicates the value of sysUpTime when the AON data plane was bootstrapped successfully.
caonLastActivateTime
1.3.6.1.4.1.9.9.646.1.1.3
DateAndTimeA date-time specification.
field octets contents range
----- ------ -------- -----
1 1-2 year* 0..65536
2 3 month 1..12
3 4 day 1..31
4 5 hour 0..23
5 6 minutes 0..59
6 7 seconds 0..60
(use 60 for leap-second)
7 8 deci-seconds 0..9
8 9 direction from UTC '+' / '-'
9 10 hours from UTC* 0..13
10 11 minutes from UTC 0..59
* Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13
For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as:
1992-5-26,13:30:15.0,-4:0
Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
This object indicates the local time at the node when the node was last activated from AMC.
caonReceivedMessages
1.3.6.1.4.1.9.9.646.1.1.4
Counter32 · messages
This object indicates the aggregate count of messages received by the node. This includes all the messages for which a PEP was executed as well as the messages that were pass-through and did not involve any PEP invocation. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of caonCounterDiscontinuityTime object.
caonAmcIpAddressType
1.3.6.1.4.1.9.9.646.1.1.5
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object indicates the type of IP address by which the AMC for the node is reachable.
caonAmcIpAddress
1.3.6.1.4.1.9.9.646.1.1.6
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This object indicates the IP Address of the AMC managing this node. The type of this address is determined by the value of caonAmcIpAddressType object
caonPepCount
1.3.6.1.4.1.9.9.646.1.1.7
Gauge32 · PEPs
This object indicates the total number of PEPs that are deployed on the node.
caonCounterDiscontinuityTime
1.3.6.1.4.1.9.9.646.1.1.11
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime at the most recent occasion at which one or more of the counters suffered a discontinuity. The relevant counters are the specific instances associated with any Counter32 or Counter64 object in the MIB. If no such discontinuities have occured since the last initialization of the local management subsystem, then this object contains a zero value.
caonMessageSrcUri
1.3.6.1.4.1.9.9.646.1.2.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..255) · OCTET STRING · hint 255t
This object indicates the message source URI.
caonMessageSrcIpAddressType
1.3.6.1.4.1.9.9.646.1.2.2
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object indicates the type of IP address of the message source.
caonMessageSrcIpAddress
1.3.6.1.4.1.9.9.646.1.2.3
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This object indicates the message source IP Address. The type of this address is determined by the value of caonMessageSrcIpAddressType.
caonMessageSrcPort
1.3.6.1.4.1.9.9.646.1.2.4
CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32
This object indicates the message source port number.
caonNotificationName
1.3.6.1.4.1.9.9.646.1.2.5
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..64) · OCTET STRING · hint 255t
This object indicates the name of the custom notification type. This notification type is defined by the customer to identify the custom notification.
caonNotificationText
1.3.6.1.4.1.9.9.646.1.2.6
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..255) · OCTET STRING · hint 255t
This object indicates additional information regarding the custom notification. This notification text is defined by the customer to provide details related to the custom notification.
caonSendResponseThreshold
1.3.6.1.4.1.9.9.646.1.2.7
TimeTicks
This object indicates the end point response time threshold that is configured in the Send bladelet. If the time to receive a response from the end point exceeds this threshold, then a caonSendResponseThresholdExceeded notification may be generated.
caonNotifEnableIndicators
1.3.6.1.4.1.9.9.646.1.2.8
BITS
This object specifies whether the SNMP notifications will or will not be sent.
If the 'caonUpNotifEnabled' bit is set, then caonUp notification will be sent when AON data plane bootstraps successfully. If the 'caonUpNotifEnabled' bit is not set, caonUp notification will not be sent.
If the 'caonDownNotifEnabled' bit is set, then caonDown notification will be sent when the AON data plane goes down. If the 'caonDownNotifEnabled' bit is not set, caonDown notification will not be sent.
If the 'caonNewPepDeployedNotifEnabled' bit is set, then caonNewPepDeployed notification will be sent when a new PEP is deployed successfully after AON bootstrap. If the 'caonNewPepDeployedNotifEnabled' bit is not set, caonNewPepDeployed notification will not be sent.
If the 'caonMessageDeliveryFailedNotifEnabled' bit is set, then caonMessageDeliveryFailed notification will be sent when a message cannot be delivered to the end point. If the 'caonMessageDeliveryFailedNotifEnabled' bit is not set, caonMessageDeliveredFailed notification will not be sent.
If the 'caonSendResponseThresholdExceededNotifEnabled' bit is set, then caonSendResponseThresholdExceeded notification will be sent when the end point response time exceeds the threshold value specified in Send Bladelet. If the bit 'caonSendResponseThresholdExceededNotifEnabled' is not set, caonSendResponseThresholdExceeded notification will not be sent.
If the 'caonCustomNotifEnabled' bit is set, caonCustomNotification will be sent. If the 'caonCustomNotifEnabled' bit is not set, caonCustomNotification will not be sent.
Table details
caonPepTable
1.3.6.1.4.1.9.9.646.1.1.8
Index: caonPepIndex
This table lists descriptive and status information about the PEPs contained by this AON node.
caonPepIndex
1.3.6.1.4.1.9.9.646.1.1.8.1.1
Unsigned32 (1..4294967295)
This object indicates an arbitary integer value that uniquely identifies a PEP.
caonPepName
1.3.6.1.4.1.9.9.646.1.1.8.1.2
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..255) · OCTET STRING · hint 255t
This object indicates the name of the PEP.
caonPepStyle
1.3.6.1.4.1.9.9.646.1.1.8.1.3
INTEGER1 = oneWay2 = requestResponse · Integer32
This object indicates the PEP interaction style commonly known as the MEP. The possible values are:
'oneWay' : Response is not expected from the receiving
end point. AON does not wait for response message in this case. 'requestResponse' : Response is expected from the receiving end point. AON waits for the response from the receiving end point.
However, the PEP interaction style can be overridden by the Send Bladelet interaction style. If the user specifies the interaction style to be 'oneWay' in the Send bladelet, it overrides the PEP level interaction style and AON does not wait for a response from the receiving end point.
caonPepReceivedMessages
1.3.6.1.4.1.9.9.646.1.1.8.1.4
Counter32
This object indicates the total number of messages that were received and for which this PEP was executed. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of caonCounterDiscontinuityTime object.
caonPepFailures
1.3.6.1.4.1.9.9.646.1.1.8.1.5
Counter32
This object indicates the number of times the PEP execution failed and PEP was forced to execute the exception path. This count is incremented whether an exception path is present or not. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of caonCounterDiscontinuityTime object.
caonPepSecurityFailures
1.3.6.1.4.1.9.9.646.1.1.8.1.6
Counter32
This object indicates the number of times authentication and certificate validation failures were encountered during PEP execution. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of caonCounterDiscontinuityTime object.
caonPepEndPointTable
1.3.6.1.4.1.9.9.646.1.1.10
Index: caonPepIndex · caonPepEndPointIndex
This table lists the end points that the messages were delivered to during PEP execution.
caonPepEndPointIndex
1.3.6.1.4.1.9.9.646.1.1.10.1.1
Unsigned32 (1..4294967295)
This object indicates an arbitary integer-value that uniquely identifies the PEP end point.
caonPepEndPointUrl
1.3.6.1.4.1.9.9.646.1.1.10.1.2
CiscoURLStringThis textual convention defines the URL string.
The Universal Resource Locator(URL). The URL strings
are compact string representation for a resource available via internet. This is the address location of the page to load. The string should represent a fully qualifying string with the format 'protocol:/server/page'. In general the string should point to any value that can be saved/loaded. Any limitation for the URL must be defined as part of the description of any object which uses this syntax.Reference: Uniform Resource Locators. RFC 1738. SIZE (1..255) · OCTET STRING
This object indicates the URL of the end point. This URL does not include the query parameters.
caonEndPointAttemptedMessages
1.3.6.1.4.1.9.9.646.1.1.10.1.3
Counter32
This object indicates the number of message delivery attempts to the end point. For example, if a message was delivered successfully on the initial try this counter will be incremented by 1; however, if that message was not successfully delivered on the initial try and 3 retry attempts were made, then the counter will be incremented by 4. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of caonCounterDiscontinuityTime object.
caonOneWayDeliveredMessages
1.3.6.1.4.1.9.9.646.1.1.10.1.4
Counter32
This object indicates the number of one-way messages successfully delivered to the end point. This count includes only those messages that do not require a response from the end point. However in case the AON node is not the exit node but rather an entry or intermediate node hop in the AON cloud then this counter represents successful delivery to the next hop. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of caonCounterDiscontinuityTime object.
caonOneWayFailedMessages
1.3.6.1.4.1.9.9.646.1.1.10.1.5
Counter32
This object indicates the number of one-way messages that failed delivery to the end point. This count includes only those messages that do not require a response from the end point. However in case the AON node is not the exit node but rather an entry or intermediate node hop in the AON cloud then this counter represents failed delivery to the next hop. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of caonCounterDiscontinuityTime object.
caonReqResponseDeliveredMessages
1.3.6.1.4.1.9.9.646.1.1.10.1.6
Counter32 · messages
This object indicates the number of response required messages successfully delivered to the end point. The count includes only those messages for which a response was received successfully from the end point. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of caonCounterDiscontinuityTime object.
caonReqResponseFailedMessages
1.3.6.1.4.1.9.9.646.1.1.10.1.7
Counter32 · messages
This object indicates the number of response required messages that failed delivery to the end point. This count includes only those messages for which a response message was expected from the end point. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of caonCounterDiscontinuityTime object.
caonEndPointMinResponseTime
1.3.6.1.4.1.9.9.646.1.1.10.1.8
TimeTicks
This object indicates the minimum response time experienced by the PEP to receive a response from the end point.
caonEndPointMaxResponseTime
1.3.6.1.4.1.9.9.646.1.1.10.1.9
TimeTicks
This object indicates the maximum response time experienced by the PEP to receive a response from the end point.
caonEndPointAvgResponseTime
1.3.6.1.4.1.9.9.646.1.1.10.1.10
TimeTicks
This object indicates the average response time experienced by the PEP to receive a response from the end point.
Trap details
caonUp
1.3.6.1.4.1.9.9.646.0.1
caonUp notification is sent when AON data plane is bootstrapped successfully and AON is ready to process messages.
caonDown
1.3.6.1.4.1.9.9.646.0.2
caonDown notification is sent when AON data plane goes down. AON data plane might be down as a result of an administrative
command i.e. stopping AON via CLI command or deactivating the
node from AMC or due to abnormal termination of AON data plane. If there is a hardware failure on the AON box then the notification might not be triggered.
caonNewPepDeployed
1.3.6.1.4.1.9.9.646.0.3
This notification is sent if a new PEP is deployed after AON has bootstrapped successfully. caonPepName identifies the name of the new PEP.
caonPepName
1.3.6.1.4.1.9.9.646.1.1.8.1.2
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..255) · OCTET STRING · hint 255t
This object indicates the name of the PEP.
caonMessageDeliveryFailed
1.3.6.1.4.1.9.9.646.0.4
This notification is sent if a message cannot be delivered to the end point. caonMessageEndPointURL identifies the end point to which the message was being delivered to. The message source is either identified by caonMessageSrcUri or (caonMessageSrcIpAddr and caonMessageSrcPort).
caonPepEndPointUrl
1.3.6.1.4.1.9.9.646.1.1.10.1.2
CiscoURLStringThis textual convention defines the URL string.
The Universal Resource Locator(URL). The URL strings
are compact string representation for a resource available via internet. This is the address location of the page to load. The string should represent a fully qualifying string with the format 'protocol:/server/page'. In general the string should point to any value that can be saved/loaded. Any limitation for the URL must be defined as part of the description of any object which uses this syntax.Reference: Uniform Resource Locators. RFC 1738. SIZE (1..255) · OCTET STRING
This object indicates the URL of the end point. This URL does not include the query parameters.
caonMessageSrcUri
1.3.6.1.4.1.9.9.646.1.2.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..255) · OCTET STRING · hint 255t
This object indicates the message source URI.
caonMessageSrcIpAddressType
1.3.6.1.4.1.9.9.646.1.2.2
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object indicates the type of IP address of the message source.
caonMessageSrcIpAddress
1.3.6.1.4.1.9.9.646.1.2.3
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This object indicates the message source IP Address. The type of this address is determined by the value of caonMessageSrcIpAddressType.
caonMessageSrcPort
1.3.6.1.4.1.9.9.646.1.2.4
CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32
This object indicates the message source port number.
caonSendResponseThresholdExceeded
1.3.6.1.4.1.9.9.646.0.5
This notification is sent if the destination end point response time exceeds the threshold value specified in the Send Bladelet. caonPepEndPointUrl identifies the URI of the end point the message was being delivered to. caonSendResponseThreshold identifies the end point response time threshold value configured in the Send bladelet.
caonPepEndPointUrl
1.3.6.1.4.1.9.9.646.1.1.10.1.2
CiscoURLStringThis textual convention defines the URL string.
The Universal Resource Locator(URL). The URL strings
are compact string representation for a resource available via internet. This is the address location of the page to load. The string should represent a fully qualifying string with the format 'protocol:/server/page'. In general the string should point to any value that can be saved/loaded. Any limitation for the URL must be defined as part of the description of any object which uses this syntax.Reference: Uniform Resource Locators. RFC 1738. SIZE (1..255) · OCTET STRING
This object indicates the URL of the end point. This URL does not include the query parameters.
caonSendResponseThreshold
1.3.6.1.4.1.9.9.646.1.2.7
TimeTicks
This object indicates the end point response time threshold that is configured in the Send bladelet. If the time to receive a response from the end point exceeds this threshold, then a caonSendResponseThresholdExceeded notification may be generated.
caonCustomNotification
1.3.6.1.4.1.9.9.646.0.6
This notification could be triggered during PEP execution. Currently this is triggered from the Notify Bladelet if the customer specified condition evaluates to true and the notification type selected is SNMP. This provides a way to
extend the AON platform to generate customer defined
notifications based on customer specified conditions. caonNotificationName identifies the name of the customer defined notification type. caonNotificationText identifies the notification text for the custom notification.
caonNotificationName
1.3.6.1.4.1.9.9.646.1.2.5
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..64) · OCTET STRING · hint 255t
This object indicates the name of the custom notification type. This notification type is defined by the customer to identify the custom notification.
caonNotificationText
1.3.6.1.4.1.9.9.646.1.2.6
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..255) · OCTET STRING · hint 255t
This object indicates additional information regarding the custom notification. This notification text is defined by the customer to provide details related to the custom notification.