This is a MIB for managing Application Acceleration System(s). This MIB includes instrumentation for providing the performance statistics and status of the condenser which is the core of the Application Acceleration System. A condenser is a software accelerator that applies several optimization techniques to accelerate Web application access. The condenser application accelerates and optimizes any HTML or XML-based application over HTTP resulting in response time improvements and decrease in bandwidth requirements. This application shall reside in a content switching module or appliance.
Acronyms and terminology:
HTTP
In this MIB it refers to both secure ('HTTPS') as well as non-secure ('HTTP') web traffic.
IMS
If-Modified-Since is an HTTP request type. The If-Modified-Since request-header field is used with a method to make it conditional: if the requested variant has not been modified since the time specified in this field, an entity will not be returned from the server; instead, a '304' ('not modified') response will be returned without any message-body.
Delta
It is the ability of condenser to dynamically update client browser caches directly with content differences, or deltas, resulting in faster page downloads.
FlashForward
FlashForward is a object acceleration technology that eliminates network delays associated with embedded cacheable web objects such as images, style sheets, JavaScript files, etc. FlashForward object acceleration places the responsibility for validating object freshness on the condenser, rather than on the client, making it more efficient. With FlashForward, the client never needs to validate the freshness of browser-cached objects with the origin server, thus significantly accelerating page downloads, and reducing both upstream and downstream traffic associated with object validation requests.
Transformation
It is the change applied on the incoming web traffic, as part of specific optimization method like delta or flashforward, to achieve web traffic acceleration.
Objects
All the non-textual embedded components of a web page are referred to as Objects in this MIB.
Condensable
It refers to all objects that can be subjected to optimization by condenser.
Non-Condensable
It refers to all objects that cannot be subjected to optimization by condenser.
REFERENCE
[1] Hypertext Transfer Protocol -- HTTP/1.1, RFC 2616 Section 14.25 If-Modified-Since.
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object represents the status of generation of the caaStateChange notification in response to a change in the state of condenser. A value of 'true' indicates that the notification generation is enabled and the caaStateChange notification is to be generated when the state changes. A value of 'false' indicates that the notification generation is disabled.
Table details
caaStatTable
1.3.6.1.4.1.9.9.594.1.1.1
Index: caaPort
This table provides the information about the performance related statistics and the status of the condenser on this system. An entry is added
to this system automatically by the agent when
the system boots up.
caaPort
1.3.6.1.4.1.9.9.594.1.1.1.1.1
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (1..65535) · Unsigned32 · hint d
This object represents the port on which the condenser listens.
caaState
1.3.6.1.4.1.9.9.594.1.1.1.1.2
CaaState1 = active2 = impaired3 = downThis textual convention provides the current state of the condenser. The semantics are as follows.
'active' : condenser is running and serving HTTP requests.
'impaired' : condenser is running, but not serving any HTTP requests.
'down' : condenser is not running. · Integer32
This object represents the current state of the condenser.
caaRequests
1.3.6.1.4.1.9.9.594.1.1.1.1.3
Counter32 · requests
This object represents the total number of end-user HTTP requests the condenser has received.
caaNoncondensableRequests
1.3.6.1.4.1.9.9.594.1.1.1.1.4
Counter32 · requests
This object represents the total number of end-user HTTP requests the condenser has received, that cannot be optimized.
caaRequestedObjectSize
1.3.6.1.4.1.9.9.594.1.1.1.1.5
Counter32 · bytes
This object represents the accumulated size (in bytes) of each end-user requested object.
caaFinalResponseSize
1.3.6.1.4.1.9.9.594.1.1.1.1.6
Counter32 · bytes
This object represents the accumulated size (in bytes) of each responses, both for condensable and non-condensable end-user HTTP request.
caaLastRestartedTime
1.3.6.1.4.1.9.9.594.1.1.1.1.7
DateAndTimeA date-time specification.
field octets contents range
----- ------ -------- -----
1 1-2 year* 0..65536
2 3 month 1..12
3 4 day 1..31
4 5 hour 0..23
5 6 minutes 0..59
6 7 seconds 0..60
(use 60 for leap-second)
7 8 deci-seconds 0..9
8 9 direction from UTC '+' / '-'
9 10 hours from UTC* 0..13
10 11 minutes from UTC 0..59
* Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13
For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as:
1992-5-26,13:30:15.0,-4:0
Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
This object represents the time when the condenser was last started.
caaTransformed
1.3.6.1.4.1.9.9.594.1.1.1.1.8
Counter32 · transformations
This object represents the total number of successful transformations for FlashForward Objects.
caaUntransformed
1.3.6.1.4.1.9.9.594.1.1.1.1.9
Counter32 · transformations
This object represents the total number of unsuccessful transformations for FlashForward Objects.
caaTransformedObjectRequests
1.3.6.1.4.1.9.9.594.1.1.1.1.10
Counter32 · requests
This object represents the total number of HTTP requests (excluding the IMS requests) for the transformed FlashForward objects.
caaTransformedObjectIMSRequests
1.3.6.1.4.1.9.9.594.1.1.1.1.11
Counter32 · requests
This object represents the total number of IMS requests for those transformed FlashForward objects.
caaStaticObjectHits
1.3.6.1.4.1.9.9.594.1.1.1.1.12
Counter32 · cache-hits
This object represents the total number of cacheable objects served from the cache, excluding the '304' ('not modified') replies.
caaStaticObjectHitSize
1.3.6.1.4.1.9.9.594.1.1.1.1.13
Counter32 · bytes
This object represents the accumulated size (in bytes) of the cacheable objects served from the cache, excluding '304' ('not modified') replies.
caaStaticObjectMisses
1.3.6.1.4.1.9.9.594.1.1.1.1.14
Counter32 · cache-misses
This object represents the total number of cacheable objects not found in the cache.
caaStaticObjectMissSize
1.3.6.1.4.1.9.9.594.1.1.1.1.15
Counter32 · bytes
This object represents the accumulated size (in bytes) of the cacheable objects not found in the cache.
caaRefreshHits
1.3.6.1.4.1.9.9.594.1.1.1.1.16
Counter32 · requests
This object represents the total number of requests for stale objects that have the responses from the origin server as 'not modified'.
caaIMSHits
1.3.6.1.4.1.9.9.594.1.1.1.1.17
Counter32 · requests
This object represents the total number of IMS requests for valid copies of objects in the cache.
caaIMSMisses
1.3.6.1.4.1.9.9.594.1.1.1.1.18
Counter32 · requests
This object represents the total number of IMS requests for objects that either do not exist or are stale in the cache.
caaDirectRequests
1.3.6.1.4.1.9.9.594.1.1.1.1.19
Counter32 · requests
This object represents the total number of non-cacheable object requests.
caaRequestSize
1.3.6.1.4.1.9.9.594.1.1.1.1.20
Counter32 · bytes
This object represents the accumulated size (in bytes) of each requests, both for condensable and non-condensable.
caaDeltaAbandons
1.3.6.1.4.1.9.9.594.1.1.1.1.21
Counter32 · requests
This object represents the total number of abandons of delta optimization requests.
Trap details
caaStateChange
1.3.6.1.4.1.9.9.594.0.1
This object represents the notification to be generated when a condenser undergoes a state change. caaState represents the new state of the condenser.
caaState
1.3.6.1.4.1.9.9.594.1.1.1.1.2
CaaState1 = active2 = impaired3 = downThis textual convention provides the current state of the condenser. The semantics are as follows.
'active' : condenser is running and serving HTTP requests.
'impaired' : condenser is running, but not serving any HTTP requests.
'down' : condenser is not running. · Integer32
This object represents the current state of the condenser.