EZ5 MIB Catalog

CISCO-BCP-MIB

2004-08-31

This MIB module describes the Managed Objects for of Bridge Control Protocol (RFC2878). This MIB is influenced by RFC1474.

Download CISCO-BCP-MIB.txt Open CISCO-BCP-MIB.txt in a new tab

TABLES (2)

Tables (2)

NameOID
bcpOperTable1.3.6.1.4.1.9.9.275.1.1
bcpConfigTable1.3.6.1.4.1.9.9.275.1.2

END OF TOC

Table details

bcpOperTable

1.3.6.1.4.1.9.9.275.1.1

Index: ifIndex

Table containing the status of the local BCP entity that is related to the operation of Bridging Control Protocol.

from IF-MIB

ifIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

bcpOperStatus

1.3.6.1.4.1.9.9.275.1.1.1.1

INTEGER1 = open2 = closed3 = listening · Integer32

The operational status of the Bridge Control Protocol. The possible values are : open(1) - the BCP link is up and both ends are configured in the compatible manner. closed(2) - the BCP link is down and neither ends are configured. listening(3) - the local BCP entity is configured and the remote end is not configured compatibly.

bcpConfigTable

1.3.6.1.4.1.9.9.275.1.2

Index: ifIndex

Table containing the configuration information for the local BCP entity that is related to the operation of Bridging over the PPP link.

from IF-MIB

ifIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

bcpConfigBridgeIdControl

1.3.6.1.4.1.9.9.275.1.2.1.1

INTEGER1 = enabled2 = disabled · Integer32

Reference: Section 5.1, Bridge-Identification, of RFC2878

The Bridge-Identification configuration option is designed for use when the line is an interface between half bridges connecting virtual or physical LAN segments. When enabled the local BCP entity initiates a Bridge Identification Option negotiation.

bcpConfigBridgeId

1.3.6.1.4.1.9.9.275.1.2.1.2

Unsigned32 (0..15)

Reference: Section 5.1, Bridge-Identification, of RFC2878

The bridge number of the local BCP entity. This value is meaningful only when the local BCP entity has negotiated the BridgeId Configuration option, which means the value of bcpConfigBridgeIdControl is enabled(1). The two half bridges must agree on the bridge number.

bcpConfigLineIdControl

1.3.6.1.4.1.9.9.275.1.2.1.3

INTEGER1 = enabled2 = disabled · Integer32

Reference: Section 5.2 , Line Identification, of RFC2878

The Line-Identification configuration option is designed for use when the line is assigned a LAN segment number. When enabled the local BCP entity initiates a Line Identification Option negotiation.

bcpConfigLineId

1.3.6.1.4.1.9.9.275.1.2.1.4

Unsigned32 (0..4095)

Reference: Section 5.2, Line-Identification, of RFC2878

The LAN segment number of the local BCP entity. This value is meaningful only when the local BCP entity negotiated the LineId Configuration option, which means the value of bcpConfigLineIdControl is enabled(1). The two half bridges must agree on the LAN segment number.

bcpConfigMacSupport

1.3.6.1.4.1.9.9.275.1.2.1.5

INTEGER1 = enabled2 = disabled · Integer32

Reference: Section 5.3 , MAC-Support, of RFC2878

The Mac-Support configuration option is provided to permit implementations to indicate the sort of traffic they are prepared to receive. When enabled the local BCP entity initiates a Mac-Support Option negotiation.

bcpConfigMacType

1.3.6.1.4.1.9.9.275.1.2.1.6

INTEGER1 = ieee802dot3Canonical2 = ieee802dot4Canonical3 = ieee802dot5NonCanonical4 = fddiNonCanonical11 = ieee802dot5Canonical12 = fddiCanonical · Integer32

Reference: Section 5.3, Mac-Support, of RFC2878

The MAC type that this local BCP entity is prepared to receive and service. This value is meaningful only when the local BCP entity has negotiated the MAC-Support Configuration option, which means the value of bcpConfigMacSupport is enabled(1). These values definition are specified in the most recent RFC1700.

bcpConfigTinygram

1.3.6.1.4.1.9.9.275.1.2.1.7

INTEGER1 = enabled2 = disabled · Integer32

Reference: Section 5.4 , Tinygram-Compression, of RFC2878

The Tinygram-Compression configuration option permits implementations to indicate support for Tinygram Compression. When enabled the local BCP Entity initiates a Tinygram-Compression Option negotiation.

bcpConfigMacAddressControl

1.3.6.1.4.1.9.9.275.1.2.1.8

INTEGER1 = enabled2 = disabled · Integer32

Reference: Section 5.5 , Mac-Address , of RFC2878

The Mac-Address configuration option enables the implementations to announce its MAC address or have one assigned. When enabled the local BCP Entity initiates a Mac-Address Option negotiation.

bcpConfigMacAddress

1.3.6.1.4.1.9.9.275.1.2.1.9

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..20) · OCTET STRING · hint 255a

Reference: Section 5.5, MAC-Address, of RFC2878

This value is meaningful only when the local BCP entity has negotiated the MAC-Address configuration option, which means the value of bcpConfigMacAddressControl is enabled(1). If it is non-zero format, the local BCP get its MAC address announced. It is represented in IEEE 802.1 Canonical format. If it is in zero format, i.e. 00-00-00-00-00-00 then the implementation of the system wishes to have a MAC address assigned.

bcpConfigSpanTreeControl

1.3.6.1.4.1.9.9.275.1.2.1.10

INTEGER1 = enabled2 = disabled · Integer32

Reference: Section 5.6, Spanning-Tree-Protocol, of RFC2878

The Spanning-Tree-Protocol configuration option enables a bridge to remain compatible with older implementations of BCP. When enabled the local BCP Entity initiates a Spanning-Tree-Protocol Option negotiation.

bcpConfigSpanTree

1.3.6.1.4.1.9.9.275.1.2.1.11

INTEGER0 = null1 = ieee802dot1D2 = ieee802dot1GExtended3 = ibmSourceRoute4 = decLanBridge100 · Integer32

Reference: Section 5.6, Spanning-Tree-Protocol, of RFC 2878

The desired spanning tree protocol of the local BCP entity. The listing values of the Spanning- Tree Protocol are specified in the most recent RFC1700. This value is meaningful only when the local BCP entity has negotiated the Spanning-Tree-Protocol configuration option, which means the value of bcpConfigSpanTreeControl is enabled(1).

bcpConfigIeee802dot1qTagged

1.3.6.1.4.1.9.9.275.1.2.1.12

INTEGER1 = enabled2 = disabled · Integer32

Reference: Section 5.7, IEEE-802-Tagged-Frame, of RFC2878

The IEEE-802-Tagged-Frame configuration option permits the implementation to support for IEEE 802.1q Tagged Frame. When enabled the local BCP Entity initiates a IEEE-802-Tagged-Frame Option negotiation.

bcpConfigMgmtInline

1.3.6.1.4.1.9.9.275.1.2.1.13

INTEGER1 = enabled2 = disabled · Integer32

Reference: Section 5.8 , Management-Inline, of RFC2878

The Management-Inline configuration option indicates that the system is willing to receive any IEEE-defined inter-bridge protocols. When enabled if the local BCP Entity initiates a Management-Inline Option negotiation.

bcpConfigBCPacketIndicator

1.3.6.1.4.1.9.9.275.1.2.1.14

INTEGER1 = enabled2 = disabled · Integer32

Reference: Section 5.9 , Bridge-Control-Packet-Indicator, of RFC2878

The Bridge Control Packet Indicator configuration option permits the implementation to indicate support for Bridge Control Packet Indicator. When enabled the local BCP Entity initiates a Bridge Control Packet Indicator Option negotiation.

↑ To TOC