An extension to the IETF BGP4 MIB module defined in RFC 1657.
Following is the terminology associated with Border Gateway Protocol(BGP).
UPDATE message UPDATE messages are used to transfer routing information between BGP peers. An UPDATE message is used to advertise a single feasible route to a peer, or to withdraw multiple unfeasible routes from service.
Adj-RIBs-In The Adj-RIBs-In store routing information that has been learned from inbound UPDATE messages. Their contents represent routes that are available as an input to the Decision Process.
Loc-RIB(BGP table) The Loc-RIB contains the local routing information that the BGP speaker has selected by applying its local policies to the routing information contained in its Adj-RIBs-In.
Adj-RIBs-Out The Adj-RIBs-Out store the information that the local BGP speaker has selected for advertisement to its peers. The routing information stored in the Adj-RIBs-Out will be carried in the local BGP speaker's UPDATE messages and advertised to its peers.
Path Attributes A variable length sequence of path attributes is present in every UPDATE. Each path attribute is a triple <attribute type, attribute length, attribute value> of variable length.
Network Layer Reachability Information(NLRI) A variable length field present in UPDATE messages which contains a list of Network Layer address prefixes.
Address Family Identifier(AFI) Primary identifier to indicate the type of the Network Layer Reachability Information(NLRI) being carried.
Subsequent Address Family Identifier(SAFI) Secondary identifier to indicate the type of the Network Layer Reachability Information(NLRI) being carried.
Indicates whether the specific notifications are enabled. If notifsEnable(0) bit is set to 1, then the notifications defined in ciscoBgp4NotificationsGroup1 are enabled; If notifsPeer2Enable(1) bit is set to 1, then the notifications defined in ciscoBgp4Peer2NotificationsGroup are enabled.
cbgpLocalAs
1.3.6.1.4.1.9.9.187.1.3.2
InetAutonomousSystemNumberRepresents an autonomous system number that identifies an Autonomous System (AS). An AS is a set of routers under a single technical administration, using an interior gateway protocol and common metrics to route packets within the AS, and using an exterior gateway protocol to route packets to other ASes'. IANA maintains the AS number space and has delegated large parts to the regional registries.
Autonomous system numbers are currently limited to 16 bits (0..65535). There is, however, work in progress to enlarge the autonomous system number space to 32 bits. Therefore, this textual convention uses an Unsigned32 value without a range restriction in order to support a larger autonomous system number space.Reference: RFC 1771, RFC 1930 · Unsigned32 · hint d
Reference: RFC 4271, Section 4.2, 'My Autonomous System'. RFC 4893, BGP Support for Four-octet AS Number Space.
Reference: RFC-1771: A Border Gateway Protocol 4 (BGP-4), RFC-2858: Multiprotocol Extensions for BGP-4, RFC-2547: BGP/MPLS VPNs
This table contains information about routes to destination networks from all BGP4 peers. Since BGP4 can carry routes for multiple Network Layer protocols, this table has the Address Family Identifier(AFI) of the Network Layer protocol as the first index. Further for a given AFI, routes carried by BGP4 are distinguished based on Subsequent Address Family Identifiers(SAFI). Hence that is used as the second index. Conceptually there is a separate Loc-RIB maintained by the BGP speaker for each combination of AFI and SAFI supported by it.
cbgpRouteAfi
1.3.6.1.4.1.9.9.187.1.1.1.1.1
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
Represents Address Family Identifier(AFI) of the Network Layer protocol associated with the route. An implementation is only required to support IPv4 unicast and VPNv4 (Value - 1) address families.
cbgpRouteSafi
1.3.6.1.4.1.9.9.187.1.1.1.1.2
CbgpSafi1 = unicast2 = multicast3 = unicastAndMulticast128 = vpnSubsequent Address Family Identifier(SAFI) is used by BGP speaker to indicate the type of the the Network Layer Reachability Information(NLRI) being carried. RFC-2858 has defined the following values for SAFI. 1 - Network Layer Reachability Information used for unicast forwarding 2 - Network Layer Reachability Information used for multicast forwarding 3 - Network Layer Reachability Information used for both unicast and multicast forwarding. SAFI values 128 through 255 are for private use.Reference: RFC-2858: Multiprotocol Extensions for BGP-4, RFC-2547: BGP/MPLS VPNs · Integer32
Represents Subsequent Address Family Identifier(SAFI) of the route. It gives additional information about the type of the route. An implementation is only required to support IPv4 unicast(Value - 1) and VPNv4( Value - 128) address families.
cbgpRoutePeerType
1.3.6.1.4.1.9.9.187.1.1.1.1.3
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
Represents the type of Network Layer address stored in cbgpRoutePeer. An implementation is only required to support IPv4 address type(Value - 1).
cbgpRoutePeer
1.3.6.1.4.1.9.9.187.1.1.1.1.4
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The Network Layer address of the peer where the route information was learned. An implementation is only required to support an IPv4 peer.
cbgpRouteAddrPrefix
1.3.6.1.4.1.9.9.187.1.1.1.1.5
CbgpNetworkAddressRepresents the Network Address prefix carried in the BGP UPDATE messages. In the following table, column 'Type' gives the kind of Network Layer address which will be stored in the object of this type based on the values of Address Family Identifier(AFI) and SAFI.
AFI SAFI Type
ipv4(1) unicast(1) IPv4 address
ipv4(1) multicast(2) IPv4 address
ipv4(1) vpn(128) VPN-IPv4 address
ipv6(2) unicast(1) IPv6 address
ipv6(2) multicast(2) IPv6 address
ipv6(2) vpn(128) VPN-IPv6 address
A VPN-IPv4 address is a 12-byte quantity, beginning with an 8-byte 'Route Distinguisher (RD)' and ending with a 4-byte IPv4 address.
A VPN-IPv6 address is a 24-byte quantity, beginning with an 8-byte 'Route Distinguisher (RD)' and ending with a 16-byte IPv6 address.Reference: RFC 2858, Multiprotocol Extensions for BGP-4. RFC 2547, Section 4.1, BGP/MPLS VPNs. SIZE (0..255) · OCTET STRING
A Network Address prefix in the Network Layer Reachability Information field of BGP UPDATE message. This object is a Network Address containing the prefix with length specified by cbgpRouteAddrPrefixLen. Any bits beyond the length specified by cbgpRouteAddrPrefixLen are zeroed.
cbgpRouteAddrPrefixLen
1.3.6.1.4.1.9.9.187.1.1.1.1.6
Unsigned32 (0..2040)
Length in bits of the Network Address prefix in the Network Layer Reachability Information field.
cbgpRouteOrigin
1.3.6.1.4.1.9.9.187.1.1.1.1.7
INTEGER1 = igp2 = egp3 = incomplete · Integer32
The ultimate origin of the route information.
cbgpRouteASPathSegment
1.3.6.1.4.1.9.9.187.1.1.1.1.8
OCTET STRING SIZE (0..255)
The sequence of AS path segments. Each AS path segment is represented by a triple <type, length, value>.
The type is a 1-octet field which has two possible values:
1 AS_SET: unordered set of ASs a route in the
UPDATE message has traversed
2 AS_SEQUENCE: ordered set of ASs a route in the
UPDATE message has traversed.
The length is a 1-octet field containing the number of ASs in the value field.
The value field contains one or more AS numbers, each AS is represented in the octet string as a pair of octets according to the following algorithm:
first-byte-of-pair = ASNumber / 256; second-byte-of-pair = ASNumber & 255;
cbgpRouteNextHop
1.3.6.1.4.1.9.9.187.1.1.1.1.9
CbgpNetworkAddressRepresents the Network Address prefix carried in the BGP UPDATE messages. In the following table, column 'Type' gives the kind of Network Layer address which will be stored in the object of this type based on the values of Address Family Identifier(AFI) and SAFI.
AFI SAFI Type
ipv4(1) unicast(1) IPv4 address
ipv4(1) multicast(2) IPv4 address
ipv4(1) vpn(128) VPN-IPv4 address
ipv6(2) unicast(1) IPv6 address
ipv6(2) multicast(2) IPv6 address
ipv6(2) vpn(128) VPN-IPv6 address
A VPN-IPv4 address is a 12-byte quantity, beginning with an 8-byte 'Route Distinguisher (RD)' and ending with a 4-byte IPv4 address.
A VPN-IPv6 address is a 24-byte quantity, beginning with an 8-byte 'Route Distinguisher (RD)' and ending with a 16-byte IPv6 address.Reference: RFC 2858, Multiprotocol Extensions for BGP-4. RFC 2547, Section 4.1, BGP/MPLS VPNs. SIZE (0..255) · OCTET STRING
The Network Layer address of the border router that should be used for the destination network.
cbgpRouteMedPresent
1.3.6.1.4.1.9.9.187.1.1.1.1.10
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Indicates the presence/absence of MULTI_EXIT_DISC attribute for the route.
cbgpRouteMultiExitDisc
1.3.6.1.4.1.9.9.187.1.1.1.1.11
Unsigned32
This metric is used to discriminate between multiple exit points to an adjacent autonomous system. The value of this object is irrelevant if the value of of cbgpRouteMedPresent is false(2).
cbgpRouteLocalPrefPresent
1.3.6.1.4.1.9.9.187.1.1.1.1.12
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Indicates the presence/absence of LOCAL_PREF attribute for the route.
cbgpRouteLocalPref
1.3.6.1.4.1.9.9.187.1.1.1.1.13
Unsigned32
The degree of preference calculated by the local BGP4 speaker for the route. The value of this object is irrelevant if the value of cbgpRouteLocalPrefPresent is false(2).
Whether or not the local system has selected a less specific route without selecting a more specific route.
cbgpRouteAggregatorAS
1.3.6.1.4.1.9.9.187.1.1.1.1.15
Unsigned32 (0..65535)
The AS number of the last BGP4 speaker that performed route aggregation. A value of zero (0) indicates the absence of this attribute.
cbgpRouteAggregatorAddrType
1.3.6.1.4.1.9.9.187.1.1.1.1.16
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
Represents the type of Network Layer address stored in cbgpRouteAggregatorAddr.
cbgpRouteAggregatorAddr
1.3.6.1.4.1.9.9.187.1.1.1.1.17
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The Network Layer address of the last BGP4 speaker that performed route aggregation. A value of all zeros indicates the absence of this attribute.
cbgpRouteBest
1.3.6.1.4.1.9.9.187.1.1.1.1.18
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
An indication of whether or not this route was chosen as the best BGP4 route.
cbgpRouteUnknownAttr
1.3.6.1.4.1.9.9.187.1.1.1.1.19
OCTET STRING SIZE (0..255)
Reference: RFC-1771: A Border Gateway Protocol 4 (BGP-4), section 4.3
One or more path attributes not understood by this BGP4 speaker. Size zero (0) indicates the absence of such attribute(s). Octets beyond the maximum size, if any, are not recorded by this object.
Each path attribute is a triple <attribute type, attribute length, attribute value> of variable length. Attribute Type is a two-octet field that consists of the Attribute Flags octet followed by the Attribute Type Code octet. If the Extended Length bit of the Attribute Flags octet is set to 0, the third octet of the Path Attribute contains the length of the attribute data in octets. If the Extended Length bit of the Attribute Flags octet is set to 1, then the third and the fourth octets of the path attribute contain the length of the attribute data in octets. The remaining octets of the Path Attribute represent the attribute value and are interpreted according to the Attribute Flags and the Attribute Type Code.
Number of Route prefixes received on this connnection, which are accepted after applying filters. Possible filters are route maps, prefix lists, distributed lists, etc.
cbgpPeerPrefixDenied
1.3.6.1.4.1.9.9.187.1.2.1.1.2
Counter32
Counter which gets incremented when a route prefix
received on this connection is denied or when a route
prefix is denied during soft reset of this connection if 'soft-reconfiguration' is on . This object is
initialized to zero when the peer is configured or
the router is rebooted
cbgpPeerPrefixLimit
1.3.6.1.4.1.9.9.187.1.2.1.1.3
Unsigned32 (1..4294967295)
Max number of route prefixes accepted on this connection
cbgpPeerPrefixAdvertised
1.3.6.1.4.1.9.9.187.1.2.1.1.4
Counter32
Counter which gets incremented when a route prefix is advertised on this connection. This object is initialized to zero when the peer is configured or the router is rebooted
cbgpPeerPrefixSuppressed
1.3.6.1.4.1.9.9.187.1.2.1.1.5
Counter32
Counter which gets incremented when a route prefix is suppressed from being sent on this connection. This object is initialized to zero when the peer is configured or the router is rebooted
cbgpPeerPrefixWithdrawn
1.3.6.1.4.1.9.9.187.1.2.1.1.6
Counter32
Counter which gets incremented when a route prefix is withdrawn on this connection. This object is initialized to zero when the peer is configured or the router is rebooted
cbgpPeerLastErrorTxt
1.3.6.1.4.1.9.9.187.1.2.1.1.7
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
Implementation specific error description for bgpPeerLastErrorReceived.
Reference: RFC 2842, Capabilities Advertisement with BGP-4.
RFC2818, Route Refresh Capability for BGP-4.
RFC2858, Multiprotocol Extensions for BGP-4.
draft-ietf-idr-restart-05.txt, Graceful Restart Mechanism for BGP
This table contains the capabilities that are supported by a peer. Capabilities of a peer are received during BGP connection establishment. Values corresponding to each received capability are stored in this table. When a new capability is received, this table is updated with a new entry. When an existing capability is not received during the latest connection establishment, the corresponding entry is deleted from the table.
This table contains information related to address families supported by a peer. Supported address families of a peer are known during BGP connection establishment. When a new supported address family is known, this table is updated with a new entry. When an address family is not supported any more, corresponding entry is deleted from the table.
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The AFI index of the entry. An implementation is only required to support IPv4 unicast and VPNv4 (Value - 1) address families.
cbgpPeerAddrFamilySafi
1.3.6.1.4.1.9.9.187.1.2.3.1.2
CbgpSafi1 = unicast2 = multicast3 = unicastAndMulticast128 = vpnSubsequent Address Family Identifier(SAFI) is used by BGP speaker to indicate the type of the the Network Layer Reachability Information(NLRI) being carried. RFC-2858 has defined the following values for SAFI. 1 - Network Layer Reachability Information used for unicast forwarding 2 - Network Layer Reachability Information used for multicast forwarding 3 - Network Layer Reachability Information used for both unicast and multicast forwarding. SAFI values 128 through 255 are for private use.Reference: RFC-2858: Multiprotocol Extensions for BGP-4, RFC-2547: BGP/MPLS VPNs · Integer32
Reference: RFC-2858: Multiprotocol Extensions for BGP-4, RFC-2547: BGP/MPLS VPNs
The SAFI index of the entry. An implementation is only required to support IPv4 unicast(Value - 1) and VPNv4( Value - 128) address families.
cbgpPeerAddrFamilyName
1.3.6.1.4.1.9.9.187.1.2.3.1.3
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This table contains prefix related information related to address families supported by a peer. Supported address families of a peer are known during BGP connection establishment. When a new supported address family is known, this table is updated with a new entry. When an address family is not supported any more, corresponding entry is deleted from the table.
Number of accepted route prefixes on this connection, which belong to an address family.
cbgpPeerDeniedPrefixes
1.3.6.1.4.1.9.9.187.1.2.4.1.2
Gauge32
This counter is incremented when a route prefix, which belongs to an address family, received on this connection is denied. It is initialized to zero when the connection is undergone a hard reset.
cbgpPeerPrefixAdminLimit
1.3.6.1.4.1.9.9.187.1.2.4.1.3
Unsigned32 (1..4294967295)
Max number of route prefixes accepted for an address family on this connection.
cbgpPeerPrefixThreshold
1.3.6.1.4.1.9.9.187.1.2.4.1.4
Unsigned32 (1..100)
Prefix threshold value (%) for an address family on this connection at which warning message stating the prefix count is crossed the threshold or corresponding SNMP notification is generated.
cbgpPeerPrefixClearThreshold
1.3.6.1.4.1.9.9.187.1.2.4.1.5
Unsigned32 (1..100)
Prefix threshold value (%) for an address family on this connection at which SNMP clear notification is generated if prefix threshold notification is already generated.
cbgpPeerAdvertisedPrefixes
1.3.6.1.4.1.9.9.187.1.2.4.1.6
Gauge32
This counter is incremented when a route prefix, which belongs to an address family is advertised on this connection. It is initialized to zero when the connection is undergone a hard reset.
cbgpPeerSuppressedPrefixes
1.3.6.1.4.1.9.9.187.1.2.4.1.7
Gauge32
This counter is incremented when a route prefix, which belongs to an address family is suppressed from being sent on this connection. It is initialized to zero when the connection is undergone a hard reset.
cbgpPeerWithdrawnPrefixes
1.3.6.1.4.1.9.9.187.1.2.4.1.8
Gauge32
This counter is incremented when a route prefix, which belongs to an address family, is withdrawn on this connection. It is initialized to zero when the connection is undergone a hard reset.
cbgpPeer2Table
1.3.6.1.4.1.9.9.187.1.2.5
Index: cbgpPeer2Type · cbgpPeer2RemoteAddr
BGP peer table. This table contains, one entry per BGP peer, information about the connections with BGP peers.
cbgpPeer2Type
1.3.6.1.4.1.9.9.187.1.2.5.1.1
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
Represents the type of Peer address stored in cbgpPeer2Entry.
cbgpPeer2RemoteAddr
1.3.6.1.4.1.9.9.187.1.2.5.1.2
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The desired state of the BGP connection. A transition from 'stop' to 'start' will cause the BGP Manual Start Event to be generated. A transition from 'start' to 'stop' will cause the BGP Manual Stop Event to be generated. This parameter can be used to restart BGP peer connections. Care should be used in providing write access to this object without adequate authentication.
The negotiated version of BGP running between the two peers.
This entry MUST be zero (0) unless the cbgpPeer2State is in the openconfirm or the established state.
Note that legal values for this object are between 0 and 255.
cbgpPeer2LocalAddr
1.3.6.1.4.1.9.9.187.1.2.5.1.6
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The local IP address of this entry's BGP connection.
cbgpPeer2LocalPort
1.3.6.1.4.1.9.9.187.1.2.5.1.7
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
The local port for the TCP connection between the BGP peers.
cbgpPeer2LocalAs
1.3.6.1.4.1.9.9.187.1.2.5.1.8
InetAutonomousSystemNumberRepresents an autonomous system number that identifies an Autonomous System (AS). An AS is a set of routers under a single technical administration, using an interior gateway protocol and common metrics to route packets within the AS, and using an exterior gateway protocol to route packets to other ASes'. IANA maintains the AS number space and has delegated large parts to the regional registries.
Autonomous system numbers are currently limited to 16 bits (0..65535). There is, however, work in progress to enlarge the autonomous system number space to 32 bits. Therefore, this textual convention uses an Unsigned32 value without a range restriction in order to support a larger autonomous system number space.Reference: RFC 1771, RFC 1930 · Unsigned32 · hint d
The local AS number for this session.
cbgpPeer2LocalIdentifier
1.3.6.1.4.1.9.9.187.1.2.5.1.9
IpAddress SIZE (4)
The BGP Identifier of this entry's BGP peer.
cbgpPeer2RemotePort
1.3.6.1.4.1.9.9.187.1.2.5.1.10
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
The remote port for the TCP connection between the BGP peers. Note that the objects cbgpPeer2LocalAddr, cbgpPeer2LocalPort, cbgpPeer2RemoteAddr, and cbgpPeer2RemotePort provide the appropriate reference to the standard MIB TCP connection table.
cbgpPeer2RemoteAs
1.3.6.1.4.1.9.9.187.1.2.5.1.11
InetAutonomousSystemNumberRepresents an autonomous system number that identifies an Autonomous System (AS). An AS is a set of routers under a single technical administration, using an interior gateway protocol and common metrics to route packets within the AS, and using an exterior gateway protocol to route packets to other ASes'. IANA maintains the AS number space and has delegated large parts to the regional registries.
Autonomous system numbers are currently limited to 16 bits (0..65535). There is, however, work in progress to enlarge the autonomous system number space to 32 bits. Therefore, this textual convention uses an Unsigned32 value without a range restriction in order to support a larger autonomous system number space.Reference: RFC 1771, RFC 1930 · Unsigned32 · hint d
Reference: RFC 4271, Section 4.2.
The remote autonomous system number received in the BGP OPEN message.
The BGP Identifier of this entry's BGP peer. This entry MUST be 0.0.0.0 unless the cbgpPeer2State is in the openconfirm or the established state.
cbgpPeer2InUpdates
1.3.6.1.4.1.9.9.187.1.2.5.1.13
Counter32
Reference: RFC 4271, Section 4.3.
The number of BGP UPDATE messages received on this connection.
cbgpPeer2OutUpdates
1.3.6.1.4.1.9.9.187.1.2.5.1.14
Counter32
Reference: RFC 4271, Section 4.3.
The number of BGP UPDATE messages transmitted on this connection.
cbgpPeer2InTotalMessages
1.3.6.1.4.1.9.9.187.1.2.5.1.15
Counter32
Reference: RFC 4271, Section 4.
The total number of messages received from the remote peer on this connection.
cbgpPeer2OutTotalMessages
1.3.6.1.4.1.9.9.187.1.2.5.1.16
Counter32
Reference: RFC 4271, Section 4.
The total number of messages transmitted to the remote peer on this connection.
cbgpPeer2LastError
1.3.6.1.4.1.9.9.187.1.2.5.1.17
OCTET STRING SIZE (2)
Reference: RFC 4271, Section 4.5.
The last error code and subcode seen by this peer on this connection. If no error has occurred, this field is zero. Otherwise, the first byte of this two byte OCTET STRING contains the error code, and the second byte contains the subcode.
cbgpPeer2FsmEstablishedTransitions
1.3.6.1.4.1.9.9.187.1.2.5.1.18
Counter32
Reference: RFC 4271, Section 8.
The total number of times the BGP FSM transitioned into the established state for this peer.
cbgpPeer2FsmEstablishedTime
1.3.6.1.4.1.9.9.187.1.2.5.1.19
Gauge32 · seconds
Reference: RFC 4271, Section 8.
This timer indicates how long (in seconds) this peer has been in the established state or how long since this peer was last in the established state. It is set to zero when a new peer is configured or when the router is booted.
cbgpPeer2ConnectRetryInterval
1.3.6.1.4.1.9.9.187.1.2.5.1.20
Integer32 (1..65535) · seconds
Reference: RFC 4271, Section 8.2.2. This is the value used to initialize the 'ConnectRetryTimer'.
Time interval (in seconds) for the ConnectRetry timer. The suggested value for this timer is 120 seconds.
cbgpPeer2HoldTime
1.3.6.1.4.1.9.9.187.1.2.5.1.21
Integer32 (0 | 3..65535) · seconds
Reference: RFC 4271, Section 4.2.
Time interval (in seconds) for the Hold Timer established with the peer. The value of this object is calculated by this BGP speaker, using the smaller of the values in cbgpPeer2HoldTimeConfigured and the Hold Time received in the OPEN message.
This value must be at least three seconds if it is not zero (0).
If the Hold Timer has not been established with the peer this object MUST have a value of zero (0).
If the cbgpPeer2HoldTimeConfigured object has a value of (0), then this object MUST have a value of (0).
cbgpPeer2KeepAlive
1.3.6.1.4.1.9.9.187.1.2.5.1.22
Integer32 (0 | 1..21845) · seconds
Reference: RFC 4271, Section 4.4.
Time interval (in seconds) for the KeepAlive timer established with the peer. The value of this object is calculated by this BGP speaker such that, when compared with cbgpPeer2HoldTime, it has the same proportion that cbgpPeer2KeepAliveConfigured has, compared with cbgpPeer2HoldTimeConfigured.
If the KeepAlive timer has not been established with the peer, this object MUST have a value of zero (0).
If the of cbgpPeer2KeepAliveConfigured object has a value of (0), then this object MUST have a value of (0).
Time interval (in seconds) for the Hold Time configured for this BGP speaker with this peer. This value is placed in an OPEN message sent to this peer by this BGP speaker, and is compared with the Hold Time field in an OPEN message received from the peer when determining the Hold Time (cbgpPeer2HoldTime) with the peer. This value must not be less than three seconds if it is not zero (0). If it is zero (0), the Hold Time is NOT to be established with the peer. The suggested value for this timer is 90 seconds.
Time interval (in seconds) for the KeepAlive timer configured for this BGP speaker with this peer. The value of this object will only determine the KEEPALIVE messages' frequency relative to the value specified in cbgpPeer2HoldTimeConfigured; the actual time interval for the KEEPALIVE messages is indicated by cbgpPeer2KeepAlive. A reasonable maximum value for this timer would be one third of that of cbgpPeer2HoldTimeConfigured. If the value of this object is zero (0), no periodical KEEPALIVE messages are sent to the peer after the BGP connection has been established. The suggested value for this timer is 30 seconds.
Time interval (in seconds) for the MinRouteAdvertisementInterval timer. The suggested value for this timer is 30 seconds for EBGP connections and 5 seconds for IBGP connections.
Elapsed time (in seconds) since the last BGP UPDATE message was received from the peer. Each time cbgpPeer2InUpdates is incremented, the value of this object is set to zero (0).
cbgpPeer2LastErrorTxt
1.3.6.1.4.1.9.9.187.1.2.5.1.28
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
Implementation specific error description for bgpPeerLastErrorReceived.
Reference: RFC 2842, Capabilities Advertisement with BGP-4. RFC 2818, Route Refresh Capability for BGP-4. RFC 2858, Multiprotocol Extensions for BGP-4. RFC 4724, Graceful Restart Mechanism for BGP. RFC 4893, BGP Support for Four-octet AS Number Space. draft-ietf-idr-add-paths-04.txt, Advertisement of Multiple Paths in BGP.
This table contains the capabilities that are supported by a peer. Capabilities of a peer are received during BGP connection establishment. Values corresponding to each received capability are stored in this table. When a new capability is received, this table is updated with a new entry. When an existing capability is not received during the latest connection establishment, the corresponding entry is deleted from the table.
Reference: RFC 2842, Capabilities Advertisement with BGP-4. RFC 2818, Route Refresh Capability for BGP-4. RFC 2858, Multiprotocol Extensions for BGP-4. RFC 4724, Graceful Restart Mechanism for BGP. RFC 4893, BGP Support for Four-octet AS Number Space. draft-ietf-idr-add-paths-04.txt, Advertisement of Multiple Paths in BGP.
The BGP Capability Advertisement Capability Code.
cbgpPeer2CapIndex
1.3.6.1.4.1.9.9.187.1.2.6.1.2
Unsigned32 (1..128)
Multiple instances of a given capability may be sent by a BGP speaker. This variable is used to index them.
cbgpPeer2CapValue
1.3.6.1.4.1.9.9.187.1.2.6.1.3
OCTET STRING SIZE (0..255)
Reference: RFC 2842, Capabilities Advertisement with BGP-4. RFC 2818, Route Refresh Capability for BGP-4. RFC 2858, Multiprotocol Extensions for BGP-4. RFC 4724, Graceful Restart Mechanism for BGP. RFC 4893, BGP Support for Four-octet AS Number Space. draft-ietf-idr-add-paths-04.txt, Advertisement of Multiple Paths in BGP.
The value of the announced capability. This MIB object value is organized as given below, Capability : Route Refresh Capability 4-Byte AS Capability Null string Capability : Multiprotocol Extensions +----------------------------------+
| AFI(16 bits) |
+----------------------------------+
| SAFI (8 bits) |
+----------------------------------+ Capability : Graceful Restart +----------------------------------+
| Restart Flags (4 bits) |
+----------------------------------+ | Restart Time in seconds (12 bits)| +----------------------------------+
| AFI(16 bits) |
+----------------------------------+
| SAFI (8 bits) |
+----------------------------------+ | Flags for Address Family (8 bits)| +----------------------------------+ | ... | +----------------------------------+
| AFI(16 bits) |
+----------------------------------+
| SAFI (8 bits) |
+----------------------------------+ | Flags for Address Family (8 bits)| +----------------------------------+ Capability : Additional Paths +----------------------------------+
| AFI(16 bits) |
+----------------------------------+
| SAFI (8 bits) |
+----------------------------------+
| Send/Receive (8 bits) |
+----------------------------------+
This table contains information related to address families supported by a peer. Supported address families of a peer are known during BGP connection establishment. When a new supported address family is known, this table is updated with a new entry. When an address family is not supported any more, corresponding entry is deleted from the table.
cbgpPeer2AddrFamilyAfi
1.3.6.1.4.1.9.9.187.1.2.7.1.1
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The AFI index of the entry. An implementation is only required to support IPv4 unicast and VPNv4 (Value - 1) address families.
cbgpPeer2AddrFamilySafi
1.3.6.1.4.1.9.9.187.1.2.7.1.2
CbgpSafi1 = unicast2 = multicast3 = unicastAndMulticast128 = vpnSubsequent Address Family Identifier(SAFI) is used by BGP speaker to indicate the type of the the Network Layer Reachability Information(NLRI) being carried. RFC-2858 has defined the following values for SAFI. 1 - Network Layer Reachability Information used for unicast forwarding 2 - Network Layer Reachability Information used for multicast forwarding 3 - Network Layer Reachability Information used for both unicast and multicast forwarding. SAFI values 128 through 255 are for private use.Reference: RFC-2858: Multiprotocol Extensions for BGP-4, RFC-2547: BGP/MPLS VPNs · Integer32
The SAFI index of the entry. An implementation is only required to support IPv4 unicast(Value - 1) and VPNv4( Value - 128) address families.
cbgpPeer2AddrFamilyName
1.3.6.1.4.1.9.9.187.1.2.7.1.3
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This table contains prefix related information related to address families supported by a peer. Supported address families of a peer are known during BGP connection establishment. When a new supported address family is known, this table is updated with a new entry. When an address family is not supported any more, corresponding entry is deleted from the table.
cbgpPeer2AcceptedPrefixes
1.3.6.1.4.1.9.9.187.1.2.8.1.1
Counter32
Number of accepted route prefixes on this connection, which belong to an address family.
cbgpPeer2DeniedPrefixes
1.3.6.1.4.1.9.9.187.1.2.8.1.2
Gauge32
This counter is incremented when a route prefix, which belongs to an address family, received on this connection is denied. It is initialized to zero when the connection is undergone a hard reset.
cbgpPeer2PrefixAdminLimit
1.3.6.1.4.1.9.9.187.1.2.8.1.3
Unsigned32 (1..4294967295)
Max number of route prefixes accepted for an address family on this connection.
cbgpPeer2PrefixThreshold
1.3.6.1.4.1.9.9.187.1.2.8.1.4
Unsigned32 (1..100) · percent
Prefix threshold value (%) for an address family on this connection at which warning message stating the prefix count is crossed the threshold or corresponding SNMP notification is generated.
cbgpPeer2PrefixClearThreshold
1.3.6.1.4.1.9.9.187.1.2.8.1.5
Unsigned32 (1..100) · percent
Prefix threshold value (%) for an address family on this connection at which SNMP clear notification is generated if prefix threshold notification is already generated.
cbgpPeer2AdvertisedPrefixes
1.3.6.1.4.1.9.9.187.1.2.8.1.6
Gauge32
This counter is incremented when a route prefix, which belongs to an address family is advertised on this connection. It is initialized to zero when the connection is undergone a hard reset.
cbgpPeer2SuppressedPrefixes
1.3.6.1.4.1.9.9.187.1.2.8.1.7
Gauge32
This counter is incremented when a route prefix, which belongs to an address family is suppressed from being sent on this connection. It is initialized to zero when the connection is undergone a hard reset.
cbgpPeer2WithdrawnPrefixes
1.3.6.1.4.1.9.9.187.1.2.8.1.8
Gauge32
This counter is incremented when a route prefix, which belongs to an address family, is withdrawn on this connection. It is initialized to zero when the connection is undergone a hard reset.
BGP peer table. This table contains, one entry per BGP peer, information about the connections with BGP peers on per vrf basis
cbgpPeer3VrfId
1.3.6.1.4.1.9.9.187.1.2.9.1.1
Unsigned32 (0..65535)
id of the vrf that peer is configured in.
cbgpPeer3Type
1.3.6.1.4.1.9.9.187.1.2.9.1.2
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
Represents the type of Peer address stored in cbgpPeer3Entry.
cbgpPeer3RemoteAddr
1.3.6.1.4.1.9.9.187.1.2.9.1.3
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The remote IP address of this entry's BGP peer.
cbgpPeer3VrfName
1.3.6.1.4.1.9.9.187.1.2.9.1.4
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..32) · OCTET STRING · hint 255t
The desired state of the BGP connection. A transition from 'stop' to 'start' will cause the BGP Manual Start Event to be generated. A transition from 'start' to 'stop' will cause the BGP Manual Stop Event to be generated. This parameter can be used to restart BGP peer connections. Care should be used in providing write access to this object without adequate authentication.
The negotiated version of BGP running between the two peers.
This entry MUST be zero (0) unless the cbgpPeer3State is in the openconfirm or the established state.
Note that legal values for this object are between 0 and 255.
cbgpPeer3LocalAddr
1.3.6.1.4.1.9.9.187.1.2.9.1.8
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The local IP address of this entry's BGP connection.
cbgpPeer3LocalPort
1.3.6.1.4.1.9.9.187.1.2.9.1.9
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
The local port for the TCP connection between the BGP peers.
cbgpPeer3LocalAs
1.3.6.1.4.1.9.9.187.1.2.9.1.10
InetAutonomousSystemNumberRepresents an autonomous system number that identifies an Autonomous System (AS). An AS is a set of routers under a single technical administration, using an interior gateway protocol and common metrics to route packets within the AS, and using an exterior gateway protocol to route packets to other ASes'. IANA maintains the AS number space and has delegated large parts to the regional registries.
Autonomous system numbers are currently limited to 16 bits (0..65535). There is, however, work in progress to enlarge the autonomous system number space to 32 bits. Therefore, this textual convention uses an Unsigned32 value without a range restriction in order to support a larger autonomous system number space.Reference: RFC 1771, RFC 1930 · Unsigned32 · hint d
The local AS number for this session.
cbgpPeer3LocalIdentifier
1.3.6.1.4.1.9.9.187.1.2.9.1.11
IpAddress SIZE (4)
The BGP Identifier of this entry's BGP peer.
cbgpPeer3RemotePort
1.3.6.1.4.1.9.9.187.1.2.9.1.12
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
The remote port for the TCP connection between the BGP peers. Note that the objects cbgpPeer3LocalAddr, cbgpPeer3LocalPort, cbgpPeer3RemoteAddr, and cbgpPeer3RemotePort provide the appropriate reference to the standard MIB TCP connection table.
cbgpPeer3RemoteAs
1.3.6.1.4.1.9.9.187.1.2.9.1.13
InetAutonomousSystemNumberRepresents an autonomous system number that identifies an Autonomous System (AS). An AS is a set of routers under a single technical administration, using an interior gateway protocol and common metrics to route packets within the AS, and using an exterior gateway protocol to route packets to other ASes'. IANA maintains the AS number space and has delegated large parts to the regional registries.
Autonomous system numbers are currently limited to 16 bits (0..65535). There is, however, work in progress to enlarge the autonomous system number space to 32 bits. Therefore, this textual convention uses an Unsigned32 value without a range restriction in order to support a larger autonomous system number space.Reference: RFC 1771, RFC 1930 · Unsigned32 · hint d
Reference: RFC 4271, Section 4.2.
The remote autonomous system number received in the BGP OPEN message.
The BGP Identifier of this entry's BGP peer. This entry MUST be 0.0.0.0 unless the cbgpPeer3State is in the openconfirm or the established state.
cbgpPeer3InUpdates
1.3.6.1.4.1.9.9.187.1.2.9.1.15
Counter32
Reference: RFC 4271, Section 4.3.
The number of BGP UPDATE messages received on this connection.
cbgpPeer3OutUpdates
1.3.6.1.4.1.9.9.187.1.2.9.1.16
Counter32
Reference: RFC 4271, Section 4.3.
The number of BGP UPDATE messages transmitted on this connection.
cbgpPeer3InTotalMessages
1.3.6.1.4.1.9.9.187.1.2.9.1.17
Counter32
Reference: RFC 4271, Section 4.
The total number of messages received from the remote peer on this connection.
cbgpPeer3OutTotalMessages
1.3.6.1.4.1.9.9.187.1.2.9.1.18
Counter32
Reference: RFC 4271, Section 4.
The total number of messages transmitted to the remote peer on this connection.
cbgpPeer3LastError
1.3.6.1.4.1.9.9.187.1.2.9.1.19
OCTET STRING SIZE (2)
Reference: RFC 4271, Section 4.5.
The last error code and subcode seen by this peer on this connection. If no error has occurred, this field is zero. Otherwise, the first byte of this two byte OCTET STRING contains the error code, and the second byte contains the subcode.
cbgpPeer3FsmEstablishedTransitions
1.3.6.1.4.1.9.9.187.1.2.9.1.20
Counter32
Reference: RFC 4271, Section 8.
The total number of times the BGP FSM transitioned into the established state for this peer.
cbgpPeer3FsmEstablishedTime
1.3.6.1.4.1.9.9.187.1.2.9.1.21
Gauge32 · seconds
Reference: RFC 4271, Section 8.
This timer indicates how long (in seconds) this peer has been in the established state or how long since this peer was last in the established state. It is set to zero when a new peer is configured or when the router is booted.
cbgpPeer3ConnectRetryInterval
1.3.6.1.4.1.9.9.187.1.2.9.1.22
Integer32 (1..65535) · seconds
Reference: RFC 4271, Section 8.2.2. This is the value used to initialize the 'ConnectRetryTimer'.
Time interval (in seconds) for the ConnectRetry timer. The suggested value for this timer is 120 seconds.
cbgpPeer3HoldTime
1.3.6.1.4.1.9.9.187.1.2.9.1.23
Integer32 (0 | 3..65535) · seconds
Reference: RFC 4271, Section 4.2.
Time interval (in seconds) for the Hold Timer established with the peer. The value of this object is calculated by this BGP speaker, using the smaller of the values in cbgpPeer3HoldTimeConfigured and the Hold Time received in the OPEN message.
This value must be at least three seconds if it is not zero (0).
If the Hold Timer has not been established with the peer this object MUST have a value of zero (0).
If the cbgpPeer3HoldTimeConfigured object has a value of (0), then this object MUST have a value of (0).
cbgpPeer3KeepAlive
1.3.6.1.4.1.9.9.187.1.2.9.1.24
Integer32 (0 | 1..21845) · seconds
Reference: RFC 4271, Section 4.4.
Time interval (in seconds) for the KeepAlive timer established with the peer. The value of this object is calculated by this BGP speaker such that, when compared with cbgpPeer3HoldTime, it has the same proportion that cbgpPeer3KeepAliveConfigured has, compared with cbgpPeer3HoldTimeConfigured.
If the KeepAlive timer has not been established with the peer, this object MUST have a value of zero (0).
If the of cbgpPeer3KeepAliveConfigured object has a value of (0), then this object MUST have a value of (0).
Time interval (in seconds) for the Hold Time configured for this BGP speaker with this peer. This value is placed in an OPEN message sent to this peer by this BGP speaker, and is compared with the Hold Time field in an OPEN message received from the peer when determining the Hold Time (cbgpPeer3HoldTime) with the peer. This value must not be less than three seconds if it is not zero (0). If it is zero (0), the Hold Time is NOT to be established with the peer. The suggested value for this timer is 90 seconds.
Time interval (in seconds) for the KeepAlive timer configured for this BGP speaker with this peer. The value of this object will only determine the KEEPALIVE messages' frequency relative to the value specified in cbgpPeer3HoldTimeConfigured; the actual time interval for the KEEPALIVE messages is indicated by cbgpPeer3KeepAlive. A reasonable maximum value for this timer would be one third of that of cbgpPeer3HoldTimeConfigured. If the value of this object is zero (0), no periodical KEEPALIVE messages are sent to the peer after the BGP connection has been established. The suggested value for this timer is 30 seconds.
Time interval (in seconds) for the MinRouteAdvertisementInterval timer. The suggested value for this timer is 30 seconds for EBGP connections and 5 seconds for IBGP connections.
Elapsed time (in seconds) since the last BGP UPDATE message was received from the peer. Each time cbgpPeer3InUpdates is incremented, the value of this object is set to zero (0).
cbgpPeer3LastErrorTxt
1.3.6.1.4.1.9.9.187.1.2.9.1.30
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
Implementation specific error description for bgpPeerLastErrorReceived.
The BGP cbgpFsmStateChange notification is generated for every BGP FSM state change. The bgpPeerRemoteAddr value is attached to the notification object ID.
bgpPeerLastError
1.3.6.1.2.1.15.3.1.14
OCTET STRING SIZE (2)
The last error code and subcode seen by this peer on this connection. If no error has occurred, this field is zero. Otherwise, the first byte of this two byte OCTET STRING contains the error code, and the second byte contains the subcode.
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
Implementation specific error description for bgpPeerLastErrorReceived.
The cbgpBackwardTransition Event is generated when the BGP FSM moves from a higher numbered state to a lower numbered state. The bgpPeerRemoteAddr value is attached to the notification object ID.
bgpPeerLastError
1.3.6.1.2.1.15.3.1.14
OCTET STRING SIZE (2)
The last error code and subcode seen by this peer on this connection. If no error has occurred, this field is zero. Otherwise, the first byte of this two byte OCTET STRING contains the error code, and the second byte contains the subcode.
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
Implementation specific error description for bgpPeerLastErrorReceived.
The cbgpPrefixThresholdExceeded notification is generated when prefix count exceeds the configured warning threshold on a session for an address family. The bgpPeerRemoteAddr, cbgpPeerAddrFamilyAfi and cbgpPeerAddrFamilySafi values are attached to the notification object ID.
cbgpPeerPrefixAdminLimit
1.3.6.1.4.1.9.9.187.1.2.4.1.3
Unsigned32 (1..4294967295)
Max number of route prefixes accepted for an address family on this connection.
cbgpPeerPrefixThreshold
1.3.6.1.4.1.9.9.187.1.2.4.1.4
Unsigned32 (1..100)
Prefix threshold value (%) for an address family on this connection at which warning message stating the prefix count is crossed the threshold or corresponding SNMP notification is generated.
cbgpPrefixThresholdClear
1.3.6.1.4.1.9.9.187.0.4
The cbgpPrefixThresholdClear notification is generated when prefix count drops below the configured clear threshold on a session for an address family once cbgpPrefixThresholdExceeded is generated. This won't be generated if the peer session goes down after the generation of cbgpPrefixThresholdExceeded. The bgpPeerRemoteAddr, cbgpPeerAddrFamilyAfi and cbgpPeerAddrFamilySafi values are attached to the notification object ID.
cbgpPeerPrefixAdminLimit
1.3.6.1.4.1.9.9.187.1.2.4.1.3
Unsigned32 (1..4294967295)
Max number of route prefixes accepted for an address family on this connection.
cbgpPeerPrefixClearThreshold
1.3.6.1.4.1.9.9.187.1.2.4.1.5
Unsigned32 (1..100)
Prefix threshold value (%) for an address family on this connection at which SNMP clear notification is generated if prefix threshold notification is already generated.
cbgpPeer2EstablishedNotification
1.3.6.1.4.1.9.9.187.0.5
The cbgpPeer2EstablishedNotification notification is generated when the BGP FSM enters the established state.
cbgpPeer2LastError
1.3.6.1.4.1.9.9.187.1.2.5.1.17
OCTET STRING SIZE (2)
Reference: RFC 4271, Section 4.5.
The last error code and subcode seen by this peer on this connection. If no error has occurred, this field is zero. Otherwise, the first byte of this two byte OCTET STRING contains the error code, and the second byte contains the subcode.
The cbgpPeer2BackwardTransNotification notification is generated when the BGP FSM moves from a higher numbered state to a lower numbered state.
cbgpPeer2LastError
1.3.6.1.4.1.9.9.187.1.2.5.1.17
OCTET STRING SIZE (2)
Reference: RFC 4271, Section 4.5.
The last error code and subcode seen by this peer on this connection. If no error has occurred, this field is zero. Otherwise, the first byte of this two byte OCTET STRING contains the error code, and the second byte contains the subcode.
The cbgpPeer2FsmStateChange notification is generated for every BGP FSM state change.
cbgpPeer2LastError
1.3.6.1.4.1.9.9.187.1.2.5.1.17
OCTET STRING SIZE (2)
Reference: RFC 4271, Section 4.5.
The last error code and subcode seen by this peer on this connection. If no error has occurred, this field is zero. Otherwise, the first byte of this two byte OCTET STRING contains the error code, and the second byte contains the subcode.
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
Implementation specific error description for bgpPeerLastErrorReceived.
The cbgpPeer2BackwardTransition notification is generated when the BGP FSM moves from a higher numbered state to a lower numbered state.
cbgpPeer2LastError
1.3.6.1.4.1.9.9.187.1.2.5.1.17
OCTET STRING SIZE (2)
Reference: RFC 4271, Section 4.5.
The last error code and subcode seen by this peer on this connection. If no error has occurred, this field is zero. Otherwise, the first byte of this two byte OCTET STRING contains the error code, and the second byte contains the subcode.
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
Implementation specific error description for bgpPeerLastErrorReceived.
The cbgpPeer2PrefixThresholdExceeded notification is generated when prefix count exceeds the configured warning threshold on a session for an address family.
cbgpPeer2PrefixAdminLimit
1.3.6.1.4.1.9.9.187.1.2.8.1.3
Unsigned32 (1..4294967295)
Max number of route prefixes accepted for an address family on this connection.
cbgpPeer2PrefixThreshold
1.3.6.1.4.1.9.9.187.1.2.8.1.4
Unsigned32 (1..100) · percent
Prefix threshold value (%) for an address family on this connection at which warning message stating the prefix count is crossed the threshold or corresponding SNMP notification is generated.
cbgpPeer2PrefixThresholdClear
1.3.6.1.4.1.9.9.187.0.10
The cbgpPeer2PrefixThresholdClear notification is generated when prefix count drops below the configured clear threshold on a session for an address family once cbgpPeer2PrefixThresholdExceeded is generated. This will not be generated if the peer session goes down after the generation of cbgpPrefixThresholdExceeded.
cbgpPeer2PrefixAdminLimit
1.3.6.1.4.1.9.9.187.1.2.8.1.3
Unsigned32 (1..4294967295)
Max number of route prefixes accepted for an address family on this connection.
cbgpPeer2PrefixClearThreshold
1.3.6.1.4.1.9.9.187.1.2.8.1.5
Unsigned32 (1..100) · percent
Prefix threshold value (%) for an address family on this connection at which SNMP clear notification is generated if prefix threshold notification is already generated.