c2900InfoBoardRevision
1.3.6.1.4.1.9.9.87.1.1.1
Gauge32
Returns the revision number of the main board on which the FastSwitch firmware resides.
2002-05-30
The MIB module for Catalyst 2900 enterprise specific information
Download CISCO-C2900-MIB.txt Open CISCO-C2900-MIB.txt in a new tab
SCALARS (17) · TABLES (4) · TRAPS (3)
| Name | OID |
|---|---|
| c2900ModuleTable | 1.3.6.1.4.1.9.9.87.1.3 |
| c2900PortTable | 1.3.6.1.4.1.9.9.87.1.4.1 |
| c2900PortStatsTable | 1.3.6.1.4.1.9.9.87.1.4.2 |
| c2900BandwidthUsagePeakTable | 1.3.6.1.4.1.9.9.87.1.5.6 |
| Name | OID |
|---|---|
| c2900AddressViolation | 1.3.6.1.4.1.9.9.87.2.0.1 |
| c2900BroadcastStorm | 1.3.6.1.4.1.9.9.87.2.0.2 |
| c2900RpsFailed | 1.3.6.1.4.1.9.9.87.2.0.3 |
END OF TOC
1.3.6.1.4.1.9.9.87.1.1.1
Gauge32
Returns the revision number of the main board on which the FastSwitch firmware resides.
1.3.6.1.4.1.9.9.87.1.1.2
Gauge32 · buffers
The maximum number of 64-byte buffers used in the main switch buffer pool.
1.3.6.1.4.1.9.9.87.1.1.3
Gauge32 · buffers
It represents the total number of 64-byte buffers in the Ethernet Controller.
1.3.6.1.4.1.9.9.87.1.1.4
Gauge32
The system-wide maximum number of MAC addresses supported in the address table, a primary resource when forwarding frames through a bridge. The address table is dynamically updated with new learned addresses inserted and aged addresses removed. The address capacity represented by this object includes dynamic, secure, and static address types. To ensure optimal performance, the number of MAC addresses in the bridged local area network to which this bridge is connected should be less than the value of this object. The system administrator can refer to this object for the number of MAC addresses suppored by this box.
1.3.6.1.4.1.9.9.87.1.1.5
Gauge32
Reference: IEEE 802.1D-1990: Section 6.7.2
The system-wide maximum number of static addresses supported. A static address is one that has explicit source port filtering information assigned. This number limits the static table's entries configured by user.
1.3.6.1.4.1.9.9.87.1.1.6
OCTET STRING SIZE (8)
A bit array where the presence of a particular bit indicates a failure of a specific Power On Self Test. Bit 0 - System Board Failure Bit 1 - CPU Buffer Failure Bit 2 - Notify RAM Failure Bit 3 - Supervisor ASIC Failure Bit 4 - Data Buffer Failure Bit 5 - Buffer Table Failure Bit 6 - Satellite ASIC Failure Bit 7 - Front End Failure
1.3.6.1.4.1.9.9.87.1.1.7
Gauge32
The number of utilization meter LEDs currently lit on the front panel, if the value of c2900InfoVisualIndicatorMode is selected as utilization(4). More LEDs are lit as more total bandwidth through the switch is being utilized. The percentage of the utilization is calculated as follows: the number of LEDs lit/the total number of LEDs. The total number of the LEDs is twenty four for c2900 switch. c2900InfoVisualIndicatorMode is utilization(4). If the value of c2900InfoVisualIndicatorMode is not utilization(4), the value of the object will be zero.
1.3.6.1.4.1.9.9.87.1.1.8
INTEGER1 = portStatus2 = fullDuplex3 = linkRate4 = utilization · Integer32
This object reflects what is currently selected as the visual indication mode, selected by the mode button. The portStatus(1) mode uses the visual LEDS to indicate port link status. The fullDuplex(2) mode uses the visual LEDS to indicate that a port is running with full duplex or half duplex or no link status. The linkRate(3) mode uses the visual LEDS to indicate the rate of operation on a port: 100 MBPS or 10 MBPS or no link. The utilization(4) mode uses the visual LEDS to indicate the utiliztion of the system as more total bandwidth through the switch is being utilized, more LED's are lit.
1.3.6.1.4.1.9.9.87.1.1.9
INTEGER1 = absent2 = connectedFunctional3 = connectedNotFunctional4 = functionalPrimaryFailed · Integer32
The switch allows a redundant power supply in addition to its local power supply. Only one power source can be supplying power to a unit. absent(1) :the redundant power supply is not connected to the switch. connectedFunctional(2) : the redundant power supply is connected to the switch and operational. connectedNotFunctional(3): the redundant power supply is connected to the switch, but cannot supply power to the system. functionalPrimaryFailed(4): the redundant power supply is installed, powered on, and operational, but a failure exists in the local power supply system.
1.3.6.1.4.1.9.9.87.1.1.10
Gauge32
Returns the identifier of the main board on which the FastSwitch firmware resides.
1.3.6.1.4.1.9.9.87.1.2.1
INTEGER1 = doNothing2 = disablePort3 = sendNotify4 = disablePortAndNotify · Integer32
Indicates what action to take when an address violation (an address mismatch or duplication) occurs on a secure port. The default action is to do nothing. doNothing(1) : do nothing disablePort(2) : disable port; the port can only be reenabled by an explicit management action. sendNotify(3) : generate address violation notification. disablePortAndNotify(4): disable port and send notification. Default value: doNothing(1). This object is deprecated. A separate object c2900PortAddressViolationAction is defined for each port.
1.3.6.1.4.1.9.9.87.1.2.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
When set to true(1), the switch will generate a broadcastStorm notification upon detecting a port is receiving broadcast packets at a rate higher than or equal to the specified broadcast threshold. When set to false(2), no such trap will be issued. Default value: false(2). This object is deprecated. A separate object c2900PortBroadcastStormAlarm is defined for each port.
1.3.6.1.4.1.9.9.87.1.5.1
Gauge32 · megabits per second
The current bandwidth consumed. The measurement unit is in megabits per second (1,000,000 bits/second). This value gives a reasonable estimate of the amount of traffic currently flowing through the switch. It is calculated as follows: Octets*8 + Frames*(96 + 64) --------------------------- Measurement Interval * 1,000,000 * 2 Where: Measurement Interval is the amount of time over which the Octets and Frames were collected, in seconds. Measurement Interval is always one second in current implementation. Octets is the total number of octets transmitted or received by all network interfaces, excluding framing data but including FCS. This includes octets in frames which were partially transmitted or received (due to collisions, for example). Frames is the total number of frames transmitted or received by all network interfaces, including frames with errors. The number of frames is multiplied by 96 plus 64 in order to estimate the delay between each frame for Ethernet's IPG and preamble/SFD. The '2' in the divisor makes this a forwarding bandwidth counter. A frame received on one interface is typically forwarded out another interface. In order to avoid double- counting this frame's bandwidth, once on the receiving interface and once on the transmitting interface, the total bandwidth is divided by two. Since multicast and broadcast frames can be sent to multiple ports, the above is at best a lower bound.
1.3.6.1.4.1.9.9.87.1.5.2
Gauge32
The maximum number of entries c2900BandwidthUsagePeakTable can have.
1.3.6.1.4.1.9.9.87.1.5.3
INTEGER1 = onehour3 = threehours6 = sixhours12 = twelvehours24 = oneday48 = twodays72 = threedays96 = fourdays120 = fivedays144 = sixdays168 = oneweek · Integer32
This object specifies the length of time which forms a peak bandwidth measurement interval. A write to this object with any new value restarts the peak bandwidth recording interval used by bandwidthUsagePeakTable. In other words, the bandwidthUsagePeakTable will be cleared and entry number one will record the peak with a new measurement interval.
1.3.6.1.4.1.9.9.87.1.5.4
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Set to true(1) to clear the c2900BandwidthUsagePeakTable and restart the peak bandwidth recording. No action will be taken if this object is set to false(2). This object returns false(2) when read.
1.3.6.1.4.1.9.9.87.1.5.5
Gauge32
A value identifying an instance of the c2900BandwidthUsagePeakIndex where the peak bandwidth estimation is most recent.
1.3.6.1.4.1.9.9.87.1.3
Index: c2900ModuleIndex
A list of module entries.
1.3.6.1.4.1.9.9.87.1.3.1.1
Integer32 (1..64)
Module index into c2900ModuleTable .
1.3.6.1.4.1.9.9.87.1.3.1.2
INTEGER1 = moduleNotInstalled2 = moduleInTest3 = moduleHealthy4 = moduleFaulty · Integer32
The overall status of of the module.
1.3.6.1.4.1.9.9.87.1.3.1.3
INTEGER1 = other2 = empty3 = wsx2914xl4 = wsx2922xl5 = atm155SMLRFiber6 = atm155SMMRFiber7 = atm155MMFiber8 = atm155UTP9 = wsx2914xlv10 = wsx2922xlv11 = wsx2924xlv12 = wsx2931xl13 = wsx2932xl · Integer32
The type of module installed in malibu switch.
1.3.6.1.4.1.9.9.87.1.3.1.4
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..12) · OCTET STRING · hint 255a
The hardware version of the module. The format of the version string x.y.z where x,y, and z are hardware register field values.
1.3.6.1.4.1.9.9.87.1.3.1.5
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..40) · OCTET STRING · hint 255a
The software version of the module.
1.3.6.1.4.1.9.9.87.1.4.1
Index: c2900PortModuleIndex · c2900PortIndex
A list of port entries. The number of entries is determined by the number of modules in the chassis and the number of ports on each module.
1.3.6.1.4.1.9.9.87.1.4.1.1.1
Integer32 (0..64)
An index value that uniquely identifies the module where this port is located. The value is determined by the chassis slot number into which the module is plugged.
1.3.6.1.4.1.9.9.87.1.4.1.1.2
Integer32 (1..64)
An index value that uniquely identifies this port within a module.
1.3.6.1.4.1.9.9.87.1.4.1.1.3
INTEGER1 = standard2 = security3 = monitor4 = portGrouping5 = network6 = networkGroup7 = portGroupDest8 = protected · Integer32
This object indicates how the port is to be used. The variable usage applications are shown above. These applications are defined such that they are mutually exclusive. In other words, a port using the security(2) application cannot also use the monitor(3) application at the same time. The default usage is standard(1), or no special behavior (the port behaves as normal switched port). The security(2) usage adds addressing security to the port, whereby all learned addresses are secure address. The monitor(3) usage provides network diagnosis by reflecting traffic on other ports to this port. The portGrouping(4) application treats this and other ports in the same group as one(inter-switch) connection for more bandwidth potential. When the c2900PortUsageApplication is portGrouping, the c2900PortGroupIndex is set to the index value of the port group. The source address of a received frame is used to determine on which port within the group the frame should be transmitted. The network(5) usage saves address table space when the port is used as the link to a large network with many MAC addresses by disabling address learning on the port and allowing unknown unicasts packets received on other ports of the vlan the port associated with to be forwarded only to the port. The networkGroup(6) usage treates this and other ports in the same group as a network port group. All ports in port are network ports in the sense that address learning is disabled on them and unknown unicast packets received on other ports of the vlan are forwarded to the group. The portGroupDest(7) application treats this and other ports in the same group as one(inter-switch) connection for more bandwidth potential. When the c2900PortUsageApplication is portGroupDest, the c2900PortGroupIndex is set to the index value of the port group. The destination address of a received frame is used to determine on which port within the group the frame should be transmitted. The protected(8) application does not forward any traffic to other protected ports. It does not forward all kinds of unicast, multicast and broadcast traffic to any other protected port. The protected ports, however, forward traffic normally to non-protected ports and vice versa.
1.3.6.1.4.1.9.9.87.1.4.1.1.4
Integer32 (1..12)
This object is meaningful only when the corresponding c2900PortUsageApplication is portGrouping. Ports assigned with the same value of c2900PortGroupIndex belong to the same connection channel.
1.3.6.1.4.1.9.9.87.1.4.1.1.5
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object reflects an internal state of the port with regard to its ability to learn new addresses. Certain port configurations such as learning time limit, security usage, etc., and some Spanning Tree Protocol states can temporarily prohibit the port from learning. This object is true(1) if the port is allowed to learn. It is false(2) otherwise. Setting this object to true(1) will fail, if the port is not in normal state. This object is deprecated.
1.3.6.1.4.1.9.9.87.1.4.1.1.6
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object reflects an internal state of the port with regard to its ability to forward frames. A port sometimes stops forwarding frames when it is blocked by the Spanning Tree Protocol, or while it is undergoing temporary load balancing as part of the port grouping usage. This object is true(1) if the port is allowed to forward frames. It is false(2) otherwise. Setting this object to true(1) will fail, if the port is in the middle of being blocked by the Spanning Tree Protocol, or while it is undergoing temporary load balancing as part of the port grouping usage. This object is only supported for static VLAN access ports.
1.3.6.1.4.1.9.9.87.1.4.1.1.7
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Seting this object to true(1) allows the switch to run its buffer congestion control algorithm on the port. Setting the object to false(2) disallows such control. The buffer congestion control algorithm is summarized in the description of the c2900PortBufferCongestionThresholdPercent below. This object is deprecated
1.3.6.1.4.1.9.9.87.1.4.1.1.8
Integer32 (1..99)
The port buffer congestion threshold provides an early warning to the switch that the port is about to exhaust all its guaranteed buffers, leading to congestion. This threshold is expressed as a percentage of the port's total guaranteed buffer depth. Once this threshold has been crossed, the switch begins colliding with frames received on the port for a fixed period of time. After this time has expired, the switch determines whether the port's buffer congestion has been alleviated. If this situation has not changed, the switch resumes this congestion control algorithm on the port.
1.3.6.1.4.1.9.9.87.1.4.1.1.9
Integer32 (50..4000) · milliseconds
Reference: Section 4.2 IEEE802.1D-1993
The aging interval in milliseconds after which old frames queued for transmission on this port are discarded.
1.3.6.1.4.1.9.9.87.1.4.1.1.10
Integer32 (1..132)
The maximum number of secure addresses that can be learned on this port when it is a secure port. This number should be always higher than c2900PortAddrSecureCurrentAddresses
1.3.6.1.4.1.9.9.87.1.4.1.1.11
Gauge32
The current number of statically assigned unicast addresses on the port.
1.3.6.1.4.1.9.9.87.1.4.1.1.12
Counter32
The number of times a source address was seen on this port which duplicates a secured address configured on another port, plus the number of times a source address was seen on this port which does not match any addresses secured for the port.
1.3.6.1.4.1.9.9.87.1.4.1.1.13
Counter32
The current number of dynamically learned addresses on the port.
1.3.6.1.4.1.9.9.87.1.4.1.1.14
Counter32
The number of times an address could not be learned or assigned for the port because its address table was full at one time.
1.3.6.1.4.1.9.9.87.1.4.1.1.15
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Set to true(1) to delete all learned and assigned dynamic, static and secure unicast addresses the port currently has. Setting the object to false(2) has no effect. This object always returns false(2) when read.
1.3.6.1.4.1.9.9.87.1.4.1.1.16
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Set to true(1) to allow forwarding to this port frames addressed to multicast addresses that have not been configured for the port. Set to false(2) to filter and discard such frames.
1.3.6.1.4.1.9.9.87.1.4.1.1.17
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object controls the forwarding of unknown unicast frames to this port. When set to true(1), the switch will, upon receiving a frame with an unknown unicast destination address from another port, transmit the frame to this port. When set to false(2), switch will filter and not transmit said frames to this port. Default value: false(2) for ports using the security or monitor application; true(1) for all other usage applications.
1.3.6.1.4.1.9.9.87.1.4.1.1.18
INTEGER1 = unknown2 = linkbeat3 = nolinkbeat · Integer32
This object depends on the physical layer in use and indicates the current port linkbeat status: if the physical link between two devices is properly connected or not. If the value is linkbeat(1), there is linkbeat. If the value is nolinkbeat(2), there is no linkbeat. If the value is unknown(3), the information is not available.
1.3.6.1.4.1.9.9.87.1.4.1.1.19
INTEGER1 = stopBroadcastForwarding2 = forwardBroadcast3 = disablePort · Integer32
Indicates what action to take when the broadcast rising threshold for a port is reached. The default action is to forwardBroadcast(2) as usual for all broadcast frames received from the port. The other action is to stopBroadcastForwarding(1) frames until the broadcast reception rate falls to or below the falling threshold. The port can also be shutdown in the event of a broadcast storm with the action disablePort(3).
1.3.6.1.4.1.9.9.87.1.4.1.1.20
Gauge32
The broadcast rising threshold is measured in the number of broadcast frames received on a port in a second. When the number of broadcast frames received per second on this port crosses this threshold, the appropriate action as specified by the object c2900PortBroadcastStormAction will take place. See the description of c2900PortBroadcastStormAction.
1.3.6.1.4.1.9.9.87.1.4.1.1.21
Gauge32
The broadcast falling threshold is measured in number of broadcast frames received on a port in a second. When the falling threshold is crossed and the c2900PortBroadcastStormAction was stopBroadcastForwarding(1) then broadcast forwarding will be re-enabled on the port. For the other values of c2900PortBroadcastStormAction, crossing the falling threshold has no affect.
1.3.6.1.4.1.9.9.87.1.4.1.1.22
INTEGER1 = other2 = disabled3 = blocking4 = listening5 = learning6 = preforwarding7 = forwarding8 = secureforwarding9 = suspended10 = broken · Integer32
Reference: Section 4.5.5.2 IEEE802.1D-1990
The port's current state as defined by application of the Spanning Tree Protocol. This state controls what action a port takes on reception of a frame. If the switch has detected a port that is malfunctioning it will place that port into the broken(10) state. For ports which are disabled(see dot1dStpPortEnable), this object will have a value of disabled(2). Since the switch implements three additional states which are not part of IEEE Standard, these additional states are possible values for c2900PortStaus. The additional states are preforwarding(6), secureforwarding(8), and suspended(9). Note: except for these additional states, this object is the same as the dot1dStpPortState object. Default value: blocking(2). This object is only supported for static VLAN access ports.
1.3.6.1.4.1.9.9.87.1.4.1.1.23
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates if the port passed power on self test or not. If the value of this object is true(1), the port passed test. If the value of this object is false(2), the port failed test.
1.3.6.1.4.1.9.9.87.1.4.1.1.24
INTEGER1 = notused2 = black3 = amber4 = green · Integer32
This object is used to indicate the current color of a LED. If a LED is flashing, the value of this object will represent the color of the LED at that instant in time. The following conventions indicate port status: Link healthy returns green(4) Link activity usually green(4), but may return black(2). Link faulty alternating green(4)/amber(3) Port disabled returns amber(3)
1.3.6.1.4.1.9.9.87.1.4.1.1.25
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The value of the instance of the ifIndex object, defined in MIB-II, for the interface corresponding to this port.
1.3.6.1.4.1.9.9.87.1.4.1.1.26
INTEGER1 = doNothing2 = disablePort3 = sendNotify4 = disablePortAndNotify · Integer32
Indicates what action to take when an address violation (an address mismatch or duplication) occurs on a secure port. The default action is to do nothing. doNothing(1) : do nothing disablePort(2) : disable port; the port can only be reenabled by an explicit management action. sendNotify(3) : generate address violation notification. disablePortAndNotify(4): disable port and send notification.
1.3.6.1.4.1.9.9.87.1.4.1.1.27
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
When set to true(1), the switch will generate a broadcastStorm notification upon detecting a port is receiving broadcast packets at a rate higher than or equal to the threshold specified by c2900PortBroadcastRisingThreshold. When set to false(2), no such trap will be issued. Default value: false(2). c2900PortBroadcastStormAlarm is defined for each port.
1.3.6.1.4.1.9.9.87.1.4.1.1.28
Integer32 (0..64)
Switch Port (c2900PortSwitchPortIndex) index value of the port that is to be monitored by this port. A value of zero can't be used to do set, it is used to return when this object is read. To remove a port from the monitored list use the object c2900PortNoMonitorDestinationPort.
1.3.6.1.4.1.9.9.87.1.4.1.1.29
Integer32 (1..64)
Switch port index of a port is a value that uniquely identifies the port within a switch. This is obtained from the port index (c2900PortIndex) and the module index (c2900PortModuleIndex).
1.3.6.1.4.1.9.9.87.1.4.1.1.30
OCTET STRING SIZE (0..32)
Indicates which ports are actually being monitored. The octet string contains one bit per port. Each bit within the octet string represents one port of the device. The ordering of ports represented within the octet string is in the same order as in the RFC 1493 dot1dStaticAllowedToGoTo in the dot1dStaticTable. The bit value interpretation is as follows: 1 = being monitored 0 = not being monitored
1.3.6.1.4.1.9.9.87.1.4.1.1.31
INTEGER1 = fullduplex2 = halfduplex3 = autoNegotiate · Integer32
Set to fullduplex(1) to operate in full duplex mode, port will allow simultaneous transmit and receive which can double its bandwidth. Set to halfduplex(2) to operate in half duplex mode. Set to autoNegotiate(3) to allow the switch to negoti- ate with the other end of the connection. The status of duplex mode on a port is available with c2900PortDuplexStatus object.
1.3.6.1.4.1.9.9.87.1.4.1.1.32
INTEGER1 = fullduplex2 = halfduplex · Integer32
The status of duplex mode on this port. When linkbeat is not present, halfduplex is always reported. When linkbeat is present, the result of full duplex auto-negotiation is reported if c2900PortDuplexState is set to auto-negotiate, otherwise it reports fullduplex if c2900PortDuplexState is set to fullduplex or halfduplex if c2900PortDuplexState is set to halfduplex.
1.3.6.1.4.1.9.9.87.1.4.1.1.33
INTEGER1 = autoDetect10000000 = s10000000100000000 = s100000000155520000 = s155520000 · Integer32
The object controls the speed of the port. The current operational speed of the port can be determined from ifSpeed.
1.3.6.1.4.1.9.9.87.1.4.1.1.34
Integer32 (0..64)
Switch Port (c2900PortSwitchPortIndex) index value of the port that is to be removed from the monitored list. A value of zero can't be used to do set, it is used to return when this object is read. To add a port to the monitored list use the object c2900PortMonitorDestinationPort.
1.3.6.1.4.1.9.9.87.1.4.1.1.35
Integer32 (1..65535)
This is the dot1dBasePort associated with this port.
1.3.6.1.4.1.9.9.87.1.4.1.1.36
INTEGER1 = enabled2 = disabled · Integer32
Indicates whether the port is operating in spantree fast start mode. A port with fast start enabled is immediately put in spanning tree forwarding state on link up, rather than starting in blocking state which is the normal operation. This is useful when the port is known to be connected to a single station which has problems waiting for the normal spanning tree operation to put the port in forwarding state.
1.3.6.1.4.1.9.9.87.1.4.1.1.37
INTEGER (0 | 1..1000 | 4095 | 4096) · Integer32
The Voice Virtual Vlan ID (VVID) to which this port belongs to. If the VVID is not supported on the port, this MIB object will not be configurable and will return 4096. Setting this MIB object to 4096, the CDP packets transmitting through this port would not include Appliance VLAN-ID TLV. Setting this MIB object to 4095, the CDP packets transmitting through this port would contain Appliance VLAN-ID TLV with value of 4095 - VoIP and related packets are expected to be sent and received untagged without an 802.1p priority. Setting this MIB object to 0, the CDP packets transmitting through this port would contain Appliance VLAN-ID TLV with value of 0 - VoIP and related packets are expected to be sent and received with VLAN-id=0 and an 802.1p priority. Setting this MIB object to N (1..1000), the CDP packets transmitting through this port would contain Appliance VLAN-ID TLV with N - VoIP and related packets are expected to be sent and received with VLAN-id=N and an 802.1p priority.
1.3.6.1.4.1.9.9.87.1.4.1.1.38
Integer32 (0..1440) · minutes
The aging interval in minutes for each secure address entry on a given port. Depending on the type of aging the secure address will age out after the expiration of the aging time and will be removed from the secure address list. Any change in the value of this object will restart the aging for all the secure addresses on this port. If the value of this object is 0 for a given port, the aging mechanism is disabled for this port.
1.3.6.1.4.1.9.9.87.1.4.1.1.39
INTEGER1 = absolute2 = inactivity · Integer32
If the value of this object on a given port is absolute - all the secure addresses on this port will age out exactly after the aging time configured for this port. inactivity - the secure addresses on this port will age out only if there is no data traffic from the given secure source address for a time period specified by aging time. Any change in the value of this object will restart the aging for all the secure addresses on this port. The value of this object is not effective when the value of c2900PortAddrSecureAgingTime is 0.
1.3.6.1.4.1.9.9.87.1.4.1.1.40
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Set to true(1) to enable aging for statically configured secure addresses on one port. Disable the aging for statically configured secure addresses if set to false(2). Any change in the value of this object will restart the aging for all the configured secure addresses on this port. The value of this object is not effective when the value of c2900PortAddrSecureAgingTime is 0.
1.3.6.1.4.1.9.9.87.1.4.2
Index: c2900PortModuleIndex · c2900PortIndex
A list of port entries. The number of entries is determined by the number of modules in the chassis and the number of ports on each module.
1.3.6.1.4.1.9.9.87.1.4.2.1.1
Counter32 · frames
A count of frames received on this port that were discarded due to a lack of bandwidth resources in the Catalyst Switch forwarding engine.
1.3.6.1.4.1.9.9.87.1.4.2.1.2
Counter32 · frames
A count of frames received that were discarded due to a lack of frame buffer resources in the Catalyst Switch forwarding engine.
1.3.6.1.4.1.9.9.87.1.4.2.1.3
Counter32 · frames
A count of unicast frames received that were discarded, because the forwarding rules stipulate that they are not be forwarded.
1.3.6.1.4.1.9.9.87.1.4.2.1.4
Counter32 · frames
A count of multicast frames received that were discarded, because they have not been configured for the port.
1.3.6.1.4.1.9.9.87.1.4.2.1.5
Counter32 · frames
A count of broadcast frames received that were discarded because of the threshold-based broadcast suppression. This object is deprecated, because there is no way that the Malibu system to give the brodcast_supress frames
1.3.6.1.4.1.9.9.87.1.4.2.1.6
Counter32 · frames
The total number of frames received with FCS errors. This total includes all frames received with an FCS error and an integral number of bytes. Unlike RFC1650's dot3StatsFCSErrors, this object does not include frames which are less than the minimum packet size (such as collision fragments).
1.3.6.1.4.1.9.9.87.1.4.2.1.7
Counter32 · frames
The total number of frames whose lengths are less than 64 and have bad FCS values. The preamble and sfd fields are excluded from the byte count of a frame while the FCS field is included.
1.3.6.1.4.1.9.9.87.1.4.2.1.8
Counter32 · frames
A count of frames that are successfully transmitted and are directed to a multicast address. Unlike RFC1573's ifOutMulticastPkts, this object does not include those that were discarded or not sent.
1.3.6.1.4.1.9.9.87.1.4.2.1.9
Counter32 · frames
A count of frames that are successfully transmitted and are directed to the broadcast address. Unlike RFC1573's ifOutBroadcastPkts, this object does not include those that were discarded or not sent.
1.3.6.1.4.1.9.9.87.1.5.6
Index: c2900BandwidthUsagePeakIndex
A list of entries containing peak bandwidth usages in a number of recording interval. After being cleared, entries are added to the bandwidthUsagePeakTable with ascending values of c2900BandwidthUsagePeakIndex starting at 1. When the number of entries reaches c2900BandwidthUsageMaxPeakEntries, each new recording interval is assigned the value of c2900BandwidthUsagePeakIndex corresponding to the oldest entry, overwriting the previous contents of that entry.
1.3.6.1.4.1.9.9.87.1.5.6.1.1
Integer32 (1..2147483647)
Number from one to c2900BandwidthUsageMaxPeakEntries identifying a particular c2900BandwithUsagePeakEntry.
1.3.6.1.4.1.9.9.87.1.5.6.1.2
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The time that marks the start of this recording interval.
1.3.6.1.4.1.9.9.87.1.5.6.1.3
Gauge32 · megabits per second
The maximum bandwidth usage of any measurement interval within this recording interval. This value is an estimate of the highest amount of traffic flowing through the switch during this recording interval. It is calculated as follows: Octets*8 + Frames*(96 + 64) --------------------------- Measurement Interval * 1,000,000 * 2 Where: Measurement Interval is the amount of time over which the Octets and Frames were collected, in seconds. Measurement Interval is always one second in c2900's implementation. Octets is the total number of octets transmitted or received by all network interfaces, excluding framing data but including FCS. This includes octets in frames which were partially transmitted or received (due to collisions, for example). Frames is the total number of frames transmitted or received by all network interfaces, including frames with errors. The number of frames is multiplied by 96 plus 64 in order to estimate the delay between each frame for Ethernet's IPG and preamble/SFD. The '2' in the divisor makes this a forwarding bandwidth counter. A frame received on one interface is typically forwarded out another interface. In order to avoid double- counting this frame's bandwidth, once on the receiving interface and once on the transmitting interface, the total bandwidth is divided by two. Since multicast and broadcast frames can be sent to multiple ports, the above is at best a lower bound.
1.3.6.1.4.1.9.9.87.1.5.6.1.4
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The start time of the measurement interval.
1.3.6.1.4.1.9.9.87.2.0.1
The addressViolation notification is generated when an address violation is detected on a secured port. The generation of the addressViolation notification can be enabled or suppressed using the object c2900ConfigAddressViolationAction. The particular secured port is indicated by the value of c2900PortIfIndex.
1.3.6.1.4.1.9.9.87.1.4.1.1.25
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The value of the instance of the ifIndex object, defined in MIB-II, for the interface corresponding to this port.
1.3.6.1.4.1.9.9.87.2.0.2
The broadcastStorm notification is generated upon detecting a port is receiving broadcast packets at a rate crossing the specified broadcast threshold. This trap is only for the rising threshold. The particular port is indicated by the values of c2900PortModuleIndex and c2900PortIndex, and the value of the threshold is given by c2900PortBroadcastRisingThreshold.
1.3.6.1.4.1.9.9.87.1.4.1.1.20
Gauge32
The broadcast rising threshold is measured in the number of broadcast frames received on a port in a second. When the number of broadcast frames received per second on this port crosses this threshold, the appropriate action as specified by the object c2900PortBroadcastStormAction will take place. See the description of c2900PortBroadcastStormAction.
1.3.6.1.4.1.9.9.87.2.0.3
A redundant power system (RPS) is connected to the switch. The RpsFailed notification is generated upon detecting RPS failure.
1.3.6.1.2.1.1.5
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
An administratively-assigned name for this managed node. By convention, this is the node's fully-qualified domain name.