This MIB module provides information for tracking the progress and status of a data call from the hardware layer through the application or service layer.
A data call is a call setup via a signaling protocol (e.g., ISDN D Channel signaling) on the Public Switching Telephony Network to a Network Access Server in order to transfer data, either as a byte stream (e.g., terminal emulation) or in a packet format (e.g., PPP packets) from a data terminal (e.g., Personal Computer) to a data network (e.g., Internet).
This object may be used in conjunction with objects of type CctCallId to provide call references which are unique across system re-initializations.
This value is generated at system re-initialization. It is a 32-bit random number, with very low likely-hood of repeating within the lifetime of the system.
cctActiveTableNumberEntries
1.3.6.1.4.1.9.9.163.1.2.1
Gauge32
The number of entries currently in the cctActiveTable.
cctActiveTableHighWaterMark
1.3.6.1.4.1.9.9.163.1.2.2
Gauge32
Maximum number of entries present in cctActiveTable since last system re-initialization.
This corresponds to the maximum value reported by cctActiveTableNumberEntries.
cctHistoryTableEntriesLimit
1.3.6.1.4.1.9.9.163.1.3.1
Unsigned32 (0..2147483647)
The upper limit on the number of entries that the cctHistoryTable may contain.
A value of zero will prevent any history from being retained.
This value may not exceed the system specific limit provided in cctHistoryTableMaxEntries.
cctHistoryTableMaxEntries
1.3.6.1.4.1.9.9.163.1.3.2
Unsigned32
The maximum allowed table length supported by this system. The value of cctHistoryTableEntriesLimit may not exceed this value.
cctHistoryTableRetainTimer
1.3.6.1.4.1.9.9.163.1.3.3
Unsigned32 (0..2147483647) · minutes
The maximum amount of time that an entry will be maintained within the cctHistoryTable before being deleted.
A value of zero will prevent any history from being retained.
cctHistoryTableNumberEntries
1.3.6.1.4.1.9.9.163.1.3.4
Gauge32
Count of the number of entries currently in the cctHistoryTable.
cctHistoryTableHighWaterMark
1.3.6.1.4.1.9.9.163.1.3.5
Gauge32
Maximum number of entries present in cctHistoryTable since last system re-initialization or the value of cctHistoryTableEntriesLimit has been changed.
This corresponds to the maximum value reported by cctHistoryTableNumberEntries.
Changing the value of cctHistoryTableEntriesLimit resets this value to zero.
cctHistoryTableNewestIndex
1.3.6.1.4.1.9.9.163.1.3.6
Unsigned32
This object provides the index value of the most recent entry currently in the cctHistoryTable.
A value of zero indicates there has never been an entry in the table or all entries have expired.
cctCallSetupTermNotifyEnable
1.3.6.1.4.1.9.9.163.1.4.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This variable controls generation of cctCallSetupNotification and cctCallTerminateNotification.
When this variable is 'true(1)', generation of these notifications is enabled. When this variable is 'false(2)', generation is disabled.
The default value is 'false(2)'.
Table details
cctActiveTable
1.3.6.1.4.1.9.9.163.1.2.3
Index: cctActiveCallId
This table contains entries for active calls in the system. All such calls either originate or terminate at this system.
The table is indexed by call ID assigned to the call.
cctActiveCallId
1.3.6.1.4.1.9.9.163.1.2.3.1.1
CctCallIdRepresents a Call Identifier. The call identifier is a monotonically assigned, positive integer which uniquely identifies the call within the system. (1..4294967295) · Unsigned32
Represents a Call Identifier. The call identifier is a monotonically increasing unsigned integer which uniquely identifies the call within the system.
The Call ID is represented as an unsigned 32-bit integer. After 4,294,967,295 calls, the ID will wrap and the 4,294,967,296th call will receive the next smallest available id starting from 1.
Zero is not a valid value.
cctActiveSetupTime
1.3.6.1.4.1.9.9.163.1.2.3.1.2
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when the call is first made known to the system.
cctActiveOrigin
1.3.6.1.4.1.9.9.163.1.2.3.1.3
INTEGER1 = originate2 = answer · Integer32
This object indicates how the call was created.
originate(1) - The call was initiated locally with the system sending the setup request. Dialout
answer(2) - The call was initiated remotely and
the system received the setup request. Dialin
cctActiveConnectionTime
1.3.6.1.4.1.9.9.163.1.2.3.1.4
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when the system connected the call.
cctActivePhysicalLayerReadyTime
1.3.6.1.4.1.9.9.163.1.2.3.1.5
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when the physical layer for the call achieved a steady state and the call is ready for higher protocol layers to begin.
In the case of modem calls, the physical layer for the call achieves a steady state when the data rates, modulations, and error correcting protocols have been negotiated between the originating and answering modems.
This is primarily intended for calls which connect to a processing resource identified by cctActiveResourceSlot and cctActiveResourcePort. It also applies to digital calls using adaptive rate technologies such as V.110 and V.120.
cctActiveServiceUpTime
1.3.6.1.4.1.9.9.163.1.2.3.1.6
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when the call service type identified in cctActiveServiceType was established.
cctActiveServiceType
1.3.6.1.4.1.9.9.163.1.2.3.1.7
CctServiceType1 = none2 = other3 = slip4 = ppp5 = mp6 = tcpClear7 = telnet8 = exec9 = l2f10 = l2tpRepresents possible service types.
none - No service associated with call.
other - Service active, but none of the following.
slip - Serial Line IP
ppp - PPP
mp - Multilink PPP (RFC 1990)
tcpClear - Byte stream over TCP
telnet - TELNET
exec - terminal server
l2f - Virtual Private Data Network service (VPDN)
using Layer 2 Forwarding protocol
l2tp - Virtual Private Data Network service (VPDN)
using Layer 2 Tunneling Protocol · Integer32
Service associated with the call.
This is the highest level of service known to the system for the call. The service represents the encapsulation protocol layer active for the call.
In the case of multiple services on a given call, the last service activated will be reported.
cctActiveUserValidationTime
1.3.6.1.4.1.9.9.163.1.2.3.1.8
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when the user identification associated with this call was validated.
See cctActiveUserId for description of user identification.
cctActiveUserId
1.3.6.1.4.1.9.9.163.1.2.3.1.9
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The User login ID or zero length string if unavailable.
cctActiveUserIpAddr
1.3.6.1.4.1.9.9.163.1.2.3.1.10
IpAddress SIZE (4)
The IP address assigned to the cctActiveUserId for this call or 0.0.0.0 if not applicable or unavailable.
cctActiveUserSubnetMask
1.3.6.1.4.1.9.9.163.1.2.3.1.11
IpAddress SIZE (4)
The IP subnet mask assigned to the cctActiveUserId for this call or 0.0.0.0 if not applicable or unavailable.
cctActiveAccountingSessionId
1.3.6.1.4.1.9.9.163.1.2.3.1.12
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
Accounting session identification assigned to this call by AAA.
The session ID is sent by AAA to RADIUS as the Acct-Session-Id attribute or TACACS+ as the task_id.
If no accounting session ID is assigned, the value is a null string. Reference: RFC 2139 RADIUS Accounting The TACACS+ Protocol Version 1.78, Internet Draft
cctActiveCallCategory
1.3.6.1.4.1.9.9.163.1.2.3.1.13
CctCallCategory1 = none2 = other3 = modem4 = isdnSync5 = v1106 = v1207 = casDigital8 = mgcpData9 = syncData10 = lapb-taRepresents possible call categories or types.
none - No call category associated with call
other - None of the following
modem - Modem call
isdn-sync - ISDN sync digital call
Now mapped to syncData
v110 - V110 Call
v120 - V120 Call
cas-digital - Channel Associated Signaling (CAS) 56k data call
mgcpData - MGCP data call
Now mapped to syncData
syncData - Sync digital data call for any
call control
lapb-ta - LAPB or LAPB-TA call · Integer32
The call category or type
cctActiveInitialRxRate
1.3.6.1.4.1.9.9.163.1.2.3.1.14
Unsigned32 · bits per second
Initial receive data rate for this call. If call is a synchronous digital call such as ISDN sync, this value is the data rate of the B-channel.
If call is asynchronous, even if using a synchronous transmission medium such as ISDN, the value is determined by the resource providing the asynchronous processing. For modem calls, this value corresponds to the value of cmRXRate from CISCO-MODEM-MGMT-MIB, immediately after the modem has completed initial negotiations.
This value does not change, even if the data rate varies during the call.
This value will be zero until an initial data rate has been determined.
cctActiveInitialTxRate
1.3.6.1.4.1.9.9.163.1.2.3.1.15
Unsigned32 · bits per second
Initial transmit data rate for this call. If call is a synchronous digital call such as ISDN sync, this value is the data rate of the B-channel.
If call is asynchronous, even if using a synchronous transmission medium such as ISDN, the value is determined by the resource providing the asynchronous processing. For modem calls, this value corresponds to the value of cmTXRate from CISCO-MODEM-MGMT-MIB, immediately after the modem has completed initial negotiations.
This value does not change, even if the data rate varies during the call.
This value will be zero until an initial data rate has been determined.
cctActiveResourceSlot
1.3.6.1.4.1.9.9.163.1.2.3.1.16
Integer32 (-1..214783647)
Identification of the processing resource allocated to the call.
In the case of a call requiring a modem resource, this is the value of cmSlotIndex from CISCO-MODEM-MGMT-MIB.
This value along with cctActiveResourcePort uniquely identifies a resource port.
Value is -1 if call does not utilize such a resource.
cctActiveResourcePort
1.3.6.1.4.1.9.9.163.1.2.3.1.17
Integer32 (-1..214783647)
Identification of the processing resource allocated to the call.
In the case of a call requiring a modem resource, this is the value of cmPortIndex from CISCO-MODEM-MGMT-MIB.
This value along with cctActiveResourceSlot uniquely identifies a resource port.
Value is -1 if call does not utilize such a resource.
cctActiveEntrySlot
1.3.6.1.4.1.9.9.163.1.2.3.1.18
Integer32 (0..214783647)
The device slot containing the port on which the call exists.
cctActiveEntryPort
1.3.6.1.4.1.9.9.163.1.2.3.1.19
Integer32 (0..214783647)
The physical port within the device slot on which the call exists.
cctActiveEntryDs1
1.3.6.1.4.1.9.9.163.1.2.3.1.20
Integer32 (0..214783647)
The DS1 link containing the call. This may be a DS1 contained within a larger grouping of multiple DS1s within a single physical port.
If the physical port is of type DS1, this value is identical to cctActiveEntryPort.
If the DS1 is a logical subinterface within the physical port, this value is the number of the DS1 within this slot.
Examples: 8 port DS1 card - cctActiveEntryPort and cctActiveEntryDs1 will have identical values.
3 port T3 card - cctActiveEntryPort represents
T3 ports. cctActiveEntryEntryDs1 represents logical T1 interfaces. Each T3 contains 28 T1 interfaces. The T1 interfaces are numbered sequentially across the entire T3 card.
cctActiveEntryChannel
1.3.6.1.4.1.9.9.163.1.2.3.1.21
Integer32 (0..214783647)
The channel or timeslot within the cctActiveEntryDs1 allocated to the call.
cctActiveCalledPartyId
1.3.6.1.4.1.9.9.163.1.2.3.1.22
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a
The called telephone number for this call. For calls answered by the system, this corresponds to the Dialed Number Identification (DNIS).
For calls originated by the system, this is the destination number.
If not available this is a zero-length string.
cctActiveCallingPartyId
1.3.6.1.4.1.9.9.163.1.2.3.1.23
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a
The calling telephone number for this call. For calls answered by the system, this corresponds to the calling identification (CLID).
For calls originated by the system, this is the number associated with the device. For the interworking call, this object contains the translated calling party number if there is a translation rule is associated with dial plan for making this outgoing call.
If not available this is a zero-length string.
cctActiveMpBundleId
1.3.6.1.4.1.9.9.163.1.2.3.1.24
Unsigned32
Multilink PPP bundle identification for call if cctActiveServiceType has the value 'mp'.
If the value of cctActiveServiceType for this call is not 'mp', then the value of this object is not meaningful.
cctActiveChargedUnits
1.3.6.1.4.1.9.9.163.1.2.3.1.25
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32
The number of charged units for this connection. For incoming calls or if charging information is not supplied by the switch, the value of this object will be zero. Reference: AOC-D defined in ETSI Standard: ETS 300 179
cctActiveReceiveBytes
1.3.6.1.4.1.9.9.163.1.2.3.1.26
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · bytes
The number of bytes received on the call. All the 'raw' bytes are counted including any protocol headers which may or may not be present depending on the value of cctActiveServiceType.
cctActiveTransmitBytes
1.3.6.1.4.1.9.9.163.1.2.3.1.27
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · bytes
The number of bytes transmitted on the call. All the 'raw' bytes are counted including any protocol headers which may or may not be present depending on the value of cctActiveServiceType.
cctActiveCallSignalingType
1.3.6.1.4.1.9.9.163.1.2.3.1.28
CctCallSigType1 = unknown2 = external3 = q9314 = autoDetectRepresents supported signaling types for a call.
Unknown - Signaling origin of call type unknown.
External - Signaling origin of call type by external
agent e.g. MGCP, H.248
Q931 - Signaling origin of call type by Q.931/ISDN
Autodetect - Signaling of call type by automatic detection · Integer32
Signaling type used to setup the call.
cctHistoryTable
1.3.6.1.4.1.9.9.163.1.3.7
Index: cctHistoryIndex
This table provides information on terminated calls.
cctHistoryIndex
1.3.6.1.4.1.9.9.163.1.3.7.1.1
Unsigned32 (1..4294967295)
A monotonically increasing integer for the sole purpose of indexing terminated calls. When it reaches the maximum value the agent wraps the value back to 1 and will flush existing entries.
cctHistoryCallId
1.3.6.1.4.1.9.9.163.1.3.7.1.2
CctCallIdRepresents a Call Identifier. The call identifier is a monotonically assigned, positive integer which uniquely identifies the call within the system. (1..4294967295) · Unsigned32
The call identifier for the call. This is the same value assigned to the call in cctActiveCallId when it was in the cctActiveTable.
It is possible for two cctHistoryEntry entries to have the same cctHistoryCallId if one very long running call terminates after the cctActiveCallId has wrapped around and is reassigned to a new short lived call.
cctHistorySetupTime
1.3.6.1.4.1.9.9.163.1.3.7.1.3
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when the call was first made known to the system.
cctHistoryOrigin
1.3.6.1.4.1.9.9.163.1.3.7.1.4
INTEGER1 = originate2 = answer · Integer32
This object indicates how the call was created.
originate(1) - The call was initiated locally with the system sending the setup request. Dialout
answer(2) - The call was initiated remotely and
the system received the setup request. Dialin
cctHistoryConnectionTime
1.3.6.1.4.1.9.9.163.1.3.7.1.5
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when the system connected the call.
cctHistoryPhysicalLayerReadyTime
1.3.6.1.4.1.9.9.163.1.3.7.1.6
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when the physical layer for the call achieved a steady state and the call is ready for higher protocol layers to begin.
In the case of modem calls, the physical layer for the call achieves a steady state when the data rates, modulations, and error correcting protocols have been negotiated between the originating and answering modems.
This is primarily intended for calls which connect to a processing resource identified by cctHistoryResourceSlot and cctHistoryResourcePort. It also applies to digital calls using adaptive rate technologies such as V.110 and V.120.
cctHistoryServiceUpTime
1.3.6.1.4.1.9.9.163.1.3.7.1.7
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when the call service type identified in cctHistoryServiceType was established.
cctHistoryServiceType
1.3.6.1.4.1.9.9.163.1.3.7.1.8
CctServiceType1 = none2 = other3 = slip4 = ppp5 = mp6 = tcpClear7 = telnet8 = exec9 = l2f10 = l2tpRepresents possible service types.
none - No service associated with call.
other - Service active, but none of the following.
slip - Serial Line IP
ppp - PPP
mp - Multilink PPP (RFC 1990)
tcpClear - Byte stream over TCP
telnet - TELNET
exec - terminal server
l2f - Virtual Private Data Network service (VPDN)
using Layer 2 Forwarding protocol
l2tp - Virtual Private Data Network service (VPDN)
using Layer 2 Tunneling Protocol · Integer32
Service associated with the call.
This is the highest level of service known to the system for the call. The service represents the encapsulation protocol layer active for the call.
In the case of multiple services on a given call, the last service activated will be reported.
cctHistoryUserValidationTime
1.3.6.1.4.1.9.9.163.1.3.7.1.9
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when the user identification associated with this call was validated.
See cctHistoryUserId for description of user identification.
cctHistoryUserId
1.3.6.1.4.1.9.9.163.1.3.7.1.10
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The User login ID or zero length string if unavailable.
If this contains a non-zero length string, and cctHistoryUserValidationTime is zero, then the user failed validation.
cctHistoryUserIpAddr
1.3.6.1.4.1.9.9.163.1.3.7.1.11
IpAddress SIZE (4)
The IP address assigned to the cctHistoryUserId for this call or 0.0.0.0 if not applicable or unavailable.
cctHistoryUserSubnetMask
1.3.6.1.4.1.9.9.163.1.3.7.1.12
IpAddress SIZE (4)
The IP subnet mask assigned to the cctHistoryUserId for this call or 0.0.0.0 if not applicable or unavailable.
cctHistoryAccountingSessionId
1.3.6.1.4.1.9.9.163.1.3.7.1.13
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
Accounting session identification assigned to this call by AAA.
The session ID is sent by AAA to RADIUS as the Acct-Session-Id attribute or TACACS+ as the task_id.
If no accounting session ID is assigned, the value is a null string. Reference: RFC 2139 RADIUS Accounting The TACACS+ Protocol Version 1.78, Internet Draft
cctHistoryCallCategory
1.3.6.1.4.1.9.9.163.1.3.7.1.14
CctCallCategory1 = none2 = other3 = modem4 = isdnSync5 = v1106 = v1207 = casDigital8 = mgcpData9 = syncData10 = lapb-taRepresents possible call categories or types.
none - No call category associated with call
other - None of the following
modem - Modem call
isdn-sync - ISDN sync digital call
Now mapped to syncData
v110 - V110 Call
v120 - V120 Call
cas-digital - Channel Associated Signaling (CAS) 56k data call
mgcpData - MGCP data call
Now mapped to syncData
syncData - Sync digital data call for any
call control
lapb-ta - LAPB or LAPB-TA call · Integer32
The call category or type
cctHistoryInitialRxRate
1.3.6.1.4.1.9.9.163.1.3.7.1.15
Unsigned32 · bits per second
Initial receive data rate for this call. If call is a synchronous digital call such as ISDN sync, this value is the data rate of the B-channel.
If call is asynchronous, even if using a synchronous transmission medium such as ISDN, the value is determined by the resource providing the asynchronous processing. For modem calls, this value corresponds to the value of cmRXRate from CISCO-MODEM-MGMT-MIB, immediately after the modem has completed initial negotiations.
This value does not change, even if the data rate varies during the call.
This value will be zero if the call terminated prior to an initial data rate determination.
cctHistoryInitialTxRate
1.3.6.1.4.1.9.9.163.1.3.7.1.16
Unsigned32 · bits per second
Initial transmit data rate for this call. If call is a synchronous digital call such as ISDN sync, this value is the data rate of the B-channel.
If call is asynchronous, even if using a synchronous transmission medium such as ISDN, the value is determined by the resource providing the asynchronous processing. For modem calls, this value corresponds to the value of cmTXRate from CISCO-MODEM-MGMT-MIB, immediately after the modem has completed initial negotiations.
This value does not change, even if the data rate varies during the call.
This value will be zero if the call terminated prior to an initial data rate determination.
cctHistoryResourceSlot
1.3.6.1.4.1.9.9.163.1.3.7.1.17
Integer32 (-1..214783647)
Identification of processing resource allocated to call.
In the case of a call requiring a modem resource, this is the value of cmSlotIndex from CISCO-MODEM-MGMT-MIB.
This value along with cctHistoryResourcePort uniquely identifies a resource port.
Value is -1 if call does not utilize such a resource.
cctHistoryResourcePort
1.3.6.1.4.1.9.9.163.1.3.7.1.18
Integer32 (-1..214783647)
Identification of processing resource allocated to call.
In the case of a call requiring a modem resource, this is the value of cmPortIndex from CISCO-MODEM-MGMT-MIB.
This value along with cctHistoryResourceSlot uniquely identifies a resource port.
Value is -1 if call does not utilize such a resource.
cctHistoryEntrySlot
1.3.6.1.4.1.9.9.163.1.3.7.1.19
Integer32 (0..214783647)
The device slot containing the port on which the call existed.
cctHistoryEntryPort
1.3.6.1.4.1.9.9.163.1.3.7.1.20
Integer32 (0..214783647)
The physical port within the device slot on which the call existed.
cctHistoryEntryDs1
1.3.6.1.4.1.9.9.163.1.3.7.1.22
Integer32 (0..214783647)
The DS1 link containing the call. This may be a DS1 contained within a larger grouping of multiple DS1s within a single physical port.
If the physical port is of type DS1, this value is identical to cctActiveEntryPort.
If the DS1 is a logical subinterface within the physical port, this value is the number of the DS1 within this slot.
Examples: 8 port DS1 card - cctActiveEntryPort and cctActiveEntryDs1 will have identical values.
3 port T3 card - cctActiveEntryPort represents
T3 ports. cctActiveEntryEntryDs1 represents logical T1 interfaces. Each T3 contains 28 T1 interfaces. The T1 interfaces are numbered sequentially across the entire T3 card.
cctHistoryEntryChannel
1.3.6.1.4.1.9.9.163.1.3.7.1.23
Integer32 (0..214783647)
The channel or timeslot within the cctHistoryEntryDs1 which was allocated to the call.
cctHistoryCalledPartyId
1.3.6.1.4.1.9.9.163.1.3.7.1.24
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a
The called telephone number for this call. For calls answered by the system, this corresponds to the Dialed Number Identification (DNIS).
For calls originated by the system, this is the destination number.
If not available the string length is zero.
cctHistoryCallingPartyId
1.3.6.1.4.1.9.9.163.1.3.7.1.25
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a
The calling telephone number for this call. For calls answered by the system, this corresponds to the calling identification (CLID).
For calls originated by the system, this is the number associated with the device. For the interworking call, this object contains the translated calling party number if there is a translation rule is associated with dial plan for making this outgoing call.
If not available this is a zero-length string.
cctHistoryMpBundleId
1.3.6.1.4.1.9.9.163.1.3.7.1.26
Unsigned32
Multilink PPP bundle identification for call if cctHistoryServiceType has the value 'mp'.
If the value of cctHistoryServiceType for this call is not 'mp', then the value of this object is not meaningful.
cctHistoryChargedUnits
1.3.6.1.4.1.9.9.163.1.3.7.1.27
Gauge32
The number of charged units for this connection. For incoming calls or if charging information is not supplied by the switch, the value of this object will be zero. Reference: AOC-D defined in ETSI Standard: ETS 300 179
cctHistoryReceiveBytes
1.3.6.1.4.1.9.9.163.1.3.7.1.28
Gauge32 · bytes
The number of bytes received on the call. All the 'raw' bytes are counted including any protocol headers which may or may not be present depending on the value of cctHistoryServiceType.
cctHistoryTransmitBytes
1.3.6.1.4.1.9.9.163.1.3.7.1.29
Gauge32 · bytes
The number of bytes transmitted on the call. All the 'raw' bytes are counted including any protocol headers which may or may not be present depending on the value of cctHistoryServiceType.
cctHistoryDisconnectTime
1.3.6.1.4.1.9.9.163.1.3.7.1.30
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when call was disconnected.
This is when the system initiates, detects, or is notified of call termination.
This is the call duration from initial setup request.
cctHistoryDisconnectReasonText
1.3.6.1.4.1.9.9.163.1.3.7.1.31
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
Text description of the disconnect reason provided.
Value is zero-length string if no text is available.
cctHistoryCallSignalingType
1.3.6.1.4.1.9.9.163.1.3.7.1.32
CctCallSigType1 = unknown2 = external3 = q9314 = autoDetectRepresents supported signaling types for a call.
Unknown - Signaling origin of call type unknown.
External - Signaling origin of call type by external
agent e.g. MGCP, H.248
Q931 - Signaling origin of call type by Q.931/ISDN
Autodetect - Signaling of call type by automatic detection · Integer32
Signaling type used to setup the call.
Trap details
cctCallSetupNotification
1.3.6.1.4.1.9.9.163.2.0.1
A Call Tracker Setup notification is generated whenever a new active call entry is created in the cctActiveTable.
cctActiveSetupTime
1.3.6.1.4.1.9.9.163.1.2.3.1.2
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Value of sysUpTime when the call is first made known to the system.
cctActiveCalledPartyId
1.3.6.1.4.1.9.9.163.1.2.3.1.22
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a
The called telephone number for this call. For calls answered by the system, this corresponds to the Dialed Number Identification (DNIS).
For calls originated by the system, this is the destination number.
If not available this is a zero-length string.
cctActiveCallingPartyId
1.3.6.1.4.1.9.9.163.1.2.3.1.23
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a
The calling telephone number for this call. For calls answered by the system, this corresponds to the calling identification (CLID).
For calls originated by the system, this is the number associated with the device. For the interworking call, this object contains the translated calling party number if there is a translation rule is associated with dial plan for making this outgoing call.
If not available this is a zero-length string.
cctActiveCallCategory
1.3.6.1.4.1.9.9.163.1.2.3.1.13
CctCallCategory1 = none2 = other3 = modem4 = isdnSync5 = v1106 = v1207 = casDigital8 = mgcpData9 = syncData10 = lapb-taRepresents possible call categories or types.
none - No call category associated with call
other - None of the following
modem - Modem call
isdn-sync - ISDN sync digital call
Now mapped to syncData
v110 - V110 Call
v120 - V120 Call
cas-digital - Channel Associated Signaling (CAS) 56k data call
mgcpData - MGCP data call
Now mapped to syncData
syncData - Sync digital data call for any
call control
lapb-ta - LAPB or LAPB-TA call · Integer32
The call category or type
cctCallTerminateNotification
1.3.6.1.4.1.9.9.163.2.0.2
A Call Tracker Terminate notification is generated whenever a new history call entry is created in the cctHistoryTable.
cctHistoryCallId
1.3.6.1.4.1.9.9.163.1.3.7.1.2
CctCallIdRepresents a Call Identifier. The call identifier is a monotonically assigned, positive integer which uniquely identifies the call within the system. (1..4294967295) · Unsigned32
The call identifier for the call. This is the same value assigned to the call in cctActiveCallId when it was in the cctActiveTable.
It is possible for two cctHistoryEntry entries to have the same cctHistoryCallId if one very long running call terminates after the cctActiveCallId has wrapped around and is reassigned to a new short lived call.