EZ5 MIB Catalog

CISCO-CASA-FA-MIB

2002-09-18

This MIB module in conjunction with the CISCO-CASA-MIB, defines the SNMP management information base for managing the Cisco Appliance Services Architecture (CASA) Forwarding Agent. The following is a set of definitions used in the rest of the MIB. CASA is a protocol allowing software entities (called Appliances, examples are web caches, firewalls, load balancers) to control the behavior of network hardware devices (called Forwarding Agents, examples are switches or routers) by providing a set of rules used to handle network traffic. A Network Appliance (referred to as an Appliance) is any subsystem whose purpose is to provide a specific additional value-added service to the network device, and could be implemented as a standalone box, a line card or processor card, or a software subsystem. Examples of Network Appliances would include Load Balancers, WebCaches, and Firewalls. An Appliance tells Fowarding Agents how to handle packets based on their source and destination IP addresses and ports, and IP protocol fields. This set of information is called an Affinity. A Service Manager is an Appliance that requests packet flows from Forwarding Agents through CASA. A Real Server is a physical computing engine or part of that physical computing engine that offers one or more application services to a set of clients in the network. A packet flow is a TCP connection or a sequence of UDP packets between a client and a specific Real Server, pertaining to a specific application. Flows are represented by entries in the affinity cache tables. The Service Manager requests packet flows from Forwarding Agents by sending Affinities which contains wildcards on some of the Affinity fields. Affinities that contain wildcards in some of the fields are called Wildcard Affinities. The Service Manager may send the Forwarding Agent an Affinity containing explicit values for each of the fields. These Affinities are called Fixed Affinities. Typically Wildcard Affinities are used to instruct the Forwarding Agent to send packets received by the Forwarding Agent, which match the Wildcard Affinity, to the Service Manager. When the Service Manager receives the matching packet, the Service Manager typically will send the Forwarding Agent a Fixed Affinity. The Forwarding Agent uses Fixed Affinities to match packets coming from the network, execute any processing required on that packet, and forward that packet to a destination IP address (designated in the Fixed Affinity) called the Dispatch Address. When an IP packet arrives at the Forwarding Agent, the Forwarding Agent attempts to match the packet with the Fixed Affinities in the Fixed Affinity cache. If there is no match, an attempt is made to match the packet with the list of Wildcard Affinities. If there is no match the packet is routed normally. If there is a match with a Wildcard Affinity, the Forwarding Agent sends the packet to the Service Manager who will send the Forwarding Manager a Fixed Affinity which provides information on how to process IP packets similar to the one received by the Forwarding Agent. Processing of such packets may include sending the packet to the Service Manager. Such packets are called Interest Packets. Alternatively a Tickle Packet may be sent to the Service Manager which is an indication that a matched packet has been received by the Forwarding Agent. Reference: [1] Cisco Appliance Services Architecture (CASA) document. [2] CISCO-CASA-MIB. Diagram showing Forwarding Agents, Service Manager, Real Server and clients. ______ ______ ______ (Real ) (Real ) (Real ) (Server) (Server) (Server) (______) (______) (______) | | | +---------------+ | | | |Service Manager|-+----------+--------------+ | +---------------+ | | | | | ++---------+ ++---------+ ++---------+ | F. Agent | | F. Agent | | F. Agent | +----------+ +----------+ +----------+ | | | ___|_________________|______________|__ ( ) ( N E T W O R K ) (_______________________________________)

Download CISCO-CASA-FA-MIB.txt Open CISCO-CASA-FA-MIB.txt in a new tab

SCALARS (9) · TABLES (3) · TRAPS (2)

Scalars (9)

NameOID
ccfaWildcardAffTotalBytes1.3.6.1.4.1.9.9.115.1.3.1
ccfaWildcardAffHCTotalBytes1.3.6.1.4.1.9.9.115.1.3.2
ccfaWildcardAffTotalPackets1.3.6.1.4.1.9.9.115.1.3.3
ccfaWildcardAffNumOf1.3.6.1.4.1.9.9.115.1.3.4
ccfaWildcardAffNotifEnabled1.3.6.1.4.1.9.9.115.1.3.5
ccfaWildcardAffHiWtrMark1.3.6.1.4.1.9.9.115.1.3.7
ccfaWildAffCacheHiWtrMarkReset1.3.6.1.4.1.9.9.115.1.3.8
ccfaWildcardAffDenies1.3.6.1.4.1.9.9.115.1.3.9
ccfaWildcardAffDrops1.3.6.1.4.1.9.9.115.1.3.10

Tables (3)

NameOID
ccfaWildcardAffTable1.3.6.1.4.1.9.9.115.1.3.6
ccfaDispatchStatsTable1.3.6.1.4.1.9.9.115.1.4.1
ccfaAdvertisedDispatchTable1.3.6.1.4.1.9.9.115.1.4.2

Traps (2)

NameOID
ciscoCasaFaWildcardAffCreated1.3.6.1.4.1.9.9.115.2.1
ciscoCasaFaWildcardAffDeleted1.3.6.1.4.1.9.9.115.2.2

END OF TOC

Scalar details

ccfaWildcardAffTotalBytes

1.3.6.1.4.1.9.9.115.1.3.1

Counter32 · bytes

Number of bytes of data for all the packets which matched any Wildcard Affinity.

ccfaWildcardAffHCTotalBytes

1.3.6.1.4.1.9.9.115.1.3.2

Counter64 (0..18446744073709551615) · bytes

Number of bytes of data for all the packets which matched any Wildcard Affinity. This object is a 64-bit version of ccfaWildcardAffTotalBytes.

ccfaWildcardAffTotalPackets

1.3.6.1.4.1.9.9.115.1.3.3

Counter32 · packets

Number of packets that matched any Wildcard Affinity.

ccfaWildcardAffNumOf

1.3.6.1.4.1.9.9.115.1.3.4

Gauge32 · affinities

This is the number of Wildcard Affinities for which this Forwarding Agent is actively using for handling TCP and UDP packets. This is the number of entries in ccfaWildcardAffTable.

ccfaWildcardAffNotifEnabled

1.3.6.1.4.1.9.9.115.1.3.5

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

true indicates that ciscoCasaFaWildcardAffCreated and ciscoCasaFaWildcardAffDeleted notification generation is enabled. false indicates that ciscoCasaFaWildcardAffCreated and ciscoCasaFaWildcardAffDeleted notification generation is disabled.

ccfaWildcardAffHiWtrMark

1.3.6.1.4.1.9.9.115.1.3.7

Unsigned32 · affinities

This is the maximum number of Wildcard Affinities (high water mark) concurrently held in the Wildcard Affinity cache since last time cCasaState transitioned to cCasaEnabled or since this object was reset. Resetting this object is achieved by setting this object to 0. Attempting to set this object to any other value will result in a wrongValue error.

ccfaWildAffCacheHiWtrMarkReset

1.3.6.1.4.1.9.9.115.1.3.8

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

This indicates when ccfaWildcardAffHiWtrMark was set to 0.

ccfaWildcardAffDenies

1.3.6.1.4.1.9.9.115.1.3.9

Counter32 · affinities

This is the number of Wildcard Affinities for which this Forwarding Agent was not able to accept (i.e. denied) because a mandatory action item included with the Wildcard Affinity was not supported by this Forwarding Agent.

ccfaWildcardAffDrops

1.3.6.1.4.1.9.9.115.1.3.10

Counter32 · affinities

This is the number of Wildcard Affinities for which this Forwarding Agent did not process (i.e. dropped). This can happen because of low resource conditions prevailing in the Forwarding Agent, such as low memory.

Table details

ccfaWildcardAffTable

1.3.6.1.4.1.9.9.115.1.3.6

Index: ccfaWildcardAffIndex

List of Wildcard Affinity entries, which contain stats on each Wildcard Affinity supported by the Forwarding Agent. This is a dynamic table. Entries are created when the Service Manager sends Wildcard Affinities to this Forwarding Agent, and deleted upon instruction from the Service Manager.

ccfaWildcardAffIndex

1.3.6.1.4.1.9.9.115.1.3.6.1.1

CasaWildcardAffIndexThis is unique identifier for a Wildcard Affinity. SIZE (32) · OCTET STRING

The value of this index uniquely identifies this Wildcard Affinity from others in the table.

ccfaWildcardAffSourceAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.2

IpAddress SIZE (4)

The value used to compare the source IP address of the TCP and UDP packets. When the comparison is done, ccfaWildcardAffSourceMask is used as the mask on this object.

ccfaWildcardAffDestinationAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.3

IpAddress SIZE (4)

The value used to compare the destination IP address of the TCP and UDP packets. When the comparison is done, ccfaWildcardAffDestinationMask is used as the mask on this object.

ccfaWildcardAffSourcePort

1.3.6.1.4.1.9.9.115.1.3.6.1.4

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The value used to compare the source port of the TCP and UDP packets. A value of 0 means all port numbers will match.

ccfaWildcardAffDestinationPort

1.3.6.1.4.1.9.9.115.1.3.6.1.5

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The value used to compare the destination port of the TCP and UDP packets. A value of 0 means all port numbers will match.

ccfaWildcardAffProtocol

1.3.6.1.4.1.9.9.115.1.3.6.1.6

CiscoIpProtocolIP protocol number range.Reference: Internet Protocol. J. Postel. RFC791 (0..255) · Integer32

The value used to compare the IP Protocol field of the TCP and UDP packets. A value of 0 means all protocol numbers will match.

ccfaWildcardAffFragment

1.3.6.1.4.1.9.9.115.1.3.6.1.7

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

True indicates that fragments are to be sent to the Service Manager, false indicates that fragments are compared against fields in this Wildcard Affinity for a possible match in which case the fragment is sent to the Service Manager.

ccfaWildcardAffSourceMask

1.3.6.1.4.1.9.9.115.1.3.6.1.8

IpAddress SIZE (4)

The IP mask indicating which bits in the ccfaWildcardAffSourceAddr are relevant. For each set bit in this mask, the corresponding bits in ccfaWildcardAffSourceAddr and the source IP address of the received packet must be equal in order to match this Wildcard Affinity.

ccfaWildcardAffDestinationMask

1.3.6.1.4.1.9.9.115.1.3.6.1.9

IpAddress SIZE (4)

The IP mask indicating which bits in the ccfaWildcardAffDestinationAddr are relevant. For each set bit in this mask, the corresponding bits in ccfaWildcardAffDestinationAddr and the destination IP address of the received packet must be equal in order to match this Wildcard Affinity.

ccfaWildcardAffSvcManagerAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.10

IpAddress SIZE (4)

CASA Service Manager IP address to which packets matching this Wildcard Affinity are forwarded.

ccfaWildcardAffSvcManagerPort

1.3.6.1.4.1.9.9.115.1.3.6.1.11

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The Service Manager port to which packets matching this Wildcard Affinity are fowarded.

ccfaWildcardAffBytes

1.3.6.1.4.1.9.9.115.1.3.6.1.12

Counter32 · bytes

Number of bytes in packets which matched this Wildcard Affinity or any Fixed Affinity associated with this Wildcard Affinity, that were forwarded to the destination IP address.

ccfaWildcardAffHCBytes

1.3.6.1.4.1.9.9.115.1.3.6.1.13

Counter64 (0..18446744073709551615) · bytes

Number of bytes in packets which matched this Wildcard Affinity or any Fixed Affinity associated with this Wildcard Affinity, that were forwarded to the destination IP address. This object is a 64-bit version of ccfaWildcardAffBytes.

ccfaWildcardAffPackets

1.3.6.1.4.1.9.9.115.1.3.6.1.14

Counter32 · packets

Number of packets which matched this Wildcard Affinity or any Fixed Affinity associated with this Wildcard Affinity, that were forwarded to the destination IP address.

ccfaWildcardAffHCPackets

1.3.6.1.4.1.9.9.115.1.3.6.1.15

Counter64 (0..18446744073709551615) · packets

Number of packets which matched this Wildcard Affinity or any Fixed Affinity associated with this Wildcard Affinity, that were forwarded to the destination IP address. This object is a 64-bit version of ccfaWildcardAffPackets.

ccfaWildcardAffFlows

1.3.6.1.4.1.9.9.115.1.3.6.1.16

Gauge32 · affinities

From a logical point of view, this is the number of TCP/UDP flows resulting from packets received which matched this Wildcard Affinity. A flow is a sequence of IP packets from a specific client to a specific real server going through this Forwarding Agent. Literally this is the current number of Fixed Affinity entries in the Fixed Affinity cache, that were put there as a result of packets matching this Wildcard Affinity.

ccfaWildcardAffInsertTime

1.3.6.1.4.1.9.9.115.1.3.6.1.17

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

Date and time when this Wildcard Affinity was inserted into this table.

ccfaWildcardAffInterestTimeouts

1.3.6.1.4.1.9.9.115.1.3.6.1.18

Counter32

Number of expected Fixed Affinities that were not received from the Service Manager within a period of time from when a Fixed Affinity was requested by this Forwarding Agent.

ccfaWildcardAffAdvertiseDestAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.19

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

true indicates that the IP address defined by ccfaWildcardAffDestinationAddr is to be advertised by the routing protocol in this Forwarding Agent. false indicates that the IP address is not to be advertised.

ccfaWildcardAffInterestAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.20

IpAddress SIZE (4)

The IP address of the CASA entity to which Interest Packets should be forwarded by this Forwarding Agent.

ccfaWildcardAffInterestPort

1.3.6.1.4.1.9.9.115.1.3.6.1.21

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The UDP port of the CASA entity to which Interest Packets should be forwarded by this Forwarding Agent.

ccfaWildAffInterestPacketSpec

1.3.6.1.4.1.9.9.115.1.3.6.1.22

CasaInterestPacketSpecificationThis enumerates the possible combinations of criteria for which a packet is considered interesting. A packet matching the specified combination of the following criteria is sent to the device specified by ccfaWildcardAffInterestAddr and ccfaWildcardAffInterestPort. The criteria enumeration follows: intFin - A packet which has the FIN bit set in the control bits of the TCP header [1]. intSyn - A packet which has the SYN bit set in the control bits of the TCP header [1]. intRst - A packet which has the RST bit set in the control bits of the TCP header [1]. intPsh - A packet which has the PSH bit set in the control bits of the TCP header [1]. intAck - A packet which has the ACK bit set in the control bits of the TCP header [1]. intUrg - A packet which has the URG bit set in the control bits of the TCP header [1]. intData - For a TCP/IP flow, this is a packet which contains payload data, i.e. a packet which is not associated with TCP connection establishment, termination or some other session control packet. For a UDP flow, this corresponds to all packets. intFirstData - For a TCP/IP flow, this corresponds to the first non control packet. For a UDP flow, this corresponds to the first packet on the flow. intFrag - Fragmented packets which match IP src and dest IP address of the Fixed Affinity. intAllPackets - All packets. These are encoded in an octet string in the order listed above, such that intFin is the least significant byte of the octet string. Reference: [1] Transmission Control Protocol. J. Postel. RFC793 SIZE (16) · OCTET STRING

The criteria used to identify an Interest Packet. When such a packet is identified, that packet is sent to the entity described by ccfaWildcardAffInterestAddr and ccfaWildcardAffInterestPort.

ccfaWildAffInterestTickelSpec

1.3.6.1.4.1.9.9.115.1.3.6.1.23

CasaInterestPacketSpecificationThis enumerates the possible combinations of criteria for which a packet is considered interesting. A packet matching the specified combination of the following criteria is sent to the device specified by ccfaWildcardAffInterestAddr and ccfaWildcardAffInterestPort. The criteria enumeration follows: intFin - A packet which has the FIN bit set in the control bits of the TCP header [1]. intSyn - A packet which has the SYN bit set in the control bits of the TCP header [1]. intRst - A packet which has the RST bit set in the control bits of the TCP header [1]. intPsh - A packet which has the PSH bit set in the control bits of the TCP header [1]. intAck - A packet which has the ACK bit set in the control bits of the TCP header [1]. intUrg - A packet which has the URG bit set in the control bits of the TCP header [1]. intData - For a TCP/IP flow, this is a packet which contains payload data, i.e. a packet which is not associated with TCP connection establishment, termination or some other session control packet. For a UDP flow, this corresponds to all packets. intFirstData - For a TCP/IP flow, this corresponds to the first non control packet. For a UDP flow, this corresponds to the first packet on the flow. intFrag - Fragmented packets which match IP src and dest IP address of the Fixed Affinity. intAllPackets - All packets. These are encoded in an octet string in the order listed above, such that intFin is the least significant byte of the octet string. Reference: [1] Transmission Control Protocol. J. Postel. RFC793 SIZE (16) · OCTET STRING

The criteria used to identify an Interest Packet resulting in a Tickle Packet being sent to the entity described by ccfaWildcardAffInterestAddr and ccfaWildcardAffInterestPort.

ccfaWildcardAffDispatch

1.3.6.1.4.1.9.9.115.1.3.6.1.24

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

true indicates that the MAC address of the IP packet should be modified to that of the dispatch entity who's IP address is given by ccfaWildcardAffDispatchAddr, prior to transmitting the packet on the interface. If ccfaWildcardAffDispatchAddr has value 0.0.0.0 then the Forwarding Agent will discard the packet. false indicates that the MAC address is not to be translated.

ccfaWildcardAffDispatchAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.25

IpAddress SIZE (4)

The IP address of the dispatch entity for packets matching Fixed Affinities derived from this Wildcard Affinity.

ccfaDispatchStatsTable

1.3.6.1.4.1.9.9.115.1.4.1

Index: ccfaDispatchAddress

Table of traffic statistics between this Forwarding Agent and the dispatch IP address. The statistics are gathered by the Forwarding agent and are relative to the Forwarding Agent.

ccfaDispatchAddress

1.3.6.1.4.1.9.9.115.1.4.1.1.1

IpAddress SIZE (4)

Dispatch Address of the remote entity for which these statistics are related to.

ccfaDispatchBytesIn

1.3.6.1.4.1.9.9.115.1.4.1.1.2

Counter32 · bytes

Number of bytes received by this Fowarding Agent from the Dispatch Address.

ccfaDispatchHCBytesIn

1.3.6.1.4.1.9.9.115.1.4.1.1.3

Counter64 (0..18446744073709551615) · bytes

Number of bytes received by this Fowarding Agent from the Dispatch Address. This object is a 64-bit version of ccfaDispatchBytesIn.

ccfaDispatchBytesOut

1.3.6.1.4.1.9.9.115.1.4.1.1.4

Counter32 · bytes

Number of bytes sent by this Fowarding Agent to the Dispatch Address.

ccfaDispatchHCBytesOut

1.3.6.1.4.1.9.9.115.1.4.1.1.5

Counter64 (0..18446744073709551615) · bytes

Number of bytes sent by this Fowarding Agent to the Dispatch Address. This object is a 64-bit version of ccfaDispatchBytesOut.

ccfaDispatchPacketsIn

1.3.6.1.4.1.9.9.115.1.4.1.1.6

Counter32 · packets

Packets received by this Fowarding Agent from the Dispatch Address.

ccfaDispatchHCPacketsIn

1.3.6.1.4.1.9.9.115.1.4.1.1.7

Counter64 (0..18446744073709551615) · packets

Packets received by this Fowarding Agent from the Dispatch Address. This object is a 64-bit version of ccfaDispatchPacketsIn.

ccfaDispatchPacketsOut

1.3.6.1.4.1.9.9.115.1.4.1.1.8

Counter32 · packets

Packets sent by this Fowarding Agent to the Dispatch Address.

ccfaDispatchHCPacketsOut

1.3.6.1.4.1.9.9.115.1.4.1.1.9

Counter64 (0..18446744073709551615) · packets

Packets sent by this Fowarding Agent to the Dispatch Address. This object is a 64-bit version of ccfaDispatchPacketsOut.

ccfaDispatchFlows

1.3.6.1.4.1.9.9.115.1.4.1.1.10

Gauge32 · affinities

From a logical point of view, this is the number of TCP/UDP flows resulting from packets received which matched any Wildcard Affinity active in this Forwarding Agent. This is current number of Fixed Affinity entries whose destination IP address is equal to ccfaDispatchAddress.

ccfaAdvertisedDispatchTable

1.3.6.1.4.1.9.9.115.1.4.2

Index: ccfaAdvertisedAddress

This table correlates dispatch addresses with their corresponding advertised address.

ccfaAdvertisedAddress

1.3.6.1.4.1.9.9.115.1.4.2.1.1

IpAddress SIZE (4)

The advertised IP Address. This corresponds to ccfaWildcardAffDestinationAddr with ccfaWildcardAffAdvertiseDestAddr set to true.

ccfaAdvertisedDispatchAddress

1.3.6.1.4.1.9.9.115.1.4.2.1.2

IpAddress SIZE (4)

Dispatch Address of the remote entity for which these statistics are related to.

Trap details

ciscoCasaFaWildcardAffCreated

1.3.6.1.4.1.9.9.115.2.1

This notification indicates that this CASA Forwarding Agent has created a Wildcard Affinity entry. This is gated on ccfaWildcardAffNotifEnabled.

ccfaWildcardAffSourceAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.2

IpAddress SIZE (4)

The value used to compare the source IP address of the TCP and UDP packets. When the comparison is done, ccfaWildcardAffSourceMask is used as the mask on this object.

ccfaWildcardAffDestinationAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.3

IpAddress SIZE (4)

The value used to compare the destination IP address of the TCP and UDP packets. When the comparison is done, ccfaWildcardAffDestinationMask is used as the mask on this object.

ccfaWildcardAffSourcePort

1.3.6.1.4.1.9.9.115.1.3.6.1.4

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The value used to compare the source port of the TCP and UDP packets. A value of 0 means all port numbers will match.

ccfaWildcardAffDestinationPort

1.3.6.1.4.1.9.9.115.1.3.6.1.5

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The value used to compare the destination port of the TCP and UDP packets. A value of 0 means all port numbers will match.

ccfaWildcardAffProtocol

1.3.6.1.4.1.9.9.115.1.3.6.1.6

CiscoIpProtocolIP protocol number range.Reference: Internet Protocol. J. Postel. RFC791 (0..255) · Integer32

The value used to compare the IP Protocol field of the TCP and UDP packets. A value of 0 means all protocol numbers will match.

ccfaWildcardAffFragment

1.3.6.1.4.1.9.9.115.1.3.6.1.7

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

True indicates that fragments are to be sent to the Service Manager, false indicates that fragments are compared against fields in this Wildcard Affinity for a possible match in which case the fragment is sent to the Service Manager.

ccfaWildcardAffSourceMask

1.3.6.1.4.1.9.9.115.1.3.6.1.8

IpAddress SIZE (4)

The IP mask indicating which bits in the ccfaWildcardAffSourceAddr are relevant. For each set bit in this mask, the corresponding bits in ccfaWildcardAffSourceAddr and the source IP address of the received packet must be equal in order to match this Wildcard Affinity.

ccfaWildcardAffDestinationMask

1.3.6.1.4.1.9.9.115.1.3.6.1.9

IpAddress SIZE (4)

The IP mask indicating which bits in the ccfaWildcardAffDestinationAddr are relevant. For each set bit in this mask, the corresponding bits in ccfaWildcardAffDestinationAddr and the destination IP address of the received packet must be equal in order to match this Wildcard Affinity.

ccfaWildcardAffSvcManagerAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.10

IpAddress SIZE (4)

CASA Service Manager IP address to which packets matching this Wildcard Affinity are forwarded.

ccfaWildcardAffSvcManagerPort

1.3.6.1.4.1.9.9.115.1.3.6.1.11

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The Service Manager port to which packets matching this Wildcard Affinity are fowarded.

ciscoCasaFaWildcardAffDeleted

1.3.6.1.4.1.9.9.115.2.2

This notification indicates that this CASA Forwarding Agent has deleted this Wildcard Affinity entry. This is gated on ccfaWildcardAffNotifEnabled.

ccfaWildcardAffSourceAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.2

IpAddress SIZE (4)

The value used to compare the source IP address of the TCP and UDP packets. When the comparison is done, ccfaWildcardAffSourceMask is used as the mask on this object.

ccfaWildcardAffDestinationAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.3

IpAddress SIZE (4)

The value used to compare the destination IP address of the TCP and UDP packets. When the comparison is done, ccfaWildcardAffDestinationMask is used as the mask on this object.

ccfaWildcardAffSourcePort

1.3.6.1.4.1.9.9.115.1.3.6.1.4

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The value used to compare the source port of the TCP and UDP packets. A value of 0 means all port numbers will match.

ccfaWildcardAffDestinationPort

1.3.6.1.4.1.9.9.115.1.3.6.1.5

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The value used to compare the destination port of the TCP and UDP packets. A value of 0 means all port numbers will match.

ccfaWildcardAffProtocol

1.3.6.1.4.1.9.9.115.1.3.6.1.6

CiscoIpProtocolIP protocol number range.Reference: Internet Protocol. J. Postel. RFC791 (0..255) · Integer32

The value used to compare the IP Protocol field of the TCP and UDP packets. A value of 0 means all protocol numbers will match.

ccfaWildcardAffFragment

1.3.6.1.4.1.9.9.115.1.3.6.1.7

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

True indicates that fragments are to be sent to the Service Manager, false indicates that fragments are compared against fields in this Wildcard Affinity for a possible match in which case the fragment is sent to the Service Manager.

ccfaWildcardAffSourceMask

1.3.6.1.4.1.9.9.115.1.3.6.1.8

IpAddress SIZE (4)

The IP mask indicating which bits in the ccfaWildcardAffSourceAddr are relevant. For each set bit in this mask, the corresponding bits in ccfaWildcardAffSourceAddr and the source IP address of the received packet must be equal in order to match this Wildcard Affinity.

ccfaWildcardAffDestinationMask

1.3.6.1.4.1.9.9.115.1.3.6.1.9

IpAddress SIZE (4)

The IP mask indicating which bits in the ccfaWildcardAffDestinationAddr are relevant. For each set bit in this mask, the corresponding bits in ccfaWildcardAffDestinationAddr and the destination IP address of the received packet must be equal in order to match this Wildcard Affinity.

ccfaWildcardAffSvcManagerAddr

1.3.6.1.4.1.9.9.115.1.3.6.1.10

IpAddress SIZE (4)

CASA Service Manager IP address to which packets matching this Wildcard Affinity are forwarded.

ccfaWildcardAffSvcManagerPort

1.3.6.1.4.1.9.9.115.1.3.6.1.11

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The Service Manager port to which packets matching this Wildcard Affinity are fowarded.

ccfaWildcardAffFlows

1.3.6.1.4.1.9.9.115.1.3.6.1.16

Gauge32 · affinities

From a logical point of view, this is the number of TCP/UDP flows resulting from packets received which matched this Wildcard Affinity. A flow is a sequence of IP packets from a specific client to a specific real server going through this Forwarding Agent. Literally this is the current number of Fixed Affinity entries in the Fixed Affinity cache, that were put there as a result of packets matching this Wildcard Affinity.

↑ To TOC