This MIB module defines objects that describe the configuration of the authentication manager for the Cisco Content Delivery System for TV (CDS-TV).
CDS-TV is a suite of products and software applications providing ingest, storage, caching, streaming, playout and on-demand delivery of video to television or set-top-box clients.
Authentication Manager is an optional feature of CDS-TV and is only for specific RTSP environments (EventIS). The Authentication Manager communicates with the back-office to validate a request received from a set-top box before setting up a session.
Abbreviations:
CCP Cache Control Protocol
CDS Content Delivery System
CORBA Common Object Request Broker Architecture
ISA Interactive Services Architecture
ISV Integrated Streamer-Vault
FSI File Service Interface
FTP File Transfer Protocol
MPEG Motion Picture Experts Group
MSA Managed Services Architecture
QAM Quadrature Amplitude Modulation
RTSP Real-Time Streaming Protocol
SOAP Simple Object Access Protocol
STB Set-Top Box
VOD Video On-Demand
Common terms:
Catcher: Device responsible for receiving content (typically via satellite dishes and antennae) from content providers or from a Headend-In-The-Sky.
Content Ingest: Acquisition of content from a source such as a catcher or an FTP server for storing it locally and making it available to streamers as needed.
TRAXIS: A part of the proprietary EventIS VOD back-office solution for transaction, session and resource management that communicates with VOD client applications, edge QAM devices, video servers and conditional access systems.
Device Roles:
Vault: Content delivery application responsible for ingesting and storing video content and making it available to streamers and/or caching nodes.
Caching Nodes: Content delivery application responsible for caching content from vault (using CCP) and then streaming content out to streamers over HTTP or CCP.
Streamer: Content delivery application responsible for streaming video out to STB's.
ISV: Content delivery application capable of acting as both a vault and as a streamer in a single device.
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object specifies the type of Authentication Manager IP address, specified by cdstvAuthMgrAddress.
cdstvAuthMgrAddress
1.3.6.1.4.1.9.9.751.1.2
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This object specifies the Authentication Manager IP address, typically the same as that of the master streamer, since the Authentication Manager resides on the master streamer. The type
of the address is specified by cdstvAuthMgrAddressType.
cdstvAuthMgrPort
1.3.6.1.4.1.9.9.751.1.3
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
This object specifies the Authentication Manager port number.
cdstvAuthMgrEventIsAddressType
1.3.6.1.4.1.9.9.751.1.4
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object specifies the type of the IP address (specified by cdstvAuthMgrEventIsAddressType) of the EventIS server.
cdstvAuthMgrEventIsAddress
1.3.6.1.4.1.9.9.751.1.5
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This object specifies the address or domain name of the EventIS server. The type of the address is specified by cdstvAuthMgrEventIsAddressType.
cdstvAuthMgrEventIsPort
1.3.6.1.4.1.9.9.751.1.6
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
This object specifies the port number on the EventIS server used to receive authentication requests.
cdstvAuthMgrTraxisSoapInterface
1.3.6.1.4.1.9.9.751.1.7
CiscoURLStringOrEmptyThis textual convention is an extension of CiscoURLString. This extension permits the additional value of empty (zero length) string. The description of any object which uses this syntax must specifically describe the meaning of empty string value.Reference: Uniform Resource Locators. RFC 1738. SIZE (0..255) · OCTET STRING
This object specifies the URL (including the address, port, and logical partition) on the Streamer used to receive messages about session tear-downs from TRAXIS.
cdstvAuthMgrServerThreadPool
1.3.6.1.4.1.9.9.751.1.8
Unsigned32
This object specifies the number of threads in the Authentication Manager server pool that are used to process authentication requests for the duration of the connection.
cdstvAuthMgrDebugLevel
1.3.6.1.4.1.9.9.751.1.9
INTEGER1 = off2 = low3 = high · Integer32
This object specifies the amount of debugging information logged. off(1) - Logging is disabled. low(2) - Errors and minimal information are logged. high(3) - Errors, warnings, and full information is logged.