EZ5 MIB Catalog

CISCO-CDSTV-FSI-MIB

2010-05-10

This MIB module defines FSI configurartion objects that faciliate the management of the Cisco Content Delivery System for TV (CDS-TV) product family. CDS-TV is a suite of products and software applications providing ingest, storage, caching, streaming, playout and on-demand delivery of video to television or set-top-box clients. Abbreviations: CDS Content Delivery System ISA Interactive Services Architecture ISV Integrated Streamer-Vault FSI File Service Interface FTP File Transfer Protocol MPEG Motion Picture Experts Group MSA Managed Services Architecture RTSP Real-Time Streaming Protocol STB Set-Top Box Common terms: Catcher: Device responsible for receiving content (typically via satellite dishes and antennae) from content providers or from a Headend-In-The-Sky. Content Ingest: Acquisition of content from a source such as a catcher or an FTP server for storing it locally and making it available to streamers as needed. Vault: Content delivery application responsible for ingesting and storing video content and making it available to streamers. Streamer: Content delivery application responsible for streaming video out to STB's.

Download CISCO-CDSTV-FSI-MIB.txt Open CISCO-CDSTV-FSI-MIB.txt in a new tab

SCALARS (9)

Scalars (9)

NameOID
cdstvFsiIpAddressType1.3.6.1.4.1.9.9.735.1.1
cdstvFsiIpAddress1.3.6.1.4.1.9.9.735.1.2
cdstvFsiServerPort1.3.6.1.4.1.9.9.735.1.3
cdstvFsiFtpClientPort1.3.6.1.4.1.9.9.735.1.4
cdstvFsiFtpOutServerPort1.3.6.1.4.1.9.9.735.1.5
cdstvFsiFtpOutLoginTTL1.3.6.1.4.1.9.9.735.1.6
cdstvFsiLogLevel1.3.6.1.4.1.9.9.735.1.7
cdstvFsiContentRootPath1.3.6.1.4.1.9.9.735.1.8
cdstvFsiAsyncCallbackURL1.3.6.1.4.1.9.9.735.1.9

END OF TOC

Scalar details

cdstvFsiIpAddressType

1.3.6.1.4.1.9.9.735.1.1

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object specifies the type of the IP address (specified by cdstvFsiIpAddress) of the vault used in FSI communications with the back office.

cdstvFsiIpAddress

1.3.6.1.4.1.9.9.735.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object specifies the IP address of the vault used in FSI communications with the back office. Value of 0.0.0.0 allows all Layer-3 interfaces on the vault that are available to handle incoming IP trafic such as content ingest to be used for FSI. The type of this address is determined by the value of the cdstvFsiIpAddressType object.

cdstvFsiServerPort

1.3.6.1.4.1.9.9.735.1.3

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the port number on the vault used in FSI communications with the back office.

cdstvFsiFtpClientPort

1.3.6.1.4.1.9.9.735.1.4

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the port used by FSI communications when connecting to the catcher or other FTP server to pull content from.

cdstvFsiFtpOutServerPort

1.3.6.1.4.1.9.9.735.1.5

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the port used by FSI communications for egress FTP out pulls from the vault.

cdstvFsiFtpOutLoginTTL

1.3.6.1.4.1.9.9.735.1.6

Unsigned32 · hops

This object specifies the configured maximum Time To Live (TTL) that an FTP client is allowed to connect and login to the vault to perform an FTP out pull with a temporary login.

cdstvFsiLogLevel

1.3.6.1.4.1.9.9.735.1.7

INTEGER1 = off2 = low3 = high · Integer32

This object specifies the logging level, i.e., the amount of event information logged. 'off' indicates that logging is completely disabled. 'low' indicates that only errors are logged. 'high' indicates that all errors, warnings and success messages are logged.

cdstvFsiContentRootPath

1.3.6.1.4.1.9.9.735.1.8

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the root directory used to store MPEG content files on the vault, for example, '/files'.

cdstvFsiAsyncCallbackURL

1.3.6.1.4.1.9.9.735.1.9

CiscoURLStringThis textual convention defines the URL string. The Universal Resource Locator(URL). The URL strings are compact string representation for a resource available via internet. This is the address location of the page to load. The string should represent a fully qualifying string with the format 'protocol:/server/page'. In general the string should point to any value that can be saved/loaded. Any limitation for the URL must be defined as part of the description of any object which uses this syntax.Reference: Uniform Resource Locators. RFC 1738. SIZE (1..255) · OCTET STRING

This object specifies the asynchronous callback URL used in the recording completion FSI notification which is sent out when a scheduled recording completes its capture. This URL is basically used to tell the client the recording is completed.

↑ To TOC