This MIB module defines ingest manager configuration objects that faciliate the management of the Cisco Content Delivery System for TV (CDS-TV) product family.
CDS-TV is a suite of products and software applications providing ingest, storage, caching, streaming, playout and on-demand delivery of video to television or set-top-box clients.
Abbreviations:
CCP Cache Control Protocol
CDS Content Delivery System
CORBA Common Object Request Broker Architecture
ISA Interactive Services Architecture
ISV Integrated Streamer-Vault
FSI File Service Interface
FTP File Transfer Protocol
MPEG Motion Picture Experts Group
MSA Managed Services Architecture
RTSP Real-Time Streaming Protocol
STB Set-Top Box
Common terms:
Catcher: Device responsible for receiving content (typically via satellite dishes and antennae) from content providers or from a Headend-In-The-Sky.
Content Ingest: Acquisition of content from a source such as a catcher or an FTP server for storing it locally and making it available to streamers as needed.
Ingest Manager: CDS module that takes care of provisioned content objects by collecting metadata, sending messages to the appropriate subsystem to ingest the content, and sending messages to expire the content when the expiration period has passed.
Device Roles:
Vault: Content delivery application responsible for ingesting and storing video content and making it available to streamers and/or caching nodes.
Caching Nodes: Content delivery application responsible for caching content from vault (using CCP) and then streaming content out to streamers over HTTP or CCP.
Streamer: Content delivery application responsible for streaming video out to STB's.
ISV: Content delivery application capable of acting as both a vault and as a streamer in a single device.
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object specifies the type of the IP address (specified by cdstvIngestMgrHostAddress) of the Ingest Manager.
cdstvIngestMgrHostAddress
1.3.6.1.4.1.9.9.739.1.1.2
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This object specifies the IP address of the Ingest Manager. The type of this address is specified by cdstvIngestMgrHostAddressType.
cdstvIngestMgrPort
1.3.6.1.4.1.9.9.739.1.1.3
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
This object specifies the port number to use for listening for inbound connections.
cdstvIngestMgrFsiCallbackPort
1.3.6.1.4.1.9.9.739.1.1.4
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
This object specifies the port number to use for File Services Interface (FSI) callbacks.
cdstvIngestMgrAdditionalPackageWindow
1.3.6.1.4.1.9.9.739.1.1.5
Unsigned32 · days
This object specifies the additional amount of time to wait once the package expiration window has ended before destroying the stored content package. Typically, when the package expiration window ends, the ingested content package is destroyed from the device. The additional package window adds a grace period to the expiration window.
cdstvIngestMgrFtpTimeout
1.3.6.1.4.1.9.9.739.1.1.6
TimeIntervalSecA period of time, measured in units of 1 second. · Unsigned32
This object specifies the maximum period the Ingest Manager waits before timing out an FTP session and terminating the process.
cdstvIngestMgrUseAssetIdEnable
1.3.6.1.4.1.9.9.739.1.1.7
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object specifies whether to use the Asset ID (a unique ID assigned to each content ingested into the CDS) for the content name. 'true' indicates that Asset ID is used for the content name. 'false' indicates Asset ID is not used for the content name.
cdstvIngestMgrManageCorbaServices
1.3.6.1.4.1.9.9.739.1.1.8
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object specifies whether the CDS manages the CORBA services. 'true' indicates that CDS manages CORBA services. 'false' indicates that CDS does not manage CORBA services.
cdstvIngestMgrRequireNotifyService
1.3.6.1.4.1.9.9.739.1.1.9
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object specifies whether the CDS requires the use of ISA Notify Service. 'true' indicates that CDS requires the use of ISA Notify Service. 'false' indicates that CDS does not require the use of ISA Notify Service.
cdstvIngestMgrDebugLevel
1.3.6.1.4.1.9.9.739.1.1.10
INTEGER1 = errors2 = all3 = off · Integer32
This object specifies the amount of debugging information logged. errors(1) - Only error messages are logged. all(2) - Errors, warnings and success message are all logged. off(3) - Debugging is disabled.
cdstvIngestMgrMetaDataPublish
1.3.6.1.4.1.9.9.739.1.1.11
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object specifies whether content metadata is published or not. 'true' indicates that content metadata is published. 'false' indicates that content metadata is not published.
cdstvIngestMgrMetaPublishUrl
1.3.6.1.4.1.9.9.739.1.1.12
CiscoURLStringThis textual convention defines the URL string.
The Universal Resource Locator(URL). The URL strings
are compact string representation for a resource available via internet. This is the address location of the page to load. The string should represent a fully qualifying string with the format 'protocol:/server/page'. In general the string should point to any value that can be saved/loaded. Any limitation for the URL must be defined as part of the description of any object which uses this syntax.Reference: Uniform Resource Locators. RFC 1738. SIZE (1..255) · OCTET STRING
This object specifies the URL where the metadata is published, typically the back-office.
cdstvIngestMgrMetaPublishBackupUrl
1.3.6.1.4.1.9.9.739.1.1.13
CiscoURLStringOrEmptyThis textual convention is an extension of CiscoURLString. This extension permits the additional value of empty (zero length) string. The description of any object which uses this syntax must specifically describe the meaning of empty string value.Reference: Uniform Resource Locators. RFC 1738. SIZE (0..255) · OCTET STRING
This object specifies the URL of the backup server where the metadata is published. This string is empty if a backup server URL is not configured.
cdstvIngestMgrIngestInterface
1.3.6.1.4.1.9.9.739.1.2.1
BITS
This object specifies all ingest interfaces (methods) available, i.e. ISA, Cisco SOAP, Prodis SOAP or any combination of the three. isa(0) - ISA. ciscoSoap(1) - Cisco SOAP prodisSoap(2) - Prodis SOAP.
cdstvIngestMgrCiscoSoapUrl
1.3.6.1.4.1.9.9.739.1.2.2
CiscoURLStringOrEmptyThis textual convention is an extension of CiscoURLString. This extension permits the additional value of empty (zero length) string. The description of any object which uses this syntax must specifically describe the meaning of empty string value.Reference: Uniform Resource Locators. RFC 1738. SIZE (0..255) · OCTET STRING
This object specifies the URL (IP address, port, and directory) on the Vault used to receive content using the Cisco SOAP (Simple Object Access Protocol). An example of the Cisco SOAP URL is http://10.22.216.251:8793/CiscoAIM. This string is empty if Cisco SOAP is not used.
cdstvIngestMgrProdisSoapUrl
1.3.6.1.4.1.9.9.739.1.2.3
CiscoURLStringOrEmptyThis textual convention is an extension of CiscoURLString. This extension permits the additional value of empty (zero length) string. The description of any object which uses this syntax must specifically describe the meaning of empty string value.Reference: Uniform Resource Locators. RFC 1738. SIZE (0..255) · OCTET STRING
This object specifies the URL (IP address, port, and directory) on the Vault used to receive content using the Prodis SOAP(Simple Object Access Protocol). An example of the Prodis SOAP URL is http://10.22.216.251:8793/ProdisAIM. This string is empty if Prodis SOAP is not used.
cdstvIngestMgrBackOfficeMaxRetries
1.3.6.1.4.1.9.9.739.1.3.1
Unsigned32 (0..1000)
This object specifies the maximum number of times to retry a failed communication with the back-office.
cdstvIngestMgrBackOfficeRetryInterval
1.3.6.1.4.1.9.9.739.1.3.2
TimeIntervalMinA period of time, measured in units of 1 minute. · Unsigned32
This object specifies the amount of time to wait before retrying a failed communication with the back-office.
cdstvIngestMgrBackOfficeTimeout
1.3.6.1.4.1.9.9.739.1.3.3
TimeIntervalSecA period of time, measured in units of 1 second. · Unsigned32
This object specifies the amount of time to wait for the back-office to respond to a communication attempt.
This object specifies the type of content store used. none(1) - Content store is disabled. isa(2) - Use ISA content store. fsi(3) - Use FSI content store. ngod(4) - Use Next-Generation On-Demand (NGOD) content store. openStream(5) - Use OpenStream content store.
cdstvIngestMgrContentStoreUrl
1.3.6.1.4.1.9.9.739.1.4.2
CiscoURLStringOrEmptyThis textual convention is an extension of CiscoURLString. This extension permits the additional value of empty (zero length) string. The description of any object which uses this syntax must specifically describe the meaning of empty string value.Reference: Uniform Resource Locators. RFC 1738. SIZE (0..255) · OCTET STRING
This object specifies the URL where the content store is located. This string is empty if content store is disabled.
This object specifies the type of encryption used. none(1) - Encryption is disabled. verimatrix(2) - Use Verimatrix encryption. widevine(3) - Use Widevine encryption.
cdstvIngestMgrEncryptionTargetUrl
1.3.6.1.4.1.9.9.739.1.5.2
CiscoURLStringOrEmptyThis textual convention is an extension of CiscoURLString. This extension permits the additional value of empty (zero length) string. The description of any object which uses this syntax must specifically describe the meaning of empty string value.Reference: Uniform Resource Locators. RFC 1738. SIZE (0..255) · OCTET STRING
This object specifies the location on the encryption server used to send MPEG files for encryption, for example, http://192.168.128.54:7898/files/encrypted. This string will be empty if encryption is disabled.
cdstvIngestMgrEncryptionRetrievalUrl
1.3.6.1.4.1.9.9.739.1.5.3
CiscoURLStringOrEmptyThis textual convention is an extension of CiscoURLString. This extension permits the additional value of empty (zero length) string. The description of any object which uses this syntax must specifically describe the meaning of empty string value.Reference: Uniform Resource Locators. RFC 1738. SIZE (0..255) · OCTET STRING
This object specifies the location on the encryption server used to retrieve encrypted MPEG files, for example, ftp://192.168.128.54:7899/files/encrypted. This string will be empty if encryption is disabled.
Table details
cdstvIngestMgrBackOfficeTable
1.3.6.1.4.1.9.9.739.1.3.4
Index: cdstvIngestMgrBackOfficeIndex
A table containing the back-office type and URL settings.
cdstvIngestMgrBackOfficeIndex
1.3.6.1.4.1.9.9.739.1.3.4.1.1
Unsigned32
This object uniquely identifies a back-office.
cdstvIngestMgrBackOfficeType
1.3.6.1.4.1.9.9.739.1.3.4.1.2
INTEGER1 = none2 = totalManage · Integer32
This object specifies the type of back-office support used. none(1) - No back-office support. totalManage(2) - Use TotalManage back-office support.
cdstvIngestMgrBackOfficeUrl
1.3.6.1.4.1.9.9.739.1.3.4.1.3
CiscoURLStringOrEmptyThis textual convention is an extension of CiscoURLString. This extension permits the additional value of empty (zero length) string. The description of any object which uses this syntax must specifically describe the meaning of empty string value.Reference: Uniform Resource Locators. RFC 1738. SIZE (0..255) · OCTET STRING
This object specifies the location (URL) of the back-office. This string is empty if back-office support is disabled.