EZ5 MIB Catalog

CISCO-CDSTV-ISA-MIB

2012-03-13

This MIB module defines ISA configuration objects that faciliate the management of the Cisco Content Delivery System for TV (CDS-TV) product family. CDS-TV is a suite of products and software applications providing ingest, storage, caching, streaming, playout and on-demand delivery of video to television or set-top-box clients. Abbreviations: ASI Asynchronous Serial Interface CDS Content Delivery System CORBA Common Object Request Broker Architecture ISA Interactive Services Architecture ISV Integrated Streamer-Vault FSI File Service Interface FTP File Transfer Protocol MPEG Motion Picture Experts Group MSA Managed Services Architecture LSCP Lightweight Stream Control Protocol RTI Roome Telecommunications, Inc RTSP Real-Time Streaming Protocol STB Set-Top Box TTV Tampereen Tietoverkko, Finland Common terms: Catcher: Device responsible for receiving content (typically via satellite dishes and antennae) from content providers or from a Headend-In-The-Sky. Content Ingest: Acquisition of content from a source such as a catcher or an FTP server for storing it locally and making it available to streamers as needed. Vault: Content delivery application responsible for ingesting and storing video content and making it available to streamers. Streamer: Content delivery application responsible for streaming video out to STB's. CorbaLoc: Corba Location (CorbaLoc) refers to a string object reference for a CORBA object that looks similar to a URL and provides a human readable and editable way to specify a location where an IOR (Interoperable Object Reference) can be obtained. An example of a corbaloc URL is: 'corbaloc::160.45.110.41:38693/StandardNS/NameServer-POA/_root' ISA: Time Warner Cable's Interactive Services Architecture is a CORBA-based framework specifying interfaces for communication between various applications and servers in a cable video-on-demand ecosystem, including back-office, billing, subscriber management and streaming.

Download CISCO-CDSTV-ISA-MIB.txt Open CISCO-CDSTV-ISA-MIB.txt in a new tab

SCALARS (54) · TABLES (1)

Scalars (54)

NameOID
cdstvISAConfigFileName1.3.6.1.4.1.9.9.755.1.1.1
cdstvISAConfigWebServicePort1.3.6.1.4.1.9.9.755.1.1.2
cdstvISAConfigMSAEnabled1.3.6.1.4.1.9.9.755.1.1.3
cdstvISAConfigTmeEnabled1.3.6.1.4.1.9.9.755.1.1.4
cdstvISAConfigLoadQueryInterval1.3.6.1.4.1.9.9.755.1.1.5
cdstvISAConfigPlayNumThreads1.3.6.1.4.1.9.9.755.1.1.6
cdstvISAConfigResourceMgrServiceName1.3.6.1.4.1.9.9.755.1.1.7
cdstvISAConfigServicePollTime1.3.6.1.4.1.9.9.755.1.1.8
cdstvISAConfigPreEncryptionEnabled1.3.6.1.4.1.9.9.755.1.1.9
cdstvISAConfigTmeStatus1.3.6.1.4.1.9.9.755.1.1.11
cdstvISAConfigContentServiceMasterIpType1.3.6.1.4.1.9.9.755.1.2.1
cdstvISAConfigContentServiceMasterIp1.3.6.1.4.1.9.9.755.1.2.2
cdstvISAConfigContentServiceMasterPort1.3.6.1.4.1.9.9.755.1.2.3
cdstvISAConfigStreamServiceMasterIpType1.3.6.1.4.1.9.9.755.1.3.1
cdstvISAConfigStreamServiceMasterIp1.3.6.1.4.1.9.9.755.1.3.2
cdstvISAConfigStreamServiceMasterPort1.3.6.1.4.1.9.9.755.1.3.3
cdstvISAConfigStreamServiceId1.3.6.1.4.1.9.9.755.1.3.4
cdstvISAConfigStreamServiceKind1.3.6.1.4.1.9.9.755.1.3.5
cdstvISAConfigMasterNumThreads1.3.6.1.4.1.9.9.755.1.3.6
cdstvISAConfigStreamSourceIPConfig1.3.6.1.4.1.9.9.755.1.3.7
cdstvISAConfigStreamSourcePort1.3.6.1.4.1.9.9.755.1.3.8
cdstvISAConfigStreamingMode1.3.6.1.4.1.9.9.755.1.3.9
cdstvISAConfigStreamHeadendIdType1.3.6.1.4.1.9.9.755.1.3.10
cdstvISAConfigStreamHeadendId1.3.6.1.4.1.9.9.755.1.3.11
cdstvISAConfigStreamTimeout1.3.6.1.4.1.9.9.755.1.3.12
cdstvISAConfigNamingServiceIpType1.3.6.1.4.1.9.9.755.1.4.1
cdstvISAConfigNamingServiceIp1.3.6.1.4.1.9.9.755.1.4.2
cdstvISAConfigNamingServicePort1.3.6.1.4.1.9.9.755.1.4.3
cdstvISAConfigNotifyServiceIpType1.3.6.1.4.1.9.9.755.1.5.1
cdstvISAConfigNotifyServiceIp1.3.6.1.4.1.9.9.755.1.5.2
cdstvISAConfigNotifyServicePort1.3.6.1.4.1.9.9.755.1.5.3
cdstvISAConfigNotifyServiceFactory1.3.6.1.4.1.9.9.755.1.5.4
cdstvISAConfigContentStoreName1.3.6.1.4.1.9.9.755.1.6.1
cdstvISAConfigContentStoreKind1.3.6.1.4.1.9.9.755.1.6.2
cdstvISAConfigContentNumThreads1.3.6.1.4.1.9.9.755.1.6.3
cdstvISAConfigFactoryId1.3.6.1.4.1.9.9.755.1.7.1
cdstvISAConfigFactoryKind1.3.6.1.4.1.9.9.755.1.7.2
cdstvISAConfigContentFactoryId1.3.6.1.4.1.9.9.755.1.8.1
cdstvISAConfigContentFactoryKind1.3.6.1.4.1.9.9.755.1.8.2
cdstvISAConfigContentChannelId1.3.6.1.4.1.9.9.755.1.9.1
cdstvISAConfigContentChannelKind1.3.6.1.4.1.9.9.755.1.9.2
cdstvISAConfigStreamChannelId1.3.6.1.4.1.9.9.755.1.10.1
cdstvISAConfigStreamChannelKind1.3.6.1.4.1.9.9.755.1.10.2
cdstvISAConfigEventChannelId1.3.6.1.4.1.9.9.755.1.11.1
cdstvISAConfigEventChannelKind1.3.6.1.4.1.9.9.755.1.11.2
cdstvISAConfigEventChannelFactory1.3.6.1.4.1.9.9.755.1.11.3
cdstvISAConfigFTPClientPort1.3.6.1.4.1.9.9.755.1.12.1
cdstvISAConfigFTPServerPort1.3.6.1.4.1.9.9.755.1.12.2
cdstvISAConfigFTPServerOutPort1.3.6.1.4.1.9.9.755.1.12.3
cdstvISAConfigFTPClientNumAttempts1.3.6.1.4.1.9.9.755.1.12.4
cdstvISAConfigFTPPollTimeout1.3.6.1.4.1.9.9.755.1.12.5
cdstvISAConfigLscpServerPort1.3.6.1.4.1.9.9.755.1.13.1
cdstvISAConfigLscpResponsePadding1.3.6.1.4.1.9.9.755.1.13.2
cdstvISAConfigfMsaLscpClientProto1.3.6.1.4.1.9.9.755.1.13.3

Tables (1)

NameOID
cdstvISAConfigSessionGatewayTable1.3.6.1.4.1.9.9.755.1.1.10

END OF TOC

Scalar details

cdstvISAConfigFileName

1.3.6.1.4.1.9.9.755.1.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the name of the file that stores the ISA configuration settings.

cdstvISAConfigWebServicePort

1.3.6.1.4.1.9.9.755.1.1.2

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the port number used by web service processes listening on this server.

cdstvISAConfigMSAEnabled

1.3.6.1.4.1.9.9.755.1.1.3

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies whether Managed Services Architecture (MSA) is enabled or disabled. 'true' - MSA is enabled. 'false' - MSA is disabled.

cdstvISAConfigTmeEnabled

1.3.6.1.4.1.9.9.755.1.1.4

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies whether Trick Mode Event (TME) enhancements are enabled. 'true' - TME enhancements enabled. 'false' - TME enhancements disabled. cdstvISAConfigTmeEnabled object is superseded by cdstvISAConfigTmeStatus.

cdstvISAConfigLoadQueryInterval

1.3.6.1.4.1.9.9.755.1.1.5

TimeIntervalSecA period of time, measured in units of 1 second. · Unsigned32

This object specifies the time interval (in seconds) between ISA process queries to the CDS database and other internal sources that aid in determining the management and distribution of streams and ingests.

cdstvISAConfigPlayNumThreads

1.3.6.1.4.1.9.9.755.1.1.6

Unsigned32

This object specifies the Lightweight Stream Control Protocol (LSCP) number of threads.

cdstvISAConfigResourceMgrServiceName

1.3.6.1.4.1.9.9.755.1.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the name of the CDS Resource Service Manager that monitors orphan sessions.

cdstvISAConfigServicePollTime

1.3.6.1.4.1.9.9.755.1.1.8

TimeIntervalSecA period of time, measured in units of 1 second. · Unsigned32

This object specifies the time interval (seconds) between polling for orphan sessions.

cdstvISAConfigPreEncryptionEnabled

1.3.6.1.4.1.9.9.755.1.1.9

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies whether pre-encryption support is enabled or disabled. 'true' - Pre-encryption support is enabled. 'false' - Pre-encryption support is disabled.

cdstvISAConfigTmeStatus

1.3.6.1.4.1.9.9.755.1.1.11

INTEGER1 = enableForOpenStream2 = enableForMystroMDN3 = disabled · Integer32

This object specifies whether Trick Mode Event (TME) enhancements are Enabled or Disabled. enableForOpenStream(1) - Enable for OpenStream enableForMystroMDN(2) - Enable for MystroMDN disabled(3) - Disabled

cdstvISAConfigContentServiceMasterIpType

1.3.6.1.4.1.9.9.755.1.2.1

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object specifies the type of the master IP address of the Content Service, which is specified by cdstvISAConfigContentServiceMasterIp.

cdstvISAConfigContentServiceMasterIp

1.3.6.1.4.1.9.9.755.1.2.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object specifies the master IP address of the Content Service, which is the same for all Vault servers in an array. The type of the IP address is specified by cdstvISAConfigContentServiceMasterIpType.

cdstvISAConfigContentServiceMasterPort

1.3.6.1.4.1.9.9.755.1.2.3

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the port used by the master Content Service for controlling content.

cdstvISAConfigStreamServiceMasterIpType

1.3.6.1.4.1.9.9.755.1.3.1

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object specifies the type of the configured IP address for the Stream Service Master, specified by cdstvISAConfigStreamServiceMasterIp.

cdstvISAConfigStreamServiceMasterIp

1.3.6.1.4.1.9.9.755.1.3.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object specifies the configured IP address for the Stream Service Master. The type of the IP address is specified by cdstvISAConfigStreamServiceMasterIpType.

cdstvISAConfigStreamServiceMasterPort

1.3.6.1.4.1.9.9.755.1.3.3

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the port used by the Stream Service Master for controlling streams.

cdstvISAConfigStreamServiceId

1.3.6.1.4.1.9.9.755.1.3.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the name of the Stream Service object that is registered with the OpenStream system.

cdstvISAConfigStreamServiceKind

1.3.6.1.4.1.9.9.755.1.3.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the Service ID extension.

cdstvISAConfigMasterNumThreads

1.3.6.1.4.1.9.9.755.1.3.6

Unsigned32

This object specifies the stream service master number of threads.

cdstvISAConfigStreamSourceIPConfig

1.3.6.1.4.1.9.9.755.1.3.7

INTEGER1 = none2 = controlIp3 = defaultStreamSourceIp4 = streamInterfaceIp · Integer32

This object specifies the type of the source IP address that is included in the session setup header. Possible values are: none(1) - No IP address included in session setup header controlIp(2) - Control IP. defaultStreamSourceIp(3) - Default Stream Source IP. streamInterfaceIp(4) - Stream Interface IP.

cdstvISAConfigStreamSourcePort

1.3.6.1.4.1.9.9.755.1.3.8

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the Streamer port used for streaming.

cdstvISAConfigStreamingMode

1.3.6.1.4.1.9.9.755.1.3.9

INTEGER1 = asi2 = gige · Integer32

This object specifies the mode expected by the next device in the network. Possible options are: asi(1) - ASI mode. gige(2) - GigE mode.

cdstvISAConfigStreamHeadendIdType

1.3.6.1.4.1.9.9.755.1.3.10

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object specifies the type of the Headend ID for the Streaming Service, specified by cdstvISAConfigStreamHeadendId.

cdstvISAConfigStreamHeadendId

1.3.6.1.4.1.9.9.755.1.3.11

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object specifies the Headend ID for the Streaming Service. The address type of the Headend ID is specified by cdstvISAConfigStreamHeadendIdType.

cdstvISAConfigStreamTimeout

1.3.6.1.4.1.9.9.755.1.3.12

TimeIntervalSecA period of time, measured in units of 1 second. · Unsigned32

This object specifies the maximum time allowed (seconds) before a stream object is played.

cdstvISAConfigNamingServiceIpType

1.3.6.1.4.1.9.9.755.1.4.1

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object specifies the type of the IP address of the CORBA Naming Service used by the OpenStream system. The IP address is specified by cdstvISAConfigNamingServiceIp.

cdstvISAConfigNamingServiceIp

1.3.6.1.4.1.9.9.755.1.4.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object specifies the IP address of the CORBA Naming Service used by the OpenStream system. The type of the address is specified by cdstvISAConfigNamingServiceIpType.

cdstvISAConfigNamingServicePort

1.3.6.1.4.1.9.9.755.1.4.3

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the port of the Naming Service used by the OpenStream system.

cdstvISAConfigNotifyServiceIpType

1.3.6.1.4.1.9.9.755.1.5.1

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object specifies the type of the IP address of the CORBA Notification Service used by the OpenStream system. The IP address is specified by cdstvISAConfigNotifyServiceIp.

cdstvISAConfigNotifyServiceIp

1.3.6.1.4.1.9.9.755.1.5.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object specifies the IP address of the CORBA Notification Service used by the OpenStream system. The type of this address is specified by cdstvISAConfigNotifyServiceIpType.

cdstvISAConfigNotifyServicePort

1.3.6.1.4.1.9.9.755.1.5.3

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

The port of the Notification Service used by the OpenStream system.

cdstvISAConfigNotifyServiceFactory

1.3.6.1.4.1.9.9.755.1.5.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the name used to locate the Notify Service through the 'corbaloc' protocol.

cdstvISAConfigContentStoreName

1.3.6.1.4.1.9.9.755.1.6.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the name of the CDS Content Store object that is registered with the OpenStream system.

cdstvISAConfigContentStoreKind

1.3.6.1.4.1.9.9.755.1.6.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the content store ID extension.

cdstvISAConfigContentNumThreads

1.3.6.1.4.1.9.9.755.1.6.3

Unsigned32

This object specifies the content store number of threads.

cdstvISAConfigFactoryId

1.3.6.1.4.1.9.9.755.1.7.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies a name that identifies the root directory of the ISA factories where all factories need to register.

cdstvISAConfigFactoryKind

1.3.6.1.4.1.9.9.755.1.7.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the Factories ID extension.

cdstvISAConfigContentFactoryId

1.3.6.1.4.1.9.9.755.1.8.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the name of the CDS Content Store Factory that is registered with the OpenStream system.

cdstvISAConfigContentFactoryKind

1.3.6.1.4.1.9.9.755.1.8.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the content store factory ID extension.

cdstvISAConfigContentChannelId

1.3.6.1.4.1.9.9.755.1.9.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies a name that identifies the Content Event Channel where all events concerning content objects are published.

cdstvISAConfigContentChannelKind

1.3.6.1.4.1.9.9.755.1.9.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the Event Channel Content ID extension.

cdstvISAConfigStreamChannelId

1.3.6.1.4.1.9.9.755.1.10.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies a name that identifies the Stream Event Channel where all events concerning stream objects are published.

cdstvISAConfigStreamChannelKind

1.3.6.1.4.1.9.9.755.1.10.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the Event Channel Stream ID extension.

cdstvISAConfigEventChannelId

1.3.6.1.4.1.9.9.755.1.11.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies a name that identifies the root directory of the Event Channel where all event channels need to register.

cdstvISAConfigEventChannelKind

1.3.6.1.4.1.9.9.755.1.11.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the directory extension of the Event Channel ID.

cdstvISAConfigEventChannelFactory

1.3.6.1.4.1.9.9.755.1.11.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies a name that identifies the Event Channel Factory which is used to create event channels, and resolves the Notification Service name.

cdstvISAConfigFTPClientPort

1.3.6.1.4.1.9.9.755.1.12.1

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the port used when the Vault receives a request from the OpenStream system to act as an FTP client and sends an FTP get command to the content provider acting as an FTP server.

cdstvISAConfigFTPServerPort

1.3.6.1.4.1.9.9.755.1.12.2

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the port used when the Vault receives a request from the OpenStream system to act as an FTP server and receives an FTP put command from the content provider acting as an FTP client.

cdstvISAConfigFTPServerOutPort

1.3.6.1.4.1.9.9.755.1.12.3

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the configured ISA FTP Server Out Port.

cdstvISAConfigFTPClientNumAttempts

1.3.6.1.4.1.9.9.755.1.12.4

Unsigned32

This object specifies the number of times the FTP client attempts to transfer the content file.

cdstvISAConfigFTPPollTimeout

1.3.6.1.4.1.9.9.755.1.12.5

TimeIntervalSecA period of time, measured in units of 1 second. · Unsigned32

This object specifies the idle seconds allowed before an FTP download is disconnected.

cdstvISAConfigLscpServerPort

1.3.6.1.4.1.9.9.755.1.13.1

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object specifies the port on the Streamer that is listening for LSCP commands from the set-top box.

cdstvISAConfigLscpResponsePadding

1.3.6.1.4.1.9.9.755.1.13.2

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies whether LSCP response padding is enabled. When enabled, three blank bytes are added to the end of the LSCP response. 'true' - LSCP response padding is enabled. 'false' - LSCP response padding is disabled.

cdstvISAConfigfMsaLscpClientProto

1.3.6.1.4.1.9.9.755.1.13.3

INTEGER1 = tvguide2 = rti3 = vodlink4 = cv5 = cisco6 = ttv7 = lscppauseateos · Integer32

This object specifies the way LSCP clients communicate with the Streamer. Possible options are: tvguide(1) - TV Guide rti(2) - RTI vodlink(3) - VOD Link cv(4) - CableVision cisco(5) - Cisco ttv(6) - TTV lscppauseateos(7) - LSCP Pause at EOS

Table details

cdstvISAConfigSessionGatewayTable

1.3.6.1.4.1.9.9.755.1.1.10

Index: cdstvISAConfigSessionGatewayIndex

This table lists the Session Gateways Identifiers. This table is supported only for server roles 'streamer' and 'ISV', indicated by the object 'cdstvServerRole' in CISCO-CDSTV-SERVER-MIB.

cdstvISAConfigSessionGatewayIndex

1.3.6.1.4.1.9.9.755.1.1.10.1.1

Unsigned32

An index into the table containing Session Gateway ID's.

cdstvISAConfigSessionGatewayID

1.3.6.1.4.1.9.9.755.1.1.10.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the Session Gateway ID used by the backoffice Session Gateway service for registering with the Name Service.

↑ To TOC