This MIB module defines server configuration that
faciliate the management of the Cisco Content Delivery System for TV (CDS-TV) product family.
CDS-TV is a suite of products and software applications providing ingest, storage, caching, streaming, playout and on-demand delivery of video to television or set-top-box clients.
Abbreviations:
CDS Content Delivery System
CDSM Content Delivery System Manager
ISA Interactive Services Architecture
ISV Integrated Streamer-Vault
FSI File Service Interface
FTP File Transfer Protocol
MPEG Motion Picture Experts Group
MSA Managed Services Architecture
NDVR Network Digital Video Recorder
RTSP Real-Time Streaming Protocol
STB Set-Top Box
VVI Virtual Video Infrastructure
Device Roles:
Vault: Content delivery application responsible for ingesting and storing video content and making it available to streamers and/or caching nodes.
Caching Nodes: Content delivery application responsible for caching content from vault (using CCP) and then streaming content out to streamers over HTTP or CCP.
Streamer: Content delivery application responsible for streaming video out to STB's.
ISV: Content delivery application capable of acting as both a vault and as a streamer in a single device.
Controller (also called 'CDSM'): CDS application providing a web-based interface for monitoring, control and configuration of CDS devices(streamers, vaults, caching nodes and ISV's), device arrays/groups, and the complete CDS deployment.
Recorder: Content delivery application responsible for recording NDVR content and delivering it to streamers.
Role-specific objects:
cdstvServerCommonObjects apply to all roles cdstvServerStreamingObjects apply to streamer and ISV role specified by cdstvServerRole cdstvServerStorageObjects apply to vault and ISV role specified by cdstvServerRole cdstvServerCachingObjects apply to cachingserver role specified by cdstvServerRole
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This object indicates the part number of this device, which uniquely identifies the type of hardware this CDS application is running on, for example, CDE-420 2S3.
cdstvServerID
1.3.6.1.4.1.9.9.754.1.1.3
Unsigned32
This object indicates the unique server ID assigned to this device. Server ID's are auto-assigned by the CDS when servers are configured and are used to uniquely identify, optionally with the group ID, a device in the CDS.
cdstvServerGroupID
1.3.6.1.4.1.9.9.754.1.1.4
Unsigned32
This object indicates the group ID of the group this server belong to. Group ID's are auto-assigned when server groups are configured in the CDS.
cdstvServerHostname
1.3.6.1.4.1.9.9.754.1.1.5
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..64) · OCTET STRING · hint 255t
This object specifies the optional fully qualified hostname for this server, for example, vault.cisco.com.
cdstvServerTTL
1.3.6.1.4.1.9.9.754.1.1.6
Unsigned32 (0..255) · hops
This object specifies the IP time to live (TTL) for data packets.
cdstvServerSourceAddressType
1.3.6.1.4.1.9.9.754.1.1.7.1
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object specifies the type of the default source IP address (specified by the cdstvServerSourceAddress) for all stream and cache interfaces.
cdstvServerSourceAddress
1.3.6.1.4.1.9.9.754.1.1.7.2
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This object specifies the default source IP address for all stream and cache interfaces. The type of this address is specified by the cdstvServerSourceAddressType.
cdstvServerCachePort
1.3.6.1.4.1.9.9.754.1.1.7.3
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
This object specifies the default UDP port number used for cache traffic between servers.
cdstvCacheJumboFramesEnable
1.3.6.1.4.1.9.9.754.1.1.8
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object specifies the status of jumbo frames on cache interfaces: 'true' - Jumbo frames are enabled 'false' - Jumbo frames are disabled
cdstvServerOffloadEnable
1.3.6.1.4.1.9.9.754.1.1.9
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object specifies the current offload status of the server. When Server Offload is enabled, the server is configured not to accept new provisioning.
'true' - Server offload is enabled
'false' - Server offload is disabled
cdstvServerTransportDSCP
1.3.6.1.4.1.9.9.754.1.1.10.1
DscpA Differentiated Services Code-Point that may be used for marking a traffic stream.Reference: RFC 2474, RFC 2780 (0..63) · Integer32 · hint d
This object specifies the Differentiated Services Code Point (DSCP) for the Transport Interface on this server. DSCP uses six bits of the DiffServ field, which was originally the ToS octet, to mark all outgoing packets with a specific DSCP value. Cache or transport traffic may require certain forwarding behavior, known as the per-hop behavior (PHB), which is specified in the DSCP. The network gives priority to marked traffic. Generally, the lower number has lower priority and the higher number has higher priority.
DSCP is set separately for cache and transport interfaces.
DSCP can also be set for HTTP Streamers when HTTP is selected as the cache-fill protocol for VVI.
cdstvServerTransportECN
1.3.6.1.4.1.9.9.754.1.1.10.2
CiscoCdstvEcn1 = ect12 = ect03 = congestion4 = disabledThe Explicit Congestion Notification (ECN) field consists of two bits that denote the end points of a transfer protocol as ECN-capable, or that ECN is not being used. The possible values of the ECN Capable Transport Codepoint (ECT) are:
ect1(1) - Use ECN with ECT(1) setting.
ect0(2) - Use ECN with ECT(0) setting (recommended).
congestion(3) - Congestion is experienced by router.
disabled(4) - Do not use ECN
Setting the ECN field to 3 is performed by the router to indicate congestion is experienced. ECN is set separately for cache and transport interfaces. ECN can also be set for HTTP Streamers when HTTP is selected as the cache-fill protocol for VVI. · Integer32
This object specifies the Explicit Congestion Notification (ECN) for the Transport Interface on this server.
cdstvServerCacheDSCP
1.3.6.1.4.1.9.9.754.1.1.10.3
DscpA Differentiated Services Code-Point that may be used for marking a traffic stream.Reference: RFC 2474, RFC 2780 (0..63) · Integer32 · hint d
his object specifies the Differentiated Services Code Point (DSCP) for the Cache Interface on this server. DSCP uses six bits of the DiffServ field, which was originally the ToS octet, to mark all outgoing packets with a specific DSCP value. Cache or transport traffic may require certain forwarding behavior, known as the per-hop behavior (PHB), which is specified in the DSCP. The network gives priority to marked traffic. Generally, the lower number has lower priority and the higher number has higher priority.
DSCP is set separately for cache and transport interfaces.
DSCP can also be set for HTTP Streamers when HTTP is selected as the cache-fill protocol for VVI.
cdstvServerCacheECN
1.3.6.1.4.1.9.9.754.1.1.10.4
CiscoCdstvEcn1 = ect12 = ect03 = congestion4 = disabledThe Explicit Congestion Notification (ECN) field consists of two bits that denote the end points of a transfer protocol as ECN-capable, or that ECN is not being used. The possible values of the ECN Capable Transport Codepoint (ECT) are:
ect1(1) - Use ECN with ECT(1) setting.
ect0(2) - Use ECN with ECT(0) setting (recommended).
congestion(3) - Congestion is experienced by router.
disabled(4) - Do not use ECN
Setting the ECN field to 3 is performed by the router to indicate congestion is experienced. ECN is set separately for cache and transport interfaces. ECN can also be set for HTTP Streamers when HTTP is selected as the cache-fill protocol for VVI. · Integer32
This object specifies the Explicit Congestion Notification (ECN) for the Cache Interface on this server.
cdstvServerNullStreamingEnable
1.3.6.1.4.1.9.9.754.1.1.11
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object specifies whether the streaming of null MPEG files is allowed or not: 'true' - Null MPEG streaming is allowed. 'false' - NUll MPEG streaming is not allowed.
cdstvServerStartingTransportPort
1.3.6.1.4.1.9.9.754.1.2.1
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
This object specifies the beginning default UDP port number used for stream and stream/cache interfaces on this streamer or ISV.
cdstvServerEndingTransportPort
1.3.6.1.4.1.9.9.754.1.2.2
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
This object specifies the ending default UDP port number used for stream and stream/cache interfaces on this streamer or ISV.
cdstvStreamJumboFramesEnable
1.3.6.1.4.1.9.9.754.1.2.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object specifies the status of jumbo frames on stream interfaces of this streamer or ISV:
'true' - Jumbo frames are enabled.
'false' - Jumbo frames are disabled.
cdstvServerStreamGroupName
1.3.6.1.4.1.9.9.754.1.2.4.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This object indicates the name of the stream group this streamer or ISV is a member of. Group name for a stream group is configured in the CDSM.
cdstvServerStreamGroupID
1.3.6.1.4.1.9.9.754.1.2.4.2
Unsigned32
This object indicates the ID of the stream group this streamer or ISV is a member of. Stream group ID is auto-assigned by CDS when the stream group is created.
cdstvServerStreamerIsCache
1.3.6.1.4.1.9.9.754.1.2.4.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object specifies whether 'Streamer Is Cache' is enabled on this streamer. If 'Streamer Is Cache' is enabled, the Streamer can be used as a possible cache-fill source by a Streamer in a different Stream Group. All Stream Groups that have at least one Streamer with 'Streamer is Cache' enabled are displayed on the 'Stream to Cache Map' page, where the Stream Group can be selected as a possible cache-fill source and given a preference. Only the Streamers with 'Streamer Is Cache' enabled are used as possible cache-fill sources. The protocol used for cache-fill responses from Streamers is always CCP. 'true' - 'Streamer Is Cache' is enabled 'false' - 'Streamer Is Cache' is disabled
cdstvVaultMirrorCopies
1.3.6.1.4.1.9.9.754.1.3.1
Unsigned32 (0..10) · copies
This object specifies the number of content copies on a Vault or ISV that will ensure there is at least one copy at each site.
cdstvVaultLocalCopies
1.3.6.1.4.1.9.9.754.1.3.2
Unsigned32 (1..4) · copies
This object specifies the number of local copies on a Vaults or ISV at a site.
cdstvServerFTPOutInterface
1.3.6.1.4.1.9.9.754.1.3.3.1
INTEGER1 = management2 = ingest · Integer32
This object specifies whether the management interface or the ingest interface is used for FTP pull and FTP push on a Vault or ISV. management(1) - Management interface is used for FTP pull and FTP push ingest(2) - Ingest interface is used for FTP pull and FTP push
cdstvServerFTPOutBandwidth
1.3.6.1.4.1.9.9.754.1.3.3.2
Unsigned32 (0..1000) · Mbps
This object specifies the maximum bandwidth allowed for FTP functionality on a Vault or ISV.
cdstvServerFTPOutSessions
1.3.6.1.4.1.9.9.754.1.3.3.3
Unsigned32 (0..100) · sessions
This object specifies the maximum number of FTP out sessions allowed on a Vault or ISV.
cdstvServerVaultGroupName
1.3.6.1.4.1.9.9.754.1.3.4.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This object indicates the name of the vault group this Vault is a member of. Group name for a vault group is configured in the CDSM.
cdstvServerVaultGroupID
1.3.6.1.4.1.9.9.754.1.3.4.2
Unsigned32
This object indicates the ID of the vault group this Vault is a member of. Vault Group ID is auto-assigned by the CDS when a vault group is configured.
cdstvServerCacheGroupName
1.3.6.1.4.1.9.9.754.1.4.1.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This object indicates the name of the cache group this Caching Node is a member of. Group name for a caching group is configured in the CDSM.
cdstvServerCacheGroupID
1.3.6.1.4.1.9.9.754.1.4.1.2
Unsigned32
This object indicates the ID of the caching group this Caching Node is a member of. Caching Group ID is auto-assigned by the CDS when a caching group is created.