This MIB applies to one or more of a set of devices which have connectivity through some kind of 'fabric'. Many features which run in such an environment require the exchange of information between the peer devices which participate in providing the feature. An example of the type of information exchanged is configuration information. It would be advantageous to have the ability to have configuration for a feature done on one device and propagated to all other devices in the fabric. Cisco Fabric Service (CFS) is a general mechanism for data distribution within the fabric that could be used by most features.
A feature supported in a device may or may not be CFS capable. In case a feature is CFS capable, the control of the CFS operations are instrumented through this MIB.
A CFS capable feature can be enabled for data distribution within the fabric by the user via SNMP. When a CFS capable feature is enabled for data distribution, CFS operations can then be performed for that particular feature.
As part of the CFS configuration the first mandatory step is to explicitly enable the feature for data distribution. This enabling of distribution for a feature needs to be done for those devices in the fabric where the distribution is intended. Following this mandatory step, feature specific configurations can be instrumented in the respective MIBs.
Once a feature is enabled for data distribution, first subsequent feature specific configuration SET operation results in a snapshot of current 'Running Configuration' of the feature, on the local device. This snapshot is used for subsequent modifications by feature specific SET operations. Such modified configuration is referred to as 'Pending Configuration'. There can only be one 'Pending Configuration' in the fabric. Additionally, such 'Pending Configuration' can be maintained within the context of additional scope, specific to the respective features. The user who initiates the creation of the 'Pending Configuration' is its owner. When a 'Pending Configuration' for a feature exists in one of the devices of the fabric, an attempt to create a 'Pending Configuration' for the same feature and on a different device by way of feature specific SET operation results in an error. This means feature specific SET operations intended for distribution can only be performed on the device that has the 'Pending Configuration' with it. This ensures data consistency for distribution.
Once the configuration of a feature is ready to be distributed to all devices connected to the fabric, a 'commit' action performed on the local device overwrites the local 'Running Configuration' and then distributes the
new local 'Running Configuration' to all other devices in
the fabric. The successful 'commit' action also results into destroying of the 'Pending Configuration' and makes the feature available for new distribution. Any attempt to perform 'commit' without any modification results in to an error. The 'commit' action can only be performed by the owner of the 'Pending Configuration'.
The 'Pending Configuration' can optionally be destroyed without any distribution. This can be done by using either 'abort' or 'clear' action. The 'abort' action needs to performed only on that device where the 'Pending Configuration' exists and can only be performed by the owner of the 'Pending Configuration'. The 'clear' action can be initiated through any of the devices in the fabric. The successful 'abort' or 'clear' operation makes the feature available for new distribution.
The CFS, in addition to providing the basic distribution infrastructure to the CFS capable features in a stable fabric, also provides infrastructure to handle data distribution when two stable fabrics merge.
This MIB module is to facilitate the global level control (enabling/disabling) and actions (commit/abort/clear) over the CFS capable features in the system.
Glossary of the terms used in this MIB: --------------------------------------
VSAN - Virtual Storage Area Network,
similar to a VLAN.
CFS feature Scope - The scope of distribution.
The scope provides the context within which the CFS actions are performed on a CFS capable feature.
CFS Fabric Merge - The merging of two stable fabrics.
The CFS provides infrastructure to handle data distribution for CFS distribution enabled features when the two stable fabrics merge.
CFS control and actions :
CFS Distribution Enable - This is to enable data distribution
for CFS capable feature.
CFS Distribution Disable - This is to disable data distribution for CFS capable feature.
CFS Commit - This is to commit the 'Pending
Configuration' on the local device. This action triggers the distribution of the 'Pending Configuration' to all the devices in the fabric.
CFS Abort - This is to Destroy the 'Pending
Configuration' on the local device without any distribution. Once local 'Pending Configuration' is destroyed, creation of 'Pending Configuration' in the local or any other device connected to the fabric is allowed.
CFS Clear - This is to Destroy the 'Pending
Configuration' that exists in any of the device in the fabric. Once 'Pending Configuration' that exists with one of the devices in the fabric is destroyed, creation of 'Pending Configuration' in the local or any other device connected to the fabric is allowed.
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t
A human readable string value uniquely identifying the name of this feature for which the 'Merge Failure' occurred.
cfsMergeFailScopeType
1.3.6.1.4.1.9.9.433.1.2.2
CiscoCFSScopeType1 = none2 = vsanIDA generic value that represents the type of CFS feature scope.
'none' - No scope
'vsanID' - VSAN scope · Integer32
The value of this object indicates the type of the value of 'cfsMergeFailScopeVal'.
cfsMergeFailScopeVal
1.3.6.1.4.1.9.9.433.1.2.3
CiscoCFSScopeValueDenotes a CFS feature scope value to be used with
CiscoCFSScopeType. A CiscoCFSScopeValue is always interpreted within the context of an CiscoCFSScopeType value. Every usage of the CiscoCFSScopeValue textual convention is required to specify the CiscoCFSScopeType object which provides the context.
The encoding of the CiscoCFSScopeValue object for a specific scope type is as below:
ScopeType Octets Contents Encoding
--------- ------ -------- --------
vsanID 1-4 VSAN ID of the VSAN network-byte order SIZE (0..32) · OCTET STRING
The value of this object indicates the scope of the feature ('cfsMergeFailFeatureName') within which the 'Merge Failure' occurred.
cfsMergeFailReasonDescription
1.3.6.1.4.1.9.9.433.1.2.4
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
The failure reason description for the 'Merge Failure'
cfsStartPeersDiscovery
1.3.6.1.4.1.9.9.433.1.3.1
INTEGER1 = startDiscovery2 = noOp · Integer32
This object specifies whether a discovery cycle should be started by the CFS to discover all the 'peers' in the fabric.
When the value of this object is set to 'startDiscovery', the discovery of the CFS capable devices in the fabric is started by the CFS. On successful completion of the discovery, the entries in the 'cfsPeersTable' will be populated.
When the value of cfsPeersDiscoveryResult is 'inProgress', setting the value of this object to 'startDiscovery' results in an error.
No action is taken if this object is set to 'noOp'. The value of this object when read is always 'noOp'.
This object represents the result of the last discovery command issued by way of setting the value of cfsStartPeersDiscovery to 'startDiscovery'.
When the CFS discovery was never initiated using the cfsStartPeersDiscovery, the value of this object is 'notInitiated'.
When the value of this object is 'notInitiated', the management station needs initiate the discovery cycle by setting the value of cfsStartPeersDiscovery to 'startDiscovery'.
If the value of this object is 'successful', then the cfsPeersTable is appropriately populated.
cfsPeersDiscoveryFailureReason
1.3.6.1.4.1.9.9.433.1.3.3
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
The failure reason description for the last failed CFS peers discovery.
If the value of cfsPeersDiscoveryResult object has the value 'failed', then the value of this object contains the reason as to why it failed. Otherwise, the value of this object is a zero-length string.
cfsDistCtrl
1.3.6.1.4.1.9.9.433.1.4.1
INTEGER1 = enable2 = disable · Integer32
The object to control CFS for distribution.
On setting the value of this object to 'enable', CFS will be ready for distribution of the data across the fabric.
On setting the value of this object to 'disable', CFS will disable its capability to distribute the data across the fabric. The CFS continues to honour distribution requests from the CFS capable features of the local device, with the scope of the distribution limited only to the local device and not fabric wide.
The value of the object when read, reflects the current operating state of the CFS.
Table details
cfsFeatureOpTable
1.3.6.1.4.1.9.9.433.1.1.1
Index: cfsFeatureOpName
This table lists all the CFS capable features in the local device.
The table provides control, actions, current operating state information and last action result information for CFS capable features.
Each entry in this table represents a CFS capable feature. An entry in the table is created by the agent when CFS capable feature registers with CFS infrastructure. The agent removes the entry from the table when the CFS capable de-registers with CFS infrastructure. Management application can not create new entry in this table.
cfsFeatureOpName
1.3.6.1.4.1.9.9.433.1.1.1.1.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t
A human readable string value uniquely identifying the name of this feature.
cfsFeatureOpAction
1.3.6.1.4.1.9.9.433.1.1.1.1.2
CiscoCFSAction1 = noop2 = enable3 = disable4 = commit5 = abort6 = clearActions available for the CFS.
'noop' - No operation
'enable' - CFS Distribution Enable
'disable' - CFS Distribution Disable
'commit' - CFS Commit
'abort' - CFS Abort
'clear' - CFS Clear. This can be initiated by any
user who has write access to the object of 'CiscoCFSAction' type. · Integer32
The CFS action to be triggered for the feature. An operator should successfully enable CFS distribution of a feature by issuing an 'enable' action before performing a 'commit' or 'abort' operation.
The value of this object and the values of corresponding instance of cfsFeatureOpScopeType and cfsFeatureOpScopeVal are interpreted and applied together as single CFS action trigger on the feature. The scope type and values provide the context/scope within which the this action is applied.
Setting of this object will fail with 'inconsistentValue', if the value of the corresponding instance of cfsFeatureOpLastActionResult is 'inProgress'. However, the value of this object can be set to 'clear' regardless of the value of the corresponding instance of cfsFeatureOpLastActionResult.
Retrieving the value of this object via SNMP will always return 'noop'.
cfsFeatureOpScopeType
1.3.6.1.4.1.9.9.433.1.1.1.1.3
CiscoCFSScopeType1 = none2 = vsanIDA generic value that represents the type of CFS feature scope.
'none' - No scope
'vsanID' - VSAN scope · Integer32
The value of this object specifies the type of the value
of the corresponding instance of cfsFeatureOpScopeVal.
The agent is not required to retain the modified value of this object across the agent restart.
cfsFeatureOpScopeVal
1.3.6.1.4.1.9.9.433.1.1.1.1.4
CiscoCFSScopeValueDenotes a CFS feature scope value to be used with
CiscoCFSScopeType. A CiscoCFSScopeValue is always interpreted within the context of an CiscoCFSScopeType value. Every usage of the CiscoCFSScopeValue textual convention is required to specify the CiscoCFSScopeType object which provides the context.
The encoding of the CiscoCFSScopeValue object for a specific scope type is as below:
ScopeType Octets Contents Encoding
--------- ------ -------- --------
vsanID 1-4 VSAN ID of the VSAN network-byte order SIZE (0..32) · OCTET STRING
The CFS feature scope value to be used with cfsFeatureOpScopeType.
The value of this object may not be relevant when the value of the corresponding instance of cfsFeatureOpAction is SET to 'enable' or 'disable'.
The agent is not required to retain the modified value of
this object across the agent restart.
cfsFeatureOpLastAction
1.3.6.1.4.1.9.9.433.1.1.1.1.5
CiscoCFSAction1 = noop2 = enable3 = disable4 = commit5 = abort6 = clearActions available for the CFS.
'noop' - No operation
'enable' - CFS Distribution Enable
'disable' - CFS Distribution Disable
'commit' - CFS Commit
'abort' - CFS Abort
'clear' - CFS Clear. This can be initiated by any
user who has write access to the object of 'CiscoCFSAction' type. · Integer32
The last action performed on this feature. If no action has been triggered for the feature since the last reboot of the system, then retrieving the value of this object will return 'noop'.
cfsFeatureOpLastScopeType
1.3.6.1.4.1.9.9.433.1.1.1.1.6
CiscoCFSScopeType1 = none2 = vsanIDA generic value that represents the type of CFS feature scope.
'none' - No scope
'vsanID' - VSAN scope · Integer32
The last CFS feature scope type used for cfsFeatureOpLastAction. If no action has been triggered for the feature since the last reboot of the system, then retrieving the value of this object will return 'none'.
cfsFeatureOpLastScopeVal
1.3.6.1.4.1.9.9.433.1.1.1.1.7
CiscoCFSScopeValueDenotes a CFS feature scope value to be used with
CiscoCFSScopeType. A CiscoCFSScopeValue is always interpreted within the context of an CiscoCFSScopeType value. Every usage of the CiscoCFSScopeValue textual convention is required to specify the CiscoCFSScopeType object which provides the context.
The encoding of the CiscoCFSScopeValue object for a specific scope type is as below:
ScopeType Octets Contents Encoding
--------- ------ -------- --------
vsanID 1-4 VSAN ID of the VSAN network-byte order SIZE (0..32) · OCTET STRING
The last CFS feature scope value used for cfsFeatureOpLastScopeType. If no action has been triggered for the feature since the last reboot of the system, then retrieving the value of this object will return zero-length string.
cfsFeatureOpLastActionResult
1.3.6.1.4.1.9.9.433.1.1.1.1.8
CiscoCFSFeatureActionResult1 = none2 = success3 = failed4 = inProgress5 = partialSuccessResult of the action performed on a CFS capable feature.
'none' - No previous action was performed
'success' - Execution of the action triggered
is completed Successfully
'failed' - Execution of the action has failed
'inProgress' - Execution of the action triggered
is in progress
'partialSuccess' - Execution of the action triggered has succeeded partially in the fabric · Integer32
The result of the execution of the last action (represented by the value of cfsFeatureOpLastAction) for the feature. When the value of this object is 'actionInProgress', the value of the corresponding instance of cfsFeatureOpAction can not be modified.
cfsFeatureOpLastFailureReason
1.3.6.1.4.1.9.9.433.1.1.1.1.9
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
The failure reason description for the failed execution of last action performed on this feature.
If the corresponding instance of cfsFeatureOpLastActionResult has the value 'actionFailed', then this object contains the reason as to why it failed. Otherwise, the value of this object is the zero-length string.
This object provides a means for management applications to either view the contents of 'Running Configuration' or 'Pending Configuration'.
When the value of this object is 'runningConfig', all the subsequent configuration retrieval for this feature will be from 'Running Configuration' on the local device.
When the value of this object is 'pendingConfig', all the subsequent configuration retrieval for this feature will be from 'Pending Configuration' on the local device.
The value of this object is meaningful only when the value of the corresponding instance of 'cfsFeatureOpStatus' is 'enabled'.
The agent is not required to retain the modified value of
this object across the agent restart.
cfsFeatureOpStatus
1.3.6.1.4.1.9.9.433.1.1.1.1.11
CiscoCFSFeatureStatus1 = unknown2 = enabled3 = disabledStatus of the CFS capable feature.
'unknown' - Unknown status
'enabled' - Feature is enabled for CFS operations
'disabled' - Feature is disabled for any CFS operations · Integer32
The current operating status of the feature.
cfsFeatureOpAttribs
1.3.6.1.4.1.9.9.433.1.1.1.1.12
BITS
The value of this object represents the attributes of a CFS capable feature as registered with the CFS infrastructure.
'fcFabric' - indicates that the CFS based
distribution for a feature spans the entire FC (Fibre Channel) fabric
'ipNetwork' - indicates that the CFS based
distribution for a feature spans the entire IP network
'vsanScope' - indicates that the CFS based
distribution for a feature is done on per VSAN basis and restricted to a specific VSAN in a FC (Fibre Channel) fabric
This table contains per-feature 'Pending Configuration' owner information. This table will have entries only for those features for which 'Pending Configuration' exists in one of the devices in the fabric. This table provides the 'Pending Configuration' owner (type and name) information and Device address where the 'Pending Configuration' exists in the fabric.
The 'Pending Configuration' owner details are per CFS capable feature within a specific scope.
cfsPendingConfOwnerScopeType
1.3.6.1.4.1.9.9.433.1.1.2.1.1
CiscoCFSScopeType1 = none2 = vsanIDA generic value that represents the type of CFS feature scope.
'none' - No scope
'vsanID' - VSAN scope · Integer32
This indicates the type of the cfsPendingConfOwnerScopeVal.
cfsPendingConfOwnerScopeVal
1.3.6.1.4.1.9.9.433.1.1.2.1.2
CiscoCFSScopeValueDenotes a CFS feature scope value to be used with
CiscoCFSScopeType. A CiscoCFSScopeValue is always interpreted within the context of an CiscoCFSScopeType value. Every usage of the CiscoCFSScopeValue textual convention is required to specify the CiscoCFSScopeType object which provides the context.
The encoding of the CiscoCFSScopeValue object for a specific scope type is as below:
ScopeType Octets Contents Encoding
--------- ------ -------- --------
vsanID 1-4 VSAN ID of the VSAN network-byte order SIZE (0..32) · OCTET STRING
The CFS scope value used with cfsPendingConfOwnerScopeType. This indicates the scope of the feature within which the 'Pending Configuration' for the feature exists.
cfsPendingConfOwnerAddrType
1.3.6.1.4.1.9.9.433.1.1.2.1.3
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The type of address of the device in the fabric where the 'Pending Configuration' exists for the feature within this scope.
cfsPendingConfOwnerAddr
1.3.6.1.4.1.9.9.433.1.1.2.1.4
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The address of the device in the fabric where the 'Pending Configuration' exists for the feature within this scope.
The type of address of an instance of this object is determined by the value of the corresponding instance of cfsPendingConfOwnerAddrType.
cfsPendingConfOwnerIDType
1.3.6.1.4.1.9.9.433.1.1.2.1.5
BITS
Reference: - 'securityName' is defined in RFC 3411, section 3.2.2 - 'snmpCommunityName' as defined in RFC3584
The value of this object indicates the type of the value of the corresponding instance of 'cfsPendingConfOwnerID':
'other' - indicates that the value of
'cfsPendingConfOwnerID' is other than any of the enumerations defined
'snmpCommunityName' - indicates that the value of
'cfsPendingConfOwnerID' is 'snmpCommunityName' of SNMPv1/ SNMPv2c
'snmpv3SecurityName' - indicate that the value of 'cfsPendingConfOwnerID' is 'securityName' of SNMPv3 user
'cliLoginName' - indicates that the value of
'cfsPendingConfOwnerID' is CLI 'User Login Name' of CLI user
cfsPendingConfOwnerID
1.3.6.1.4.1.9.9.433.1.1.2.1.6
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
A human readable string representing the identity of the owner of the 'Pending Configuration' that exists in the device represented by the values of corresponding instance of cfsPendingConfOwnerAddrType and cfsPendingConfOwnerAddr. The value of the corresponding instance of cfsPendingConfOwnerIDType indicates the type of the value of this object.
This table provides status of the 'Fabric Merge' on the CFS capable features within the context of a scope.
This table will have entries only for those features for which CFS fabric distribution is enabled and 'Fabric Merge' is supported.
cfsMergeStatusScopeType
1.3.6.1.4.1.9.9.433.1.1.3.1.1
CiscoCFSScopeType1 = none2 = vsanIDA generic value that represents the type of CFS feature scope.
'none' - No scope
'vsanID' - VSAN scope · Integer32
This indicates the type of the cfsMergeStatusScopeVal.
cfsMergeStatusScopeVal
1.3.6.1.4.1.9.9.433.1.1.3.1.2
CiscoCFSScopeValueDenotes a CFS feature scope value to be used with
CiscoCFSScopeType. A CiscoCFSScopeValue is always interpreted within the context of an CiscoCFSScopeType value. Every usage of the CiscoCFSScopeValue textual convention is required to specify the CiscoCFSScopeType object which provides the context.
The encoding of the CiscoCFSScopeValue object for a specific scope type is as below:
ScopeType Octets Contents Encoding
--------- ------ -------- --------
vsanID 1-4 VSAN ID of the VSAN network-byte order SIZE (0..32) · OCTET STRING
The CFS scope value used with cfsMergeStatusScopeType. This indicates the scope of the feature within which the 'Fabric Merge' for the feature has occurred.
The result of the last 'Fabric Merge' for the feature within the context of the combination of 'cfsMergeStatusScopeType' and 'cfsMergeStatusScopeVal' in the system:
'success' - Fabric Merge successfully
completed
'inProgress' - Fabric Merge in progress
'failure' - Fabric Merge failed
'waiting' - Waiting for existing Merge
conflict to be cleared
'other' - None of the other values of
this enumeration
The value of this object is 'inProgress' when the local device is part of a fabric that is in the process of merging with another fabric.
The value of this object is 'waiting' when this local device is waiting for any existing 'Fabric Merge Conflict' to be resolved before it initiates the new instance of 'Fabric Merge'.
This table provides a list of devices in the local/ remote fabric after 'Fabric Merge' on a per CFS capable feature basis within the context of a scope.
This table will have entries only for those features for which CFS fabric distribution is enabled and 'Fabric Merge' is supported.
cfsMergeMemberAddrType
1.3.6.1.4.1.9.9.433.1.1.4.1.1
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The type of the address of the device in the fabric which has participated in the 'Fabric Merge' within the context of a CFS feature and scope.
cfsMergeMemberAddr
1.3.6.1.4.1.9.9.433.1.1.4.1.2
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..32) · OCTET STRING
The address of the device in the fabric which has participated in the 'Fabric Merge' within the context of a CFS feature and scope.
The type of address of an instance of this object is determined by the value of the corresponding instance of cfsMergeMemberAddrType.
cfsMergeMemberFabricType
1.3.6.1.4.1.9.9.433.1.1.4.1.3
INTEGER1 = unknown2 = local3 = remote · Integer32
The type of the fabric to which the device belongs to, during/after the 'Fabric Merge'.
The fabric to which the local device is attached to is referred to as 'local fabric'. The fabric which attempted to merge with the local fabric is referred to as 'remote fabric'.
When the value of the corresponding instance of cfsMergeStatusValue is 'successful' or 'waiting', all the devices will be in a single 'CFS fabric' and belong to the 'local' fabric.
When the value of the corresponding instance of cfsMergeStatusValue is 'failure' or 'inProgress', the devices in the other fabric which attempted 'Fabric Merge' are marked as 'remote'.
cfsMergeMemberRole
1.3.6.1.4.1.9.9.433.1.1.4.1.4
INTEGER1 = unknown2 = master3 = peer · Integer32
The role of the device during the 'Fabric Merge'. In case of a successful fabric merge/stable fabric only one device can be a 'master'. In case of a fabric merge failure, there can be multiple 'master' devices, corresponding to each of the fabric fragments. All other devices which are not 'master' assume the role of a 'peer'.
The algorithm for the selection of the 'Merge Master' device within a stable fabric is platform specific.
cfsPeersTable
1.3.6.1.4.1.9.9.433.1.1.5
Index: cfsPeerAddrType · cfsPeerAddr
This table provides list of devices in a stable fabric. This table is populated with the entries only when the CFS discovery cycle is successfully completed.
cfsPeerAddrType
1.3.6.1.4.1.9.9.433.1.1.5.1.1
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The type of the address of the CFS capable device in the fabric.
cfsPeerAddr
1.3.6.1.4.1.9.9.433.1.1.5.1.2
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..32) · OCTET STRING
The address of a CFS capable device in the fabric.
The type of address of an instance of this object is determined by the value of the corresponding instance of cfsPeerAddrType.
This table provides list of devices in a stable fabric on per CFS capable feature basis.
cfsFeaturePeersScopeType
1.3.6.1.4.1.9.9.433.1.1.6.1.1
CiscoCFSScopeType1 = none2 = vsanIDA generic value that represents the type of CFS feature scope.
'none' - No scope
'vsanID' - VSAN scope · Integer32
This indicates the type of the cfsFeaturePeersScopeVal.
cfsFeaturePeersScopeVal
1.3.6.1.4.1.9.9.433.1.1.6.1.2
CiscoCFSScopeValueDenotes a CFS feature scope value to be used with
CiscoCFSScopeType. A CiscoCFSScopeValue is always interpreted within the context of an CiscoCFSScopeType value. Every usage of the CiscoCFSScopeValue textual convention is required to specify the CiscoCFSScopeType object which provides the context.
The encoding of the CiscoCFSScopeValue object for a specific scope type is as below:
ScopeType Octets Contents Encoding
--------- ------ -------- --------
vsanID 1-4 VSAN ID of the VSAN network-byte order SIZE (0..32) · OCTET STRING
The CFS scope value used with cfsFeaturePeersScopeType. This indicates the scope of the feature within which the device exists in the fabric.
cfsFeaturePeersAddrType
1.3.6.1.4.1.9.9.433.1.1.6.1.3
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The type of the address of a peer device in the fabric for a CFS capable feature within the context of a scope.
cfsFeaturePeersAddr
1.3.6.1.4.1.9.9.433.1.1.6.1.4
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..32) · OCTET STRING
The address of a peer device in the fabric for a CFS capable feature within the context of a scope.
The type of address of an instance of this object is determined by the value of the corresponding instance of cfsFeaturePeersAddrType.
This table lists all the CFS capable features in the local device and provides:
- the information of the result of the last CFS action triggered on the CFS capable feature within the context of a scope
- control flag to specify the source of 'configuration view', within the context of a scope of the CFS capable feature
The last action corresponds to the action triggered on a CFS capable feature using the cfsFeatureOpAction of the cfsFeatureOpTable.
cfsFeatureOpExtScopeType
1.3.6.1.4.1.9.9.433.1.1.7.1.1
CiscoCFSScopeType1 = none2 = vsanIDA generic value that represents the type of CFS feature scope.
'none' - No scope
'vsanID' - VSAN scope · Integer32
This indicates the type of the cfsFeatureOpExtScopeVal.
cfsFeatureOpExtScopeVal
1.3.6.1.4.1.9.9.433.1.1.7.1.2
CiscoCFSScopeValueDenotes a CFS feature scope value to be used with
CiscoCFSScopeType. A CiscoCFSScopeValue is always interpreted within the context of an CiscoCFSScopeType value. Every usage of the CiscoCFSScopeValue textual convention is required to specify the CiscoCFSScopeType object which provides the context.
The encoding of the CiscoCFSScopeValue object for a specific scope type is as below:
ScopeType Octets Contents Encoding
--------- ------ -------- --------
vsanID 1-4 VSAN ID of the VSAN network-byte order SIZE (0..32) · OCTET STRING
The CFS feature scope value to be used with cfsFeatureOpExtScopeType.
cfsFeatureOpExtLastAction
1.3.6.1.4.1.9.9.433.1.1.7.1.3
CiscoCFSAction1 = noop2 = enable3 = disable4 = commit5 = abort6 = clearActions available for the CFS.
'noop' - No operation
'enable' - CFS Distribution Enable
'disable' - CFS Distribution Disable
'commit' - CFS Commit
'abort' - CFS Abort
'clear' - CFS Clear. This can be initiated by any
user who has write access to the object of 'CiscoCFSAction' type. · Integer32
The last action performed on this feature within the context of a scope. If no action has been triggered for the feature since the last reboot of the system, then retrieving the value of this object will return 'noop'.
cfsFeatureOpExtLastActionResult
1.3.6.1.4.1.9.9.433.1.1.7.1.4
CiscoCFSFeatureActionResult1 = none2 = success3 = failed4 = inProgress5 = partialSuccessResult of the action performed on a CFS capable feature.
'none' - No previous action was performed
'success' - Execution of the action triggered
is completed Successfully
'failed' - Execution of the action has failed
'inProgress' - Execution of the action triggered
is in progress
'partialSuccess' - Execution of the action triggered has succeeded partially in the fabric · Integer32
The result of the execution of the last action (represented by the value of cfsFeatureOpExtLastAction) for the feature.
cfsFeatureOpExtLastFailureReason
1.3.6.1.4.1.9.9.433.1.1.7.1.5
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
The failure reason description for the failed execution of last action performed on this feature.
If the corresponding instance of cfsFeatureOpExtLastActionResult has the value 'actionFailed', then this object contains the reason as to why it failed. Otherwise, the value of this object is a zero-length string.
This object provides a means for management applications to either view the contents of 'Running Configuration' or 'Pending Configuration'.
When the value of this object is 'runningConfig', all the subsequent configuration retrieval for this feature within the specified context of the scope will be from 'Running Configuration' on the local device.
When the value of this object is 'pendingConfig', all the subsequent configuration retrieval for this feature within the specified context of the scope will be from 'Pending Configuration' on the local device.
The value of this object is meaningful only when the value of the corresponding instance of 'cfsFeatureOpStatus' is 'enabled'.
The agent is not required to retain the modified value of
this object across the agent restart.
cfsFeatureOpExtLastActionTime
1.3.6.1.4.1.9.9.433.1.1.7.1.7
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
Time stamp of the last action performed. If no action has been triggered for the feature (i.e cfsFeatureOpExtLastAction
equal to one '1') since the last reboot of the system, the value
zero will be returned.
cfsDistCtrlTable
1.3.6.1.4.1.9.9.433.1.4.2
Index: cfsDistCtrlAddrType
The table to control CFS for distribution over IP.
cfsDistCtrlAddrType
1.3.6.1.4.1.9.9.433.1.4.2.1.1
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The type of multicast address to which the CFS distribution is restricted. Only the entries corresponding to the 'ipv4' and 'ipv6' internet address types exist in this table.
cfsDistCtrlAddr
1.3.6.1.4.1.9.9.433.1.4.2.1.2
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The multicast address domain to which the CFS distribution is restricted.
The type of this address is determined by the instance identifier value of the cfsDistCtrlAddrType.
There is a default multicast address for both IPv4 and IPv6 through which the Keep-alive messages are sent and received to discover the CFS capable switches over IP. All switches with similar multicast address form one CFS-over-IP fabric.
The default multicast address for IPv4 is 239.255.70.83 and range supported is [239.255.0.0 - 239.255.255.255]
The default multicast address for IPv6 is ff13::7743:4653 and the supported range is [ff13::0000:0000 - ff13::ffff:ffff]
The value of this object can only be modified when the value of the corresponding instance of cfsDistCtrlAction is 'disable'.
cfsDistCtrlAction
1.3.6.1.4.1.9.9.433.1.4.2.1.3
INTEGER1 = enable2 = disable · Integer32
This object specifies the current operating mode employed in CFS for distribution over the corresponding type of Internet address.
By setting the value of this object to 'enable', CFS will enable its capability to distribute the application data across the fabric over the corresponding type of Internet address.
By setting the value of this object to 'disable', CFS will disable its capability to distribute the data across the fabric over the corresponding type of Internet address.
Only one instance of this object can have the value of 'enable' among all the conceptual rows.
Trap details
ciscoCFSFeatureActionNotif
1.3.6.1.4.1.9.9.433.0.1
Notification to covey the information of the action performed on a CFS capable feature.
This notification gets generated when :
- a CFS operation action is triggered on CFS capable feature
- the result of last action performed on the CFS capable feature changes.
The 'cfsFeatureOpLastActionResult' indicates the new value of the last action result performed on the feature.
cfsFeatureOpLastAction
1.3.6.1.4.1.9.9.433.1.1.1.1.5
CiscoCFSAction1 = noop2 = enable3 = disable4 = commit5 = abort6 = clearActions available for the CFS.
'noop' - No operation
'enable' - CFS Distribution Enable
'disable' - CFS Distribution Disable
'commit' - CFS Commit
'abort' - CFS Abort
'clear' - CFS Clear. This can be initiated by any
user who has write access to the object of 'CiscoCFSAction' type. · Integer32
The last action performed on this feature. If no action has been triggered for the feature since the last reboot of the system, then retrieving the value of this object will return 'noop'.
cfsFeatureOpLastScopeType
1.3.6.1.4.1.9.9.433.1.1.1.1.6
CiscoCFSScopeType1 = none2 = vsanIDA generic value that represents the type of CFS feature scope.
'none' - No scope
'vsanID' - VSAN scope · Integer32
The last CFS feature scope type used for cfsFeatureOpLastAction. If no action has been triggered for the feature since the last reboot of the system, then retrieving the value of this object will return 'none'.
cfsFeatureOpLastScopeVal
1.3.6.1.4.1.9.9.433.1.1.1.1.7
CiscoCFSScopeValueDenotes a CFS feature scope value to be used with
CiscoCFSScopeType. A CiscoCFSScopeValue is always interpreted within the context of an CiscoCFSScopeType value. Every usage of the CiscoCFSScopeValue textual convention is required to specify the CiscoCFSScopeType object which provides the context.
The encoding of the CiscoCFSScopeValue object for a specific scope type is as below:
ScopeType Octets Contents Encoding
--------- ------ -------- --------
vsanID 1-4 VSAN ID of the VSAN network-byte order SIZE (0..32) · OCTET STRING
The last CFS feature scope value used for cfsFeatureOpLastScopeType. If no action has been triggered for the feature since the last reboot of the system, then retrieving the value of this object will return zero-length string.
cfsFeatureOpLastActionResult
1.3.6.1.4.1.9.9.433.1.1.1.1.8
CiscoCFSFeatureActionResult1 = none2 = success3 = failed4 = inProgress5 = partialSuccessResult of the action performed on a CFS capable feature.
'none' - No previous action was performed
'success' - Execution of the action triggered
is completed Successfully
'failed' - Execution of the action has failed
'inProgress' - Execution of the action triggered
is in progress
'partialSuccess' - Execution of the action triggered has succeeded partially in the fabric · Integer32
The result of the execution of the last action (represented by the value of cfsFeatureOpLastAction) for the feature. When the value of this object is 'actionInProgress', the value of the corresponding instance of cfsFeatureOpAction can not be modified.
ciscoCFSMergeFailNotif
1.3.6.1.4.1.9.9.433.0.2
Notification to convey the information of the 'Merge Failure' occurred in the fabric. This notification gets generated when the merge of the two fabrics fail for a CFS capable feature.
cfsMergeFailFeatureName
1.3.6.1.4.1.9.9.433.1.2.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t
A human readable string value uniquely identifying the name of this feature for which the 'Merge Failure' occurred.
cfsMergeFailScopeType
1.3.6.1.4.1.9.9.433.1.2.2
CiscoCFSScopeType1 = none2 = vsanIDA generic value that represents the type of CFS feature scope.
'none' - No scope
'vsanID' - VSAN scope · Integer32
The value of this object indicates the type of the value of 'cfsMergeFailScopeVal'.
cfsMergeFailScopeVal
1.3.6.1.4.1.9.9.433.1.2.3
CiscoCFSScopeValueDenotes a CFS feature scope value to be used with
CiscoCFSScopeType. A CiscoCFSScopeValue is always interpreted within the context of an CiscoCFSScopeType value. Every usage of the CiscoCFSScopeValue textual convention is required to specify the CiscoCFSScopeType object which provides the context.
The encoding of the CiscoCFSScopeValue object for a specific scope type is as below:
ScopeType Octets Contents Encoding
--------- ------ -------- --------
vsanID 1-4 VSAN ID of the VSAN network-byte order SIZE (0..32) · OCTET STRING
The value of this object indicates the scope of the feature ('cfsMergeFailFeatureName') within which the 'Merge Failure' occurred.
cfsMergeFailReasonDescription
1.3.6.1.4.1.9.9.433.1.2.4
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
The failure reason description for the 'Merge Failure'
ciscoCFSDiscoveryCompleteNotif
1.3.6.1.4.1.9.9.433.0.3
Notification to indicate that the CFS has completed discovering the CFS capable devices in the fabric.
If the value of cfsPeersDiscoveryResult is 'successful', then the cfsPeersTable is appropriately populated.
This object represents the result of the last discovery command issued by way of setting the value of cfsStartPeersDiscovery to 'startDiscovery'.
When the CFS discovery was never initiated using the cfsStartPeersDiscovery, the value of this object is 'notInitiated'.
When the value of this object is 'notInitiated', the management station needs initiate the discovery cycle by setting the value of cfsStartPeersDiscovery to 'startDiscovery'.
If the value of this object is 'successful', then the cfsPeersTable is appropriately populated.
cfsPeersDiscoveryFailureReason
1.3.6.1.4.1.9.9.433.1.3.3
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
The failure reason description for the last failed CFS peers discovery.
If the value of cfsPeersDiscoveryResult object has the value 'failed', then the value of this object contains the reason as to why it failed. Otherwise, the value of this object is a zero-length string.