EZ5 MIB Catalog

CISCO-CONFIG-MAN-MIB

2006-08-22

Configuration management MIB. The MIB represents a model of configuration data that exists in various locations: running in use by the running system terminal operator's mind or attached hardware local saved locally in NVRAM or flash remote saved to some server on the network Although some of the system functions that relate here can be used for general file storage and transfer, this MIB intends to include only such operations as clearly relate to configuration. Its primary emphasis is to track changes and saves of the running configuration. As saved data moves further from startup use, such as into different local flash files or onto the network, tracking becomes difficult to impossible, so the MIB's interest and functions are confined in that area. Information from ccmCLIHistoryCommandTable can be used to track the exact configuration changes that took place within a particular Configuration History event. NMS' can use this information to update the related components. For example: If commands related only to MPLS are entered then the NMS need to update only the MPLS related management information rather than updating all of its management information. Acronyms and terms: CLI Command Line Interface.

Download CISCO-CONFIG-MAN-MIB.txt Open CISCO-CONFIG-MAN-MIB.txt in a new tab

SCALARS (13) · TABLES (2) · TRAPS (3)

Scalars (13)

NameOID
ccmHistoryRunningLastChanged1.3.6.1.4.1.9.9.43.1.1.1
ccmHistoryRunningLastSaved1.3.6.1.4.1.9.9.43.1.1.2
ccmHistoryStartupLastChanged1.3.6.1.4.1.9.9.43.1.1.3
ccmHistoryMaxEventEntries1.3.6.1.4.1.9.9.43.1.1.4
ccmHistoryEventEntriesBumped1.3.6.1.4.1.9.9.43.1.1.5
ccmCLIHistoryMaxCmdEntries1.3.6.1.4.1.9.9.43.1.2.1
ccmCLIHistoryCmdEntries1.3.6.1.4.1.9.9.43.1.2.2
ccmCLIHistoryCmdEntriesAllowed1.3.6.1.4.1.9.9.43.1.2.3
ccmCLICfgRunConfNotifEnable1.3.6.1.4.1.9.9.43.1.3.1
ccmCTID1.3.6.1.4.1.9.9.43.1.4.1
ccmCTIDLastChangeTime1.3.6.1.4.1.9.9.43.1.4.2
ccmCTIDWhoChanged1.3.6.1.4.1.9.9.43.1.4.3
ccmCTIDRolledOverNotifEnable1.3.6.1.4.1.9.9.43.1.4.4

Tables (2)

NameOID
ccmHistoryEventTable1.3.6.1.4.1.9.9.43.1.1.6
ccmCLIHistoryCommandTable1.3.6.1.4.1.9.9.43.1.2.4

Traps (3)

NameOID
ciscoConfigManEvent1.3.6.1.4.1.9.9.43.2.0.1
ccmCLIRunningConfigChanged1.3.6.1.4.1.9.9.43.2.0.2
ccmCTIDRolledOver1.3.6.1.4.1.9.9.43.2.0.3

END OF TOC

Scalar details

ccmHistoryRunningLastChanged

1.3.6.1.4.1.9.9.43.1.1.1

TimeTicks

The value of sysUpTime when the running configuration was last changed. If the value of ccmHistoryRunningLastChanged is greater than ccmHistoryRunningLastSaved, the configuration has been changed but not saved.

ccmHistoryRunningLastSaved

1.3.6.1.4.1.9.9.43.1.1.2

TimeTicks

The value of sysUpTime when the running configuration was last saved (written). If the value of ccmHistoryRunningLastChanged is greater than ccmHistoryRunningLastSaved, the configuration has been changed but not saved. What constitutes a safe saving of the running configuration is a management policy issue beyond the scope of this MIB. For some installations, writing the running configuration to a terminal may be a way of capturing and saving it. Others may use local or remote storage. Thus ANY write is considered saving for the purposes of the MIB.

ccmHistoryStartupLastChanged

1.3.6.1.4.1.9.9.43.1.1.3

TimeTicks

The value of sysUpTime when the startup configuration was last written to. In general this is the default configuration used when cold starting the system. It may have been changed by a save of the running configuration or by a copy from elsewhere.

ccmHistoryMaxEventEntries

1.3.6.1.4.1.9.9.43.1.1.4

Integer32 (0..2147483647)

The maximum number of entries that can be held in ccmHistoryEventTable. The recommended value for implementations is 10.

ccmHistoryEventEntriesBumped

1.3.6.1.4.1.9.9.43.1.1.5

Counter32

The number of times the oldest entry in ccmHistoryEventTable was deleted to make room for a new entry.

ccmCLIHistoryMaxCmdEntries

1.3.6.1.4.1.9.9.43.1.2.1

Unsigned32

The maximum number of entries that can be held in ccmCLIHistoryCommandTable. The recommended value for implementations is 100. If the number of entries in ccmCLIHistoryCommandTable exceeds the value of this object, old entries will be bumped to make room for new entries. The ccmCLIHistoryCommandTable will not be populated if the value of this object is 0.

ccmCLIHistoryCmdEntries

1.3.6.1.4.1.9.9.43.1.2.2

Gauge32

The current number of entries in ccmCLIHistoryCommandTable.

ccmCLIHistoryCmdEntriesAllowed

1.3.6.1.4.1.9.9.43.1.2.3

Unsigned32

This object indicates the upper limit on the number of entries allowed in ccmCLIHistoryCommandTable by the managed system.

ccmCLICfgRunConfNotifEnable

1.3.6.1.4.1.9.9.43.1.3.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This variable indicates whether the system produces the ccmCLIRunningConfigChanged notification. A false value will prevent notifications from being generated by this system.

ccmCTID

1.3.6.1.4.1.9.9.43.1.4.1

Unsigned64An unsigned 64 bit integer. We use SYNTAX Counter64 for the encoding rules. (0..18446744073709551615) · Counter64

This object indicates the Config Change Tracking ID which uniquely represents version-incrementing changes to the IOS running configuration.

ccmCTIDLastChangeTime

1.3.6.1.4.1.9.9.43.1.4.2

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This object indicates the time when the Config Change Tracking ID last changed.

ccmCTIDWhoChanged

1.3.6.1.4.1.9.9.43.1.4.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object indicates the user who last reset the Config Change Tracking ID.

ccmCTIDRolledOverNotifEnable

1.3.6.1.4.1.9.9.43.1.4.4

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This variable indicates whether the system produces the ccmCTIDRolledOver notification. A false value will prevent notifications from being generated by this system.

Table details

ccmHistoryEventTable

1.3.6.1.4.1.9.9.43.1.1.6

Index: ccmHistoryEventIndex

A table of configuration events on this router.

ccmHistoryEventIndex

1.3.6.1.4.1.9.9.43.1.1.6.1.1

Integer32 (1..2147483647)

A monotonically increasing integer for the sole purpose of indexing events. When it reaches the maximum value, an extremely unlikely event, the agent wraps the value back to 1 and may flush existing entries.

ccmHistoryEventTime

1.3.6.1.4.1.9.9.43.1.1.6.1.2

TimeTicks

The value of sysUpTime when the event occurred.

ccmHistoryEventCommandSource

1.3.6.1.4.1.9.9.43.1.1.6.1.3

INTEGER1 = commandLine2 = snmp · Integer32

The source of the command that instigated the event.

ccmHistoryEventConfigSource

1.3.6.1.4.1.9.9.43.1.1.6.1.4

HistoryEventMedium1 = erase2 = commandSource3 = running4 = startup5 = local6 = networkTftp7 = networkRcp8 = networkFtp9 = networkScpThe source or destination of a configuration change, save, or copy. erase erasing destination (source only) running live operational data commandSource the command source itself startup what the system will use next reboot local local NVRAM or flash networkTftp network host via Trivial File Transfer networkRcp network host via Remote Copy networkFtp network host via File transfer networkScp network host via Secure Copy · Integer32

The configuration data source for the event.

ccmHistoryEventConfigDestination

1.3.6.1.4.1.9.9.43.1.1.6.1.5

HistoryEventMedium1 = erase2 = commandSource3 = running4 = startup5 = local6 = networkTftp7 = networkRcp8 = networkFtp9 = networkScpThe source or destination of a configuration change, save, or copy. erase erasing destination (source only) running live operational data commandSource the command source itself startup what the system will use next reboot local local NVRAM or flash networkTftp network host via Trivial File Transfer networkRcp network host via Remote Copy networkFtp network host via File transfer networkScp network host via Secure Copy · Integer32

The configuration data destination for the event.

ccmHistoryEventTerminalType

1.3.6.1.4.1.9.9.43.1.1.6.1.6

INTEGER1 = notApplicable2 = unknown3 = console4 = terminal5 = virtual6 = auxiliary · Integer32

If ccmHistoryEventCommandSource is 'commandLine', the terminal type, otherwise 'notApplicable'.

ccmHistoryEventTerminalNumber

1.3.6.1.4.1.9.9.43.1.1.6.1.7

Integer32

If ccmHistoryEventCommandSource is 'commandLine', the terminal number. The value is -1 if not available or not applicable.

ccmHistoryEventTerminalUser

1.3.6.1.4.1.9.9.43.1.1.6.1.8

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a

If ccmHistoryEventCommandSource is 'commandLine', the name of the logged in user. The length is zero if not available or not applicable.

ccmHistoryEventTerminalLocation

1.3.6.1.4.1.9.9.43.1.1.6.1.9

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a

If ccmHistoryEventCommandSource is 'commandLine', the hard-wired location of the terminal or the remote host for an incoming connection. The length is zero if not available or not applicable.

ccmHistoryEventCommandSourceAddress

1.3.6.1.4.1.9.9.43.1.1.6.1.10

IpAddress SIZE (4)

If ccmHistoryEventTerminalType is 'virtual', the internet address of the connected system. If ccmHistoryEventCommandSource is 'snmp', the internet address of the requester. The value is 0.0.0.0 if not available or not applicable. This object is deprecated by ccmHistoryEventCommandSourceAddrRev1

ccmHistoryEventVirtualHostName

1.3.6.1.4.1.9.9.43.1.1.6.1.11

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a

If ccmHistoryEventTerminalType is 'virtual', the host name of the connected system. The length is zero if not available or not applicable.

ccmHistoryEventServerAddress

1.3.6.1.4.1.9.9.43.1.1.6.1.12

IpAddress SIZE (4)

If ccmHistoryEventConfigSource or ccmHistoryEventConfigDestination is 'networkTftp' or 'networkRcp', the internet address of the storage file server. The value is 0.0.0.0 if not applicable or not available. This object is deprecated by ccmHistoryEventServerAddrRev1

ccmHistoryEventFile

1.3.6.1.4.1.9.9.43.1.1.6.1.13

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a

If ccmHistoryEventConfigSource or ccmHistoryEventConfigDestination is 'networkTftp' or 'networkRcp', the configuration file name at the storage file server. The length is zero if not available or not applicable.

ccmHistoryEventRcpUser

1.3.6.1.4.1.9.9.43.1.1.6.1.14

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a

If ccmHistoryEventConfigSource or ccmHistoryEventConfigDestination is 'networkRcp', the remote user name. The length is zero if not applicable or not available.

ccmHistoryCLICmdEntriesBumped

1.3.6.1.4.1.9.9.43.1.1.6.1.15

Counter32

The number of times the oldest entry in ccmCLIHistoryCommandTable with first index as ccmHistoryEventIndex was deleted to make room for a new entry. This object is applicable only if ccmHistoryEventCommandSource has a value of 'commandLine'.

ccmHistoryEventCommandSourceAddrType

1.3.6.1.4.1.9.9.43.1.1.6.1.16

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the transport type of the address contained in ccmHistoryEventCommandSourceAddrRev1. The value will be zero if not available or not applicable.

ccmHistoryEventCommandSourceAddrRev1

1.3.6.1.4.1.9.9.43.1.1.6.1.17

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

If ccmHistoryEventTerminalType is 'virtual', the internet address of the connected system. If ccmHistoryEventCommandSource is 'snmp', the internet address of the requester. The value of all bit's is zero if not available or not applicable. The Format of this address depends on the value of the ccmHistoryEventCommandSourceAddrType object. This object deprecates ccmHistoryEventCommandSourceAddress

ccmHistoryEventServerAddrType

1.3.6.1.4.1.9.9.43.1.1.6.1.18

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the transport type of the address contained in ccmHistoryEventServerAddrRev1. The value will be zero if not available or not aplicable.

ccmHistoryEventServerAddrRev1

1.3.6.1.4.1.9.9.43.1.1.6.1.19

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

If ccmHistoryEventConfigSource or ccmHistoryEventConfigDestination is 'networkTftp' or 'networkRcp', the internet address of the storage file server. The value of all bits is 0s if not applicable or not available. The Format of this address depends on the value of the ccmHistoryEventServerAddrType object. This object deprecates ccmHistoryEventServerAddress.

ccmCLIHistoryCommandTable

1.3.6.1.4.1.9.9.43.1.2.4

Index: ccmHistoryEventIndex · ccmCLIHistoryCommandIndex

A table of CLI commands that took effect during configuration events.

ccmCLIHistoryCommandIndex

1.3.6.1.4.1.9.9.43.1.2.4.1.1

Unsigned32 (1..4294967295)

A monotonically increasing integer for the purpose of indexing CLI commands which took effect during a configuration event.

ccmCLIHistoryCommand

1.3.6.1.4.1.9.9.43.1.2.4.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The CLI command entered which took effect during the configuration event pointed by ccmHistoryEventIndex.

Trap details

ciscoConfigManEvent

1.3.6.1.4.1.9.9.43.2.0.1

Notification of a configuration management event as recorded in ccmHistoryEventTable.

ccmHistoryEventCommandSource

1.3.6.1.4.1.9.9.43.1.1.6.1.3

INTEGER1 = commandLine2 = snmp · Integer32

The source of the command that instigated the event.

ccmHistoryEventConfigSource

1.3.6.1.4.1.9.9.43.1.1.6.1.4

HistoryEventMedium1 = erase2 = commandSource3 = running4 = startup5 = local6 = networkTftp7 = networkRcp8 = networkFtp9 = networkScpThe source or destination of a configuration change, save, or copy. erase erasing destination (source only) running live operational data commandSource the command source itself startup what the system will use next reboot local local NVRAM or flash networkTftp network host via Trivial File Transfer networkRcp network host via Remote Copy networkFtp network host via File transfer networkScp network host via Secure Copy · Integer32

The configuration data source for the event.

ccmHistoryEventConfigDestination

1.3.6.1.4.1.9.9.43.1.1.6.1.5

HistoryEventMedium1 = erase2 = commandSource3 = running4 = startup5 = local6 = networkTftp7 = networkRcp8 = networkFtp9 = networkScpThe source or destination of a configuration change, save, or copy. erase erasing destination (source only) running live operational data commandSource the command source itself startup what the system will use next reboot local local NVRAM or flash networkTftp network host via Trivial File Transfer networkRcp network host via Remote Copy networkFtp network host via File transfer networkScp network host via Secure Copy · Integer32

The configuration data destination for the event.

ccmHistoryEventTerminalUser

1.3.6.1.4.1.9.9.43.1.1.6.1.8

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a

If ccmHistoryEventCommandSource is 'commandLine', the name of the logged in user. The length is zero if not available or not applicable.

ccmCLIRunningConfigChanged

1.3.6.1.4.1.9.9.43.2.0.2

This notification indicates that the running configuration of the managed system has changed from the CLI. If the managed system supports a separate configuration mode(where the configuration commands are entered under a configuration session which affects the running configuration of the system), then this notification is sent when the configuration mode is exited. During this configuration session there can be one or more running configuration changes.

ccmHistoryRunningLastChanged

1.3.6.1.4.1.9.9.43.1.1.1

TimeTicks

The value of sysUpTime when the running configuration was last changed. If the value of ccmHistoryRunningLastChanged is greater than ccmHistoryRunningLastSaved, the configuration has been changed but not saved.

ccmHistoryEventTerminalType

1.3.6.1.4.1.9.9.43.1.1.6.1.6

INTEGER1 = notApplicable2 = unknown3 = console4 = terminal5 = virtual6 = auxiliary · Integer32

If ccmHistoryEventCommandSource is 'commandLine', the terminal type, otherwise 'notApplicable'.

ccmHistoryEventTerminalUser

1.3.6.1.4.1.9.9.43.1.1.6.1.8

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..64) · OCTET STRING · hint 255a

If ccmHistoryEventCommandSource is 'commandLine', the name of the logged in user. The length is zero if not available or not applicable.

ccmCTIDRolledOver

1.3.6.1.4.1.9.9.43.2.0.3

This notification indicates that the Config Change Tracking ID has rolled over and will be reset.

↑ To TOC