EZ5 MIB Catalog

CISCO-CUICAPPS-MIB

2010-01-23

The Cisco Unified Intelligence Center (CUIC) is a scalable robust and secure reporting solution for contact center applications. The CUIC application can be deployed on multiple servers that form a cluster, where each server hosts a reporting engine. The CISCO-CUICAPPS-MIB defines objects that describe instrumentation implemented by the components comprising CUIC. DEFINITION OF TERMS AND ACRONYMS CUIC Cisco Unified Intelligence Center cluster A group of CUIC servers deployed and associated to form high availability model. sub system A subsystem is a coherent and somewhat independent component of a larger system. Service A functional component of the CUIC application publisher A server in a CUIC cluster which provides administration facility. first node Publisher node is alternatively referred as first node. Connector A CUIC Tomcat Connector represents an endpoint that receives requests and sends responses. The Connector handles HTTP/HTTPS requests and sends HTTP/HTTPS responses that occur when CUIC - related web pages are accessed. data source Data source is a connection to a database server.

Download CISCO-CUICAPPS-MIB.txt Open CISCO-CUICAPPS-MIB.txt in a new tab

SCALARS (21) · TABLES (8) · TRAPS (1)

Scalars (21)

NameOID
cuicThreadsMaxAvailable1.3.6.1.4.1.9.9.718.1.9.1
cuicThreadsRunning1.3.6.1.4.1.9.9.718.1.9.2
cuicQueuedTasks1.3.6.1.4.1.9.9.718.1.9.3
cuicQueuedTasksMax1.3.6.1.4.1.9.9.718.1.9.4
cuicWaErrors1.3.6.1.4.1.9.9.718.1.10.1
cuicWaSessionsActive1.3.6.1.4.1.9.9.718.1.10.2
cuicJvmPercentCPUTime1.3.6.1.4.1.9.9.718.1.10.3
cuicJvmMemoryFree1.3.6.1.4.1.9.9.718.1.10.4
cuicJvmMemoryTotal1.3.6.1.4.1.9.9.718.1.10.5
cuicJvmMemoryMax1.3.6.1.4.1.9.9.718.1.10.6
cuicTomcatThreadsBusy1.3.6.1.4.1.9.9.718.1.10.7
cuicTomcatThreadsTotal1.3.6.1.4.1.9.9.718.1.10.8
cuicTomcatThreadsMax1.3.6.1.4.1.9.9.718.1.10.9
cuicEventId1.3.6.1.4.1.9.9.718.1.11.1
cuicEventHostName1.3.6.1.4.1.9.9.718.1.11.2
cuicEventAppName1.3.6.1.4.1.9.9.718.1.11.3
cuicEventName1.3.6.1.4.1.9.9.718.1.11.4
cuicEventState1.3.6.1.4.1.9.9.718.1.11.5
cuicEventSeverity1.3.6.1.4.1.9.9.718.1.11.6
cuicEventTimestamp1.3.6.1.4.1.9.9.718.1.11.7
cuicEventText1.3.6.1.4.1.9.9.718.1.11.8

Tables (8)

NameOID
cuicGeneralInfoTable1.3.6.1.4.1.9.9.718.1.1
cuicLicenseInfoTable1.3.6.1.4.1.9.9.718.1.2
cuicReportingTable1.3.6.1.4.1.9.9.718.1.3
cuicSchedulerTable1.3.6.1.4.1.9.9.718.1.4
cuicDbInfoTable1.3.6.1.4.1.9.9.718.1.5
cuicClusterTable1.3.6.1.4.1.9.9.718.1.6
cuicDatasourceTable1.3.6.1.4.1.9.9.718.1.7
cuicSecurityTable1.3.6.1.4.1.9.9.718.1.8

Traps (1)

NameOID
ciscoCuicappsMIBEvent1.3.6.1.4.1.9.9.718.0.1

END OF TOC

Scalar details

cuicThreadsMaxAvailable

1.3.6.1.4.1.9.9.718.1.9.1

Gauge32 · threads

This object indicates the maximum number of threads available to the CUIC web server's thread pool manager.

cuicThreadsRunning

1.3.6.1.4.1.9.9.718.1.9.2

Gauge32 · threads

This object indicates the number of threads that are currently running tasks. This counter is useful in monitoring performance of the server. If the number of threads is close to maximum available, then next reporting request will have to wait till a thread becomes free.

cuicQueuedTasks

1.3.6.1.4.1.9.9.718.1.9.3

Gauge32 · tasks

This object indicates the number of queued tasks. A task is a job, performed by one or more thread.

cuicQueuedTasksMax

1.3.6.1.4.1.9.9.718.1.9.4

Gauge32 · tasks

This object indicates the maximum number of queued tasks.

cuicWaErrors

1.3.6.1.4.1.9.9.718.1.10.1

Counter32 · errors

This object indicates the total number of HTTP errors (for example, 401 Unauthorized) encountered by a CUIC-related web application.

cuicWaSessionsActive

1.3.6.1.4.1.9.9.718.1.10.2

Gauge32 · sessions

This object indicates the number of currently active (in use) sessions the web application currently has

cuicJvmPercentCPUTime

1.3.6.1.4.1.9.9.718.1.10.3

Gauge32 (0..100) · percent

This object indicates the percentage of CPU utilized by the Tomcat JVM. This object is for the CUIC Tomcat JVM object.

cuicJvmMemoryFree

1.3.6.1.4.1.9.9.718.1.10.4

Gauge32 · kilo bytes

This object indicates the amount of free dynamic memory in the CUIC Tomcat Java Virtual Machine.

cuicJvmMemoryTotal

1.3.6.1.4.1.9.9.718.1.10.5

Gauge32 · kilo bytes

This object indicates the Tomcat Java Virtual Machine current total dynamic memory including free and in-use memory.

cuicJvmMemoryMax

1.3.6.1.4.1.9.9.718.1.10.6

Gauge32 · kilo bytes

This object indicates the CUIC Tomcat Java Virtual Machine maximum dynamic size.

cuicTomcatThreadsBusy

1.3.6.1.4.1.9.9.718.1.10.7

Gauge32 · threads

This object indicates the CUIC Tomcat Connector's current number of busy/in-use request processing threads.

cuicTomcatThreadsTotal

1.3.6.1.4.1.9.9.718.1.10.8

Gauge32 · threads

This object indicates the CUIC tomcat Connector's current total number of request processing threads, including available and in-use threads.

cuicTomcatThreadsMax

1.3.6.1.4.1.9.9.718.1.10.9

Gauge32 · threads

This object indicates the Connector maximum number of request processing threads. Each incoming request on a CUIC -related web page requires a thread for the duration of that request. If more simultaneous requests are received than can be handled by the currently available request processing threads, additional threads will be created up to the configured maximum shown in this counter.

cuicEventId

1.3.6.1.4.1.9.9.718.1.11.1

Unsigned32

The event ID is the unique notification message identifier that is assigned by the CUIC application. This identifier is unique for each different notification but consistent for each instance of the same notification. This id can be used to correlate raise and clear notification.

cuicEventHostName

1.3.6.1.4.1.9.9.718.1.11.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The event host name object specifies the host name or the fully qualified domain name of the CUIC server from which this event originated.

cuicEventAppName

1.3.6.1.4.1.9.9.718.1.11.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The event application name object specifies the service-specific name of the functional service that generated this notification.

cuicEventName

1.3.6.1.4.1.9.9.718.1.11.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The event name object specifies the service-specific name of the CUIC service notification message. The object value is used to group and correlate similar notifications.

cuicEventState

1.3.6.1.4.1.9.9.718.1.11.5

INTEGER1 = raise2 = clear · Integer32

The event state object identifies the state (not to be confused with severity) of the notification and potentially the current state of the functional component that generated the notification. The possible states are: 'raise': A raise state identifies a notification received as a result of a health-impacting condition, such as a process failure. A subsequent clear state notification will follow when the error condition is resolved. 'clear': The clear state indicates that the condition which generated a previous raise notification has been resolved.

cuicEventSeverity

1.3.6.1.4.1.9.9.718.1.11.6

INTEGER1 = emergency2 = alert3 = critical4 = error5 = warning6 = notice7 = informational8 = debug · Integer32

The event severity object indicates the severity level of this notification. The severity levels are: 'emergency': The notification indicates that a devastating failure has occurred; the system or service is unusable. Immediate operator intervention is required. 'alert': The notification indicates that a devastating failure is imminent that will render the system unusable. Immediate operator attention is necessary. 'critical': The notification indicates that a service impacting failure is likely to occur soon; an error has occurred that was not appropriately handled by the system. Operator attention is needed as soon as possible. 'error': The notification contains important operational state information and may indicate that the system has experienced a temporary impairment or an error that was appropriately handled by the system. An operator should review the notification soon to determine if action is needed. 'warning': The notification contains important operational state information that may be a precursor to an error occurrence. An operator should review the notification soon to determine if action is needed. 'notice': The notification contains health or operational state information that may be pertinent to the health of the system but does not require the attention of the administrator at this time. 'informational': The notification contains interesting system-level information that is valuable to an administrator, however, the event itself does not indicate a failure or impairment condition. 'debug': The notification provides supplemental information that may be beneficial toward diagnosing or resolving a problem but does not in itself provide operational health status.

cuicEventTimestamp

1.3.6.1.4.1.9.9.718.1.11.7

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The event time stamp object specifies the date and time that the notification was generated on the originating device.

cuicEventText

1.3.6.1.4.1.9.9.718.1.11.8

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The event text is the full text of the notification. This text includes a description of the event that was generated, component state information and potentially a brief description of administrative action that may be necessary to correct the condition that caused the event to occur.

Table details

cuicGeneralInfoTable

1.3.6.1.4.1.9.9.718.1.1

Index: cuicGeneralInfoIndex

This table contains a list of CUIC servers

cuicGeneralInfoIndex

1.3.6.1.4.1.9.9.718.1.1.1.1

CuicSubsystemIdSub System ID is five digit unique identifier for a given CUIC server in a cluster. For example an the value could be like 43009. (0..2147483647) · Unsigned32 · hint d

This object indicates the sub-system identifier assigned to the CUIC reporting component.

cuicGeneralInfoServerName

1.3.6.1.4.1.9.9.718.1.1.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object indicates the host name of a CUIC server.

cuicGeneralInfoServerDescription

1.3.6.1.4.1.9.9.718.1.1.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object indicates a textual description of the CUIC application installed on this server. This information is same as description entered for the application during installation.

cuicGeneralInfoVersion

1.3.6.1.4.1.9.9.718.1.1.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object indicates the version number of the CUIC software installed on the server. The following illustrates the format of the value for an instance of this object: CUIC_<major>_<minor>_<buildnumber> where, <major> is an integer denoting Major revision number. <minor> is an integer denoting minor revision number. <buildnumebr> is an integer denoting the build number.

cuicGeneralInfoStartTime

1.3.6.1.4.1.9.9.718.1.1.1.5

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This object indicates the CUIC application server starting time.

cuicGeneralInfoTimeZoneName

1.3.6.1.4.1.9.9.718.1.1.1.6

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object indicates the time zone where the CUIC server is physically located.

cuicGeneralInfoSystemStatus

1.3.6.1.4.1.9.9.718.1.1.1.7

CuicServiceStatus1 = inService2 = partialService3 = notResponding4 = unknownThis textual convention denotes the run status of a CUIC's service. The value is the result of evaluating the current run status of each of the individual elements associated with the service. 'inService' The service is up and running optimally. 'partialService' Some of the components comprising the application are not running; service is in warning state. 'notResponding' The service is either shut down or not responding. 'unknown' The service status is unknown · Integer32

This object indicates, last known status of the application.

cuicGeneralInfoOpsConsoleURL

1.3.6.1.4.1.9.9.718.1.1.1.8

CiscoURLStringThis textual convention defines the URL string. The Universal Resource Locator(URL). The URL strings are compact string representation for a resource available via internet. This is the address location of the page to load. The string should represent a fully qualifying string with the format 'protocol:/server/page'. In general the string should point to any value that can be saved/loaded. Any limitation for the URL must be defined as part of the description of any object which uses this syntax.Reference: Uniform Resource Locators. RFC 1738. SIZE (1..255) · OCTET STRING

This object indicates the URL for CUIC operations Console web server. The operations console offers a web-based, centralized interface for mapping and summarizing the solution network configuration, setting and displaying configuration information on a batch or per-Device basis and storing local copies of those configurations. Other functions include troubleshooting, health monitoring and direct administration.

cuicGeneralInfoEnableNotifications

1.3.6.1.4.1.9.9.718.1.1.1.9

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies the notification status to management station, to disable and alternatively enable outbound notifications on this server.

cuicLicenseInfoTable

1.3.6.1.4.1.9.9.718.1.2

Index: cuicLicenseInfoIndex

This table contains a list of CUIC servers where license is instaled on. Usually license is installed on a publisher node.

cuicLicenseInfoIndex

1.3.6.1.4.1.9.9.718.1.2.1.1

CuicSubsystemIdSub System ID is five digit unique identifier for a given CUIC server in a cluster. For example an the value could be like 43009. (0..2147483647) · Unsigned32 · hint d

This object indicates the sub-system identifier assigned to the CUIC reporting component.

cuicLicenseInfoType

1.3.6.1.4.1.9.9.718.1.2.1.2

INTEGER1 = unknown2 = trial3 = standard4 = premium · Integer32

This object specifies the type of license installed. trial license exipire in 90 days. standard and premium license supports unlimited number of users but latter supports premium features.

cuicLicenseInfoStartTime

1.3.6.1.4.1.9.9.718.1.2.1.3

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This object specifies the CUIC application license install time.

cuicLicenseInfoExpirationTime

1.3.6.1.4.1.9.9.718.1.2.1.4

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This object specifies the CUIC application license expiration time.

cuicLicenseInfoHost

1.3.6.1.4.1.9.9.718.1.2.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the host name of the publisher node. CUIC license will be installed on publisher node of the CUIC cluster.

cuicReportingTable

1.3.6.1.4.1.9.9.718.1.3

Index: cuicReportingIndex

This table contains a list of CUIC Reporting Engine. CUIC is a reporting software for Cisco Call Center application and reporting engine is a main component of this application.

cuicReportingIndex

1.3.6.1.4.1.9.9.718.1.3.1.1

CuicSubsystemIdSub System ID is five digit unique identifier for a given CUIC server in a cluster. For example an the value could be like 43009. (0..2147483647) · Unsigned32 · hint d

This object indicates the sub-system identifier assigned to the CUIC reporting component.

cuicReportingDataSourceCount

1.3.6.1.4.1.9.9.718.1.3.1.2

Gauge32 · data sources

This object indicates the number of data sources configured on the CUIC application. CUIC application require data source connection to be setup to a database server. CUIC reports read data from an associated and data source.

cuicReportingEngineStatus

1.3.6.1.4.1.9.9.718.1.3.1.3

CuicServiceStatus1 = inService2 = partialService3 = notResponding4 = unknownThis textual convention denotes the run status of a CUIC's service. The value is the result of evaluating the current run status of each of the individual elements associated with the service. 'inService' The service is up and running optimally. 'partialService' Some of the components comprising the application are not running; service is in warning state. 'notResponding' The service is either shut down or not responding. 'unknown' The service status is unknown · Integer32

This object indicates the last known status of the Reporting Engine component. The CUIC Reporting Engine component is responsible for fetching data from data source and pass it to a report.

cuicReportingHistoricalReportDefinitionCount

1.3.6.1.4.1.9.9.718.1.3.1.4

Gauge32 · report definitions

This object indicates the number of historical report definitions installed on the CUIC application. A Report definition is template for a report. A report has an association with a report definition. CUIC application has two types of report definitions: real time and historical.

cuicReportingRealTimeReportDefinitionCount

1.3.6.1.4.1.9.9.718.1.3.1.5

Gauge32 · report definitions

This object indicates the number of real time reports installed on the CUIC application. A Report definition is template for a report. A report has an association with a report definition. CUIC application has two types of reports: real time and historical.

cuicReportingHistoricalReportRunning

1.3.6.1.4.1.9.9.718.1.3.1.6

Gauge32 · reports

This object indicates the number of historical reports that are currently running.

cuicReportingHistoricalReportWaiting

1.3.6.1.4.1.9.9.718.1.3.1.7

Gauge32 · reports

This object indicates the number of historical reports that are currently waiting to execute.

cuicReportingTotalKickedOffHistoricalReports

1.3.6.1.4.1.9.9.718.1.3.1.8

Counter32 · reports

This object indicates the total number of historical reports that have been launched.

cuicReportingRealTimeReportRunning

1.3.6.1.4.1.9.9.718.1.3.1.9

Gauge32 · reports

This object indicates the number of real time reports that are currently running.

cuicReportingTotalKickedOffRealTimeReports

1.3.6.1.4.1.9.9.718.1.3.1.10

Counter32 · reports

This object indicates the total number of real time reports that have been launched.

cuicReportingRealTimeReportWaiting

1.3.6.1.4.1.9.9.718.1.3.1.11

Gauge32 · reports

This object indicates the number of real time reports that are currently waiting to be executed.

cuicSchedulerTable

1.3.6.1.4.1.9.9.718.1.4

Index: cuicSchedulerIndex

This table contains a list of CUIC Scheduler Component. The Scheduler is a component that allows users to run reports at some time in the future. Either once or periodically and have the reports be delivered via email or show in a dashboard.

cuicSchedulerIndex

1.3.6.1.4.1.9.9.718.1.4.1.1

CuicSubsystemIdSub System ID is five digit unique identifier for a given CUIC server in a cluster. For example an the value could be like 43009. (0..2147483647) · Unsigned32 · hint d

This object indicates the sub-system identifier assigned to the CUIC reporting component.

cuicSchedulerStatus

1.3.6.1.4.1.9.9.718.1.4.1.2

CuicServiceStatus1 = inService2 = partialService3 = notResponding4 = unknownThis textual convention denotes the run status of a CUIC's service. The value is the result of evaluating the current run status of each of the individual elements associated with the service. 'inService' The service is up and running optimally. 'partialService' Some of the components comprising the application are not running; service is in warning state. 'notResponding' The service is either shut down or not responding. 'unknown' The service status is unknown · Integer32

This object indicates the status of the Report Scheduler engine.

cuicSchedulerEmailServerStatus

1.3.6.1.4.1.9.9.718.1.4.1.3

CuicServiceStatus1 = inService2 = partialService3 = notResponding4 = unknownThis textual convention denotes the run status of a CUIC's service. The value is the result of evaluating the current run status of each of the individual elements associated with the service. 'inService' The service is up and running optimally. 'partialService' Some of the components comprising the application are not running; service is in warning state. 'notResponding' The service is either shut down or not responding. 'unknown' The service status is unknown · Integer32

This object indicates the status of the emailing server. The Report Scheduler allows users to run reports at some time in future. Either once or periodically and have the report results be delivered via email.

cuicSchedulerJobsCompletedCount

1.3.6.1.4.1.9.9.718.1.4.1.4

Counter32 · jobs

This object indicates the number of jobs that the scheduler service has completed.

cuicSchedulerJobsRunningCount

1.3.6.1.4.1.9.9.718.1.4.1.5

Gauge32 · jobs

This object indicates the number of jobs that the scheduler service is currently running.

cuicSchedulerJobsFailedCount

1.3.6.1.4.1.9.9.718.1.4.1.6

Counter32 · jobs

This object indicates the number of jobs that the scheduler service has failed to complete successfully.

cuicDbInfoTable

1.3.6.1.4.1.9.9.718.1.5

Index: cuicDbInfoIndex

This table contains a list database servers. CUIC reporting server uses database to store reports and configurations.

cuicDbInfoIndex

1.3.6.1.4.1.9.9.718.1.5.1.1

CuicSubsystemIdSub System ID is five digit unique identifier for a given CUIC server in a cluster. For example an the value could be like 43009. (0..2147483647) · Unsigned32 · hint d

This object indicates the sub-system identifier assigned to the CUIC reporting component.

cuicDbInfoStatus

1.3.6.1.4.1.9.9.718.1.5.1.2

CuicServiceStatus1 = inService2 = partialService3 = notResponding4 = unknownThis textual convention denotes the run status of a CUIC's service. The value is the result of evaluating the current run status of each of the individual elements associated with the service. 'inService' The service is up and running optimally. 'partialService' Some of the components comprising the application are not running; service is in warning state. 'notResponding' The service is either shut down or not responding. 'unknown' The service status is unknown · Integer32

This object indicates the status of the Database Server.

cuicDbInfoReplicationStatus

1.3.6.1.4.1.9.9.718.1.5.1.3

CuicServiceStatus1 = inService2 = partialService3 = notResponding4 = unknownThis textual convention denotes the run status of a CUIC's service. The value is the result of evaluating the current run status of each of the individual elements associated with the service. 'inService' The service is up and running optimally. 'partialService' Some of the components comprising the application are not running; service is in warning state. 'notResponding' The service is either shut down or not responding. 'unknown' The service status is unknown · Integer32

This object indicates the status of replication server. CUIC replicates a database to other CUIC servers in a cluster.

cuicDbInfoTmpSpaceUsed

1.3.6.1.4.1.9.9.718.1.5.1.4

Gauge32 (0..100) · percent

This object indicates the percentage temporary disk space used.

cuicDbInfoSpaceUsed

1.3.6.1.4.1.9.9.718.1.5.1.5

Gauge32 (0..100) · percent

This object indicates the percentage database disk space.

cuicClusterTable

1.3.6.1.4.1.9.9.718.1.6

Index: cuicClusterIndex

This table contains a list of cluster information. CUIC can consist of multiple servers that form a cluster.

cuicClusterIndex

1.3.6.1.4.1.9.9.718.1.6.1.1

CuicSubsystemIdSub System ID is five digit unique identifier for a given CUIC server in a cluster. For example an the value could be like 43009. (0..2147483647) · Unsigned32 · hint d

This object indicates the sub-system identifier assigned to the CUIC reporting component.

cuicClusterName

1.3.6.1.4.1.9.9.718.1.6.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the unique name of cluster. At any point in time, the cluster name helps in associating a device to any given cluster.

cuicClusterServerCount

1.3.6.1.4.1.9.9.718.1.6.1.3

Gauge32 · servers

This object specifies the number of CUIC servers in this cluster.

cuicClusterFirstNodeName

1.3.6.1.4.1.9.9.718.1.6.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the hostname of the first node server (Publisher node).

cuicDatasourceTable

1.3.6.1.4.1.9.9.718.1.7

Index: cuicDatasourceIndex

This table contains a list of data sources configured in CUIC server. The data for the report has to come from a database server. There will be data sources configured in the CUIC application to connect to a particular database.

cuicDatasourceIndex

1.3.6.1.4.1.9.9.718.1.7.1.1

Unsigned32 (1..1000)

This object indicates a row index which is an integer starting from value one.

cuicDatasourceName

1.3.6.1.4.1.9.9.718.1.7.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object indicates the name of the data source configured in the CUIC application.

cuicDatasourceStatus

1.3.6.1.4.1.9.9.718.1.7.1.3

INTEGER1 = online2 = offline3 = unknown · Integer32

This object indicates the status of the datsource. The data sources configured in CUIC application can go offline due to various reasons. The value can be, 'online' The data source is connected and it is online. 'offline' The data source is disconnected and it is offline. 'unknown' The data source connectivity status is unknown.

cuicDatasourceHost

1.3.6.1.4.1.9.9.718.1.7.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object indicates the host name of database server.

cuicDatasourceType

1.3.6.1.4.1.9.9.718.1.7.1.5

INTEGER1 = other2 = mssql3 = informix · Integer32

This object indicates the vendor name. CUIC can support different vendor data sources like MSSQL,IBM Informix etc.

cuicSecurityTable

1.3.6.1.4.1.9.9.718.1.8

Index: cuicSecurityIndex

This table contains a list of CUIC server's security information. CUIC application is a multiuser system. There can be many number of users and groups configured. This table gives information about users and groups.

cuicSecurityIndex

1.3.6.1.4.1.9.9.718.1.8.1.1

CuicSubsystemIdSub System ID is five digit unique identifier for a given CUIC server in a cluster. For example an the value could be like 43009. (0..2147483647) · Unsigned32 · hint d

This object indicates the sub-system identifier assigned to the CUIC reporting component.

cuicSecurityUsersConfigured

1.3.6.1.4.1.9.9.718.1.8.1.2

Gauge32 · users

This object indicates number of users configured to access CUIC application.

cuicSecurityUsersLoggedIn

1.3.6.1.4.1.9.9.718.1.8.1.3

Gauge32 · users

This object indicates the number of users currently logged in.

cuicSecurityLoginFailedAttempts

1.3.6.1.4.1.9.9.718.1.8.1.4

Counter32

This object indicates the number of rejected login attempts.

cuicSecurityGroupsConfigured

1.3.6.1.4.1.9.9.718.1.8.1.5

Gauge32 · groups

This object indicates the overall number of groups configured on this server. There can be different groups with various privileges; Like Admin, Restricted, Designer etc. Each group can share objects like Reports, Report Definition etc.

Trap details

ciscoCuicappsMIBEvent

1.3.6.1.4.1.9.9.718.0.1

This notification indicates an unusual condition occur that potentially, can affect the functioning of a service in CUIC. Notification describes the operation state information of a service when such service impacting conditions occur. Notification is sent by a functional service of the CUIC application.

cuicEventId

1.3.6.1.4.1.9.9.718.1.11.1

Unsigned32

The event ID is the unique notification message identifier that is assigned by the CUIC application. This identifier is unique for each different notification but consistent for each instance of the same notification. This id can be used to correlate raise and clear notification.

cuicEventHostName

1.3.6.1.4.1.9.9.718.1.11.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The event host name object specifies the host name or the fully qualified domain name of the CUIC server from which this event originated.

cuicEventAppName

1.3.6.1.4.1.9.9.718.1.11.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The event application name object specifies the service-specific name of the functional service that generated this notification.

cuicEventName

1.3.6.1.4.1.9.9.718.1.11.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The event name object specifies the service-specific name of the CUIC service notification message. The object value is used to group and correlate similar notifications.

cuicEventState

1.3.6.1.4.1.9.9.718.1.11.5

INTEGER1 = raise2 = clear · Integer32

The event state object identifies the state (not to be confused with severity) of the notification and potentially the current state of the functional component that generated the notification. The possible states are: 'raise': A raise state identifies a notification received as a result of a health-impacting condition, such as a process failure. A subsequent clear state notification will follow when the error condition is resolved. 'clear': The clear state indicates that the condition which generated a previous raise notification has been resolved.

cuicEventSeverity

1.3.6.1.4.1.9.9.718.1.11.6

INTEGER1 = emergency2 = alert3 = critical4 = error5 = warning6 = notice7 = informational8 = debug · Integer32

The event severity object indicates the severity level of this notification. The severity levels are: 'emergency': The notification indicates that a devastating failure has occurred; the system or service is unusable. Immediate operator intervention is required. 'alert': The notification indicates that a devastating failure is imminent that will render the system unusable. Immediate operator attention is necessary. 'critical': The notification indicates that a service impacting failure is likely to occur soon; an error has occurred that was not appropriately handled by the system. Operator attention is needed as soon as possible. 'error': The notification contains important operational state information and may indicate that the system has experienced a temporary impairment or an error that was appropriately handled by the system. An operator should review the notification soon to determine if action is needed. 'warning': The notification contains important operational state information that may be a precursor to an error occurrence. An operator should review the notification soon to determine if action is needed. 'notice': The notification contains health or operational state information that may be pertinent to the health of the system but does not require the attention of the administrator at this time. 'informational': The notification contains interesting system-level information that is valuable to an administrator, however, the event itself does not indicate a failure or impairment condition. 'debug': The notification provides supplemental information that may be beneficial toward diagnosing or resolving a problem but does not in itself provide operational health status.

cuicEventTimestamp

1.3.6.1.4.1.9.9.718.1.11.7

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The event time stamp object specifies the date and time that the notification was generated on the originating device.

cuicEventText

1.3.6.1.4.1.9.9.718.1.11.8

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The event text is the full text of the notification. This text includes a description of the event that was generated, component state information and potentially a brief description of administrative action that may be necessary to correct the condition that caused the event to occur.

↑ To TOC