Specifies the peer search preference based on the type of peers in an universal/integrated port platform.
none - both voice and data peers are searched
in same preference. datavoice - search data peers first. If no data peers are found, the voice peers are searched. voicedata - search voice peers first. If no voice peers are found, the data peers are searched.
Table details
cCallHistoryTable
1.3.6.1.4.1.9.10.25.1.4.3
Index: cCallHistoryIndex
A table containing information about specific calls to a specific destination.
cCallHistoryIndex
1.3.6.1.4.1.9.10.25.1.4.3.1.1
Unsigned32 (1..4294967295)
A monotonically increasing integer for the sole purpose of indexing call disconnection events. When it reaches the maximum value, an extremely unlikely event, the agent wraps the value back to 1 and may flush existing entries.
cCallHistorySetupTime
1.3.6.1.4.1.9.10.25.1.4.3.1.2
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime when the call setup was started. This will be useful for an NMS to sort the call history entry with call setup time. Also, this object can be useful in finding large delays between the time the call was started and the time the call was connected. For ISDN media, this will be the time when the setup message was received from or sent to the network. The value of this object is the same as callActiveSetupTime in the callActiveTable
cCallHistoryPeerAddress
1.3.6.1.4.1.9.10.25.1.4.3.1.3
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The number this call was connected to. If the number is not available, then it will have a length of zero.
cCallHistoryPeerSubAddress
1.3.6.1.4.1.9.10.25.1.4.3.1.4
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The subaddress this call was connected to. If the subaddress is undefined or not available, this will be a zero length string.
cCallHistoryPeerId
1.3.6.1.4.1.9.10.25.1.4.3.1.5
INTEGER (0..2147483647) · Integer32
This is the Id value of the peer table entry to which this call was made. If a peer table entry for this call does not exist, the value of this object will be zero.
cCallHistoryPeerIfIndex
1.3.6.1.4.1.9.10.25.1.4.3.1.6
INTEGER (0..2147483647) · Integer32
This is the ifIndex value of the peer table entry to which this call was made. If a peer table entry for this call does not exist, the value of this object will be zero.
cCallHistoryLogicalIfIndex
1.3.6.1.4.1.9.10.25.1.4.3.1.7
InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d
This is the ifIndex value of the logical interface through which this call was made. For ISDN media, this would be the ifIndex of the B channel which was used for this call. If the ifIndex value is unknown, the value of this object will be zero. For an IP call, the value will be zero.
cCallHistoryDisconnectCause
1.3.6.1.4.1.9.10.25.1.4.3.1.8
OCTET STRING SIZE (0..4)
The encoded network cause value associated with this call.
The value of this object will depend on the interface type as well as on the protocol and protocol version being used on this interface. Some references for possible cause values are given below. Reference: - Bellcore SR-NWT-001953, Generic Guidelines for ISDN Terminal Equipment On Basic Access Interfaces, chapter 5.2.5.8. - Bellcore SR-NWT-002343, ISDN Primary Rate Interface Generic Guidelines for Customer Premises Equipment, chapter 8.2.5.8. - ITU-T Q.931, Appendix I. - ITU-T X.25, CAUSE and DIAGNOSTIC field values. - German Telekom FTZ 1TR6, chapter 3.2.3.4.4.4.
cCallHistoryDisconnectText
1.3.6.1.4.1.9.10.25.1.4.3.1.9
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
ASCII text describing the reason for call termination.
This object exists because it would be impossible for a management station to store all possible cause values for all types of interfaces. It should be used only if a management station is unable to decode the value of dialCtlPeerStatsLastDisconnectCause.
cCallHistoryConnectTime
1.3.6.1.4.1.9.10.25.1.4.3.1.10
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime when the call was connected.
cCallHistoryDisconnectTime
1.3.6.1.4.1.9.10.25.1.4.3.1.11
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime when the call was disconnected.
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32
The number of charged units for this connection. For incoming calls or if charging information is not supplied by the switch, the value of this object will be zero.
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32
The number of packets which were transmitted while this call was active.
cCallHistoryTransmitBytes
1.3.6.1.4.1.9.10.25.1.4.3.1.16
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32
The number of bytes which were transmitted while this call was active.
cCallHistoryReceivePackets
1.3.6.1.4.1.9.10.25.1.4.3.1.17
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32
The number of packets which were received while this call was active.
cCallHistoryReceiveBytes
1.3.6.1.4.1.9.10.25.1.4.3.1.18
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32
The number of bytes which were received while this call was active.
Originator of the call release. Indicates the source of the call release as follows : 1) callingPartyInPstn : Calling party in PSTN. 2) callingPartyInVoip : Calling party in VoIP. 3) calledPartyInPstn : Called party in PSTN. 4) calledPartyInVoip : Called party in VoIP. 5) internalReleaseInPotsLeg : Due to an internal error in Telephony call leg. 6) internalReleaseInVoipLeg : Due to an internal error in VoIP call leg. 7) internalCallControlApp : Due to an internal error in Session Application or Tcl or VXML script originated release. 8) internalReleaseInVoipAAA : Due to an internal error in VoIP AAA module. 9) consoleCommand : Due to CLI or MML. 10) externalRadiusServer : Call failed during authorization , authentication or due to receipt of POD from the RADIUS server. 11) externalNmsApp : Due to SNMP request to clear the call. 12) externalCallControlAgent : External Call Control Agent initiated clear. 13) gatekeeper : Gatekeeper initiated clear due to receipt of Admission Reject, Disengage Request message. 14) externalGKTMPServer : External GKTMP server initiated clear due to receipt of Admission Reject message from the gatekeeper, triggered by RESPONSE.ARJ message from the GKTMP server.
cCallHistoryIecTable
1.3.6.1.4.1.9.10.25.1.4.4
Index: cCallHistoryIndex · cCallHistoryIecIndex
This table contains information about Internal Error Code(s) (IEC) which caused the call to fail.
cCallHistoryIecIndex
1.3.6.1.4.1.9.10.25.1.4.4.1.1
Unsigned32 (1..1024)
This object is used to index one or more IECs in the context of a single call. In most cases there will only be one IEC when a call fails. However, it is possible for the software processing the call to generate multiple IECs before the call ultimately fails. In that scenario, there will be multiple entries in this table related to a single call (cCallHistoryIndex) and this object will serve to uniquely identify each IEC.
cCallHistoryIec
1.3.6.1.4.1.9.10.25.1.4.4.1.2
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This object reflects the Internal Error Code. The format is a string of dotted decimal numbers composed of the following components:
Version.Entity.Category.Subsystem.Errorcode.Diagnostic
Each component is defined as follows:
Version : The version of IEC software.
Entity : The network entity that originated
the error.
Category : The category of the error (eg, software
error, hardware resource unavailable, ...)
Subsystem : The subsystem in which the error occurred.
Errorcode : A subsytem-specific error code.
Diagnostic : An implementation-specific diagnostic code.