The MIB module for management of Cisco specific Data Link Switching protocol enhancements. DLSw is described in RFC 1795 and RFC 2024.
DLSw+ Defined
Data link switching Plus (DLSw+) is a means of transporting Systems Network Architecture (SNA) and NetBIOS traffic over an IP network. The end systems can attach to the network over Token Ring, Ethernet, Synchronous Data Link Control (SDLC) protocol, or Qualified Logical Link Control (QLLC). DLSw+ switches between diverse media, and locally terminates the data links, keeping acknowledgments, keepalives, and polling off of the WAN. Local termination of data links also eliminates data link control time-outs that can occur during transient network congestion or when rerouting around failed links. Finally, DLSw+ provides a mechanism for dynamically searching a network for SNA or NetBIOS resources and includes caching algorithms that minimize the broadcast traffic required.
In this document, DLSw+ routers are referred to as peers, or partners. The connection between two DLSw+ routers is referred to as a peer connection. A DLSw circuit is comprised of the data link control connection between the originating end system and the originating router, the connection between the two routers (typically a TCP connection), and the data link control connection between the target router and the target end system. A single peer connection can carry multiple circuits.
The transport connection between DLSw+ routers can vary according to the needs of the network and is not tied to TCP/IP as the DLSw standard is. Cisco supports four different transport protocols between DLSw+ routers:
TCP/IP-for transport of SNA and NetBIOS traffic across WANs where local acknowledgment is required to minimize unnecessary traffic and prevent data-link control timeouts and where non-disruptive rerouting around link failures is critical. This transport option is required when DLSw+ is operating in DLSw standards mode.
FST/IP-for transport across WANs with an arbitrary topology and with sufficient bandwidth to accommodate SNA and NetBIOS traffic. This solution allows for rerouting around link failures, but recovery may be disruptive depending on the time required to find an alternate path. This option does not support local acknowledgment of frames.
Direct-encapsulation for transport across a point-to-point or Frame Relay connection where the benefits of an arbitrary topology are not important and where nondisruptive rerouting around link failures is not required. This option does not support local acknowledgment of frames.
DLSw Lite-also known as Logical Link Control, Type2 (LLC2) encapsulation -for transport across a point-to-point connection (currently only Frame Relay is supported) where local acknowledgment and reliable transport are important, but where nondisruptive rerouting around link failures is not required. DLSw Lite uses RFC 1490 encapsulation of LLC2.
TAddressDenotes a transport service address. For dlswTCPDomain, a TAddress is 4 octets long, containing the IP-address in network-byte order. SIZE (0..255) · OCTET STRING
The local peer IP address; required for Fast-Sequenced Transport (FST) and TCP. If no local peer IP address is configured then this object will be the empty string.
cdeNodeGroup
1.3.6.1.4.1.9.9.74.1.2.2
INTEGER (0..255) · Integer32
Peer group number for this router. Peer groups are arbitrary groups of routers with one or more designated border peers. Border peers form peer connections with every router in their group and with border peers in other groups. The role of a border peer is to forward explorers on behalf of other routers. A value of zero means no group has been set and the DLSw is not a group member.
cdeNodeBorder
1.3.6.1.4.1.9.9.74.1.2.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This variable indicates if this DLSw is capable of operating as a border peer. True indicates that it is capable, false indicates that it is not.
Border peers form peer connections with every router in their group and with border peers in other groups. The role of a border peer is to forward explorers on behalf of other DLSw routers.
cdeNodeCost
1.3.6.1.4.1.9.9.74.1.2.4
CostAllows a cost to be assigned to a peer. If an end station can be reached through more than one peer, the cost of each peer will be considered when a circuit is established. A lower cost indicates that peer will be the preferred choice if there is more than one path to the destination. (1..5) · Integer32
Peer cost advertised to remote peers in the capabilities exchange. If an end station can be reached through more than one peer, the cost of each peer will be considered when a circuit is established. A lower cost indicates that peer will be the preferred choice if there is more than one path to the destination. A value of zero means no cost has been set and that cost will not be considered during circuit establishment.
cdeNodeKeepaliveInterval
1.3.6.1.4.1.9.9.74.1.2.5
KeepaliveIntervalThe keepalive parameter refers to how often DLSw peers send peer keep alives to each other. These periodic messages allow DLSw to keep track of the state of all peers. The keepalive interval is measured in seconds. If set to zero, no keepalives are sent. (0..1200) · Integer32 · Seconds
Default remote peer keepalive interval in seconds. The keepalive parameter refers to how often DLSw peers send peer keep alives to each other. These periodic messages allow DLSw to keep track of the state of all peers. If set to zero, no keepalives are sent.
cdeNodePassiveConnect
1.3.6.1.4.1.9.9.74.1.2.6
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This variable indicates if DLSw will not initiate remote peer connections to configured peers. True indicates that it will not initiate remote peer connections, false indicates that it will initiate remote peer connections. In other words a passive peer will wait for the remote peer to initiate a peer connection
cdeNodeBiuSegment
1.3.6.1.4.1.9.9.74.1.2.7
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This variable indicates if DLSw will spoof the maximum receivable Basic Information Unit (frame) size in XID so that each end station sends the largest frame it can. True indicates that it will spoof, false indicates that it will not.
cdeNodeInitPacingWindow
1.3.6.1.4.1.9.9.74.1.2.8
INTEGER (1..2000) · Integer32 · packets
Initial pacing window size. This is the starting size of the pacing window. DLSw uses an adaptive pacing flow control algorithm that automatically adjusts to congestion levels in the network. Pacing windows are used to control how many packets may be sent to a peer before acknowlegement.
cdeNodeMaxPacingWindow
1.3.6.1.4.1.9.9.74.1.2.9
INTEGER (1..2000) · Integer32 · packets
Maximum pacing window size. This is the largest size that the pacing window will grow to. DLSw uses an adaptive pacing flow control algorithm that automatically adjusts to congestion levels in the network. Pacing windows are used to control how many packets may be sent to a peer before acknowlegement.
cdeNodePromiscuous
1.3.6.1.4.1.9.9.74.1.2.10
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This variable indicates if DLSw will accept connections from non-configured remote peers. Promiscuous routers will accept peer connection requests from routers that are not preconfigured. This feature allows central site routers to remain unchanged when branch offices are added or deleted. It also minimizes required coordination of configurations. True indicates that it will accept connections, false indicates that it will not.
cdeNodePromPeerDefaultsCost
1.3.6.1.4.1.9.9.74.1.2.11
CostAllows a cost to be assigned to a peer. If an end station can be reached through more than one peer, the cost of each peer will be considered when a circuit is established. A lower cost indicates that peer will be the preferred choice if there is more than one path to the destination. (1..5) · Integer32
This variable indicates the cost that will be used with promiscuous peers. If an end station can be reached through more than one peer, the cost of each peer will be considered when a circuit is established. A lower cost indicates that peer will be the preferred choice if there is more than one path to the destination.
cdeNodePromPeerDefaultsDestMac
1.3.6.1.4.1.9.9.74.1.2.12
MacAddressNCRepresents an 802 MAC address represented in non-canonical format. That is, the most significant bit will be transmitted first. If this information is not available, the value is a zero length string. SIZE (0 | 6) · OCTET STRING · hint 1x:
Permits the promiscuous peer connection to be established only when there is an explorer frame destined for the specified 48-bit MAC address. If no default destination mac is configured then this object will be the empty string.
cdeNodePromPeerDefaultsKeepaliveInterval
1.3.6.1.4.1.9.9.74.1.2.13
KeepaliveIntervalThe keepalive parameter refers to how often DLSw peers send peer keep alives to each other. These periodic messages allow DLSw to keep track of the state of all peers. The keepalive interval is measured in seconds. If set to zero, no keepalives are sent. (0..1200) · Integer32 · Seconds
Default promiscuous peer keepalive interval in seconds. The keepalive parameter refers to how often DLSw peers send peer keep alives to each other. These periodic messages allow DLSw to keep track of the state of all peers. If set to zero, no keepalives are sent.
The default Largest Frame Size associated with the default promiscuous peer transport connection. In other words its the largest size of the INFO field (including DLC header, not including any MAC-level or framing octets).
cdeNodePromPeerDefaultsTCPQueueMax
1.3.6.1.4.1.9.9.74.1.2.15
TCPQueueMaxFor DLSw over TCP encapsulation, packets may be queued due to congestion of the TCP network. The TCPQueueMax is used to set the output queue maximum of the underlying TCP connection. (25..2000) · Integer32 · packets
Default promiscuous peer maximum output TCP queue size. For DLSw over TCP encapsulation, packets may be queued due to congestion of the TCP network. This variable is used to set the output queue maximum of the underlying TCP connection, by default on a promiscuous peer transport connection.
cdeNodePeerOnDemandDefaultsCost
1.3.6.1.4.1.9.9.74.1.2.16
CostAllows a cost to be assigned to a peer. If an end station can be reached through more than one peer, the cost of each peer will be considered when a circuit is established. A lower cost indicates that peer will be the preferred choice if there is more than one path to the destination. (1..5) · Integer32
This variable indicates the cost that will be used with peer on demand peers. If an end station can be reached through more than one peer, the cost of each peer will be considered when a circuit is established. A lower cost indicates that peer will be the preferred choice if there is more than one path to the destination.
cdeNodePeerOnDemandDefaultsFst
1.3.6.1.4.1.9.9.74.1.2.17
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This variable indicates if Fast-Sequenced Transport (FST) will be for peer on demand peers. True indicates that FST will be used, false indicates that it will not.
cdeNodePeerOnDemandDefaultsInactivityInterval
1.3.6.1.4.1.9.9.74.1.2.18
INTEGER (0..1440) · Integer32 · Minutes
This variable indicates the length of time a peer on demand connection can be idle before shutting down this peer on demand connection. If set to zero, the peer on demand connection will not be closed due to inactivity.
cdeNodePeerOnDemandDefaultsKeepaliveInterval
1.3.6.1.4.1.9.9.74.1.2.19
KeepaliveIntervalThe keepalive parameter refers to how often DLSw peers send peer keep alives to each other. These periodic messages allow DLSw to keep track of the state of all peers. The keepalive interval is measured in seconds. If set to zero, no keepalives are sent. (0..1200) · Integer32 · Seconds
Default peer on demand keepalive interval in seconds. The keepalive parameter refers to how often DLSw peers send peer keep alives to each other. These periodic messages allow DLSw to keep track of the state of all peers. If set to zero, no keepalives are sent.
The default Largest Frame Size associated with the default peer on demand transport connections. In other words its the largest size of the INFO field (including DLC header, not including any MAC-level or framing octets).
cdeNodePeerOnDemandDefaultsPriority
1.3.6.1.4.1.9.9.74.1.2.21
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This variable indicates if circuit prioritization will be used for peer-on-demand peers. True indicates that circuit prioritization specified by the dlswCircuitPriority object in the DLSW-MIB (RFC 2024) will be used, false indicates that there will be no circuit prioritization.
cdeNodePeerOnDemandDefaultsTCPQueueMax
1.3.6.1.4.1.9.9.74.1.2.22
TCPQueueMaxFor DLSw over TCP encapsulation, packets may be queued due to congestion of the TCP network. The TCPQueueMax is used to set the output queue maximum of the underlying TCP connection. (25..2000) · Integer32 · packets
Default peer-on-demand Maximum output TCP queue size. For DLSw over TCP encapsulation, packets may be queued due to congestion of the TCP network. This variable is used to set the output queue maximum of the underlying TCP connection, by default on a peer on demand transport connection.
cdeTrapCntlTConn
1.3.6.1.4.1.9.9.74.1.7.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Indicates whether DLSw is permitted to emit transport connection up and down traps. With the value of `true' DLSw will emit traps when connections enter `connected' and `disconnected' states. With the value of `false' DLSw will not emit traps when connections enter `connected' and `disconnected' states. The changes take effect immediately.
cdeTrapCntlCircuit
1.3.6.1.4.1.9.9.74.1.7.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Indicates whether the DLSw is permitted to generate circuit up and down traps. With the value of `true' the DLSw will emit traps when circuits enter `connected' and `disconnected' states. With the value of `false' the DLSw will not emit traps when circuits enter `connected' and `disconnected' states. The changes take effect immediately.
This table defines the peer transport connections that will be initiated or accepted by this DLSw. Structure of masks allows wildcard definition for a collection of transport connections by a conceptual row. For a specific transport connection, there may be multiple conceptual rows that match the transport address. The `best' match will be the one to determine the characteristics of the transport connection.
This table augments dlswTConnConfigTable.
The index to the conceptual row of the table. Negative numbers are not allowed. There are objects defined that point to conceptual rows of this table with this index value. Zero is used to denote that no corresponding row exists.
Index values are assigned by the agent, and should not be reused but should continue to increase in value.
cdeTConnConfigTDomainType
1.3.6.1.4.1.9.9.74.1.3.1.1.1
TDomainType1 = tcp2 = fst3 = directHdlc4 = directFrameRelay5 = llc2The type of DLSw encapsulation in use on this peer connection. · Integer32
The type of DLSw encapsulation in use on this peer connection.
cdeTConnConfigLocalAck
1.3.6.1.4.1.9.9.74.1.3.1.1.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Reflects whether the peer connection is locally acknowledged. Locally acknoledgement means terminating the DLC connections at the router, eliminating the requirement for link-layer acknowledgements and keepalive messages to flow across the WAN. In addition because link-layer frames are acknowledged locally, link-layer time-outs should not occur.
In general ciscoDlswTConnConfigLocalAck will be true when the domain type is tcp, false when the domain type is fst, direct-hdlc, or direct-frame-relay.
Configuring the remote-peer as pass-thru, the remote peer will not use local acknowlegement.
cdeTConnConfigCost
1.3.6.1.4.1.9.9.74.1.3.1.1.3
CostAllows a cost to be assigned to a peer. If an end station can be reached through more than one peer, the cost of each peer will be considered when a circuit is established. A lower cost indicates that peer will be the preferred choice if there is more than one path to the destination. (1..5) · Integer32
The cost associated with the transport connection, assigned to this conceptual row representing a peer. If an end station can be reached through more than one peer, the cost of each peer will be considered when a circuit is established. A lower cost indicates that peer will be the preferred choice if there is more than one path to the destination.
The Largest Frame Size associated with the transport connection. In other words its the largest size of the INFO field (including DLC header, not including any MAC-level or framing octets).
cdeTConnConfigKeepaliveInterval
1.3.6.1.4.1.9.9.74.1.3.1.1.5
KeepaliveIntervalThe keepalive parameter refers to how often DLSw peers send peer keep alives to each other. These periodic messages allow DLSw to keep track of the state of all peers. The keepalive interval is measured in seconds. If set to zero, no keepalives are sent. (0..1200) · Integer32 · Seconds
The amount of time between keepalive messages on a transport connection. The keepalive parameter refers to how often DLSw peers send peer keep alives to each other. These periodic messages allow DLSw to keep track of the state of all peers. If set to zero, no keepalives are sent.
cdeTConnConfigBackup
1.3.6.1.4.1.9.9.74.1.3.1.1.6
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This variable indicates if this peer is defined as a backup to an existing peer. A backup peer is used to provide an alternate path in case an existing peer becomes unavailable. A backup peer will not enter the connected state until the primary peer that it backs up becomes disconnected. True indicates that this conecptual row is a backup peer to a pre-existing peer, false indicates this peer is not a backup peer.
cdeTConnConfigBackupTAddr
1.3.6.1.4.1.9.9.74.1.3.1.1.7
TAddressDenotes a transport service address. For dlswTCPDomain, a TAddress is 4 octets long, containing the IP-address in network-byte order. SIZE (0..255) · OCTET STRING
The primary peer's IP address that this entry backs up. Valid only when ciscoDlswTConnConfigBackup is true.
cdeTConnConfigBackupLinger
1.3.6.1.4.1.9.9.74.1.3.1.1.8
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This variable indicates whether the backup peer will remain connected after the primary peer connection has been re-established. True indicates that the backup peer will remain connected after the primary peer connection has been re-established, for the length of time specified in cdeTConnConfigBackupLingerInterval. False indicates that the backup peer will remain connected until all circuits on the backup peer connection have been disconnected.
cdeTConnConfigBackupLingerInterval
1.3.6.1.4.1.9.9.74.1.3.1.1.9
INTEGER (0..1440) · Integer32 · Minutes
This variable indicates the length of time the backup peer remains connected after the primary peer connection has been re-established. If this variable is zero, the backup peer will be disconnected immediately after the primary peer connection has been re-established. If greater than zero the backup will stay connected for the number of minutes indicated by this variable, after the primary peer connection has been re-established. Note that the linger interval is only used when cdeTConnConfigBackupLinger is true.
cdeTConnConfigPriority
1.3.6.1.4.1.9.9.74.1.3.1.1.10
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Indicator of whether this peer connection supports priority. When priority is configured for the remote peer, DLSw+ will automatically activate four TCP connections to that remote peer (ports 2065, 1981, 1982, and 1983). Priority only needs to be configured if you need to prioritize between SNA and NetBIOS, or within SNA by LOCADDR or MAC/SAP pair (known as SAP prioritization). In addition, this granular packet classification is only possible when TCP encapsulation is selected for a specific remote peer. By default DLSw+ assigns certain traffic to specific TCP ports.
cdeTConnConfigDestMac
1.3.6.1.4.1.9.9.74.1.3.1.1.11
MacAddressNCRepresents an 802 MAC address represented in non-canonical format. That is, the most significant bit will be transmitted first. If this information is not available, the value is a zero length string. SIZE (0 | 6) · OCTET STRING · hint 1x:
Permits the peer connection to be established only when there is an explorer frame destined for the specified 48-bit MAC address.
If no expolorer traffic with a destination address of cdeTConnConfigDestMac is received by DLSw, the peer reprented by this conceptual row will not be connected.
cdeTConnConfigDynamic
1.3.6.1.4.1.9.9.74.1.3.1.1.12
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Indicates the peer connection is to be established only when there is DLSw+ data to send.
cdeTConnConfigDynamicNoLlc
1.3.6.1.4.1.9.9.74.1.3.1.1.13
INTEGER (1..300) · Integer32 · Minutes
This variable indicates the length of time a dynamic peer remains connected after all LLC2 circuits are gone.
cdeTConnConfigDynamicInactivityInterval
1.3.6.1.4.1.9.9.74.1.3.1.1.14
INTEGER (0..300) · Integer32 · Minutes
Indicates the length of time a connection can be idle before closing the dynamic peer connection. If set to zero, the dynamic peer connection will not be closed due to inactivity.
A list of peer transport connections. Each connected peer will create a conceptual row in the table. When the peer disconnects, the row will be deleted from the table. This table augments dlswTConnOperTable.
The object identifier indicates the transport domain of this transport connection.
dlswTConnOperRemoteTAddr
TAddressDenotes a transport service address. For dlswTCPDomain, a TAddress is 4 octets long, containing the IP-address in network-byte order. SIZE (0..255) · OCTET STRING
The remote transport address of this transport connection.
cdeTConnOperPartnerCost
1.3.6.1.4.1.9.9.74.1.3.2.1.1
CostAllows a cost to be assigned to a peer. If an end station can be reached through more than one peer, the cost of each peer will be considered when a circuit is established. A lower cost indicates that peer will be the preferred choice if there is more than one path to the destination. (1..5) · Integer32
The partner's cost on this peer connection, as received through capabilities exchange. If an end station can be reached through more than one peer, the cost of each peer will be considered when a circuit is established. A lower cost indicates that peer will be the preferred choice if there is more than one path to the destination.
cdeTConnOperPartnerPriority
1.3.6.1.4.1.9.9.74.1.3.2.1.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The partner's priority setting on this peer connection, as received through capabilities exchange. When priority is enabled for the remote peer, DLSw+ will automatically activate four TCP connections to that remote peer (ports 2065, 1981, 1982, and 1983). Priority only needs to be configured if you need to prioritize between SNA and NetBIOS, or within SNA by LOCADDR or MAC/SAP pair (known as SAP prioritization). In addition, this granular packet classification is only possible when TCP encapsulation is selected for a specific remote peer. By default DLSw+ assigns certain traffic to specific TCP ports.
cdeTConnOperPartnerBorderPeer
1.3.6.1.4.1.9.9.74.1.3.2.1.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This variable indicates if the partner DLSw is capable of operating as a border peer, as received through capabilities exchange. True indicates that it is capable, false indicates that it is not.
Border peers form peer connections with every router in their group and with border peers in other groups. The role of a border peer is to forward explorers on behalf of other DLSw routers.
cdeTConnOperPartnerGroupNum
1.3.6.1.4.1.9.9.74.1.3.2.1.4
INTEGER (0..255) · Integer32
This variable indicates the partner's group number, as received through capabilities exchange. Peer groups are arbitrary groups of routers with one or more designated border peers. Border peers form peer connections with every router in their group and with border peers in other groups. The role of a border peer is to forward explorers on behalf of other routers. A value of zero means no group has been set and the DLSw is not a group member.
cdeTConnOperTDomainType
1.3.6.1.4.1.9.9.74.1.3.2.1.5
TDomainType1 = tcp2 = fst3 = directHdlc4 = directFrameRelay5 = llc2The type of DLSw encapsulation in use on this peer connection. · Integer32
The type of DLSw encapsulation in use on this peer connection.
This table defines the TCP transport connections that will be either initiated by or accepted by this DSLw. It augments the entries in dlswTConnConfigTable whose domain is dlswTCPDomain. In other words for each conceptual row in the dlswTConnConfigTable, if the dlswTConnConfigTDomain is dlswTCPDomain, that conceptual row will be augmented by this table.
dlswTCPDomain, dlswTConnConfigTable, and dlswTConnConfigTDomain are all imported from DLSW-MIB (RFC 2024).
This table augments dlswTConnTcpConfigTable.
The index to the conceptual row of the table. Negative numbers are not allowed. There are objects defined that point to conceptual rows of this table with this index value. Zero is used to denote that no corresponding row exists.
Index values are assigned by the agent, and should not be reused but should continue to increase in value.
cdeTConnTcpConfigQueueMax
1.3.6.1.4.1.9.9.74.1.3.3.1.1.1.1
TCPQueueMaxFor DLSw over TCP encapsulation, packets may be queued due to congestion of the TCP network. The TCPQueueMax is used to set the output queue maximum of the underlying TCP connection. (25..2000) · Integer32 · packets
Maximum output TCP queue size for this remote peer. For DLSw over TCP encapsulation, packets may be queued due to congestion of the TCP network. This variable is used to set the output queue maximum of the underlying TCP connection for the peer represented by the conceptual row.
cdeTConnDirectConfigTable
1.3.6.1.4.1.9.9.74.1.3.3.2.1
Index: dlswTConnConfigIndex
This table contains direct peer media-specific configuration information. An entry is maintained for every peer in the cdeTConnConfigTable whose domain is either cdeDirectHdlcDomain, cdeDirectFrameRelayDomain, or cdeLlc2Domain.
In other words, for each conceptual row in the dlswTConnConfigTable, if the dlswTConnConfigTDomain is either cdeDirectHdlcDomain, cdeDirectFrameRelayDomain, or cdeLlc2Domain, there will be an entry in this table.
dlswTConnConfigTable, and dlswTConnConfigTDomain are imported from DLSW-MIB (RFC 2024).
The index to the conceptual row of the table. Negative numbers are not allowed. There are objects defined that point to conceptual rows of this table with this index value. Zero is used to denote that no corresponding row exists.
Index values are assigned by the agent, and should not be reused but should continue to increase in value.
cdeTConnDirectConfigIfIndex
1.3.6.1.4.1.9.9.74.1.3.3.2.1.1.1
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The IfEntry index of the local interface, on which the direct peer can be reached.
The type of media encapsulation to be used on this peer connection. When using DLSw Direct-encapsulation or DLSw Lite (Frame Relay) encapsulation, the peer transport connection is defined as either directHdlc or directFrameRelay, respectively.
Hdlc peer transport encapsulation does not support local acknowledgment of frames.
Logical Link Control, Type2 (LLC2) peer transport encapsulation -for transport across a point-to-point connection (currently only Frame Relay is supported) provides local acknowledgment and reliable transport.
cdeTConnDirectConfigFrameRelayDlci
1.3.6.1.4.1.9.9.74.1.3.3.2.1.1.3
DlciNumberNumerical format of Data Link Connection Identifier (DLCI) in decimal, identical to the 'DLCI' as INTEGER of 0..DLCINumber in RFC1315. The maximum value depends on Frame Relay implementation, which is currently set to be 1023 for 2-octet address format per UNI Implementation Agreement FRF.1. (0..1023) · Integer32
The Data Link Connection Identifier for the virtual circuit on this interface. This object will only be valid if the value of cdeTConnDirectConfigMediaEncap is llc2.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.
cdeIfType
1.3.6.1.4.1.9.9.74.1.4.1.1.1
DlcType1 = other2 = na3 = llc4 = sdlc5 = qllcRepresenting the type of DLC of an end station, if applicable. · Integer32
A list of circuits. Each new circuit will create a conceptual row in the table. When the circuit disconnects, the row will be deleted from the table. End station 1 (S1) and End station 2 (S2) are used to represent the two end stations of the circuit. S1 is always an end station which is locally attached. S2 may be locally attached or remote.
This table augments the dlswCircuitTable.
MacAddressNCRepresents an 802 MAC address represented in non-canonical format. That is, the most significant bit will be transmitted first. If this information is not available, the value is a zero length string. SIZE (0 | 6) · OCTET STRING · hint 1x:
The MAC Address of End Station 1 (S1) used for this circuit.
dlswCircuitS1Sap
OCTET STRING SIZE (1)
The SAP at End Station 1 (S1) used for this circuit.
dlswCircuitS2Mac
MacAddressNCRepresents an 802 MAC address represented in non-canonical format. That is, the most significant bit will be transmitted first. If this information is not available, the value is a zero length string. SIZE (0 | 6) · OCTET STRING · hint 1x:
The MAC Address of End Station 2 (S2) used for this circuit.
dlswCircuitS2Sap
OCTET STRING SIZE (1)
The SAP at End Station 2 (S2) used for this circuit.
cdeCircuitS1Name
1.3.6.1.4.1.9.9.74.1.5.1.1.1
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..17) · OCTET STRING · hint 255a
Represents the PU Name of End Station 1 (S1), if available.
cdeCircuitS2Name
1.3.6.1.4.1.9.9.74.1.5.1.1.2
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..17) · OCTET STRING · hint 255a
Represents the PU Name of End Station 2 (S2), if available.
cdeCircuitS1IdBlock
1.3.6.1.4.1.9.9.74.1.5.1.1.3
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..3) · OCTET STRING · hint 255a
The block number is the first three digits of the SNA Node id of End Station 1 (S1), if available. These 3 hexadecimal digits identify the product.
cdeCircuitS1IdNum
1.3.6.1.4.1.9.9.74.1.5.1.1.4
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..5) · OCTET STRING · hint 255a
The ID number is the last 5 digits of the SNA Node id of End Station 1 (S1), if available. These 5 hexadecimal digits are administratively defined and combined with the 3 digit block number form the Node id. This Node id is used to identify the local node and is included in SNA XIDs.
A table containing fast cache entries. The table contains cache information for FST peers or direct encapsulation peers (without local acknowledgement enabled).
When using these encapsulation types, a fast-switching cache must be built. The first frame between two end stations will be process switched, and during this process an entry will be made in the fast-switching cache so that subsequent frames between those end stations may be fast switched.
End station 1 (S1) and End station 2 (S2) are used to represent the two end stations of the faat cache entry. S1 is always an end station which is locally attached. S2 is always an end station which is remote.
cdeFastS1Mac
1.3.6.1.4.1.9.9.74.1.6.1.1.1
MacAddressNCRepresents an 802 MAC address represented in non-canonical format. That is, the most significant bit will be transmitted first. If this information is not available, the value is a zero length string. SIZE (0 | 6) · OCTET STRING · hint 1x:
The MAC Address of End Station 1 (S1) used for this cache entry.
cdeFastS1Sap
1.3.6.1.4.1.9.9.74.1.6.1.1.2
SAPTypeService Access Point - is a term that denotes the means by which a user entity in layer n+1 accesses a service of a provider entity in layer n. (0..254) · Integer32
The SAP at End Station 1 (S1) used for this cache entry.
cdeFastS2Mac
1.3.6.1.4.1.9.9.74.1.6.1.1.3
MacAddressNCRepresents an 802 MAC address represented in non-canonical format. That is, the most significant bit will be transmitted first. If this information is not available, the value is a zero length string. SIZE (0 | 6) · OCTET STRING · hint 1x:
The MAC Address of End Station 2 (S2) used for this cache entry.
cdeFastS2Sap
1.3.6.1.4.1.9.9.74.1.6.1.1.4
SAPTypeService Access Point - is a term that denotes the means by which a user entity in layer n+1 accesses a service of a provider entity in layer n. (0..254) · Integer32
The SAP at End Station 2 (S2) used for this cache entry.
cdeFastS1IfIndex
1.3.6.1.4.1.9.9.74.1.6.1.1.5
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The ifEntry index of the local interface through which S1 can be reached.
cdeFastS1RouteInfo
1.3.6.1.4.1.9.9.74.1.6.1.1.6
OCTET STRING SIZE (0..30)
If source-route bridging is in use between the DLSw and S1, this is the routing information field describing the path between the two devices. Otherwise the value will be an OCTET STRING of zero length.
cdeFastS1CacheId
1.3.6.1.4.1.9.9.74.1.6.1.1.7
OCTET STRING SIZE (8)
The Cache ID assigned by this DLSw to this fast cache entry. Every Fast cache entry will have a unique id. A management station could use this object by periodically polling this table, and determine whether the same cache entries were present or absent.
cdeFastS2TDomain
1.3.6.1.4.1.9.9.74.1.6.1.1.8
OBJECT IDENTIFIER
This object contains the transport domain of the peer transport protocol that the fast cache entry is running over.
cdeFastS2TAddress
1.3.6.1.4.1.9.9.74.1.6.1.1.9
TAddressDenotes a transport service address. For dlswTCPDomain, a TAddress is 4 octets long, containing the IP-address in network-byte order. SIZE (0..255) · OCTET STRING
This object contains the transport address of the partner DLSw.
cdeFastS2CacheId
1.3.6.1.4.1.9.9.74.1.6.1.1.10
OCTET STRING SIZE (8)
The Cache ID assigned to this fast cache entry by the partner DLSw. Every Fast cache entry will have a unique id. A management station could use this object by periodically polling this table, and determine whether the same cache entries were present or absent.
cdeFastOrigin
1.3.6.1.4.1.9.9.74.1.6.1.1.11
INTEGER1 = s12 = s2 · Integer32
This object specifies which of the two end stations initiated the establishment of this circuit.
cdeFastTimeToLive
1.3.6.1.4.1.9.9.74.1.6.1.1.12
TimeTicks · hundredths of a second
The amount of time (in hundredths of a second) remaining before this fast cache entry will be removed from the table. After 5 minutes of inactivity, the fast cache entry will be deleted.
Trap details
cdeTrapTConnUpDown
1.3.6.1.4.1.9.9.74.2.0.1
This trap is sent each time a transport connection changes state to `connected' or `disconnected'. The emission of this trap is controlled by cdeTrapCntlTConn.
The state of this transport connection. The transport connection enters `connecting' state when DLSw makes a connection request to the transport layer. Once initial Capabilities Exchange is sent, the transport connection enters enters `initCapExchange' state. When partner capabilities have been determined and the transport connection is ready for sending CanUReach (CUR) messages, it moves to the `connected' state. When DLSw is in the process of bringing down the connection, it is in the `disconnecting' state. When the transport layer indicates one of its connections is disconnected, the transport connection moves to the `disconnected' state.
Whereas all of the values will be returned in response to a management protocol retrieval operation, only two values may be specified in a management protocol set operation: `quiescing' and `disconnecting'. Changing the value to `quiescing' prevents new circuits from being established, and will cause a transport disconnect when the last circuit on the connection goes away. Changing the value to `disconnecting' will force off all circuits immediately and bring the connection to `disconnected' state.
cdeTrapCircuitUpDown
1.3.6.1.4.1.9.9.74.2.0.2
This trap is sent each time a circuit changes state to `connected' or `disconnected'. the emission of this trap is controlled by cdeTrapCntlCircuit.
The current state of this circuit. The agent, implementation specific, may choose to keep entries for some period of time after circuit disconnect, so the manager can gather the time and cause of disconnection.
While all of the specified values may be returned from a GET operation, the only SETable value is `disconnectPending'. When this value is set, DLSw should perform the appropriate action given its previous state (e.g., send HALT_DL if the state was `connected') to bring the circuit down to the `disconnected' state. Both the partner DLSw and local end station(s) should be notified as appropriate.
This MIB provides no facility to re-establish a disconnected circuit, because in DLSw this should be an end station-driven function.