The MIB module for entities implementing the server side of the Domain Name System (DNS) protocol. P. Mockapetris, 'Domain names - implementation and specification', RFC 1035, November 1987
Descriptions of acronyms and definitions:
Reporting The interval in seconds over which
interval the server last calculated the sample
interval statistics
RR Resource Record for DNS
AXFR Full zone transfer
IXFR Incremental zone transfer
M.Ohta, 'Incremental Zone Transfer in DNS', RFC-1995, August 1996
ACL DNS Access Control List
RCODE Flag in a DNS packet
P. Vixie, S. Thomson, Y. Rekhter, J. Bound, 'Dynamic Updates in the Domain Name System (DNS UPDATE)', RFC-2136, April 1997
The following are values of RCODE in the update packet:
FORMERR The name server was unable to
interpret the request due to a format error.
REFUSED The name server refuses to
perform the specified operation for policy or security reasons.
TSIG A transaction signature of secret key
transaction authentication for DNS.
O. Gudmundsson, D. Eastlake 3rd, B. Wellington, 'Secret Key Transaction Authentication for DNS (TSIG)', RFC-2845, May 2000
The following are TSIG related error conditions, while processing incoming messages:
BADTIME The time in the TSIG message is
off the limit
BADKEY The key in the TSIG message is
not valid
BADSIG The signature in the TSIG
message is not valid
HA High Availability DNS servers to eliminate
single-point-of-failure for dynamic DNS updates
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
Reference: R. Austein, J. Saperia, 'DNS Server MIB Extensions', RFC-1611, May 1994, dnsServConfigImplementIdent.
The implementation identification string for the DNS server software in use on the system, for example; `FNS-2.1'
Reference: R. Austein, J. Saperia, 'DNS Server MIB Extensions', RFC-1611, May 1994, dnsServConfigRecurs.
This represents the recursion services offered by this name server. The values that can be read are:
available(1) - performs recursion on requests from clients.
restricted(2) - recursion is performed on requests only from certain clients, for example; clients on an access control list.
unavailable(3) - recursion is not available.
cDnsServConfigUpTime
1.3.6.1.4.1.9.9.405.1.1.3
CDnsTimeDnsTime values are 32-bit unsigned integers which measure time in seconds.Reference: R. Austein, J. Saperia, 'DNS Server MIB Extensions', RFC-1611, May 1994, DnsTime. · Unsigned32 · hint d
Reference: R. Austein, J. Saperia, 'DNS Server MIB Extensions', RFC-1611, May 1994, dnsServConfigUpTime.
If the server has a persistent state (e.g., a process), this value will be the time elapsed since it started. For software without persistent state, this value will be zero.
cDnsServConfigResetTime
1.3.6.1.4.1.9.9.405.1.1.4
CDnsTimeDnsTime values are 32-bit unsigned integers which measure time in seconds.Reference: R. Austein, J. Saperia, 'DNS Server MIB Extensions', RFC-1611, May 1994, DnsTime. · Unsigned32 · hint d
Reference: R. Austein, J. Saperia, 'DNS Server MIB Extensions', RFC-1611, May 1994, dnsServConfigResetTime.
If the server has a persistent state (e.g., a process) and supports a `reset' operation (e.g., can be told to re-read configuration files), this value will be the time elapsed since the last time the name server was
`reset.' For software that does not have persistence or
does not support a `reset' operation, this value will be zero.
Reference: R. Austein, J. Saperia, 'DNS Server MIB Extensions', RFC-1611, May 1994, dnsServConfigReset.
Status/action object to reinitialize any persistant name server state. When set to reset(2), any persistant name server state (such as a process) is reinitialized as if the name server had just been started. This value will never be returned by a read operation. When read, one of the following values will be returned: other(1) - server in some unknown state; initializing(3) - server (re)initializing; running(4) - server currently running.
cDnsServConfigIntervalSample
1.3.6.1.4.1.9.9.405.1.1.6
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds
Configures the sample time for the various interval counters.
cDnsQueryAuthAnswers
1.3.6.1.4.1.9.9.405.1.2.1
Counter32
Number of queries which were authoritatively answered.
cDnsQueryAuthNoNames
1.3.6.1.4.1.9.9.405.1.2.2
Counter32
Number of queries for which `authoritative no such name' responses were made.
cDnsQueryAuthNoDataResps
1.3.6.1.4.1.9.9.405.1.2.3
Counter32
Number of queries for which `authoritative no such data' (empty answer) responses were made.
cDnsQueryReferrals
1.3.6.1.4.1.9.9.405.1.2.4
Counter32
Number of requests that were referred to other servers.
cDnsQueryNonAuthAnswers
1.3.6.1.4.1.9.9.405.1.2.5
Counter32
Number of queries which were non-authoritatively answered (from cached data).
cDnsQueryNonAuthNoDataResps
1.3.6.1.4.1.9.9.405.1.2.6
Counter32
Number of queries which were non-authoritatively answered with no data.
cDnsQueryRelNameRequests
1.3.6.1.4.1.9.9.405.1.2.7
Counter32
Number of requests received by the server for names that are only one label long (i.e. in text form - no internal dots).
cDnsQueryLameDelegations
1.3.6.1.4.1.9.9.405.1.2.8
Counter32
Number of query lame delegations.
cDnsQueryMemCacheHits
1.3.6.1.4.1.9.9.405.1.2.9
Counter32
Number of mem-cache lookup hits.
cDnsQueryMemCacheMisses
1.3.6.1.4.1.9.9.405.1.2.10
Counter32
Number of mem-cache lookup misses.
cDnsQueryMemCacheWrites
1.3.6.1.4.1.9.9.405.1.2.11
Counter32
Number of mem-cache writes.
cDnsQueryRefusals
1.3.6.1.4.1.9.9.405.1.2.12
Counter32
Number of queries refused.
cDnsQueryIntAuthAnswers
1.3.6.1.4.1.9.9.405.1.3.1
Unsigned32
Number of queries which were authoritatively answered during reporting interval.
cDnsQueryIntAuthNoNames
1.3.6.1.4.1.9.9.405.1.3.2
Unsigned32
Number of queries for which `authoritative no such name' responses were made during reporting interval.
cDnsQueryIntAuthNoDataResps
1.3.6.1.4.1.9.9.405.1.3.3
Unsigned32
Number of queries for which `authoritative no such data' (empty answer) responses were made during reporting interval.
cDnsQueryIntReferrals
1.3.6.1.4.1.9.9.405.1.3.4
Unsigned32
Number of requests that were referred to other servers during reporting interval.
cDnsQueryIntNonAuthAnswers
1.3.6.1.4.1.9.9.405.1.3.5
Unsigned32
Number of queries which were non-authoritatively answered (from cached data) during reporting interval.
cDnsQueryIntNonAuthNoDataResps
1.3.6.1.4.1.9.9.405.1.3.6
Unsigned32
Number of queries which were non-authoritatively answered with no data during reporting interval.
cDnsQueryIntRelNameRequests
1.3.6.1.4.1.9.9.405.1.3.7
Unsigned32
Number of requests received by the server for names that are only one label long (i.e. in text form - no internal dots) during reporting interval.
cDnsQueryIntLameDelegations
1.3.6.1.4.1.9.9.405.1.3.8
Unsigned32
Number of query lame delegations during reporting interval.
cDnsQueryIntMemCacheHits
1.3.6.1.4.1.9.9.405.1.3.9
Unsigned32
Number of mem-cache lookup hits during reporting interval.
cDnsQueryIntMemCacheMisses
1.3.6.1.4.1.9.9.405.1.3.10
Unsigned32
Number of mem-cache lookup misses during reporting interval.
cDnsQueryIntMemCacheWrites
1.3.6.1.4.1.9.9.405.1.3.11
Unsigned32
Number of mem-cache writes during reporting interval.
cDnsQueryIntRefusals
1.3.6.1.4.1.9.9.405.1.3.12
Counter32
Number of queries refused during reporting interval.
cDnsQueryIntSampleTime
1.3.6.1.4.1.9.9.405.1.3.13
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The time stamp of last sample.
cDnsQueryIntSampleInterval
1.3.6.1.4.1.9.9.405.1.3.14
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds
The interval in seconds over which the server last calculated the sample interval statistics. This is the configured reporting interval and the statistics are reset since the last cDnsQueryIntSampleTime.
cDnsPerfUpdateRRs
1.3.6.1.4.1.9.9.405.1.4.1
Counter32
Total number of RR's added and deleted.
cDnsPerfUpdatePkts
1.3.6.1.4.1.9.9.405.1.4.2
Counter32
Total number of update packets successfully processed.
cDnsPerfOutboundIxfrs
1.3.6.1.4.1.9.9.405.1.4.3
Counter32
Total number of successful outbound incremental transfers.
cDnsPerfInboundIxfrs
1.3.6.1.4.1.9.9.405.1.4.4
Counter32
Total number of successful inbound incremental transfers.
cDnsPerfFullRespIxfrs
1.3.6.1.4.1.9.9.405.1.4.5
Counter32
Total number of outbound full zone transfers in response to IXFR requests.
cDnsPerfOutboundAxfrs
1.3.6.1.4.1.9.9.405.1.4.6
Counter32
Total number of successful outbound full zone transfers.
cDnsPerfInboundAxfrs
1.3.6.1.4.1.9.9.405.1.4.7
Counter32
Total number of successful inbound AXFRs.
cDnsPerfQueries
1.3.6.1.4.1.9.9.405.1.4.8
Counter32
Total number of queries responded to.
cDnsPerfOutboundAtLimitXfrs
1.3.6.1.4.1.9.9.405.1.4.9
Counter32
Total number of occasions that outbound transfers reached the concurrent limit.
cDnsPerfInboundAtLimitXfrs
1.3.6.1.4.1.9.9.405.1.4.10
Counter32
Total number of occasions that inbound transfers reached the concurrent limit.
cDnsPerfOutboundNotifies
1.3.6.1.4.1.9.9.405.1.4.11
Counter32
Total number of outbound notifies.
cDnsPerfInboundNotifies
1.3.6.1.4.1.9.9.405.1.4.12
Counter32
Total number of inbound notifies.
cDnsPerfIntUpdateRRs
1.3.6.1.4.1.9.9.405.1.5.1
Unsigned32
Number of RR's added and deleted during reporting interval.
cDnsPerfIntUpdatePkts
1.3.6.1.4.1.9.9.405.1.5.2
Unsigned32
Number of update packets successfully processed during reporting interval.
cDnsPerfIntOutboundIxfrs
1.3.6.1.4.1.9.9.405.1.5.3
Unsigned32
Number of successful outbound incremental transfers during reporting interval.
cDnsPerfIntInboundIxfrs
1.3.6.1.4.1.9.9.405.1.5.4
Unsigned32
Number of successful inbound incremental transfers during reporting interval.
cDnsPerfIntFullRespIxfrs
1.3.6.1.4.1.9.9.405.1.5.5
Unsigned32
Number of outbound full zone transfers in response to IXFR requests during reporting interval.
cDnsPerfIntOutboundAxfrs
1.3.6.1.4.1.9.9.405.1.5.6
Unsigned32
Number of successful outbound full zone transfers during reporting interval.
cDnsPerfIntInboundAxfrs
1.3.6.1.4.1.9.9.405.1.5.7
Unsigned32
Number of successful inbound AXFRs during reporting interval.
cDnsPerfIntQueries
1.3.6.1.4.1.9.9.405.1.5.8
Unsigned32
Number of queries responded to during reporting interval.
cDnsPerfIntOutboundAtLimitXfrs
1.3.6.1.4.1.9.9.405.1.5.9
Unsigned32
Number of occasions that outbound transfers reached the concurrent limit during reporting interval.
cDnsPerfIntInboundAtLimitXfrs
1.3.6.1.4.1.9.9.405.1.5.10
Unsigned32
Number of occasions that inbound transfers reached the concurrent limit during reporting interval.
cDnsPerfIntOutboundNotifies
1.3.6.1.4.1.9.9.405.1.5.11
Unsigned32
Number of outbound notifies during reporting interval.
cDnsPerfIntInboundNotifies
1.3.6.1.4.1.9.9.405.1.5.12
Unsigned32
Number of inbound notifies during reporting interval.
cDnsPerfIntSampleTime
1.3.6.1.4.1.9.9.405.1.5.13
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The time stamp of last sample.
cDnsPerfIntSampleInterval
1.3.6.1.4.1.9.9.405.1.5.14
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds
The interval in seconds over which the server last calculated the sample interval statistics. This is the configured reporting interval and the statistics are reset since the last cDnsQueryIntSampleTime.
cDnsSecurityRcvdTsigPackets
1.3.6.1.4.1.9.9.405.1.6.1
Counter32
Total number of packets with a TSIG RR that are processed.
cDnsSecurityDetecTsigBadTimes
1.3.6.1.4.1.9.9.405.1.6.2
Counter32
Returns BADTIME error code if value of bad timestamp in TSIG is detected in an incoming packet.
cDnsSecurityDetectTsigBadKeys
1.3.6.1.4.1.9.9.405.1.6.3
Counter32
Returns BADKEY error code if value of bad keyname in TSIG is detected in an incoming packet.
cDnsSecurityDetectTsigBadSigs
1.3.6.1.4.1.9.9.405.1.6.4
Counter32
Returns BADSIG error code if value of bad signature in TSIG is detected in an incoming packet.
cDnsSecurityRcvdTsigBadTimes
1.3.6.1.4.1.9.9.405.1.6.5
Counter32
Total number of BADTIME errors received after sending a TSIG.
cDnsSecurityRcvdTsigBadKeys
1.3.6.1.4.1.9.9.405.1.6.6
Counter32
Total number of BADKEY errors received after sending a TSIG.
cDnsSecurityRcvdTsigBadSigs
1.3.6.1.4.1.9.9.405.1.6.7
Counter32
Total number of BADSIG errors received after sending a TSIG.
cDnsSecurityUnauthXferReqs
1.3.6.1.4.1.9.9.405.1.6.8
Counter32
Total number of ACL authorization failures if zone transfer restriction has been enabled.
cDnsSecurityUnauthUpdateReqs
1.3.6.1.4.1.9.9.405.1.6.9
Counter32
Total number of updates which result in ACL authorization failure, or which target zones which do not support updates.
cDnsSecurityRestrictQueryAcls
1.3.6.1.4.1.9.9.405.1.6.10
Counter32
Total number of queries to be restricted by the DNS server through the global or zone Access Control List.
cDnsSecurityIntRcvdTsigPackets
1.3.6.1.4.1.9.9.405.1.7.1
Unsigned32
Number of packets with a TSIG RR that are processed during reporting interval.
cDnsSecurityIntDetecTsigBadTimes
1.3.6.1.4.1.9.9.405.1.7.2
Unsigned32
Value of bad timestamp in TSIG in an incoming packet during reporting interval.
cDnsSecurityIntDetectTsigBadKeys
1.3.6.1.4.1.9.9.405.1.7.3
Unsigned32
Value of bad keyname in TSIG in an incoming packet during reporting interval.
cDnsSecurityIntDetectTsigBadSigs
1.3.6.1.4.1.9.9.405.1.7.4
Unsigned32
Value of bad signature in TSIG in an incoming packet during reporting interval.
cDnsSecurityIntRcvdTsigBadTimes
1.3.6.1.4.1.9.9.405.1.7.5
Unsigned32
Number of BADTIME errors received after sending a TSIG during reporting interval.
cDnsSecurityIntRcvdTsigBadKeys
1.3.6.1.4.1.9.9.405.1.7.6
Unsigned32
Number of BADKEY errors received after sending a TSIG during reporting interval.
cDnsSecurityIntRcvdTsigBadSigs
1.3.6.1.4.1.9.9.405.1.7.7
Unsigned32
Number of BADSIG errors received after sending a TSIG during reporting interval.
cDnsSecurityIntUnauthXferReqs
1.3.6.1.4.1.9.9.405.1.7.8
Unsigned32
Number of ACL authorization failures if zone transfer restriction has been enabled during reporting interval.
cDnsSecurityIntUnauthUpdateReqs
1.3.6.1.4.1.9.9.405.1.7.9
Unsigned32
Number of updates which result in ACL not support updates during reporting interval.
cDnsSecurityIntRestrictQueryAcls
1.3.6.1.4.1.9.9.405.1.7.10
Unsigned32
Number of queries to be restricted by the DNS server through the global or zone Access Control List during reporting interval.
cDnsSecurityIntSampleTime
1.3.6.1.4.1.9.9.405.1.7.11
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The time stamp of last sample.
cDnsSecurityIntSampleInterval
1.3.6.1.4.1.9.9.405.1.7.12
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds
The interval in seconds over which the server last calculated the sample interval statistics. This is the configured reporting interval and the statistics are reset since the last cDnsSecurityIntSampleTime.
cDnsErrorUpdateErrors
1.3.6.1.4.1.9.9.405.1.8.1
Counter32
Total number of updates resulting in errors or failures.
cDnsErrorIxfrInErrors
1.3.6.1.4.1.9.9.405.1.8.2
Counter32
Total in-bound IXFR errors.
cDnsErrorIxfrOutErrors
1.3.6.1.4.1.9.9.405.1.8.3
Counter32
Total IXFR error responses sent.
cDnsErrorAxfrInErrors
1.3.6.1.4.1.9.9.405.1.8.4
Counter32
Total in-bound AXFR errors.
cDnsErrorAxfrOutErrors
1.3.6.1.4.1.9.9.405.1.8.5
Counter32
Total AXFR error responses sent.
cDnsErrorSentTotalErrors
1.3.6.1.4.1.9.9.405.1.8.6
Counter32
Total number of requests the server answered with errors.
cDnsErrorSentFormatErrors
1.3.6.1.4.1.9.9.405.1.8.7
Counter32
Total number of requests received which were unparseable.
cDnsErrorSentOtherErrors
1.3.6.1.4.1.9.9.405.1.8.8
Counter32
Total number of requests which were aborted for other local server errors.
cDnsErrorSentRefusalErrors
1.3.6.1.4.1.9.9.405.1.8.9
Counter32
Total number of requests which resulted in REFUSED.
cDnsErrorRcvdFormatErrors
1.3.6.1.4.1.9.9.405.1.8.10
Counter32
Total number of responses received with FORMERR status.
cDnsErrorIntUpdateErrors
1.3.6.1.4.1.9.9.405.1.9.1
Unsigned32
Total number of updates resulting in errors or failures.
cDnsErrorIntIxfrInErrors
1.3.6.1.4.1.9.9.405.1.9.2
Unsigned32
Total in-bound IXFR errors.
cDnsErrorIntIxfrOutErrors
1.3.6.1.4.1.9.9.405.1.9.3
Unsigned32
Total IXFR error responses sent.
cDnsErrorIntAxfrInErrors
1.3.6.1.4.1.9.9.405.1.9.4
Unsigned32
Total in-bound AXFR errors.
cDnsErrorIntAxfrOutErrors
1.3.6.1.4.1.9.9.405.1.9.5
Unsigned32
Total AXFR error responses sent.
cDnsErrorIntSentTotalErrors
1.3.6.1.4.1.9.9.405.1.9.6
Unsigned32
Total number of requests the server answered with errors.
cDnsErrorIntSentFormatErrors
1.3.6.1.4.1.9.9.405.1.9.7
Unsigned32
Total number of requests received which were unparseable.
cDnsErrorIntSentOtherErrors
1.3.6.1.4.1.9.9.405.1.9.8
Unsigned32
Total number of requests which were aborted for other local server errors.
cDnsErrorIntSentRefusalErrors
1.3.6.1.4.1.9.9.405.1.9.9
Unsigned32
Total number of requests which resulted in REFUSED.
cDnsErrorIntRcvdFormatErrors
1.3.6.1.4.1.9.9.405.1.9.10
Unsigned32
Total number of responses received with FORMERR status.
cDnsErrorIntSampleTime
1.3.6.1.4.1.9.9.405.1.9.11
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The time stamp of last sample.
cDnsErrorIntSampleInterval
1.3.6.1.4.1.9.9.405.1.9.12
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds
The interval in seconds over which the server last calculated the sample interval statistics. This is the configured reporting interval and the statistics are reset since the last cDnsErrorIntSampleTime.
cDnsMaxCntrConcurXfrsInCnts
1.3.6.1.4.1.9.9.405.1.10.1
Counter32
Maximum number of concurrent threads processing inbound transfers.
cDnsMaxCntrConcurXfrsOutCnts
1.3.6.1.4.1.9.9.405.1.10.2
Counter32
Maximum number of concurrent threads processing outbound transfers.
cDnsMaxCntrHaSvrNoRespTime
1.3.6.1.4.1.9.9.405.1.10.3
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds
Total time in seconds, where the partner of the server was not responding.
cDnsMaxCntrHaSvrMaxNoRespTime
1.3.6.1.4.1.9.9.405.1.10.4
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds
Maximum contiguous time in seconds, where the partner of the server was not responding.
cDnsMaxCntrHaBatchLimitCnts
1.3.6.1.4.1.9.9.405.1.10.5
Counter32
Number of occurrences where maximum batch count is reached in active server.
cDnsMaxCntrHaRRPendListCnts
1.3.6.1.4.1.9.9.405.1.10.6
Counter32
Maximum number of RRs in the pending list waiting acknowledgement from the backup server.
cDnsMaxCntrHaRRActiveListCnts
1.3.6.1.4.1.9.9.405.1.10.7
Counter32
Maximum number of RRs in the active list waiting to be sent to the backup server.
cDnsMaxCntrHaPersEditListCnts
1.3.6.1.4.1.9.9.405.1.10.8
Counter32
Maximum number of names persisted in the edits list db.
cDnsMaxCntrHaUpdLatencyMax
1.3.6.1.4.1.9.9.405.1.10.9
Gauge32 · seconds
Maximum DNS update latency in seconds. Latency is measured as the time an update remains in the pending list.
cDnsMaxCntrIntConcurXfrsInCnts
1.3.6.1.4.1.9.9.405.1.11.1
Unsigned32
Maximum number of concurrent threads processing inbound transfers during reporting interval.
cDnsMaxCntrIntConcurXfrsOutCnts
1.3.6.1.4.1.9.9.405.1.11.2
Unsigned32
Maximum number of concurrent threads processing outbound transfers during reporting interval.
cDnsMaxCntrIntHaSvrNoRespTime
1.3.6.1.4.1.9.9.405.1.11.3
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds
Total time in seconds, where the partner of the server was not responding during reporting interval.
cDnsMaxCntrIntHaSvrMaxNoRespTime
1.3.6.1.4.1.9.9.405.1.11.4
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds
Maximum time in seconds, where the partner of the server was not responding during reporting interval.
cDnsMaxCntrIntHaBatchLimitCnts
1.3.6.1.4.1.9.9.405.1.11.5
Unsigned32
Number of occurrences where maximum batch count is reached in active server during reporting interval.
cDnsMaxCntrIntHaRRPendListCnts
1.3.6.1.4.1.9.9.405.1.11.6
Unsigned32
Maximum number of RRs in the pending list waiting acknowledgement from the backup server during reporting interval.
cDnsMaxCntrIntHaRRActiveListCnts
1.3.6.1.4.1.9.9.405.1.11.7
Unsigned32
Maximum number of RRs in the active list waiting to be sent to the backup server during reporting interval.
cDnsMaxCntrIntHaPersEditListCnts
1.3.6.1.4.1.9.9.405.1.11.8
Unsigned32
Maximum number of names persisted in the edits list db during reporting interval.
cDnsMaxCntrIntHaUpdLatencyMax
1.3.6.1.4.1.9.9.405.1.11.9
Gauge32 · seconds
Maximum DNS update latency in seconds during reporting interval. Latency is measured as the time an update remains in the pending list.
cDnsMaxCntrIntSampleTime
1.3.6.1.4.1.9.9.405.1.11.10
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The time stamp of last sample.
cDnsMaxCntrIntSampleInterval
1.3.6.1.4.1.9.9.405.1.11.11
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds
The interval in seconds over which the server last calculated the sample interval statistics. This is the configured reporting interval and the statistics are reset since the last cDnsMaxCntrIntSampleTime.
cDnsHaCommInterruptedStates
1.3.6.1.4.1.9.9.405.1.12.1
Counter32
Total number of occurrences where the server enters the HA communication-interrupted state.
cDnsHaPartnerDownStates
1.3.6.1.4.1.9.9.405.1.12.2
Counter32
Total of occurrences where the server enters the HA partner-down state.
cDnsHaSyncs
1.3.6.1.4.1.9.9.405.1.12.3
Counter32
Total of occurrences where the server enters the HA synchronization state.
cDnsHaMsgConnectSentCnts
1.3.6.1.4.1.9.9.405.1.12.4
Counter32
Total number of HA connection establishment messages sent.
cDnsHaMsgReconcileSentCnts
1.3.6.1.4.1.9.9.405.1.12.5
Counter32
Total number of HA zone reconciliation messages sent.
cDnsHaMsgHeartBeatSentCnts
1.3.6.1.4.1.9.9.405.1.12.6
Counter32
Total number of HA heartbeat messages sent.
cDnsHaMsgZoneSyncSentCnts
1.3.6.1.4.1.9.9.405.1.12.7
Counter32
Total number of HA zone synchronization messages sent.
cDnsHaMsgRRSyncSentCnts
1.3.6.1.4.1.9.9.405.1.12.8
Counter32
Total number of HA rr-sync messages sent.
cDnsHaMsgRRUpdateSentCnts
1.3.6.1.4.1.9.9.405.1.12.9
Counter32
Total number of HA rr-update messages sent.
cDnsHaMsgResponseSentCnts
1.3.6.1.4.1.9.9.405.1.12.10
Counter32
Total number of HA response messages sent.
cDnsHaMsgConnectRcvdCnts
1.3.6.1.4.1.9.9.405.1.12.11
Counter32
Total number of HA connection establishment messages received.
cDnsHaMsgReconcileRcvdCnts
1.3.6.1.4.1.9.9.405.1.12.12
Counter32
Total number of HA zone reconciliation messages received.
cDnsHaMsgHeartbeatRcvdCnts
1.3.6.1.4.1.9.9.405.1.12.13
Counter32
Total number of HA heartbeat messages received.
cDnsHaMsgZoneSyncRcvdCnts
1.3.6.1.4.1.9.9.405.1.12.14
Counter32
Total number of HA zone synchronization messages received.
cDnsHaMsgRRSyncRcvdCnts
1.3.6.1.4.1.9.9.405.1.12.15
Counter32
Total number of HA rr-sync messages received.
cDnsHaMsgRRUpdateRcvdCnts
1.3.6.1.4.1.9.9.405.1.12.16
Counter32
Total number of HA rr-update messages received.
cDnsHaMsgResponseRcvdCnts
1.3.6.1.4.1.9.9.405.1.12.17
Counter32
Total number of HA response messages received.
cDnsHaHeartbeatTimeoutCnts
1.3.6.1.4.1.9.9.405.1.12.18
Counter32
Total number of HA heartbeat timeouts.
cDnsHaUpdateRejectCnts
1.3.6.1.4.1.9.9.405.1.12.19
Counter32
Total number of HA DNS updates rejected by the server.
cDnsHaResponseMismatchCnts
1.3.6.1.4.1.9.9.405.1.12.20
Counter32
Total number of HA responses reporting a mismatch error.
cDnsHaResponseServFailCnts
1.3.6.1.4.1.9.9.405.1.12.21
Counter32
Total number of HA responses reporting a server failure error.
cDnsHaRespInconsistentCnts
1.3.6.1.4.1.9.9.405.1.12.22
Counter32
Total number of HA responses reporting an inconsistent server state.
cDnsHaRespUnknownCnts
1.3.6.1.4.1.9.9.405.1.12.23
Counter32
Total number of HA responses with an unknown message type.
cDnsHaFullZoneResyncCnts
1.3.6.1.4.1.9.9.405.1.12.24
Counter32
Total number of zones requiring HA full-zone ??? resynchronization for nameset reconciliation.
cDnsHaUpdatePrivateReqCnts
1.3.6.1.4.1.9.9.405.1.12.25
Counter32
Total number of HA DNS updates received containing a private request RR.
cDnsHaUpdatePrivateRespCnts
1.3.6.1.4.1.9.9.405.1.12.26
Counter32
Total number of HA DNS update responses sent containing a private response RR.
cDnsHaSyncConflictCnts
1.3.6.1.4.1.9.9.405.1.12.27
Counter32
Total number of HA zones with name conflicts during nameset reconciliation.
cDnsHaSyncDiscardNameCnts
1.3.6.1.4.1.9.9.405.1.12.28
Counter32
Total number of HA name conflicts where one nameset must be discarded to synchronize the zone.
cDnsHaSyncMergeNameCnts
1.3.6.1.4.1.9.9.405.1.12.29
Counter32
Total number of HA name conflicts which the namesets can be merged to synchronize the zone.
cDnsHaUpdateLatencyAverage
1.3.6.1.4.1.9.9.405.1.12.30
Gauge32 · seconds
Average HA DNS update latency in seconds. Latency is measured as the time an update remains in the pending list.
cDnsHaMsgSyncPendingRcvdCnts
1.3.6.1.4.1.9.9.405.1.12.31
Counter32
Total number of HA_DNS_SYNCPENDING messages received.
cDnsHaMsgSyncPendingSentCnts
1.3.6.1.4.1.9.9.405.1.12.32
Counter32
Total number of HA_DNS_SYNCPENDING messages sent.
cDnsHaMsgShutdownRcvdCnts
1.3.6.1.4.1.9.9.405.1.12.33
Counter32
Total number of HA_DNS_SHUTDOWN messages received.
cDnsHaMsgShutdownSentCnts
1.3.6.1.4.1.9.9.405.1.12.34
Counter32
Total number of HA_DNS_SHUTDOWN messages sent.
cDnsHaIntCommInterruptedStates
1.3.6.1.4.1.9.9.405.1.13.1
Unsigned32
Number of occurrences where the server enters the HA communication-interrupted state.
cDnsHaIntPartnerDownStates
1.3.6.1.4.1.9.9.405.1.13.2
Unsigned32
Total of occurrences where the server enters the HA partner-down state during reporting interval.
cDnsHaIntSyncs
1.3.6.1.4.1.9.9.405.1.13.3
Unsigned32
Total of occurrences where the server enters the HA synchronization state during reporting interval.
cDnsHaIntMsgConnectSentCnts
1.3.6.1.4.1.9.9.405.1.13.4
Unsigned32
Number of HA connection establishment messages sent during reporting interval.
cDnsHaIntMsgReconcileSentCnts
1.3.6.1.4.1.9.9.405.1.13.5
Unsigned32
Number of HA zone reconciliation messages sent during reporting interval.
cDnsHaIntMsgHeartBeatSentCnts
1.3.6.1.4.1.9.9.405.1.13.6
Unsigned32
Number of HA heartbeat messages sent during reporting interval.
cDnsHaIntMsgZoneSyncSentCnts
1.3.6.1.4.1.9.9.405.1.13.7
Unsigned32
Number of HA zone synchronization messages sent during reporting interval.
cDnsHaIntMsgRRSyncSentCnts
1.3.6.1.4.1.9.9.405.1.13.8
Unsigned32
Number of HA rr-sync messages sent during reporting interval.
cDnsHaIntMsgRRUpdateSentCnts
1.3.6.1.4.1.9.9.405.1.13.9
Unsigned32
Number of HA rr-update messages sent during reporting interval.
cDnsHaIntMsgResponseSentCnts
1.3.6.1.4.1.9.9.405.1.13.10
Unsigned32
Number of HA response messages sent during reporting interval.
cDnsHaIntMsgConnectRcvdCnts
1.3.6.1.4.1.9.9.405.1.13.11
Unsigned32
Number of HA connection establishment messages received during reporting interval.
cDnsHaIntMsgReconcileRcvdCnts
1.3.6.1.4.1.9.9.405.1.13.12
Unsigned32
Number of HA zone reconciliation messages received during reporting interval.
cDnsHaIntMsgHeartbeatRcvdCnts
1.3.6.1.4.1.9.9.405.1.13.13
Unsigned32
Number of HA heartbeat messages received during reporting interval.
cDnsHaIntMsgZoneSyncRcvdCnts
1.3.6.1.4.1.9.9.405.1.13.14
Unsigned32
Number of HA zone synchronization messages received during reporting interval.
cDnsHaIntMsgRRSyncRcvdCnts
1.3.6.1.4.1.9.9.405.1.13.15
Unsigned32
Number of HA rr-sync messages received during reporting interval.
cDnsHaIntMsgRRUpdateRcvdCnts
1.3.6.1.4.1.9.9.405.1.13.16
Unsigned32
Number of HA rr-update messages received during reporting interval.
cDnsHaIntMsgResponseRcvdCnts
1.3.6.1.4.1.9.9.405.1.13.17
Unsigned32
Number of HA response messages received during reporting interval.
cDnsHaIntHeartbeatTimeoutCnts
1.3.6.1.4.1.9.9.405.1.13.18
Unsigned32
Number of HA heartbeat timeouts during reporting interval.
cDnsHaIntUpdateRejectCnts
1.3.6.1.4.1.9.9.405.1.13.19
Unsigned32
Number of HA DNS updates rejected by the server during reporting interval.
cDnsHaIntResponseMismatchCnts
1.3.6.1.4.1.9.9.405.1.13.20
Unsigned32
Number of HA responses reporting a mismatch error during reporting interval.
cDnsHaIntResponseServFailCnts
1.3.6.1.4.1.9.9.405.1.13.21
Unsigned32
Number of HA responses reporting a server failure error during reporting interval.
cDnsHaIntRespInconsistentCnts
1.3.6.1.4.1.9.9.405.1.13.22
Unsigned32
Number of HA responses reporting an inconsistent server state during reporting interval.
cDnsHaIntRespUnknownCnts
1.3.6.1.4.1.9.9.405.1.13.23
Unsigned32
Number of HA responses with an unknown message type during reporting interval.
cDnsHaIntFullZoneResyncCnts
1.3.6.1.4.1.9.9.405.1.13.24
Unsigned32
Number of HA zones requiring full-zone resynchronization for nameset reconciliation during reporting interval.
cDnsHaIntUpdatePrivateReqCnts
1.3.6.1.4.1.9.9.405.1.13.25
Unsigned32
Number of HA DNS updates received containing a private request RR during reporting interval.
cDnsHaIntUpdatePrivateRespCnts
1.3.6.1.4.1.9.9.405.1.13.26
Unsigned32
Number of HA DNS update responses sent containing a private response RR during reporting interval.
cDnsHaIntSyncConflictCnts
1.3.6.1.4.1.9.9.405.1.13.27
Unsigned32
Number of HA zones with name conflicts during nameset reconciliation during reporting interval.
cDnsHaIntSyncDiscardNameCnts
1.3.6.1.4.1.9.9.405.1.13.28
Unsigned32
Number of HA name conflicts where one nameset must be discarded to synchronize the zone during reporting interval.
cDnsHaIntSyncMergeNameCnts
1.3.6.1.4.1.9.9.405.1.13.29
Unsigned32
Number of HA name conflicts which the namesets can be merged to synchronize the zone during reporting interval.
cDnsHaIntUpdateLatencyAverage
1.3.6.1.4.1.9.9.405.1.13.30
Gauge32 · seconds
Average HA DNS update latency in seconds during reporting interval. Latency is measured as the time an update remains in the pending list.
cDnsHaIntSampleTime
1.3.6.1.4.1.9.9.405.1.13.31
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The time stamp of last HA sample.
cDnsHaIntSampleInterval
1.3.6.1.4.1.9.9.405.1.13.32
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds
The interval in seconds over which the server last calculated the HA sample interval statistics. This is the configured reporting interval and the statistics are reset since the last cDnsHaIntSampleTime.
cDnsHaIntMsgSyncPendingRcvdCnts
1.3.6.1.4.1.9.9.405.1.13.33
Unsigned32
Total number of HA_DNS_SYNCPENDING messages received during reporting interval.
cDnsHaIntMsgSyncPendingSentCnts
1.3.6.1.4.1.9.9.405.1.13.34
Unsigned32
Total number of HA_DNS_SYNCPENDING messages sent during reporting interval.
cDnsHaIntMsgShutdownRcvdCnts
1.3.6.1.4.1.9.9.405.1.13.35
Unsigned32
Total number of HA_DNS_SHUTDOWN messages received during reporting interval.
cDnsHaIntMsgShutdownSentCnts
1.3.6.1.4.1.9.9.405.1.13.36
Unsigned32
Total number of HA_DNS_SHUTDOWN messages sent during reporting interval.