EZ5 MIB Catalog

CISCO-ENTITY-EXT-MIB

2018-04-04

This MIB is an extension of the ENTITY-MIB specified in RFC2737. This MIB module contains Cisco-defined extensions to the entityPhysicalTable to represent information related to entities of class module(entPhysicalClass = 'module') which have a Processor. A processor module is defined as a physical entity that has a CPU, RAM and NVRAM so that it can independently - load a bootable image - save configuration. This module is the entry point for external applications like SNMP Manager, CLI, FTP etc. Line card is an interface card with at least a Processor and RAM. This might be referred to as Service Module in some cisco products. A configuration register is a 16 bit software register. The configuration register is mainly used to check for instructions on where to find the Cisco Operating System software. Some other functions of configuration register are: - To select a boot source and default boot filename. - To enable or disable the Break function. - To control broadcast addresses. - To set the console terminal baud rate. - To load operating software from Flash memory. - To allow us to manually boot the system using the boot command at the bootstrap program prompt. Booting is the process of initializing the hardware and starting the Operating System.

Download CISCO-ENTITY-EXT-MIB.txt Open CISCO-ENTITY-EXT-MIB.txt in a new tab

SCALARS (3) · TABLES (5) · TRAPS (6)

Scalars (3)

NameOID
ceExtEntDoorNotifEnable1.3.6.1.4.1.9.9.195.1.5.1
ceExtEntBreakOutPortNotifEnable1.3.6.1.4.1.9.9.195.1.5.2
ceExtEntUsbModemNotifEnable1.3.6.1.4.1.9.9.195.1.5.3

Tables (5)

NameOID
ceExtPhysicalProcessorTable1.3.6.1.4.1.9.9.195.1.1
ceExtConfigRegTable1.3.6.1.4.1.9.9.195.1.2
ceExtEntityLEDTable1.3.6.1.4.1.9.9.195.1.3
ceExtEntPhysicalTableaugments entPhysicalTable (ENTITY-MIB)1.3.6.1.4.1.9.9.195.1.4
ceExtUSBModemTable1.3.6.1.4.1.9.9.195.1.6

Traps (6)

NameOID
ceExtEntDoorCloseNotif1.3.6.1.4.1.9.9.195.2.0.1
ceExtEntDoorOpenNotif1.3.6.1.4.1.9.9.195.2.0.2
ceExtBreakOutPortInserted1.3.6.1.4.1.9.9.195.2.0.3
ceExtBreakOutPortRemoved1.3.6.1.4.1.9.9.195.2.0.4
ceExtUSBModemPlugInNotif1.3.6.1.4.1.9.9.195.2.0.5
ceExtUSBModemPlugOutNotif1.3.6.1.4.1.9.9.195.2.0.6

END OF TOC

Scalar details

ceExtEntDoorNotifEnable

1.3.6.1.4.1.9.9.195.1.5.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object controls the generation of ceExtEntDoorCloseNotif and ceExtEntDoorOpenNotif notifications as follows: 'true(1)' - the generation of ceExtEntDoorCloseNotif and ceExtEntDoorOpenNotif notifications are enabled. 'false(2)' - the generation of ceExtEntDoorCloseNotif and ceExtEntDoorOpenNotif notifications are disabled.

ceExtEntBreakOutPortNotifEnable

1.3.6.1.4.1.9.9.195.1.5.2

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object controls the generation of ceExtBreakOutPortInserted and ceExtBreakOutPortRemoved as follows: 'true(1)' - the generation of ceExtBreakOutPortInserted and ceExtBreakOutPortRemoved notifications is enabled. 'false(2)' - the generation of ceExtBreakOutPortInserted and ceExtBreakOutPortRemoved notifications is disabled.

ceExtEntUsbModemNotifEnable

1.3.6.1.4.1.9.9.195.1.5.3

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object controls the generation of ceExtUSBModemPlugInNotif and ceExtUSBModemPlugOutNotif as follows: 'true(1)' - the generation of ceExtUSBModemPlugInNotif and ceExtUSBModemPlugOutNotif notifications is enabled. 'false(2)' - the generation of ceExtUSBModemPlugOutNotif and ceExtUSBModemPlugOutNotif notifications is disabled.

Table details

ceExtPhysicalProcessorTable

1.3.6.1.4.1.9.9.195.1.1

Index: entPhysicalIndex

Reference: RFC2737: Section 2.12.1

The ceExtPhysicalProcessorTable extends the ENTITY-MIB entPhysicalTable for modules (Non FRUs(Field Replacable Units) or FRUs).

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

ceExtProcessorRam

1.3.6.1.4.1.9.9.195.1.1.1.1

Unsigned32 · bytes

Total number of bytes of RAM available on the Processor.

ceExtNVRAMSize

1.3.6.1.4.1.9.9.195.1.1.1.2

Unsigned32 · bytes

Total number of bytes of NVRAM in the entity. A value of 0 for this object means the entity does not support NVRAM or NVRAM information is not available.

ceExtNVRAMUsed

1.3.6.1.4.1.9.9.195.1.1.1.3

Unsigned32 · bytes

Number of bytes of NVRAM in use. This object is irrelevant if ceExtNVRAMSize is 0.

ceExtProcessorRamOverflow

1.3.6.1.4.1.9.9.195.1.1.1.4

Unsigned32 · bytes

This object represents the upper 32-bit of ceExtProcessorRam. This object needs to be supported only if the available RAM bytes exceeds 32-bit, otherwise this object value would be set to 0.

ceExtHCProcessorRam

1.3.6.1.4.1.9.9.195.1.1.1.5

Unsigned64An unsigned 64 bit integer. We use SYNTAX Counter64 for the encoding rules. (0..18446744073709551615) · Counter64 · bytes

This object represents the total number of bytes of RAM available on the Processor. This object is a 64-bit version of ceExtProcessorRam.

ceExtNVRAMSizeOverflow

1.3.6.1.4.1.9.9.195.1.1.1.6

Unsigned32 · bytes

This object represents the upper 32-bit of ceExtNVRAMSize. This object needs to be supported only if the available NVRAM bytes exceeds 32-bit, otherwise this object value would be set to 0.

ceExtHCNVRAMSize

1.3.6.1.4.1.9.9.195.1.1.1.7

Unsigned64An unsigned 64 bit integer. We use SYNTAX Counter64 for the encoding rules. (0..18446744073709551615) · Counter64 · bytes

This object represents the total number of bytes of NVRAM available on the Processor. This object is a 64-bit version of ceExtNVRAMSize.

ceExtNVRAMUsedOverflow

1.3.6.1.4.1.9.9.195.1.1.1.8

Unsigned32 · bytes

This object represents the upper 32-bit of ceExtNVRAMUsed. This object needs to be supported only if the used NVRAM bytes exceeds 32-bit, otherwise this object value would be set to 0.

ceExtHCNVRAMUsed

1.3.6.1.4.1.9.9.195.1.1.1.9

Unsigned64An unsigned 64 bit integer. We use SYNTAX Counter64 for the encoding rules. (0..18446744073709551615) · Counter64 · bytes

This object represents the number of bytes of NVRAM used on the Processor. This object is a 64-bit version of ceExtHCNVRAMUsed.

ceExtConfigRegTable

1.3.6.1.4.1.9.9.195.1.2

Index: entPhysicalIndex

Reference: RFC2737: Section 2.12.1

The ceExtConfigRegTable extends the ENTITY-MIB entPhysicalTable.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

ceExtConfigRegister

1.3.6.1.4.1.9.9.195.1.2.1.1

ConfigRegisterValueAn Integer containing the value of config register. The definition of individual bits from right to left when set are as follows: 00 to 03 Boot Fields(Refer below for explanation). 04 to 05 Not Used. 06 Causes system software to ignore the contents of NVRAM. 07 Enable the original equipment manufacturer (OEM) bit. 08 The Break function is disabled. 09 Not used. 10 Broadcast based on 0.0.0.0 IP address. 11 to 12 Defines the console baud rate as below: Bits 11 & 12 unset: 9600 baud(default), Bit 11 set & 12 unset: 4800 baud, Bit 11 unset & 12 set: 1200 baud, Bit 11 set & 12 set: 2400 baud 13 Boots default Flash software if network boot fails. 14 IP broadcasts do not have network numbers. 15 Enables diagnostic messages and ignores the contents of NVRAM. Meanings for different values of Boot Fields (Bits 00 to 03) are explained below: Value(in hex) Description ------------ ----------- 00 On powerup or reload, the system remains at the ROM monitor prompt (rommon>), awaiting a user command to boot the system manually by means of the rommon boot command. 01 On powerup or reload, the system loads the system image found in onboard Flash memory. 02 to On powerup or reload, the system loads 0F the system image specified by ceExtSysBootImageList. It tries to boot the image in the order in which the image names are entered in ceExtSysBootImageList. If it cannot boot any image in the ceExtSysBootImageList, it stays in ROM monitor mode. SIZE (2) · OCTET STRING · hint 2x

The value of configuration register with which the processor module booted.

ceExtConfigRegNext

1.3.6.1.4.1.9.9.195.1.2.1.2

ConfigRegisterValueAn Integer containing the value of config register. The definition of individual bits from right to left when set are as follows: 00 to 03 Boot Fields(Refer below for explanation). 04 to 05 Not Used. 06 Causes system software to ignore the contents of NVRAM. 07 Enable the original equipment manufacturer (OEM) bit. 08 The Break function is disabled. 09 Not used. 10 Broadcast based on 0.0.0.0 IP address. 11 to 12 Defines the console baud rate as below: Bits 11 & 12 unset: 9600 baud(default), Bit 11 set & 12 unset: 4800 baud, Bit 11 unset & 12 set: 1200 baud, Bit 11 set & 12 set: 2400 baud 13 Boots default Flash software if network boot fails. 14 IP broadcasts do not have network numbers. 15 Enables diagnostic messages and ignores the contents of NVRAM. Meanings for different values of Boot Fields (Bits 00 to 03) are explained below: Value(in hex) Description ------------ ----------- 00 On powerup or reload, the system remains at the ROM monitor prompt (rommon>), awaiting a user command to boot the system manually by means of the rommon boot command. 01 On powerup or reload, the system loads the system image found in onboard Flash memory. 02 to On powerup or reload, the system loads 0F the system image specified by ceExtSysBootImageList. It tries to boot the image in the order in which the image names are entered in ceExtSysBootImageList. If it cannot boot any image in the ceExtSysBootImageList, it stays in ROM monitor mode. SIZE (2) · OCTET STRING · hint 2x

The value of configuration register in the processor module at next reboot. Just after the reboot this has the same value as ceExtConfigRegister.

ceExtSysBootImageList

1.3.6.1.4.1.9.9.195.1.2.1.3

BootImageListThis contains a list of boot images, each separated by the ';' (semi-colon) character. The following provides a syntax for parsing a single boot image list item. <device>:[filename] | <URL> <device> can be (but not limited to): flash, bootflash, slot0, rom, C The transfer protocol used in the <URL> can be (but not limited to): tftp, ftp, rcp, mop. The following is en example containing two boot image names: disk0:c7100-ik2s-mz;tftp://dirt/c7100-ik2s-mz If the filename is not specified, then the first file on the <device> will be used. If the last two characters in the returned value are ';+' this indicates that additional boot image items are configured on the device but can not be returned because the maximum string size limitation would be exceeded. For example: disk0:image1;disk0:image2;+ SIZE (0..255) · OCTET STRING

The list of system boot images which can be used for booting.

ceExtKickstartImageList

1.3.6.1.4.1.9.9.195.1.2.1.4

BootImageListThis contains a list of boot images, each separated by the ';' (semi-colon) character. The following provides a syntax for parsing a single boot image list item. <device>:[filename] | <URL> <device> can be (but not limited to): flash, bootflash, slot0, rom, C The transfer protocol used in the <URL> can be (but not limited to): tftp, ftp, rcp, mop. The following is en example containing two boot image names: disk0:c7100-ik2s-mz;tftp://dirt/c7100-ik2s-mz If the filename is not specified, then the first file on the <device> will be used. If the last two characters in the returned value are ';+' this indicates that additional boot image items are configured on the device but can not be returned because the maximum string size limitation would be exceeded. For example: disk0:image1;disk0:image2;+ SIZE (0..255) · OCTET STRING

The list of system kickstart images which can be used for booting.

ceExtEntityLEDTable

1.3.6.1.4.1.9.9.195.1.3

Index: entPhysicalIndex · ceExtEntityLEDType

A table containing information of LED on an entity.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

ceExtEntityLEDType

1.3.6.1.4.1.9.9.195.1.3.1.1

INTEGER1 = status2 = system3 = active4 = power5 = battery · Integer32

Reference: Cisco MDS 9500 Series Hardware Installation Guide, Product Overview.

The type of LED on this entity. 'status' - indicates the entity status. 'system' - indicates the overall system status. 'active' - the redundancy status of a module, for e.g. supervisor module. 'power' - indicates sufficient power availability for all modules. 'battery'- indicates the battery status.

ceExtEntityLEDColor

1.3.6.1.4.1.9.9.195.1.3.1.2

INTEGER1 = off2 = green3 = amber4 = red · Integer32

Reference: Cisco MDS 9500 Series Multilayer Switches, Product Overview.

The color of the LED.

ceExtEntPhysicalTable

1.3.6.1.4.1.9.9.195.1.4

augments entPhysicalTable (ENTITY-MIB)

Index: entPhysicalIndex

Reference: RFC2737: Section 2.12.1

This table contains additional information about a particular physical entity. This table augments the 'entPhysicalTable' of the ENTITY-MIB.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

ceEntPhysicalSecondSerialNum

1.3.6.1.4.1.9.9.195.1.4.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

This object represents the vendor-specific second serial number string for the physical entity. The first serial number string of the physical entity is represented in the value of corresponding instance of the 'entPhysicalSerialNum' object. On the first instantiation of an physical entity, the value of this object is the correct vendor-assigned second serial number, if this information is available to the agent. If the second serial number is unknown or non-existent, then the value of this object will be a zero-length string instead. Note that implementations which can correctly identify the second serial numbers of all installed physical entities do not need to provide write access to this object. Agents which cannot provide non-volatile storage for the second serial number strings are not required to implement write access for this object. Not every physical component will have a serial number, or even need one. Physical entities for which the associated value of the entPhysicalIsFRU object is equal to 'false(2)' (e.g., the repeater ports within a repeater module), do not need their own unique serial number. An agent does not have to provide write access for such entities, and may return a zero-length string. If write access is implemented for an instance of 'ceEntPhysicalSecondSerialNum', and a value is written into the instance, the agent must retain the supplied value in the 'ceEntPhysicalSecondSerialNum' instance associated with the same physical entity for as long as that entity remains instantiated. This includes instantiations across all re- initializations/reboots of the network management system, including those which result in a change of the physical entity's entPhysicalIndex value.

ceExtUSBModemTable

1.3.6.1.4.1.9.9.195.1.6

Index: entPhysicalIndex

A table containing information of USB MODEMs on an entity.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

ceExtUSBModemIMEI

1.3.6.1.4.1.9.9.195.1.6.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..64) · OCTET STRING · hint 255t

Reference: RFC 6155

The International Mobile Equipment Identifier (IMEI) of the USB-MODEM

ceExtUSBModemIMSI

1.3.6.1.4.1.9.9.195.1.6.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..64) · OCTET STRING · hint 255t

Reference: RFC 4186

The International Mobile Subscriber Identifier(IMSI) - for a GSM USB MODEM.

ceExtUSBModemServiceProvider

1.3.6.1.4.1.9.9.195.1.6.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..64) · OCTET STRING · hint 255t

The Service Provider name for a USB MODEM.

ceExtUSBModemSignalStrength

1.3.6.1.4.1.9.9.195.1.6.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..64) · OCTET STRING · hint 255t

The signal strength of the USB MODEM.

Trap details

ceExtEntDoorCloseNotif

1.3.6.1.4.1.9.9.195.2.0.1

A ceExtEntDoorCloseNotif is generated if the door of an entity has been closed.

entPhysicalDescr

1.3.6.1.2.1.47.1.1.1.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

A textual description of physical entity. This object should contain a string that identifies the manufacturer's name for the physical entity and should be set to a distinct value for each version or model of the physical entity.

entPhysicalName

1.3.6.1.2.1.47.1.1.1.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The textual name of the physical entity. The value of this object should be the name of the component as assigned by the local device and should be suitable for use in commands entered at the device's 'console'. This might be a text name (e.g., 'console') or a simple component number (e.g., port or module number, such as '1'), depending on the physical component naming syntax of the device. If there is no local name, or if this object is otherwise not applicable, then this object contains a zero-length string. Note that the value of entPhysicalName for two physical entities will be the same in the event that the console interface does not distinguish between them, e.g., slot-1 and the card in slot-1.

ceExtEntDoorOpenNotif

1.3.6.1.4.1.9.9.195.2.0.2

A ceExtEntDoorOpenNotif is generated if the door of an entity has been opened.

entPhysicalDescr

1.3.6.1.2.1.47.1.1.1.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

A textual description of physical entity. This object should contain a string that identifies the manufacturer's name for the physical entity and should be set to a distinct value for each version or model of the physical entity.

entPhysicalName

1.3.6.1.2.1.47.1.1.1.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The textual name of the physical entity. The value of this object should be the name of the component as assigned by the local device and should be suitable for use in commands entered at the device's 'console'. This might be a text name (e.g., 'console') or a simple component number (e.g., port or module number, such as '1'), depending on the physical component naming syntax of the device. If there is no local name, or if this object is otherwise not applicable, then this object contains a zero-length string. Note that the value of entPhysicalName for two physical entities will be the same in the event that the console interface does not distinguish between them, e.g., slot-1 and the card in slot-1.

ceExtBreakOutPortInserted

1.3.6.1.4.1.9.9.195.2.0.3

The ceExtBreakOutPortInserted notification indicates that a Breakout port was inserted. The varbind for this notification indicates the entPhysicalIndex of the inserted Breakout port, and the entPhysicalIndex of the BreakOut Port module that contains this port.

entPhysicalContainedIn

1.3.6.1.2.1.47.1.1.1.1.4

PhysicalIndexOrZeroThis TEXTUAL-CONVENTION is an extension of the PhysicalIndex convention, which defines a greater than zero value used to identify a physical entity. This extension permits the additional value of zero. The semantics of the value zero are object-specific and must, therefore, be defined as part of the description of any object that uses this syntax. Examples of the usage of this extension are situations where none or all physical entities need to be referenced. (0..2147483647) · Integer32 · hint d

The value of entPhysicalIndex for the physical entity that 'contains' this physical entity. A value of zero indicates this physical entity is not contained in any other physical entity. Note that the set of 'containment' relationships define a strict hierarchy; that is, recursion is not allowed. In the event that a physical entity is contained by more than one physical entity (e.g., double-wide modules), this object should identify the containing entity with the lowest value of entPhysicalIndex.

entPhysicalName

1.3.6.1.2.1.47.1.1.1.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The textual name of the physical entity. The value of this object should be the name of the component as assigned by the local device and should be suitable for use in commands entered at the device's 'console'. This might be a text name (e.g., 'console') or a simple component number (e.g., port or module number, such as '1'), depending on the physical component naming syntax of the device. If there is no local name, or if this object is otherwise not applicable, then this object contains a zero-length string. Note that the value of entPhysicalName for two physical entities will be the same in the event that the console interface does not distinguish between them, e.g., slot-1 and the card in slot-1.

ceExtBreakOutPortRemoved

1.3.6.1.4.1.9.9.195.2.0.4

The ceExtBreakOutPortRemoved notification indicates that a Breakout Port was removed. The varbind for this notification indicates the entPhysicalIndex of the removed Breakout port, and the entPhysicalIndex of the BreakOut Port module that contains this port.

entPhysicalContainedIn

1.3.6.1.2.1.47.1.1.1.1.4

PhysicalIndexOrZeroThis TEXTUAL-CONVENTION is an extension of the PhysicalIndex convention, which defines a greater than zero value used to identify a physical entity. This extension permits the additional value of zero. The semantics of the value zero are object-specific and must, therefore, be defined as part of the description of any object that uses this syntax. Examples of the usage of this extension are situations where none or all physical entities need to be referenced. (0..2147483647) · Integer32 · hint d

The value of entPhysicalIndex for the physical entity that 'contains' this physical entity. A value of zero indicates this physical entity is not contained in any other physical entity. Note that the set of 'containment' relationships define a strict hierarchy; that is, recursion is not allowed. In the event that a physical entity is contained by more than one physical entity (e.g., double-wide modules), this object should identify the containing entity with the lowest value of entPhysicalIndex.

entPhysicalName

1.3.6.1.2.1.47.1.1.1.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The textual name of the physical entity. The value of this object should be the name of the component as assigned by the local device and should be suitable for use in commands entered at the device's 'console'. This might be a text name (e.g., 'console') or a simple component number (e.g., port or module number, such as '1'), depending on the physical component naming syntax of the device. If there is no local name, or if this object is otherwise not applicable, then this object contains a zero-length string. Note that the value of entPhysicalName for two physical entities will be the same in the event that the console interface does not distinguish between them, e.g., slot-1 and the card in slot-1.

ceExtUSBModemPlugInNotif

1.3.6.1.4.1.9.9.195.2.0.5

The ceExtUSBModemPlugInNotif notification indicates that a USB MODEM was inserted. The varbind for this notification indicates the entPhysicalDescr of the inserted USB MODEM, and the entPhysicalIndex of the USB MODEM's container.

entPhysicalContainedIn

1.3.6.1.2.1.47.1.1.1.1.4

PhysicalIndexOrZeroThis TEXTUAL-CONVENTION is an extension of the PhysicalIndex convention, which defines a greater than zero value used to identify a physical entity. This extension permits the additional value of zero. The semantics of the value zero are object-specific and must, therefore, be defined as part of the description of any object that uses this syntax. Examples of the usage of this extension are situations where none or all physical entities need to be referenced. (0..2147483647) · Integer32 · hint d

The value of entPhysicalIndex for the physical entity that 'contains' this physical entity. A value of zero indicates this physical entity is not contained in any other physical entity. Note that the set of 'containment' relationships define a strict hierarchy; that is, recursion is not allowed. In the event that a physical entity is contained by more than one physical entity (e.g., double-wide modules), this object should identify the containing entity with the lowest value of entPhysicalIndex.

entPhysicalDescr

1.3.6.1.2.1.47.1.1.1.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

A textual description of physical entity. This object should contain a string that identifies the manufacturer's name for the physical entity and should be set to a distinct value for each version or model of the physical entity.

ceExtUSBModemPlugOutNotif

1.3.6.1.4.1.9.9.195.2.0.6

The ceExtUSBModemPlugOutNotif notification indicates that a USB MODEM was removed. The varbind for this notification indicates the entPhysicalDescr of the removed USB MODEM, and the entPhysicalIndex of the USB MODEM's container.

entPhysicalContainedIn

1.3.6.1.2.1.47.1.1.1.1.4

PhysicalIndexOrZeroThis TEXTUAL-CONVENTION is an extension of the PhysicalIndex convention, which defines a greater than zero value used to identify a physical entity. This extension permits the additional value of zero. The semantics of the value zero are object-specific and must, therefore, be defined as part of the description of any object that uses this syntax. Examples of the usage of this extension are situations where none or all physical entities need to be referenced. (0..2147483647) · Integer32 · hint d

The value of entPhysicalIndex for the physical entity that 'contains' this physical entity. A value of zero indicates this physical entity is not contained in any other physical entity. Note that the set of 'containment' relationships define a strict hierarchy; that is, recursion is not allowed. In the event that a physical entity is contained by more than one physical entity (e.g., double-wide modules), this object should identify the containing entity with the lowest value of entPhysicalIndex.

entPhysicalDescr

1.3.6.1.2.1.47.1.1.1.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

A textual description of physical entity. This object should contain a string that identifies the manufacturer's name for the physical entity and should be set to a distinct value for each version or model of the physical entity.

↑ To TOC