EZ5 MIB Catalog

CISCO-ENTITY-PFE-MIB

2002-11-27

The Packet Forwarding Engine technology are Cisco developed Network Processors, which accelerates certain features in order to provide better network performance. An agent uses this MIB to monitor the performance history on any active PFE pipeline listed in the ENTITY-MIB (RFC 2737) entPhysicalTable. This monitoring is via measurement periods of actual, 1-minute, 5-minutes and 15-minutes. For the 1-minute and 5-minute measurement periods, perfor- mance statistics are calculated and displayed based on pre- vious 1 minute and 5 minute respectively. For the 15-minute period, the performance statistics are accumulated in fifteen minute intervals. At any one time, an agent maintains one current (incomplete) interval and up to 96 completed intervals (24 hours worth). Fewer than 96 intervals of data will be available if the agent has been restarted within the last 24 hours. In addition, there is a rolling 24-hour total of each performance statistic. There is no requirement for an agent to ensure fixed rela- tionship between the start of a fifteen minute interval and any wall clock; however some agents may align the fifteen minute intervals with quarter hours.

Download CISCO-ENTITY-PFE-MIB.txt Open CISCO-ENTITY-PFE-MIB.txt in a new tab

SCALARS (3) · TABLES (5) · TRAPS (2)

Scalars (3)

NameOID
cePfeHistNotifiesEnable1.3.6.1.4.1.9.9.265.1.2.1
cePfeHistTableSize1.3.6.1.4.1.9.9.265.1.2.2
cePfeHistTableLastIndex1.3.6.1.4.1.9.9.265.1.2.3

Tables (5)

NameOID
cePfePerfConfigTable1.3.6.1.4.1.9.9.265.1.1.1
cePfePerfCurrentTableaugments cePfePerfConfigTable1.3.6.1.4.1.9.9.265.1.1.2
cePfePerfIntervalTable1.3.6.1.4.1.9.9.265.1.1.3
cePfePerfTotalTable1.3.6.1.4.1.9.9.265.1.1.4
cePfeHistTable1.3.6.1.4.1.9.9.265.1.2.4

Traps (2)

NameOID
cePfeHistThldEvent1.3.6.1.4.1.9.9.265.0.1
cePfeHistRestartEvent1.3.6.1.4.1.9.9.265.0.2

END OF TOC

Scalar details

cePfeHistNotifiesEnable

1.3.6.1.4.1.9.9.265.1.2.1

EventType1 = none2 = log3 = notify4 = logAndNotifyType of action to execute when an event occurs. 'none' Neither log an entry in the cePfeHistTable, nor sent out an SNMP notification. 'log' Create a cePfeHistTable entry, but do not sent out an SNMP notification. 'notify' Sent out an SNMP notification, but do not create a log entry in the cePfeHistTable. 'logAndNotify' Both create a log entry in the cePfeHistTable and sent out an SNMP notification. · Integer32

This object indicates what type of action should be taken by the agent when a event is generated.

cePfeHistTableSize

1.3.6.1.4.1.9.9.265.1.2.2

Unsigned32 (0..500)

This object specifies the number of entries that the cePfeHistTable can contain. When a event is generated, and the capacity of the cePfeHistTable has reached the value specified by this object, then the agent deletes the oldest entity in order to accommodate the new entry. A value of '0' prevents any history from being retained.

cePfeHistTableLastIndex

1.3.6.1.4.1.9.9.265.1.2.3

Unsigned32

This object specifies the value of the cePfeHistIndex object corresponding to the last entry added to the table by the agent. It will return zero if there are no entries in the table. If the management client uses the notifications defined by this module, then it can poll this object to determine whether it has missed a notification sent by the agent.

Table details

cePfePerfConfigTable

1.3.6.1.4.1.9.9.265.1.1.1

Index: entPhysicalIndex

This table contains configuration information on a PFE pipeline.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

cePfePerfConfigTimeElapsed

1.3.6.1.4.1.9.9.265.1.1.1.1.1

Unsigned32 (0..899) · seconds

The number of seconds that have elapsed since the beginning of the current 15 min interval. If for some reason, such as an adjustment in the system's time-of-day clock, the current interval exceeds the maximum value, the agent will return the maximum value.

cePfePerfConfigValidIntervals

1.3.6.1.4.1.9.9.265.1.1.1.1.2

Unsigned32 (0..96)

The number of completed 15 min intervals for which valid PFE performance data has been collected. The value will be 96 unless the interface was brought online within the last 24 hours, in which case the value will be the number of completed 15 minute intervals since the PFE pipeline has been online.

cePfePerfConfigThldUtilization

1.3.6.1.4.1.9.9.265.1.1.1.1.3

PercentageA percentage value. (0..100) · Unsigned32

This object contains the threshold value for the cePfePerfCurrentUtilization object. If during the last 5 second measurement period the cePfePerfCurrentUtilization object becomes greater than or equal to this threshold value, an event of type 'thldUtilizationEvent' will be genera- ted. Value of zero indicates that no comparison is being made between the cePfePerfCurrentUtilization object value and the threshold value, therefore no event action will be gene- rated.

cePfePerfConfigThldEfficiency

1.3.6.1.4.1.9.9.265.1.1.1.1.4

PercentageA percentage value. (0..100) · Unsigned32

This object contains the threshold value for the cePfePerfCurrentEffciency object. If during the last 5 second measurement period the cePfePerfCurrentEfficiency object becomes less than or equal to this threshold value, an event of type 'thldEfficiencyEvent' will be genera- ted. Value of zero indicates that no comparison is being made between the cePfePerfCurrentEfficiency object value and the threshold value, therefore no event action will be gene- rated.

cePfePerfConfigThld1MinUtilization

1.3.6.1.4.1.9.9.265.1.1.1.1.5

PercentageA percentage value. (0..100) · Unsigned32

This object contains the threshold value for the cePfePerfCurrent1MinUtilization object. If during the last 1 minute measurement period the cePfePerfCurrent1MinUtilization object becomes greater than or equal to this threshold value, an event of type 'thld1MinUtilizationEvent' will be genera- ted. Value of zero indicates that no comparison is being made between the cePfePerfCurrent1MinUtilization object value and the threshold value, therefore no event action will be gene- rated.

cePfePerfConfigThld1MinEfficiency

1.3.6.1.4.1.9.9.265.1.1.1.1.6

PercentageA percentage value. (0..100) · Unsigned32

This object contains the threshold value for the cePfePerfCurrent1MinEfficiency object. If during the last 1 minute measurement period the cePfePerfCurrent1MinEfficiency object becomes less than or equal to this threshold value, an event of type 'thld1MinEfficiencyEvent' will be genera- ted. Value of zero indicates that no comparison is being made between the cePfePerfCurrent1MinEfficiency object value and the threshold value, therefore no event action will be gene- rated.

cePfePerfConfigThld5MinUtilization

1.3.6.1.4.1.9.9.265.1.1.1.1.7

PercentageA percentage value. (0..100) · Unsigned32

This object contains the threshold value for the cePfePerfCurrent5MinUtilization object. If during the last 5 minute measurement period the cePfePerfCurrent5MinUtilization object becomes greater than or equal to this threshold value, an event of type 'thld5MinUtilizationEvent' will be genera- ted. Value of zero indicates that no comparison is being made between the cePfePerfCurrent5MinUtilization object value and the threshold value, therefore no event action will be gene- rated.

cePfePerfConfigThld5MinEfficiency

1.3.6.1.4.1.9.9.265.1.1.1.1.8

PercentageA percentage value. (0..100) · Unsigned32

This object contains the threshold value for the cePfePerfCurrent5MinEfficiency object. If during the last 5 minute measurement period the cePfePerfCurrent5MinEfficiency object becomes less than or equal to this threshold value, an event of type 'thld5MinEfficiencyEvent' will be genera- ted. Value of zero indicates that no comparison is being made between the cePfePerfCurrent5MinEfficiency object value and the threshold value, therefore no event action will be gene- rated.

cePfePerfCurrentTable

1.3.6.1.4.1.9.9.265.1.1.2

augments cePfePerfConfigTable

Index: entPhysicalIndex

This table maintains PFE current running performance, which are collected at various measurement periods.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

cePfePerfCurrentUtilization

1.3.6.1.4.1.9.9.265.1.1.2.1.1

CurrentUtilizationA percentage value that represent the actual utilization performance measurement. (0..100) · Gauge32

This object provides the actual PFE percentage utilization. It is determined by the number of new work contexts + feedback contexts divided by total number of contexts that can be supported by the PFE pipeline.

cePfePerfCurrentEfficiency

1.3.6.1.4.1.9.9.265.1.1.2.1.2

CurrentEfficiencyA percentage value that represents the actual efficiency performance measurement. (0..100) · Gauge32

This object provides the actual PFE percentage efficiency. It is determined by the total number of contexts per second divided by maximum theoretical contexts per second supported by the PFE pipeline. Under normal conditions, this number will be 100 and when efficiency starts degrading, it will start going down until it reaches zero.

cePfePerfCurrent1MinUtilization

1.3.6.1.4.1.9.9.265.1.1.2.1.3

CurrentUtilizationA percentage value that represent the actual utilization performance measurement. (0..100) · Gauge32

This object provides the PFE percentage utilization over the previous 1 minute period. It is determined by the number of new work contexts + feedback contexts divided by total number of contexts that can be supported by the PFE pipeline.

cePfePerfCurrent1MinEfficiency

1.3.6.1.4.1.9.9.265.1.1.2.1.4

CurrentEfficiencyA percentage value that represents the actual efficiency performance measurement. (0..100) · Gauge32

This object provides the PFE percentage efficiency over the previous 1 minute period. It is determined by the totalnumber of contexts per second divided by maximum theoretical contexts per second supported by the PFE pipeline. Under normal conditions, this number will be 100 and when efficiency starts degrading, it will start going down until it reaches zero.

cePfePerfCurrent5MinUtilization

1.3.6.1.4.1.9.9.265.1.1.2.1.5

CurrentUtilizationA percentage value that represent the actual utilization performance measurement. (0..100) · Gauge32

This object provides the PFE percentage utilization over the previous 5 minutes period. It is determined by the number of new work contexts + feedback contexts divided by total number of contexts that can be supported by the PFE pipeline.

cePfePerfCurrent5MinEfficiency

1.3.6.1.4.1.9.9.265.1.1.2.1.6

CurrentEfficiencyA percentage value that represents the actual efficiency performance measurement. (0..100) · Gauge32

This object provides the PFE percentage efficiency over the previous 5 minutes period. It is determined by the total number of contexts per second divided by maximum theoretical contexts per second supported by the PFE pipeline. Under normal conditions, this number will be 100 and when efficiency starts degrading, it will start going down until it reaches zero.

cePfePerfIntervalTable

1.3.6.1.4.1.9.9.265.1.1.3

Index: entPhysicalIndex · cePfePerfIntervalNumber

This table contains performance statistics for completed 15 minutes intervals, specifically up to 96 such intervals over a 24 hours of operation.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

cePfePerfIntervalNumber

1.3.6.1.4.1.9.9.265.1.1.3.1.1

Unsigned32 (1..96)

An interval number between 1 and 96, where 1 is the most recently completed 15 min interval and 96 is the 15 min interval completed 23 hours and 45 minutes prior to interval 1.

cePfePerfIntervalUtilization

1.3.6.1.4.1.9.9.265.1.1.3.1.2

IntervalUtilizationA percentage value that represents the utilization perfor- mance measurement in a previous 15 minute measurement interval. In the case where the agent has no valid data available for a particular interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchObject error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). In a system supporting a history of n intervals with IntervalUtilization(1) and IntervalUtilization(n) the most and least recent intervals respectively, the following proce- dure is used to update the intervals at end of a 15 minute interval: - discard the value of IntervalUtilization(n) - the value of IntervalUtilization(i) becomes that of IntervalUtilization(i-1) for n >= i > 1 - the value of IntervalUtilization(1) becomes that of current 15-minute %utilization. (0..100) · Gauge32

The percentage of processor utilization by the PFE pipeline during this completed 15 min interval.

cePfePerfIntervalEfficiency

1.3.6.1.4.1.9.9.265.1.1.3.1.3

IntervalEfficiencyA percentage value that represents the efficiency performance measurement in a previous 15 minute measurement interval. In the case where the agent has no valid data available for a particular interval the corresponding object instance is not available and upon a retrieval request a corresponding error message shall be returned to indicate that this instance does not exist (for example, a noSuchObject error for SNMPv1 and a noSuchInstance for SNMPv2 GET operation). In a system supporting a history of n intervals with IntervalEfficiency(1) and IntervalEfficiency(n) the most and least recent intervals respectively, the following procedure is used to update the intervals at end of a 15 minute inter- val: - discard the value of IntervalEfficiency(n) - the value of IntervalEfficiency(i) becomes that of IntervalEfficiency(i-1) for n >= i > 1 - the value of IntervalEfficiency(1) becomes that of currente 15-minute %efficiency. (0..100) · Gauge32

The percentage of processor efficiency by the PFE pipeline during this completed 15 min interval. Under normal conditions, this number will be 100 and when efficiency starts degrading, it will start going down until it reaches zero.

cePfePerfTotalTable

1.3.6.1.4.1.9.9.265.1.1.4

Index: entPhysicalIndex

This table contains the running utilization and efficiency of the PFE pipeline for the 24 hour period preceding the current interval. If the agent was restarted less than 24 hours ago, i.e., when there are less than 96 intervals in the cePfePerfIntervalTable, it will contain the running utiliza- tion and efficiency up to the last collected 15 minute inter- val.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

cePfePerfTotalUtilization

1.3.6.1.4.1.9.9.265.1.1.4.1.1

TotalUtilizationA percentage value that represents the total running utili- zation performance measurements. (0..100) · Gauge32

The running utilization by the PFE pipeline for the prece- ding 24 hrs.

cePfePerfTotalEfficiency

1.3.6.1.4.1.9.9.265.1.1.4.1.2

TotalEfficiencyA percentage value that represents the total running Effi- ciency performance measurements. (0..100) · Gauge32

The running efficiency by the PFE pipeline for the preceding 24 hrs. Under normal conditions, this number will be 100 and when efficiency starts degrading, it will start going down until it reaches zero.

cePfeHistTable

1.3.6.1.4.1.9.9.265.1.2.4

Index: cePfeHistIndex

This table contains a history of events generated by the agent.

cePfeHistIndex

1.3.6.1.4.1.9.9.265.1.2.4.1.1

Unsigned32 (1..4294967295)

An integer value uniquely identifying the entry in the table. The value of this object starts at '1' and monotonically increases for each event condition transition monitored by the agent. If the value of this object is '4294967295', the agent will reset the index to '1' upon monitoring the next event condition transition.

cePfeHistEntPhysIndex

1.3.6.1.4.1.9.9.265.1.2.4.1.2

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The value in this object is equal to the value of the entPhysicalIndex, from the Physical Entity Table (RFC 2037), that is associated with the PFE pipeline that has caused this event.

cePfeHistType

1.3.6.1.4.1.9.9.265.1.2.4.1.3

HistEventType1 = thldUtilizationEvent2 = thldEfficiencyEvent3 = thld1MinUtilizationEvent4 = thld1MinEfficiencyEvent5 = thld5MinUtilizationEvent6 = thld5MinEfficiencyEvent7 = restartEventType of event that has occurred. 'thldUtilizationEvent' This event is generated if the cePfePerfCurrentUtilization, at the time of sampling, becomes greater than or equal to the cePfePerfThldUtilization. 'thldEfficiencyEvent' This event is generated if the cePfePerfCurrentEfficiency, at the time of sampling, becomes less than or equal to the cePfePerfThldEfficiency. 'thld1MinUtilizationEvent' This event is generated if the cePfePerfCurrent1MinUtilization, at the time of sampling, becomes greater than or equal to the cePfePerfThld1MinUtilization. 'thld1MinEfficiencyEvent' This event is generated if the cePfePerfCurrent1MinEfficiency, at the time of sampling, becomes less than or equal to the cePfePerfThld1MinEfficiency. 'thld5MinUtilizationEvent' This event is generated if the cePfePerfCurrent5MinUtilization, at the time of sampling, becomes greater than or equal to the cePfePerfThld5MinUtilization. 'thld5MinEfficiencyEvent' This event is generated if the cePfePerfCurrent5MinEfficiency, at the time of sampling, becomes less than or equal to the cePfePerfThld5MinEfficiency. 'restartEvent' This event is generated every time the processor gets restarted. · Integer32

This object describes the type of event that has occurred.

cePfeHistThld

1.3.6.1.4.1.9.9.265.1.2.4.1.4

PercentageA percentage value. (0..100) · Unsigned32

The configured value of the specific threshold.

cePfeHistValue

1.3.6.1.4.1.9.9.265.1.2.4.1.5

PercentageA percentage value. (0..100) · Unsigned32

The actual value of the specific performance objects, at the time of the sample, which is related to the threshold event.

cePfeHistRestartReason

1.3.6.1.4.1.9.9.265.1.2.4.1.6

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The reason for which the PFE pipeline has restarted.

cePfeHistTimeStamp

1.3.6.1.4.1.9.9.265.1.2.4.1.7

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

This object specifies the value of the sysUpTime object at the time the event was generated.

Trap details

cePfeHistThldEvent

1.3.6.1.4.1.9.9.265.0.1

This notification is generated when a threshold event has occurred and the cePfeHistNotifiesEnable is set to 'notify (3)' or 'logAndNotify(4)'. After generating this notification, another such notifica- tion will not be sent out until the sample value has fallen below the threshold value.

cePfeHistEntPhysIndex

1.3.6.1.4.1.9.9.265.1.2.4.1.2

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The value in this object is equal to the value of the entPhysicalIndex, from the Physical Entity Table (RFC 2037), that is associated with the PFE pipeline that has caused this event.

cePfeHistType

1.3.6.1.4.1.9.9.265.1.2.4.1.3

HistEventType1 = thldUtilizationEvent2 = thldEfficiencyEvent3 = thld1MinUtilizationEvent4 = thld1MinEfficiencyEvent5 = thld5MinUtilizationEvent6 = thld5MinEfficiencyEvent7 = restartEventType of event that has occurred. 'thldUtilizationEvent' This event is generated if the cePfePerfCurrentUtilization, at the time of sampling, becomes greater than or equal to the cePfePerfThldUtilization. 'thldEfficiencyEvent' This event is generated if the cePfePerfCurrentEfficiency, at the time of sampling, becomes less than or equal to the cePfePerfThldEfficiency. 'thld1MinUtilizationEvent' This event is generated if the cePfePerfCurrent1MinUtilization, at the time of sampling, becomes greater than or equal to the cePfePerfThld1MinUtilization. 'thld1MinEfficiencyEvent' This event is generated if the cePfePerfCurrent1MinEfficiency, at the time of sampling, becomes less than or equal to the cePfePerfThld1MinEfficiency. 'thld5MinUtilizationEvent' This event is generated if the cePfePerfCurrent5MinUtilization, at the time of sampling, becomes greater than or equal to the cePfePerfThld5MinUtilization. 'thld5MinEfficiencyEvent' This event is generated if the cePfePerfCurrent5MinEfficiency, at the time of sampling, becomes less than or equal to the cePfePerfThld5MinEfficiency. 'restartEvent' This event is generated every time the processor gets restarted. · Integer32

This object describes the type of event that has occurred.

cePfeHistThld

1.3.6.1.4.1.9.9.265.1.2.4.1.4

PercentageA percentage value. (0..100) · Unsigned32

The configured value of the specific threshold.

cePfeHistValue

1.3.6.1.4.1.9.9.265.1.2.4.1.5

PercentageA percentage value. (0..100) · Unsigned32

The actual value of the specific performance objects, at the time of the sample, which is related to the threshold event.

cePfeHistRestartEvent

1.3.6.1.4.1.9.9.265.0.2

This notification is generated when a restart event has occurred and the cePfeHistNotifiesEnable is set to 'notifyp (3)' or 'logAndNotify(4)'.

cePfeHistEntPhysIndex

1.3.6.1.4.1.9.9.265.1.2.4.1.2

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The value in this object is equal to the value of the entPhysicalIndex, from the Physical Entity Table (RFC 2037), that is associated with the PFE pipeline that has caused this event.

cePfeHistRestartReason

1.3.6.1.4.1.9.9.265.1.2.4.1.6

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The reason for which the PFE pipeline has restarted.

↑ To TOC