EZ5 MIB Catalog

CISCO-FLOW-METADATA-MIB

2012-12-20

The MIB module for managing Cisco medianet flow metadata. Metadata, in the simplest form, is data that qualifies other data. Flow metadata is data that describes a flow in the network. Metadata plays an important role in providing a framework, that makes data from one component available to another component on the same network element as well as across other network elements. MIB Table Overview: =================== This MIB consists of two tables: 1) cfmMetadataFlowTable 2) cfmMetadataFlowAttrTable cfmMetadataFlowTable provides the details about the six tuple which can uniquely identify a network traffic flow. cfmMetadataFlowAttrTable will specify flow attributes carried in the metadata flow. Flow attribute values are represented in 'Type-Value' format. cfmMetadataFlowAttrType - Represent the type of flow attribute. cfmMetadataFlowAttrValue - Represent corresponding flow attribute value. cfmMetadataFlowTable and cfmMetadataFlowAttrTable are linked together using flow ID which will map respective metadata flow attributes with the corresponding flow key.

Download CISCO-FLOW-METADATA-MIB.txt Open CISCO-FLOW-METADATA-MIB.txt in a new tab

TABLES (3)

Tables (3)

NameOID
cfmMetadataFlowTable1.3.6.1.4.1.9.9.789.1.1
cfmMetadataFlowAttrTable1.3.6.1.4.1.9.9.789.1.2
cfmMetadataFlowAllAttrTable1.3.6.1.4.1.9.9.789.1.3

END OF TOC

Table details

cfmMetadataFlowTable

1.3.6.1.4.1.9.9.789.1.1

Index: cfmMetadataFlowId

A list of 6-tuple and flow id that is used to identify the metadata flows.

cfmMetadataFlowId

1.3.6.1.4.1.9.9.789.1.1.1.1

Unsigned32

ID that uniquely identifies this metadata flow. It is dynamically generated once the flow key information is available and assigned to the flow.

cfmMetadataFlowProtocolType

1.3.6.1.4.1.9.9.789.1.1.1.2

INTEGER1 = tcp2 = udp · Integer32

The protocol type of this metadata flow.

cfmMetadataFlowDestAddrType

1.3.6.1.4.1.9.9.789.1.1.1.3

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The type of destination Internet address of this metadata flow.

cfmMetadataFlowDestAddr

1.3.6.1.4.1.9.9.789.1.1.1.4

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The destination Internet address of this metadata flow. The type of this address is determined by the value of cfmMetadataFlowDestAddrType.

cfmMetadataFlowDestPort

1.3.6.1.4.1.9.9.789.1.1.1.5

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

The destination port of this metadata flow.

cfmMetadataFlowSrcAddrType

1.3.6.1.4.1.9.9.789.1.1.1.6

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The type of source Internet address of this metadata flow.

cfmMetadataFlowSrcAddr

1.3.6.1.4.1.9.9.789.1.1.1.7

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The source Internet address of this metadata flow. The type of this address is determined by the value of cfmMetadataFlowSrcAddrType.

cfmMetadataFlowSrcPort

1.3.6.1.4.1.9.9.789.1.1.1.8

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

The source port of this metadata flow.

cfmMetadataFlowSSRC

1.3.6.1.4.1.9.9.789.1.1.1.9

Unsigned32

The Synchronization Source Identifier (SSRC) of this metadata flow.

cfmMetadataFlowAttrTable

1.3.6.1.4.1.9.9.789.1.2

Index: cfmMetadataFlowId · cfmMetadataFlowAttrType

A list of metadata flows and their additional attribute parameters. cfmMetadataFlowAttrTable object is superseded by cfmMetadataFlowAttribTable.

cfmMetadataFlowAttrType

1.3.6.1.4.1.9.9.789.1.2.1.1

CfmMetadataFlowAttributeType0 = other94 = appDescription95 = appTag96 = appName97 = appVersion98 = appVendor100 = vmFlowTimeout101 = vmRTPClockFrequency103 = pakRate104 = l3Bitrate105 = mediaBitrate106 = mediaVideoPaksize107 = globalSessionID108 = multipartySessionID109 = rtpMediaFlow110 = mediaEncryptionStatus111 = syntheticTraffic112 = meteringPriority113 = endpointModel114 = endpointVendor115 = endpointVersion116 = ssrc117 = endpointIPAddressType118 = endpointIPAddressLength119 = endpointIPAddressValue120 = sipProxyServerType121 = sipProxyServerLength122 = sipProxyServerValue123 = bandwidth124 = deviceName125 = deviceClass126 = sipUserName127 = sipEmail128 = audioCodec129 = bandwidthConsumed130 = payloadType131 = mimeType132 = extrapolatedBandwidth134 = cname135 = videoCodec136 = sdpSessionID137 = domainName138 = endpointSwVersion139 = tosDscpThis object specifies the attributes types that is applicable to a given flow. The following are the entire possible metadata attribute types and a brief explanation for the same. other(0) - Other attribute types than listed below. appDescription(94) - Application description of the the flow. It is represented as a string of length 55 characters. appTag(95) - Application tag value of the flow. It is represented as unsigned32. appName(96) - Application name of the flow. It is represented as a string of length 24 characters. appVersion(97) - Application version of the flow. It is represented as a string of length 40 characters. appVendor(98) - Application vendor of the flow. It is represented as a string of length 40 characters. vmFlowTimeout(100) - Flow time out value of the flow. It is represented as unsigned32. vmRTPClockFrequency(101) - Clock frequency of the flow. It is represented as unsigned32. pakrate(103) - Packet rate of the flow. It is represented as unsigned64. l3Bitrate(104) - L3 bit rate of the flow. It is represented as unsigned32. mediaBitrate(105) - Media bit rate of the flow. It is represented as unsigned32. mediaVideoPaksize(106) - Media video bit rate of the flow. It is represented as unsigned32. globalSessionID(107) - Global session ID of the flow.It is represented as a string of length 80 characters. multipartySessionID(108) - Multi party session ID of the flow. It is represented as a string of length 80 characters. rtpMediaFlow(109) - RTP media flow attribute of the flow. It is represented as uint8. mediaEncryptionStatus(110) - Media encryption status of the flow. It is represented as uint8. syntheticTraffic(111) - Synthetic traffic represented as uint8. meteringPriority(112) - Metering Priority of the flow. It is represented as uint8. endpointModel(113) - Endpoint device model signaling the flow. It is represented as string of 40 characters length. endpointVendor(114) - Endpoint device vendor signaling the flow. It is represented as string of 40 characters length. endpointVersion(115) - Endpoint device version signaling the flow. It is represented as string of 40 characters length. ssrc(116) - Synchronization source of the flow. It is represented as uint32. endpointIPAddressType(117) - IP address type of the endpoint device signaling the flow. It is represented as uint8. endpointIPAddressLength(118) - IP address length of the endpoint device signaling the flow. It is represented as uint8. endpointIPAddressValue(119) - IP address of the endpoint device signaling the flow. It is represented as a string of 16 characters length. sipProxyServerType(120) - SIP proxy server IP address type of the flow. It is represented as uint8. sipProxyServerLength(121) - SIP proxy server IP address length of the flow. It is represented as uint8. sipProxyServerValue(122) - SIP proxy server IP address of the flow. It is represented as a string of 16 characters length. bandwidth(123) - Bandwidth of the flow. It is represented as uint32. deviceName(124) - Endpoint device name signaling the flow. It is represented as a string of 100 characters length. deviceClass(125) - Endpoint device class signaling the flow. It is represented as a string of 100 characters length. sipUserName(126) - SIP flow user name. It is represented as a string of 16 characters length. sipEmail(127) - SIP flow email ID. It is represented as a string of 24 characters length. audioCodec(128) - Audio codec of the flow. It is represented as uint8. bandwidthConsumed(129) - Bandwidth consumed of the flow. It is represented as uint32. payloadType(130) - Payload type of the flow. It is represented as uint8. mimeType(131) - MIME type of the flow. It is represented as a string of 16 characters length. extrapolatedBandwidth(132) - Extrapolated bandwidth of the flow. It is represented as uint32. cname(134) - cname of the flow. It is represented as a string of 24 characters in length. videoCodec(135) - Video codec of the flow. It is represented as uint8. sdpSessionID(136) - SDP session ID of the flow. It is represented as a string of 80 characters length. domainName(137) - Domain name of the flow. It is represented as a string of 24 characters length. endpointSwVersion(138) - Software version of the endpoint device signaling the flow. It is represented as a string of 24 characters length. tosDscp(139) - Tos/Dscp value of the flow. It is represented as uint8. This textual-convention and objects of this type have been deprecated as no longer needed. CfmMetadataFlowAttributeType object is superseded by cfmMetadataFlowAllAttrValue. · Integer32

The attribute type applicable to a given metadata flow. The attribute types are explained in CfmMetadataFlowAttrType. cfmMetadataFlowAttrType object is superseded by cfmMetadataIpFixIeId.

cfmMetadataFlowAttrValue

1.3.6.1.4.1.9.9.789.1.2.1.2

CfmMetadataFlowAttrValThis textual convention denotes a value to be used with 'cfmMetadataFlowAttributeType'. A ' CfmMetadataFlowAttrVal ' is always interpreted within the context of cfmMetadataFlowAttrEntry. Every usage of the ' CfmMetadataFlowAttrVal' textual convention is required to specify the ' CfmMetadataFlowAttributeType ' object. CfmMetadataFlowAttrVal object is deprecated as no longer needed. SIZE (1..255) · OCTET STRING

The attribute value associated with the attribute type of a given metadata flow. cfmMetadataFlowAttrValue object is superseded by cfmMetadataFlowAttribValue.

cfmMetadataFlowAllAttrTable

1.3.6.1.4.1.9.9.789.1.3

Index: cfmMetadataFlowId · cfmMetadataIpFixIeId · cfmMetadataFlowAllAttrInstanceId

A list of metadata flows and their additional attribute parameters.

cfmMetadataIpFixIeId

1.3.6.1.4.1.9.9.789.1.3.1.1

Unsigned32 (0..65535)

The attribute IPFix IE-ID associated with the attribute of a given metadata flow. Logically, IE-ID is only 15 bits, but in existing transports, such as the actual IPFIX transport protocol, and Cisco metadata signaling in RSVP, the IE-ID is encoded as a uint16. If the high-order bit is 0, then it indicates that VendorID is 0 (IANA = IETF standardized attributes).

cfmMetadataFlowAllAttrInstanceId

1.3.6.1.4.1.9.9.789.1.3.1.2

Unsigned32 (0..2147483647)

The attribute arbitrary instance, assigned locally by the implementation, associated with the attribute IPFix IE-ID of a given metadata flow.

cfmMetadataFlowAllAttrValue

1.3.6.1.4.1.9.9.789.1.3.1.3

OCTET STRING SIZE (0..255)

The attribute value associated with the attribute IPFix IE-ID of a given metadata flow.

cfmMetadataFlowAllAttrPen

1.3.6.1.4.1.9.9.789.1.3.1.4

Unsigned32 (0..2147483647)

Reference: http://www.iana.org/assignments/enterprise-numbers

The attribute IANA Private Enterprise Number associated with vendor for the attribute IPFix IE-ID of a given metadata flow.

↑ To TOC