cGgsnExtNoWaitSgsnLocalDelPDPs
1.3.6.1.4.1.9.9.647.1.1.1
Counter32 · PDP Context
This object indicates the total number of PDPs deleted in GGSN without waiting for a delete context response from the SGSN.
2011-03-18
This MIB module extends the CISCO-GGSN-MIB. This MIB module manages the Gateway GPRS Support Node (GGSN) devices. A GGSN device provides interworking with external packet-data network of a particular GPRS service provider. It provides a combination of IP routing and GPRS specific functionality to support mobile users. A PDP context on the GGSN device contains the mobile users session information, during an active session. This information is used by the device to control the session. An active PDP context is created when a mobile station's service request is authenticated and served by the GGSN device. Acronyms and terms: APN Access Point Name CDR Call Detail Record COA Change of Authorization CSG2 Content Services Gateway (2nd Generation) DT Direct Tunnel DFP Dynamic Feedback Protocol GGSN Gateway GPRS Support Node GPRS General Packet Radio Service GTP GPRS Tunneling Protocol IE Information Element IMEI International Mobile Equipment Identification IMSI International Mobile Subscriber Identification MCC Mobile Country Code MNC Mobile Network Code MS Mobile Station MSISDN Mobile Station ISDN number PDP Packet Data Protocol PDN Packet Data Network PPP Point-to-Point Protocol RNC Radio Network Controller SGSN Serving GPRS Support Node REFERENCE [1] GSM 03.60: Digital cellular telecommunications system (Phase 2+); General Packet Radio Service (GPRS); Service description; Stage 2. V7.1.0 [2] GSM 09.60: Digital cellular telecommunication system (Phase 2+); General Packet Radio Service (GPRS); GPRS Tunnelling Protocol (GTP) across Gn and Gp Interface. V7.3.0 [3] 3GPP; Technical Specification Group Services and System Aspects; QoS Concept and Architecture. 3G TS 23.107 v3.2.0. [4] 3GPP; Technical Specification Group Core Network; General Packet Radio Service(GPRS); GPRS Tunnelling Protocol (GTP) across Gn and Gp Interface (Release 7). 3G TS 29.060 v7.5.1. [5] 3GPP: Technical Specification Group Core Network; Policy control over Go interface (Release 5). 3GPP TS 29.207 V5.2.0 [6] 3GPP: Technical Specification Group Services and System Aspects; General Packet Radio Service (GPRS); Service Description (Release 7) 3GPP TS 23.060 V7.4.0 [7] 3GPP: Technical Specification Group Services and System Aspects; One Tunnel Functional description; (Release 7) 3GPP TR 23.809 V1.0.0
Download CISCO-GGSN-EXT-MIB.txt Open CISCO-GGSN-EXT-MIB.txt in a new tab
SCALARS (62) · TABLES (7) · TRAPS (1)
| Name | OID |
|---|---|
| cGgsnExtSubsTraceFailNotif | 1.3.6.1.4.1.9.9.647.0.1 |
END OF TOC
1.3.6.1.4.1.9.9.647.1.1.1
Counter32 · PDP Context
This object indicates the total number of PDPs deleted in GGSN without waiting for a delete context response from the SGSN.
1.3.6.1.4.1.9.9.647.1.1.2
Counter32 · PDP Context
This object indicates the total number of PDPs deleted in GGSN without sending a delete request to the SGSN.
1.3.6.1.4.1.9.9.647.1.1.3
Counter32 · messages
This object indicates the total number of GGSN initiated update PDP context requests sent to SGSN.
1.3.6.1.4.1.9.9.647.1.1.4
Counter32 · messages
This object represents the total number of update PDP context responses received from the SGSN for the GGSN initiated update requests.
1.3.6.1.4.1.9.9.647.1.1.5
Counter32 · messages
Reference: RFC 3576 - Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS)
This object indicates the total number of Change of Authorization (COA) messages received at GGSN.
1.3.6.1.4.1.9.9.647.1.1.6
Counter32 · messages
This object indicates the total number of COA messges dropped at GGSN.
1.3.6.1.4.1.9.9.647.1.1.7
Counter32 · messages
This object indicates the total number of COA initiated update PDP requests for QOS change sent from GGSN.
1.3.6.1.4.1.9.9.647.1.1.8
Counter32 · messages
Reference: 3GPP TS 23.060 V7.4.0 General Packet Radio Service (GPRS); Service description; Stage 2 (Release 7)
This object indicates the number of error indication messages sent from GGSN. Trigger condition: A error indication message will be sent from GGSN when a data packet is received for a non-existent PDP context.
1.3.6.1.4.1.9.9.647.1.1.9
Counter32 · messages
Reference: 3GPP TS 23.060 v7.4.0 General Packet Radio Service (GPRS); Service description; Stage 2 (Release 7)
This object indicates the number of error indication messages received on GGSN.
1.3.6.1.4.1.9.9.647.1.1.10
Counter32
This object indicates the number of times Direct tunnel is enabled for the PDP contexts in GGSN.
1.3.6.1.4.1.9.9.647.1.1.11
Counter32 · messages
Reference: 3GPP TR 23.809 v1.0.0: 3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; One Tunnel Functional description;(Release 7)
This object indicates the total number of error indications received for Direct Tunnel PDP contexts from the RNC.
1.3.6.1.4.1.9.9.647.1.1.12
Counter32 · PDP Context
This object indicates the total number of Direct tunnel PDP contexts deleted due to update response failure. Trigger condition: If the GGSN initiated update request is triggered by the error indication from RNC and the response is received with cause value other than 'request accepted' then the PDP is deleted locally in GGSN.
1.3.6.1.4.1.9.9.647.1.1.14
Counter32 · messages
This object indicates the total number of PDP non-existent messages sent from the GGSN.
1.3.6.1.4.1.9.9.647.1.1.19
Counter32
This object represents the total number of successfully created IPv4v6 PDP contexts. The counter is incremented whenever a IPv4v6 PDP contexts is created. This includes static, dynamic, IP, PPP PDPs.
1.3.6.1.4.1.9.9.647.1.1.20
Counter32
This object represents the total number of IPv4v6 PDP contexts deleted. The counter is incremented whenever a IPv4v6 PDP contexts is deleted. This includes static, dynamic, IP, PPP PDPs.
1.3.6.1.4.1.9.9.647.1.1.21.1
Counter32
This object represents the total number of sessions for which trace has been activated.
1.3.6.1.4.1.9.9.647.1.1.21.2
Counter32
This object represents the total number of sessions initiated trace with signaling activations.
1.3.6.1.4.1.9.9.647.1.1.21.3
Counter32
This object represents the total number of sessions initiated trace with management interface activations.
1.3.6.1.4.1.9.9.647.1.1.21.4
Counter32
This object represents the total number of traces initiated for new sessions.
1.3.6.1.4.1.9.9.647.1.1.21.5
Counter32
This object represents the total number of traces initiated for existing sessions.
1.3.6.1.4.1.9.9.647.1.1.21.6
Counter32
This object represents the total number of sessions that failed to initiate trace by signaling activations.
1.3.6.1.4.1.9.9.647.1.1.21.7
Counter32
This object represents the total number of sessions that failed to initiate trace by management interface activations.
1.3.6.1.4.1.9.9.647.1.1.21.8
Counter32
This object represents the total number of sessions that deactivated traces.
1.3.6.1.4.1.9.9.647.1.1.21.9
Counter32
This object represents the total number of signaling initiated deactivation of traces.
1.3.6.1.4.1.9.9.647.1.1.21.10
Counter32
This object represents the total number of management initiated deactivation of traces.
1.3.6.1.4.1.9.9.647.1.1.21.11
Counter32
This object represents the total number of sessions that failed to deactivate trace by signaling initiated deactivations.
1.3.6.1.4.1.9.9.647.1.1.21.12
Counter32
This object represents the total number of sessions that failed to deactivate trace by management initiated deactivations.
1.3.6.1.4.1.9.9.647.1.1.22.1
Counter32
This object represents the total number of XML traced files.
1.3.6.1.4.1.9.9.647.1.1.22.2
Counter32
This object represents the total number of XML trace notification failed files.
1.3.6.1.4.1.9.9.647.1.1.22.3
Counter32
This object represents the total number of successful XML file transfers.
1.3.6.1.4.1.9.9.647.1.1.22.4
Counter32
This object represents the number of XML file transferred to the primary trace collection entity.
1.3.6.1.4.1.9.9.647.1.1.22.5
Counter32
This object represents the number of XML file transferred to the secondary trace collection entity.
1.3.6.1.4.1.9.9.647.1.1.22.6
Counter32
This object represents the total number of failed XML file transfers.
1.3.6.1.4.1.9.9.647.1.1.22.7
Counter32
This object represents the total number of failed XML file transfers to the primary trace collection entity.
1.3.6.1.4.1.9.9.647.1.1.22.8
Counter32
This object represents the total number of XML file transfer retries made to the trace collection entity.
1.3.6.1.4.1.9.9.647.1.1.22.9
Counter32
This object represents the number of failed XML file transfers to the secondary trace collection entity.
1.3.6.1.4.1.9.9.647.1.1.23
Counter32
This object represents the total number of response messages sent with the cause code of conditional IE missing.
1.3.6.1.4.1.9.9.647.1.1.24
Counter32
This object represents the total number of response messages sent with cause code of invalid reply from peers.
1.3.6.1.4.1.9.9.647.1.2.1
Unsigned32 (0 | 15..71582) · minutes
This object specifies the global periodic accounting timer interval value. When this object is set to a value, 'interim' type accounting records will be sent at the specified interval for the PDP contexts.
1.3.6.1.4.1.9.9.647.1.2.2
Unsigned32 (0 | 10..75)
This object specifies the value of the CPU load to be included in the DFP weight calculation.
1.3.6.1.4.1.9.9.647.1.2.3
Unsigned32 (0 | 10..75)
This object specifies the value of the Memory Load to be included in the DFP weight calculation.
1.3.6.1.4.1.9.9.647.1.2.4
Unsigned32 (0 | 1..100)
This object specifies the number of throughput history entries to be maintained in the cGgsnExtHistThruputStatsTable.
1.3.6.1.4.1.9.9.647.1.2.5
TimeIntervalMinA period of time, measured in units of 1 minute. (0..65535) · Unsigned32 · minutes
This object specifies the interval at which the call rate statistics needs to be collected in GGSN. When this object is set to a valid value, the call rate statistics are collected for the interval and updated in cGgsnExtCallRateStatsTable every time the interval expires. When the object is set to 0, the call rate statistics will not be collected.
1.3.6.1.4.1.9.9.647.1.2.6
Unsigned32 (0..100)
This object specifies the number of callrate history be maintained in the cGgsnExtHistCallRateStatsTable.
1.3.6.1.4.1.9.9.647.1.2.7
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object specifies whether GGSN can function as a standalone entity for prepaid quota management and enforcement. If the value of this object is 'true' then GGSN can function as a stand alone entity for prepaid quota management and enforcement. If the value of this object is set to 'false' then GGSN will depend on CSG2 for prepaid quota management and enforcement.
1.3.6.1.4.1.9.9.647.1.2.8
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object is used to enable redundancy for GGSN.
1.3.6.1.4.1.9.9.647.1.2.9
Unsigned32 (1..200)
This object specifies sync window size of the local sequence number. This object can assign value only when redundancy(cGgsnExtRedundancyEnabled) is enabled.
1.3.6.1.4.1.9.9.647.1.2.10
Unsigned32 (1..20)
This object specifies sync window size of the CDR record sequence number. This object can assign value only when redundancy(cGgsnExtRedundancyEnabled)is enabled.
1.3.6.1.4.1.9.9.647.1.2.11
Unsigned32 (5..65535)
This object specifies sync window size of the GTP packet sequence number. This object can assign value only when redundancy(cGgsnExtRedundancyEnabled)is enabled.
1.3.6.1.4.1.9.9.647.1.2.12
Unsigned32 (2000..10000) · Bytes
This object defines buffer limit when tracing is active for a subscriber.
1.3.6.1.4.1.9.9.647.1.2.13
Unsigned32 (60..86400) · seconds
This object defines the trace XML file transfer interval when tracing is active for a subscriber.
1.3.6.1.4.1.9.9.647.1.3.1
Gauge32
This object represents the number of device specific interface constructs created for association with PPP-Regen PDP contexts.
1.3.6.1.4.1.9.9.647.1.3.2
Gauge32 · PDP Context
This object represents the number of active PDP contexts with Direct tunnel enabled.
1.3.6.1.4.1.9.9.647.1.3.3
Gauge32
This object indicates the current number of Mobile Stations with active PDP contexts.
1.3.6.1.4.1.9.9.647.1.3.4
Gauge32 · PDP Context
This object represents the current number of active GTPv0 IPv4v6 PDP contexts.
1.3.6.1.4.1.9.9.647.1.3.5
Gauge32 · PDP Context
This object represents the current number of active GTPv1 IPv4v6 PDP contexts.
1.3.6.1.4.1.9.9.647.1.3.6
Gauge32
This object represents the current number of mobile stations with active IPv4v6 PDP contexts.
1.3.6.1.4.1.9.9.647.1.4.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object represents whether cGgsnExtSubsTraceFailNotif is enabled or not. true - indicates that the notification is enabled. false - indicates that the notification is disabled.
1.3.6.1.4.1.9.9.647.1.5.1
Unsigned32
MCC value of the subscriber, for which trace activation failure has occured.
1.3.6.1.4.1.9.9.647.1.5.2
Unsigned32
MNC value of the subscriber, for which trace activation failure has occured.
1.3.6.1.4.1.9.9.647.1.5.3
Unsigned32
Trace Identifier of the subscriber, for which trace activation failure has occured.
1.3.6.1.4.1.9.9.647.1.5.4
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
Reason for the trace activation failure.
1.3.6.1.4.1.9.9.647.1.1.13
Index: cGgsnExtThruputInterval
This table contains the global GTP throughput statistics on this GGSN for a configurable duration set in cGgsnThruputIntervalOne and cGgsnThruputIntervalTwo. Once the cGgsnThruputIntervalOne is set to some valid value, the data throughput collections gets started. The data throughput collection is updated periodically for each expiry of configured throughput interval to the corresponding objects in the cGgsnThruputStatsTable. cGgsnThruputIntervalTwo is just an option for a second throughput collection for a different throughput interval time.
1.3.6.1.4.1.9.9.647.1.1.13.1.1
Integer32 (1..65535) · minutes
This object indicates the time interval at which the statistics are sampled. The objects cGgsnThruputIntervalOne and cGgsnThruputIntervalTwo in the CISCO-GGSN-MIB represent the configuration values of the intervals.
1.3.6.1.4.1.9.9.647.1.1.13.1.2
Integer32 (0..65535) · minutes
This object indicates the delta value between the time when this data is collected and the time it is been retrieved. It means the time elapsed after the previous collection/updation of the data.
1.3.6.1.4.1.9.9.647.1.1.13.1.3
CounterBasedGauge64The CounterBasedGauge64 type represents a non-negative integer, which may increase or decrease, but shall never exceed a maximum value, nor fall below a minimum value. The maximum value can not be greater than 2^64-1 (18446744073709551615 decimal), and the minimum value can not be smaller than 0. The value of a CounterBasedGauge64 has its maximum value whenever the information being modeled is greater than or equal to its maximum value, and has its minimum value whenever the information being modeled is smaller than or equal to its minimum value. If the information being modeled subsequently decreases below (increases above) the maximum (minimum) value, the CounterBasedGauge64 also decreases (increases). Note that this TC is not strictly supported in SMIv2, because the 'always increasing' and 'counter wrap' semantics associated with the Counter64 base type are not preserved. It is possible that management applications which rely solely upon the (Counter64) ASN.1 tag to determine object semantics will mistakenly operate upon objects of this type as they would for Counter64 objects. This textual convention represents a limited and short-term solution, and may be deprecated as a long term solution is defined and deployed to replace it. (0..18446744073709551615) · Counter64 · bytes
This object indicates the total number of upstream traffic bytes sent in the last sampling period specified by cGgsnExtThruputInterval.
1.3.6.1.4.1.9.9.647.1.1.13.1.4
CounterBasedGauge64The CounterBasedGauge64 type represents a non-negative integer, which may increase or decrease, but shall never exceed a maximum value, nor fall below a minimum value. The maximum value can not be greater than 2^64-1 (18446744073709551615 decimal), and the minimum value can not be smaller than 0. The value of a CounterBasedGauge64 has its maximum value whenever the information being modeled is greater than or equal to its maximum value, and has its minimum value whenever the information being modeled is smaller than or equal to its minimum value. If the information being modeled subsequently decreases below (increases above) the maximum (minimum) value, the CounterBasedGauge64 also decreases (increases). Note that this TC is not strictly supported in SMIv2, because the 'always increasing' and 'counter wrap' semantics associated with the Counter64 base type are not preserved. It is possible that management applications which rely solely upon the (Counter64) ASN.1 tag to determine object semantics will mistakenly operate upon objects of this type as they would for Counter64 objects. This textual convention represents a limited and short-term solution, and may be deprecated as a long term solution is defined and deployed to replace it. (0..18446744073709551615) · Counter64 · bytes
This object indicates the total number of downstream traffic bytes sent in the last sampling period specified by cGgsnExtThruputInterval.
1.3.6.1.4.1.9.9.647.1.1.13.1.5
Gauge32 · packets
This object indicates the number of upstream packets sent in the last sampling period specified by cGgsnExtThruputInterval.
1.3.6.1.4.1.9.9.647.1.1.13.1.6
Gauge32 · packets
This object indicates the number of downstream packets sent in the last sampling period specified by cGgsnExtThruputInterval.
1.3.6.1.4.1.9.9.647.1.1.15
Index: cGgsnExtCallRateStatsInterval
This table contains the global call rate statistics on this GGSN for a cindicatesonfigurable duration set in cGgsnExtCallRateInterval. When the cGgsnExtCallRateInterval is set to some valid value, the call rate data collections gets started. The call rate data is updated periodically for each expiry of the configured call rate interval to the corresponding objects in the cGgsnExtCallRateStatsTable.
1.3.6.1.4.1.9.9.647.1.1.15.1.1
Unsigned32 (1..65535) · minutes
This object indicates the time interval at which the statistics are sampled. The object cGgsnExtCallRateInterval represents the configuration value of the interval.
1.3.6.1.4.1.9.9.647.1.1.15.1.2
Unsigned32 (0..65535) · minutes
This object indicates the time elapsed (in minutes) from the time when this data is collected and the time it is been retrieved.
1.3.6.1.4.1.9.9.647.1.1.15.1.3
Gauge32 · PDP Context
This object indicates the number of PDP contexts created in the last sampling period specified by cGgsnExtCallRateInterval.
1.3.6.1.4.1.9.9.647.1.1.15.1.4
Gauge32 · PDP Context
This object indicates the number of PDP contexts deleted in the last sampling period specified by cGgsnExtCallRateInterval.
1.3.6.1.4.1.9.9.647.1.1.16
Index: cGgsnExtHistCallRateIndex
This table contains the historical call rate statistics on this GGSN for a configurable duration set in cGgsnExtCallRateInterval.
1.3.6.1.4.1.9.9.647.1.1.16.1.1
Unsigned32 (1..100)
This object indicates an arbitrary index number which uniquely identifies a history call rate entry in this table.
1.3.6.1.4.1.9.9.647.1.1.16.1.2
TimeIntervalMinA period of time, measured in units of 1 minute. (1..65535) · Unsigned32 · minutes
This object indicates the time interval for which the statistics are sampled.
1.3.6.1.4.1.9.9.647.1.1.16.1.3
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks · minutes
This object represents the time at which this data was collected.
1.3.6.1.4.1.9.9.647.1.1.16.1.4
Counter32 · PDP Context
This object indicates the historical number of PDP contexts created in a specific sampling period specified by cGgsnExtCallRateInterval.
1.3.6.1.4.1.9.9.647.1.1.16.1.5
Counter32 · PDP Context
This object indicates the historical number of PDP contexts deleted in a specific sampling period specified by cGgsnExtCallRateInterval.
1.3.6.1.4.1.9.9.647.1.1.17
Index: cGgsnExtHistThruputIndex · cGgsnExtHistThruputInterval
This table contains the historical GTP throughput statistics on this GGSN for a configurable duration set in cGgsnThruputIntervalOne and cGgsnThruputIntervalTwo.
1.3.6.1.4.1.9.9.647.1.1.17.1.1
Unsigned32 (1..100)
This object indicates an arbitray index number which uniquely identify a entry in this table.
1.3.6.1.4.1.9.9.647.1.1.17.1.2
TimeIntervalMinA period of time, measured in units of 1 minute. (1..65535) · Unsigned32 · minutes
This object indicates the time interval at which the statistics are sampled. The objects cGgsnThruputIntervalOne and cGgsnThruputIntervalTwo in the CISCO-GGSN-MIB represent the configuration values of the intervals.
1.3.6.1.4.1.9.9.647.1.1.17.1.3
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks · minutes
This object indicates the time at which this data was collected.
1.3.6.1.4.1.9.9.647.1.1.17.1.4
Counter64 (0..18446744073709551615) · bytes
This object indicates the historical number of upstream traffic bytes sent from GGSN to PDN in a specific sampling period specified by cGgsnExtThruputInterval.
1.3.6.1.4.1.9.9.647.1.1.17.1.5
Counter64 (0..18446744073709551615) · bytes
This object indicates the historical number of downstream traffic bytes sent from PDN to GGSN in a specific sampling period specified by cGgsnExtThruputInterval.
1.3.6.1.4.1.9.9.647.1.1.17.1.6
Counter32 · packets
This object indicates the historical number of upstream packets sent in a specific sampling period specified by cGgsnExtThruputInterval.
1.3.6.1.4.1.9.9.647.1.1.17.1.7
Counter32 · packets
This object represents the historical number of downstream packets sent in a specific sampling period specified by cGgsnExtThruputInterval.
1.3.6.1.4.1.9.9.647.1.1.18
Index: cGgsnExtSubscriberMsisdn
This table contains the details of the subscribers connected to the GGSN.
1.3.6.1.4.1.9.9.647.1.1.18.1.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..20) · OCTET STRING · hint 255t
This object indicates a human readable string representing the Mobile Subscriber ISDN (MSISDN) value of the subscriber.
1.3.6.1.4.1.9.9.647.1.1.18.1.2
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..18) · OCTET STRING · hint 255t
This object indicates a human readable string representing the Tunnel identifier of the Subscriber/PDP context in GGSN.
1.3.6.1.4.1.9.9.647.1.1.18.1.3
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object indicates the address type of the object cGgsnExtSubscriberMSAddr.
1.3.6.1.4.1.9.9.647.1.1.18.1.4
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This object indicates the inet address of the Subscriber.
1.3.6.1.4.1.9.9.647.1.1.18.1.5
INTEGER1 = pdpAddrSrcNone2 = pdpAddrSrcStatic3 = pdpAddrSrcLocalPool4 = pdpAddrSrcRadius5 = pdpAddrSrcDhcp6 = pdpAddrSrcIpcp · Integer32
This object indicates the source from which the IP addr for the subscriber is assigned. pdpAddrSrcNone - None pdpAddrSrcStatic - static address specified by the MS pdpAddrSrcLocalPool - from the local pool pdpAddrSrcRadius - from Radius server pdpAddrSrcDhcp - from DHCP server pdpAddrSrcIpcp - from Ipcp
1.3.6.1.4.1.9.9.647.1.1.18.1.6
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object indicates the address type of the object cGgsnExtSubscriberSGSNAddr.
1.3.6.1.4.1.9.9.647.1.1.18.1.7
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This object indicates the Inet address of the subscriber's SGSN.
1.3.6.1.4.1.9.9.647.1.1.18.1.8
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..100) · OCTET STRING · hint 255t
This object indicates a human readable string representing the access point name in GGSN to which the subscriber is connected.
1.3.6.1.4.1.9.9.647.1.2.14
Index: cGgsnExtTraceProfile
This table contains a list of subscriber trace profiles configured on this gateway. The SNMP entity adds a conceptual row(s) to this table when the user configures a trace profile. The SNMP entity deletes a conceptual row(s) from this table when the user removes the trace profile. The SNMP entity modifies the conceptual row when the user changes any trace parameters of the profile.
1.3.6.1.4.1.9.9.647.1.2.14.1.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..40) · OCTET STRING · hint 255t
This object represents the subscriber trace policy name and it uniquely identifies a subscriber trace policy.
1.3.6.1.4.1.9.9.647.1.2.14.1.2
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
This object represents the primary URL to which the subscriber trace information needs to be transferred when the trace activated user anchors to the gateway.
1.3.6.1.4.1.9.9.647.1.2.14.1.3
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
This object represents the secondary URL to which the subscriber trace information needs to be transferred when the primary URL is unreachable and the trace activated user anchors to the gateway.
1.3.6.1.4.1.9.9.647.1.2.14.1.4
Unsigned32 (0..10)
This object represents the number of times the gateway will retry to transfer the trace information in case of failure.
1.3.6.1.4.1.9.9.647.1.2.14.1.5
Unsigned32 (10..180) · seconds
This object represents the time interval between ever retry to transfer the trace information in case of failure.
1.3.6.1.4.1.9.9.647.1.2.14.1.6
RowStatus1 = active2 = notInService3 = notReady4 = createAndGo5 = createAndWait6 = destroyThe RowStatus textual convention is used to manage the creation and deletion of conceptual rows, and is used as the value of the SYNTAX clause for the status column of a conceptual row (as described in Section 7.7.1 of [2].) The status column has six defined values: - `active', which indicates that the conceptual row is available for use by the managed device; - `notInService', which indicates that the conceptual row exists in the agent, but is unavailable for use by the managed device (see NOTE below); 'notInService' has no implication regarding the internal consistency of the row, availability of resources, or consistency with the current state of the managed device; - `notReady', which indicates that the conceptual row exists in the agent, but is missing information necessary in order to be available for use by the managed device (i.e., one or more required columns in the conceptual row have not been instanciated); - `createAndGo', which is supplied by a management station wishing to create a new instance of a conceptual row and to have its status automatically set to active, making it available for use by the managed device; - `createAndWait', which is supplied by a management station wishing to create a new instance of a conceptual row (but not make it available for use by the managed device); and, - `destroy', which is supplied by a management station wishing to delete all of the instances associated with an existing conceptual row. Whereas five of the six values (all except `notReady') may be specified in a management protocol set operation, only three values will be returned in response to a management protocol retrieval operation: `notReady', `notInService' or `active'. That is, when queried, an existing conceptual row has only three states: it is either available for use by the managed device (the status column has value `active'); it is not available for use by the managed device, though the agent has sufficient information to attempt to make it so (the status column has value `notInService'); or, it is not available for use by the managed device, and an attempt to make it so would fail because the agent has insufficient information (the state column has value `notReady'). NOTE WELL This textual convention may be used for a MIB table, irrespective of whether the values of that table's conceptual rows are able to be modified while it is active, or whether its conceptual rows must be taken out of service in order to be modified. That is, it is the responsibility of the DESCRIPTION clause of the status column to specify whether the status column must not be `active' in order for the value of some other column of the same conceptual row to be modified. If such a specification is made, affected columns may be changed by an SNMP set PDU if the RowStatus would not be equal to `active' either immediately before or after processing the PDU. In other words, if the PDU also contained a varbind that would change the RowStatus value, the column in question may be changed if the RowStatus was not equal to `active' as the PDU was received, or if the varbind sets the status to a value other than 'active'. Also note that whenever any elements of a row exist, the RowStatus column must also exist. To summarize the effect of having a conceptual row with a status column having a SYNTAX clause value of RowStatus, consider the following state diagram: STATE +--------------+-----------+-------------+------------- | A | B | C | D | |status col.|status column| |status column | is | is |status column ACTION |does not exist| notReady | notInService| is active --------------+--------------+-----------+-------------+------------- set status |noError ->D|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndGo |inconsistent- | | | | Value| | | --------------+--------------+-----------+-------------+------------- set status |noError see 1|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndWait |wrongValue | | | --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError column to | Value| entValue| | active | | | | | | or | | | | | | | |see 2 ->D|see 8 ->D| ->D --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError ->C column to | Value| entValue| | notInService | | | | | | or | | or | | | | | |see 3 ->C| ->C|see 6 --------------+--------------+-----------+-------------+------------- set status |noError |noError |noError |noError ->A column to | | | | or destroy | ->A| ->A| ->A|see 7 --------------+--------------+-----------+-------------+------------- set any other |see 4 |noError |noError |see 5 column to some| | | | value | | see 1| ->C| ->D --------------+--------------+-----------+-------------+------------- (1) goto B or C, depending on information available to the agent. (2) if other variable bindings included in the same PDU, provide values for all columns which are missing but required, and all columns have acceptable values, then return noError and goto D. (3) if other variable bindings included in the same PDU, provide legal values for all columns which are missing but required, then return noError and goto C. (4) at the discretion of the agent, the return value may be either: inconsistentName: because the agent does not choose to create such an instance when the corresponding RowStatus instance does not exist, or inconsistentValue: if the supplied value is inconsistent with the state of some other MIB object's value, or noError: because the agent chooses to create the instance. If noError is returned, then the instance of the status column must also be created, and the new state is B or C, depending on the information available to the agent. If inconsistentName or inconsistentValue is returned, the row remains in state A. (5) depending on the MIB definition for the column/table, either noError or inconsistentValue may be returned. (6) the return value can indicate one of the following errors: wrongValue: because the agent does not support notInService (e.g., an agent which does not support createAndWait), or inconsistentValue: because the agent is unable to take the row out of service at this time, perhaps because it is in use and cannot be de-activated. (7) the return value can indicate the following error: inconsistentValue: because the agent is unable to remove the row at this time, perhaps because it is in use and cannot be de-activated. (8) the transition to D can fail, e.g., if the values of the conceptual row are inconsistent, then the error code would be inconsistentValue. NOTE: Other processing of (this and other varbinds of) the set request may result in a response other than noError being returned, e.g., wrongValue, noCreation, etc. Conceptual Row Creation There are four potential interactions when creating a conceptual row: selecting an instance-identifier which is not in use; creating the conceptual row; initializing any objects for which the agent does not supply a default; and, making the conceptual row available for use by the managed device. Interaction 1: Selecting an Instance-Identifier The algorithm used to select an instance-identifier varies for each conceptual row. In some cases, the instance- identifier is semantically significant, e.g., the destination address of a route, and a management station selects the instance-identifier according to the semantics. In other cases, the instance-identifier is used solely to distinguish conceptual rows, and a management station without specific knowledge of the conceptual row might examine the instances present in order to determine an unused instance-identifier. (This approach may be used, but it is often highly sub-optimal; however, it is also a questionable practice for a naive management station to attempt conceptual row creation.) Alternately, the MIB module which defines the conceptual row might provide one or more objects which provide assistance in determining an unused instance-identifier. For example, if the conceptual row is indexed by an integer-value, then an object having an integer-valued SYNTAX clause might be defined for such a purpose, allowing a management station to issue a management protocol retrieval operation. In order to avoid unnecessary collisions between competing management stations, `adjacent' retrievals of this object should be different. Finally, the management station could select a pseudo-random number to use as the index. In the event that this index was already in use and an inconsistentValue was returned in response to the management protocol set operation, the management station should simply select a new pseudo-random number and retry the operation. A MIB designer should choose between the two latter algorithms based on the size of the table (and therefore the efficiency of each algorithm). For tables in which a large number of entries are expected, it is recommended that a MIB object be defined that returns an acceptable index for creation. For tables with small numbers of entries, it is recommended that the latter pseudo-random index mechanism be used. Interaction 2: Creating the Conceptual Row Once an unused instance-identifier has been selected, the management station determines if it wishes to create and activate the conceptual row in one transaction or in a negotiated set of interactions. Interaction 2a: Creating and Activating the Conceptual Row The management station must first determine the column requirements, i.e., it must determine those columns for which it must or must not provide values. Depending on the complexity of the table and the management station's knowledge of the agent's capabilities, this determination can be made locally by the management station. Alternately, the management station issues a management protocol get operation to examine all columns in the conceptual row that it wishes to create. In response, for each column, there are three possible outcomes: - a value is returned, indicating that some other management station has already created this conceptual row. We return to interaction 1. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it should supply a value for this column when the conceptual row is to be created. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. Once the column requirements have been determined, a management protocol set operation is accordingly issued. This operation also sets the new instance of the status column to `createAndGo'. When the agent processes the set operation, it verifies that it has sufficient information to make the conceptual row available for use by the managed device. The information available to the agent is provided by two sources: the management protocol set operation which creates the conceptual row, and, implementation-specific defaults supplied by the agent (note that an agent must provide implementation-specific defaults for at least those objects which it implements as read-only). If there is sufficient information available, then the conceptual row is created, a `noError' response is returned, the status column is set to `active', and no further interactions are necessary (i.e., interactions 3 and 4 are skipped). If there is insufficient information, then the conceptual row is not created, and the set operation fails with an error of `inconsistentValue'. On this error, the management station can issue a management protocol retrieval operation to determine if this was because it failed to specify a value for a required column, or, because the selected instance of the status column already existed. In the latter case, we return to interaction 1. In the former case, the management station can re-issue the set operation with the additional information, or begin interaction 2 again using `createAndWait' in order to negotiate creation of the conceptual row. NOTE WELL Regardless of the method used to determine the column requirements, it is possible that the management station might deem a column necessary when, in fact, the agent will not allow that particular columnar instance to be created or written. In this case, the management protocol set operation will fail with an error such as `noCreation' or `notWritable'. In this case, the management station decides whether it needs to be able to set a value for that particular columnar instance. If not, the management station re-issues the management protocol set operation, but without setting a value for that particular columnar instance; otherwise, the management station aborts the row creation algorithm. Interaction 2b: Negotiating the Creation of the Conceptual Row The management station issues a management protocol set operation which sets the desired instance of the status column to `createAndWait'. If the agent is unwilling to process a request of this sort, the set operation fails with an error of `wrongValue'. (As a consequence, such an agent must be prepared to accept a single management protocol set operation, i.e., interaction 2a above, containing all of the columns indicated by its column requirements.) Otherwise, the conceptual row is created, a `noError' response is returned, and the status column is immediately set to either `notInService' or `notReady', depending on whether it has sufficient information to (attempt to) make the conceptual row available for use by the managed device. If there is sufficient information available, then the status column is set to `notInService'; otherwise, if there is insufficient information, then the status column is set to `notReady'. Regardless, we proceed to interaction 3. Interaction 3: Initializing non-defaulted Objects The management station must now determine the column requirements. It issues a management protocol get operation to examine all columns in the created conceptual row. In the response, for each column, there are three possible outcomes: - a value is returned, indicating that the agent implements the object-type associated with this column and had sufficient information to provide a value. For those columns to which the agent provides read-create access (and for which the agent allows their values to be changed after their creation), a value return tells the management station that it may issue additional management protocol set operations, if it desires, in order to change the value associated with this column. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. However, the agent does not have sufficient information to provide a value, and until a value is provided, the conceptual row may not be made available for use by the managed device. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it must issue additional management protocol set operations, in order to provide a value associated with this column. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. If the value associated with the status column is `notReady', then the management station must first deal with all `noSuchInstance' columns, if any. Having done so, the value of the status column becomes `notInService', and we proceed to interaction 4. Interaction 4: Making the Conceptual Row Available Once the management station is satisfied with the values associated with the columns of the conceptual row, it issues a management protocol set operation to set the status column to `active'. If the agent has sufficient information to make the conceptual row available for use by the managed device, the management protocol set operation succeeds (a `noError' response is returned). Otherwise, the management protocol set operation fails with an error of `inconsistentValue'. NOTE WELL A conceptual row having a status column with value `notInService' or `notReady' is unavailable to the managed device. As such, it is possible for the managed device to create its own instances during the time between the management protocol set operation which sets the status column to `createAndWait' and the management protocol set operation which sets the status column to `active'. In this case, when the management protocol set operation is issued to set the status column to `active', the values held in the agent supersede those used by the managed device. If the management station is prevented from setting the status column to `active' (e.g., due to management station or network failure) the conceptual row will be left in the `notInService' or `notReady' state, consuming resources indefinitely. The agent must detect conceptual rows that have been in either state for an abnormally long period of time and remove them. It is the responsibility of the DESCRIPTION clause of the status column to indicate what an abnormally long period of time would be. This period of time should be long enough to allow for human response time (including `think time') between the creation of the conceptual row and the setting of the status to `active'. In the absence of such information in the DESCRIPTION clause, it is suggested that this period be approximately 5 minutes in length. This removal action applies not only to newly-created rows, but also to previously active rows which are set to, and left in, the notInService state for a prolonged period exceeding that which is considered normal for such a conceptual row. Conceptual Row Suspension When a conceptual row is `active', the management station may issue a management protocol set operation which sets the instance of the status column to `notInService'. If the agent is unwilling to do so, the set operation fails with an error of `wrongValue' or `inconsistentValue'. Otherwise, the conceptual row is taken out of service, and a `noError' response is returned. It is the responsibility of the DESCRIPTION clause of the status column to indicate under what circumstances the status column should be taken out of service (e.g., in order for the value of some other column of the same conceptual row to be modified). Conceptual Row Deletion For deletion of conceptual rows, a management protocol set operation is issued which sets the instance of the status column to `destroy'. This request may be made regardless of the current value of the status column (e.g., it is possible to delete conceptual rows which are either `notReady', `notInService' or `active'.) If the operation succeeds, then all instances associated with the conceptual row are immediately removed. · Integer32
This object is used to create a new row or delete an existing row in this table. To create a row, set this object to 'createAndGo'. To delete a row, set this object to 'destroy'.
1.3.6.1.4.1.9.9.647.1.3.7
Index: cGgsnExtTraceStatusImsi
This table contains a list of subscribers and their tracing status on this gateway. The SNMP entity adds a conceptual row(s) to this table when a trace is begun for a subscriber. The SNMP entity deletes a conceptual row(s) from this table when a trace is stopped for a subscriber.
1.3.6.1.4.1.9.9.647.1.3.7.1.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..8) · OCTET STRING · hint 255t
This object represents the IMSI of the subscriber who is being traced currently on this gateway.
1.3.6.1.4.1.9.9.647.1.3.7.1.2
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..8) · OCTET STRING · hint 255t
This object represents the IMEI of the subscriber who is being traced currently on this gateway.
1.3.6.1.4.1.9.9.647.1.3.7.1.3
INTEGER1 = signaling2 = management · Integer32
This object indicates the source through which an equipment trace has activated on the gateway for a subscriber. 'signaling' - tracing has been activated by gtp signaling messages. 'management' - tracing has been activated by the user directly on the gateway using a gateway management tool.
1.3.6.1.4.1.9.9.647.1.3.7.1.4
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..16) · OCTET STRING · hint 255t
This object represents the trace reference of the subscriber who is being traced currently on this gateway.
1.3.6.1.4.1.9.9.647.0.1
This notification is triggered on failure of a subscriber trace activation.
1.3.6.1.4.1.9.9.647.1.5.1
Unsigned32
MCC value of the subscriber, for which trace activation failure has occured.
1.3.6.1.4.1.9.9.647.1.5.2
Unsigned32
MNC value of the subscriber, for which trace activation failure has occured.
1.3.6.1.4.1.9.9.647.1.5.3
Unsigned32
Trace Identifier of the subscriber, for which trace activation failure has occured.
1.3.6.1.4.1.9.9.647.1.5.4
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
Reason for the trace activation failure.