EZ5 MIB Catalog

CISCO-IETF-DHCP-SERVER-MIB

2007-03-27

The MIB module for entities implementing the server side of the Bootstrap Protocol (BOOTP) and the Dynamic Host Configuration protocol (DHCP) for Internet Protocol version 4(IPv4). This MIB does not include support for Dynamic DNS (DDNS) updating nor for the DHCP Failover Protocol.

Download CISCO-IETF-DHCP-SERVER-MIB.txt Open CISCO-IETF-DHCP-SERVER-MIB.txt in a new tab

SCALARS (40) · TABLES (4) · TRAPS (5)

Scalars (40)

NameOID
cDhcpv4SrvSystemDescr1.3.6.1.4.1.9.10.102.1.1.1
cDhcpv4SrvSystemObjectID1.3.6.1.4.1.9.10.102.1.1.2
cBootpCountRequests1.3.6.1.4.1.9.10.102.1.2.1
cBootpCountInvalids1.3.6.1.4.1.9.10.102.1.2.2
cBootpCountReplies1.3.6.1.4.1.9.10.102.1.2.3
cBootpCountDropUnknownClients1.3.6.1.4.1.9.10.102.1.2.4
cBootpCountDropNotServingSubnet1.3.6.1.4.1.9.10.102.1.2.5
cDhcpv4CountDiscovers1.3.6.1.4.1.9.10.102.1.3.1
cDhcpv4CountOffers1.3.6.1.4.1.9.10.102.1.3.2
cDhcpv4CountRequests1.3.6.1.4.1.9.10.102.1.3.3
cDhcpv4CountDeclines1.3.6.1.4.1.9.10.102.1.3.4
cDhcpv4CountAcks1.3.6.1.4.1.9.10.102.1.3.5
cDhcpv4CountNaks1.3.6.1.4.1.9.10.102.1.3.6
cDhcpv4CountReleases1.3.6.1.4.1.9.10.102.1.3.7
cDhcpv4CountInforms1.3.6.1.4.1.9.10.102.1.3.8
cDhcpv4CountInvalids1.3.6.1.4.1.9.10.102.1.3.10
cDhcpv4CountDropUnknownClient1.3.6.1.4.1.9.10.102.1.3.11
cDhcpv4CountDropNotServingSubnet1.3.6.1.4.1.9.10.102.1.3.12
cDhcpv4ServerNotifyDuplicateIpAddr1.3.6.1.4.1.9.10.102.1.7.1
cDhcpv4ServerNotifyDuplicateMac1.3.6.1.4.1.9.10.102.1.7.2
cDhcpv4ServerNotifyClientOrServerDetected1.3.6.1.4.1.9.10.102.1.7.3
cDhcpv4ServerNotifyServerStart1.3.6.1.4.1.9.10.102.1.7.4
cDhcpv4ServerNotifyServerStop1.3.6.1.4.1.9.10.102.1.7.5
cBootpHCCountRequests1.3.6.1.4.1.9.10.102.1.8.1
cBootpHCCountInvalids1.3.6.1.4.1.9.10.102.1.8.2
cBootpHCCountReplies1.3.6.1.4.1.9.10.102.1.8.3
cBootpHCCountDropUnknownClients1.3.6.1.4.1.9.10.102.1.8.4
cBootpHCCountDropNotServingSubnet1.3.6.1.4.1.9.10.102.1.8.5
cDhcpv4HCCountDiscovers1.3.6.1.4.1.9.10.102.1.9.1
cDhcpv4HCCountOffers1.3.6.1.4.1.9.10.102.1.9.2
cDhcpv4HCCountRequests1.3.6.1.4.1.9.10.102.1.9.3
cDhcpv4HCCountDeclines1.3.6.1.4.1.9.10.102.1.9.4
cDhcpv4HCCountAcks1.3.6.1.4.1.9.10.102.1.9.5
cDhcpv4HCCountNaks1.3.6.1.4.1.9.10.102.1.9.6
cDhcpv4HCCountReleases1.3.6.1.4.1.9.10.102.1.9.7
cDhcpv4HCCountInforms1.3.6.1.4.1.9.10.102.1.9.8
cDhcpv4HCCountForcedRenews1.3.6.1.4.1.9.10.102.1.9.9
cDhcpv4HCCountInvalids1.3.6.1.4.1.9.10.102.1.9.10
cDhcpv4HCCountDropUnknownClient1.3.6.1.4.1.9.10.102.1.9.11
cDhcpv4HCCountDropNotServingSubnet1.3.6.1.4.1.9.10.102.1.9.12

Tables (4)

NameOID
cDhcpv4ServerSharedNetTable1.3.6.1.4.1.9.10.102.1.4.1
cDhcpv4ServerSubnetTable1.3.6.1.4.1.9.10.102.1.4.2
cDhcpv4ServerRangeTable1.3.6.1.4.1.9.10.102.1.4.3
cDhcpv4ServerClientTable1.3.6.1.4.1.9.10.102.1.4.4

Traps (5)

NameOID
cDhcpv4ServerFreeAddressLow1.3.6.1.4.1.9.10.102.0.2.0.1
cDhcpv4ServerFreeAddressHigh1.3.6.1.4.1.9.10.102.0.2.0.2
cDhcpv4ServerStartTime1.3.6.1.4.1.9.10.102.0.2.0.3
cDhcpv4ServerStopTime1.3.6.1.4.1.9.10.102.0.2.0.4
cDhcpv4ServerDuplicateAddress1.3.6.1.4.1.9.10.102.0.2.0.5

END OF TOC

Scalar details

cDhcpv4SrvSystemDescr

1.3.6.1.4.1.9.10.102.1.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

A textual description of the server. This value should include the full name and version identification of the server.

cDhcpv4SrvSystemObjectID

1.3.6.1.4.1.9.10.102.1.1.2

OBJECT IDENTIFIER

The vendor's authoritative identification of the network management subsystem contained in this entity. This value is allocated within the SMI enterprise subtree (1.3.6.1.4.1) and provides an easy and unambiguous means for determining what kind of server is being managed. For example, if vendor Ohso Soft, Inc. is assigned the subtree 1.3.6.1.4.1.4242, it may assign the identifier 1.3.6.1.4.1.4242.1.1 to its Ursa DHCP Server.

cBootpCountRequests

1.3.6.1.4.1.9.10.102.1.2.1

Counter32

Reference: RFC-2131.

The number of packets received that contain a Message Type of 1 (BOOTREQUEST) in the first octet and do not contain option number 53 (DHCP Message Type) in the options.

cBootpCountInvalids

1.3.6.1.4.1.9.10.102.1.2.2

Counter32

The number of packets received that do not contain a Message Type of 1 (BOOTREQUEST) in the first octet or are not valid BOOTP packets (e.g., too short, invalid field in packet header).

cBootpCountReplies

1.3.6.1.4.1.9.10.102.1.2.3

Counter32

Reference: RFC-2131.

The number of packets sent that contain a Message Type of 2 (BOOTREPLY) in the first octet and do not contain option number 53 (DHCP Message Type) in the options.

cBootpCountDropUnknownClients

1.3.6.1.4.1.9.10.102.1.2.4

Counter32

The number of BOOTP packets dropped due to the server not recognizing or not providing service to the hardware address received in the incoming packet.

cBootpCountDropNotServingSubnet

1.3.6.1.4.1.9.10.102.1.2.5

Counter32

The number of BOOTP packets dropped due to the server not being configured or not otherwise able to serve addresses on the subnet from which this message was received.

cDhcpv4CountDiscovers

1.3.6.1.4.1.9.10.102.1.3.1

Counter32

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPDISCOVER (option 53 with value 1) packets received.

cDhcpv4CountOffers

1.3.6.1.4.1.9.10.102.1.3.2

Counter32

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPOFFER (option 53 with value 2) packets sent.

cDhcpv4CountRequests

1.3.6.1.4.1.9.10.102.1.3.3

Counter32

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPREQUEST (option 53 with value 3) packets received.

cDhcpv4CountDeclines

1.3.6.1.4.1.9.10.102.1.3.4

Counter32

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPDECLINE (option 53 with value 4) packets received.

cDhcpv4CountAcks

1.3.6.1.4.1.9.10.102.1.3.5

Counter32

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPACK (option 53 with value 5) packets sent.

cDhcpv4CountNaks

1.3.6.1.4.1.9.10.102.1.3.6

Counter32

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPNACK (option 53 with value 6) packets sent.

cDhcpv4CountReleases

1.3.6.1.4.1.9.10.102.1.3.7

Counter32

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPRELEASE (option 53 with value 7) packets received.

cDhcpv4CountInforms

1.3.6.1.4.1.9.10.102.1.3.8

Counter32

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPINFORM (option 53 with value 8) packets received.

cDhcpv4CountInvalids

1.3.6.1.4.1.9.10.102.1.3.10

Counter32

The number of DHCP packets received whose DHCP message type (i.e., option number 53) is not understood or handled by the server.

cDhcpv4CountDropUnknownClient

1.3.6.1.4.1.9.10.102.1.3.11

Counter32

The number of DHCP packets dropped due to the server not recognizing or not providing service to the client-id and/or hardware address received in the incoming packet.

cDhcpv4CountDropNotServingSubnet

1.3.6.1.4.1.9.10.102.1.3.12

Counter32

The number of DHCP packets dropped due to the server not being configured or not otherwise able to serve addresses on the subnet from which this message was received.

cDhcpv4ServerNotifyDuplicateIpAddr

1.3.6.1.4.1.9.10.102.1.7.1

InetAddressIPv4Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. SIZE (4) · OCTET STRING · hint 1d.1d.1d.1d

The IPv4 address found to be a duplicate. Duplicates are detected by servers, which issue an ICMP ECHOREQUEST prior to offering an IPv4 address lease, or by a client issuing a gratuitous ARP message and reported through a DHCPDECLINE message.

cDhcpv4ServerNotifyDuplicateMac

1.3.6.1.4.1.9.10.102.1.7.2

CDhcpv4PhysicalAddressA DHCP-specific encoding of the physical address type and physical address, intended to mirror the representation of physical addresses in DHCP messages. The first octet of this object contains the hardware type from the 'htype' field of the DHCP message, the second octet of this object contains the hardware length from the 'hlen' field, and the remaining octets contain the hardware address from the 'chaddr' field.Reference: RFC 2131 SIZE (18) · OCTET STRING · hint 1d,1d,1x:1x:1x:1x:1x:1x

The offending MAC address which caused a duplicate IPv4 address to be detected, if captured by the server, else 00-00- 00-00-00-00.

cDhcpv4ServerNotifyClientOrServerDetected

1.3.6.1.4.1.9.10.102.1.7.3

INTEGER1 = client2 = server · Integer32

Duplicate IPv4 addresses can be detected either by a server, using an ICMP ECHO message, or by a client using ARP. This object is set by the server to (1) if the client used DHCPDECLINE to mark the offered address as in-use, or to (2) if the server discovered the address in use by some client before offering it.

cDhcpv4ServerNotifyServerStart

1.3.6.1.4.1.9.10.102.1.7.4

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The date and time when the server began operation.

cDhcpv4ServerNotifyServerStop

1.3.6.1.4.1.9.10.102.1.7.5

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The date and time when the server ceased operation.

cBootpHCCountRequests

1.3.6.1.4.1.9.10.102.1.8.1

Counter64 (0..18446744073709551615)

Reference: RFC-2131.

The number of packets received that contain a Message Type of 1 (BOOTREQUEST) in the first octet and do not contain option number 53 (DHCP Message Type) in the options.

cBootpHCCountInvalids

1.3.6.1.4.1.9.10.102.1.8.2

Counter64 (0..18446744073709551615)

The number of packets received that do not contain a Message Type of 1 (BOOTREQUEST) in the first octet or are not valid BOOTP packets (e.g., too short, invalid field in packet header).

cBootpHCCountReplies

1.3.6.1.4.1.9.10.102.1.8.3

Counter64 (0..18446744073709551615)

Reference: RFC-2131.

The number of packets sent that contain a Message Type of 2 (BOOTREPLY) in the first octet and do not contain option number 53 (DHCP Message Type) in the options.

cBootpHCCountDropUnknownClients

1.3.6.1.4.1.9.10.102.1.8.4

Counter64 (0..18446744073709551615)

The number of BOOTP packets dropped due to the server not recognizing or not providing service to the hardware address received in the incoming packet.

cBootpHCCountDropNotServingSubnet

1.3.6.1.4.1.9.10.102.1.8.5

Counter64 (0..18446744073709551615)

The number of BOOTP packets dropped due to the server not being configured or not otherwise able to serve addresses on the subnet from which this message was received.

cDhcpv4HCCountDiscovers

1.3.6.1.4.1.9.10.102.1.9.1

Counter64 (0..18446744073709551615)

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPDISCOVER (option 53 with value 1) packets received.

cDhcpv4HCCountOffers

1.3.6.1.4.1.9.10.102.1.9.2

Counter64 (0..18446744073709551615)

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPOFFER (option 53 with value 2) packets sent.

cDhcpv4HCCountRequests

1.3.6.1.4.1.9.10.102.1.9.3

Counter64 (0..18446744073709551615)

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPREQUEST (option 53 with value 3) packets received.

cDhcpv4HCCountDeclines

1.3.6.1.4.1.9.10.102.1.9.4

Counter64 (0..18446744073709551615)

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPDECLINE (option 53 with value 4) packets received.

cDhcpv4HCCountAcks

1.3.6.1.4.1.9.10.102.1.9.5

Counter64 (0..18446744073709551615)

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPACK (option 53 with value 5) packets sent.

cDhcpv4HCCountNaks

1.3.6.1.4.1.9.10.102.1.9.6

Counter64 (0..18446744073709551615)

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPNACK (option 53 with value 6) packets sent.

cDhcpv4HCCountReleases

1.3.6.1.4.1.9.10.102.1.9.7

Counter64 (0..18446744073709551615)

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPRELEASE (option 53 with value 7) packets received.

cDhcpv4HCCountInforms

1.3.6.1.4.1.9.10.102.1.9.8

Counter64 (0..18446744073709551615)

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPINFORM (option 53 with value 8) packets received.

cDhcpv4HCCountForcedRenews

1.3.6.1.4.1.9.10.102.1.9.9

Counter64 (0..18446744073709551615)

Reference: RFC 3203, DHCP reconfigure extension.

The number of DHCPFORCERENEW (option 53 with value 9) packets sent.

cDhcpv4HCCountInvalids

1.3.6.1.4.1.9.10.102.1.9.10

Counter64 (0..18446744073709551615)

The number of DHCP packets received whose DHCP message type (i.e., option number 53) is not understood or handled by the server.

cDhcpv4HCCountDropUnknownClient

1.3.6.1.4.1.9.10.102.1.9.11

Counter64 (0..18446744073709551615)

The number of DHCP packets dropped due to the server not recognizing or not providing service to the client-id and/or hardware address received in the incoming packet.

cDhcpv4HCCountDropNotServingSubnet

1.3.6.1.4.1.9.10.102.1.9.12

Counter64 (0..18446744073709551615)

The number of DHCP packets dropped due to the server not being configured or not otherwise able to serve addresses on the subnet from which this message was received.

Table details

cDhcpv4ServerSharedNetTable

1.3.6.1.4.1.9.10.102.1.4.1

Index: cDhcpv4ServerSharedNetName

A list of shared networks that are configured in the server. A shared network is the logical aggregation of one or more subnets that share a common network segment (e.g., multi- tapped coaxial cable, wiring hub, or switch). This table is present ONLY for those servers that organize the ranges of addresses available for assignment where a higher-level grouping (i.e., the 'shared' network) exists above ranges and subnets.

cDhcpv4ServerSharedNetName

1.3.6.1.4.1.9.10.102.1.4.1.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..100) · OCTET STRING · hint 255t

The name of the shared network, which uniquely identifies an entry in the cDhcpv4ServerSharedNetTable.

cDhcpv4ServerSharedNetFreeAddrLowThreshold

1.3.6.1.4.1.9.10.102.1.4.1.1.2

Unsigned32

The low threshold for available free addresses in this shared network. If the value for available free addresses in this shared network becomes equal to or less than this value, a cDhcpv4ServerFreeAddressLow event is generated for this shared network. No more cDhcpv4ServerFreeAddressLow events will be generated for this subnet during this execution of the DHCP server until the value for available free addresses has exceeded the value of cDhcpv4ServerSharedNetFreeAddrHighThreshold.

cDhcpv4ServerSharedNetFreeAddrHighThreshold

1.3.6.1.4.1.9.10.102.1.4.1.1.3

Unsigned32

The high threshold for available free addresses in this shared network. If a cDhcpv4ServerFreeAddressLow event was generated for this subnet, and the value for available free addresses has exceeded the value of cDhcpv4ServerSubnetFreeAddrHighThreshold, then a cDhcpv4ServerFreeAddressHigh event will be generated. No more cDhcpv4ServerFreeAddressHigh events will be generated for this subnet during this execution of the DHCP server until the value for available free addresses becomes equal to or less than the value of cDhcpv4ServerSubnetFreeAddrLowThreshold.

cDhcpv4ServerSharedNetFreeAddresses

1.3.6.1.4.1.9.10.102.1.4.1.1.4

Unsigned32

The number of IPv4 addresses which are available within this shared network. If the server does not count free addresses by shared network segment, this value will be zero.

cDhcpv4ServerSharedNetReservedAddresses

1.3.6.1.4.1.9.10.102.1.4.1.1.5

Unsigned32

The number of IPv4 addresses which are reserved (not available for assignment) within this shared network. If the server does not count reserved addresses by shared network segment, this value will be zero.

cDhcpv4ServerSharedNetTotalAddresses

1.3.6.1.4.1.9.10.102.1.4.1.1.6

Unsigned32

The number of IPv4 addresses which are available within this shared network. If the server does not count total addresses by shared network segment, this value will be zero.

cDhcpv4ServerSubnetTable

1.3.6.1.4.1.9.10.102.1.4.2

Index: cDhcpv4ServerSubnetAddress

A list of subnets that are configured in this server.

cDhcpv4ServerSubnetAddress

1.3.6.1.4.1.9.10.102.1.4.2.1.1

InetAddressIPv4Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. SIZE (4) · OCTET STRING · hint 1d.1d.1d.1d

The IPv4 address of the subnet entry in the cDhcpv4ServerSubnetTable.

cDhcpv4ServerSubnetMask

1.3.6.1.4.1.9.10.102.1.4.2.1.2

InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d

The subnet mask of the subnet. This MUST be the same as the value of DHCP option 1 offered to clients on this subnet.

cDhcpv4ServerSubnetSharedNetworkName

1.3.6.1.4.1.9.10.102.1.4.2.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..100) · OCTET STRING · hint 255t

The shared subnet name (used as an index into the server shared subnet table) to which this subnet belongs. This value will be null for servers that do not organize or describe networks in this manner.

cDhcpv4ServerSubnetFreeAddrLowThreshold

1.3.6.1.4.1.9.10.102.1.4.2.1.4

Unsigned32

The low threshold for available free addresses in this subnet. If the value for available free addresses in this subnet becomes equal to or less than this value, a cDhcpv4ServerSubnetFreeAddrLowThreshold event will be generated for this shared network. No more cDhcpv4ServerSubnetFreeAddrLowThreshold events will be generated for this subnet during this execution of the DHCP server until the value for available free addresses has exceeded the value of cDhcpv4ServerSubnetFreeAddrHighThreshold.

cDhcpv4ServerSubnetFreeAddrHighThreshold

1.3.6.1.4.1.9.10.102.1.4.2.1.5

Unsigned32

The high threshold for available free addresses in this subnet. If a cDhcpv4ServerSubnetFreeAddrLowThreshold event has been generated for this subnet, and the value for available free addresses has exceeded the value of cDhcpv4ServerSubnetFreeAddrHighThreshold, then a cDhcpv4ServerFreeAddressHigh event will be generated. No more cDhcpv4ServerFreeAddressHigh events will be generated for this subnet during this execution of the DHCP server until the value for available free addresses becomes equal to or less than the value of cDhcpv4ServerSubnetFreeAddrLowThreshold.

cDhcpv4ServerSubnetFreeAddresses

1.3.6.1.4.1.9.10.102.1.4.2.1.6

Unsigned32

The number of free IPv4 addresses which are available in this subnet.

cDhcpv4ServerRangeTable

1.3.6.1.4.1.9.10.102.1.4.3

Index: cDhcpv4ServerRangeStartAddress · cDhcpv4ServerRangeEndAddress

A list of ranges that are configured on this server.

cDhcpv4ServerRangeStartAddress

1.3.6.1.4.1.9.10.102.1.4.3.1.1

InetAddressIPv4Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. SIZE (4) · OCTET STRING · hint 1d.1d.1d.1d

The IPv4 address of the first address in the range. The value of cDhcpv4ServerRangeStartAddress MUST be less than or equal to the value of cDhcpv4ServerRangeEndAddress.

cDhcpv4ServerRangeEndAddress

1.3.6.1.4.1.9.10.102.1.4.3.1.2

InetAddressIPv4Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. SIZE (4) · OCTET STRING · hint 1d.1d.1d.1d

The IPv4 address of the last address in the range. The value of cDhcpv4ServerRangeEndAddress MUST be greater than or equal to the value of cDhcpv4ServerRangeStartAddress.

cDhcpv4ServerRangeSubnetMask

1.3.6.1.4.1.9.10.102.1.4.3.1.3

InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d

The subnet address mask for this range.

cDhcpv4ServerRangeInUse

1.3.6.1.4.1.9.10.102.1.4.3.1.4

Gauge32

The number of addresses in this range that are currently in use. This number includes those addresses whose lease has not expired and addresses which have been reserved (either by the server or through configuration).

cDhcpv4ServerRangeOutstandingOffers

1.3.6.1.4.1.9.10.102.1.4.3.1.5

Gauge32

The number of outstanding DHCPOFFER messages for this range is reported with this value. An offer is outstanding if the server has sent a DHCPOFFER message to a client, but has not yet received a DHCPREQUEST message from the client nor has the server-specific timeout (limiting the time in which a client can respond to the offer message) for the offer message expired.

cDhcpv4ServerClientTable

1.3.6.1.4.1.9.10.102.1.4.4

Index: cDhcpv4ServerClient

An optional list of addresses that are known by this server. The list MUST contain addresses that have not expired. The list MUST NOT contain addresses that have never been assigned by the server UNLESS the lease is pre-configured in the server (e.g., a static lease for a host). Expired leases MAY appear during the time they are 'remembered' by the server for subsequent assignment to the same host.

cDhcpv4ServerClient

1.3.6.1.4.1.9.10.102.1.4.4.1.1

InetAddressIPv4Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. SIZE (4) · OCTET STRING · hint 1d.1d.1d.1d

The IPv4 address of this entry in the cDhcpv4ServerClientTable.

cDhcpv4ServerClientSubnetMask

1.3.6.1.4.1.9.10.102.1.4.4.1.2

InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d

The subnet mask (DHCP option 1) provided to the client offered this address. The subnet, resulting from logically ANDing the subnet mask with the entry's IPv4 address, MUST be configured on this server and appear as a row in the cDhcpSubnetTable.

cDhcpv4ServerClientRange

1.3.6.1.4.1.9.10.102.1.4.4.1.3

InetAddressIPv4Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. SIZE (4) · OCTET STRING · hint 1d.1d.1d.1d

The starting IPv4 address (cDhcpv4ServerRangeStartAddress object) of the range to which this address belongs. If the address does not fall into one of the configured ranges (e.g., a statically configured address on a subnet) the range MAY be 0.0.0.0.

cDhcpv4ServerClientLeaseType

1.3.6.1.4.1.9.10.102.1.4.4.1.4

INTEGER1 = static2 = dynamic3 = expired4 = configurationReserved5 = serverReserved · Integer32

The type of this address. Types are: (1) Static addresses defined by the server configuration. (2) Dynamic addresses defined by the server configuration AND actually assigned by the server. (3) Expired dynamic addresses, previously assigned by the server, and 'remembered' for subsequent assignment to the same host. (4) Addresses reserved (i.e., not assignable) by the server configuration. (5) Addresses previously assigned by the server, but temporarily or permanently removed from assignable state for some reason, e.g., the server received an ICMP ECHOREPLY for the IPv4 address or a DHCPDECLINE message has been received for the IPv4 address.

cDhcpv4ServerClientTimeRemaining

1.3.6.1.4.1.9.10.102.1.4.4.1.5

Unsigned32

The number of seconds until the lease expires. A value of 4294967295 (i.e., 0xFFFFFFFF) SHOULD be used for leases that have a lease time which is 'infinite' and for BOOTP leases.

cDhcpv4ServerClientAllowedProtocol

1.3.6.1.4.1.9.10.102.1.4.4.1.6

INTEGER1 = none2 = bootp3 = dhcp4 = bootpOrDhcp · Integer32

The type of protocol that is allowed to be used to serve this address. A type of none (1) indicates that the address is not available to be served (e.g., a reserved address). Type (2) is reserved for BOOTP only devices, while type (3) is reserved for DHCP only devices. A type of bootp-or-dhcp (4) can be offered to any type of client.

cDhcpv4ServerClientServedProtocol

1.3.6.1.4.1.9.10.102.1.4.4.1.7

INTEGER1 = none2 = bootp3 = dhcp · Integer32

The type of protocol that was used when this address was assigned. This object will have the value of none (1) if the address has not been served.

cDhcpv4ServerClientPhysicalAddress

1.3.6.1.4.1.9.10.102.1.4.4.1.8

CDhcpv4PhysicalAddressA DHCP-specific encoding of the physical address type and physical address, intended to mirror the representation of physical addresses in DHCP messages. The first octet of this object contains the hardware type from the 'htype' field of the DHCP message, the second octet of this object contains the hardware length from the 'hlen' field, and the remaining octets contain the hardware address from the 'chaddr' field.Reference: RFC 2131 SIZE (18) · OCTET STRING · hint 1d,1d,1x:1x:1x:1x:1x:1x

The hardware type and hardware address of the client that has been assigned this lease. The first octet of this object contains the hardware type from the 'htype' field of the BOOTP packet and the remaining octets contain the hardware address from the 'chaddr' field of the BOOTP packet. This object MAY be empty if the address has not been previously served.

cDhcpv4ServerClientClientId

1.3.6.1.4.1.9.10.102.1.4.4.1.9

OCTET STRING SIZE (0..255)

The client-id of the client that has been assigned this lease. The client-id is the value specified in option 61 (client-id option) when the lease was assigned. This object MAY be empty if the lease has not been previously assigned or if the client-id option was not specified when the address was assigned.

cDhcpv4ServerClientHostName

1.3.6.1.4.1.9.10.102.1.4.4.1.10

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..255) · OCTET STRING · hint 255t

The host name (DHCP option 12) the client is configured to use, or if no host name was configured then the host name that the client supplied when requesting an address. While this object has a maximum size of 255 octets, a Fully-Qualified Domain Name (FQDN) consisting of a Host Name part and a Domain Name part is currently limited to 255 octets. Therefore, the sum of the string lengths for this object and the cDhcpv4ServerClientDomainName MUST be, in practice, less than 256 octets.

cDhcpv4ServerClientDomainName

1.3.6.1.4.1.9.10.102.1.4.4.1.11

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..255) · OCTET STRING · hint 255t

The domain name (DHCP option 15) assigned to the client. While this object has a maximum size of 255 octets, a Fully- Qualified Domain Name (FQDN) consisting of a Host Name part and a Domain Name part is currently limited to 255 octets, less the separator ('.') character. Therefore, the sum of the string lengths for this object and the cDhcpv4ServerClientHostName MUST be, in practice, less than 256 octets.

Trap details

cDhcpv4ServerFreeAddressLow

1.3.6.1.4.1.9.10.102.0.2.0.1

This notification signifies that the number of available IPv4 addresses for a particular shared network has fallen below the value of cDhcpv4ServerSharedNetFreeAddrLowThreshold for that shared network.

cDhcpv4ServerSharedNetFreeAddrLowThreshold

1.3.6.1.4.1.9.10.102.1.4.1.1.2

Unsigned32

The low threshold for available free addresses in this shared network. If the value for available free addresses in this shared network becomes equal to or less than this value, a cDhcpv4ServerFreeAddressLow event is generated for this shared network. No more cDhcpv4ServerFreeAddressLow events will be generated for this subnet during this execution of the DHCP server until the value for available free addresses has exceeded the value of cDhcpv4ServerSharedNetFreeAddrHighThreshold.

cDhcpv4ServerSharedNetFreeAddresses

1.3.6.1.4.1.9.10.102.1.4.1.1.4

Unsigned32

The number of IPv4 addresses which are available within this shared network. If the server does not count free addresses by shared network segment, this value will be zero.

cDhcpv4ServerFreeAddressHigh

1.3.6.1.4.1.9.10.102.0.2.0.2

This notification signifies that the number of available IPv4 addresses for a particular shared network has risen above the value of cDhcpv4ServerSharedNetFreeAddrHighThreshold for that shared network.

cDhcpv4ServerSharedNetFreeAddrHighThreshold

1.3.6.1.4.1.9.10.102.1.4.1.1.3

Unsigned32

The high threshold for available free addresses in this shared network. If a cDhcpv4ServerFreeAddressLow event was generated for this subnet, and the value for available free addresses has exceeded the value of cDhcpv4ServerSubnetFreeAddrHighThreshold, then a cDhcpv4ServerFreeAddressHigh event will be generated. No more cDhcpv4ServerFreeAddressHigh events will be generated for this subnet during this execution of the DHCP server until the value for available free addresses becomes equal to or less than the value of cDhcpv4ServerSubnetFreeAddrLowThreshold.

cDhcpv4ServerSharedNetFreeAddresses

1.3.6.1.4.1.9.10.102.1.4.1.1.4

Unsigned32

The number of IPv4 addresses which are available within this shared network. If the server does not count free addresses by shared network segment, this value will be zero.

cDhcpv4ServerStartTime

1.3.6.1.4.1.9.10.102.0.2.0.3

This notification signifies that the server of the specified type has started on the host from which this notification has been sent.

cDhcpv4ServerNotifyServerStart

1.3.6.1.4.1.9.10.102.1.7.4

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The date and time when the server began operation.

cDhcpv4ServerStopTime

1.3.6.1.4.1.9.10.102.0.2.0.4

This notification signifies that the server of the specified type has stopped normally on the host from which this notification has been sent.

cDhcpv4ServerNotifyServerStop

1.3.6.1.4.1.9.10.102.1.7.5

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The date and time when the server ceased operation.

cDhcpv4ServerDuplicateAddress

1.3.6.1.4.1.9.10.102.0.2.0.5

This notification signifies that a duplicate IPv4 address has been detected. The DHCP server can detect this condition through the ping-before-offer mechanism. Alternatively, the client may have sent a DHCPDECLINE back to the server; this is assumed to be the result of the client detecting that the address was in use. In either case, the DHCP server marks the IPv4 address as unavailable for leasing to clients. The cDhcpv4ServerNotifyClientOrServerDetected object indicates whether the client or server detected this condition.

cDhcpv4ServerNotifyDuplicateIpAddr

1.3.6.1.4.1.9.10.102.1.7.1

InetAddressIPv4Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. SIZE (4) · OCTET STRING · hint 1d.1d.1d.1d

The IPv4 address found to be a duplicate. Duplicates are detected by servers, which issue an ICMP ECHOREQUEST prior to offering an IPv4 address lease, or by a client issuing a gratuitous ARP message and reported through a DHCPDECLINE message.

cDhcpv4ServerNotifyDuplicateMac

1.3.6.1.4.1.9.10.102.1.7.2

CDhcpv4PhysicalAddressA DHCP-specific encoding of the physical address type and physical address, intended to mirror the representation of physical addresses in DHCP messages. The first octet of this object contains the hardware type from the 'htype' field of the DHCP message, the second octet of this object contains the hardware length from the 'hlen' field, and the remaining octets contain the hardware address from the 'chaddr' field.Reference: RFC 2131 SIZE (18) · OCTET STRING · hint 1d,1d,1x:1x:1x:1x:1x:1x

The offending MAC address which caused a duplicate IPv4 address to be detected, if captured by the server, else 00-00- 00-00-00-00.

cDhcpv4ServerNotifyClientOrServerDetected

1.3.6.1.4.1.9.10.102.1.7.3

INTEGER1 = client2 = server · Integer32

Duplicate IPv4 addresses can be detected either by a server, using an ICMP ECHO message, or by a client using ARP. This object is set by the server to (1) if the client used DHCPDECLINE to mark the offered address as in-use, or to (2) if the server discovered the address in use by some client before offering it.

↑ To TOC