The MIB for providing information related to monitoring SS7 links.
This information can be used to manage the state of software used to collect all packets transported and received over a SS7 link.
Abbreviations:
MSU - Message Signalling Unit
MTP - Message Transport Protocol
SS7 - System No. 7 (SS7) Network
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The ITP monitor congestion States notification truth value.
'true' Indicates that cItpmCongestionNotifEnabled
notification is to be generated when the state changes. That is, the notification generation is enabled. 'false' Indicates that cItpmCongestionNotifEnabled notification generation is disabled.
cItpmMonitorStateNotifEnabled
1.3.6.1.4.1.9.9.379.1.4
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The ITP monitor state notification truth value.
'true' - Indicates that ciscoItpMonitorState notification
is to be generated when the state of connection changes. That is, the notification generation is enabled.
'false' - Indicates that ciscoItpMonitorState notification generation is disabled.
Table details
cItpmConnTable
1.3.6.1.4.1.9.9.379.1.1.1
Index: cItpmConnPortNumber
This table provides information on connections used to collect information on SS7 links. Information in this table can be used to customize connection parameters. In addition, this table provides measurements and status information for each connection.
cItpmConnPortNumber
1.3.6.1.4.1.9.9.379.1.1.1.1.1
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
The port number used to establish TCP connection.
cItpmConnKeepAlive
1.3.6.1.4.1.9.9.379.1.1.1.1.2
Unsigned32 (0..60000) · milliseconds
Specifies the keepalive time value in milliseconds. Keepalive packets are sent between the monitor and the remote server as a mechanism to ensure the TCP session is active and detect session failure in a timely manner. During periods of idle monitor traffic, the monitor will send a keepalive packet to the remote server at the specified interval. The monitor also expects to receive a keepalive packet from the remote server at the same interval. If the monitor does not receive a keepalive packet from the remote server in two times the keep alive value, the monitor will close the TCP session. The value of zero disables the keep alive processing.
cItpmConnMaxQDepth
1.3.6.1.4.1.9.9.379.1.1.1.1.3
Unsigned32 (10..100000) · packets
The maximum number of packets that can be queued for transmission. If the monitor cannot send a TCP packet immediately, the packet will be queued for retransmit. This object defines the maximum number of TCP packets that may be queued for retransmit. Once the number of TCP packets on the queue reaches the value specified by this object, additional TCP packets will be dropped.
cItpmConnCongOnset
1.3.6.1.4.1.9.9.379.1.1.1.1.4
Unsigned32 (100..100000) · packets
Threshold used to mark onset of congestion. When the cItpmConnQueueDepth object reaches value specified by this object the connection will considered congested. It will remain congested until the cItpmConnQueueDepth object drops below the value specified by the cItpmConnCongAbate object.
cItpmConnCongAbate
1.3.6.1.4.1.9.9.379.1.1.1.1.5
Unsigned32 (0..100000) · packets
Threshold used to mark end of congestion. When the cItpmConnQueueDepth object drops below the value specified by this object the connection will exit congestion.
cItpmConnRcvWindowSize
1.3.6.1.4.1.9.9.379.1.1.1.1.6
Unsigned32 (100..1000000) · bytes
The size of TCP receive window. This object defines the number of outstanding (unacknowledged) bytes that the ITP monitor can receive on TCP connection.
cItpmConnFastStart
1.3.6.1.4.1.9.9.379.1.1.1.1.7
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Defines the fast-start option for establishing TCP connectivity as follows.
'true' - FastStart is enabled.
'false' - FastStart is disabled.
Normally, after the TCP session with the remote server is established, the monitor will not send MSUs from the monitored links to the server until the server responds to the first keepalive.
This mechanism prevents the ITP from over-running the server until the TCP session and receive window sizes are fully established.
Configuration of fast-start overrides this mechanism and allows the ITP to start sending MSUs to the server immediately after the TCP session is established.
Caution should be used with the fast-start configuration as MSUs may be lost until the TCP session server and receive window sizes are fully established.
cItpmConnQueueDepth
1.3.6.1.4.1.9.9.379.1.1.1.1.8
Gauge32 (0..100000) · packets
The number of packets queued for transmission. The maximum value is specified by the cItpmConnMaxQDepth object.
cItpmConnMonitorState
1.3.6.1.4.1.9.9.379.1.1.1.1.9
INTEGER1 = active2 = inactive · Integer32
The state of the connection as follows.
'active' - connection is transmitting SS7 link
traffic to server.
'inactive' - connection is not transmitting SS7 link
traffic to server.
cItpmConnCongestion
1.3.6.1.4.1.9.9.379.1.1.1.1.10
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Congestion indicator for connection as follows.
'true' - connection is congested.
'false' - connection not congested.
Congestion onset occurs when the cItpmConnQueueDepth object reaches the maximum allowed value specified by the cItpmConnMaxQDepth object.
Congestion abate occurs when the cItpmConnQueueDepth object reaches the maximum allowed value specified by the cItpmConnMaxQDepth object.
cItpmConnCongCounts
1.3.6.1.4.1.9.9.379.1.1.1.1.11
Counter32 · occurences
The number of times the connection has entered congestion.
cItpmLinkTable
1.3.6.1.4.1.9.9.379.1.1.2
Index: cItpmConnPortNumber · cItpmLinkNumber
This table provides information and measurements on the monitored SS7 links per connection. This table shares the cItpmConnPortNumber index with the cItpmConnTable.
cItpmLinkNumber
1.3.6.1.4.1.9.9.379.1.1.2.1.1
Unsigned32 (1..65535)
This object specifies the secondary index for objects in the cItpmLinkTable table. A unique number is assigned to each link when it is assigned to a connection.
cItpmLinkDescription
1.3.6.1.4.1.9.9.379.1.1.2.1.2
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..128) · OCTET STRING · hint 255t
Brief customer defined description.
cItpmLinkSlotNumber
1.3.6.1.4.1.9.9.379.1.1.2.1.3
Unsigned32 (0..32767)
The slot number support interface used to collect SS7 link traffic.
cItpmLinkStatus
1.3.6.1.4.1.9.9.379.1.1.2.1.4
INTEGER1 = active2 = inactive · Integer32
The state of the monitored SS7 Link as follows.
'active' - SS7 link is available for monitoring.
'inactive' - SS7 link is unavailable for monitoring.
cItpmLinkRcvdMsus
1.3.6.1.4.1.9.9.379.1.1.2.1.5
Counter32 · MSUs
The number of MSUs received on SS7 Link.
cItpmLinkRcvdMsuDrops
1.3.6.1.4.1.9.9.379.1.1.2.1.6
Counter32 · MSUs
The number of MSUs that were received on SS7 Link and were dropped due to congestion.
cItpmLinkRcvdMsuRate
1.3.6.1.4.1.9.9.379.1.1.2.1.7
Gauge32 · MSUs per second
The number of MSUs received on SS7 Link per second.
cItpmLinkRcvdBitsRate
1.3.6.1.4.1.9.9.379.1.1.2.1.8
Gauge32 · bits per second
The number of bits received on SS7 Link per second.
cItpmLinkSentMsus
1.3.6.1.4.1.9.9.379.1.1.2.1.9
Counter32 · MSUs
The number of MSUs sent on SS7 Link.
cItpmLinkSentMsuDrops
1.3.6.1.4.1.9.9.379.1.1.2.1.10
Counter32 · MSUs
The number of MSUs that were sent on SS7 Link and were dropped due to congestion.
cItpmLinkSentMsuRate
1.3.6.1.4.1.9.9.379.1.1.2.1.11
Gauge32 · MSUs per second
The number of MSUs sent on SS7 Link per second.
cItpmLinkSentBitsRate
1.3.6.1.4.1.9.9.379.1.1.2.1.12
Gauge32 · bits per second
The number of bits sent on SS7 Link per second.
Trap details
ciscoItpMonitorCongestion
1.3.6.1.4.1.9.9.379.0.1
The notification generated when a connection enters or exits congestion state. The value of cItpmConnCongestion indicates new state.
cItpmConnCongestion
1.3.6.1.4.1.9.9.379.1.1.1.1.10
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Congestion indicator for connection as follows.
'true' - connection is congested.
'false' - connection not congested.
Congestion onset occurs when the cItpmConnQueueDepth object reaches the maximum allowed value specified by the cItpmConnMaxQDepth object.
Congestion abate occurs when the cItpmConnQueueDepth object reaches the maximum allowed value specified by the cItpmConnMaxQDepth object.
ciscoItpMonitorState
1.3.6.1.4.1.9.9.379.0.2
The notification generated when a connection changes states. The value of cItpmConnMonitorState indicates new state.
cItpmConnMonitorState
1.3.6.1.4.1.9.9.379.1.1.1.1.9
INTEGER1 = active2 = inactive · Integer32
The state of the connection as follows.
'active' - connection is transmitting SS7 link
traffic to server.
'inactive' - connection is not transmitting SS7 link
traffic to server.