EZ5 MIB Catalog

CISCO-LICENSE-MIB

2004-01-31

This MIB module provides objects to view the features and services that are licensed to run on a system (usually a network entity), and an inventory of the licenses for these features and services. The inventory of the licenses is kept in a license pool which is a repository of the installed licenses. This MIB does not provide any object to facilitate the installation or addition of licenses in the license pool. The licenses are used to perform specific services, and are used by, but not limited to, the physical entities. The meaningful entities which can use licenses to perform specific services include: module(9), or chassis(3) as defined in RFC 2737. As an example, some of the services/features that can be licensed include (but not limited to) the following : - Single Service. Only one of: ATM, FR, or CES (Circuit Emulation Service). - Multi Service. More than one of: ATM, FR, or CES. - IMA (Inverse Multiplexing over ATM). - MFR (Multilink Frame Relay). - Channelization. As an example of implementation, all licenses can be kept in the license pool owned by a chassis, while licenseable services are performed by service modules plugged into that chassis. In order to provide licenseable services/features, the service modules use/consume appropriate licenses from the license pool owned by the chassis.

Download CISCO-LICENSE-MIB.txt Open CISCO-LICENSE-MIB.txt in a new tab

TABLES (5)

Tables (5)

NameOID
celLicenseConfigHistoryTable1.3.6.1.4.1.9.9.359.1.1.1
celLicenseConfigDetailTable1.3.6.1.4.1.9.9.359.1.1.2
celPoolLicenseTable1.3.6.1.4.1.9.9.359.1.1.3
celInUseLicenseTable1.3.6.1.4.1.9.9.359.1.1.4
celPhysicallyProgLicenseTable1.3.6.1.4.1.9.9.359.1.1.5

END OF TOC

Table details

celLicenseConfigHistoryTable

1.3.6.1.4.1.9.9.359.1.1.1

Index: celLicenseConfigIndex

This table keeps track of the license installation history. Each time licenses are installed, a record is made in one of the entries in this table. When licensed features are applicable to physical entities, this table contains entries showing various licenseable vendor-specific hardware entities represented by the object celLicenseEntityVendorType, the corresponding license serial numbers (if any), and license update time-stamp, and license update sequence numbers. When licensed features are not applicable to a physical entity, the object celLicenseEntityVendorType is set to NULL. Each time a new entry is made in this table, the total number of installed licenses is updated in the table celPoolLicenseTable in the appropriate entry. If the necessary entry in the table celPoolLicenseTable does not exist, it is created. The implementations may choose to implement the table in circular fashion by limiting the number of entries in the table. In this case the oldest entry is overwritten by the latest. The object celLicenseConfigHistoryIndex always increase monotonically and indicates how many times the licenses have been installed.

celLicenseConfigIndex

1.3.6.1.4.1.9.9.359.1.1.1.1.1

Unsigned32 (1..4294967295)

A unique running value greater than 0, used as index into the table. The values of this index are assigned contiguously starting normally from 1.

celLicenseEntityVendorType

1.3.6.1.4.1.9.9.359.1.1.1.1.2

AutonomousTypeRepresents an independently extensible type identification value. It may, for example, indicate a particular sub-tree with further MIB definitions, or define a particular type of protocol or hardware. · OBJECT IDENTIFIER

This represents vendor-specific hardware type of a physical entity which can use one or more licenses to provide licensed services or features. If no vendor-specific registration identifier exists for this object, or the value is unknown by this agent, then the value { 0 0 } is returned.

celLicenseSerialNumber

1.3.6.1.4.1.9.9.359.1.1.1.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

A textual representation of the license serial number, if any. Value contained in this object is optional, and if not used, it should be zero length string.

celLicenseInstallEntitySerNum

1.3.6.1.4.1.9.9.359.1.1.1.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

A textual representation of the serial number of the physical entity (if applicable) from where the license installation took place. Value contained in this object is optional, and if not used, it should be zero length string.

celLicenseUpdateTimeStamp

1.3.6.1.4.1.9.9.359.1.1.1.1.5

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This represents the time-stamp when the licenses, usable by the corresponding vendor-specific hardware, were upgraded or modified.

celLicenseConfigHistoryIndex

1.3.6.1.4.1.9.9.359.1.1.1.1.6

Counter32

This value shows the license update sequence number recorded in the license pool. Each time licenses are updated or installed, this object is incremented. If the table size is limited and circular, this number may be different from the running index celLicenseConfigIndex. This value is greater than zero.

celLicenseUpdateSequenceNum

1.3.6.1.4.1.9.9.359.1.1.1.1.7

Counter32

This value shows the license update sequence number as contained in the license itself. Each time licenses are updated or installed, this object is assigned the sequence number that is a part of the license being installed. Depending upon the implementation, it serves the purpose of preventing the reuse of an already installed license, especially when that license is applied in additive mode. When an attempt is made to update/install the licenses, the implementation may allow update only if the new license's sequence number is greater than the last installed license sequence number. If the license update/installation is successful, this object reflects the new license sequence number and can be used to detect if attempt is being made to reuse a previous license. This value is greater than zero.

celLicenseUpdateMethod

1.3.6.1.4.1.9.9.359.1.1.1.1.8

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..40) · OCTET STRING · hint 255t

Use of this object is implementation dependent. A textual short description explaining how this entry was updated in this table. If not used, it should be zero length string.

celLicenseConfigDetailTable

1.3.6.1.4.1.9.9.359.1.1.2

Index: celLicenseConfigIndex · celLicenseConfigType

For each entry in the table celLicenseConfigHistoryTable, this table expands the information showing the installed type of license, and the number of licenses. There may be more than one entries corresponding to a single entry in the table celLicenseConfigHistoryTable One of the indicies of this table is celLicenseConfigIndex which is the index into the table celLicenseConfigHistoryTable.

celLicenseConfigType

1.3.6.1.4.1.9.9.359.1.1.2.1.1

LicenseType1 = unknown2 = none3 = reserved4 = singleService5 = multiService6 = channelization7 = ima8 = mfr9 = rateControl10 = multilink11 = pppThis defines a licenseable feature: unknown(1) The license type can not be determined. none(2) No license is granted for any licenseable feature/service. reserved(3) This is special restricted license. singleService(4) Only one of following services: ATM, FR (FrameRelay), or CES (Circuit emulation service). multiService(5) More than one of: ATM, FR, CES. channelization (6) Channelization. ima(7) Inverse multiplexing over ATM. mfr(8) Multilink Frame Relay. rateControl(9) Rate-Control (Cisco Foresight and/or ABR). multilink(10) Multilink features such as: Inverse Multiplexing over ATM (IMA), Multilink Frame Relay (MFR). ppp(11) Point-to-point protocols (PPP), such as: Multilink Point-to-point Protocol(MLPPP), PPP Multiplexing (PPPMux). · Integer32

This represents one of the the license types corresponding to the entry indexed by celLicenseConfigIndex in the table celLicenseConfigHistoryTable.

celLicenseTypeDescr

1.3.6.1.4.1.9.9.359.1.1.2.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

A textual representation of the licensable feature. Value contained in this object is optional, and if not used, it should be zero length string.

celLicenseConfigCount

1.3.6.1.4.1.9.9.359.1.1.2.1.3

Unsigned32 (1..4294967295)

Number of licenses of the type celLicenseConfigType. This represents the count of installed licenses represented by the entry with index celLicenseConfigIndex in the table celLicenseConfigHistoryTable.

celPoolLicenseTable

1.3.6.1.4.1.9.9.359.1.1.3

Index: celPoolLicenseIndex

This table contains the inventory of installed licenses and completely defines the license pool owned by the SNMP agent implementing this table. These licenses can be used by the appropriate entities (physical or otherwise) to which these licenses are applicable.

celPoolLicenseIndex

1.3.6.1.4.1.9.9.359.1.1.3.1.1

Unsigned32 (1..4294967295)

A unique running value greater than 0, used as index into the table. The values of this index are assigned contiguously starting from 1.

celPoolLicenseEntityVendorType

1.3.6.1.4.1.9.9.359.1.1.3.1.2

AutonomousTypeRepresents an independently extensible type identification value. It may, for example, indicate a particular sub-tree with further MIB definitions, or define a particular type of protocol or hardware. · OBJECT IDENTIFIER

This represents vendor-specific hardware type of a physical entity which can use one or more licenses to provide licensed services or features. If no vendor-specific registration identifier exists for this object, or the value is unknown by this agent, then the value { 0 0 } is returned.

celPoolLicenseType

1.3.6.1.4.1.9.9.359.1.1.3.1.3

LicenseType1 = unknown2 = none3 = reserved4 = singleService5 = multiService6 = channelization7 = ima8 = mfr9 = rateControl10 = multilink11 = pppThis defines a licenseable feature: unknown(1) The license type can not be determined. none(2) No license is granted for any licenseable feature/service. reserved(3) This is special restricted license. singleService(4) Only one of following services: ATM, FR (FrameRelay), or CES (Circuit emulation service). multiService(5) More than one of: ATM, FR, CES. channelization (6) Channelization. ima(7) Inverse multiplexing over ATM. mfr(8) Multilink Frame Relay. rateControl(9) Rate-Control (Cisco Foresight and/or ABR). multilink(10) Multilink features such as: Inverse Multiplexing over ATM (IMA), Multilink Frame Relay (MFR). ppp(11) Point-to-point protocols (PPP), such as: Multilink Point-to-point Protocol(MLPPP), PPP Multiplexing (PPPMux). · Integer32

This represents a useable license type.

celPoolLicensesInstalled

1.3.6.1.4.1.9.9.359.1.1.3.1.4

Gauge32

Total number of licenses of the type celPoolLicenseType at a given time in the license pool. This number changes as a result of installation of licenses of the type celPoolLicenseType.

celPoolLicensesInUse

1.3.6.1.4.1.9.9.359.1.1.3.1.5

Gauge32

Number of used up licenses of the type celPoolLicenseType. Each time a license is used up by the appropriate entity (physical or otherwise), this number is incremented. Similarly, when a license is released back to the license pool, this number decrements. Difference between celPoolLicensesInstalled and this object is the number of licenses still available for use. Depending upon the implementation and the system operational considerations, it is possible that at a given time, this object has a value greater than celPoolLicensesInstalled. This indicates over-subscription to the licenses. The implementation may choose to disallow such situation or treat this situation as temporary and allow the system operation to continue until the implementation specific time period. In this case, more licenses of this type must be installed in the license pool to avoid disruption of the services.

celPoolLicenseMaxUsage

1.3.6.1.4.1.9.9.359.1.1.3.1.6

Gauge32

The value represented by this object specifies the maximum number of the licenses of type celPoolLicenseType which can be allowed for use by the corresponding entity type (physical or otherwise). As an example of usage of this object, if the entity of corresponding type attempts to use more licenses than this value, it is considered an error.

celInUseLicenseTable

1.3.6.1.4.1.9.9.359.1.1.4

Index: celInUseSlotIndex · celInUseLicenseType

This table contains entries showing the entities (physical or otherwise) that are using up licenses, and the number and type of licenses in use. For example, if a service module is consuming certain type of licenses from the license pool, an entry corresponding to that module will exist in this table and will show the number and type licenses being used. An entry in this table is automatically created as soon as an appropriate entity starts using one or more licenses of the type celInUseLicenseType. The object celInUseLicenses can increase or decrease any time the number of in-use licenses changes. As soon as the value of the object celInUseLicenses reduces to the value 0, the corresponding entry is deleted automatically.

celInUseSlotIndex

1.3.6.1.4.1.9.9.359.1.1.4.1.1

Integer32 (0..65535)

A unique running value used as index into the table. When not 0, this index is interpreted as the slot number (within the chassis) containing the entity that is using licenses. If corresponding entPhysicalIndex (RFC 2737) exists for this slot, celEntPhysicalIndex contains its value. When it is 0, it can be interpreted as a reference to all non-physical entities which can use licenses and which do hot have entPhysicalIndex. In such cases the object celEntPhysicalIndex is also set to 0. In addition, when referring to a physical entity for which a slot is non meaningful, but entPhysicalIndex exists, this index has a value 0 and the object celEntPhysicalIndex contains the corresponding value of entPhysicalIndex.

celInUseLicenseType

1.3.6.1.4.1.9.9.359.1.1.4.1.2

LicenseType1 = unknown2 = none3 = reserved4 = singleService5 = multiService6 = channelization7 = ima8 = mfr9 = rateControl10 = multilink11 = pppThis defines a licenseable feature: unknown(1) The license type can not be determined. none(2) No license is granted for any licenseable feature/service. reserved(3) This is special restricted license. singleService(4) Only one of following services: ATM, FR (FrameRelay), or CES (Circuit emulation service). multiService(5) More than one of: ATM, FR, CES. channelization (6) Channelization. ima(7) Inverse multiplexing over ATM. mfr(8) Multilink Frame Relay. rateControl(9) Rate-Control (Cisco Foresight and/or ABR). multilink(10) Multilink features such as: Inverse Multiplexing over ATM (IMA), Multilink Frame Relay (MFR). ppp(11) Point-to-point protocols (PPP), such as: Multilink Point-to-point Protocol(MLPPP), PPP Multiplexing (PPPMux). · Integer32

This represents a license type being used by the entity (physical or otherwise).

celEntPhysicalIndex

1.3.6.1.4.1.9.9.359.1.1.4.1.3

EntPhysicalIndexOrZeroThis textual convention is an extension of entPhysicalIndex. If non-zero, the object is an entPhysicalIndex. If zero, no appropriate entPhysicalIndex exists. Any additional semantics are object specific. (0..2147483647) · Integer32

When its value is not 0, it represents entPhysicalIndex for the physical entity which is using up license/licenses. When it is 0, it represents all entities (most likly non- physical) which do not have implementation in the entity MIB (RFC 2737).

celInUseLicenseDescr

1.3.6.1.4.1.9.9.359.1.1.4.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

A textual representation of the licensable feature. Value contained in this object is optional, and if not used, it should be zero length string.

celInUseLicenses

1.3.6.1.4.1.9.9.359.1.1.4.1.5

Gauge32 (1..65535)

Number of licenses of type celInUseLicenseType being used by this physical entity (represented by entPhysicalIndex) at this time. These licenses are obtained from the license pool represented by the table celPoolLicenseTable. Therefore, the value of the object celPoolLicensesInUse, corresponding to relevant license and the vendor-specific hardware type, increases or decreases when the value of this object increases or decreases.

celNeededLicenses

1.3.6.1.4.1.9.9.359.1.1.4.1.6

Gauge32 (1..65535)

Number of licenses of type celInUseLicenseType required by this entity (physical or otherwise) at this time to perform the desired services. When this number is more than celInUseLicenses, a shortfall of licenses is indicated. In this case, the object celOperationExpiryTmStamp specifies until how long such condition can continue.

celOperationExpiryTmStamp

1.3.6.1.4.1.9.9.359.1.1.4.1.7

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The use of this object is implementation specific. This time-stamp indicates that the physical entity's operation will not continue beyond this time, since for this particular entity (physical or otherwise), celNeededLicenses exceeds celInUseLicenses. Under these conditions, user is expected to install sufficient number of licenses, before this time-stamp expires, to avoid interruption of the operation. No expiration is indicated by a value: Jan 1, 0000.

celPhysicallyProgLicenseTable

1.3.6.1.4.1.9.9.359.1.1.5

Index: celPhysicallyProgSlotNumber · celPhysicallyProgLicenseType

This table contains entries for those physical entities into which licenses have been physically programmed. Depending upon the implementation, this may involve programming the licenses into the non-volatile ram (NVRAM) of a physical entity, such as a service module. An entry in this table is automatically created for those entities which contain such licenses. This table exists independently of all previous tables described in this MIB. The following example illustrates the use of this table for a specific implementation: For a module, if the object celPhysicallyProgLicenseStatus has the value 'hasInstallableLic', it means that this module has never had its programmed licenses installed (or transferred) into any chassis, and therefore its license can be installed (or transferred) if needed. If installation (or transferring) of licenses (programmed on the entity) takes place, it results in incrementing the number of licenses in the license pool (object celPoolLicensesInstalled) for the vendor-specific hardware type corresponding to this module. Once the licenses from the module have been installed (or transferred) into the chassis, the value of the object celPhysicallyProgLicenseStatus changes to 'alreadyInstalled'. This prevents any re-installation or re-use of licenses. This example shows the usage of the module as a vehicle for installing (or transporting) licenses into the license pool.

celPhysicallyProgSlotNumber

1.3.6.1.4.1.9.9.359.1.1.5.1.1

Integer32 (0..65535)

A unique running value used as index into the table. When not 0, this index is interpreted as the slot number (within the chassis) containing the entity that is using licenses. If corresponding entPhysicalIndex (RFC 2737) exists for this slot, celPhysicallyProgEntIndex contains its value. When referring to a physical entity for which a slot is non meaningful, but entPhysicalIndex exists, this index has a value 0 and the object celPhysicallyProgEntIndex contains the corresponding value of entPhysicalIndex.

celPhysicallyProgLicenseType

1.3.6.1.4.1.9.9.359.1.1.5.1.2

LicenseType1 = unknown2 = none3 = reserved4 = singleService5 = multiService6 = channelization7 = ima8 = mfr9 = rateControl10 = multilink11 = pppThis defines a licenseable feature: unknown(1) The license type can not be determined. none(2) No license is granted for any licenseable feature/service. reserved(3) This is special restricted license. singleService(4) Only one of following services: ATM, FR (FrameRelay), or CES (Circuit emulation service). multiService(5) More than one of: ATM, FR, CES. channelization (6) Channelization. ima(7) Inverse multiplexing over ATM. mfr(8) Multilink Frame Relay. rateControl(9) Rate-Control (Cisco Foresight and/or ABR). multilink(10) Multilink features such as: Inverse Multiplexing over ATM (IMA), Multilink Frame Relay (MFR). ppp(11) Point-to-point protocols (PPP), such as: Multilink Point-to-point Protocol(MLPPP), PPP Multiplexing (PPPMux). · Integer32

This represents a programmed license type on this entity.

celPhysicallyProgEntIndex

1.3.6.1.4.1.9.9.359.1.1.5.1.3

EntPhysicalIndexOrZeroThis textual convention is an extension of entPhysicalIndex. If non-zero, the object is an entPhysicalIndex. If zero, no appropriate entPhysicalIndex exists. Any additional semantics are object specific. (0..2147483647) · Integer32

When its value is not 0, it represents entPhysicalIndex corresponding to slot for this entry. If entPhysicalIndex is not available, this object is set to 0.

celPhysicallyProgLicTypeDescr

1.3.6.1.4.1.9.9.359.1.1.5.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

A textual representation of the licensable feature. Value contained in this object is optional, and if not used, it should be zero length string.

celPhysicallyProgLicenses

1.3.6.1.4.1.9.9.359.1.1.5.1.5

Unsigned32 (1..65535)

Number of licenses of type celPhysicallyProgLicenseType programmed into this physical entity.

celPhysicallyProgLicenseStatus

1.3.6.1.4.1.9.9.359.1.1.5.1.6

INTEGER1 = unknown2 = noInstallableLic3 = hasInstallableLic4 = alreadyInstalled · Integer32

Status of the programmed licenses of the type celPhysicallyProgLicenseType. Depending upon the implementation, all of the programmed licenses of different types on the physical entity may be installed (or transferred) into the license pool owned by the agent at the same time. In this case this object will have the same value for different license types(represented by the object celPhysicallyProgLicenseType). These comments also apply to the next two objects. Note that in this context, 'license installation' is akin to 'license transfer' from physical entity to license pool. The possible values are: unknown (1) noInstallableLic(2): Licenses not programmed on this entity. hasInstallableLic(3): The entity has usable licenses, which can be installed. alreadyInstalled(4): The programmed licenses on this entity have been already installed.

celPhysicallyProgLicInstSysName

1.3.6.1.4.1.9.9.359.1.1.5.1.7

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

A textual string containing the name of the system to which this entity's programmed licenses were installed. As an example of use of this object, it may be the sysName of node where the license installation/transfer took place. The usefulness of this object is to track the system where such operation was performed.

celPhysicallyProgLicInstSerNum

1.3.6.1.4.1.9.9.359.1.1.5.1.8

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

A textual string containing the serial number of the system to which this entity's programmed licenses were installed. For example, it may be the serial number of the chassis where installation took place.

celPhysicallyProgLicSerialNum

1.3.6.1.4.1.9.9.359.1.1.5.1.9

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

A textual representation of the license serial number, if any. Value contained by this object is optional, and if it is not used, it should be zero length string. Depending upon the implementation, the licenses of different types can be programmed into the physical entity in one shot and with same value of this object.

celPhysicallyProgLicUseTmStamp

1.3.6.1.4.1.9.9.359.1.1.5.1.10

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This represents the time-stamp when the object celPhysicallyProgLicInstSysName was written after licenses were installed to the corresponding system.

↑ To TOC