EZ5 MIB Catalog

CISCO-MPLS-TE-STD-EXT-MIB

2016-08-05

This MIB module contains Cisco specific managed object definitions for MPLS Traffic Engineering (TE), not contained in MPLS-TE-STD-MIB. The auto bandwidth feature enables MPLS TE Tunnels to adapt automatically their bandwidth to their actual load.

Download CISCO-MPLS-TE-STD-EXT-MIB.txt Open CISCO-MPLS-TE-STD-EXT-MIB.txt in a new tab

SCALARS (1) · TABLES (4) · TRAPS (5)

Scalars (1)

NameOID
cmplsTeLoadshareBalance1.3.6.1.4.1.9.9.738.1.5.1

Tables (4)

NameOID
cmplsTunnelAutoBWTable1.3.6.1.4.1.9.9.738.1.1
cmplsTeTunnelReasonTable1.3.6.1.4.1.9.9.738.1.2
cmplsTeTunnelFailReasonTable1.3.6.1.4.1.9.9.738.1.3
cmplsTunnelLoadshareTable1.3.6.1.4.1.9.9.738.1.4

Traps (5)

NameOID
cmplsTunnelPreempt1.3.6.1.4.1.9.9.738.0.1
cmplsTunnelInsuffBW1.3.6.1.4.1.9.9.738.0.2
cmplsTunnelReRoutePending1.3.6.1.4.1.9.9.738.0.3
cmplsTunnelReRoutePendingClear1.3.6.1.4.1.9.9.738.0.4
cmplsTunnelBringupFail1.3.6.1.4.1.9.9.738.0.5

END OF TOC

Scalar details

cmplsTeLoadshareBalance

1.3.6.1.4.1.9.9.738.1.5.1

INTEGER0 = equal1 = unequal · Integer32

This object indicates if the load-share balance is equal or unequal.

Table details

cmplsTunnelAutoBWTable

1.3.6.1.4.1.9.9.738.1.1

Index: mplsTunnelIndex · mplsTunnelInstance · mplsTunnelIngressLSRId · mplsTunnelEgressLSRId

This table is used in order to manage auto bandwidth data. This table is sparse dependent on the mplsTunnelTable. An entry in this table exists for each mplsTunnelEntry with a mplsTunnelRole of 'head' or 'headTail'. Each row contains auto-bandwidth data for the tunnel identified by the indexes defined later. An entry is created as soon as a 'head' or 'headTail' MPLS TE tunnel is configured in the system.

from MPLS-TE-STD-MIB

mplsTunnelIndex

MplsTunnelIndexA unique index into mplsTunnelTable. For tunnels signaled using RSVP, this value should correspond to the RSVP Tunnel ID used for the RSVP-TE session. (0..65535) · Unsigned32

Uniquely identifies a set of tunnel instances between a pair of ingress and egress LSRs. Managers should obtain new values for row creation in this table by reading mplsTunnelIndexNext. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the value signaled in the Tunnel Id of the Session object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the value signaled in the LSP ID.

mplsTunnelInstance

MplsTunnelInstanceIndexThe tunnel entry with instance index 0 should refer to the configured tunnel interface (if one exists). Values greater than 0, but less than or equal to 65535, should be used to indicate signaled (or backup) tunnel LSP instances. For tunnel LSPs signaled using RSVP, this value should correspond to the RSVP LSP ID used for the RSVP-TE LSP. Values greater than 65535 apply to FRR detour instances. (0 | 1..65535 | 65536..4294967295) · Unsigned32

Uniquely identifies a particular instance of a tunnel between a pair of ingress and egress LSRs. It is useful to identify multiple instances of tunnels for the purposes of backup and parallel tunnels. When the MPLS signaling protocol is rsvp(2) this value SHOULD be equal to the LSP Id of the Sender Template object. When the signaling protocol is crldp(3) there is no equivalent signaling object.

mplsTunnelIngressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Reference: 1. RSVP-TE: Extensions to RSVP for LSP Tunnels, Awduche et al, RFC 3209, December 2001 2. Constraint-Based LSP Setup using LDP, Jamoussi (Editor), RFC 3212, January 2002

Identity of the ingress LSR associated with this tunnel instance. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the Tunnel Sender Address in the Sender Template object and MAY be equal to the Extended Tunnel Id field in the SESSION object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the Ingress LSR Router ID field in the LSPID TLV object.

mplsTunnelEgressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Identity of the egress LSR associated with this tunnel instance.

cmplsTunnelAutoBWStatus

1.3.6.1.4.1.9.9.738.1.1.1.1

INTEGER1 = autoBWDisabled2 = autoBWEnabled3 = autoBWCollectOnlyMode · Integer32

This object indicates the operational status [or mode] of the auto bandwidth algorithm: - autoBWDisabled: The auto-bandwidth algorithm is not running; - autoBWEnabled: The auto-bandwidth algorithm is running; - autoBWCollectOnlyMode: The auto-bandwidth algorithm is running, but the bandwidth applications are disabled;

cmplsTunnelAutoBWMin

1.3.6.1.4.1.9.9.738.1.1.1.2

Unsigned32 · kbps

This object specifies the minimum bandwidth that the auto-bandwidth algorithm can apply to a tunnel when the adjustment threshold is overcome. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWMax

1.3.6.1.4.1.9.9.738.1.1.1.3

Unsigned32 · kbps

This object specifies the maximum bandwidth that the auto-bandwidth algorithm can apply to a tunnel when the adjustment threshold is overcome. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWAdjThreshPercs

1.3.6.1.4.1.9.9.738.1.1.1.4

CmplsTunnelBWPercentA fraction of the bandwidth expressed in percentage. (0..100) · Unsigned32 · hint d

This object specifies the adjustment threshold percentage that needs to be overcome in order to trigger a new bandwidth application. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWAdjThreshBW

1.3.6.1.4.1.9.9.738.1.1.1.5

Unsigned32 · kbps

This object specifies the adjustment threshold bandwidth that needs to be overcome in order to trigger a new bandwidth application. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWOverflowThreshPercs

1.3.6.1.4.1.9.9.738.1.1.1.6

CmplsTunnelBWPercentA fraction of the bandwidth expressed in percentage. (0..100) · Unsigned32 · hint d

This object specifies the adjustment threshold percentage that needs to be overcome in order to trigger an overflow occurrence. If the application period has not completed when a cmplsTunnelAutoBWOverflowLimit overflow has occurred, a new bandwidth will be applied. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWOverflowThreshBW

1.3.6.1.4.1.9.9.738.1.1.1.7

Unsigned32 · kbps

This object specifies the adjustment threshold bandwidth that needs to be overcome in order to trigger an overflow occurrence. If the application period has not completed when a cmplsTunnelAutoBWOverflowLimit overflow has occurred, a new bandwidth will be applied. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWOverflowLimit

1.3.6.1.4.1.9.9.738.1.1.1.8

Unsigned32

This object specifies the number of consecutive collections exceeding overflow threshold. If the application period has not completed when a cmplsTunnelAutoBWOverflowLimit overflow has occurred, a new bandwidth will be applied. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWUnderflowThreshPercs

1.3.6.1.4.1.9.9.738.1.1.1.9

CmplsTunnelBWPercentA fraction of the bandwidth expressed in percentage. (0..100) · Unsigned32 · hint d

This object specifies the adjustment threshold percentage that needs to be overcome in order to trigger an underflow occurrence. If the application period has not completed when a cmplsTunnelAutoBWUnderflowLimit underflow has occurred, a new bandwidth will be applied. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWUnderflowThreshBW

1.3.6.1.4.1.9.9.738.1.1.1.10

Unsigned32 · kbps

This object specifies the adjustment threshold bandwidth that needs to be overcome in order to trigger an underflow occurrence. If the application period has not completed when a cmplsTunnelAutoBWUnderflowLimit underflow has occurred, a new bandwidth will be applied. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWUnderflowLimit

1.3.6.1.4.1.9.9.738.1.1.1.11

Unsigned32

This object specifies the number of consecutive collections under the underflow threshold. If the application period has not completed when a cmplsTunnelAutoBWUnderflowLimit underflow has occurred, a new bandwidth will be applied. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWApplicationFrequency

1.3.6.1.4.1.9.9.738.1.1.1.12

Unsigned32 · seconds

This object specifies the bandwidth application period. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWCollectionFrequency

1.3.6.1.4.1.9.9.738.1.1.1.13

Unsigned32 · seconds

This object specifies the sampling period for data rates. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWLastAppliedBW

1.3.6.1.4.1.9.9.738.1.1.1.14

Unsigned32 · kbps

This object indicates the last bandwidth applied by the auto-bandwidth algorithm. It will be set to zero if no bandwidth has been applied yet. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWApplications

1.3.6.1.4.1.9.9.738.1.1.1.15

Counter32

This object indicates the number of auto bandwidths applied. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWLastApplicationTrigger

1.3.6.1.4.1.9.9.738.1.1.1.16

INTEGER1 = applicationNone2 = applicationPeriodic3 = applicationManual4 = applicationOverflow5 = applicationUnderflow · Integer32

This object indicates the trigger reason for the last bandwidth application. If mplsTunnelInstance is zero this object will be set to 'applicationNone'. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWOverflowApplications

1.3.6.1.4.1.9.9.738.1.1.1.17

Counter32

This object indicates the number of bandwidth applications due to overflow occurrences. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWOverflowOccurrences

1.3.6.1.4.1.9.9.738.1.1.1.18

Counter32

This object indicates the number of overflow occurrences since last application period. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWUnderflowApplications

1.3.6.1.4.1.9.9.738.1.1.1.19

Counter32

This object indicates the number of bandwidth applications due to underflow occurrences. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWUnderflowOccurrences

1.3.6.1.4.1.9.9.738.1.1.1.20

Counter32

This object indicates the number of underflow occurrences since last application period. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWUnderflowHighestBW

1.3.6.1.4.1.9.9.738.1.1.1.21

Gauge32 · kbps

This object indicates the highest sample collected during an underflow sequence. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWRequested

1.3.6.1.4.1.9.9.738.1.1.1.22

Unsigned32 · kpbs

This object indicates the bandwidth requested by the auto-bandwidth algorithm. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWSignaled

1.3.6.1.4.1.9.9.738.1.1.1.23

Unsigned32 · kpbs

This object indicates the bandwidth signaled by the auto-bandwidth algorithm. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWCollectOnlyRequested

1.3.6.1.4.1.9.9.738.1.1.1.24

Unsigned32 · kpbs

This object indicates the bandwidth that would have been requested by the auto-bandwidth algorithm if the auto-bandwidth functionality was enabled. If the collect only mode is enabled, the bandwidth change request will not be executed. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWHighest

1.3.6.1.4.1.9.9.738.1.1.1.25

Unsigned32 · kpbs

This object indicates the highest bandwidth sampled by the auto-bandwidth algorithm. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWCollectedSamples

1.3.6.1.4.1.9.9.738.1.1.1.26

Counter32

This object indicates the samples collected since the last auto-bandwidth application. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWJitter

1.3.6.1.4.1.9.9.738.1.1.1.27

Unsigned32

This object indicates the auto-bandwidth application jitter. Jitter is the extra time to be added to the application interval the first time the auto bandwidth is applied. If mplsTunnelInstance is zero this object will be set to zero. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTunnelAutoBWAppRejectReason

1.3.6.1.4.1.9.9.738.1.1.1.28

INTEGER1 = applicationAllowed2 = autoBWDisabled3 = tunnelIsDown4 = tunnelIsFRR5 = tunnelIsBackup6 = tunnelIsLockDown · Integer32

This object indicates the reason for the bandwidth application rejection. This object value is not aplicable if cmplsTunnelAutoBWStatus is 'autoBWDisabled'.

cmplsTeTunnelReasonTable

1.3.6.1.4.1.9.9.738.1.2

Index: mplsTunnelIndex · mplsTunnelInstance · mplsTunnelIngressLSRId · mplsTunnelEgressLSRId

This table is used in order to indicate the causes for the notifications.

from MPLS-TE-STD-MIB

mplsTunnelIndex

MplsTunnelIndexA unique index into mplsTunnelTable. For tunnels signaled using RSVP, this value should correspond to the RSVP Tunnel ID used for the RSVP-TE session. (0..65535) · Unsigned32

Uniquely identifies a set of tunnel instances between a pair of ingress and egress LSRs. Managers should obtain new values for row creation in this table by reading mplsTunnelIndexNext. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the value signaled in the Tunnel Id of the Session object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the value signaled in the LSP ID.

mplsTunnelInstance

MplsTunnelInstanceIndexThe tunnel entry with instance index 0 should refer to the configured tunnel interface (if one exists). Values greater than 0, but less than or equal to 65535, should be used to indicate signaled (or backup) tunnel LSP instances. For tunnel LSPs signaled using RSVP, this value should correspond to the RSVP LSP ID used for the RSVP-TE LSP. Values greater than 65535 apply to FRR detour instances. (0 | 1..65535 | 65536..4294967295) · Unsigned32

Uniquely identifies a particular instance of a tunnel between a pair of ingress and egress LSRs. It is useful to identify multiple instances of tunnels for the purposes of backup and parallel tunnels. When the MPLS signaling protocol is rsvp(2) this value SHOULD be equal to the LSP Id of the Sender Template object. When the signaling protocol is crldp(3) there is no equivalent signaling object.

mplsTunnelIngressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Reference: 1. RSVP-TE: Extensions to RSVP for LSP Tunnels, Awduche et al, RFC 3209, December 2001 2. Constraint-Based LSP Setup using LDP, Jamoussi (Editor), RFC 3212, January 2002

Identity of the ingress LSR associated with this tunnel instance. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the Tunnel Sender Address in the Sender Template object and MAY be equal to the Extended Tunnel Id field in the SESSION object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the Ingress LSR Router ID field in the LSPID TLV object.

mplsTunnelEgressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Identity of the egress LSR associated with this tunnel instance.

cmplsTunnelReoptReason

1.3.6.1.4.1.9.9.738.1.2.1.1

INTEGER1 = unknown2 = periodicTimerExpiry3 = bandwidthCLIChange4 = bandwidthOverflow5 = bandwidthUnderflow6 = bandwidthAdjustment7 = fastReRoute8 = cliRequest9 = metricTypeChange10 = preferredPathExists11 = poSwitchoverTrigger12 = bandwidthChange13 = autoBandwidth14 = remergeError15 = dueToMaximumMetric16 = pathProtectionSwitchover17 = iEPEnableReoptimization18 = affinityPathVerificationFail19 = softPreemption20 = preferredTreeExists21 = costLimitPathVerificationFail22 = linkupReopt23 = iEPChange24 = poChange25 = destChange26 = bfdSessionTypeChange · Integer32

This object indicates the reason of the tunnel reoptimization: - unknown: the reason is not known - periodicTimerExpiry: Periodic Reoptimization - bandwidthCLIChange: the tunnel bandwidth has been changed from CLI - bandwidthOverflow: an auto-bandwidth overflow occurred - bandwidthUnderflow: an auto-bandwidth underflow occured - bandwidthAdjustment: an auto-bandwidth application occured - fastReRoute: a fast re-route occured - cliRequest: User-triggerred - metricTypeChange: tunnel metric type has been changed from CLI - preferredPathExists: preferred-path-exists message received from a downstream node - poSwitchoverTrigger: User-requested path-option switchover - bandwidthChange: bandwidth change - autoBandwidth: Auto Bandwidth - remergeError: Remerge Error - dueToMaximumMetric: Reoptimization due to receiving an LSA with MAX metric - pathProtectionSwitchover: Path Protection Switchover - iEPEnableReoptimization: IEP Enable Reoptimization - affinityPathVerificationFail: Affinity path verification failure - softPreemption: soft preemption (see RFC 5712) - preferredTreeExists: preferred-tree-exists message received from a downstream node - costLimitPathVerificationFail: Cost Limit path verification failure - linkupReopt: link state up - iEPChangeReoptimization: inuse explicit-path change - poChangeReoptimization: inuse path-option change - bfdSessionTypeChange: a bfd session type change occured This object is intended to be included in the trap mplsTunnelReoptimized defined in MPLS-TE-STD-MIB.

cmplsTunnelInsuffBWFailedOperation

1.3.6.1.4.1.9.9.738.1.2.1.2

INTEGER1 = unknown2 = failedToSetup3 = failedToReoptimize · Integer32

This object indicates whether the tunnel could not be setup or reoptimized because of insufficient bandwidth: - unknown: the reason is not known - failedToSetup: insufficient bandwidth during initial setup - failedToReoptimize: insufficient bandwidth during reoptimization

cmplsTunnelPreemptionType

1.3.6.1.4.1.9.9.738.1.2.1.3

INTEGER1 = unknown2 = hardPreemption3 = softPreemption4 = frrSoftPreemption · Integer32

This object indicates LSP Preemption type of this LSP: - unknown: the type is not known - hardPreemption: the preempted LSP resources are freed immediately; the LSP is broken immediately and the traffic is disrupted. - softPreemption: the resources release pending on the reoptimization of this LSP. The head of the LSP reroutes the traffic before the LSP is broken. - frrSoftPreemption: similar to softPreemption. In this case the traffic of the soft preempted LSP is switched to the backup. See: Farrel, A., Interim Report on MPLS Pre-emption, draft-farrel-mpls-preemption-interim-00.txt, work in progress

cmplsTunnelPreemptionLinkAddrType

1.3.6.1.4.1.9.9.738.1.2.1.4

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the address type of the link where the preemption occurs - another, higher priority LSP is being admitted on this link and there is not enough bandwidth for it causing this LSP to be preempted (removed) from this link: - unknown: the object cmplsTunnelPreemptionLinkAddr does not contain any address - ipv4: the object cmplsTunnelPreemptionLinkAddr contains the IPv4 address - ipv6: the object cmplsTunnelPreemptionLinkAddr contains the IPv6 address

cmplsTunnelPreemptionLinkAddr

1.3.6.1.4.1.9.9.738.1.2.1.5

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates the address of the link where the preemption occurs - another, higher priority LSP is being admitted on this link and there is not enough bandwidth for it causing this LSP to be preempted (removed) from this link.

cmplsTunnelReRoutePendingClearReason

1.3.6.1.4.1.9.9.738.1.2.1.6

INTEGER1 = unknown2 = reoptimized3 = reinstated · Integer32

This object indicates the reason why the tunnel is not longer in the reroute pending state: - unknown: the reason is unknown - reoptimized: the tunnel has been reoptimized - reinstated: the tunnel has been reinstated

cmplsTeTunnelFailReasonTable

1.3.6.1.4.1.9.9.738.1.3

Index: mplsTunnelIndex · mplsTunnelInstance · mplsTunnelIngressLSRId · mplsTunnelEgressLSRId · mplsTunnelARHopListIndex

This table is used in order to indicate the causes for the MPLS TE tunnel failure notifications.

from MPLS-TE-STD-MIB

mplsTunnelIndex

MplsTunnelIndexA unique index into mplsTunnelTable. For tunnels signaled using RSVP, this value should correspond to the RSVP Tunnel ID used for the RSVP-TE session. (0..65535) · Unsigned32

Uniquely identifies a set of tunnel instances between a pair of ingress and egress LSRs. Managers should obtain new values for row creation in this table by reading mplsTunnelIndexNext. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the value signaled in the Tunnel Id of the Session object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the value signaled in the LSP ID.

mplsTunnelInstance

MplsTunnelInstanceIndexThe tunnel entry with instance index 0 should refer to the configured tunnel interface (if one exists). Values greater than 0, but less than or equal to 65535, should be used to indicate signaled (or backup) tunnel LSP instances. For tunnel LSPs signaled using RSVP, this value should correspond to the RSVP LSP ID used for the RSVP-TE LSP. Values greater than 65535 apply to FRR detour instances. (0 | 1..65535 | 65536..4294967295) · Unsigned32

Uniquely identifies a particular instance of a tunnel between a pair of ingress and egress LSRs. It is useful to identify multiple instances of tunnels for the purposes of backup and parallel tunnels. When the MPLS signaling protocol is rsvp(2) this value SHOULD be equal to the LSP Id of the Sender Template object. When the signaling protocol is crldp(3) there is no equivalent signaling object.

mplsTunnelIngressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Reference: 1. RSVP-TE: Extensions to RSVP for LSP Tunnels, Awduche et al, RFC 3209, December 2001 2. Constraint-Based LSP Setup using LDP, Jamoussi (Editor), RFC 3212, January 2002

Identity of the ingress LSR associated with this tunnel instance. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the Tunnel Sender Address in the Sender Template object and MAY be equal to the Extended Tunnel Id field in the SESSION object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the Ingress LSR Router ID field in the LSPID TLV object.

mplsTunnelEgressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Identity of the egress LSR associated with this tunnel instance.

mplsTunnelARHopListIndex

MplsPathIndexA unique value to index (by Path number) an entry in a table. (1..4294967295) · Unsigned32

Primary index into this table identifying a particular recorded hop list.

cmplsTeFailReasonType

1.3.6.1.4.1.9.9.738.1.3.1.1

INTEGER1 = unknown2 = bfd3 = generalTe · Integer32

This object indicates the type (category) of fail reason.

cmplsTeFailReason

1.3.6.1.4.1.9.9.738.1.3.1.2

Integer32

This object indicates specific fail reason value based on the fail reason type indicated by cmplsTeFailReasonType. Fail Reason Type Fail Reason Value Type ---------------- ----------------------- bfd(2) CiscoBfdDiag generalTe(3) CmplsTeTunnelDiag This object is replaced by cmplsTeFailReasonRev

cmplsTeFailReasonRev

1.3.6.1.4.1.9.9.738.1.3.1.3

INTEGER0 = noDiagnostic1 = controlDetectionTimeExpired2 = echoFunctionFailed3 = neighborSignaledSessionDown4 = forwardingPlaneReset5 = pathDown6 = concatenatedPathDown7 = administrativelyDown8 = reverseConcatenatedPathDown9 = unknown21 = bfdSessionBringupTimeout · Integer32

This object provieds more deails on fail reason. cmplsTeFailReason values for reasonType bfd(2) mirror the CiscoBfdDiag values: - noDiagnostic No bfd diagnostic info - controlDetectionTimeExpired Control Detection Timer Expired - echoFunctionFailed Echo Function Failed - neighborSignaledSessionDown Neighbor Signaled Session Down - forwardingPlaneReset Forwarding Plane Reset - pathDown Path Down - concatenatedPathDown Concatenated Path Down - administrativelyDown Administratively Down - reverseConcatenatedPathDown Reverse Concatenated Path Down - unknown Unknown error code cmplsTeFailReason values for reasonType generalTe(3) mirror the CmplsTeTunnelDiag values: - unknown Unknown error code - bfdSessionBringupTimeout bfd session failed to come up before timeout

cmplsTunnelLoadshareTable

1.3.6.1.4.1.9.9.738.1.4

Index: mplsTunnelIndex · mplsTunnelInstance · mplsTunnelIngressLSRId · mplsTunnelEgressLSRId

This table is used in order to manage load data.

from MPLS-TE-STD-MIB

mplsTunnelIndex

MplsTunnelIndexA unique index into mplsTunnelTable. For tunnels signaled using RSVP, this value should correspond to the RSVP Tunnel ID used for the RSVP-TE session. (0..65535) · Unsigned32

Uniquely identifies a set of tunnel instances between a pair of ingress and egress LSRs. Managers should obtain new values for row creation in this table by reading mplsTunnelIndexNext. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the value signaled in the Tunnel Id of the Session object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the value signaled in the LSP ID.

mplsTunnelInstance

MplsTunnelInstanceIndexThe tunnel entry with instance index 0 should refer to the configured tunnel interface (if one exists). Values greater than 0, but less than or equal to 65535, should be used to indicate signaled (or backup) tunnel LSP instances. For tunnel LSPs signaled using RSVP, this value should correspond to the RSVP LSP ID used for the RSVP-TE LSP. Values greater than 65535 apply to FRR detour instances. (0 | 1..65535 | 65536..4294967295) · Unsigned32

Uniquely identifies a particular instance of a tunnel between a pair of ingress and egress LSRs. It is useful to identify multiple instances of tunnels for the purposes of backup and parallel tunnels. When the MPLS signaling protocol is rsvp(2) this value SHOULD be equal to the LSP Id of the Sender Template object. When the signaling protocol is crldp(3) there is no equivalent signaling object.

mplsTunnelIngressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Reference: 1. RSVP-TE: Extensions to RSVP for LSP Tunnels, Awduche et al, RFC 3209, December 2001 2. Constraint-Based LSP Setup using LDP, Jamoussi (Editor), RFC 3212, January 2002

Identity of the ingress LSR associated with this tunnel instance. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the Tunnel Sender Address in the Sender Template object and MAY be equal to the Extended Tunnel Id field in the SESSION object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the Ingress LSR Router ID field in the LSPID TLV object.

mplsTunnelEgressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Identity of the egress LSR associated with this tunnel instance.

cmplsTunnelLoadShare

1.3.6.1.4.1.9.9.738.1.4.1.1

Unsigned32

This object indicates the Load-share as defined by the bandwidth attribute (default) or explicitly configured using the load-share command under tunnel configuration.

Trap details

cmplsTunnelPreempt

1.3.6.1.4.1.9.9.738.0.1

This notification is generated when a MPLS TE tunnel is preempted.

mplsTunnelAdminStatus

1.3.6.1.2.1.10.166.3.2.2.1.34

INTEGER1 = up2 = down3 = testing · Integer32

Indicates the desired operational status of this tunnel.

mplsTunnelOperStatus

1.3.6.1.2.1.10.166.3.2.2.1.35

INTEGER1 = up2 = down3 = testing4 = unknown5 = dormant6 = notPresent7 = lowerLayerDown · Integer32

Indicates the actual operational status of this tunnel, which is typically but not limited to, a function of the state of individual segments of this tunnel.

mplsTunnelName

1.3.6.1.2.1.10.166.3.2.2.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Reference: RFC 2863 - The Interfaces Group MIB, McCloghrie, K., and F. Kastenholtz, June 2000

The canonical name assigned to the tunnel. This name can be used to refer to the tunnel on the LSR's console port. If mplsTunnelIsIf is set to true then the ifName of the interface corresponding to this tunnel should have a value equal to mplsTunnelName. Also see the description of ifName in RFC 2863.

cmplsTunnelPreemptionType

1.3.6.1.4.1.9.9.738.1.2.1.3

INTEGER1 = unknown2 = hardPreemption3 = softPreemption4 = frrSoftPreemption · Integer32

This object indicates LSP Preemption type of this LSP: - unknown: the type is not known - hardPreemption: the preempted LSP resources are freed immediately; the LSP is broken immediately and the traffic is disrupted. - softPreemption: the resources release pending on the reoptimization of this LSP. The head of the LSP reroutes the traffic before the LSP is broken. - frrSoftPreemption: similar to softPreemption. In this case the traffic of the soft preempted LSP is switched to the backup. See: Farrel, A., Interim Report on MPLS Pre-emption, draft-farrel-mpls-preemption-interim-00.txt, work in progress

cmplsTunnelPreemptionLinkAddrType

1.3.6.1.4.1.9.9.738.1.2.1.4

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the address type of the link where the preemption occurs - another, higher priority LSP is being admitted on this link and there is not enough bandwidth for it causing this LSP to be preempted (removed) from this link: - unknown: the object cmplsTunnelPreemptionLinkAddr does not contain any address - ipv4: the object cmplsTunnelPreemptionLinkAddr contains the IPv4 address - ipv6: the object cmplsTunnelPreemptionLinkAddr contains the IPv6 address

cmplsTunnelPreemptionLinkAddr

1.3.6.1.4.1.9.9.738.1.2.1.5

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates the address of the link where the preemption occurs - another, higher priority LSP is being admitted on this link and there is not enough bandwidth for it causing this LSP to be preempted (removed) from this link.

cmplsTunnelInsuffBW

1.3.6.1.4.1.9.9.738.0.2

This notification is generated when a MPLS TE tunnel could not be setup or reoptimized.

mplsTunnelAdminStatus

1.3.6.1.2.1.10.166.3.2.2.1.34

INTEGER1 = up2 = down3 = testing · Integer32

Indicates the desired operational status of this tunnel.

mplsTunnelOperStatus

1.3.6.1.2.1.10.166.3.2.2.1.35

INTEGER1 = up2 = down3 = testing4 = unknown5 = dormant6 = notPresent7 = lowerLayerDown · Integer32

Indicates the actual operational status of this tunnel, which is typically but not limited to, a function of the state of individual segments of this tunnel.

mplsTunnelName

1.3.6.1.2.1.10.166.3.2.2.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Reference: RFC 2863 - The Interfaces Group MIB, McCloghrie, K., and F. Kastenholtz, June 2000

The canonical name assigned to the tunnel. This name can be used to refer to the tunnel on the LSR's console port. If mplsTunnelIsIf is set to true then the ifName of the interface corresponding to this tunnel should have a value equal to mplsTunnelName. Also see the description of ifName in RFC 2863.

cmplsTunnelInsuffBWFailedOperation

1.3.6.1.4.1.9.9.738.1.2.1.2

INTEGER1 = unknown2 = failedToSetup3 = failedToReoptimize · Integer32

This object indicates whether the tunnel could not be setup or reoptimized because of insufficient bandwidth: - unknown: the reason is not known - failedToSetup: insufficient bandwidth during initial setup - failedToReoptimize: insufficient bandwidth during reoptimization

cmplsTunnelReRoutePending

1.3.6.1.4.1.9.9.738.0.3

This notification is generated when re-route is required for the tunnel.

mplsTunnelAdminStatus

1.3.6.1.2.1.10.166.3.2.2.1.34

INTEGER1 = up2 = down3 = testing · Integer32

Indicates the desired operational status of this tunnel.

mplsTunnelOperStatus

1.3.6.1.2.1.10.166.3.2.2.1.35

INTEGER1 = up2 = down3 = testing4 = unknown5 = dormant6 = notPresent7 = lowerLayerDown · Integer32

Indicates the actual operational status of this tunnel, which is typically but not limited to, a function of the state of individual segments of this tunnel.

mplsTunnelName

1.3.6.1.2.1.10.166.3.2.2.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Reference: RFC 2863 - The Interfaces Group MIB, McCloghrie, K., and F. Kastenholtz, June 2000

The canonical name assigned to the tunnel. This name can be used to refer to the tunnel on the LSR's console port. If mplsTunnelIsIf is set to true then the ifName of the interface corresponding to this tunnel should have a value equal to mplsTunnelName. Also see the description of ifName in RFC 2863.

cmplsTunnelReRoutePendingClear

1.3.6.1.4.1.9.9.738.0.4

This notification is generated when tunnel no longer needs to be re-routed.

mplsTunnelAdminStatus

1.3.6.1.2.1.10.166.3.2.2.1.34

INTEGER1 = up2 = down3 = testing · Integer32

Indicates the desired operational status of this tunnel.

mplsTunnelOperStatus

1.3.6.1.2.1.10.166.3.2.2.1.35

INTEGER1 = up2 = down3 = testing4 = unknown5 = dormant6 = notPresent7 = lowerLayerDown · Integer32

Indicates the actual operational status of this tunnel, which is typically but not limited to, a function of the state of individual segments of this tunnel.

mplsTunnelName

1.3.6.1.2.1.10.166.3.2.2.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Reference: RFC 2863 - The Interfaces Group MIB, McCloghrie, K., and F. Kastenholtz, June 2000

The canonical name assigned to the tunnel. This name can be used to refer to the tunnel on the LSR's console port. If mplsTunnelIsIf is set to true then the ifName of the interface corresponding to this tunnel should have a value equal to mplsTunnelName. Also see the description of ifName in RFC 2863.

cmplsTunnelReRoutePendingClearReason

1.3.6.1.4.1.9.9.738.1.2.1.6

INTEGER1 = unknown2 = reoptimized3 = reinstated · Integer32

This object indicates the reason why the tunnel is not longer in the reroute pending state: - unknown: the reason is unknown - reoptimized: the tunnel has been reoptimized - reinstated: the tunnel has been reinstated

cmplsTunnelBringupFail

1.3.6.1.4.1.9.9.738.0.5

This notification is generated when MPLS TE tunnel failed to come up

mplsTunnelName

1.3.6.1.2.1.10.166.3.2.2.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Reference: RFC 2863 - The Interfaces Group MIB, McCloghrie, K., and F. Kastenholtz, June 2000

The canonical name assigned to the tunnel. This name can be used to refer to the tunnel on the LSR's console port. If mplsTunnelIsIf is set to true then the ifName of the interface corresponding to this tunnel should have a value equal to mplsTunnelName. Also see the description of ifName in RFC 2863.

cmplsTeFailReasonType

1.3.6.1.4.1.9.9.738.1.3.1.1

INTEGER1 = unknown2 = bfd3 = generalTe · Integer32

This object indicates the type (category) of fail reason.

↑ To TOC