A MIB module for extending the POWER-ETHERNET-MIB (RFC3621) to add objects which provide additional management information about Power Sourcing Equipment (PSE) not available in POWER-ETHERNET-MIB.
Glossary
Power Sourcing Equipment (PSE) These are devices supplying electrical power to other equipment. They are, for example, inline power switches, inline power daughterboards and power patch panels.
Powered Device (PD) These are devices receiving their electrical power supply from Power Sourcing Equipment. They are, for example, IP telephones and wireless access points or bridges.
This object indicates the default inline power allocation per port. This is a global configuration parameter that applies to all inline power capable ports in the system.
The system must consider this object as well as the per port configuration object, cpeExtPsePortPwrMax, when determining how much power to allocate to a port. The system will use the lower of the two numbers.
This object indicates the total number of the powered devices with any power classifications in the system.
Classification is a way to tag different terminals on the Power over LAN network according to their power consumption. Devices such as IP telephones, WLAN access points and others, will be classified according to their power requirements.
cpeExtPolicingNotifEnable
1.3.6.1.4.1.9.9.402.1.5
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object is used to enable/disable the the cpeExtPolicingNotif notification.
cpeExtPowerPriorityEnable
1.3.6.1.4.1.9.9.402.1.6
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object is the global control of the power priority feature on the device. 'true' indicates that the power priority feature is globally enabled. 'false' indicates that the power priority feature is globally disabled.
This variable uniquely identifies the group containing the port to which a power Ethernet PSE is connected. Group means box in the stack, module in a rack and the value 1 MUST be used for non-modular devices. Furthermore, the same value MUST be used in this variable, pethMainPseGroupIndex, and pethNotificationControlGroupIndex to refer to a given box in a stack or module in the rack.
pethPsePortIndex
Integer32 (1..2147483647)
This variable uniquely identifies the power Ethernet PSE port within group pethPsePortGroupIndex to which the power Ethernet PSE entry is connected.
This object is an extension of the pethPsePortAdminEnable object from RFC3621. It allows the user to be more specific when enabling the PSE functions. The states, 'auto', 'static' and 'limit' correspond to a value of 'true' for the pethPsePortAdminEnable object. The state 'disable' corresponds to a value of 'false' for the pethPsePortAdminEnable object.
Setting this value to 'auto' enables Powered Device discovery on the interface and the amount of power allocated depends on the Powered Device discovered. If pethPsePortAdminEnable was 'false' prior to this set operation, then it will become 'true'.
Setting this value to 'static' will also enable Powered Device discovery. However, this is different from 'auto' in that the amount of power is pre-allocated based on the configuration on the Power Sourcing Equipment. If pethPsePortAdminEnable was 'false' prior to this set operation, then it will become 'true'.
Setting this value to 'limit' enables Powered Device discovery on the interface. The amount of power allocated depends on the Powered Device discovered and the value of cpeExtPsePortPwrMax. The lower value will be used. If pethPsePortAdminEnable was 'false' prior to this set operation, then it will become 'true'.
Setting this value to 'disable' disables the PSE functions. The pethPsePortAdminEnable object will adopt the value of 'false' if it was 'true' prior to this set operation. When setting the pethPsePortAdminEnable object to 'false' this object cpeExtPsePortEnable will adopt the value of 'disable'.
If cpeExtPsePortPolicingCapable of the PSE port, or cpeExtMainPsePwrMonitorCapable of the PSE port's main group, has the value of 'false', this object can only be set to 'auto', 'static' or 'disable'. Otherwise, this object can be set to 'auto', 'static', 'limit' or 'disable'.
This object indicates the discover mode used by the system to discover the PD.
A value of 'unknown' indicates that the discover mode on the interface is unknown.
A value of 'off' indicates that discovery is disabled on the interface.
A value of 'ieee' indicates that the discover mode on the interface is IEEE based.
A value of 'cisco' indicates that the discover mode on the interface is Cisco based.
A value of 'ieeeAndCisco' indicates that the discover mode on the interface is both IEEE and Cisco based.
cpeExtPsePortDeviceDetected
1.3.6.1.4.1.9.9.402.1.2.1.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates if a Powered Device (PD) has been detected on the interface.
A value of 'true' indicates that a PD has been detected on the interface.
A value of 'false' indicates that no PD has been detected on the interface.
cpeExtPsePortIeeePd
1.3.6.1.4.1.9.9.402.1.2.1.4
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates whether the Powered Device attached to the interface is an IEEE compliant Powered Device or not.
A value of 'true' indicates the attached Powered Device is an IEEE compliant Powered Device.
A value of 'false' indicates the attached Powered Device is not an IEEE compliant Powered Device. This also means that the value of the corresponding object from the pethPsePortTable, pethPsePortPowerClassifications is irrelevant.
cpeExtPsePortAdditionalStatus
1.3.6.1.4.1.9.9.402.1.2.1.5
BITS
This object is an extension of the pethPsePortDetectionStatus object from RFC3621 and provides additional status information.
deny: When set, the PD attached to the interface is being denied power due to insufficient power resources on the Power Sourcing Equipment.
overdraw: When set, the PD attached to the interface is being denied power because the PD is trying to consume more power than it has been configured to consume.
overdrawLog: When set, the PD attached to the interface is trying to consume more power than it has been configured to consume, but is not being denied power.
cpeExtPsePortPwrMax
1.3.6.1.4.1.9.9.402.1.2.1.6
Unsigned32 · milliwatts
This indicates the maximum amount of power that the PSE will make available to the PD connected to this interface.
cpeExtPsePortPwrAllocated
1.3.6.1.4.1.9.9.402.1.2.1.7
Unsigned32 · milliwatts
This object indicates the amount of power allocated from the PSE for the PD.
cpeExtPsePortPwrAvailable
1.3.6.1.4.1.9.9.402.1.2.1.8
Unsigned32 · milliwatts
This object indicates the amount of power available for the PD to use. This value may differ from the value cpeExtPsePortPwrAllocated due to the efficiency issues of delivering the power from the PSE to the PD.
When sufficient power is available to power a PD, this value should be equal to the lower of the two objects, cpeExtDefaultAllocation and cpeExtPsePortPwrMax.
cpeExtPsePortPwrConsumption
1.3.6.1.4.1.9.9.402.1.2.1.9
Unsigned32 · milliwatts
This indicates the actual power consumption of the PD connected to this interface. It may not necessarily be equal to the value of cpeExtPsePortPwrAvailable.
cpeExtPsePortMaxPwrDrawn
1.3.6.1.4.1.9.9.402.1.2.1.10
Unsigned32 · milliwatts
This indicates the maximum amount of power drawn by the PD connected to this interface, since it was powered on.
cpeExtPsePortEntPhyIndex
1.3.6.1.4.1.9.9.402.1.2.1.11
EntPhysicalIndexOrZeroThis textual convention is an extension of entPhysicalIndex. If non-zero, the object is an entPhysicalIndex. If zero, no appropriate entPhysicalIndex exists. Any additional semantics are object specific. (0..2147483647) · Integer32
Reference: RFC 2737, entPhysicalIndex.
The entPhysicalIndex value that uniquely identifies the PSE port. If the PSE port does not have a corresponding physical entry in entPhysicalTable or if the entPhysicalTable is not supported by the management system, this object has the value of zero.
cpeExtPsePortPolicingCapable
1.3.6.1.4.1.9.9.402.1.2.1.12
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates whether the PSE port hardware is capable of policing the port for proper power consumption based on the allocated value.
cpeExtPsePortPolicingEnable
1.3.6.1.4.1.9.9.402.1.2.1.13
INTEGER1 = on2 = off · Integer32
This object allows the user to turn on or turn off the power policing of the PSE port. If the instance value of cpeExtPsePortPolicingCapable is 'TRUE', the user is allowed to set this object to 'on' or 'off'. Otherwise, this object is read-only and always has the value of 'off'.
cpeExtPsePortPolicingAction
1.3.6.1.4.1.9.9.402.1.2.1.14
INTEGER1 = deny2 = logOnly · Integer32
This object specifies the power policing action that the device will take on this PSE port when the real-time power consumption exceeds its max power allocation if the value of cpeExtPsePortPolicingEnable is 'on'.
'deny' - the device will deny the power to
the PSE port
'logOnly' - the device will not deny the power
to the PSE port
cpeExtPsePortPwrManAlloc
1.3.6.1.4.1.9.9.402.1.2.1.15
Unsigned32 · milliwatts
This object specifies the manual power allocation that the PSE will allocate to the PD connected to this interface regardless of the amount requested via CDP or IEEE.
Setting this object value to zero disables the manual power allocation.
Warning: Misconfiguring this manual power allocation may cause damage to the system and void the warranty. Take precautions not to oversubscribe the power supply.
cpeExtPsePortCapabilities
1.3.6.1.4.1.9.9.402.1.2.1.16
BITS
This object indicates the PSE functionality that this port supports.
If the 'policing' BIT is set, then this PSE port is capable of policing the port for proper power consumption based on the allocated value.
If the 'poePlus' BIT is set, then this PSE port supports PoE Plus functions.
cpeExtMainPseTable
1.3.6.1.4.1.9.9.402.1.3
Index: pethMainPseGroupIndex
Reference: RFC3621, pethMainPseTable
This table contains the additional information for the main PSE group in pethMainPseTable.
This variable uniquely identifies the group to which power Ethernet PSE is connected. Group means (box in the stack, module in a rack) and the value 1 MUST be used for non-modular devices. Furthermore, the same value MUST be used in this variable, pethPsePortGroupIndex, and pethNotificationControlGroupIndex to refer to a given box in a stack or module in a rack.
cpeExtMainPseEntPhyIndex
1.3.6.1.4.1.9.9.402.1.3.1.1
EntPhysicalIndexOrZeroThis textual convention is an extension of entPhysicalIndex. If non-zero, the object is an entPhysicalIndex. If zero, no appropriate entPhysicalIndex exists. Any additional semantics are object specific. (0..2147483647) · Integer32
Reference: RFC 2737, entPhysicalIndex.
The entPhysicalIndex value that uniquely identifies the main PSE group. If the main PSE group does not have a corresponding physical entry in entPhysicalTable or if the entPhysicalTable is not supported by the management system, then this object has the value of zero.
cpeExtMainPseDescr
1.3.6.1.4.1.9.9.402.1.3.1.2
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
A textual string containing information about the Power Source Equipment (PSE) group.
cpeExtMainPsePwrMonitorCapable
1.3.6.1.4.1.9.9.402.1.3.1.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates if the given group is capable of monitoring the power consumption of the interfaces that belong to the group. The value 'true' means that the group is capable. The value 'false' means that the group in not capable.
cpeExtMainPseUsedPower
1.3.6.1.4.1.9.9.402.1.3.1.4
Unsigned32 · miliwatts
This object indicates used power expressed in miliwatts.
cpeExtMainPseRemainingPower
1.3.6.1.4.1.9.9.402.1.3.1.5
Unsigned32 · miliwatts
This object indicates remaining power expressed in miliwatts, this parameter is calculated as pethMainPsePower minus cpeExtMainPseUsedPower.
The power classification as the index for the statistics information for powered devices.
A value of 'cisco' indicates that the powered devices are CISCO proprietary and their power classification does not fall into any class in IEEE specifications.
A value of 'class0' indicates that the power classification of the powered devices falls into class 0 in IEEE specifications.
A value of 'class1' indicates that the power classification of the powered devices falls into class 1 in IEEE specifications.
A value of 'class2' indicates that the power classification of the powered devices falls into class 2 in IEEE specifications.
A value of 'class3' indicates that the power classification of the powered devices falls into class 3 in IEEE specifications.
A value of 'class4' indicates that the power classification of the powered devices falls into class 4 in IEEE specifications.
cpeExtPdStatsDeviceCount
1.3.6.1.4.1.9.9.402.1.4.2.1.2
Unsigned32
This object indicates the count of the powered devices whose power classification falls into a specific value of cpeExtPdStatsIndex.
cpeExtPsePortLldpTable
1.3.6.1.4.1.9.9.402.1.7
Index: pethPsePortGroupIndex · pethPsePortIndex
A table provides the Link Layer Discovery Protocol (LLDP) based Data Link Layer (DLL) power classification characteristics of PSE ports and PDs attached to them.
This variable uniquely identifies the group containing the port to which a power Ethernet PSE is connected. Group means box in the stack, module in a rack and the value 1 MUST be used for non-modular devices. Furthermore, the same value MUST be used in this variable, pethMainPseGroupIndex, and pethNotificationControlGroupIndex to refer to a given box in a stack or module in the rack.
pethPsePortIndex
Integer32 (1..2147483647)
This variable uniquely identifies the power Ethernet PSE port within group pethPsePortGroupIndex to which the power Ethernet PSE entry is connected.
cpeExtPsePortLldpPwrType
1.3.6.1.4.1.9.9.402.1.7.1.1
CpeExtLldpPwrType1 = type1Pd2 = type1Pse3 = type2Pd4 = type2PseThe requested Data Terminal Equipment (DTE) Power via Media Dependent Interface (MDI) type based on Data Link Layer (DLL) power classification.
In Data Link Layer power classification, the PSE and PD perform power negotiation using the Link Layer Discovery Protocol (LLDP) as soon as the data link is established. It has finer power resolution than the Physical Layer power classification and has the ability for the PSE and PD to participate in dynamic power allocation wherein allocated power to the PD may change one or more times during PD operation.
'type1Pd' - A PD that advertises a power draw less than or
equal to 12.95 W (at the PD). 'type1Pse' - A PSE that is designed to support a Type 1 PD.
'type2Pd' - A PD that advertises a power draw greater than
12.95 W (at the PD).
'type2Pse - A PSE that is designed to support either a Type 1
or a Type 2 PD. · Integer32
The DTE Power via MDI type of the local system (PSE).
cpeExtPsePortLldpPdPwrType
1.3.6.1.4.1.9.9.402.1.7.1.2
CpeExtLldpPwrType1 = type1Pd2 = type1Pse3 = type2Pd4 = type2PseThe requested Data Terminal Equipment (DTE) Power via Media Dependent Interface (MDI) type based on Data Link Layer (DLL) power classification.
In Data Link Layer power classification, the PSE and PD perform power negotiation using the Link Layer Discovery Protocol (LLDP) as soon as the data link is established. It has finer power resolution than the Physical Layer power classification and has the ability for the PSE and PD to participate in dynamic power allocation wherein allocated power to the PD may change one or more times during PD operation.
'type1Pd' - A PD that advertises a power draw less than or
equal to 12.95 W (at the PD). 'type1Pse' - A PSE that is designed to support a Type 1 PD.
'type2Pd' - A PD that advertises a power draw greater than
12.95 W (at the PD).
'type2Pse - A PSE that is designed to support either a Type 1
or a Type 2 PD. · Integer32
The DTE Power via MDI type of the remote system (PD).
cpeExtPsePortLldpPwrSrc
1.3.6.1.4.1.9.9.402.1.7.1.3
CpeExtLldpPwrSrc1 = pseAndLocal2 = local3 = pse4 = backupSrc5 = primarySrc6 = unknownThe power source of the PD or PSE port which implements the LLDP based Data Link Layer power classification.
'pseAndLocal' - A PD powered both locally and by a PSE.
'local' - A PD powered locally only.
'pse' - A PD powered by a PSE only.
'backupSrc' - A PSE powered by a backup power source.
'primarySrc' - A PSE powered by its primary power source.
'unknown' - A PD or PSE where the power source is
unknown. · Integer32
The power source of the local system (PSE).
cpeExtPsePortLldpPdPwrSrc
1.3.6.1.4.1.9.9.402.1.7.1.4
CpeExtLldpPwrSrc1 = pseAndLocal2 = local3 = pse4 = backupSrc5 = primarySrc6 = unknownThe power source of the PD or PSE port which implements the LLDP based Data Link Layer power classification.
'pseAndLocal' - A PD powered both locally and by a PSE.
'local' - A PD powered locally only.
'pse' - A PD powered by a PSE only.
'backupSrc' - A PSE powered by a backup power source.
'primarySrc' - A PSE powered by its primary power source.
'unknown' - A PD or PSE where the power source is
unknown. · Integer32
The power source of the remote system (PD).
cpeExtPsePortLldpPwrPriority
1.3.6.1.4.1.9.9.402.1.7.1.5
CpeExtPwrPriority1 = critical2 = high3 = low4 = unknownThe power priority for the PD on the PSE port which implements the LLDP based Data Link Layer power classification.
'critical' - power priority is at critical level.
'high' - power priority is at high level.
'low' - power priority is at low level.
'unknown' - power priority level is unknown. · Integer32
The power priority of the local system (PSE).
cpeExtPsePortLldpPdPwrPriority
1.3.6.1.4.1.9.9.402.1.7.1.6
CpeExtPwrPriority1 = critical2 = high3 = low4 = unknownThe power priority for the PD on the PSE port which implements the LLDP based Data Link Layer power classification.
'critical' - power priority is at critical level.
'high' - power priority is at high level.
'low' - power priority is at low level.
'unknown' - power priority level is unknown. · Integer32
The power priority of the remote system (PD).
cpeExtPsePortLldpPwrReq
1.3.6.1.4.1.9.9.402.1.7.1.7
Unsigned32 · milliwatts
The requested PD power value that the local system (PSE) mirrors back to the remote system (PD).
cpeExtPsePortLldpPdPwrReq
1.3.6.1.4.1.9.9.402.1.7.1.8
Unsigned32 · milliwatts
The PD requested power value received from the remote system (PD).
cpeExtPsePortLldpPwrAlloc
1.3.6.1.4.1.9.9.402.1.7.1.9
Unsigned32 · milliwatts
The PSE allocated power value for the remote system (PD).
cpeExtPsePortLldpPdPwrAlloc
1.3.6.1.4.1.9.9.402.1.7.1.10
Unsigned32 · milliwatts
The PSE allocated power value received from the remote system (PD).
cpeExtPsePortLldpPwrClass
1.3.6.1.4.1.9.9.402.1.7.1.11
CpeExtLldpPwrClassOrZero0 = unknown1 = class02 = class13 = class24 = class35 = class4The power class of the PD or PSE port that implements the LLDP based Data Link Layer power classification
'unknown' - power classification of the powered devices is unknown.
'class0' - power classification of the powered devices is
class 0 in IEEE specifications.
'class1' - power classification of the powered devices is
class 1 in IEEE specifications.
'class2' - power classification of the powered devices is
class 2 in IEEE specifications.
'class3' - power classification of the powered devices is
class 3 in IEEE specifications.
'class4' - power classification of the powered devices is
class 4 in IEEE specifications. · Integer32
The PSE power classification sent to the remote PD via MDI TLV in LLDP Protocol.
cpeExtPsePortLldpPdPwrClass
1.3.6.1.4.1.9.9.402.1.7.1.12
CpeExtLldpPwrClassOrZero0 = unknown1 = class02 = class13 = class24 = class35 = class4The power class of the PD or PSE port that implements the LLDP based Data Link Layer power classification
'unknown' - power classification of the powered devices is unknown.
'class0' - power classification of the powered devices is
class 0 in IEEE specifications.
'class1' - power classification of the powered devices is
class 1 in IEEE specifications.
'class2' - power classification of the powered devices is
class 2 in IEEE specifications.
'class3' - power classification of the powered devices is
class 3 in IEEE specifications.
'class4' - power classification of the powered devices is
class 4 in IEEE specifications. · Integer32
This power classification received from the remote system (PD).
cpeExtPsePortLldpPdPwrSupport
1.3.6.1.4.1.9.9.402.1.7.1.13
BITS
This object indicates the power support mode received from the remote PD via MDI TLV in LLDP protocol.
'portClass' - This bit is set if the port is
operating as PSE. Otherwise, it is operating as PD.
'pseMdiPwrSupport' - This bit is set if power is supported in
MDI TLV.
'pseMdiPwrState' - This bit is set if power is enabled.
'psePairCtrlAbility' - This bit is set if pair selection can be controlled.
cpeExtPsePortLldpPdPwrPairsOrZero
1.3.6.1.4.1.9.9.402.1.7.1.14
INTEGER0 = unknown1 = signal2 = spare · Integer32
This object indicates the pinout pairs in use received from the remote PD via MDI TLV in LLDP Protocol.
'unknown' - information is not available
'signal' - the signal pairs are in use.
'spare' - the spare pairs are in use.
Trap details
cpeExtPolicingNotif
1.3.6.1.4.1.9.9.402.0.1
This notification is generated when the 'overdraw' or 'overdrawLog' bit in value of cpeExtPsePortAdditionalStatus is set or cleared.
cpeExtPsePortPolicingAction
1.3.6.1.4.1.9.9.402.1.2.1.14
INTEGER1 = deny2 = logOnly · Integer32
This object specifies the power policing action that the device will take on this PSE port when the real-time power consumption exceeds its max power allocation if the value of cpeExtPsePortPolicingEnable is 'on'.
'deny' - the device will deny the power to
the PSE port
'logOnly' - the device will not deny the power
to the PSE port
cpeExtPsePortAdditionalStatus
1.3.6.1.4.1.9.9.402.1.2.1.5
BITS
This object is an extension of the pethPsePortDetectionStatus object from RFC3621 and provides additional status information.
deny: When set, the PD attached to the interface is being denied power due to insufficient power resources on the Power Sourcing Equipment.
overdraw: When set, the PD attached to the interface is being denied power because the PD is trying to consume more power than it has been configured to consume.
overdrawLog: When set, the PD attached to the interface is trying to consume more power than it has been configured to consume, but is not being denied power.
cpeExtPsePortPwrAllocated
1.3.6.1.4.1.9.9.402.1.2.1.7
Unsigned32 · milliwatts
This object indicates the amount of power allocated from the PSE for the PD.
cpeExtPsePortMaxPwrDrawn
1.3.6.1.4.1.9.9.402.1.2.1.10
Unsigned32 · milliwatts
This indicates the maximum amount of power drawn by the PD connected to this interface, since it was powered on.