EZ5 MIB Catalog

CISCO-SERVICE-CONTROL-RDR-MIB

2007-08-14

This MIB module defines objects describing statistics and configuration relating to the Raw Data Record Formatter running on a service control entity. The Raw Data Record (RDR) formatter is a component implemented by the service control entity that gathers raw data records produced by the entity and delivers them to external entities as reports. The external entities are called RDR destinations or RDR collectors. The RDR formatter can be configured to send reports to one or multiple destinations. RDR formatter can group RDRs into potentially four categories. RDR mapping to the categories is done by the client application or the user and reflects different logical destinations or purposes. For example the application may map Quota related RDRs to category 1, and Transaction related RDRs to category 2. The user can configure these categories to different destinations and assign them with different priorities. Each category has a separate queue for forwarding the RDRs and has seperate counters for gathering of statistics (sent, dropped, queued etc.). An RDR can belong to any one of the category as chosen by the user or client application. The RDR formatter supports multiple destinations identified by IP address and a port number. Each destination is assigned with a priority for each of the categories. Priority is a number in the range of 1-100, with 100 being the highest priority. The priorities are effective only when the formatter is in forwarding mode 'Redundancy' and are configured during destination configuration (while assigning the destination with categories). For example we have destination A configured with category 1 which is configured with priority 100, destination B configured with category 1 and priority 80 and destination C with category 1 and priority 90. When in redundancy mode the formatter will set the active destination for a category to be the destination with the highest priority. For category 1 the active destination will be A. If destination A goes down then the next destination selected by the formatter as active is destination C.

Download CISCO-SERVICE-CONTROL-RDR-MIB.txt Open CISCO-SERVICE-CONTROL-RDR-MIB.txt in a new tab

SCALARS (2) · TABLES (4) · TRAPS (6)

Scalars (2)

NameOID
cscRdrReportsEnableNotifs1.3.6.1.4.1.9.9.637.1.5.1
cscRdrCounterDiscontinuityTime1.3.6.1.4.1.9.9.637.1.6

Tables (4)

NameOID
cscRdrFormatterTable1.3.6.1.4.1.9.9.637.1.1
cscRdrDestTable1.3.6.1.4.1.9.9.637.1.2
cscRdrCategoryTable1.3.6.1.4.1.9.9.637.1.3
cscRdrCategoryDestTable1.3.6.1.4.1.9.9.637.1.4

Traps (6)

NameOID
cscRdrCategoryStoppedDiscardingReportsTrap1.3.6.1.4.1.9.9.637.0.1
cscRdrCategoryDiscardingReportsTrap1.3.6.1.4.1.9.9.637.0.2
cscRdrNoActiveConnectionTrap1.3.6.1.4.1.9.9.637.0.3
cscRdrConnectionStatusDownTrap1.3.6.1.4.1.9.9.637.0.4
cscRdrActiveConnectionTrap1.3.6.1.4.1.9.9.637.0.5
cscRdrConnectionStatusUpTrap1.3.6.1.4.1.9.9.637.0.6

END OF TOC

Scalar details

cscRdrReportsEnableNotifs

1.3.6.1.4.1.9.9.637.1.5.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object controls whether the system produces notifications defined in thi MIB. A 'false' value will prevent the notifications from being generated by this system.

cscRdrCounterDiscontinuityTime

1.3.6.1.4.1.9.9.637.1.6

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of service up time on the most recent occasion at which any one or more of the RDR counters suffered a discontinuity. If no such discontinuities have occurred since the last re-initialization of the local management subsystem, then this object contains a zero value.

Table details

cscRdrFormatterTable

1.3.6.1.4.1.9.9.637.1.1

Index: entPhysicalIndex

This table lists the operational information and aggregated statistics for the RDR formatter of a service control entity.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

cscRdrFormatterEnable

1.3.6.1.4.1.9.9.637.1.1.1.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies whether the RDR formatter is enabled or disabled. When the RDR formatter is enabled, it sends the records it gets from the traffic processors to the RDR destination as defined in the cscRdrDestTable.

cscRdrFormatterNumSentReports

1.3.6.1.4.1.9.9.637.1.1.1.2

Counter32 · reports

This object indicates the number of reports sent by the RDR formatter. Discontinuities in the value of this counter can occur at disabling/enabling of the RDR formatter, and at other times as indicated by the value of cscRdrCounterDiscontinuityTime.

cscRdrFormatterNumDiscardedReports

1.3.6.1.4.1.9.9.637.1.1.1.3

Counter32 · reports

This object indicates the number of reports discarded by the RDR formatter due to insufficient resources or unavailibility of the destination. Discontinuities in the value of this counter can occur at disabling/enabling of the RDR formatter, and at other times as indicated by the value of cscRdrCounterDiscontinuityTime.

cscRdrFormatterReportRate

1.3.6.1.4.1.9.9.637.1.1.1.4

Gauge32 · reports per second

This object indicates the rate at which the RDR formatter is currently sending reports to all of the destinations.

cscRdrFormatterReportRatePeak

1.3.6.1.4.1.9.9.637.1.1.1.5

Gauge32 · reports per second

This object indicates the maximum rate at which the RDR formatter sent reports to all of the destinations since sysUpTime, if cscRdrCounterDiscontinuityTime is zero. If cscRdrCounterDiscontinuityTime has a non zero value, the maximum rate is determined from this value.

cscRdrFormatterReportRatePeakTime

1.3.6.1.4.1.9.9.637.1.1.1.6

TimeTicks

This object indicates the time elapsed since the cscRdrFormatterReportRatePeak value occured.

cscRdrFormatterProtocol

1.3.6.1.4.1.9.9.637.1.1.1.7

INTEGER1 = other2 = rdrv13 = netflowV9 · Integer32

This object specifies the RDR protocol currently used by the RDR formatter. 'other' : The RDR formatter is using a protocol not recognized by this revision of the MIB. 'rdrv1' : RDR protocol version 1 'netflowV9' : NetFlow ver 9

cscRdrFormatterForwardingMode

1.3.6.1.4.1.9.9.637.1.1.1.8

INTEGER1 = other2 = redundancy3 = simpleLoadBalancing4 = multicast · Integer32

This object specifies the mode by which the RDR formatter sends the reports to its destinations. 'other' : The RDR formatter is using a protocol not recognized by this revision of the MIB. 'redundancy' : The reports are sent to the primary (active destination) and all of the other destinations are in standby. 'simpleLoadBalancing' : The reports are sent to one destination at a time in a round robin manner. 'multicast' : The reports are sent to all of the destinations.

cscRdrDestTable

1.3.6.1.4.1.9.9.637.1.2

Index: entPhysicalIndex · cscRdrDestIndex

This table lists the addresses of the configured RDR destination servers and the corresponding connection status for each destination. The RDR formatter sends reports to one or more configured destinations that have a connection to the RDR formatter. This table also shows the current connection status of each destination.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

cscRdrDestIndex

1.3.6.1.4.1.9.9.637.1.2.1.1

Unsigned32 (1..4294967295)

A monotonically increasing integer for the sole purpose of indexing RDR destinations. When it reaches the maximum value the agent flushes the table and wraps the value back to 1.

cscRdrDestInetAddressType

1.3.6.1.4.1.9.9.637.1.2.1.2

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the type of Internet address by which the RDR destination server is reachable.

cscRdrDestInetAddress

1.3.6.1.4.1.9.9.637.1.2.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates the RDR destination server IP Address.

cscRdrDestPort

1.3.6.1.4.1.9.9.637.1.2.1.4

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object indicates the port on which the RDR destination server listens.

cscRdrDestPriority

1.3.6.1.4.1.9.9.637.1.2.1.5

Integer32 (1..100)

This object indicates the priority given to the RDR destination server. The RDR formatter determines the priority of a destination by the value of entPhysicalIndex and the RDR category of the destination. RDR formatter assigns the highest priority to the destination which has the same value of entPhysicalIndex and RDR category as that of the RDR formatter. The RDR formatter activates the destination server which is reachable and with the highest priority.

cscRdrDestStatus

1.3.6.1.4.1.9.9.637.1.2.1.6

INTEGER1 = other2 = active3 = standby · Integer32

This object indicates the status of this RDR destination. 'other' : None of the following. 'active' : The reports are sent to this destination. 'standby': This destination is a backup. Only one RDR destination can be 'active' if the cscRdrFormatterForwardingMode is set to either 'redundancy' or 'simpleLoadBalancing'. Multiple RDR destinations can be in 'active' state when cscRdrFormatterForwardingMode is set to 'multicast'.

cscRdrDestConnectionStatus

1.3.6.1.4.1.9.9.637.1.2.1.7

INTEGER1 = other2 = up3 = down · Integer32

This object indicates the status of the connection between the RDR formatter and this destination. 'other' : The connection is in some unknown state. 'up' : The RDR formatter can reach this destination. 'down' : The RDR formatter cannot reach this destination.

cscRdrDestNumSentReports

1.3.6.1.4.1.9.9.637.1.2.1.8

Counter32 · reports

This object indicates the number of reports sent by the RDR formatter to this destination. Discontinuities in the value of this counter can occur at disabling/enabling of the RDR formatter, and at other times as indicated by the value of cscRdrCounterDiscontinuityTime.

cscRdrDestNumDiscardedReports

1.3.6.1.4.1.9.9.637.1.2.1.9

Counter32

This object indicates the number of reports dropped by the RDR formatter for this destination. Discontinuities in the value of this counter can occur at disabling/enabling of the RDR formatter, and at other times as indicated by the value of cscRdrCounterDiscontinuityTime.

cscRdrDestReportRate

1.3.6.1.4.1.9.9.637.1.2.1.10

Gauge32 · reports per second

This object indicates the rate at which the RDR formatter is currently sending reports to this destinations.

cscRdrCategoryTable

1.3.6.1.4.1.9.9.637.1.3

Index: entPhysicalIndex · cscRdrCategoryIndex

This table describes the operational values and aggregated statistics of the different categories of the RDR Formatter.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

cscRdrCategoryIndex

1.3.6.1.4.1.9.9.637.1.3.1.1

Unsigned32 (1..4)

This object indicates the category number, index to the table.

cscRdrCategoryID

1.3.6.1.4.1.9.9.637.1.3.1.2

Unsigned32

This object indicates the unique id assigned to this RDR category by the RDR formatter.

cscRdrCategoryName

1.3.6.1.4.1.9.9.637.1.3.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object indicates the human readable name assigned to this RDR category by the RDR formatter. The client application provides the RDR formatter with the value of this object.

cscRdrCategoryNumSentReports

1.3.6.1.4.1.9.9.637.1.3.1.4

Counter32 · reports

This object indicates the number of RDR reports sent over this category. Discontinuities in the value of this counter can occur at disabling/enabling of the RDR formatter, and at other times as indicated by the value of cscRdrCounterDiscontinuityTime.

cscRdrCategoryNumDiscardedReports

1.3.6.1.4.1.9.9.637.1.3.1.5

Counter32 · reports

This object indicates the number of RDR reports dropped for this category. Discontinuities in the value of this counter can occur at disabling/enabling of the RDR formatter, and at other times as indicated by the value of cscRdrCounterDiscontinuityTime.

cscRdrCategoryReportRate

1.3.6.1.4.1.9.9.637.1.3.1.6

Gauge32 · reports per second

This object indicates the rate at which the RDR formatter is currently sending reports over this category.

cscRdrCategoryNumQueuedReports

1.3.6.1.4.1.9.9.637.1.3.1.7

Gauge32 · reports

This object indicates the number of pending RDR reports within this category.

cscRdrCategoryDestTable

1.3.6.1.4.1.9.9.637.1.4

Index: entPhysicalIndex · cscRdrCategoryIndex · cscRdrDestPort · cscRdrDestInetAddress

This table lists the operational data for RDR destination servers for each RDR category for a service control entity.

from ENTITY-MIB

entPhysicalIndex

PhysicalIndexAn arbitrary value that uniquely identifies the physical entity. The value should be a small positive integer. Index values for different physical entities are not necessarily contiguous. (1..2147483647) · Integer32 · hint d

The index for this entry.

cscRdrCategoryDestPriority

1.3.6.1.4.1.9.9.637.1.4.1.1

Integer32 (1..100)

This object indicates the priority configured for this category on the RDR destination server. The priority is determined by entPhysicalIndex and the category of the destination server.

cscRdrCategoryDestStatus

1.3.6.1.4.1.9.9.637.1.4.1.2

INTEGER1 = other2 = active3 = standby · Integer32

This object indicates the status of this RDR destination for this category. 'other' : None of the following. 'active' : The reports are sent to this destination. 'standby': This destination is a backup. Only one RDR destination can be 'active' if the cscRdrFormatterForwardingMode is set to either 'redundancy' or 'simpleLoadBalancing'. Multiple RDR destinations can be in 'active' state when cscRdrFormatterForwardingMode is set to 'multicast'.

Trap details

cscRdrCategoryStoppedDiscardingReportsTrap

1.3.6.1.4.1.9.9.637.0.1

The system generates this notification to indicate that the system has recovered from congestion or unavailibility of the RDR collector identified by the value of cscRdrCategoryID and has stopped discarding reports being sent to this RDR collector.

entPhysicalName

1.3.6.1.2.1.47.1.1.1.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The textual name of the physical entity. The value of this object should be the name of the component as assigned by the local device and should be suitable for use in commands entered at the device's 'console'. This might be a text name (e.g., 'console') or a simple component number (e.g., port or module number, such as '1'), depending on the physical component naming syntax of the device. If there is no local name, or if this object is otherwise not applicable, then this object contains a zero-length string. Note that the value of entPhysicalName for two physical entities will be the same in the event that the console interface does not distinguish between them, e.g., slot-1 and the card in slot-1.

cscRdrCategoryID

1.3.6.1.4.1.9.9.637.1.3.1.2

Unsigned32

This object indicates the unique id assigned to this RDR category by the RDR formatter.

cscRdrCategoryDiscardingReportsTrap

1.3.6.1.4.1.9.9.637.0.2

The system generates this notification to indicate that the system has either encountered congestion or unavailibility of the RDR collector with the category identified by the value of cscRdrCategoryID and has started discarding reports destined to this collector. The value of cscRdrCategoryNumReportsDiscarded indicates the number of discarded reports.

entPhysicalName

1.3.6.1.2.1.47.1.1.1.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The textual name of the physical entity. The value of this object should be the name of the component as assigned by the local device and should be suitable for use in commands entered at the device's 'console'. This might be a text name (e.g., 'console') or a simple component number (e.g., port or module number, such as '1'), depending on the physical component naming syntax of the device. If there is no local name, or if this object is otherwise not applicable, then this object contains a zero-length string. Note that the value of entPhysicalName for two physical entities will be the same in the event that the console interface does not distinguish between them, e.g., slot-1 and the card in slot-1.

cscRdrCategoryID

1.3.6.1.4.1.9.9.637.1.3.1.2

Unsigned32

This object indicates the unique id assigned to this RDR category by the RDR formatter.

cscRdrNoActiveConnectionTrap

1.3.6.1.4.1.9.9.637.0.3

The system generates this notification to indicate that there is no active connection between the RDR formatter and any collector.

entPhysicalName

1.3.6.1.2.1.47.1.1.1.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The textual name of the physical entity. The value of this object should be the name of the component as assigned by the local device and should be suitable for use in commands entered at the device's 'console'. This might be a text name (e.g., 'console') or a simple component number (e.g., port or module number, such as '1'), depending on the physical component naming syntax of the device. If there is no local name, or if this object is otherwise not applicable, then this object contains a zero-length string. Note that the value of entPhysicalName for two physical entities will be the same in the event that the console interface does not distinguish between them, e.g., slot-1 and the card in slot-1.

cscRdrConnectionStatusDownTrap

1.3.6.1.4.1.9.9.637.0.4

The system generates this notification to indicate that a connection to destination has transitioned to the 'down' state.

entPhysicalName

1.3.6.1.2.1.47.1.1.1.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The textual name of the physical entity. The value of this object should be the name of the component as assigned by the local device and should be suitable for use in commands entered at the device's 'console'. This might be a text name (e.g., 'console') or a simple component number (e.g., port or module number, such as '1'), depending on the physical component naming syntax of the device. If there is no local name, or if this object is otherwise not applicable, then this object contains a zero-length string. Note that the value of entPhysicalName for two physical entities will be the same in the event that the console interface does not distinguish between them, e.g., slot-1 and the card in slot-1.

cscRdrDestStatus

1.3.6.1.4.1.9.9.637.1.2.1.6

INTEGER1 = other2 = active3 = standby · Integer32

This object indicates the status of this RDR destination. 'other' : None of the following. 'active' : The reports are sent to this destination. 'standby': This destination is a backup. Only one RDR destination can be 'active' if the cscRdrFormatterForwardingMode is set to either 'redundancy' or 'simpleLoadBalancing'. Multiple RDR destinations can be in 'active' state when cscRdrFormatterForwardingMode is set to 'multicast'.

cscRdrDestInetAddress

1.3.6.1.4.1.9.9.637.1.2.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates the RDR destination server IP Address.

cscRdrDestPort

1.3.6.1.4.1.9.9.637.1.2.1.4

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object indicates the port on which the RDR destination server listens.

cscRdrActiveConnectionTrap

1.3.6.1.4.1.9.9.637.0.5

The system generates this notification to indicate that a connection to the destination address cscRdrDestInetAddress has become active on TCP port cscRdrDestPort.

entPhysicalName

1.3.6.1.2.1.47.1.1.1.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The textual name of the physical entity. The value of this object should be the name of the component as assigned by the local device and should be suitable for use in commands entered at the device's 'console'. This might be a text name (e.g., 'console') or a simple component number (e.g., port or module number, such as '1'), depending on the physical component naming syntax of the device. If there is no local name, or if this object is otherwise not applicable, then this object contains a zero-length string. Note that the value of entPhysicalName for two physical entities will be the same in the event that the console interface does not distinguish between them, e.g., slot-1 and the card in slot-1.

cscRdrDestInetAddress

1.3.6.1.4.1.9.9.637.1.2.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates the RDR destination server IP Address.

cscRdrDestPort

1.3.6.1.4.1.9.9.637.1.2.1.4

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object indicates the port on which the RDR destination server listens.

cscRdrConnectionStatusUpTrap

1.3.6.1.4.1.9.9.637.0.6

The system generates this notification to indicate that a connection to the destination address cscRdrDestInetAddress has become transitioned to 'up' state on TCP port cscRdrDestPort.

entPhysicalName

1.3.6.1.2.1.47.1.1.1.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The textual name of the physical entity. The value of this object should be the name of the component as assigned by the local device and should be suitable for use in commands entered at the device's 'console'. This might be a text name (e.g., 'console') or a simple component number (e.g., port or module number, such as '1'), depending on the physical component naming syntax of the device. If there is no local name, or if this object is otherwise not applicable, then this object contains a zero-length string. Note that the value of entPhysicalName for two physical entities will be the same in the event that the console interface does not distinguish between them, e.g., slot-1 and the card in slot-1.

cscRdrDestStatus

1.3.6.1.4.1.9.9.637.1.2.1.6

INTEGER1 = other2 = active3 = standby · Integer32

This object indicates the status of this RDR destination. 'other' : None of the following. 'active' : The reports are sent to this destination. 'standby': This destination is a backup. Only one RDR destination can be 'active' if the cscRdrFormatterForwardingMode is set to either 'redundancy' or 'simpleLoadBalancing'. Multiple RDR destinations can be in 'active' state when cscRdrFormatterForwardingMode is set to 'multicast'.

cscRdrDestInetAddress

1.3.6.1.4.1.9.9.637.1.2.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates the RDR destination server IP Address.

cscRdrDestPort

1.3.6.1.4.1.9.9.637.1.2.1.4

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object indicates the port on which the RDR destination server listens.

↑ To TOC