Forces the snapshot state to active for all entries of the ciscoSnapshotActivityTable whose ciscoSnapshotIfIndex value is specified as parameter. The interface associated with ciscoSnapshotIfIndex must be a client interface.
Retrieval of this object will return the value of the ciscoSnapshotIfIndex that was last forced into the active state, or 0 if no interfaces have been forced into the active state since the router was reset
Table details
ciscoSnapshotInterfaceTable
1.3.6.1.4.1.9.9.19.1.2
Index: ciscoSnapshotIfIndex
A list of Snapshot Routing configuration entries.
ciscoSnapshotIfIndex
1.3.6.1.4.1.9.9.19.1.2.1.1
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface to which this entry pertains.
ciscoSnapshotClient
1.3.6.1.4.1.9.9.19.1.2.1.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
When true, this router is the client snapshot router on the interface. When false, this router is the server snapshot router on the interface.
ciscoSnapshotDialer
1.3.6.1.4.1.9.9.19.1.2.1.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Indicates whether or not snapshot routing on this interface uses Dial-on-Demand routing.
ciscoSnapshotActiveInterval
1.3.6.1.4.1.9.9.19.1.2.1.4
Integer32 (5..1000) · minutes
The amount of time during which routes may be exchanged between the client and server routers.
ciscoSnapshotQuietInterval
1.3.6.1.4.1.9.9.19.1.2.1.5
Integer32 (8..100000) · minutes
The amount of time during which routes are retained and frozen between active periods.
An instance of this object may only be present if the value of the associated ciscoSnapshotClient object is true.
ciscoSnapshotRetryInterval
1.3.6.1.4.1.9.9.19.1.2.1.6
Integer32 · minutes
The amount of time to wait and retry a route exchange if an active period elapses with no routes being exchanged. For example, if an interface is down (or a DDR phone number is busy, or a DDR interface is unavailable) during the active interval, instead of waiting for the amount of time specified by ciscoSnapshotQuietTime to elapse before an attempt is made to exchange routing updates again, the attempt is made after the amount of time specified by this object has elapsed. This value is calculated automatically based on the ciscoSnapshotActiveInterval.
An instance of this object may only be present if the value of the associated ciscoSnapshotClient object is true.
ciscoSnapshotIfUpAction
1.3.6.1.4.1.9.9.19.1.2.1.7
INTEGER1 = goActive2 = noAction · Integer32
This object controls the action that takes place when the interface associated with this entry transitions to the `up' state while snapshot routing on the interface is in quiet mode.
A value of goActive will cause the immediate transition to the active state.
A value of noAction will cause no such transition. Instead, the transition to the active state will occur normally when the current quiet period has expired.
Going active immediately incurs extra routing protocol overhead, but allows a fresh set of routing updates be exchanged each time the line is brought up. This is useful in a Dial-on-Demand routing environment.
An instance of this object may only be present if the value of the associated ciscoSnapshotClient object is true.
ciscoSnapshotRowStatus
1.3.6.1.4.1.9.9.19.1.2.1.8
RowStatus1 = active2 = notInService3 = notReady4 = createAndGo5 = createAndWait6 = destroyThe RowStatus textual convention is used to manage the creation and deletion of conceptual rows, and is used as the value of the SYNTAX clause for the status column of a conceptual row (as described in Section 7.7.1 of [2].)
The status column has six defined values:
- `active', which indicates that the conceptual row is available for use by the managed device;
- `notInService', which indicates that the conceptual row exists in the agent, but is unavailable for use by the managed device (see NOTE below); 'notInService' has no implication regarding the internal consistency of the row, availability of resources, or consistency with the current state of the managed device;
- `notReady', which indicates that the conceptual row exists in the agent, but is missing information necessary in order to be available for use by the managed device (i.e., one or more required columns in the conceptual row have not been instanciated);
- `createAndGo', which is supplied by a management station wishing to create a new instance of a conceptual row and to have its status automatically set to active, making it available for use by the managed device;
- `createAndWait', which is supplied by a management station wishing to create a new instance of a conceptual row (but not make it available for use by the managed device); and, - `destroy', which is supplied by a management station wishing to delete all of the instances associated with an existing conceptual row.
Whereas five of the six values (all except `notReady') may be specified in a management protocol set operation, only three values will be returned in response to a management
protocol retrieval operation: `notReady', `notInService' or
`active'. That is, when queried, an existing conceptual row
has only three states: it is either available for use by
the managed device (the status column has value `active'); it is not available for use by the managed device, though the agent has sufficient information to attempt to make it so (the status column has value `notInService'); or, it is not available for use by the managed device, and an attempt to make it so would fail because the agent has insufficient information (the state column has value `notReady').
NOTE WELL
This textual convention may be used for a MIB table, irrespective of whether the values of that table's conceptual rows are able to be modified while it is active, or whether its conceptual rows must be taken out of service in order to be modified. That is, it is the responsibility of the DESCRIPTION clause of the status column to specify whether the status column must not be `active' in order for the value of some other column of the same conceptual row to be modified. If such a specification is made, affected columns may be changed by an SNMP set PDU if the RowStatus would not be equal to `active' either immediately before or after processing the PDU. In other words, if the PDU also contained a varbind that would change the RowStatus value, the column in question may be changed if the RowStatus was not equal to `active' as the PDU was received, or if the varbind sets the status to a value other than 'active'.
Also note that whenever any elements of a row exist, the RowStatus column must also exist.
To summarize the effect of having a conceptual row with a status column having a SYNTAX clause value of RowStatus, consider the following state diagram:
STATE +--------------+-----------+-------------+-------------
| A | B | C | D
| |status col.|status column|
|status column | is | is |status column
ACTION |does not exist| notReady | notInService| is active
--------------+--------------+-----------+-------------+-------------
set status |noError ->D|inconsist- |inconsistent-|inconsistent-
column to | or | entValue| Value| Value
createAndGo |inconsistent- | | |
| Value| | |
--------------+--------------+-----------+-------------+-------------
set status |noError see 1|inconsist- |inconsistent-|inconsistent-
column to | or | entValue| Value| Value
createAndWait |wrongValue | | |
--------------+--------------+-----------+-------------+-------------
set status |inconsistent- |inconsist- |noError |noError
column to | Value| entValue| |
active | | | |
| | or | |
| | | |
| |see 2 ->D|see 8 ->D| ->D
--------------+--------------+-----------+-------------+-------------
set status |inconsistent- |inconsist- |noError |noError ->C
column to | Value| entValue| |
notInService | | | |
| | or | | or
| | | |
| |see 3 ->C| ->C|see 6
--------------+--------------+-----------+-------------+-------------
set status |noError |noError |noError |noError ->A
column to | | | | or
destroy | ->A| ->A| ->A|see 7
--------------+--------------+-----------+-------------+-------------
set any other |see 4 |noError |noError |see 5
column to some| | | |
value | | see 1| ->C| ->D
--------------+--------------+-----------+-------------+-------------
(1) goto B or C, depending on information available to the agent.
(2) if other variable bindings included in the same PDU, provide values for all columns which are missing but required, and all columns have acceptable values, then return noError and goto D.
(3) if other variable bindings included in the same PDU, provide legal values for all columns which are missing but required, then return noError and goto C.
(4) at the discretion of the agent, the return value may be either:
inconsistentName: because the agent does not choose to
create such an instance when the corresponding RowStatus instance does not exist, or
inconsistentValue: if the supplied value is
inconsistent with the state of some other MIB object's value, or
noError: because the agent chooses to create the instance.
If noError is returned, then the instance of the status column must also be created, and the new state is B or C, depending on the information available to the agent. If inconsistentName or inconsistentValue is returned, the row remains in state A.
(5) depending on the MIB definition for the column/table, either noError or inconsistentValue may be returned.
(6) the return value can indicate one of the following errors:
wrongValue: because the agent does not support notInService (e.g., an agent which does not support createAndWait), or
inconsistentValue: because the agent is unable to take the row out of service at this time, perhaps because it is in use and cannot be de-activated.
(7) the return value can indicate the following error:
inconsistentValue: because the agent is unable to remove the row at this time, perhaps because it is in use and cannot be de-activated.
(8) the transition to D can fail, e.g., if the values of the conceptual row are inconsistent, then the error code would be inconsistentValue.
NOTE: Other processing of (this and other varbinds of) the set request may result in a response other than noError being returned, e.g., wrongValue, noCreation, etc.
Conceptual Row Creation
There are four potential interactions when creating a
conceptual row: selecting an instance-identifier which is
not in use; creating the conceptual row; initializing any objects for which the agent does not supply a default; and, making the conceptual row available for use by the managed device.
Interaction 1: Selecting an Instance-Identifier
The algorithm used to select an instance-identifier varies for each conceptual row. In some cases, the instance- identifier is semantically significant, e.g., the destination address of a route, and a management station selects the instance-identifier according to the semantics.
In other cases, the instance-identifier is used solely to distinguish conceptual rows, and a management station without specific knowledge of the conceptual row might examine the instances present in order to determine an unused instance-identifier. (This approach may be used, but it is often highly sub-optimal; however, it is also a questionable practice for a naive management station to attempt conceptual row creation.)
Alternately, the MIB module which defines the conceptual row might provide one or more objects which provide assistance in determining an unused instance-identifier. For example, if the conceptual row is indexed by an integer-value, then an object having an integer-valued SYNTAX clause might be defined for such a purpose, allowing a management station to issue a management protocol retrieval operation. In order to avoid unnecessary collisions between competing management stations, `adjacent' retrievals of this object should be different.
Finally, the management station could select a pseudo-random number to use as the index. In the event that this index
was already in use and an inconsistentValue was returned in response to the management protocol set operation, the management station should simply select a new pseudo-random number and retry the operation.
A MIB designer should choose between the two latter algorithms based on the size of the table (and therefore the efficiency of each algorithm). For tables in which a large number of entries are expected, it is recommended that a MIB object be defined that returns an acceptable index for creation. For tables with small numbers of entries, it is recommended that the latter pseudo-random index mechanism be used.
Interaction 2: Creating the Conceptual Row
Once an unused instance-identifier has been selected, the management station determines if it wishes to create and activate the conceptual row in one transaction or in a negotiated set of interactions.
Interaction 2a: Creating and Activating the Conceptual Row
The management station must first determine the column requirements, i.e., it must determine those columns for which it must or must not provide values. Depending on the complexity of the table and the management station's knowledge of the agent's capabilities, this determination can be made locally by the management station. Alternately, the management station issues a management protocol get operation to examine all columns in the conceptual row that it wishes to create. In response, for each column, there are three possible outcomes:
- a value is returned, indicating that some other management station has already created this conceptual row. We return to interaction 1.
- the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it should supply a value for this column when the conceptual row is to be created.
- the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column.
Once the column requirements have been determined, a management protocol set operation is accordingly issued. This operation also sets the new instance of the status column to `createAndGo'.
When the agent processes the set operation, it verifies that it has sufficient information to make the conceptual row available for use by the managed device. The information
available to the agent is provided by two sources: the
management protocol set operation which creates the conceptual row, and, implementation-specific defaults supplied by the agent (note that an agent must provide implementation-specific defaults for at least those objects which it implements as read-only). If there is sufficient information available, then the conceptual row is created, a `noError' response is returned, the status column is set to `active', and no further interactions are necessary (i.e., interactions 3 and 4 are skipped). If there is insufficient information, then the conceptual row is not created, and the set operation fails with an error of `inconsistentValue'. On this error, the management station can issue a management protocol retrieval operation to determine if this was because it failed to specify a value for a required column, or, because the selected instance of the status column already existed. In the latter case, we return to interaction 1. In the former case, the management station can re-issue the set operation with the additional information, or begin interaction 2 again using `createAndWait' in order to negotiate creation of the conceptual row.
NOTE WELL
Regardless of the method used to determine the column requirements, it is possible that the management station might deem a column necessary when, in fact, the agent will not allow that particular columnar instance to be created or written. In this case, the management protocol set operation will fail with an error such as `noCreation' or `notWritable'. In this case, the management station decides whether it needs to be able to set a value for that particular columnar instance. If not, the management station re-issues the management protocol set operation, but without setting a value for that particular columnar instance; otherwise, the management station aborts the row creation algorithm.
Interaction 2b: Negotiating the Creation of the Conceptual Row
The management station issues a management protocol set operation which sets the desired instance of the status column to `createAndWait'. If the agent is unwilling to process a request of this sort, the set operation fails with an error of `wrongValue'. (As a consequence, such an agent must be prepared to accept a single management protocol set operation, i.e., interaction 2a above, containing all of the
columns indicated by its column requirements.) Otherwise,
the conceptual row is created, a `noError' response is returned, and the status column is immediately set to either `notInService' or `notReady', depending on whether it has sufficient information to (attempt to) make the conceptual row available for use by the managed device. If there is sufficient information available, then the status column is set to `notInService'; otherwise, if there is insufficient information, then the status column is set to `notReady'. Regardless, we proceed to interaction 3.
Interaction 3: Initializing non-defaulted Objects
The management station must now determine the column requirements. It issues a management protocol get operation to examine all columns in the created conceptual row. In the response, for each column, there are three possible outcomes:
- a value is returned, indicating that the agent implements the object-type associated with this column and had sufficient information to provide a value. For those columns to which the agent provides read-create access (and for which the agent allows their values to be changed after their creation), a value return tells the management station that it may issue additional management protocol set operations, if it desires, in order to change the value associated with this column.
- the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. However, the agent does not have sufficient information to provide a value, and until a value is provided, the conceptual row may not be made available for use by the managed device. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it must issue additional management protocol set operations, in order to provide a value associated with this column.
- the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column.
If the value associated with the status column is `notReady', then the management station must first deal with all `noSuchInstance' columns, if any. Having done so, the value of the status column becomes `notInService', and we proceed to interaction 4.
Interaction 4: Making the Conceptual Row Available
Once the management station is satisfied with the values associated with the columns of the conceptual row, it issues a management protocol set operation to set the status column to `active'. If the agent has sufficient information to make the conceptual row available for use by the managed device, the management protocol set operation succeeds (a `noError' response is returned). Otherwise, the management protocol set operation fails with an error of `inconsistentValue'.
NOTE WELL
A conceptual row having a status column with value `notInService' or `notReady' is unavailable to the managed device. As such, it is possible for the managed device to create its own instances during the time between the management protocol set operation which sets the status column to `createAndWait' and the management protocol set operation which sets the status column to `active'. In this case, when the management protocol set operation is issued to set the status column to `active', the values held in the agent supersede those used by the managed device.
If the management station is prevented from setting the status column to `active' (e.g., due to management station or network failure) the conceptual row will be left in the `notInService' or `notReady' state, consuming resources indefinitely. The agent must detect conceptual rows that have been in either state for an abnormally long period of time and remove them. It is the responsibility of the DESCRIPTION clause of the status column to indicate what an abnormally long period of time would be. This period of time should be long enough to allow for human response time (including `think time') between the creation of the conceptual row and the setting of the status to `active'. In the absence of such information in the DESCRIPTION clause, it is suggested that this period be approximately 5 minutes in length. This removal action applies not only to newly-created rows, but also to previously active rows which are set to, and left in, the notInService state for a prolonged period exceeding that which is considered normal for such a conceptual row.
Conceptual Row Suspension
When a conceptual row is `active', the management station may issue a management protocol set operation which sets the instance of the status column to `notInService'. If the agent is unwilling to do so, the set operation fails with an error of `wrongValue' or `inconsistentValue'. Otherwise, the conceptual row is taken out of service, and a `noError' response is returned. It is the responsibility of the DESCRIPTION clause of the status column to indicate under what circumstances the status column should be taken out of service (e.g., in order for the value of some other column of the same conceptual row to be modified).
Conceptual Row Deletion
For deletion of conceptual rows, a management protocol set operation is issued which sets the instance of the status column to `destroy'. This request may be made regardless of the current value of the status column (e.g., it is possible to delete conceptual rows which are either `notReady',
`notInService' or `active'.) If the operation succeeds,
then all instances associated with the conceptual row are immediately removed. · Integer32
The status of this table entry. Once the entry status is set to active, the snapshot routing process will be enabled for this interface.
The current state of snapshot routing for this entry. active means that routing information may be exchanged. quiet, only present on a client snapshot interface, means that routes are frozen, and that no routing information may be exchanged until the active state is reentered. serverPostActive, only present on a server snapshot interface, means that the active period has expired, but routing information will still be accepted from (but not sent to) the associated client router. transitionToQuiet, and transitionToActive, only present on a client, are temporary states entered after the active state, wherein any down to up transition of the interface will cause a move to the quiet or active state, respectively. limbo is a temporary state for activity blocks that are in the process of being created or destroyed.
ciscoSnapshotActivityTimer
1.3.6.1.4.1.9.9.19.1.3.1.3
Integer32 · minutes
The amount of time remaining in the current state.
ciscoSnapshotExchangeTimer
1.3.6.1.4.1.9.9.19.1.3.1.4
Integer32 · minutes
The amount of time during the last active state, in which protocol exchanges occurred. The minimum time required to allow updates to be exchanged for a 'successfull update cycle' is the greater of 3 minutes, or 1/2 the active time. If the ciscoSnapshotExchangeTimer is less than this, the quiet state will use the retry interval to determine when next to go active.
An instance of this object will only be present when the associated value of ciscoSnapshotClient is true for this interface.
ciscoSnapshotDialerMap
1.3.6.1.4.1.9.9.19.1.3.1.5
Integer32
Index of the dialer map entry associated with this snapshot activity record. A value of 0 indicates that no dialer map is associated with this entry.
An instance of this object will only be present when the associated value of ciscoSnapshotDialer is true.
The protocol of the host that initiated the snapshot routing activity associated with this record.
An instance of this object will only be present when the associated value of ciscoSnapshotClient is false.
ciscoSnapshotSourceAddress
1.3.6.1.4.1.9.9.19.1.3.1.7
CiscoNetworkAddressRepresents a network layer address. The length and format of the address is protocol dependent as follows:
ip 4 octets
decnet 2 octets
pup obsolete
chaos 2 octets
xns 10 octets
first 4 octets are the net number last 6 octets are the host number x121 appletalk 3 octets first 2 octets are the net number last octet is the host number clns lat
vines 6 octets
first 4 octets are the net number last 2 octets are the host number cons
apollo 10 octets
first 4 octets are the net number last 6 octets are the host number
stun 8 octets
novell 10 octets
first 4 octets are the net number last 6 octets are the host number
qllc 6 octets
bstun 1 octet - bi-sync serial tunnel
snapshot 1 octet
atmIlmi 4 octets
x25 pvc 2 octets (12 bits)
ipv6 16 octets
cdm nbf bgpIgx
clnsPfx upto 20 octets
http upto 70 octets
first 4 octets are the IPv4 host address next 2 octets are the TCP port number remaining(1 upto 64) octets are the URI · OCTET STRING
The address of the host that initiated the snapshot routing activity associated with this record.
An instance of this object will only be present when the associated value of ciscoSnapshotClient is false.
ciscoSnapshotProtocolsExchanged
1.3.6.1.4.1.9.9.19.1.3.1.8
OCTET STRING SIZE (0..4)
An array of bits that indicates whether or not routing information has been exchanged for all protocols. The most significant bit of the first octet represents the protocol associated with CiscoNetworkProtocol value of 0; the least significant bit of the first octet represents the protocol associated with CiscoNetworkProtocol value of 7; the most significant bit of the second octet represents the protocol associated with the CiscoNetworkProtocol value of 8; and so forth. Routing information for a given protocol has been exchanged if the associated bit is set.
An instance of this object will only be present when the associated value of ciscoSnapshotClient is true.