EZ5 MIB Catalog

CISCO-SYSLOG-EXT-MIB

2019-04-02

Corrected the spelling of Telemetry in SyslogExFacility TC.

Download CISCO-SYSLOG-EXT-MIB.txt Open CISCO-SYSLOG-EXT-MIB.txt in a new tab

SCALARS (10) · TABLES (2)

Scalars (10)

NameOID
cseSyslogConsoleEnable1.3.6.1.4.1.9.9.301.1.1.1
cseSyslogConsoleMsgSeverity1.3.6.1.4.1.9.9.301.1.1.2
cseSyslogLogFileName1.3.6.1.4.1.9.9.301.1.1.3
cseSyslogLogFileMsgSeverity1.3.6.1.4.1.9.9.301.1.1.4
cseSyslogFileLoggingDisable1.3.6.1.4.1.9.9.301.1.1.5
cseSyslogServerTableMaxEntries1.3.6.1.4.1.9.9.301.1.1.6
cseSyslogTerminalEnable1.3.6.1.4.1.9.9.301.1.1.9
cseSyslogTerminalMsgSeverity1.3.6.1.4.1.9.9.301.1.1.10
cseSyslogLinecardEnable1.3.6.1.4.1.9.9.301.1.1.11
cseSyslogLinecardMsgSeverity1.3.6.1.4.1.9.9.301.1.1.12

Tables (2)

NameOID
cseSyslogServerTable1.3.6.1.4.1.9.9.301.1.1.7
cseSyslogMessageControlTable1.3.6.1.4.1.9.9.301.1.1.8

END OF TOC

Scalar details

cseSyslogConsoleEnable

1.3.6.1.4.1.9.9.301.1.1.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicate whether the Syslog messages should be sent to the console.

cseSyslogConsoleMsgSeverity

1.3.6.1.4.1.9.9.301.1.1.2

SyslogSeverity1 = emergency2 = alert3 = critical4 = error5 = warning6 = notice7 = info8 = debugThe severity of a syslog message. The enumeration values are equal to the values that syslog uses + 1. For example, with syslog, emergency=0. 'emergency' : system is unusable 'alert' : action must be taken immediately 'critical' : critical conditions 'error' : error conditions 'warning' : warning conditions 'notice' : normal but significant condition 'informational': informational messages 'debug' : debug-level messages.Reference: RFC 3164, Section 4.1 - syslog Message Parts · Integer32

Minimum severity of the message that are sent to the Console.

cseSyslogLogFileName

1.3.6.1.4.1.9.9.301.1.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Name of file to which the Syslog messages are logged. Set operation with a zero length will fail.

cseSyslogLogFileMsgSeverity

1.3.6.1.4.1.9.9.301.1.1.4

SyslogSeverity1 = emergency2 = alert3 = critical4 = error5 = warning6 = notice7 = info8 = debugThe severity of a syslog message. The enumeration values are equal to the values that syslog uses + 1. For example, with syslog, emergency=0. 'emergency' : system is unusable 'alert' : action must be taken immediately 'critical' : critical conditions 'error' : error conditions 'warning' : warning conditions 'notice' : normal but significant condition 'informational': informational messages 'debug' : debug-level messages.Reference: RFC 3164, Section 4.1 - syslog Message Parts · Integer32

Minimum severity of the message that are sent to the log file (cseSyslogLogFileName).

cseSyslogFileLoggingDisable

1.3.6.1.4.1.9.9.301.1.1.5

INTEGER1 = true2 = noOp · Integer32

Indicates whether the Syslog messages should be sent to the file indicated by cseSyslogLogFileName. Once this object is set to 'true', the Syslog messages are no longer sent to the file. The value of 'cseSyslogLogFileName' is set to zero length string. To restart the file logging, the cseSyslogLogFileName should be set to a valid file name. No action is taken if this object is set to 'noOp'. The value of the object when read is always 'noOp'.

cseSyslogServerTableMaxEntries

1.3.6.1.4.1.9.9.301.1.1.6

Unsigned32 (0..65535)

The maximum number of entries that the agent supports in the cseSyslogServerTable.

cseSyslogTerminalEnable

1.3.6.1.4.1.9.9.301.1.1.9

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicate whether the Syslog messages should be sent to the terminals.

cseSyslogTerminalMsgSeverity

1.3.6.1.4.1.9.9.301.1.1.10

SyslogSeverity1 = emergency2 = alert3 = critical4 = error5 = warning6 = notice7 = info8 = debugThe severity of a syslog message. The enumeration values are equal to the values that syslog uses + 1. For example, with syslog, emergency=0. 'emergency' : system is unusable 'alert' : action must be taken immediately 'critical' : critical conditions 'error' : error conditions 'warning' : warning conditions 'notice' : normal but significant condition 'informational': informational messages 'debug' : debug-level messages.Reference: RFC 3164, Section 4.1 - syslog Message Parts · Integer32

Minimum severity of the message that are sent to the terminals.

cseSyslogLinecardEnable

1.3.6.1.4.1.9.9.301.1.1.11

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicate whether the Syslog messages should be generated at the line cards.

cseSyslogLinecardMsgSeverity

1.3.6.1.4.1.9.9.301.1.1.12

SyslogSeverity1 = emergency2 = alert3 = critical4 = error5 = warning6 = notice7 = info8 = debugThe severity of a syslog message. The enumeration values are equal to the values that syslog uses + 1. For example, with syslog, emergency=0. 'emergency' : system is unusable 'alert' : action must be taken immediately 'critical' : critical conditions 'error' : error conditions 'warning' : warning conditions 'notice' : normal but significant condition 'informational': informational messages 'debug' : debug-level messages.Reference: RFC 3164, Section 4.1 - syslog Message Parts · Integer32

Minimum severity of the message that are sent from linecards.

Table details

cseSyslogServerTable

1.3.6.1.4.1.9.9.301.1.1.7

Index: cseSyslogServerIndex

This table contains all the Syslog servers which are configured.

cseSyslogServerIndex

1.3.6.1.4.1.9.9.301.1.1.7.1.1

Unsigned32 (1..65535)

An arbitrary integer value, greater than zero, and less than and equal to cseSyslogServerTableMaxEntries, which identifies a Syslog server row in this table.

cseSyslogServerAddressType

1.3.6.1.4.1.9.9.301.1.1.7.1.2

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The type of the address of the Syslog server which is given by the corresponding value of cseSyslogServerAddress.

cseSyslogServerAddress

1.3.6.1.4.1.9.9.301.1.1.7.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The address of the Syslog server.

cseSyslogServerMsgSeverity

1.3.6.1.4.1.9.9.301.1.1.7.1.4

SyslogSeverity1 = emergency2 = alert3 = critical4 = error5 = warning6 = notice7 = info8 = debugThe severity of a syslog message. The enumeration values are equal to the values that syslog uses + 1. For example, with syslog, emergency=0. 'emergency' : system is unusable 'alert' : action must be taken immediately 'critical' : critical conditions 'error' : error conditions 'warning' : warning conditions 'notice' : normal but significant condition 'informational': informational messages 'debug' : debug-level messages.Reference: RFC 3164, Section 4.1 - syslog Message Parts · Integer32

Minimum severity of the message that are sent to this Syslog server.

cseSyslogServerStatus

1.3.6.1.4.1.9.9.301.1.1.7.1.5

RowStatus1 = active2 = notInService3 = notReady4 = createAndGo5 = createAndWait6 = destroyThe RowStatus textual convention is used to manage the creation and deletion of conceptual rows, and is used as the value of the SYNTAX clause for the status column of a conceptual row (as described in Section 7.7.1 of [2].) The status column has six defined values: - `active', which indicates that the conceptual row is available for use by the managed device; - `notInService', which indicates that the conceptual row exists in the agent, but is unavailable for use by the managed device (see NOTE below); 'notInService' has no implication regarding the internal consistency of the row, availability of resources, or consistency with the current state of the managed device; - `notReady', which indicates that the conceptual row exists in the agent, but is missing information necessary in order to be available for use by the managed device (i.e., one or more required columns in the conceptual row have not been instanciated); - `createAndGo', which is supplied by a management station wishing to create a new instance of a conceptual row and to have its status automatically set to active, making it available for use by the managed device; - `createAndWait', which is supplied by a management station wishing to create a new instance of a conceptual row (but not make it available for use by the managed device); and, - `destroy', which is supplied by a management station wishing to delete all of the instances associated with an existing conceptual row. Whereas five of the six values (all except `notReady') may be specified in a management protocol set operation, only three values will be returned in response to a management protocol retrieval operation: `notReady', `notInService' or `active'. That is, when queried, an existing conceptual row has only three states: it is either available for use by the managed device (the status column has value `active'); it is not available for use by the managed device, though the agent has sufficient information to attempt to make it so (the status column has value `notInService'); or, it is not available for use by the managed device, and an attempt to make it so would fail because the agent has insufficient information (the state column has value `notReady'). NOTE WELL This textual convention may be used for a MIB table, irrespective of whether the values of that table's conceptual rows are able to be modified while it is active, or whether its conceptual rows must be taken out of service in order to be modified. That is, it is the responsibility of the DESCRIPTION clause of the status column to specify whether the status column must not be `active' in order for the value of some other column of the same conceptual row to be modified. If such a specification is made, affected columns may be changed by an SNMP set PDU if the RowStatus would not be equal to `active' either immediately before or after processing the PDU. In other words, if the PDU also contained a varbind that would change the RowStatus value, the column in question may be changed if the RowStatus was not equal to `active' as the PDU was received, or if the varbind sets the status to a value other than 'active'. Also note that whenever any elements of a row exist, the RowStatus column must also exist. To summarize the effect of having a conceptual row with a status column having a SYNTAX clause value of RowStatus, consider the following state diagram: STATE +--------------+-----------+-------------+------------- | A | B | C | D | |status col.|status column| |status column | is | is |status column ACTION |does not exist| notReady | notInService| is active --------------+--------------+-----------+-------------+------------- set status |noError ->D|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndGo |inconsistent- | | | | Value| | | --------------+--------------+-----------+-------------+------------- set status |noError see 1|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndWait |wrongValue | | | --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError column to | Value| entValue| | active | | | | | | or | | | | | | | |see 2 ->D|see 8 ->D| ->D --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError ->C column to | Value| entValue| | notInService | | | | | | or | | or | | | | | |see 3 ->C| ->C|see 6 --------------+--------------+-----------+-------------+------------- set status |noError |noError |noError |noError ->A column to | | | | or destroy | ->A| ->A| ->A|see 7 --------------+--------------+-----------+-------------+------------- set any other |see 4 |noError |noError |see 5 column to some| | | | value | | see 1| ->C| ->D --------------+--------------+-----------+-------------+------------- (1) goto B or C, depending on information available to the agent. (2) if other variable bindings included in the same PDU, provide values for all columns which are missing but required, and all columns have acceptable values, then return noError and goto D. (3) if other variable bindings included in the same PDU, provide legal values for all columns which are missing but required, then return noError and goto C. (4) at the discretion of the agent, the return value may be either: inconsistentName: because the agent does not choose to create such an instance when the corresponding RowStatus instance does not exist, or inconsistentValue: if the supplied value is inconsistent with the state of some other MIB object's value, or noError: because the agent chooses to create the instance. If noError is returned, then the instance of the status column must also be created, and the new state is B or C, depending on the information available to the agent. If inconsistentName or inconsistentValue is returned, the row remains in state A. (5) depending on the MIB definition for the column/table, either noError or inconsistentValue may be returned. (6) the return value can indicate one of the following errors: wrongValue: because the agent does not support notInService (e.g., an agent which does not support createAndWait), or inconsistentValue: because the agent is unable to take the row out of service at this time, perhaps because it is in use and cannot be de-activated. (7) the return value can indicate the following error: inconsistentValue: because the agent is unable to remove the row at this time, perhaps because it is in use and cannot be de-activated. (8) the transition to D can fail, e.g., if the values of the conceptual row are inconsistent, then the error code would be inconsistentValue. NOTE: Other processing of (this and other varbinds of) the set request may result in a response other than noError being returned, e.g., wrongValue, noCreation, etc. Conceptual Row Creation There are four potential interactions when creating a conceptual row: selecting an instance-identifier which is not in use; creating the conceptual row; initializing any objects for which the agent does not supply a default; and, making the conceptual row available for use by the managed device. Interaction 1: Selecting an Instance-Identifier The algorithm used to select an instance-identifier varies for each conceptual row. In some cases, the instance- identifier is semantically significant, e.g., the destination address of a route, and a management station selects the instance-identifier according to the semantics. In other cases, the instance-identifier is used solely to distinguish conceptual rows, and a management station without specific knowledge of the conceptual row might examine the instances present in order to determine an unused instance-identifier. (This approach may be used, but it is often highly sub-optimal; however, it is also a questionable practice for a naive management station to attempt conceptual row creation.) Alternately, the MIB module which defines the conceptual row might provide one or more objects which provide assistance in determining an unused instance-identifier. For example, if the conceptual row is indexed by an integer-value, then an object having an integer-valued SYNTAX clause might be defined for such a purpose, allowing a management station to issue a management protocol retrieval operation. In order to avoid unnecessary collisions between competing management stations, `adjacent' retrievals of this object should be different. Finally, the management station could select a pseudo-random number to use as the index. In the event that this index was already in use and an inconsistentValue was returned in response to the management protocol set operation, the management station should simply select a new pseudo-random number and retry the operation. A MIB designer should choose between the two latter algorithms based on the size of the table (and therefore the efficiency of each algorithm). For tables in which a large number of entries are expected, it is recommended that a MIB object be defined that returns an acceptable index for creation. For tables with small numbers of entries, it is recommended that the latter pseudo-random index mechanism be used. Interaction 2: Creating the Conceptual Row Once an unused instance-identifier has been selected, the management station determines if it wishes to create and activate the conceptual row in one transaction or in a negotiated set of interactions. Interaction 2a: Creating and Activating the Conceptual Row The management station must first determine the column requirements, i.e., it must determine those columns for which it must or must not provide values. Depending on the complexity of the table and the management station's knowledge of the agent's capabilities, this determination can be made locally by the management station. Alternately, the management station issues a management protocol get operation to examine all columns in the conceptual row that it wishes to create. In response, for each column, there are three possible outcomes: - a value is returned, indicating that some other management station has already created this conceptual row. We return to interaction 1. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it should supply a value for this column when the conceptual row is to be created. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. Once the column requirements have been determined, a management protocol set operation is accordingly issued. This operation also sets the new instance of the status column to `createAndGo'. When the agent processes the set operation, it verifies that it has sufficient information to make the conceptual row available for use by the managed device. The information available to the agent is provided by two sources: the management protocol set operation which creates the conceptual row, and, implementation-specific defaults supplied by the agent (note that an agent must provide implementation-specific defaults for at least those objects which it implements as read-only). If there is sufficient information available, then the conceptual row is created, a `noError' response is returned, the status column is set to `active', and no further interactions are necessary (i.e., interactions 3 and 4 are skipped). If there is insufficient information, then the conceptual row is not created, and the set operation fails with an error of `inconsistentValue'. On this error, the management station can issue a management protocol retrieval operation to determine if this was because it failed to specify a value for a required column, or, because the selected instance of the status column already existed. In the latter case, we return to interaction 1. In the former case, the management station can re-issue the set operation with the additional information, or begin interaction 2 again using `createAndWait' in order to negotiate creation of the conceptual row. NOTE WELL Regardless of the method used to determine the column requirements, it is possible that the management station might deem a column necessary when, in fact, the agent will not allow that particular columnar instance to be created or written. In this case, the management protocol set operation will fail with an error such as `noCreation' or `notWritable'. In this case, the management station decides whether it needs to be able to set a value for that particular columnar instance. If not, the management station re-issues the management protocol set operation, but without setting a value for that particular columnar instance; otherwise, the management station aborts the row creation algorithm. Interaction 2b: Negotiating the Creation of the Conceptual Row The management station issues a management protocol set operation which sets the desired instance of the status column to `createAndWait'. If the agent is unwilling to process a request of this sort, the set operation fails with an error of `wrongValue'. (As a consequence, such an agent must be prepared to accept a single management protocol set operation, i.e., interaction 2a above, containing all of the columns indicated by its column requirements.) Otherwise, the conceptual row is created, a `noError' response is returned, and the status column is immediately set to either `notInService' or `notReady', depending on whether it has sufficient information to (attempt to) make the conceptual row available for use by the managed device. If there is sufficient information available, then the status column is set to `notInService'; otherwise, if there is insufficient information, then the status column is set to `notReady'. Regardless, we proceed to interaction 3. Interaction 3: Initializing non-defaulted Objects The management station must now determine the column requirements. It issues a management protocol get operation to examine all columns in the created conceptual row. In the response, for each column, there are three possible outcomes: - a value is returned, indicating that the agent implements the object-type associated with this column and had sufficient information to provide a value. For those columns to which the agent provides read-create access (and for which the agent allows their values to be changed after their creation), a value return tells the management station that it may issue additional management protocol set operations, if it desires, in order to change the value associated with this column. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. However, the agent does not have sufficient information to provide a value, and until a value is provided, the conceptual row may not be made available for use by the managed device. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it must issue additional management protocol set operations, in order to provide a value associated with this column. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. If the value associated with the status column is `notReady', then the management station must first deal with all `noSuchInstance' columns, if any. Having done so, the value of the status column becomes `notInService', and we proceed to interaction 4. Interaction 4: Making the Conceptual Row Available Once the management station is satisfied with the values associated with the columns of the conceptual row, it issues a management protocol set operation to set the status column to `active'. If the agent has sufficient information to make the conceptual row available for use by the managed device, the management protocol set operation succeeds (a `noError' response is returned). Otherwise, the management protocol set operation fails with an error of `inconsistentValue'. NOTE WELL A conceptual row having a status column with value `notInService' or `notReady' is unavailable to the managed device. As such, it is possible for the managed device to create its own instances during the time between the management protocol set operation which sets the status column to `createAndWait' and the management protocol set operation which sets the status column to `active'. In this case, when the management protocol set operation is issued to set the status column to `active', the values held in the agent supersede those used by the managed device. If the management station is prevented from setting the status column to `active' (e.g., due to management station or network failure) the conceptual row will be left in the `notInService' or `notReady' state, consuming resources indefinitely. The agent must detect conceptual rows that have been in either state for an abnormally long period of time and remove them. It is the responsibility of the DESCRIPTION clause of the status column to indicate what an abnormally long period of time would be. This period of time should be long enough to allow for human response time (including `think time') between the creation of the conceptual row and the setting of the status to `active'. In the absence of such information in the DESCRIPTION clause, it is suggested that this period be approximately 5 minutes in length. This removal action applies not only to newly-created rows, but also to previously active rows which are set to, and left in, the notInService state for a prolonged period exceeding that which is considered normal for such a conceptual row. Conceptual Row Suspension When a conceptual row is `active', the management station may issue a management protocol set operation which sets the instance of the status column to `notInService'. If the agent is unwilling to do so, the set operation fails with an error of `wrongValue' or `inconsistentValue'. Otherwise, the conceptual row is taken out of service, and a `noError' response is returned. It is the responsibility of the DESCRIPTION clause of the status column to indicate under what circumstances the status column should be taken out of service (e.g., in order for the value of some other column of the same conceptual row to be modified). Conceptual Row Deletion For deletion of conceptual rows, a management protocol set operation is issued which sets the instance of the status column to `destroy'. This request may be made regardless of the current value of the status column (e.g., it is possible to delete conceptual rows which are either `notReady', `notInService' or `active'.) If the operation succeeds, then all instances associated with the conceptual row are immediately removed. · Integer32

The status of this row. A row can not become 'active' until the values for cseSyslogServerAddressType and cseSyslogServerAddress in that row have both been set. A row cannot be created until corresponding instances of following objects are instantiated. - cseSyslogServerAddressType - cseSyslogServerAddress The following objects may not be modified while the value of this object is active (1): - cseSyslogServerAddressType - cseSyslogServerAddress.

cseSyslogServerFacility

1.3.6.1.4.1.9.9.301.1.1.7.1.6

SyslogFacility0 = kernel8 = user16 = mail24 = daemon32 = auth40 = syslog48 = lpr56 = news64 = uucp72 = cron80 = authPriv88 = ftp128 = local0136 = local1144 = local2152 = local3160 = local4168 = local5176 = local6184 = local7The Syslog standard facilities. kernel (0) - Kernel user (8) - User Level mail (16) - Mail System daemon(24) - System Daemon auth (32) - Security/Authorization syslog (40) - Internal Syslogd lpr (48) - Line Printer subsystem news (56) - Network New subsystem uucp (64) - UUCP subsystem cron (72) - Clock Daemon authPriv (80) - Security/Auth(private) ftp (88) - FTP Daemon local0 (128) - Reserved local use local1 (136) - Reserved local use local2 (144) - Reserved local use local3 (152) - Reserved local use local4 (160) - Reserved local use local5 (168) - Reserved local use local6 (176) - Reserved local use local7 (184) - Reserved local use.Reference: RFC 3164 - The BSD Syslog Protocol, Section 4. · Integer32

The facility to be used when sending Syslog messages to this server.

cseSyslogServerProtocol

1.3.6.1.4.1.9.9.301.1.1.7.1.7

SyslogProtocol6 = tcp17 = udpThe protocol used for sending syslog messages to syslog server. tcp (6) - TCP udp (17) - UDP. · Integer32

The transport protocol used for sending syslog messages to syslog server.

cseSyslogServerPort

1.3.6.1.4.1.9.9.301.1.1.7.1.8

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (1..65535) · Unsigned32 · hint d

The port number of the syslog server to which syslog messages are sent. The default value in case of 'cseSyslogServerProtocol' value of 'udp' is 514. The default value in case of 'cseSyslogServerProtocol' value of 'tcp' is 1468.

cseSyslogServerProtocolFallback

1.3.6.1.4.1.9.9.301.1.1.7.1.9

SyslogProtocol6 = tcp17 = udpThe protocol used for sending syslog messages to syslog server. tcp (6) - TCP udp (17) - UDP. · Integer32

This object is used for specifying the protcol to fallback to if the sending of syslog messages using the protocol configured in 'cseSyslogServerProtocol' fails. If the value of this object is same as the value specified in 'cseSyslogServerProtocol', then protocol fallback in case of failure is not supported.

cseSyslogMessageControlTable

1.3.6.1.4.1.9.9.301.1.1.8

Index: cseSyslogMessageFacility

This table contains the information about what system log messages should be sent to Syslog host, console, log file, and/or logged into the internal buffer.

cseSyslogMessageFacility

1.3.6.1.4.1.9.9.301.1.1.8.1.1

SyslogExFacility0 = kernel8 = user16 = mail24 = daemon32 = auth40 = syslog48 = lpr56 = news64 = uucp72 = cron80 = authPriv88 = ftp128 = local0136 = local1144 = local2152 = local3160 = local4168 = local5176 = local6184 = local7200 = vsanMgr208 = fspf216 = domainMgr224 = mtsDaemon232 = linecardMgr240 = sysMgr248 = sysMgrLib256 = zoneServer264 = virtualIfMgr272 = ipConfMgr280 = ipfc288 = xBarMgr296 = fcDns304 = fabricConfMgr312 = aclMgr320 = tlPortMgr328 = portMgr336 = fportServer344 = portChMgr352 = mpls360 = tftpLib368 = wwnMgr376 = fcc384 = qosMgr392 = vhba400 = procMgr408 = fcRedirect416 = span424 = vrrpMgr432 = fcfwd440 = ntp448 = pltmfmMgr456 = xbarClient464 = vrrpEngine472 = callhome480 = ipsMgr488 = fc2496 = debugLib504 = vpm512 = mcast520 = rdl536 = rscn552 = bootvar576 = pss584 = snmp592 = security608 = vhbad648 = dns656 = rib672 = vshd688 = fvpd704 = prefpath736 = avm816 = mplsTunnel848 = cdpd920 = ohmsd928 = migd960 = portSec976 = ethPortMgr992 = zbm1016 = ipaclMgr1064 = ficonMgr1072 = fsDaemon1096 = ficonContDev1128 = rlir1136 = fdmi1152 = licmgr1160 = fcspmgr1168 = epp1192 = confCheck1232 = ivr1240 = aaad1248 = tacacsd1256 = radiusd1320 = fc2d1328 = cimServer1336 = lcohmsd1344 = isns1352 = ficonStat1360 = featureMgr1376 = lttd1392 = fccLc1408 = ilcHelper1432 = cfs1448 = dstats1456 = ipsec1480 = dpvm1488 = ike1504 = ddas1512 = scheduler1520 = sanExtTuner1536 = fscm1712 = cloud1720 = smartCard1752 = certEnroll1768 = stp1784 = ethpm1792 = pixm1816 = ifMgr1872 = plugin1936 = acl2048 = ldap2072 = portResources2080 = aclqos2088 = portSecurity2112 = eltm2120 = udld2144 = svi2160 = mfdm2176 = vlanMgr2184 = ufdm2240 = aclmgr2248 = dot1x2368 = nfm2376 = hsrpEngine2384 = bgp2392 = l2fm2400 = evms2416 = evmc2440 = monitor2448 = lacp2528 = vdcMgr2592 = sdv2600 = glbp2608 = dhcpSnooping2616 = xmlma2648 = diagclient2656 = diagmgr2704 = vedbMgr2728 = cluster2760 = ipv6Conf2800 = ipqosMgr2840 = ethPortChannel2848 = otm2888 = l3vm2896 = m6rib2904 = mrib2920 = pim2936 = rpm2944 = u6rib2952 = urib2960 = smm2976 = resMgr3048 = ip3056 = ipv63080 = arp3096 = diagportlb3112 = vmm3144 = tm3152 = npv3160 = deviceTest3168 = cts3200 = sal3216 = copp3248 = sme3296 = mvsh3336 = pltfmCfg3360 = acllog3448 = orib3496 = m2rib3512 = vpc3544 = u2rib3576 = lldp3680 = aam3872 = spm3888 = sifMgr3904 = fwm3920 = zschk3952 = afm3960 = gatosUsd3984 = pfm4008 = nicmgr4024 = qd4032 = nqosm4040 = ethpc4048 = fcpc4056 = enm4064 = dcbx4072 = altos4088 = nohms4096 = satMgr4104 = satCtrl4112 = redwoodUsd4120 = fwmCtrl4128 = qosCtrl4136 = nppm4144 = satSyslog4152 = fcoeMgr4168 = ioa4192 = ppm4208 = bfd4224 = wccp4320 = vntagMgr4368 = assocMgr4552 = l2pt4592 = clkmgr4880 = cmond5168 = evc5320 = slaSender5328 = slaResponder5640 = iscm5744 = pixmgl5752 = pixmvl5776 = blogger5784 = snmpmib5808 = plsm5840 = giscm5848 = sim5864 = vman5920 = fpOam5960 = lim6016 = ecp6048 = adbm6168 = plcmgr6368 = patchd6592 = nxapi6824 = analytics7128 = vmis7272 = telemetryThe Syslog facilities including both standard and proprietary facilities. kernel (0) - Kernel user (8) - User Level mail (16) - Mail System daemon(24) - System Daemon auth (32) - Security/Authorization syslog (40) - Internal Syslogd lpr (48) - Line Printer subsystem news (56) - Network New subsystem uucp (64) - UUCP subsystem cron (72) - Clock Daemon authPriv (80) - Security/Auth(private) ftp (88) - FTP Daemon local0 (128) - Reserved local use local1 (136) - Reserved local use local2 (144) - Reserved local use local3 (152) - Reserved local use local4 (160) - Reserved local use local5 (168) - Reserved local use local6 (176) - Reserved local use local7 (184) - Reserved local use vsanMgr (200) - VSAN Manager fspf (208) - FSPF domainMgr (216) - Domain Manager mtsDaemon (224) - MTS Daemon linecardMgr (232) - Line Card Mgr sysMgr (240) - System Manager sysMgrLib (248) - System Mgr Library zoneServer (256) - Zone Server virtualIfMgr (264) - VirtualInterface Mgr ipConfMgr (272) - IP Config Manager ipfc (280) - IP Over FC xBarMgr (288) - Xbar Manager fcDns (296) - Fibre Channel DNS fabricConfMgr (304) - Fabric Config Server aclMgr (312) - AccessControlList Mgr tlPortMgr (320) - TL Port Manager portMgr (328) - Port Manager fportServer (336) - FPort Server portChMgr (344) - Port Channel Mgr mpls (352) - MPLS tftpLib (360) - TFTP Library wwnMgr (368) - WWN Mgr fcc (376), - FCC Process qosMgr (384) - QOS Mgr vhba (392) - VHBA procMgr (400) - Proc Mgr fcRedirect (408) - FC Redirect span (416) - SPAN vrrpMgr (424) - VRRP Mgr fcfwd (432) - FCFWD ntp (440) - NTP pltmfmMgr (448) - Platform Mgr xbarClient (456) - XBAR Client vrrpEngine (464) - VRRP Engine callhome (472) - Callhome ipsMgr (480) - IPS Mgr fc2 (488) - FC2 debugLib (496) - Debug Library vpm (504) - VPM mcast (512) - Multicast rdl (520) - RDL rscn (536) - RSCN bootvar (552) - BootVar pss (576) - Persistent Storage System snmp (584) - SNMP security (592) - Security vhbad (608) - VHBAD dns (648) - DNS rib (656) - RIB vshd (672) - VSH Daemon fvpd (688) - Fabric Virtual Port Daemon prefpath (704) - Preferred Path avm (736) - Avanti Mgr mplsTunnel (816) - MPLS Tunnel cdpd (848) - CDP Daemon ohmsd (920) - OHMs Daemon migd (928) - Capability Daemon portSec (960) - Port Security Manager ethPortMgr (976) - Ethernet Port Manager zbm (992) - Zone Block Manager ipaclMgr (1016) - IP ACL Manager ficonMgr (1064) - FICON Manager fsDaemon (1072) - Sup-filesystem Daemon ficonContDev (1096) - Ficon Control Device rlir (1128) - RLIR Module fdmi (1136) - Fabric Device Management Interface licmgr (1152) - License Manager fcspmgr (1160) - FCSP Manager epp (1168) - Exchange Peer Parameters confCheck (1192) - Configuration Check ivr (1232) - Inter-VSAN Routing aaad (1240) - AAA Daemon tacacsd (1248) - TACACS Daemon radiusd (1256) - Radius Daemon fc2d (1320) - FC2 Daemon cimServer (1328) - Common Information Model Server lcohmsd (1336) - LC Ohms Daemon isns (1344) - iSNS ficonStat (1352) - FICON Statistics, featureMgr (1360) - Feature Manager lttd (1376) - LTT Daemon fccLc (1392) - linecard FCC ilcHelper (1408) - ILC Helper cfs (1432) - Cisco Fabric Services dstats (1448) - Delta Statistics ipsec (1456) - IP Sec dpvm (1480) - Dynamic Port Vsan Mgr ike (1488) - IKE ddas (1504) - DDAS scheduler (1512) - scheduler fscm (1536) - Fabric Startup Configuration Manager sanExtTuner (1520) - SAN extension Tuner cloud (1712) - Cloud smartCard (1720) - Smart Card certEnroll (1752) - Certificate Enrollment stp (1768) - Spanning Tree Protocol ethpm (1784) - Ethernet Port Manager pixm (1792) - Port-index Manager ifMgr (1816) - Interface Manager plugin (1872) - Plugin Manager acl (1936) - AccessControlList ldap (2048) - LDAP portResources(2072) - Port Resource Manager aclqos (2080) - ACL Qos portSecurity (2088) - Ethernet Port Security eltm (2112) - Eureka Lamira Table Manager udld (2120) - Uni-Directional Link Detection svi (2144) - SVI mfdm (2160) - Multicast FIB Distribution Manager vlanMgr (2176) - VLAN Manager ufdm (2184) - Unicast FIB Distribution Manager aclMgr (2240) - Access Control List Manager dot1x (2248) - IEEE 802.1X nfm (2368) - Netflow Manager hsrpEngine (2376) - Hot Standby Router Protocol(HSRP) Engine bgp (2384) - Border Gateway Protocol l2fm (2392) - Layer-2 Forwarding Manager evms (2400) - Event Management Server evmc (2416) - Event Manager monitor (2440) - Ethernet and FC SPAN lacp (2448) - Link Aggregation Control Protocol vdcMgr (2528) - Virtual Device Context Manager sdv (2592) - SAN Device Virtualization glbp (2600) - Gateway Load Balancing Protocol dhcpSnooping (2608) - Dynamic Host Configuration Protocol (DHCP) Snooping xmlma (2616) - XML Master Agent diagclient(2648) - Diag Client diagmgr (2656) - GOLD DiagMgr vedbMgr (2704) - VEBD Mgr cluster(2728) - Cluster Service ipv6Conf (2760) - IP v6 Configuration ipqosMgr(2800) - IP QOS Manager ethPortChannel (2840) - Ethernet Port Channel otm (2848) - Object Tracking Manager l3vm (2888) - L3 Virtualization Manager m6rib (2896) - Multicast IPv6 Routing Information Base mrib (2904) - Multicast IP Routing Information Base pim (2920) - Protocol Independent Multicast rpm (2936) - Routing Policy Manager u6rib (2944) - Unicast Routing Info Base for IPv6 urib (2952) - Unicast Routing Info Base smm (2960) - Shared Memory Mgr resMgr (2976) - Resource Manager ip (3048) - IP ipv6 (3056) - IP v6 arp (3080) - Address Resolution Protocol diagportlb (3096) - Diagnostic Port Loopback Test vmm (3112) - Virtual Module Manager tm (3144) - Tunnel Manager npv (3152) - N_Port Virtualizer deviceTest (3160) - Gold Device Test cts (3168) - Cisco TrustSec(CTS) sal (3200) - Security Hardware Abstraction Layer copp (3216) - Control Plane Policing sme (3248) - SME Service mvsh (3296) - Message VSH Server pltfmCfg(3336) - Platform Config Logging acllog(3360) - ACL Logging orib (3448) - OTV Routing Information Base m2rib (3496) - L2 Multicast RIB vpc (3512) - Virtual Port-Channel u2rib (3544) - L2 Unicast RIB lldp (3576) - LLDP aam (3680) - Abstract ACL Manager spm (3872) - Service Policy Manager sifMgr (3888) - Server Interface Manager fwm (3904) - Forwarding Manager zschk(3920) - Zone check afm(3952) - ACL Feature Manager gatosUsd(3960) - Gatos USD pfm(3984) - Nuova Platform Manager nicmgr(4008) - Nic Manager qd(4024) - Qos Driver nqosm(4032) - Nuova Qos Manager ethpc(4040) - Ethernet Port Client fcpc(4048) - FC Port Client enm(4056) - endnode manager dcbx(4064) - DCBX Protocol altos(4072) - altosusd nohms(4088) - Nuova ohms satMgr(4096) - Satellite manager satCtrl(4104) - Satellite control redwoodUsd(4112) - redwood usd fwmCtrl(4120) - forwarding ctrl qosCtrl(4128) - Qos Controller nppm(4136) - Nuova Port Profile Manager satSyslog(4144) - Satellite Syslog fcoeMgr(4152) - Fcoe manager ioa(4168) - IO Accel Service ppm(4192) - Port Profile Manager bfd (4208) - Bi-directional Forwarding Detection wccp (4224) - Web Cache Communication Protocol vntagMgr(4320) - VNTag Manager assocMgr(4368) - Association Manager l2pt (4552) - L2 Protocol Tunneling for Qinq clkmgr(4592) - Clock Manager cmond (4880) - CPU Monitor evc (5168) - Flexible VLAN Match And Rewrite slaSender (5320) - Service Level Agreements (SLA) Sender slaResponder (5328) - Service Level Agreements (SLA) Responder iscm (5640) - ISCM pixmgl(5744) - PIXMGL pixmvl(5752) - PIXMVL blogger (5776) - Blogger Daemon snmpmib(5784) - SNMP MIB Proc plsm(5808) - PLSM giscm (5840) - GISCM sim(5848) - Shadow Interface Manager vman (5864) - VMAN fpOam (5920) - FabricPath Operations Administration and Maintenance(OAM) lim(5960) - Logical Interface Manager ecp(6016) - ECP Daemon adbm(6048) - Asset DB Manager plcmgr(6168) - PLC Manager patchd(6368) - Patch Installer nxapi(6592) - NXAPI analytics(6824) - ANALYTICS vmis(7128) - VMIS telemetry(7272) - TELEMETRYReference: RFC 3164 - The BSD Syslog Protocol, Section 4. · Integer32

System log message facility.

cseSyslogMessageSeverity

1.3.6.1.4.1.9.9.301.1.1.8.1.2

SyslogSeverity1 = emergency2 = alert3 = critical4 = error5 = warning6 = notice7 = info8 = debugThe severity of a syslog message. The enumeration values are equal to the values that syslog uses + 1. For example, with syslog, emergency=0. 'emergency' : system is unusable 'alert' : action must be taken immediately 'critical' : critical conditions 'error' : error conditions 'warning' : warning conditions 'notice' : normal but significant condition 'informational': informational messages 'debug' : debug-level messages.Reference: RFC 3164, Section 4.1 - syslog Message Parts · Integer32

Minimum severity of the message that are generated by this Syslog message facility.

↑ To TOC