EZ5 MIB Catalog

CISCO-SYSTEM-EXT-MIB

2016-06-14

MIB module for monitoring High Availability, SNMP SET errors and bandwidths. This mib module also provides the information on core files that are generated in the system. GLOSSARY FIPS Federal Information Processing Standards Publication.

Download CISCO-SYSTEM-EXT-MIB.txt Open CISCO-SYSTEM-EXT-MIB.txt in a new tab

SCALARS (23) · TABLES (2) · TRAPS (6)

Scalars (23)

NameOID
cseSysCPUUtilization1.3.6.1.4.1.9.9.305.1.1.1
cseSysMemoryUtilization1.3.6.1.4.1.9.9.305.1.1.2
cseSysConfLastChange1.3.6.1.4.1.9.9.305.1.1.3
cseSysAutoSync1.3.6.1.4.1.9.9.305.1.1.4
cseSysAutoSyncState1.3.6.1.4.1.9.9.305.1.1.5
cseWriteErase1.3.6.1.4.1.9.9.305.1.1.6
cseSysConsolePortStatus1.3.6.1.4.1.9.9.305.1.1.7
cseSysTelnetServiceActivation1.3.6.1.4.1.9.9.305.1.1.8
cseSysFIPSModeActivation1.3.6.1.4.1.9.9.305.1.1.9
cseSysUpTime1.3.6.1.4.1.9.9.305.1.1.10
cseHaRestartReason1.3.6.1.4.1.9.9.305.1.3.2
cseHaRestartStateless1.3.6.1.4.1.9.9.305.1.3.3
cseHaRestartService1.3.6.1.4.1.9.9.305.1.3.4
cseHaShutDownReason1.3.6.1.4.1.9.9.305.1.3.6
cseSwCorePath1.3.6.1.4.1.9.9.305.1.4.1
ciscoSwFailureNotifEnable1.3.6.1.4.1.9.9.305.1.5.1
ciscoSystemSwitchingModeAdmin1.3.6.1.4.1.9.9.305.1.6.1
ciscoSystemSwitchingModeOper1.3.6.1.4.1.9.9.305.1.6.2
ciscoSystemSwitchingMode1.3.6.1.4.1.9.9.305.1.6.3
cseMaintModeState1.3.6.1.4.1.9.9.305.1.7.1
ciscoSystemNormalModeNotifEnable1.3.6.1.4.1.9.9.305.1.8.1
ciscoSystemMaintModeNotifEnable1.3.6.1.4.1.9.9.305.1.8.2
cseSystemReloadPending1.3.6.1.4.1.9.9.305.1.9.1

Tables (2)

NameOID
cseSnmpErrorTable1.3.6.1.4.1.9.9.305.1.2.1
cseSwCoresTable1.3.6.1.4.1.9.9.305.1.4.2

Traps (6)

NameOID
cseHaRestartNotify1.3.6.1.4.1.9.9.305.1.3.5.0.1
cseShutDownNotify1.3.6.1.4.1.9.9.305.1.3.5.0.2
cseFailSwCoreNotify1.3.6.1.4.1.9.9.305.1.4.3.0.1
cseFailSwCoreNotifyExtended1.3.6.1.4.1.9.9.305.1.4.3.0.2
cseNormalModeChangeNotify1.3.6.1.4.1.9.9.305.1.7.2.0.1
cseMaintModeChangeNotify1.3.6.1.4.1.9.9.305.1.7.2.0.2

END OF TOC

Scalar details

cseSysCPUUtilization

1.3.6.1.4.1.9.9.305.1.1.1

Gauge32 (0..100) · %

The average utilization of CPU on the active supervisor.

cseSysMemoryUtilization

1.3.6.1.4.1.9.9.305.1.1.2

Gauge32 (0..100) · %

The average utilization of memory on the active supervisor.

cseSysConfLastChange

1.3.6.1.4.1.9.9.305.1.1.3

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The local date and time when the configuration was last changed. This object will be set to zero on power cycle or on reboot of the system. Also, if the clock is changed on local system it is set to zero.

cseSysAutoSync

1.3.6.1.4.1.9.9.305.1.1.4

INTEGER1 = sync2 = noSync · Integer32

The state of the auto synchronization of images between the active and standby supervisor. Setting the value to sync when the existing value is sync, has no effect on the operation.

cseSysAutoSyncState

1.3.6.1.4.1.9.9.305.1.1.5

INTEGER1 = inProgress2 = succeeded3 = failed4 = notStarted · Integer32

The status of the current auto synchronization process, or if no such process is in progress, then the state of the most recent one. The value 'notStarted' indicates no auto synchronization process has occurred recently.

cseWriteErase

1.3.6.1.4.1.9.9.305.1.1.6

INTEGER1 = noOp2 = eraseAll · Integer32

This object is used to initiate a write erase on the device's saved configuration file(s) from which the device loads its configuration when it restarts. If the value of this object is set to 'eraseAll', then all the saved configurations are removed. No action is taken when the this object is set to 'noOp'. When read, the value of this object is always 'noOp'.

cseSysConsolePortStatus

1.3.6.1.4.1.9.9.305.1.1.7

INTEGER1 = connected2 = notConnected · Integer32

This object describes the status of the console port on this device. The status 'connected' means that there is a cable attached to the console port. The status 'notConnected' means that there is no connection out of the console port.

cseSysTelnetServiceActivation

1.3.6.1.4.1.9.9.305.1.1.8

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Enables or disables the Telnet service on the device. In other words, it enables or disables the telneting to the device.

cseSysFIPSModeActivation

1.3.6.1.4.1.9.9.305.1.1.9

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Reference: FIPS PUB 140-2 Security Requirements for Cryptographic Modules

The object to enable/disable FIPS mode on the device. FIPS 140-2 is a set of security requirements for cryptographic modules and it details the U.S. Government requirements for cryptographic modules. A module will comprise both hardware and software, eg a datacenter switching or routing module. The module is said to be in FIPS enabled mode when a request is recieved to enable the FIPS mode and a set of self-tests are successfully run in response to the request. If the self-tests fail, then an appropriate error is returned.

cseSysUpTime

1.3.6.1.4.1.9.9.305.1.1.10

TimeIntervalSecA period of time, measured in units of 1 second. · Unsigned32 · Seconds

The time (in seconds) since the entire system was last re-initialized as a result of reload. The initialization being system loaded and running with a system image software on the first active supervisor (SUP). In High Availibility (HA) capable system / System that provides Supervisor module redundancy, this uptime indicates time elapsed since the first active SUP was booted. This will not change even if the active SUP goes down and stand-by takes over as active.

cseHaRestartReason

1.3.6.1.4.1.9.9.305.1.3.2

CseHaRestartReason1 = unknown2 = ungracefulExit3 = otherSignal4 = sigterm5 = softwareUpgrade6 = configUpdate7 = configRemove8 = shutdown9 = aborted10 = heartbeatFailure11 = userTerminate12 = gracefulExit13 = noCallHomeFailure14 = serviceTimeoutReason codes for the restart of a service. unknown (1) - ungraceful exit ungracefulExit (2) - ungraceful exit otherSignal (3) - service got some other signal sigterm (4) - received SIGTERM softwareUpgrade (5) - software upgrade configUpdate (6) - config update configRemove (7) - config removal shutdown (8) - manually shutdown aborted (9) - aborted heartbeatFailure (10) - heartbeat failure userTerminate (11) - user termination gracefulExit (12) - graceful exit failureNoCallhome (13)- service exited but it does not want a callhome message to be generated serviceTimeout (14) - service timeout · Integer32

The reason for most recent restart of a service on the 'active' supervisor.

cseHaRestartStateless

1.3.6.1.4.1.9.9.305.1.3.3

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Tells if the most recent restart of a service on the 'active' supervisor was 'stateless' or not. A 'stateless' restart of a service is where no runtime information is preserved while restarting the service.

cseHaRestartService

1.3.6.1.4.1.9.9.305.1.3.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Name of the service (or process) that was restarted on the 'active' supervisor.

cseHaShutDownReason

1.3.6.1.4.1.9.9.305.1.3.6

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The description of the reason as to why the system is going to go down.

cseSwCorePath

1.3.6.1.4.1.9.9.305.1.4.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Provides the path where the software cores are stored on the system. The management application can use this path to copy the cores from the system using CISCO-FLASH-MIB.

ciscoSwFailureNotifEnable

1.3.6.1.4.1.9.9.305.1.5.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object is used for administratively enabling/disabling the cseFailSwCoreNotify or cseFailSwCoreNotifyExtended notifications.

ciscoSystemSwitchingModeAdmin

1.3.6.1.4.1.9.9.305.1.6.1

INTEGER1 = other2 = notApplicable3 = nexus30004 = nexus9000 · Integer32

Object to specify system's switching mode. 'other' - any other state not covered by below enumerations 'notApplicable' - switching mode configuration is not applicable for this system 'nexus3000' - system switching mode is configured as Nexus 3000 'nexus9000' - system switching mode is configured as Nexus 9000.

ciscoSystemSwitchingModeOper

1.3.6.1.4.1.9.9.305.1.6.2

INTEGER1 = other2 = notApplicable3 = nexus30004 = nexus9000 · Integer32

Object indicate system's operational switching mode. 'other' - any other state not covered by below enumerations 'notApplicable' - switching mode configuration is not applicable for this system 'nexus3000' - system is opeerating in Nexus 3000 mode 'nexus9000' - system is opeerating in Nexus 9000 mode.

ciscoSystemSwitchingMode

1.3.6.1.4.1.9.9.305.1.6.3

INTEGER1 = cutThrough2 = storeAndForward · Integer32

Object indicate system's operating switching mode. 'cutThrough' - switch begins forwarding the frame as soon as the switch has read the destination details in the packet header 'storeAndForward' - switch checks each frame for CRC errors before forwarding them to the network. Each frame is stored until the entire frame has been received and checked.

cseMaintModeState

1.3.6.1.4.1.9.9.305.1.7.1

CiscoMaintModeState1 = normal2 = maintenance3 = unplannedMaintMaintenance Mode state for the system. normal (1) - normal operational state maintenance (2) - maintenance mode operational state unplannedMaint (3) - unplanned maintenance state · Integer32

The maintenance mode operational state for the system.

ciscoSystemNormalModeNotifEnable

1.3.6.1.4.1.9.9.305.1.8.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object is used for administratively enabling/disabling the cseNormalModeChangeNotify.

ciscoSystemMaintModeNotifEnable

1.3.6.1.4.1.9.9.305.1.8.2

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object is used for administratively enabling/disabling the cseMaintModeChangeNotify.

cseSystemReloadPending

1.3.6.1.4.1.9.9.305.1.9.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object is used to indicate if a system reload is needed to make feature configuration change effective. The object returns 'true' if a system reload is required; it returns 'false' if no system reload is required.

Table details

cseSnmpErrorTable

1.3.6.1.4.1.9.9.305.1.2.1

Index: cseSnmpErrorAddressType · cseSnmpErrorAddress · cseSnmpErrorRequestId

A table containing information about the errors which have recently caused the generation of a SNMP Response PDU with a non-zero value in its error-status field for SNMP Set Response PDU. This table serves as an extension to the SNMP's error status when a SNMP Set request fails. SNMP returns only a pre-defined set of standard error codes which does not convey the specific cause for an error. Typically, there is an incumbent and sizable burden on the configuration application to determine if the configuration request failure is the result of a resource issue, a security issue, or an application error (like an object depending on some other objects). So from a user perspective, it is important that a specific error be made known. Ideally, when a 'badValue' error occurs for a given set request, an application can query the command responder for more details on the error. This table provides a framework for the command responders to provide more information on the SET errors. It is up to the implementation to create entries in this table for either only certain SNMP errors or all of the SNMP errors. Note that only most recent incarnation of an entry is kept in this table.

cseSnmpErrorAddressType

1.3.6.1.4.1.9.9.305.1.2.1.1.1

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The type of address from which the error-ed SetRequest originated.

cseSnmpErrorAddress

1.3.6.1.4.1.9.9.305.1.2.1.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The address from which the error-ed SetRequest originated.

cseSnmpErrorRequestId

1.3.6.1.4.1.9.9.305.1.2.1.1.3

Unsigned32

The request-id of the error-ed SetRequest.

cseSnmpErrorCode

1.3.6.1.4.1.9.9.305.1.2.1.1.4

Unsigned32

The code for the Mib object specific error which caused a SetRequest to fail. This error code is platform-specific and for debugging purposes only. For information on this code, the corresponding instance of cseSnmpErrorDescription must be used. This code is not the same as the value contained in the error-status field of SNMP Response PDU.

cseSnmpErrorDescription

1.3.6.1.4.1.9.9.305.1.2.1.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The error description for the error happened for the SetRequest.

cseSwCoresTable

1.3.6.1.4.1.9.9.305.1.4.2

Index: cseSwCoresModule · cseSwCoresProcName · cseSwCoresInstance

A table containing information about the system cores that have been generated as an effect of some system failures.

cseSwCoresModule

1.3.6.1.4.1.9.9.305.1.4.2.1.1

EntPhysicalIndexOrZeroThis textual convention is an extension of entPhysicalIndex. If non-zero, the object is an entPhysicalIndex. If zero, no appropriate entPhysicalIndex exists. Any additional semantics are object specific. (0..2147483647) · Integer32

The physical module on which the process crashed.

cseSwCoresProcName

1.3.6.1.4.1.9.9.305.1.4.2.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..64) · OCTET STRING · hint 255t

The name of the process that crashed and generated core.

cseSwCoresInstance

1.3.6.1.4.1.9.9.305.1.4.2.1.3

Unsigned32

The instance of the core for a process identified by cseSwCoresProcName and on the module identified by cseSwCoresModule. To uniquely identify a core, the module number and process name are not sufficient as there could be multiple cores for the same module number and process name.

cseSwCoresPID

1.3.6.1.4.1.9.9.305.1.4.2.1.4

Unsigned32

The process identifier of the process that dumped the core.

cseSwCoresTimeCreated

1.3.6.1.4.1.9.9.305.1.4.2.1.5

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The time at which the core was created.

cseSwCoresSlotNum

1.3.6.1.4.1.9.9.305.1.4.2.1.6

Unsigned32

The slot number corresponding to the cseSwCoresModule in this chassis.

cseSwCoresFileName

1.3.6.1.4.1.9.9.305.1.4.2.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the core file-name(including the path, relative to the value in the cseSwCorePath object). If the cseSwCorePath contains zero length octet string, then this object will contain the filename with absolute path. If this object contains zero length octet string, then the core file is available in path identified in cseSwCorePath.

Trap details

cseHaRestartNotify

1.3.6.1.4.1.9.9.305.1.3.5.0.1

A service restart notification is generated whenever a service (or a process) on the 'active' supervisor is restarted.

cseHaRestartReason

1.3.6.1.4.1.9.9.305.1.3.2

CseHaRestartReason1 = unknown2 = ungracefulExit3 = otherSignal4 = sigterm5 = softwareUpgrade6 = configUpdate7 = configRemove8 = shutdown9 = aborted10 = heartbeatFailure11 = userTerminate12 = gracefulExit13 = noCallHomeFailure14 = serviceTimeoutReason codes for the restart of a service. unknown (1) - ungraceful exit ungracefulExit (2) - ungraceful exit otherSignal (3) - service got some other signal sigterm (4) - received SIGTERM softwareUpgrade (5) - software upgrade configUpdate (6) - config update configRemove (7) - config removal shutdown (8) - manually shutdown aborted (9) - aborted heartbeatFailure (10) - heartbeat failure userTerminate (11) - user termination gracefulExit (12) - graceful exit failureNoCallhome (13)- service exited but it does not want a callhome message to be generated serviceTimeout (14) - service timeout · Integer32

The reason for most recent restart of a service on the 'active' supervisor.

cseHaRestartService

1.3.6.1.4.1.9.9.305.1.3.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Name of the service (or process) that was restarted on the 'active' supervisor.

cseHaRestartStateless

1.3.6.1.4.1.9.9.305.1.3.3

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Tells if the most recent restart of a service on the 'active' supervisor was 'stateless' or not. A 'stateless' restart of a service is where no runtime information is preserved while restarting the service.

cseShutDownNotify

1.3.6.1.4.1.9.9.305.1.3.5.0.2

A system shutdown notification is generated whenever a system is going to shut down. The cseHaShutDownReason, describes the reason as to why the system is going to go down.

cseHaShutDownReason

1.3.6.1.4.1.9.9.305.1.3.6

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The description of the reason as to why the system is going to go down.

cseFailSwCoreNotify

1.3.6.1.4.1.9.9.305.1.4.3.0.1

A notification is generated whenever a software crash occurs and a core file is generated.

cseFailSwCoreNotifyExtended

1.3.6.1.4.1.9.9.305.1.4.3.0.2

A notification is generated whenever a software crash occurs and a core file is generated.

sysName

1.3.6.1.2.1.1.5

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

An administratively-assigned name for this managed node. By convention, this is the node's fully-qualified domain name. If the name is unknown, the value is the zero-length string.

cseSwCoresFileName

1.3.6.1.4.1.9.9.305.1.4.2.1.7

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the core file-name(including the path, relative to the value in the cseSwCorePath object). If the cseSwCorePath contains zero length octet string, then this object will contain the filename with absolute path. If this object contains zero length octet string, then the core file is available in path identified in cseSwCorePath.

cseSwCorePath

1.3.6.1.4.1.9.9.305.1.4.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Provides the path where the software cores are stored on the system. The management application can use this path to copy the cores from the system using CISCO-FLASH-MIB.

cseSwCoresPID

1.3.6.1.4.1.9.9.305.1.4.2.1.4

Unsigned32

The process identifier of the process that dumped the core.

cseNormalModeChangeNotify

1.3.6.1.4.1.9.9.305.1.7.2.0.1

A normal mode state change is generated when the system is changed from maintenance mode to normal mode.

cseMaintModeState

1.3.6.1.4.1.9.9.305.1.7.1

CiscoMaintModeState1 = normal2 = maintenance3 = unplannedMaintMaintenance Mode state for the system. normal (1) - normal operational state maintenance (2) - maintenance mode operational state unplannedMaint (3) - unplanned maintenance state · Integer32

The maintenance mode operational state for the system.

cseMaintModeChangeNotify

1.3.6.1.4.1.9.9.305.1.7.2.0.2

A maintenance mode state change is generated when the system is changed from normal mode to maintenance mode.

cseMaintModeState

1.3.6.1.4.1.9.9.305.1.7.1

CiscoMaintModeState1 = normal2 = maintenance3 = unplannedMaintMaintenance Mode state for the system. normal (1) - normal operational state maintenance (2) - maintenance mode operational state unplannedMaint (3) - unplanned maintenance state · Integer32

The maintenance mode operational state for the system.

↑ To TOC