EZ5 MIB Catalog

CISCO-VLAN-MEMBERSHIP-MIB

2007-12-14

The MIB module for the management of the VLAN Membership within the frame work of Cisco VLAN Architecture, v 2.0 by Keith McCloghrie. The MIB provides information on VLAN Membership Policy Servers used by a device and VLAN membership assignments of non-trunk bridge ports of the device.

Download CISCO-VLAN-MEMBERSHIP-MIB.txt Open CISCO-VLAN-MEMBERSHIP-MIB.txt in a new tab

SCALARS (16) · TABLES (5) · TRAPS (1)

Scalars (16)

NameOID
vmVmpsVQPVersion1.3.6.1.4.1.9.9.68.1.1.1
vmVmpsRetries1.3.6.1.4.1.9.9.68.1.1.2
vmVmpsReconfirmInterval1.3.6.1.4.1.9.9.68.1.1.3
vmVmpsReconfirm1.3.6.1.4.1.9.9.68.1.1.4
vmVmpsReconfirmResult1.3.6.1.4.1.9.9.68.1.1.5
vmVmpsCurrent1.3.6.1.4.1.9.9.68.1.1.6
vmVlanCreationMode1.3.6.1.4.1.9.9.68.1.2.4
vmVQPQueries1.3.6.1.4.1.9.9.68.1.3.1
vmVQPResponses1.3.6.1.4.1.9.9.68.1.3.2
vmVmpsChanges1.3.6.1.4.1.9.9.68.1.3.3
vmVQPShutdown1.3.6.1.4.1.9.9.68.1.3.4
vmVQPDenied1.3.6.1.4.1.9.9.68.1.3.5
vmVQPWrongDomain1.3.6.1.4.1.9.9.68.1.3.6
vmVQPWrongVersion1.3.6.1.4.1.9.9.68.1.3.7
vmInsufficientResources1.3.6.1.4.1.9.9.68.1.3.8
vmNotificationsEnabled1.3.6.1.4.1.9.9.68.1.4.1

Tables (5)

NameOID
vmVmpsTable1.3.6.1.4.1.9.9.68.1.1.7
vmMembershipSummaryTable1.3.6.1.4.1.9.9.68.1.2.1
vmMembershipTable1.3.6.1.4.1.9.9.68.1.2.2
vmMembershipSummaryExtTable1.3.6.1.4.1.9.9.68.1.2.3
vmVoiceVlanTable1.3.6.1.4.1.9.9.68.1.5.1

Traps (1)

NameOID
vmVmpsChange1.3.6.1.4.1.9.9.68.2.0.1

END OF TOC

Scalar details

vmVmpsVQPVersion

1.3.6.1.4.1.9.9.68.1.1.1

Integer32

The VLAN Query Protocol (VQP) version supported on the device. VQP is the protocol used to query VLAN Membership Policy Server (VMPS) for VLAN membership assignments of dynamic VLAN ports. A VMPS provides VLAN membership policy assignments based on the content of the packets received on a port.

vmVmpsRetries

1.3.6.1.4.1.9.9.68.1.1.2

INTEGER (1..10) · Integer32

The number of retries for VQP requests to a VMPS before using the next available VMPS.

vmVmpsReconfirmInterval

1.3.6.1.4.1.9.9.68.1.1.3

INTEGER (0..120) · Integer32 · Minutes

The switch will reconfirm membership of addresses on each port with VMPS periodically. This object specifies the interval to perform reconfirmation. If the value is set to 0, the switch does not reconfirm membership with VMPS.

vmVmpsReconfirm

1.3.6.1.4.1.9.9.68.1.1.4

INTEGER1 = ready2 = execute · Integer32

Setting this object to execute(2) causes the switch to reconfirm membership of every dynamic port. Reading this object always return ready(1).

vmVmpsReconfirmResult

1.3.6.1.4.1.9.9.68.1.1.5

INTEGER1 = other2 = inProgress3 = success4 = noResponse5 = noVmps6 = noDynamicPort7 = noHostConnected · Integer32

This object returns the result of the last request that sets vmVmpsReconfirm to execute(2). The semantics of the possible results are as follows: other(1) - none of following inProgress(2) - reconfirm in progress success(3) - reconfirm completed successfully noResponse(4) - reconfirm failed because no VMPS responded noVmps(5) - No VMPS configured noDynamicPort(6) - No dynamic ports configured noHostConnected(7) - No hosts on dynamic ports

vmVmpsCurrent

1.3.6.1.4.1.9.9.68.1.1.6

IpAddress SIZE (4)

This is the IpAddress of the current VMPS used.

vmVlanCreationMode

1.3.6.1.4.1.9.9.68.1.2.4

INTEGER1 = automatic2 = manual · Integer32

This object is used to determine whether or not a non-existing VLAN will be created automatically by the system after assigned to a port. automatic(1): a non-existing VLAN will be created automatically by the system after assigned to a port. manual(2): a non-existing VLAN will not be created automatically by the system and need to be manually created by the users after assigned to a port.

vmVQPQueries

1.3.6.1.4.1.9.9.68.1.3.1

Counter32

The total number of VQP requests sent by this device to all VMPS since last system re-initialization.

vmVQPResponses

1.3.6.1.4.1.9.9.68.1.3.2

Counter32

The number of VQP responses received by this device from all VMPS since last system re-initialization.

vmVmpsChanges

1.3.6.1.4.1.9.9.68.1.3.3

Counter32

The number of times, since last system re-initialization, the current VMPS was changed. The current VMPS is changed whenever the VMPS fails to response after vmVmpsRetries of a VQP request.

vmVQPShutdown

1.3.6.1.4.1.9.9.68.1.3.4

Counter32

The number of times, since last system re-initialization, a VQP response indicates 'shutdown'. A 'shutdown' response is a result of the membership policy configured at a VMPS by the administrator.

vmVQPDenied

1.3.6.1.4.1.9.9.68.1.3.5

Counter32

The number of times, since last system re-initialization, a VQP response indicates 'denied'. A 'denied' response is a result of the membership policy configured at a VMPS by the administrator.

vmVQPWrongDomain

1.3.6.1.4.1.9.9.68.1.3.6

Counter32

The number of times, since last system re-initialization, a VQP response indicates wrong management domain. A wrong management domain response indicates that the VMPS used serves a management domain that is different from the device's management domain.

vmVQPWrongVersion

1.3.6.1.4.1.9.9.68.1.3.7

Counter32

The number of times, since last system re-initialization, a VQP response indicates wrong VQP version. A wrong VQP version response indicates that the VMPS used supports a VQP version that is different from the device's VQP version.

vmInsufficientResources

1.3.6.1.4.1.9.9.68.1.3.8

Counter32

The number of times, since last system re-initialization, a VQP response indicates insufficient resources. An insufficient resources response indicates that the VMPS used does not have the required resources to verify the membership assignment requested.

vmNotificationsEnabled

1.3.6.1.4.1.9.9.68.1.4.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

An indication of whether the notifications/traps defined in this MIB are enabled.

Table details

vmVmpsTable

1.3.6.1.4.1.9.9.68.1.1.7

Index: vmVmpsIpAddress

A table of VMPS to use. The device will use the the primary VMPS by default. If the device is unable to reach the primary server after vmVmpsRetries retries, it uses the first secondary server in the table until it runs out of secondary servers, in which case it will return to using the primary server. Entries in this table may be created and deleted via this MIB or the management console on a device.

vmVmpsIpAddress

1.3.6.1.4.1.9.9.68.1.1.7.1.1

IpAddress SIZE (4)

The Ip Address of the VMPS.

vmVmpsPrimary

1.3.6.1.4.1.9.9.68.1.1.7.1.2

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

The status of the VMPS. Setting this value to true will make this VMPS the primary server and make the switch use this as the current server. Setting this entry to true causes other rows to transition to false. Attempting to write a value of false after creation will result in a return of bad value. Deleting an entry whose value is true will result in the first entry in the table being set to true.

vmVmpsRowStatus

1.3.6.1.4.1.9.9.68.1.1.7.1.3

RowStatus1 = active2 = notInService3 = notReady4 = createAndGo5 = createAndWait6 = destroyThe RowStatus textual convention is used to manage the creation and deletion of conceptual rows, and is used as the value of the SYNTAX clause for the status column of a conceptual row (as described in Section 7.7.1 of [2].) The status column has six defined values: - `active', which indicates that the conceptual row is available for use by the managed device; - `notInService', which indicates that the conceptual row exists in the agent, but is unavailable for use by the managed device (see NOTE below); 'notInService' has no implication regarding the internal consistency of the row, availability of resources, or consistency with the current state of the managed device; - `notReady', which indicates that the conceptual row exists in the agent, but is missing information necessary in order to be available for use by the managed device (i.e., one or more required columns in the conceptual row have not been instanciated); - `createAndGo', which is supplied by a management station wishing to create a new instance of a conceptual row and to have its status automatically set to active, making it available for use by the managed device; - `createAndWait', which is supplied by a management station wishing to create a new instance of a conceptual row (but not make it available for use by the managed device); and, - `destroy', which is supplied by a management station wishing to delete all of the instances associated with an existing conceptual row. Whereas five of the six values (all except `notReady') may be specified in a management protocol set operation, only three values will be returned in response to a management protocol retrieval operation: `notReady', `notInService' or `active'. That is, when queried, an existing conceptual row has only three states: it is either available for use by the managed device (the status column has value `active'); it is not available for use by the managed device, though the agent has sufficient information to attempt to make it so (the status column has value `notInService'); or, it is not available for use by the managed device, and an attempt to make it so would fail because the agent has insufficient information (the state column has value `notReady'). NOTE WELL This textual convention may be used for a MIB table, irrespective of whether the values of that table's conceptual rows are able to be modified while it is active, or whether its conceptual rows must be taken out of service in order to be modified. That is, it is the responsibility of the DESCRIPTION clause of the status column to specify whether the status column must not be `active' in order for the value of some other column of the same conceptual row to be modified. If such a specification is made, affected columns may be changed by an SNMP set PDU if the RowStatus would not be equal to `active' either immediately before or after processing the PDU. In other words, if the PDU also contained a varbind that would change the RowStatus value, the column in question may be changed if the RowStatus was not equal to `active' as the PDU was received, or if the varbind sets the status to a value other than 'active'. Also note that whenever any elements of a row exist, the RowStatus column must also exist. To summarize the effect of having a conceptual row with a status column having a SYNTAX clause value of RowStatus, consider the following state diagram: STATE +--------------+-----------+-------------+------------- | A | B | C | D | |status col.|status column| |status column | is | is |status column ACTION |does not exist| notReady | notInService| is active --------------+--------------+-----------+-------------+------------- set status |noError ->D|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndGo |inconsistent- | | | | Value| | | --------------+--------------+-----------+-------------+------------- set status |noError see 1|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndWait |wrongValue | | | --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError column to | Value| entValue| | active | | | | | | or | | | | | | | |see 2 ->D|see 8 ->D| ->D --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError ->C column to | Value| entValue| | notInService | | | | | | or | | or | | | | | |see 3 ->C| ->C|see 6 --------------+--------------+-----------+-------------+------------- set status |noError |noError |noError |noError ->A column to | | | | or destroy | ->A| ->A| ->A|see 7 --------------+--------------+-----------+-------------+------------- set any other |see 4 |noError |noError |see 5 column to some| | | | value | | see 1| ->C| ->D --------------+--------------+-----------+-------------+------------- (1) goto B or C, depending on information available to the agent. (2) if other variable bindings included in the same PDU, provide values for all columns which are missing but required, and all columns have acceptable values, then return noError and goto D. (3) if other variable bindings included in the same PDU, provide legal values for all columns which are missing but required, then return noError and goto C. (4) at the discretion of the agent, the return value may be either: inconsistentName: because the agent does not choose to create such an instance when the corresponding RowStatus instance does not exist, or inconsistentValue: if the supplied value is inconsistent with the state of some other MIB object's value, or noError: because the agent chooses to create the instance. If noError is returned, then the instance of the status column must also be created, and the new state is B or C, depending on the information available to the agent. If inconsistentName or inconsistentValue is returned, the row remains in state A. (5) depending on the MIB definition for the column/table, either noError or inconsistentValue may be returned. (6) the return value can indicate one of the following errors: wrongValue: because the agent does not support notInService (e.g., an agent which does not support createAndWait), or inconsistentValue: because the agent is unable to take the row out of service at this time, perhaps because it is in use and cannot be de-activated. (7) the return value can indicate the following error: inconsistentValue: because the agent is unable to remove the row at this time, perhaps because it is in use and cannot be de-activated. (8) the transition to D can fail, e.g., if the values of the conceptual row are inconsistent, then the error code would be inconsistentValue. NOTE: Other processing of (this and other varbinds of) the set request may result in a response other than noError being returned, e.g., wrongValue, noCreation, etc. Conceptual Row Creation There are four potential interactions when creating a conceptual row: selecting an instance-identifier which is not in use; creating the conceptual row; initializing any objects for which the agent does not supply a default; and, making the conceptual row available for use by the managed device. Interaction 1: Selecting an Instance-Identifier The algorithm used to select an instance-identifier varies for each conceptual row. In some cases, the instance- identifier is semantically significant, e.g., the destination address of a route, and a management station selects the instance-identifier according to the semantics. In other cases, the instance-identifier is used solely to distinguish conceptual rows, and a management station without specific knowledge of the conceptual row might examine the instances present in order to determine an unused instance-identifier. (This approach may be used, but it is often highly sub-optimal; however, it is also a questionable practice for a naive management station to attempt conceptual row creation.) Alternately, the MIB module which defines the conceptual row might provide one or more objects which provide assistance in determining an unused instance-identifier. For example, if the conceptual row is indexed by an integer-value, then an object having an integer-valued SYNTAX clause might be defined for such a purpose, allowing a management station to issue a management protocol retrieval operation. In order to avoid unnecessary collisions between competing management stations, `adjacent' retrievals of this object should be different. Finally, the management station could select a pseudo-random number to use as the index. In the event that this index was already in use and an inconsistentValue was returned in response to the management protocol set operation, the management station should simply select a new pseudo-random number and retry the operation. A MIB designer should choose between the two latter algorithms based on the size of the table (and therefore the efficiency of each algorithm). For tables in which a large number of entries are expected, it is recommended that a MIB object be defined that returns an acceptable index for creation. For tables with small numbers of entries, it is recommended that the latter pseudo-random index mechanism be used. Interaction 2: Creating the Conceptual Row Once an unused instance-identifier has been selected, the management station determines if it wishes to create and activate the conceptual row in one transaction or in a negotiated set of interactions. Interaction 2a: Creating and Activating the Conceptual Row The management station must first determine the column requirements, i.e., it must determine those columns for which it must or must not provide values. Depending on the complexity of the table and the management station's knowledge of the agent's capabilities, this determination can be made locally by the management station. Alternately, the management station issues a management protocol get operation to examine all columns in the conceptual row that it wishes to create. In response, for each column, there are three possible outcomes: - a value is returned, indicating that some other management station has already created this conceptual row. We return to interaction 1. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it should supply a value for this column when the conceptual row is to be created. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. Once the column requirements have been determined, a management protocol set operation is accordingly issued. This operation also sets the new instance of the status column to `createAndGo'. When the agent processes the set operation, it verifies that it has sufficient information to make the conceptual row available for use by the managed device. The information available to the agent is provided by two sources: the management protocol set operation which creates the conceptual row, and, implementation-specific defaults supplied by the agent (note that an agent must provide implementation-specific defaults for at least those objects which it implements as read-only). If there is sufficient information available, then the conceptual row is created, a `noError' response is returned, the status column is set to `active', and no further interactions are necessary (i.e., interactions 3 and 4 are skipped). If there is insufficient information, then the conceptual row is not created, and the set operation fails with an error of `inconsistentValue'. On this error, the management station can issue a management protocol retrieval operation to determine if this was because it failed to specify a value for a required column, or, because the selected instance of the status column already existed. In the latter case, we return to interaction 1. In the former case, the management station can re-issue the set operation with the additional information, or begin interaction 2 again using `createAndWait' in order to negotiate creation of the conceptual row. NOTE WELL Regardless of the method used to determine the column requirements, it is possible that the management station might deem a column necessary when, in fact, the agent will not allow that particular columnar instance to be created or written. In this case, the management protocol set operation will fail with an error such as `noCreation' or `notWritable'. In this case, the management station decides whether it needs to be able to set a value for that particular columnar instance. If not, the management station re-issues the management protocol set operation, but without setting a value for that particular columnar instance; otherwise, the management station aborts the row creation algorithm. Interaction 2b: Negotiating the Creation of the Conceptual Row The management station issues a management protocol set operation which sets the desired instance of the status column to `createAndWait'. If the agent is unwilling to process a request of this sort, the set operation fails with an error of `wrongValue'. (As a consequence, such an agent must be prepared to accept a single management protocol set operation, i.e., interaction 2a above, containing all of the columns indicated by its column requirements.) Otherwise, the conceptual row is created, a `noError' response is returned, and the status column is immediately set to either `notInService' or `notReady', depending on whether it has sufficient information to (attempt to) make the conceptual row available for use by the managed device. If there is sufficient information available, then the status column is set to `notInService'; otherwise, if there is insufficient information, then the status column is set to `notReady'. Regardless, we proceed to interaction 3. Interaction 3: Initializing non-defaulted Objects The management station must now determine the column requirements. It issues a management protocol get operation to examine all columns in the created conceptual row. In the response, for each column, there are three possible outcomes: - a value is returned, indicating that the agent implements the object-type associated with this column and had sufficient information to provide a value. For those columns to which the agent provides read-create access (and for which the agent allows their values to be changed after their creation), a value return tells the management station that it may issue additional management protocol set operations, if it desires, in order to change the value associated with this column. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. However, the agent does not have sufficient information to provide a value, and until a value is provided, the conceptual row may not be made available for use by the managed device. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it must issue additional management protocol set operations, in order to provide a value associated with this column. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. If the value associated with the status column is `notReady', then the management station must first deal with all `noSuchInstance' columns, if any. Having done so, the value of the status column becomes `notInService', and we proceed to interaction 4. Interaction 4: Making the Conceptual Row Available Once the management station is satisfied with the values associated with the columns of the conceptual row, it issues a management protocol set operation to set the status column to `active'. If the agent has sufficient information to make the conceptual row available for use by the managed device, the management protocol set operation succeeds (a `noError' response is returned). Otherwise, the management protocol set operation fails with an error of `inconsistentValue'. NOTE WELL A conceptual row having a status column with value `notInService' or `notReady' is unavailable to the managed device. As such, it is possible for the managed device to create its own instances during the time between the management protocol set operation which sets the status column to `createAndWait' and the management protocol set operation which sets the status column to `active'. In this case, when the management protocol set operation is issued to set the status column to `active', the values held in the agent supersede those used by the managed device. If the management station is prevented from setting the status column to `active' (e.g., due to management station or network failure) the conceptual row will be left in the `notInService' or `notReady' state, consuming resources indefinitely. The agent must detect conceptual rows that have been in either state for an abnormally long period of time and remove them. It is the responsibility of the DESCRIPTION clause of the status column to indicate what an abnormally long period of time would be. This period of time should be long enough to allow for human response time (including `think time') between the creation of the conceptual row and the setting of the status to `active'. In the absence of such information in the DESCRIPTION clause, it is suggested that this period be approximately 5 minutes in length. This removal action applies not only to newly-created rows, but also to previously active rows which are set to, and left in, the notInService state for a prolonged period exceeding that which is considered normal for such a conceptual row. Conceptual Row Suspension When a conceptual row is `active', the management station may issue a management protocol set operation which sets the instance of the status column to `notInService'. If the agent is unwilling to do so, the set operation fails with an error of `wrongValue' or `inconsistentValue'. Otherwise, the conceptual row is taken out of service, and a `noError' response is returned. It is the responsibility of the DESCRIPTION clause of the status column to indicate under what circumstances the status column should be taken out of service (e.g., in order for the value of some other column of the same conceptual row to be modified). Conceptual Row Deletion For deletion of conceptual rows, a management protocol set operation is issued which sets the instance of the status column to `destroy'. This request may be made regardless of the current value of the status column (e.g., it is possible to delete conceptual rows which are either `notReady', `notInService' or `active'.) If the operation succeeds, then all instances associated with the conceptual row are immediately removed. · Integer32

The status of this conceptual row.

vmMembershipSummaryTable

1.3.6.1.4.1.9.9.68.1.2.1

Index: vmMembershipSummaryVlanIndex

A summary of VLAN membership of non-trunk bridge ports. This is a convenience table for retrieving VLAN membership information. A row is created for a VLAN if: a) the VLAN exists, or b) a port is assigned to a non-existent VLAN. VLAN membership can only be modified via the vmMembershipTable.

vmMembershipSummaryVlanIndex

1.3.6.1.4.1.9.9.68.1.2.1.1.1

VlanIndexThe VLAN-id of a VLAN on ISL or 802.1q trunks. Modification of default parameters is allowed. Implementations are allowed to restrict the range of VLANs. For entities support up to 1024 VLANS. VLANs above 1000 are reserved for default VLANs and future use. Modification of default parameters is allowed. Creation or deletion of VLANs above 1000 is not allowed. For a new object which needs the vlan-id of a VLAN as its SYNTAX, it is suggested to import VlanIndex from Q-BRIDGE-MIB instead of importing this TC here in CISCO-VTP-MIB. (0..4095) · Integer32

The VLAN id of the VLAN.

vmMembershipSummaryMemberPorts

1.3.6.1.4.1.9.9.68.1.2.1.1.2

OCTET STRING SIZE (0..128)

The set of the device's member ports that belong to the VLAN. Each octet within the value of this object specifies a set of eight ports, with the first octet specifying ports 1 through 8, the second octet specifying ports 9 through 16, etc. Within each octet, the most significant bit represents the lowest numbered port, and the least significant bit represents the highest numbered port. Thus, each port of the VLAN is represented by a single bit within the value of this object. If that bit has a value of '1' then that port is included in the set of ports; the port is not included if its bit has a value of '0'. A port number is the value of dot1dBasePort for the port in the BRIDGE-MIB (RFC 1493).

vmMembershipSummaryMember2kPorts

1.3.6.1.4.1.9.9.68.1.2.1.1.3

CiscoPortListEach octet within this value specifies a set of eight ports. The object defined by this textual convention can specify a port range of 2k ports in its description. Example: 1 - 2048, 2049 - 4096, etc. The first octet represents the first 8 ports of the range of ports specified by the object, the second octet represents the next 8 ports, etc. When a port range is not specified, a default port range of '1 - 2048' is assumed. Within each octet, the most significant bit represents the lowest numbered port, and the least significant bit represents the highest numbered port. Thus, each port of the bridge is represented by a single bit within the value of this object. If that bit has a value of '1' then that port is included in the set of ports; the port is not included if its bit has a value of '0'. Note that if the length of this string is less than 256 octets, any 'missing' octets are assumed to contain the value zero. An NMS may omit any zero-valued octets from the end of this string in order to reduce SetPDU size, and the agent may also omit zero-valued trailing octets, to reduce the size of GetResponse PDUs. SIZE (0..256) · OCTET STRING

The set of the device's member ports that belong to the VLAN. It has the VLAN membership information of up to 2048 ports with the port number from 1 to 2048. Each octet within the value of this object specifies a set of eight ports, with the first octet specifying ports 1 through 8, the second octet specifying ports 9 through 16, etc. Within each octet, the most significant bit represents the lowest numbered port, and the least significant bit represents the highest numbered port. Thus, each port of the VLAN is represented by a single bit within the value of this object. If that bit has a value of '1' then that port is included in the set of ports; the port is not included if its bit has a value of '0'. A port number is the value of dot1dBasePort for the port in the BRIDGE-MIB (RFC 1493).

vmMembershipTable

1.3.6.1.4.1.9.9.68.1.2.2

Index: ifIndex

A table for configuring VLAN port membership. There is one row for each bridge port that is assigned to a static or dynamic access port. Trunk ports are not represented in this table. An entry may be created and deleted when ports are created or deleted via SNMP or the management console on a device.

from IF-MIB

ifIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

vmVlanType

1.3.6.1.4.1.9.9.68.1.2.2.1.1

INTEGER1 = static2 = dynamic3 = multiVlan · Integer32

The type of VLAN membership assigned to this port. A port with static vlan membership is assigned to a single VLAN directly. A port with dynamic membership is assigned a single VLAN based on content of packets received on the port and via VQP queries to VMPS. A port with multiVlan membership may be assigned to one or more VLANs directly. A static or dynamic port membership is specified by the value of vmVlan. A multiVlan port membership is specified by the value of vmVlans.

vmVlan

1.3.6.1.4.1.9.9.68.1.2.2.1.2

INTEGER (0..4095) · Integer32

The VLAN id of the VLAN the port is assigned to when vmVlanType is set to static or dynamic. This object is not instantiated if not applicable. The value may be 0 if the port is not assigned to a VLAN. If vmVlanType is static, the port is always assigned to a VLAN and the object may not be set to 0. If vmVlanType is dynamic the object's value is 0 if the port is currently not assigned to a VLAN. In addition, the object may be set to 0 only.

vmPortStatus

1.3.6.1.4.1.9.9.68.1.2.2.1.3

INTEGER1 = inactive2 = active3 = shutdown · Integer32

An indication of the current VLAN status of the port. A status of inactive(1) indicates that a dynamic port does not yet have a VLAN assigned, or a port is assigned to a VLAN that is currently not active. A status of active(2) indicates that the currently assigned VLAN is active. A status of shutdown(3) indicates that the port has been disabled as a result of VQP shutdown response.

vmVlans

1.3.6.1.4.1.9.9.68.1.2.2.1.4

OCTET STRING SIZE (0..128)

The VLAN(s) the port is assigned to when the port's vmVlanType is set to multiVlan. This object is not instantiated if not applicable. The port is always assigned to one or more VLANs and the object may not be set so that there are no vlans assigned. Each octet within the value of this object specifies a set of eight VLANs, with the first octet specifying VLAN id 1 through 8, the second octet specifying VLAN ids 9 through 16, etc. Within each octet, the most significant bit represents the lowest numbered VLAN id, and the least significant bit represents the highest numbered VLAN id. Thus, each VLAN of the port is represented by a single bit within the value of this object. If that bit has a value of '1' then that VLAN is included in the set of VLANs; the VLAN is not included if its bit has a value of '0'.

vmVlans2k

1.3.6.1.4.1.9.9.68.1.2.2.1.5

OCTET STRING SIZE (0..128)

The VLAN(s) the port is assigned to when the port's vmVlanType is set to multiVlan. This object is not instantiated if not applicable. The port is always assigned to one or more VLANs and the object may not be set so that there are no vlans assigned. Each octet within the value of this object specifies a set of eight VLANs, with the first octet specifying VLAN id 1024 through 1031, the second octet specifying VLAN ids 1032 through 1039, etc. Within each octet, the most significant bit represents the lowest numbered VLAN id, and the least significant bit represents the highest numbered VLAN id. Thus, each VLAN of the port is represented by a single bit within the value of this object. If that bit has a value of '1' then that VLAN is included in the set of VLANs; the VLAN is not included if its bit has a value of '0'.

vmVlans3k

1.3.6.1.4.1.9.9.68.1.2.2.1.6

OCTET STRING SIZE (0..128)

The VLAN(s) the port is assigned to when the port's vmVlanType is set to multiVlan. This object is not instantiated if not applicable. The port is always assigned to one or more VLANs and the object may not be set so that there are no vlans assigned. Each octet within the value of this object specifies a set of eight VLANs, with the first octet specifying VLAN id 2048 through 2055, the second octet specifying VLAN ids 2056 through 2063, etc. Within each octet, the most significant bit represents the lowest numbered VLAN id, and the least significant bit represents the highest numbered VLAN id. Thus, each VLAN of the port is represented by a single bit within the value of this object. If that bit has a value of '1' then that VLAN is included in the set of VLANs; the VLAN is not included if its bit has a value of '0'.

vmVlans4k

1.3.6.1.4.1.9.9.68.1.2.2.1.7

OCTET STRING SIZE (0..128)

The VLAN(s) the port is assigned to when the port's vmVlanType is set to multiVlan. This object is not instantiated if not applicable. The port is always assigned to one or more VLANs and the object may not be set so that there are no vlans assigned. Each octet within the value of this object specifies a set of eight VLANs, with the first octet specifying VLAN id 3072 through 3079, the second octet specifying VLAN ids 3040 through 3047, etc. Within each octet, the most significant bit represents the lowest numbered VLAN id, and the least significant bit represents the highest numbered VLAN id. Thus, each VLAN of the port is represented by a single bit within the value of this object. If that bit has a value of '1' then that VLAN is included in the set of VLANs; the VLAN is not included if its bit has a value of '0'.

vmMembershipSummaryExtTable

1.3.6.1.4.1.9.9.68.1.2.3

Index: vmMembershipSummaryVlanIndex · vmMembershipPortRangeIndex

A summary of VLAN membership of non-trunk bridge ports. This table is used for retrieving VLAN membership information for the device which supports dot1dBasePort with value greater than 2048. A row is created for a VLAN and a particular bridge port range, where at least one port in the range is assigned to this VLAN. VLAN membership can only be modified via the vmMembershipTable.

vmMembershipPortRangeIndex

1.3.6.1.4.1.9.9.68.1.2.3.1.1

CiscoPortListRange1 = oneto2k2 = twoKto4K3 = fourKto6K4 = sixKto8K5 = eightKto10K6 = tenKto12K7 = twelveKto14K8 = fourteenKto16KIndicates the port range. oneto2K(1) indicates that the port number range is from 1 to 2048. twoKto4K(2) indicates that the port number range is from 2049 to 4096. fourKto6K(3) indicates that the port number range is from 4097 to 6144. sixKto8K(4) indicates that the port number range is from 6145 to 8192. eightKto10K(5) indicates that the port number range is from 8193 to 10240. tenKto12K(6) indicates that the port number range is from 10241 to 12288. twelveKto14K(7) indicates that the port number range is from 12289 to 14336. fourteenKto16K(8) indicates that the port number range is from 14337 to 16384. When an object is defined with this textual convention, it must be accompanied by an object of CiscoPortList syntax. · Integer32

The bridge port range index of this row.

vmMembershipSummaryExtPorts

1.3.6.1.4.1.9.9.68.1.2.3.1.2

CiscoPortListEach octet within this value specifies a set of eight ports. The object defined by this textual convention can specify a port range of 2k ports in its description. Example: 1 - 2048, 2049 - 4096, etc. The first octet represents the first 8 ports of the range of ports specified by the object, the second octet represents the next 8 ports, etc. When a port range is not specified, a default port range of '1 - 2048' is assumed. Within each octet, the most significant bit represents the lowest numbered port, and the least significant bit represents the highest numbered port. Thus, each port of the bridge is represented by a single bit within the value of this object. If that bit has a value of '1' then that port is included in the set of ports; the port is not included if its bit has a value of '0'. Note that if the length of this string is less than 256 octets, any 'missing' octets are assumed to contain the value zero. An NMS may omit any zero-valued octets from the end of this string in order to reduce SetPDU size, and the agent may also omit zero-valued trailing octets, to reduce the size of GetResponse PDUs. SIZE (0..256) · OCTET STRING

The set of the device's member ports that belong to the VLAN. It has the VLAN membership information of up to 2k ports with the port number starting from the information indicated in vmMembershipPortRangeIndex object of the same row. For example, if the value of vmMembershipPortRangeIndex is 'twoKto4K', the port number indicated in this object starting from 2049 and ending to 4096. A port number is the value of dot1dBasePort for the port in the BRIDGE-MIB (RFC 1493).

vmVoiceVlanTable

1.3.6.1.4.1.9.9.68.1.5.1

Index: ifIndex

A table for configuring the Voice VLAN-ID for the ports. An entry will exist for each interface which supports Voice Vlan feature.

from IF-MIB

ifIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

vmVoiceVlanId

1.3.6.1.4.1.9.9.68.1.5.1.1.1

INTEGER (0..4096) · Integer32

The Voice Vlan ID (VVID) to which this port belongs to. 0 - The CDP packets transmitting through this port would contain Appliance VLAN-ID TLV with value of 0. VoIP and related packets are expected to be sent and received with VLAN-id=0 and an 802.1p priority. 1..4094 - The CDP packets transmitting through this port would contain Appliance VLAN-ID TLV with N. VoIP and related packets are expected to be sent and received with VLAN-id=N and an 802.1p priority. 4095 - The CDP packets transmitting through this port would contain Appliance VLAN-ID TLV with value of 4095. VoIP and related packets are expected to be sent and received untagged without an 802.1p priority. 4096 - The CDP packets transmitting through this port would not include Appliance VLAN-ID TLV; or, if the VVID is not supported on the port, this MIB object will not be configurable and will return 4096.

vmVoiceVlanCdpVerifyEnable

1.3.6.1.4.1.9.9.68.1.5.1.1.2

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Enable or Disable the feature of CDP message verification of voice VLANs. true - The voice VLAN vmVoiceVlan is enabled only after CDP messages are received from the IP phone. false - The voice VLAN vmVoiceVlan is enabled as soon as the IP phone interface is up. There is no verification needed from CDP messages from the IP phone.

Trap details

vmVmpsChange

1.3.6.1.4.1.9.9.68.2.0.1

A VMPS change notification is generated whenever vmVmpsChanges is incremented. The IP address of the new VMPS is sent.

vmVmpsIpAddress

1.3.6.1.4.1.9.9.68.1.1.7.1.1

IpAddress SIZE (4)

The Ip Address of the VMPS.

↑ To TOC