EZ5 MIB Catalog

CISCO-VOICE-CONNECTIVITY-MIB

2005-09-13

This MIB module provides connectivity related information for devices (e.g., 'connectivity between voice gateway, phones, gatekeepers and call processing agent'). The MIB can be used by network management applications to collect the information regarding voice connectivity among the devices in the network. The MIB can also be used to retrieve the status of voice connectivity between the devices. *** ABBREVIATIONS, ACRONYMS, AND SYMBOLS *** SCCP - Skinny Client Control Protocol SGCP - Simple Gateway Control Protocol MGCP - Media Gateway Control Protocol H323 - H.323 protocol SIP - Session Initiation Protocol *** DEFINITIONS *** CALL AGENT A call processing agent component of a device in IP telephony and VoIP network. PORT A port on the device that is associated with call processing agent. REGISTRATION In an IP telephony network, there are typically keep- alive messages or expected registration refresh timers that are used to formulate the registration status of devices and/or users. Possible values of the registration status are as follows: registered: The port has successfully registered with the call agent unregistered: The port is no longer registered with the call agent rejected: Registration request from the port was rejected by the call agent.

Download CISCO-VOICE-CONNECTIVITY-MIB.txt Open CISCO-VOICE-CONNECTIVITY-MIB.txt in a new tab

SCALARS (1) · TABLES (3) · TRAPS (1)

Scalars (1)

NameOID
cvcNotifEnable1.3.6.1.4.1.9.9.393.1.4.1

Tables (3)

NameOID
cvcCallAgentTable1.3.6.1.4.1.9.9.393.1.1.1
cvcPortTable1.3.6.1.4.1.9.9.393.1.2.1
cvcCallAgentConnectionTable1.3.6.1.4.1.9.9.393.1.3.1

Traps (1)

NameOID
cvcPortRegistrationStatusChange1.3.6.1.4.1.9.9.393.0.1

END OF TOC

Scalar details

cvcNotifEnable

1.3.6.1.4.1.9.9.393.1.4.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This variable indicates whether the system generates notifications defined in this MIB. A false value will prevent all the notifications from being generated by this system.

Table details

cvcCallAgentTable

1.3.6.1.4.1.9.9.393.1.1.1

Index: cvcCallAgentIndex

This table contains information about call agents. When the network management subsystem implements this MIB, this table lists the call agents that exist in this system. This table will contain one entry per call agent. When systems other than those hosting call agents implement this MIB, this table will contain the list of call agents to which ports of this system are associated. The entries would be representative of remote call agents. For example, if a device is a voice gateway having a T1 port associated with three call processing agents, then this table will have three entries representing each of the three call processing agents. The network management subsystem adds conceptual rows to this table for every call agent.

cvcCallAgentIndex

1.3.6.1.4.1.9.9.393.1.1.1.1.1

Unsigned32 (1..4294967295)

An arbitrary integer, a unique value for each call agent associated with the device.

cvcCallAgentName

1.3.6.1.4.1.9.9.393.1.1.1.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..128) · OCTET STRING · hint 255t

This object indicates name of the call agent given by call agent administrator.

cvcCallAgentInetAddressType

1.3.6.1.4.1.9.9.393.1.1.1.1.3

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

Reference: RFC 3291, section 3

This object reflects a particular type of internet address and provides the context for interpreting one or more address objects elsewhere in this MIB module.

cvcCallAgentInetAddress

1.3.6.1.4.1.9.9.393.1.1.1.1.4

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Reference: RFC 3291, section 3

This object indicates the IP address of the call agent. The type of internet address is indicated by the value of cvcCallAgentInetAddressType.

cvcCallAgentType

1.3.6.1.4.1.9.9.393.1.1.1.1.5

AutonomousTypeRepresents an independently extensible type identification value. It may, for example, indicate a particular sub-tree with further MIB definitions, or define a particular type of protocol or hardware. · OBJECT IDENTIFIER

This object indicates the type of call agent. A list of call agent types can be found in the CISCO-VOICE-APPLICATIONS-OID-MIB.

cvcPortTable

1.3.6.1.4.1.9.9.393.1.2.1

Index: cvcPortIndex

This table contains information about ports. When the network management subsystem implements this MIB, this table lists all the ports associated with the call agents listed in cvcCallAgentTable. When systems other than those hosting call agents implement this MIB, this table will contain information of all the ports of the system,associated with the call agents listed in cvcCallAgentTable. The network management subsystem adds conceptual rows to this table for every port associated to call agent.

cvcPortIndex

1.3.6.1.4.1.9.9.393.1.2.1.1.1

Unsigned32 (1..4294967295)

An arbitrary integer value uniquely identifying each physical or virtual port of the device associated with call agent.

cvcPortAssociation

1.3.6.1.4.1.9.9.393.1.2.1.1.2

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

An association to conceptual row of the port define within another MIB group. This can be used to get more information about the port defined in other MIB group. For example, to get more information about the T1 port defined in this table, this attribute points to a row in ifTable for that T1 port, e.g value for this attribute will be 'ifIndex.5'.

cvcPortDeviceName

1.3.6.1.4.1.9.9.393.1.2.1.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The device name under which this port has been registered with call agent. This is a mandatory field that represents the port.

cvcPortInetAddressType

1.3.6.1.4.1.9.9.393.1.2.1.1.4

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

Reference: RFC 3291, section 3

This object reflects a particular type of internet address and provides the context for interpreting one or more address objects elsewhere in this MIB module.

cvcPortInetAddress

1.3.6.1.4.1.9.9.393.1.2.1.1.5

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Reference: RFC 3291, section 3

This object indicates the IP address of the port. The type of internet address is indicated bythe value of cvcPortInetAddressType.

cvcPortMACAddress

1.3.6.1.4.1.9.9.393.1.2.1.1.6

MacAddressRepresents an 802 MAC address represented in the `canonical' order defined by IEEE 802.1a, i.e., as if it were transmitted least significant bit first, even though 802.5 (in contrast to other 802.x protocols) requires MAC addresses to be transmitted most significant bit first. SIZE (6) · OCTET STRING · hint 1x:

This object indicates the MAC address of the port. For ports which do not have such an address, this object should contain an octet string of zero length.

cvcPortType

1.3.6.1.4.1.9.9.393.1.2.1.1.7

IANAifType1 = other2 = regular18223 = hdh18224 = ddnX255 = rfc877x256 = ethernetCsmacd7 = iso88023Csmacd8 = iso88024TokenBus9 = iso88025TokenRing10 = iso88026Man11 = starLan12 = proteon10Mbit13 = proteon80Mbit14 = hyperchannel15 = fddi16 = lapb17 = sdlc18 = ds119 = e120 = basicISDN21 = primaryISDN22 = propPointToPointSerial23 = ppp24 = softwareLoopback25 = eon26 = ethernet3Mbit27 = nsip28 = slip29 = ultra30 = ds331 = sip32 = frameRelay33 = rs23234 = para35 = arcnet36 = arcnetPlus37 = atm38 = miox2539 = sonet40 = x25ple41 = iso88022llc42 = localTalk43 = smdsDxi44 = frameRelayService45 = v3546 = hssi47 = hippi48 = modem49 = aal550 = sonetPath51 = sonetVT52 = smdsIcip53 = propVirtual54 = propMultiplexor55 = ieee8021256 = fibreChannel57 = hippiInterface58 = frameRelayInterconnect59 = aflane802360 = aflane802561 = cctEmul62 = fastEther63 = isdn64 = v1165 = v3666 = g703at64k67 = g703at2mb68 = qllc69 = fastEtherFX70 = channel71 = ieee8021172 = ibm370parChan73 = escon74 = dlsw75 = isdns76 = isdnu77 = lapd78 = ipSwitch79 = rsrb80 = atmLogical81 = ds082 = ds0Bundle83 = bsc84 = async85 = cnr86 = iso88025Dtr87 = eplrs88 = arap89 = propCnls90 = hostPad91 = termPad92 = frameRelayMPI93 = x21394 = adsl95 = radsl96 = sdsl97 = vdsl98 = iso88025CRFPInt99 = myrinet100 = voiceEM101 = voiceFXO102 = voiceFXS103 = voiceEncap104 = voiceOverIp105 = atmDxi106 = atmFuni107 = atmIma108 = pppMultilinkBundle109 = ipOverCdlc110 = ipOverClaw111 = stackToStack112 = virtualIpAddress113 = mpc114 = ipOverAtm115 = iso88025Fiber116 = tdlc117 = gigabitEthernet118 = hdlc119 = lapf120 = v37121 = x25mlp122 = x25huntGroup123 = transpHdlc124 = interleave125 = fast126 = ip127 = docsCableMaclayer128 = docsCableDownstream129 = docsCableUpstream130 = a12MppSwitch131 = tunnel132 = coffee133 = ces134 = atmSubInterface135 = l2vlan136 = l3ipvlan137 = l3ipxvlan138 = digitalPowerline139 = mediaMailOverIp140 = dtm141 = dcn142 = ipForward143 = msdsl144 = ieee1394145 = if-gsn146 = dvbRccMacLayer147 = dvbRccDownstream148 = dvbRccUpstream149 = atmVirtual150 = mplsTunnel151 = srp152 = voiceOverAtm153 = voiceOverFrameRelay154 = idsl155 = compositeLink156 = ss7SigLink157 = propWirelessP2P158 = frForward159 = rfc1483160 = usb161 = ieee8023adLag162 = bgppolicyaccounting163 = frf16MfrBundle164 = h323Gatekeeper165 = h323Proxy166 = mpls167 = mfSigLink168 = hdsl2169 = shdsl170 = ds1FDL171 = pos172 = dvbAsiIn173 = dvbAsiOut174 = plc175 = nfas176 = tr008177 = gr303RDT178 = gr303IDT179 = isup180 = propDocsWirelessMaclayer181 = propDocsWirelessDownstream182 = propDocsWirelessUpstream183 = hiperlan2184 = propBWAp2Mp185 = sonetOverheadChannel186 = digitalWrapperOverheadChannel187 = aal2188 = radioMAC189 = atmRadio190 = imt191 = mvl192 = reachDSL193 = frDlciEndPt194 = atmVciEndPt195 = opticalChannel196 = opticalTransport197 = propAtm198 = voiceOverCable199 = infiniband200 = teLink201 = q2931202 = virtualTg203 = sipTg204 = sipSig205 = docsCableUpstreamChannel206 = econet207 = pon155208 = pon622209 = bridge210 = linegroup211 = voiceEMFGD212 = voiceFGDEANA213 = voiceDID214 = mpegTransport215 = sixToFour216 = gtp217 = pdnEtherLoop1218 = pdnEtherLoop2219 = opticalChannelGroup220 = homepna221 = gfp222 = ciscoISLvlan223 = actelisMetaLOOP224 = fcipLink225 = rpr226 = qam227 = lmp228 = cblVectaStar229 = docsCableMCmtsDownstream230 = adsl2231 = macSecControlledIF232 = macSecUncontrolledIF233 = aviciOpticalEther234 = atmbond235 = voiceFGDOS236 = mocaVersion1237 = ieee80216WMAN238 = adsl2plus239 = dvbRcsMacLayer240 = dvbTdm241 = dvbRcsTdma242 = x86Laps243 = wwanPP244 = wwanPP2245 = voiceEBS246 = ifPwType247 = ilan248 = pip249 = aluELP250 = gpon251 = vdsl2252 = capwapDot11Profile253 = capwapDot11Bss254 = capwapWtpVirtualRadio255 = bits256 = docsCableUpstreamRfPort257 = cableDownstreamRfPort258 = vmwareVirtualNic259 = ieee802154260 = otnOdu261 = otnOtu262 = ifVfiType263 = g9981264 = g9982265 = g9983266 = aluEpon267 = aluEponOnu268 = aluEponPhysicalUni269 = aluEponLogicalLink270 = aluGponOnu271 = aluGponPhysicalUni272 = vmwareNicTeam277 = docsOfdmDownstream278 = docsOfdmaUpstream279 = gfast280 = sdci281 = xboxWireless282 = fastdsl283 = docsCableScte55d1FwdOob284 = docsCableScte55d1RetOob285 = docsCableScte55d2DsOob286 = docsCableScte55d2UsOob287 = docsCableNdf288 = docsCableNdr289 = ptm290 = ghn291 = otnOtsi292 = otnOtuc293 = otnOduc294 = otnOtsig295 = microwaveCarrierTermination296 = microwaveRadioLinkTerminal297 = ieee8021axDrni298 = ax25299 = ieee19061nanocomThis data type is used as the syntax of the ifType object in the (updated) definition of MIB-II's ifTable. The definition of this textual convention with the addition of newly assigned values is published periodically by the IANA, in either the Assigned Numbers RFC, or some derivative of it specific to Internet Network Management number assignments. (The latest arrangements can be obtained by contacting the IANA.) Interface types must not be directly added to the IANAifType-MIB MIB module. They must instead be added to the 'ifType definitions' registry at https://www.iana.org/assignments/smi-numbers. The relationship between the assignment of ifType values and of OIDs to particular media-specific MIBs is solely the purview of IANA and is subject to change without notice. Quite often, a media-specific MIB's OID-subtree assignment within MIB-II's 'transmission' subtree will be the same as its ifType value. However, in some circumstances this will not be the case, and implementors must not pre-assume any specific relationship between ifType values and transmission subtree OIDs. · Integer32

The type of port. Additional values for cvcPortType are assigned by the Internet Assigned Numbers Authority (IANA), through updating the syntax of the IANAifType textual convention. If the port type is not defined in IANAifType, then value of this object will be other(1). In this case, port type can be identified either by productCategory or by referring to other MIB pointed by cvcPortAssociation.

cvcProductCategory

1.3.6.1.4.1.9.9.393.1.2.1.1.8

INTEGER1 = phone2 = gateway3 = h323Device4 = ctiDevice5 = voiceMailDevice6 = mediaResourceDevice7 = huntListDevice8 = sipDevice · Integer32

This object indicates type of the device that contains the port.

cvcProtocol

1.3.6.1.4.1.9.9.393.1.2.1.1.9

INTEGER1 = sccp2 = sgcp3 = mgcp4 = h3235 = sip · Integer32

Reference: RFC 3435 on Media Gateway Control Protocol (MGCP) Version 1.0 RFC 3261 - SIP: Session Initiation Protocol ITU-T Recommendation H.323v.4,'Packet-based multimedia communications systems', November 2000.

Protocol the port use for communication to its associated device.

cvcVirtualInterfaceDN

1.3.6.1.4.1.9.9.393.1.2.1.1.10

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This attribute indicates directory number of the port. This attribute is applicable only to virtual or logical interface that is associated with call agent.

cvcCallAgentConnectionTable

1.3.6.1.4.1.9.9.393.1.3.1

Index: cvcPortIndex · cvcCallAgentIndex

This table contains current registration status information for all the ports, listed in cvcPortTable, that are associated with the call agents listed cvcCallAgentTable. The network management subsystem adds a conceptual row to this table per port and its associated call agent pair. Entries in this table depends on entries in cvcPortTable and cvcCallAgentTable. Deletion of any entry in those other two table will result in deletion of corresponding entry in this table.

cvcCallAgentPriority

1.3.6.1.4.1.9.9.393.1.3.1.1.1

Unsigned32

A port can be associated with multiple call agents. In case of failure of the call agent to which the port has been registered, port falls back to the back-up call agent. To achieve this redundancy each call agent is assigned a priority number in context of port. This object indicates the call agent's priority number.

cvcRegistrationStatus

1.3.6.1.4.1.9.9.393.1.3.1.1.2

INTEGER1 = unknown2 = notapplicable3 = registered4 = unregistered5 = rejected · Integer32

This syntax is used to identify the registration status of the port with call agent. unknown: The registration status of the port is unknown. notapplicable: The registration status of the port is not applicable registered: The port has successfully registered with the call agent unregistered: The port is no longer registered with the call agent rejected: Registration request from the port was rejected by the call agent.

cvcStatusReason

1.3.6.1.4.1.9.9.393.1.3.1.1.3

INTEGER1 = noError2 = unknown3 = configurationError4 = deviceNameUnresolveable5 = maxDevRegReached6 = connectivityError7 = initializationError8 = deviceReset · Integer32

This syntax is used as means of identifying the reasons for a device registration error. Following are possible reason of registration status value. noError: No Error unknown: Unknown error cause configurationError: Device configuration error deviceNameUnresolveable: Unable to resolve the device name to an IP address maxDevRegReached: Maximum number of device registration have been reached connectivityError: Call agent is unable to establish communication with the device during registration initializationError: An error occurred during initialization of the device deviceReset: Indicates that the error was due to device reset.

cvcLastStatusChangeTime

1.3.6.1.4.1.9.9.393.1.3.1.1.4

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The time registration status of the port changed.

cvcLastRegisteredTime

1.3.6.1.4.1.9.9.393.1.3.1.1.5

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The time the port last registered with the call agent.

Trap details

cvcPortRegistrationStatusChange

1.3.6.1.4.1.9.9.393.0.1

A cvcPortRegistrationStatusChange notification is generated when the value of cvcRegistrationStatus changes. It can be utilized by an NMS to get current registration status change information. cvcPortDeviceName and cvcCallAgentInetAddress can be used by NMS to get information about the port and call agent from cvcPortTable and cvcCallAgentTable respectively. An NMS should periodically check the value of cvcLastStatusChangeTime to detect any missed cvcPortRegistrationStatusChange notification-events due to network problem or any other problem.

cvcPortDeviceName

1.3.6.1.4.1.9.9.393.1.2.1.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The device name under which this port has been registered with call agent. This is a mandatory field that represents the port.

cvcCallAgentInetAddress

1.3.6.1.4.1.9.9.393.1.1.1.1.4

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Reference: RFC 3291, section 3

This object indicates the IP address of the call agent. The type of internet address is indicated by the value of cvcCallAgentInetAddressType.

cvcCallAgentPriority

1.3.6.1.4.1.9.9.393.1.3.1.1.1

Unsigned32

A port can be associated with multiple call agents. In case of failure of the call agent to which the port has been registered, port falls back to the back-up call agent. To achieve this redundancy each call agent is assigned a priority number in context of port. This object indicates the call agent's priority number.

cvcRegistrationStatus

1.3.6.1.4.1.9.9.393.1.3.1.1.2

INTEGER1 = unknown2 = notapplicable3 = registered4 = unregistered5 = rejected · Integer32

This syntax is used to identify the registration status of the port with call agent. unknown: The registration status of the port is unknown. notapplicable: The registration status of the port is not applicable registered: The port has successfully registered with the call agent unregistered: The port is no longer registered with the call agent rejected: Registration request from the port was rejected by the call agent.

cvcStatusReason

1.3.6.1.4.1.9.9.393.1.3.1.1.3

INTEGER1 = noError2 = unknown3 = configurationError4 = deviceNameUnresolveable5 = maxDevRegReached6 = connectivityError7 = initializationError8 = deviceReset · Integer32

This syntax is used as means of identifying the reasons for a device registration error. Following are possible reason of registration status value. noError: No Error unknown: Unknown error cause configurationError: Device configuration error deviceNameUnresolveable: Unable to resolve the device name to an IP address maxDevRegReached: Maximum number of device registration have been reached connectivityError: Call agent is unable to establish communication with the device during registration initializationError: An error occurred during initialization of the device deviceReset: Indicates that the error was due to device reset.

cvcLastStatusChangeTime

1.3.6.1.4.1.9.9.393.1.3.1.1.4

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The time registration status of the port changed.

cvcLastRegisteredTime

1.3.6.1.4.1.9.9.393.1.3.1.1.5

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The time the port last registered with the call agent.

↑ To TOC