EZ5 MIB Catalog

CISCO-VPDN-MGMT-MIB

2009-06-16

The MIB module for VPDN. Overview of VPDN MIB MIB description This MIB is to support the Virtual Private Dialup Network (VPDN) feature of Cisco IOS. VPDN handles the forwarding of PPP links from an Internet Provider (ISP) to a Home Gateway. The VPDN MIB provides the operational information on Cisco's VPDN tunnelling implementation. The following entities are managed: 1) Global VPDN information 2) VPDN tunnel information 3) VPDN tunnel's user information 4) Failure history per user The following example configuration shows how the VPDN MIB returns VPDN information, from either CISCO A - Network Access Server (NAS) or CISCO B - Tunnel Server (TS). The User call is projected by either domain name or Dialed Number Identification Service (DNIS). The terms NAS and TS are generic terms refering to the VPDN systems. The following table shows the corresponding technology-specific terms. Network Access Server Tunnel Server ------------------------------ ------------------------- L2F Network Access Server (NAS) Home Gateway (HGW) L2TP L2TP Access Concentrator (LAC) L2TP Network Server (LNS) PPTP PPTP Access Concentrator (PAC) PPTP Network Server (PNS) (NAS) (TS) User ===== Cisco A ===== IP Network ===== Cisco B ===== Server | | +========== VPDN ==========+ 1) The VPDN global entry identifies the system wide VPDN information. 2) The VPDN tunnel table identifies the active VPDN tunnels on Cisco A and Cisco B. The table contains an entry for each active tunnel on the system. 3) The VPDN tunnel user table identifies the active users for each active tunnel on each system and provides relevant information for each user. 4) The VPDN failure history table identifies the last failure recorded per user and provides relevant information.

Download CISCO-VPDN-MGMT-MIB.txt Open CISCO-VPDN-MGMT-MIB.txt in a new tab

SCALARS (11) · TABLES (9) · TRAPS (1)

Scalars (11)

NameOID
cvpdnNotifSessionID1.3.6.1.4.1.9.10.24.0.1
cvpdnNotifSessionEvent1.3.6.1.4.1.9.10.24.0.2
cvpdnTunnelTotal1.3.6.1.4.1.9.10.24.1.1.1
cvpdnSessionTotal1.3.6.1.4.1.9.10.24.1.1.2
cvpdnDeniedUsersTotal1.3.6.1.4.1.9.10.24.1.1.3
cvpdnSystemNotifSessionEnabled1.3.6.1.4.1.9.10.24.1.1.5
cvpdnSystemClearSessions1.3.6.1.4.1.9.10.24.1.1.6
cvpdnBundlesWithOneLink1.3.6.1.4.1.9.10.24.1.6.1
cvpdnBundlesWithTwoLinks1.3.6.1.4.1.9.10.24.1.6.2
cvpdnBundlesWithMoreThanTwoLinks1.3.6.1.4.1.9.10.24.1.6.3
cvpdnBundleLastChanged1.3.6.1.4.1.9.10.24.1.6.5

Tables (9)

NameOID
cvpdnSystemTable1.3.6.1.4.1.9.10.24.1.1.4
cvpdnTunnelTable1.3.6.1.4.1.9.10.24.1.2.1
cvpdnTunnelAttrTable1.3.6.1.4.1.9.10.24.1.2.2
cvpdnTunnelSessionTable1.3.6.1.4.1.9.10.24.1.3.1
cvpdnSessionAttrTable1.3.6.1.4.1.9.10.24.1.3.2
cvpdnUserToFailHistInfoTable1.3.6.1.4.1.9.10.24.1.4.1
cvpdnTemplateTable1.3.6.1.4.1.9.10.24.1.5.1
cvpdnBundleTable1.3.6.1.4.1.9.10.24.1.6.4
cvpdnBundleChildTable1.3.6.1.4.1.9.10.24.1.6.6

Traps (1)

NameOID
cvpdnNotifSession1.3.6.1.4.1.9.10.24.0.3

END OF TOC

Scalar details

cvpdnNotifSessionID

1.3.6.1.4.1.9.10.24.0.1

Integer32 (0..65535)

This object contains the local session ID of the L2X session for which this notification has been generated.

cvpdnNotifSessionEvent

1.3.6.1.4.1.9.10.24.0.2

INTEGER1 = up2 = down3 = pwUp4 = pwDown · Integer32

Indicates the event that generated the L2X session notification. The events are represented as follows: up: Session has come up. down: Session has gone down. pwUp: Pseudowire associated with this session has come up. pwDown: Pseudowire associated with this session has gone down.

cvpdnTunnelTotal

1.3.6.1.4.1.9.10.24.1.1.1

Gauge32 · tunnels

The total number of VPDN tunnels that are currently active within this system.

cvpdnSessionTotal

1.3.6.1.4.1.9.10.24.1.1.2

Gauge32 · users

The total number of active users in all the active VPDN tunnels within this system.

cvpdnDeniedUsersTotal

1.3.6.1.4.1.9.10.24.1.1.3

Counter32 · attempts

The total number of denied user attempts to all the active VPDN tunnels within this system.

cvpdnSystemNotifSessionEnabled

1.3.6.1.4.1.9.10.24.1.1.5

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicates whether Layer 2 VPN session notifications are enabled.

cvpdnSystemClearSessions

1.3.6.1.4.1.9.10.24.1.1.6

INTEGER1 = none2 = all3 = l2f4 = l2tp5 = pptp · Integer32

Clears all the sessions in a given tunnel type. When reading this object, the value of 'none' will always be returned. When setting these values, the following operations will be performed: none: no operation. all: clears all the sessions in all the tunnels. l2f: clears all the L2F sessions. l2tp: clears all the L2TP sessions. pptp: clears all the PPTP sessions.

1.3.6.1.4.1.9.10.24.1.6.1

Gauge32

The total number of bundles comprised of a single link.

1.3.6.1.4.1.9.10.24.1.6.2

Gauge32

The total number of bundles comprised of two links.

1.3.6.1.4.1.9.10.24.1.6.3

Gauge32

The total number of bundles comprised of more than two links.

cvpdnBundleLastChanged

1.3.6.1.4.1.9.10.24.1.6.5

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of the sysUpTime object when the contents of cvpdnBundleTable last changed.

Table details

cvpdnSystemTable

1.3.6.1.4.1.9.10.24.1.1.4

Index: cvpdnSystemTunnelType

Table of information about the VPDN system for all tunnel types.

cvpdnSystemTunnelType

1.3.6.1.4.1.9.10.24.1.1.4.1.1

TunnelType1 = l2f2 = l2tp3 = pptpThe tunnel type. This is the tunnel protocol of a VPDN tunnel. · Integer32

The tunnel type. This is the tunnel protocol.

cvpdnSystemTunnelTotal

1.3.6.1.4.1.9.10.24.1.1.4.1.2

Gauge32 · tunnels

The total number of VPDN tunnels that are currently active of this tunnel type.

cvpdnSystemSessionTotal

1.3.6.1.4.1.9.10.24.1.1.4.1.3

Gauge32 · sessions

The total number of active sessions in all the active VPDN tunnels of this tunnel type.

cvpdnSystemDeniedUsersTotal

1.3.6.1.4.1.9.10.24.1.1.4.1.4

Counter32 · attempts

The total number of denied user attempts to all the VPDN tunnels of this tunnel type since last system re-initialization.

cvpdnSystemInitialConnReq

1.3.6.1.4.1.9.10.24.1.1.4.1.5

Counter32 · attempts

The total number tunnel connection attempts on all the VPDN tunnels of this tunnel type since last system re-initialization.

cvpdnSystemSuccessConnReq

1.3.6.1.4.1.9.10.24.1.1.4.1.6

Counter32 · attempts

The total number tunnel Successful connection attempts in VPDN tunnels of this tunnel type since last system re-initialization.

cvpdnSystemFailedConnReq

1.3.6.1.4.1.9.10.24.1.1.4.1.7

Counter32 · attempts

The total number tunnel Failed connection attempts in VPDN tunnels of this tunnel type since last system re-initialization.

cvpdnTunnelTable

1.3.6.1.4.1.9.10.24.1.2.1

Index: cvpdnTunnelTunnelId

Table of information about the active VPDN tunnels.

cvpdnTunnelTunnelId

1.3.6.1.4.1.9.10.24.1.2.1.1.1

Unsigned32

The Tunnel ID of an active VPDN tunnel. If it is the instigator of the tunnel, the ID is the HGW/LNS tunnel ID, otherwise it is the NAS/LAC tunnel ID.

cvpdnTunnelRemoteTunnelId

1.3.6.1.4.1.9.10.24.1.2.1.1.2

Unsigned32

The remote Tunnel ID of an active VPDN tunnel. If it is the instigator of the tunnel, the ID is the NAS/LAC tunnel ID, otherwise it is the HGW/LNS tunnel ID.

cvpdnTunnelLocalName

1.3.6.1.4.1.9.10.24.1.2.1.1.3

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..255) · OCTET STRING · hint 255a

The local name of an active VPDN tunnel. It will be the NAS/LAC name of the tunnel if the router serves as the NAS/LAC, or the HGW/LNS name of the tunnel if the system serves as the home gateway. Typically, the local name is the configured host name of the router.

cvpdnTunnelRemoteName

1.3.6.1.4.1.9.10.24.1.2.1.1.4

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..255) · OCTET STRING · hint 255a

The remote name of an active VPDN tunnel. It will be the home gateway name of the tunnel if the system is a NAS/LAC, or the NAS/LAC name of the tunnel if the system serves as the home gateway.

cvpdnTunnelRemoteEndpointName

1.3.6.1.4.1.9.10.24.1.2.1.1.5

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..255) · OCTET STRING · hint 255a

The remote end point name of an active VPDN tunnel. This name is either the domain name or the DNIS that this tunnel is projected with.

cvpdnTunnelLocalInitConnection

1.3.6.1.4.1.9.10.24.1.2.1.1.6

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object indicates whether the tunnel was generated locally or not.

cvpdnTunnelOrigCause

1.3.6.1.4.1.9.10.24.1.2.1.1.7

INTEGER1 = domain2 = dnis3 = stack · Integer32

The cause which originated an active VPDN tunnel. The tunnel can be projected via domain name, DNIS or a stack group (SGBP).

cvpdnTunnelState

1.3.6.1.4.1.9.10.24.1.2.1.1.8

INTEGER1 = unknown2 = opening3 = open4 = closing · Integer32

The current state of an active VPDN tunnel. Each state code is explained below: unknown: The current state of the tunnel is unknown. opening: The tunnel has just been instigated and is pending for a remote end reply to complete the process. open: The tunnel is active. closing: The tunnel has just been shut down and is pending for the remote end to reply to complete the process.

cvpdnTunnelActiveSessions

1.3.6.1.4.1.9.10.24.1.2.1.1.9

Gauge32 · sessions

The total number of active session currently in the tunnel.

cvpdnTunnelDeniedUsers

1.3.6.1.4.1.9.10.24.1.2.1.1.10

Counter32 · calls

A count of the accumulated total of denied users for the tunnel.

cvpdnTunnelSoftshut

1.3.6.1.4.1.9.10.24.1.2.1.1.12

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

A VPDN tunnel can be put into a soft shut state to prevent any new user session to be added. This object specifies whether this tunnel has been soft shut.

cvpdnTunnelNetworkServiceType

1.3.6.1.4.1.9.10.24.1.2.1.1.13

INTEGER1 = ip · Integer32

The type of network service used in the active tunnel. For now it is IP only.

cvpdnTunnelLocalIpAddress

1.3.6.1.4.1.9.10.24.1.2.1.1.14

IpAddress SIZE (4)

The local IP address of the tunnel. This IP address is that of the interface at the local end of the tunnel.

cvpdnTunnelSourceIpAddress

1.3.6.1.4.1.9.10.24.1.2.1.1.15

IpAddress SIZE (4)

Reference: The Stack Group Biding Protocol (SGBP), United States Patent 6073176

The source IP address of the tunnel. This IP address is the user configurable IP address for Stack Group Biding Protocol (SGBP) via the CLI command: vpdn source-ip

cvpdnTunnelRemoteIpAddress

1.3.6.1.4.1.9.10.24.1.2.1.1.16

IpAddress SIZE (4)

The remote IP address of the tunnel. This IP address is that of the interface at the remote end of the tunnel.

cvpdnTunnelAttrTable

1.3.6.1.4.1.9.10.24.1.2.2

Index: cvpdnSystemTunnelType · cvpdnTunnelAttrTunnelId

Table of information about the active VPDN tunnels. An entry is added to the table when a new tunnel is initiated and removed from the table when the tunnel is terminated.

cvpdnTunnelAttrTunnelId

1.3.6.1.4.1.9.10.24.1.2.2.1.1

Integer32 (0..65535)

The Tunnel ID of an active VPDN tunnel. If this end is the instigator of the tunnel, the ID is the TS tunnel ID, otherwise it is the NAS tunnel ID. Two distinct tunnels with the same tunnel ID may exist, but with different tunnel types.

cvpdnTunnelAttrRemoteTunnelId

1.3.6.1.4.1.9.10.24.1.2.2.1.2

Integer32 (0..65535)

The remote Tunnel ID of an active VPDN tunnel. If this end is the instigator of the tunnel, the ID is the NAS tunnel ID, otherwise it is the TS tunnel ID.

cvpdnTunnelAttrLocalName

1.3.6.1.4.1.9.10.24.1.2.2.1.3

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..255) · OCTET STRING · hint 255a

The local name of an active VPDN tunnel. It will be the NAS name of the tunnel if the system serves as the NAS, or the TS name of the tunnel if the system serves as the tunnel server. Typically, the local name is the configured host name of the system.

cvpdnTunnelAttrRemoteName

1.3.6.1.4.1.9.10.24.1.2.2.1.4

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..255) · OCTET STRING · hint 255a

The remote name of an active VPDN tunnel. It will be the tunnel server name of the tunnel if the system is a NAS, or the NAS name of the tunnel if the system serves as the tunnel server.

cvpdnTunnelAttrRemoteEndpointName

1.3.6.1.4.1.9.10.24.1.2.2.1.5

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..255) · OCTET STRING · hint 255a

The remote end point name of an active VPDN tunnel. This name is either the domain name or the DNIS that this tunnel is projected with.

cvpdnTunnelAttrLocalInitConnection

1.3.6.1.4.1.9.10.24.1.2.2.1.6

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object indicates whether the tunnel was originated locally or not. If it's true, the tunnel was originated locally.

cvpdnTunnelAttrOrigCause

1.3.6.1.4.1.9.10.24.1.2.2.1.7

INTEGER1 = domain2 = dnis3 = stack4 = xconnect · Integer32

The cause which originated an active VPDN tunnel. The tunnel can be projected via domain name, DNIS, stack group, or L2 Xconnect.

cvpdnTunnelAttrState

1.3.6.1.4.1.9.10.24.1.2.2.1.8

INTEGER1 = unknown2 = l2fOpening3 = l2fOpenWait4 = l2fOpen5 = l2fClosing6 = l2fCloseWait7 = l2tpIdle8 = l2tpWaitCtlReply9 = l2tpEstablished10 = l2tpShuttingDown11 = l2tpNoSessionLeft12 = pptpIdle13 = pptpWaitConnect14 = pptpWaitCtlRequest15 = pptpWaitCtlReply16 = pptpEstablished17 = pptpWaitStopReply18 = pptpTerminal · Integer32

The current state of an active VPDN tunnel. Tunnels of type l2f will have states with the 'l2f' prefix. Tunnels of type l2tp will have states with the 'l2tp' prefix. Tunnels of type pptp will have states with the 'pptp' prefix. Each state code is explained below: unknown: The current state of the tunnel is unknown. l2fOpening: The tunnel has just been initiated and is pending for a remote end reply to complete the process. l2fOpenWait: This end received a tunnel open request from the remote end and is waiting for the tunnel to be established. l2fOpen: The tunnel is active. l2fClosing: This end received a tunnel close request. l2fCloseWait: The tunnel has just been shut down and is pending for the remote end to reply to complete the process. l2tpIdle: No tunnel is initiated yet. l2tpWaitCtlReply: The tunnel has been initiated and is pending for a remote end reply to complete the process. l2tpEstablished: The tunnel is active. l2tpShuttingDown: The tunnel is in progress of shutting down. l2tpNoSessionLeft: There is no session left in the tunnel. pptpIdle: No tunnel is initiated yet. pptpWaitConnect: The tunnel is waiting for a TCP connection. pptpWaitCtlRequest: The tunnel has been initiated and is pending for a remote end request. pptpWaitCtlReply: The tunnel has been initiated and is pending for a remote end reply. pptpEstablished: The tunnel is active. pptpWaitStopReply: The tunnel is being shut down and is pending for a remote end reply. pptpTerminal: The tunnel has been shut down.

cvpdnTunnelAttrActiveSessions

1.3.6.1.4.1.9.10.24.1.2.2.1.9

Gauge32 · sessions

The total number of active session currently in the tunnel.

cvpdnTunnelAttrDeniedUsers

1.3.6.1.4.1.9.10.24.1.2.2.1.10

Counter32 · calls

A count of the accumulated total of denied users for the tunnel.

cvpdnTunnelAttrSoftshut

1.3.6.1.4.1.9.10.24.1.2.2.1.11

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

A VPDN tunnel can be put into a soft shut state to prevent any new session to be added. This object specifies whether this tunnel has been soft shut. If its true, it has been soft shut.

cvpdnTunnelAttrNetworkServiceType

1.3.6.1.4.1.9.10.24.1.2.2.1.12

INTEGER1 = ip · Integer32

The type of network service used in the active tunnel.

cvpdnTunnelAttrLocalIpAddress

1.3.6.1.4.1.9.10.24.1.2.2.1.13

IpAddress SIZE (4)

The local IP address of the tunnel. This IP address is that of the interface at the local end of the tunnel.

cvpdnTunnelAttrSourceIpAddress

1.3.6.1.4.1.9.10.24.1.2.2.1.14

IpAddress SIZE (4)

Reference: The Stack Group Biding Protocol (SGBP), United States Patent 6073176

The source IP address of the tunnel. This IP address is the user configurable IP address for Stack Group Biding Protocol.

cvpdnTunnelAttrRemoteIpAddress

1.3.6.1.4.1.9.10.24.1.2.2.1.15

IpAddress SIZE (4)

The remote IP address of the tunnel. This IP address is that of the interface at the remote end of the tunnel.

cvpdnTunnelAttrLocalInetAddressType

1.3.6.1.4.1.9.10.24.1.2.2.1.16

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

Indicates the type of address contained in cvpdnTunnelAttrLocalInetAddress

cvpdnTunnelAttrLocalInetAddress

1.3.6.1.4.1.9.10.24.1.2.2.1.17

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The local IP address of the tunnel. This IP address is that of the interface at the local end of the tunnel. The type of this address is determined by the value of cvpdnTunnelAttrLocalInetAddressType.

cvpdnTunnelAttrSourceInetAddressType

1.3.6.1.4.1.9.10.24.1.2.2.1.18

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

Indicates the type of address contained in cvpdnTunnelAttrSourceInetAddress

cvpdnTunnelAttrSourceInetAddress

1.3.6.1.4.1.9.10.24.1.2.2.1.19

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Reference: The Stack Group Biding Protocol (SGBP), United States Patent 6073176

The source IP address of the tunnel. This IP address is the user configurable IP address for Stack Group Biding Protocol. The type of this address is determined by the value of cvpdnTunnelAttrSourceInetAddressType.

cvpdnTunnelAttrRemoteInetAddressType

1.3.6.1.4.1.9.10.24.1.2.2.1.20

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

Indicates the type of address contained in cvpdnTunnelAttrRemoteInetAddress

cvpdnTunnelAttrRemoteInetAddress

1.3.6.1.4.1.9.10.24.1.2.2.1.21

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The remote IP address of the tunnel. This IP address is that of the interface at the remote end of the tunnel. The type of this address is determined by the value of cvpdnTunnelAttrRemoteInetAddressType.

cvpdnTunnelSessionTable

1.3.6.1.4.1.9.10.24.1.3.1

Index: cvpdnTunnelTunnelId · cvpdnTunnelSessionId

Table of information about individual user sessions within the active tunnels. Entry is added to the table when new user session is initiated and be removed from the table when the user session is terminated.

cvpdnTunnelSessionId

1.3.6.1.4.1.9.10.24.1.3.1.1.1

Unsigned32

The ID of an active VPDN tunnel user session.

cvpdnTunnelSessionUserName

1.3.6.1.4.1.9.10.24.1.3.1.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..255) · OCTET STRING · hint 255a

The name of the user of the user session.

cvpdnTunnelSessionState

1.3.6.1.4.1.9.10.24.1.3.1.1.3

INTEGER1 = unknown2 = opening3 = open4 = closing5 = waitingForTunnel · Integer32

The current state of an active user session. Each state code is explained below: unknown: The current state of the tunnel's session is unknown. opening: The user session has just been initiated through a tunnel and is pending for the remote end reply to complete the process. open: The user session is active. closing: The user session has just been closed and is pending for the remote end reply to complete the process. waitingForTunnel: The user session is in this state when the tunnel which this session is going through is still in CLOSED state. It waits for the tunnel to become OPEN before the session is allow to be fully established.

cvpdnTunnelSessionCallDuration

1.3.6.1.4.1.9.10.24.1.3.1.1.4

TimeTicks

This object specifies the call duration of the current active user session in value of system uptime.

cvpdnTunnelSessionPacketsOut

1.3.6.1.4.1.9.10.24.1.3.1.1.5

Counter32 · packets

The total number of output packets through this active user session.

cvpdnTunnelSessionBytesOut

1.3.6.1.4.1.9.10.24.1.3.1.1.6

Counter32 · bytes

The total number of output bytes through this active user session.

cvpdnTunnelSessionPacketsIn

1.3.6.1.4.1.9.10.24.1.3.1.1.7

Counter32 · packets

The total number of input packets through this active user session.

cvpdnTunnelSessionBytesIn

1.3.6.1.4.1.9.10.24.1.3.1.1.8

Counter32 · bytes

The total number of input bytes through this active user session.

cvpdnTunnelSessionDeviceType

1.3.6.1.4.1.9.10.24.1.3.1.1.9

INTEGER1 = other2 = asyncInternalModem3 = async4 = bchan5 = sync6 = virtualAccess7 = xdsl8 = cable · Integer32

The type of physical devices that this user session is attached to for the local end of the tunnel. The meaning of each device type is explained below: other: Any device that has not been defined. asyncInternalModem: Modem Pool device of an access server. async: A regular asynchronous serial interface. sync: A regular synchronous serial interface. bchan: An ISDN call. xdsl: Future application with xDSL devices. cable: Future application with Cable modem devices.

cvpdnTunnelSessionDeviceCallerId

1.3.6.1.4.1.9.10.24.1.3.1.1.10

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The incoming caller identification of the user. It is the originating number that called into the device that initiates the user session. This object can be empty since not all dial device can provide caller ID information.

cvpdnTunnelSessionDevicePhyId

1.3.6.1.4.1.9.10.24.1.3.1.1.11

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

The device ID of the physical interface for the user session. The object is the the interface index which points to the ifTable. For virtual interface that is not in the ifTable, it will have zero value.

1.3.6.1.4.1.9.10.24.1.3.1.1.12

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object indicates whether the session is part of a multilink or not.

cvpdnTunnelSessionModemSlotIndex

1.3.6.1.4.1.9.10.24.1.3.1.1.13

Unsigned32

The Modem Pool database slot index if it is associated with this user session. Only a session with device of type asyncInternalModem will have a valid value for this object.

cvpdnTunnelSessionModemPortIndex

1.3.6.1.4.1.9.10.24.1.3.1.1.14

Unsigned32

The Modem Pool database port index if it is associated with this user session. Only a session with a device of type asyncInternalModem will have a valid value for this object.

cvpdnTunnelSessionDS1SlotIndex

1.3.6.1.4.1.9.10.24.1.3.1.1.15

Unsigned32

The DS1 database slot index if it is associated with this user session. Only a session with a device of type asyncInternalModem will have a valid value for this object.

cvpdnTunnelSessionDS1PortIndex

1.3.6.1.4.1.9.10.24.1.3.1.1.16

Unsigned32

The DS1 database port index if it is associated with this user session. Only a session with a device of type asyncInternalModem will have a a valid value for this object.

cvpdnTunnelSessionDS1ChannelIndex

1.3.6.1.4.1.9.10.24.1.3.1.1.17

Unsigned32

The DS1 database channel index if it is associated with this user session. Only a session over a device of type asyncInternalModem will have a valid value for this object.

cvpdnTunnelSessionModemCallStartTime

1.3.6.1.4.1.9.10.24.1.3.1.1.18

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The start time of the current modem call. Only a session with a device of type asyncInternalModem will have a valid value for this object.

cvpdnTunnelSessionModemCallStartIndex

1.3.6.1.4.1.9.10.24.1.3.1.1.19

Unsigned32

Arbitrary small integer to distinguish modem calls that occurred at the same time tick. Only session over device asyncInternalModem will have a valid value for this object.

cvpdnSessionAttrTable

1.3.6.1.4.1.9.10.24.1.3.2

Index: cvpdnSystemTunnelType · cvpdnTunnelAttrTunnelId · cvpdnSessionAttrSessionId

Table of information about individual sessions within the active tunnels. An entry is added to the table when a new session is initiated and removed from the table when the session is terminated.

cvpdnSessionAttrSessionId

1.3.6.1.4.1.9.10.24.1.3.2.1.1

Integer32 (0..65535)

The ID of an active VPDN session.

cvpdnSessionAttrUserName

1.3.6.1.4.1.9.10.24.1.3.2.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..255) · OCTET STRING · hint 255a

The name of the user of the session.

cvpdnSessionAttrState

1.3.6.1.4.1.9.10.24.1.3.2.1.3

INTEGER1 = unknown2 = l2fOpening3 = l2fOpen4 = l2fCloseWait5 = l2fWaitingForTunnel6 = l2tpIdle7 = l2tpWaitingTunnel8 = l2tpWaitReply9 = l2tpWaitConnect10 = l2tpEstablished11 = l2tpShuttingDown12 = pptpWaitVAccess13 = pptpPacEstablished14 = pptpWaitTunnel15 = pptpWaitOCRP16 = pptpPnsEstablished17 = pptpWaitCallDisc18 = pptpTerminal · Integer32

The current state of a tunnel session. L2F tunnel sessions will have states with the 'l2f' prefix. L2TP tunnel sessions will have states with the 'l2tp' prefix. Each state code is explained below: unknown: The current state of the tunnel's session is unknown. l2fOpening: The session has just been initiated through a tunnel and is pending for the remote end reply to complete the process. l2fOpen: The session is active. l2fCloseWait: The session has just been closed and is pending for the remote end reply to complete the process. l2fWaitingForTunnel: The session is in this state when the tunnel which this session is going through is still in CLOSED state. It waits for the tunnel to become OPEN before the session is allowed to be fully established. l2tpIdle: No session is initiated yet. l2tpWaitingTunnel: The session is waiting for the tunnel to be established. l2tpWaitReply: The session has been initiated and is pending for the remote end reply to complete the process. l2tpWaitConnect: This end has acknowledged a connection request and is waiting for the remote end to connect. l2tpEstablished: The session is active. l2tpShuttingDown: The session is in progress of shutting down. pptpWaitVAccess: The session is waiting for the creation of a virtual access interface. pptpPacEstablished: The session is active. pptpWaitTunnel: The session is waiting for the tunnel to be established. pptpWaitOCRP: The session has been initiated and is pending for the remote end reply to complete the process. pptpPnsEstablished: The session is active. pptpWaitCallDisc: Session shutdown is in progress.

cvpdnSessionAttrCallDuration

1.3.6.1.4.1.9.10.24.1.3.2.1.4

TimeTicks

This object specifies the call duration of the current active session.

cvpdnSessionAttrPacketsOut

1.3.6.1.4.1.9.10.24.1.3.2.1.5

Counter32 · packets

The total number of output packets through this active session.

cvpdnSessionAttrBytesOut

1.3.6.1.4.1.9.10.24.1.3.2.1.6

Counter32 · bytes

The total number of output bytes through this active session.

cvpdnSessionAttrPacketsIn

1.3.6.1.4.1.9.10.24.1.3.2.1.7

Counter32 · packets

The total number of input packets through this active session.

cvpdnSessionAttrBytesIn

1.3.6.1.4.1.9.10.24.1.3.2.1.8

Counter32 · bytes

The total number of input bytes through this active session.

cvpdnSessionAttrDeviceType

1.3.6.1.4.1.9.10.24.1.3.2.1.9

INTEGER1 = other2 = asyncInternalModem3 = async4 = bchan5 = sync6 = virtualAccess7 = xdsl8 = cable · Integer32

The type of physical devices that this session is attached to for the local end of the tunnel. The meaning of each device type is explained below: other: Any device that has not been defined. asyncInternalModem: Modem Pool device of an access server. async: A regular asynchronous serial interface. sync: A regular synchronous serial interface. bchan: An ISDN call. xdsl: xDSL interface. cable: cable modem interface.

cvpdnSessionAttrDeviceCallerId

1.3.6.1.4.1.9.10.24.1.3.2.1.10

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The incoming caller identification of the user. It is the originating number that called into the device that initiates the session. This object can be empty since not all dial devices can provide caller ID information.

cvpdnSessionAttrDevicePhyId

1.3.6.1.4.1.9.10.24.1.3.2.1.11

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

The device ID of the physical interface for the session. The object is the the interface index which points to the ifTable. For virtual interfaces that are not in the ifTable, the value will be zero.

1.3.6.1.4.1.9.10.24.1.3.2.1.12

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object indicates whether the session is part of a multilink PPP bundle, even if there is only one link or session in the bundle. If it is multilink PPP, the value is true.

cvpdnSessionAttrModemSlotIndex

1.3.6.1.4.1.9.10.24.1.3.2.1.13

Unsigned32

The Modem Pool database slot index if it is associated with this session. Only a session with device of type 'asyncInternalModem' will have a valid value for this object; otherwise, it is not instantiated.

cvpdnSessionAttrModemPortIndex

1.3.6.1.4.1.9.10.24.1.3.2.1.14

Unsigned32

The Modem Pool database port index if it is associated with this session. Only a session with a device of type 'asyncInternalModem' will have a valid value for this object; otherwise, it is not instantiated.

cvpdnSessionAttrDS1SlotIndex

1.3.6.1.4.1.9.10.24.1.3.2.1.15

Unsigned32

The DS1 database slot index if it is associated with this session. Only a session with a device of type 'asyncInternalModem' will have a valid value for this object; otherwise it is not instantiated.

cvpdnSessionAttrDS1PortIndex

1.3.6.1.4.1.9.10.24.1.3.2.1.16

Unsigned32

The DS1 database port index if it is associated with this session. Only a session with a device of type 'asyncInternalModem' will have a valid value for this object; otherwise it is not instantiated.

cvpdnSessionAttrDS1ChannelIndex

1.3.6.1.4.1.9.10.24.1.3.2.1.17

Unsigned32

The DS1 database channel index if it is associated with this session. Only a session over a device of type 'asyncInternalModem' will have a valid value for this object; otherwise it is not instantiated.

cvpdnSessionAttrModemCallStartTime

1.3.6.1.4.1.9.10.24.1.3.2.1.18

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The start time of the current modem call. Only a session with a device of type 'asyncInternalModem' will have a valid value for this object; otherwise, it is not instantiated.

cvpdnSessionAttrModemCallStartIndex

1.3.6.1.4.1.9.10.24.1.3.2.1.19

Unsigned32

Arbitrary small integer to distinguish modem calls that occurred at the same time tick. Only session over device 'asyncInternalModem' will have a valid value for this object; otherwise, it is not instantiated.

cvpdnSessionAttrVirtualCircuitID

1.3.6.1.4.1.9.10.24.1.3.2.1.20

Unsigned32

The virtual circuit ID of an active Layer 2 VPN session.

cvpdnSessionAttrSentPktsDropped

1.3.6.1.4.1.9.10.24.1.3.2.1.21

Counter32 · packets

The total number of dropped packets that could not be sent into this active session.

cvpdnSessionAttrRecvPktsDropped

1.3.6.1.4.1.9.10.24.1.3.2.1.22

Counter32 · packets

The total number of dropped packets that were received from this active session.

cvpdnSessionAttrMultilinkBundle

1.3.6.1.4.1.9.10.24.1.3.2.1.23

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object specifies the name of the multilink bundle to which this session belongs. The value of this object is only valid when the value of cvpdnSessionAttrMultilink is 'true'. If the value of cvpdnSessionAttrMultilink is 'false', then the value of this object will be the empty string.

cvpdnSessionAttrMultilinkIfIndex

1.3.6.1.4.1.9.10.24.1.3.2.1.24

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

This object specifies the ifIndex of the multilink bundle to which this session belongs. The value of this object is only valid when the value of cvpdnSessionAttrMultilink is 'true'. If the value of cvpdnSessionAttrMultilink is 'false', then the value of this object will be zero.

cvpdnUserToFailHistInfoTable

1.3.6.1.4.1.9.10.24.1.4.1

Index: cvpdnUnameToFailHistUname · cvpdnUnameToFailHistTunnelId

Table of the record of failure objects which can be referenced by an user name. Only a name that has a valid item in the Cisco IOS VPDN failure history table will yield a valid entry in this table. The table has a maximum size of 50 entries. Only the newest 50 entries will be kept in the table.

cvpdnUnameToFailHistUname

1.3.6.1.4.1.9.10.24.1.4.1.1.1

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..255) · OCTET STRING · hint 255a

The user name for this failure entry.

cvpdnUnameToFailHistTunnelId

1.3.6.1.4.1.9.10.24.1.4.1.1.2

Unsigned32

The Tunnel ID for this failure entry. If it is the instigator of the tunnel, the ID is the TS tunnel ID, otherwise it is the NAS tunnel ID.

cvpdnUnameToFailHistUserId

1.3.6.1.4.1.9.10.24.1.4.1.1.3

Unsigned32

The user ID of this failure entry.

cvpdnUnameToFailHistLocalInitConn

1.3.6.1.4.1.9.10.24.1.4.1.1.4

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object indicates whether the tunnel in which the failure occurred was generated locally or not.

cvpdnUnameToFailHistLocalName

1.3.6.1.4.1.9.10.24.1.4.1.1.5

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The local name of the VPDN tunnel in which the failure occurred. It will be the NAS name of the tunnel if the system serves as the NAS, or the TS name of the tunnel if the system serves as the tunnel server. The local name is the configured host name of the system. This object can be empty if the failure occurred prior to successful tunnel projection, thus no source name will be available.

cvpdnUnameToFailHistRemoteName

1.3.6.1.4.1.9.10.24.1.4.1.1.6

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The remote name of the VPDN tunnel in which the failure occurred. It will be the tunnel server name of the tunnel if the system is a NAS, or the NAS name of the tunnel if the system serves as the tunnel server. This object can be empty if the failure occurred prior to successful tunnel projection, thus no source name will be available.

cvpdnUnameToFailHistSourceIp

1.3.6.1.4.1.9.10.24.1.4.1.1.7

IpAddress SIZE (4)

The source IP address of the tunnel in which the failure occurred. This IP address is that of the interface at the instigator end of the tunnel.

cvpdnUnameToFailHistDestIp

1.3.6.1.4.1.9.10.24.1.4.1.1.8

IpAddress SIZE (4)

The destination IP address of the tunnel in which the failure occurred. This IP address is that of the interface at the receiver end of the tunnel.

cvpdnUnameToFailHistCount

1.3.6.1.4.1.9.10.24.1.4.1.1.9

Counter32 · failures

This object is incremented when multiple failures has been experienced by this user on this tunnel. Seeing a delta of >1 is an indication that the current failure record is the latest of a series of failures that has been recorded.

cvpdnUnameToFailHistFailTime

1.3.6.1.4.1.9.10.24.1.4.1.1.10

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

This object specifies the time when the failure is occurred.

cvpdnUnameToFailHistFailType

1.3.6.1.4.1.9.10.24.1.4.1.1.11

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..255) · OCTET STRING · hint 255a

The type of failure for the current failure record. It comes in a form of a an ASCII string which describes the type of failure.

cvpdnUnameToFailHistFailReason

1.3.6.1.4.1.9.10.24.1.4.1.1.12

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..255) · OCTET STRING · hint 255a

The reason of failure for the current failure record.

cvpdnUnameToFailHistSourceInetType

1.3.6.1.4.1.9.10.24.1.4.1.1.13

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

Indicates the type of address contained in cvpdnUnameToFailHistSourceInetAddr.

cvpdnUnameToFailHistSourceInetAddr

1.3.6.1.4.1.9.10.24.1.4.1.1.14

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The source IP address of the tunnel in which the failure occurred. This IP address is that of the interface at the instigator end of the tunnel. The instigator end is the peer which initiates the tunnel estalishment. The type of this address is determined by the value of cvpdnUnameToFailHistSourceInetType.

cvpdnUnameToFailHistDestInetType

1.3.6.1.4.1.9.10.24.1.4.1.1.15

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

Indicates the type of address contained in cvpdnUnameToFailHistDestInetAddr.

cvpdnUnameToFailHistDestInetAddr

1.3.6.1.4.1.9.10.24.1.4.1.1.16

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The destination IP address of the tunnel in which the failure occurred. This IP address is that of the interface at the receiver end of the tunnel. The type of this address is determined by the value of cvpdnUnameToFailHistDestInetType.

cvpdnTemplateTable

1.3.6.1.4.1.9.10.24.1.5.1

Index: IMPLIED cvpdnTemplateName

Table of information about the VPDN templates. The VPDN template is a grouping mechanism that allows configuration settings to be shared among multiple VPDN groups. One such setting is a limit on the number of active sessions across all VPDN groups associated with the template. The template table allows customers to monitor template-wide information such as tracking the allocation of sessions across templates.

cvpdnTemplateName

1.3.6.1.4.1.9.10.24.1.5.1.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..255) · OCTET STRING · hint 255t

The name of the VPDN template.

cvpdnTemplateActiveSessions

1.3.6.1.4.1.9.10.24.1.5.1.1.2

Gauge32 · sessions

The total number of active session in all groups associated with the template.

cvpdnBundleTable

1.3.6.1.4.1.9.10.24.1.6.4

Index: cvpdnBundleName

Table that describes the multilink PPP attributes of the active VPDN sessions.

cvpdnBundleName

1.3.6.1.4.1.9.10.24.1.6.4.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..64) · OCTET STRING · hint 255t

The name of the multilink PPP bundle associated with a VPDN tunnel.

cvpdnBundleLinkCount

1.3.6.1.4.1.9.10.24.1.6.4.1.2

Gauge32 · links

The total number of active links in a multilink PPP bundle associated with a VPDN tunnel.

cvpdnBundleEndpointType

1.3.6.1.4.1.9.10.24.1.6.4.1.3

INTEGER1 = none2 = hostname3 = string4 = macAddress5 = ipV4Address6 = ipV6Address7 = phone8 = magicNumber · Integer32

The multilink PPP bundle discriminator type associated with a VPDN tunnel. The value of this object represents the type of discriminator used in cvpdnBundleEndpoint. none: No endpoint discriminator was supplied, the default value is being used. hostname: The router's hostname is being used as discriminator. string: User specified string is being used as discriminator. macAddress: A MAC address as defined by the MacAddress textual convention is being used as discriminator. ipV4Address: An IP address as defined by the InetAddressIPv4 textual convention is being used as discriminator. ipV6Address: An IP address as defined by the InetAddressIPv6 textual convention is being used as discriminator. phone: The PSTN phone number is being used as discriminator. magicNumber: A magic number is being used as discriminator.

cvpdnBundleEndpoint

1.3.6.1.4.1.9.10.24.1.6.4.1.4

OCTET STRING SIZE (0..255)

Indicates the discriminator used in this bundle that is associated with a VPDN tunnel.

cvpdnBundlePeerIpAddrType

1.3.6.1.4.1.9.10.24.1.6.4.1.5

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

Indicates the type of address contained in cvpdnBundlePeerIpAddr.

cvpdnBundlePeerIpAddr

1.3.6.1.4.1.9.10.24.1.6.4.1.6

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The IP address of the multilink PPP peer in a VPDN tunnel.

cvpdnBundleEndpointClass

1.3.6.1.4.1.9.10.24.1.6.4.1.7

EndpointClass1 = none2 = local3 = ipV4Address4 = macAddress5 = magicNumber6 = phoneThe endpoint discriminator class supplied by the remote peer in a PPP Multilink bundle. RFC 1990 defines the following classes: none: Class 0 - Null Class. No endpoint discriminator is being used. The endpoint discriminator should contain a SnmpAdminString (SIZE (0)) value. local: Class 1 - Locally Assigned Address. This class is defined to permit a local assignment in the case where use of one of the globally unique classes is not possible. The endpoint discriminator should contain a SnmpAdminString (SIZE(1..20)) value. ipV4Address: Class 2 - Internet Protocol (IP) Address. An address in this class contains an IP host address. The endpoint discriminator should contain a InetAddressIPv4 value. macAddress: Class 3 - IEEE 802.1 Globally Assigned MAC Address. An address in this class contains an IEEE 802.1 MAC address in canonical (802.3) format. The endpoint discriminator should contain a MacAddress value. magicNumber: Class 4 - PPP Magic-Number Block. This is not an address but a block of 1 to 5 concatenated 32 bit PPP Magic-Numbers. The endpoint discriminator should contain an OCTET STRING (SIZE (4|8|12|16| 20)) value. phone: Class 5 - Public Switched Network Directory Number. An address in this class contains an octet sequence as defined by I.331 (E.164) representing an international telephone directory number suitable for use to access the endpoint via the public switched telephone network. The endpoint discriminator should contain a SnmpAdminString (SIZE(1..15)) value.Reference: The PPP Multilink Protocol (MP), RFC 1990, Section 5.1.3. · Integer32

The multilink PPP bundle discriminator class associated with a VPDN tunnel. The value of this object represents the type of discriminator used in cvpdnBundleEndpoint.

cvpdnBundleChildTable

1.3.6.1.4.1.9.10.24.1.6.6

Index: cvpdnBundleName · cvpdnBundleChildTunnelType · cvpdnBundleChildTunnelId · cvpdnBundleChildSessionId

A table that exposes the containment relationship between a multilink PPP bundle and a VPDN tunnel.

cvpdnBundleChildTunnelType

1.3.6.1.4.1.9.10.24.1.6.6.1.1

TunnelType1 = l2f2 = l2tp3 = pptpThe tunnel type. This is the tunnel protocol of a VPDN tunnel. · Integer32

The tunnel type. This is the tunnel protocol of an active VPDN session that is associated with a multilink PPP bundle.

cvpdnBundleChildTunnelId

1.3.6.1.4.1.9.10.24.1.6.6.1.2

Unsigned32

The Tunnel ID of an active VPDN session that is associated with a multilink PPP bundle.

cvpdnBundleChildSessionId

1.3.6.1.4.1.9.10.24.1.6.6.1.3

Unsigned32

The ID of an active VPDN session that is associated with a multilink PPP bundle.

Trap details

cvpdnNotifSession

1.3.6.1.4.1.9.10.24.0.3

Conveys an event regarding the L2X session with the indicated session ID and Xconnect VCID.

cvpdnNotifSessionID

1.3.6.1.4.1.9.10.24.0.1

Integer32 (0..65535)

This object contains the local session ID of the L2X session for which this notification has been generated.

cvpdnNotifSessionEvent

1.3.6.1.4.1.9.10.24.0.2

INTEGER1 = up2 = down3 = pwUp4 = pwDown · Integer32

Indicates the event that generated the L2X session notification. The events are represented as follows: up: Session has come up. down: Session has gone down. pwUp: Pseudowire associated with this session has come up. pwDown: Pseudowire associated with this session has gone down.

cvpdnSessionAttrDevicePhyId

1.3.6.1.4.1.9.10.24.1.3.2.1.11

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

The device ID of the physical interface for the session. The object is the the interface index which points to the ifTable. For virtual interfaces that are not in the ifTable, the value will be zero.

cvpdnSessionAttrVirtualCircuitID

1.3.6.1.4.1.9.10.24.1.3.2.1.20

Unsigned32

The virtual circuit ID of an active Layer 2 VPN session.

↑ To TOC