EZ5 MIB Catalog

CISCO-VQES-MIB

2010-02-05

This MIB module defines a set of objects for monitoring the Visual Quality Experience Server (VQE-S) operational status. VQE-S receives the channel lineups from the VQE Channel Provisioning Tool. Each channel is uniquely identified with a Service Delivery Protocol (SDP) description, including: - IP multicast address - Real-Time Protocol (RTP) port number - Real-Time Control Protocol (RTCP) port number - Unicast feedback target address - RTP and RTCP port numbers VQE-S supports Error Repair (ER) and Rapid Channel Change (RCC) technologies to improve the delivery of IPTV video services. When a VQE client (VQE-C) notices a missing packet or a group of missing packets, it sends an RTCP Feedback Generic NACK to the VQE-S. The VQE-S looks into its cache, and if it has any of the requested packets, it sends them immediately to the VQE-C as RTP retransmission repair packets. When the VQE-C detects a channel change, it immediately sends an RTCP Picture Loss Indication (PLI) NACK to the VQE-S to request the information for the VQE-C to recover its picture. Both ER and RCC are unicast retransmissions.

Download CISCO-VQES-MIB.txt Open CISCO-VQES-MIB.txt in a new tab

SCALARS (15) · TABLES (1) · TRAPS (2)

Scalars (15)

NameOID
cvqsNotificationsEnable1.3.6.1.4.1.9.9.942.1.1.1
cvqsNumberofChannels1.3.6.1.4.1.9.9.942.1.2.1
cvqsActiveChannels1.3.6.1.4.1.9.9.942.1.2.2
cvqsLastUpdatedTime1.3.6.1.4.1.9.9.942.1.2.3
cvqsTotalReceivedERMsgs1.3.6.1.4.1.9.9.942.1.3.1
cvqsTotalReceivedInvalidERMsgs1.3.6.1.4.1.9.9.942.1.3.2
cvqsTotalReceivedERPkts1.3.6.1.4.1.9.9.942.1.3.3
cvqsTotalSentERPkts1.3.6.1.4.1.9.9.942.1.3.4
cvqsTotalReceivedRCCs1.3.6.1.4.1.9.9.942.1.4.1
cvqsTotalAcceptedRCCs1.3.6.1.4.1.9.9.942.1.4.2
cvqsTotalRefusedRCCs1.3.6.1.4.1.9.9.942.1.4.3
cvqsTotalRTCPReceivers1.3.6.1.4.1.9.9.942.1.5.1
cvqsRejectedRTCPs1.3.6.1.4.1.9.9.942.1.5.2
cvqsRejectedERs1.3.6.1.4.1.9.9.942.1.5.3
cvqsRejectedRCCs1.3.6.1.4.1.9.9.942.1.5.4

Tables (1)

NameOID
cvqsChannelTable1.3.6.1.4.1.9.9.942.1.2.4

Traps (2)

NameOID
cvqsChannelUp1.3.6.1.4.1.9.9.942.0.1
cvqsChannelDown1.3.6.1.4.1.9.9.942.0.2

END OF TOC

Scalar details

cvqsNotificationsEnable

1.3.6.1.4.1.9.9.942.1.1.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies whether cvqsChannelUp and cvqsChannelDown notifications will be generated or not. A false value will prevent these notifications from being generated.

cvqsNumberofChannels

1.3.6.1.4.1.9.9.942.1.2.1

Gauge32

This object indicates total number of channels in the channel lineup configuration.

cvqsActiveChannels

1.3.6.1.4.1.9.9.942.1.2.2

Gauge32

This object indicates total number of channels successfully parsed from the channel lineup.

cvqsLastUpdatedTime

1.3.6.1.4.1.9.9.942.1.2.3

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This object indicates the time when the channel lineup was last updated.

cvqsTotalReceivedERMsgs

1.3.6.1.4.1.9.9.942.1.3.1

Counter64 (0..18446744073709551615) · ER requests

This object indicates the total number of requests for ER (Generic NACK RTCP) messages received.

cvqsTotalReceivedInvalidERMsgs

1.3.6.1.4.1.9.9.942.1.3.2

Counter64 (0..18446744073709551615) · ER requests

This object indicates the number of requests for ER (Generic NACK RTCP messages) received that were invalid.

cvqsTotalReceivedERPkts

1.3.6.1.4.1.9.9.942.1.3.3

Counter64 (0..18446744073709551615) · ER packets

This object indicates the total number of RTP packets requested for retransmission.

cvqsTotalSentERPkts

1.3.6.1.4.1.9.9.942.1.3.4

Counter64 (0..18446744073709551615) · ER packets

This object indicates the total number of retransmitted RTP packets.

cvqsTotalReceivedRCCs

1.3.6.1.4.1.9.9.942.1.4.1

Counter64 (0..18446744073709551615) · RCC requests

This object indicates the total number of RCC requests received by the VQE-S.

cvqsTotalAcceptedRCCs

1.3.6.1.4.1.9.9.942.1.4.2

Counter64 (0..18446744073709551615) · RCC requests

This object indicates the total number of RCC requests accepted by the VQE-S.

cvqsTotalRefusedRCCs

1.3.6.1.4.1.9.9.942.1.4.3

Counter64 (0..18446744073709551615) · RCC requests

This object indicates the total number of RCC requests not accepted by the VQE-S.

cvqsTotalRTCPReceivers

1.3.6.1.4.1.9.9.942.1.5.1

Gauge32 · RTCP receivers

This object indicates the number of currently active RTCP receivers.

cvqsRejectedRTCPs

1.3.6.1.4.1.9.9.942.1.5.2

Counter64 (0..18446744073709551615) · RTCP packets

This object indicates the number of received RTCP packets (ER requests, RCC requests or Receiver Reports) rejected by the VQE-S due to active RTCP receivers in VQE-S reaching their limit of accepting RTCP requests.

cvqsRejectedERs

1.3.6.1.4.1.9.9.942.1.5.3

Counter64 (0..18446744073709551615) · ER requests

This object indicates the number of received ER requests rejected by the VQE-S due to VQE-S reaching its limit of accepting ER requests.

cvqsRejectedRCCs

1.3.6.1.4.1.9.9.942.1.5.4

Counter64 (0..18446744073709551615) · RCC requests

This object indicates the number of received RCC requests rejected by the VQE-S due to VQE-S reaching its limit of accepting RCC requests.

Table details

cvqsChannelTable

1.3.6.1.4.1.9.9.942.1.2.4

Index: cvqsChannelIndex

This table contains the list of channels (i.e., the channel lineup) this VQE-S is servicing.

cvqsChannelIndex

1.3.6.1.4.1.9.9.942.1.2.4.1.1

Unsigned32 (1..4294967295)

An arbitrary integer-value that uniquely identifies this channel.

cvqsChannelMulticastIPType

1.3.6.1.4.1.9.9.942.1.2.4.1.2

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the address type of channel multicast IP address.

cvqsChannelMulticastIPAddr

1.3.6.1.4.1.9.9.942.1.2.4.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates the channel's multicast IP address.

cvqsChannelMulticastPort

1.3.6.1.4.1.9.9.942.1.2.4.1.4

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object indicates the channel's multicast port number.

cvqsChannelStatus

1.3.6.1.4.1.9.9.942.1.2.4.1.5

INTEGER1 = active2 = inactive3 = inoperative · Integer32

This object indicates the current status of this channel.

cvqsChannelMemberPopulation

1.3.6.1.4.1.9.9.942.1.2.4.1.6

Gauge32

This object indicates the number of VQE clients listening to this channel.

Trap details

cvqsChannelUp

1.3.6.1.4.1.9.9.942.0.1

This notification indicates that a VQE-S channel status is changed to ACTIVE.

cvqsChannelMulticastIPType

1.3.6.1.4.1.9.9.942.1.2.4.1.2

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the address type of channel multicast IP address.

cvqsChannelMulticastIPAddr

1.3.6.1.4.1.9.9.942.1.2.4.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates the channel's multicast IP address.

cvqsChannelMulticastPort

1.3.6.1.4.1.9.9.942.1.2.4.1.4

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object indicates the channel's multicast port number.

cvqsChannelDown

1.3.6.1.4.1.9.9.942.0.2

This notification indicates that a VQE-S channel status is changed to INACTIVE or INOPERATIVE.

cvqsChannelMulticastIPType

1.3.6.1.4.1.9.9.942.1.2.4.1.2

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the address type of channel multicast IP address.

cvqsChannelMulticastIPAddr

1.3.6.1.4.1.9.9.942.1.2.4.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates the channel's multicast IP address.

cvqsChannelMulticastPort

1.3.6.1.4.1.9.9.942.1.2.4.1.4

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object indicates the channel's multicast port number.

↑ To TOC