EZ5 MIB Catalog

CISCO-WAN-MGC-REDUN-MIB

2004-01-19

The MIB module for Media Gateways (MGs) to allow multiple Media Gateway Controllers (MGCs) to be configured and managed on the Gateway. MGCs can be group together as part of the same MGC redundancy group. Terms used: CA: Call Agent GW: Gateway MGC: Media Gateway Controller MGCP: Media Gateway Control Protocol NTFY: Notify message (MGCP standard message) RSIP: Restart In Progress (MGCP standard message) RSVP: Resource Reservation Setup Protocol SGCP: Simple Gateway Control Protocol SRCP: Simple Resource Coordination Protocol

Download CISCO-WAN-MGC-REDUN-MIB.txt Open CISCO-WAN-MGC-REDUN-MIB.txt in a new tab

TABLES (3)

Tables (3)

NameOID
mgcRedundancyGrpTable1.3.6.1.4.1.351.150.22.1.1
mgcRedundancyGrpParamTable1.3.6.1.4.1.351.150.22.1.2
mgcRedundancyGrpProtocolTable1.3.6.1.4.1.351.150.22.1.3

END OF TOC

Table details

mgcRedundancyGrpTable

1.3.6.1.4.1.351.150.22.1.1

Index: mgcRedundancyGrpNum · mgcNumber

Multiple Media Gateway Controllers can be grouped together as part of the same MGC redundancy group. This configuration supports the notion of redundant Media Gateway Controllers. This table keeps track of the MGCs in a redundancy group. It is used to create MGC redundancy groups. MGCs can also be removed from a group.

from CISCO-WAN-MG-MIB

mgcNumber

Integer32 (1..65535)

Serves as index to this table.

mgcRedundancyGrpNum

1.3.6.1.4.1.351.150.22.1.1.1.1

Integer32 (1..65535)

This is the MGC group number. A group can contain more than 1 MGC. So for a group containing more than 1 MGC, there will be more than 1 row of this table that will have a common group number.

mgcRedundancyGrpPref

1.3.6.1.4.1.351.150.22.1.1.1.2

Integer32 (1..65535)

Allows to configure the preference on a MGCs. The GW use this object in the selection of an MGC when there are multiple MGCs in the same MGC redundancy group. This object can be modified at any time while the mgcRedundancyGrpRowStatus is 'active'. It has to be unique among various MGCs of a same MGC redundancy group. The lower the number the higher the preference, for example 1 will have higher preference than 2.

mgcRedundancyGrpActState

1.3.6.1.4.1.351.150.22.1.1.1.3

INTEGER1 = mgcActive2 = mgcInactive · Integer32

This object is used to denote the status of MGC within an MGC Redundancy group. 'mgcActive' - Indicates the MGC is active or controlling the GW. 'mgcInactive' - Indicates the MGC is in standby state.

mgcRedundancyGrpRowStatus

1.3.6.1.4.1.351.150.22.1.1.1.4

RowStatus1 = active2 = notInService3 = notReady4 = createAndGo5 = createAndWait6 = destroyThe RowStatus textual convention is used to manage the creation and deletion of conceptual rows, and is used as the value of the SYNTAX clause for the status column of a conceptual row (as described in Section 7.7.1 of [2].) The status column has six defined values: - `active', which indicates that the conceptual row is available for use by the managed device; - `notInService', which indicates that the conceptual row exists in the agent, but is unavailable for use by the managed device (see NOTE below); 'notInService' has no implication regarding the internal consistency of the row, availability of resources, or consistency with the current state of the managed device; - `notReady', which indicates that the conceptual row exists in the agent, but is missing information necessary in order to be available for use by the managed device (i.e., one or more required columns in the conceptual row have not been instanciated); - `createAndGo', which is supplied by a management station wishing to create a new instance of a conceptual row and to have its status automatically set to active, making it available for use by the managed device; - `createAndWait', which is supplied by a management station wishing to create a new instance of a conceptual row (but not make it available for use by the managed device); and, - `destroy', which is supplied by a management station wishing to delete all of the instances associated with an existing conceptual row. Whereas five of the six values (all except `notReady') may be specified in a management protocol set operation, only three values will be returned in response to a management protocol retrieval operation: `notReady', `notInService' or `active'. That is, when queried, an existing conceptual row has only three states: it is either available for use by the managed device (the status column has value `active'); it is not available for use by the managed device, though the agent has sufficient information to attempt to make it so (the status column has value `notInService'); or, it is not available for use by the managed device, and an attempt to make it so would fail because the agent has insufficient information (the state column has value `notReady'). NOTE WELL This textual convention may be used for a MIB table, irrespective of whether the values of that table's conceptual rows are able to be modified while it is active, or whether its conceptual rows must be taken out of service in order to be modified. That is, it is the responsibility of the DESCRIPTION clause of the status column to specify whether the status column must not be `active' in order for the value of some other column of the same conceptual row to be modified. If such a specification is made, affected columns may be changed by an SNMP set PDU if the RowStatus would not be equal to `active' either immediately before or after processing the PDU. In other words, if the PDU also contained a varbind that would change the RowStatus value, the column in question may be changed if the RowStatus was not equal to `active' as the PDU was received, or if the varbind sets the status to a value other than 'active'. Also note that whenever any elements of a row exist, the RowStatus column must also exist. To summarize the effect of having a conceptual row with a status column having a SYNTAX clause value of RowStatus, consider the following state diagram: STATE +--------------+-----------+-------------+------------- | A | B | C | D | |status col.|status column| |status column | is | is |status column ACTION |does not exist| notReady | notInService| is active --------------+--------------+-----------+-------------+------------- set status |noError ->D|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndGo |inconsistent- | | | | Value| | | --------------+--------------+-----------+-------------+------------- set status |noError see 1|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndWait |wrongValue | | | --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError column to | Value| entValue| | active | | | | | | or | | | | | | | |see 2 ->D|see 8 ->D| ->D --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError ->C column to | Value| entValue| | notInService | | | | | | or | | or | | | | | |see 3 ->C| ->C|see 6 --------------+--------------+-----------+-------------+------------- set status |noError |noError |noError |noError ->A column to | | | | or destroy | ->A| ->A| ->A|see 7 --------------+--------------+-----------+-------------+------------- set any other |see 4 |noError |noError |see 5 column to some| | | | value | | see 1| ->C| ->D --------------+--------------+-----------+-------------+------------- (1) goto B or C, depending on information available to the agent. (2) if other variable bindings included in the same PDU, provide values for all columns which are missing but required, and all columns have acceptable values, then return noError and goto D. (3) if other variable bindings included in the same PDU, provide legal values for all columns which are missing but required, then return noError and goto C. (4) at the discretion of the agent, the return value may be either: inconsistentName: because the agent does not choose to create such an instance when the corresponding RowStatus instance does not exist, or inconsistentValue: if the supplied value is inconsistent with the state of some other MIB object's value, or noError: because the agent chooses to create the instance. If noError is returned, then the instance of the status column must also be created, and the new state is B or C, depending on the information available to the agent. If inconsistentName or inconsistentValue is returned, the row remains in state A. (5) depending on the MIB definition for the column/table, either noError or inconsistentValue may be returned. (6) the return value can indicate one of the following errors: wrongValue: because the agent does not support notInService (e.g., an agent which does not support createAndWait), or inconsistentValue: because the agent is unable to take the row out of service at this time, perhaps because it is in use and cannot be de-activated. (7) the return value can indicate the following error: inconsistentValue: because the agent is unable to remove the row at this time, perhaps because it is in use and cannot be de-activated. (8) the transition to D can fail, e.g., if the values of the conceptual row are inconsistent, then the error code would be inconsistentValue. NOTE: Other processing of (this and other varbinds of) the set request may result in a response other than noError being returned, e.g., wrongValue, noCreation, etc. Conceptual Row Creation There are four potential interactions when creating a conceptual row: selecting an instance-identifier which is not in use; creating the conceptual row; initializing any objects for which the agent does not supply a default; and, making the conceptual row available for use by the managed device. Interaction 1: Selecting an Instance-Identifier The algorithm used to select an instance-identifier varies for each conceptual row. In some cases, the instance- identifier is semantically significant, e.g., the destination address of a route, and a management station selects the instance-identifier according to the semantics. In other cases, the instance-identifier is used solely to distinguish conceptual rows, and a management station without specific knowledge of the conceptual row might examine the instances present in order to determine an unused instance-identifier. (This approach may be used, but it is often highly sub-optimal; however, it is also a questionable practice for a naive management station to attempt conceptual row creation.) Alternately, the MIB module which defines the conceptual row might provide one or more objects which provide assistance in determining an unused instance-identifier. For example, if the conceptual row is indexed by an integer-value, then an object having an integer-valued SYNTAX clause might be defined for such a purpose, allowing a management station to issue a management protocol retrieval operation. In order to avoid unnecessary collisions between competing management stations, `adjacent' retrievals of this object should be different. Finally, the management station could select a pseudo-random number to use as the index. In the event that this index was already in use and an inconsistentValue was returned in response to the management protocol set operation, the management station should simply select a new pseudo-random number and retry the operation. A MIB designer should choose between the two latter algorithms based on the size of the table (and therefore the efficiency of each algorithm). For tables in which a large number of entries are expected, it is recommended that a MIB object be defined that returns an acceptable index for creation. For tables with small numbers of entries, it is recommended that the latter pseudo-random index mechanism be used. Interaction 2: Creating the Conceptual Row Once an unused instance-identifier has been selected, the management station determines if it wishes to create and activate the conceptual row in one transaction or in a negotiated set of interactions. Interaction 2a: Creating and Activating the Conceptual Row The management station must first determine the column requirements, i.e., it must determine those columns for which it must or must not provide values. Depending on the complexity of the table and the management station's knowledge of the agent's capabilities, this determination can be made locally by the management station. Alternately, the management station issues a management protocol get operation to examine all columns in the conceptual row that it wishes to create. In response, for each column, there are three possible outcomes: - a value is returned, indicating that some other management station has already created this conceptual row. We return to interaction 1. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it should supply a value for this column when the conceptual row is to be created. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. Once the column requirements have been determined, a management protocol set operation is accordingly issued. This operation also sets the new instance of the status column to `createAndGo'. When the agent processes the set operation, it verifies that it has sufficient information to make the conceptual row available for use by the managed device. The information available to the agent is provided by two sources: the management protocol set operation which creates the conceptual row, and, implementation-specific defaults supplied by the agent (note that an agent must provide implementation-specific defaults for at least those objects which it implements as read-only). If there is sufficient information available, then the conceptual row is created, a `noError' response is returned, the status column is set to `active', and no further interactions are necessary (i.e., interactions 3 and 4 are skipped). If there is insufficient information, then the conceptual row is not created, and the set operation fails with an error of `inconsistentValue'. On this error, the management station can issue a management protocol retrieval operation to determine if this was because it failed to specify a value for a required column, or, because the selected instance of the status column already existed. In the latter case, we return to interaction 1. In the former case, the management station can re-issue the set operation with the additional information, or begin interaction 2 again using `createAndWait' in order to negotiate creation of the conceptual row. NOTE WELL Regardless of the method used to determine the column requirements, it is possible that the management station might deem a column necessary when, in fact, the agent will not allow that particular columnar instance to be created or written. In this case, the management protocol set operation will fail with an error such as `noCreation' or `notWritable'. In this case, the management station decides whether it needs to be able to set a value for that particular columnar instance. If not, the management station re-issues the management protocol set operation, but without setting a value for that particular columnar instance; otherwise, the management station aborts the row creation algorithm. Interaction 2b: Negotiating the Creation of the Conceptual Row The management station issues a management protocol set operation which sets the desired instance of the status column to `createAndWait'. If the agent is unwilling to process a request of this sort, the set operation fails with an error of `wrongValue'. (As a consequence, such an agent must be prepared to accept a single management protocol set operation, i.e., interaction 2a above, containing all of the columns indicated by its column requirements.) Otherwise, the conceptual row is created, a `noError' response is returned, and the status column is immediately set to either `notInService' or `notReady', depending on whether it has sufficient information to (attempt to) make the conceptual row available for use by the managed device. If there is sufficient information available, then the status column is set to `notInService'; otherwise, if there is insufficient information, then the status column is set to `notReady'. Regardless, we proceed to interaction 3. Interaction 3: Initializing non-defaulted Objects The management station must now determine the column requirements. It issues a management protocol get operation to examine all columns in the created conceptual row. In the response, for each column, there are three possible outcomes: - a value is returned, indicating that the agent implements the object-type associated with this column and had sufficient information to provide a value. For those columns to which the agent provides read-create access (and for which the agent allows their values to be changed after their creation), a value return tells the management station that it may issue additional management protocol set operations, if it desires, in order to change the value associated with this column. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. However, the agent does not have sufficient information to provide a value, and until a value is provided, the conceptual row may not be made available for use by the managed device. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it must issue additional management protocol set operations, in order to provide a value associated with this column. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. If the value associated with the status column is `notReady', then the management station must first deal with all `noSuchInstance' columns, if any. Having done so, the value of the status column becomes `notInService', and we proceed to interaction 4. Interaction 4: Making the Conceptual Row Available Once the management station is satisfied with the values associated with the columns of the conceptual row, it issues a management protocol set operation to set the status column to `active'. If the agent has sufficient information to make the conceptual row available for use by the managed device, the management protocol set operation succeeds (a `noError' response is returned). Otherwise, the management protocol set operation fails with an error of `inconsistentValue'. NOTE WELL A conceptual row having a status column with value `notInService' or `notReady' is unavailable to the managed device. As such, it is possible for the managed device to create its own instances during the time between the management protocol set operation which sets the status column to `createAndWait' and the management protocol set operation which sets the status column to `active'. In this case, when the management protocol set operation is issued to set the status column to `active', the values held in the agent supersede those used by the managed device. If the management station is prevented from setting the status column to `active' (e.g., due to management station or network failure) the conceptual row will be left in the `notInService' or `notReady' state, consuming resources indefinitely. The agent must detect conceptual rows that have been in either state for an abnormally long period of time and remove them. It is the responsibility of the DESCRIPTION clause of the status column to indicate what an abnormally long period of time would be. This period of time should be long enough to allow for human response time (including `think time') between the creation of the conceptual row and the setting of the status to `active'. In the absence of such information in the DESCRIPTION clause, it is suggested that this period be approximately 5 minutes in length. This removal action applies not only to newly-created rows, but also to previously active rows which are set to, and left in, the notInService state for a prolonged period exceeding that which is considered normal for such a conceptual row. Conceptual Row Suspension When a conceptual row is `active', the management station may issue a management protocol set operation which sets the instance of the status column to `notInService'. If the agent is unwilling to do so, the set operation fails with an error of `wrongValue' or `inconsistentValue'. Otherwise, the conceptual row is taken out of service, and a `noError' response is returned. It is the responsibility of the DESCRIPTION clause of the status column to indicate under what circumstances the status column should be taken out of service (e.g., in order for the value of some other column of the same conceptual row to be modified). Conceptual Row Deletion For deletion of conceptual rows, a management protocol set operation is issued which sets the instance of the status column to `destroy'. This request may be made regardless of the current value of the status column (e.g., it is possible to delete conceptual rows which are either `notReady', `notInService' or `active'.) If the operation succeeds, then all instances associated with the conceptual row are immediately removed. · Integer32

Controls the creation and deletion of a table entry. An entry may be created using the 'createAndGo' option. When the row is successfully created, the RowStatus would be set to 'active' by the agent. An entry may be deleted by setting the RowStatus to 'destroy'. Other options such as `createAndWait', 'notInService', 'notReady' are not supported. mgcRedundancyGrpNum, mgcNumber and mgcRedundancyGrpPref are the mandatory parameters while creating an entry.

mgcRedundancyGrpParamTable

1.3.6.1.4.1.351.150.22.1.2

Index: mgcRedundancyGrpNum

This table contains the parameters of the MGC redundancy groups like the association state and priority of the group within the GW. An entry in this table is implicitly created when the first MGC is added for an MGC redundancy group. The objects are set to their default values. When the last MGC from an MGC redundancy group is removed, the corresponding entry from this table is implicitly removed.

mgcRedundancyGrpStateChangeNtfy

1.3.6.1.4.1.351.150.22.1.2.1.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object 'true(1) will enable sending state change notifications to the MGC. 'false(2)' will disable sending state change notifications to MGC, for example, if MGCP/SGCP is the protocol used, then RSIPs are sent to the MGC if this object is set to 'true(1)'.

mgcRedundancyGrpCommState

1.3.6.1.4.1.351.150.22.1.2.1.2

INTEGER1 = commOk2 = commLoss · Integer32

Represents the state of the communication between the GW and the MGC (call agent) group. The possible values are: 'commOk': This indicates that the communication between the gateway and the media gateway controller is ok. 'commLoss': This indicates that the communication between the GW and the MGC is lost. This object is set to 'commLoss' if no response is receive from any MGC in this group to a GW initiated message. If the GW is able to successfully send a message to the MGC or if a message is received from the MGC, the value of this object is set to 'commOk' else it will remain in the 'commLoss' state.

mgcRedundancyGrpPriority

1.3.6.1.4.1.351.150.22.1.2.1.3

Integer32 (0..65535)

This field determines the priority amongst the MGC redundancy groups within the GW. A MGC group with a priority of 0 means that the MGC group is not interested in receiving GW initiated messages. A group with a priority value of 1 has the highest preference. A higher value indicates a lower preference. Multiple MGC redundancy groups can have the same priority.

mgcRedundancyGrpProtocolTable

1.3.6.1.4.1.351.150.22.1.3

Index: mgcRedundancyGrpNum · mgProtocolNumber

This table contains information about which protocols are being used in a particular association between the gateway and the MGC redundancy groups. Because there may be a number of different protocols in use for a particular control association between the gateway and an MGC group, this information is kept in a separate table rather than being included in mgcRedundancyGrpTable. In effect, it constitutes a relationship between mgcRedundancyGrpTable and mgSupportedProtocolTable defined in CISCO-WAN-MG-MIB. This table restricts all MGCs within a MGC redundancy group to have the same set of protocols defined.

from CISCO-WAN-MG-MIB

mgProtocolNumber

Integer32 (1..65535)

Serves as index to this table.

mgcRedundancyGrpProtocolRowStatus

1.3.6.1.4.1.351.150.22.1.3.1.1

RowStatus1 = active2 = notInService3 = notReady4 = createAndGo5 = createAndWait6 = destroyThe RowStatus textual convention is used to manage the creation and deletion of conceptual rows, and is used as the value of the SYNTAX clause for the status column of a conceptual row (as described in Section 7.7.1 of [2].) The status column has six defined values: - `active', which indicates that the conceptual row is available for use by the managed device; - `notInService', which indicates that the conceptual row exists in the agent, but is unavailable for use by the managed device (see NOTE below); 'notInService' has no implication regarding the internal consistency of the row, availability of resources, or consistency with the current state of the managed device; - `notReady', which indicates that the conceptual row exists in the agent, but is missing information necessary in order to be available for use by the managed device (i.e., one or more required columns in the conceptual row have not been instanciated); - `createAndGo', which is supplied by a management station wishing to create a new instance of a conceptual row and to have its status automatically set to active, making it available for use by the managed device; - `createAndWait', which is supplied by a management station wishing to create a new instance of a conceptual row (but not make it available for use by the managed device); and, - `destroy', which is supplied by a management station wishing to delete all of the instances associated with an existing conceptual row. Whereas five of the six values (all except `notReady') may be specified in a management protocol set operation, only three values will be returned in response to a management protocol retrieval operation: `notReady', `notInService' or `active'. That is, when queried, an existing conceptual row has only three states: it is either available for use by the managed device (the status column has value `active'); it is not available for use by the managed device, though the agent has sufficient information to attempt to make it so (the status column has value `notInService'); or, it is not available for use by the managed device, and an attempt to make it so would fail because the agent has insufficient information (the state column has value `notReady'). NOTE WELL This textual convention may be used for a MIB table, irrespective of whether the values of that table's conceptual rows are able to be modified while it is active, or whether its conceptual rows must be taken out of service in order to be modified. That is, it is the responsibility of the DESCRIPTION clause of the status column to specify whether the status column must not be `active' in order for the value of some other column of the same conceptual row to be modified. If such a specification is made, affected columns may be changed by an SNMP set PDU if the RowStatus would not be equal to `active' either immediately before or after processing the PDU. In other words, if the PDU also contained a varbind that would change the RowStatus value, the column in question may be changed if the RowStatus was not equal to `active' as the PDU was received, or if the varbind sets the status to a value other than 'active'. Also note that whenever any elements of a row exist, the RowStatus column must also exist. To summarize the effect of having a conceptual row with a status column having a SYNTAX clause value of RowStatus, consider the following state diagram: STATE +--------------+-----------+-------------+------------- | A | B | C | D | |status col.|status column| |status column | is | is |status column ACTION |does not exist| notReady | notInService| is active --------------+--------------+-----------+-------------+------------- set status |noError ->D|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndGo |inconsistent- | | | | Value| | | --------------+--------------+-----------+-------------+------------- set status |noError see 1|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndWait |wrongValue | | | --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError column to | Value| entValue| | active | | | | | | or | | | | | | | |see 2 ->D|see 8 ->D| ->D --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError ->C column to | Value| entValue| | notInService | | | | | | or | | or | | | | | |see 3 ->C| ->C|see 6 --------------+--------------+-----------+-------------+------------- set status |noError |noError |noError |noError ->A column to | | | | or destroy | ->A| ->A| ->A|see 7 --------------+--------------+-----------+-------------+------------- set any other |see 4 |noError |noError |see 5 column to some| | | | value | | see 1| ->C| ->D --------------+--------------+-----------+-------------+------------- (1) goto B or C, depending on information available to the agent. (2) if other variable bindings included in the same PDU, provide values for all columns which are missing but required, and all columns have acceptable values, then return noError and goto D. (3) if other variable bindings included in the same PDU, provide legal values for all columns which are missing but required, then return noError and goto C. (4) at the discretion of the agent, the return value may be either: inconsistentName: because the agent does not choose to create such an instance when the corresponding RowStatus instance does not exist, or inconsistentValue: if the supplied value is inconsistent with the state of some other MIB object's value, or noError: because the agent chooses to create the instance. If noError is returned, then the instance of the status column must also be created, and the new state is B or C, depending on the information available to the agent. If inconsistentName or inconsistentValue is returned, the row remains in state A. (5) depending on the MIB definition for the column/table, either noError or inconsistentValue may be returned. (6) the return value can indicate one of the following errors: wrongValue: because the agent does not support notInService (e.g., an agent which does not support createAndWait), or inconsistentValue: because the agent is unable to take the row out of service at this time, perhaps because it is in use and cannot be de-activated. (7) the return value can indicate the following error: inconsistentValue: because the agent is unable to remove the row at this time, perhaps because it is in use and cannot be de-activated. (8) the transition to D can fail, e.g., if the values of the conceptual row are inconsistent, then the error code would be inconsistentValue. NOTE: Other processing of (this and other varbinds of) the set request may result in a response other than noError being returned, e.g., wrongValue, noCreation, etc. Conceptual Row Creation There are four potential interactions when creating a conceptual row: selecting an instance-identifier which is not in use; creating the conceptual row; initializing any objects for which the agent does not supply a default; and, making the conceptual row available for use by the managed device. Interaction 1: Selecting an Instance-Identifier The algorithm used to select an instance-identifier varies for each conceptual row. In some cases, the instance- identifier is semantically significant, e.g., the destination address of a route, and a management station selects the instance-identifier according to the semantics. In other cases, the instance-identifier is used solely to distinguish conceptual rows, and a management station without specific knowledge of the conceptual row might examine the instances present in order to determine an unused instance-identifier. (This approach may be used, but it is often highly sub-optimal; however, it is also a questionable practice for a naive management station to attempt conceptual row creation.) Alternately, the MIB module which defines the conceptual row might provide one or more objects which provide assistance in determining an unused instance-identifier. For example, if the conceptual row is indexed by an integer-value, then an object having an integer-valued SYNTAX clause might be defined for such a purpose, allowing a management station to issue a management protocol retrieval operation. In order to avoid unnecessary collisions between competing management stations, `adjacent' retrievals of this object should be different. Finally, the management station could select a pseudo-random number to use as the index. In the event that this index was already in use and an inconsistentValue was returned in response to the management protocol set operation, the management station should simply select a new pseudo-random number and retry the operation. A MIB designer should choose between the two latter algorithms based on the size of the table (and therefore the efficiency of each algorithm). For tables in which a large number of entries are expected, it is recommended that a MIB object be defined that returns an acceptable index for creation. For tables with small numbers of entries, it is recommended that the latter pseudo-random index mechanism be used. Interaction 2: Creating the Conceptual Row Once an unused instance-identifier has been selected, the management station determines if it wishes to create and activate the conceptual row in one transaction or in a negotiated set of interactions. Interaction 2a: Creating and Activating the Conceptual Row The management station must first determine the column requirements, i.e., it must determine those columns for which it must or must not provide values. Depending on the complexity of the table and the management station's knowledge of the agent's capabilities, this determination can be made locally by the management station. Alternately, the management station issues a management protocol get operation to examine all columns in the conceptual row that it wishes to create. In response, for each column, there are three possible outcomes: - a value is returned, indicating that some other management station has already created this conceptual row. We return to interaction 1. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it should supply a value for this column when the conceptual row is to be created. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. Once the column requirements have been determined, a management protocol set operation is accordingly issued. This operation also sets the new instance of the status column to `createAndGo'. When the agent processes the set operation, it verifies that it has sufficient information to make the conceptual row available for use by the managed device. The information available to the agent is provided by two sources: the management protocol set operation which creates the conceptual row, and, implementation-specific defaults supplied by the agent (note that an agent must provide implementation-specific defaults for at least those objects which it implements as read-only). If there is sufficient information available, then the conceptual row is created, a `noError' response is returned, the status column is set to `active', and no further interactions are necessary (i.e., interactions 3 and 4 are skipped). If there is insufficient information, then the conceptual row is not created, and the set operation fails with an error of `inconsistentValue'. On this error, the management station can issue a management protocol retrieval operation to determine if this was because it failed to specify a value for a required column, or, because the selected instance of the status column already existed. In the latter case, we return to interaction 1. In the former case, the management station can re-issue the set operation with the additional information, or begin interaction 2 again using `createAndWait' in order to negotiate creation of the conceptual row. NOTE WELL Regardless of the method used to determine the column requirements, it is possible that the management station might deem a column necessary when, in fact, the agent will not allow that particular columnar instance to be created or written. In this case, the management protocol set operation will fail with an error such as `noCreation' or `notWritable'. In this case, the management station decides whether it needs to be able to set a value for that particular columnar instance. If not, the management station re-issues the management protocol set operation, but without setting a value for that particular columnar instance; otherwise, the management station aborts the row creation algorithm. Interaction 2b: Negotiating the Creation of the Conceptual Row The management station issues a management protocol set operation which sets the desired instance of the status column to `createAndWait'. If the agent is unwilling to process a request of this sort, the set operation fails with an error of `wrongValue'. (As a consequence, such an agent must be prepared to accept a single management protocol set operation, i.e., interaction 2a above, containing all of the columns indicated by its column requirements.) Otherwise, the conceptual row is created, a `noError' response is returned, and the status column is immediately set to either `notInService' or `notReady', depending on whether it has sufficient information to (attempt to) make the conceptual row available for use by the managed device. If there is sufficient information available, then the status column is set to `notInService'; otherwise, if there is insufficient information, then the status column is set to `notReady'. Regardless, we proceed to interaction 3. Interaction 3: Initializing non-defaulted Objects The management station must now determine the column requirements. It issues a management protocol get operation to examine all columns in the created conceptual row. In the response, for each column, there are three possible outcomes: - a value is returned, indicating that the agent implements the object-type associated with this column and had sufficient information to provide a value. For those columns to which the agent provides read-create access (and for which the agent allows their values to be changed after their creation), a value return tells the management station that it may issue additional management protocol set operations, if it desires, in order to change the value associated with this column. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. However, the agent does not have sufficient information to provide a value, and until a value is provided, the conceptual row may not be made available for use by the managed device. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it must issue additional management protocol set operations, in order to provide a value associated with this column. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. If the value associated with the status column is `notReady', then the management station must first deal with all `noSuchInstance' columns, if any. Having done so, the value of the status column becomes `notInService', and we proceed to interaction 4. Interaction 4: Making the Conceptual Row Available Once the management station is satisfied with the values associated with the columns of the conceptual row, it issues a management protocol set operation to set the status column to `active'. If the agent has sufficient information to make the conceptual row available for use by the managed device, the management protocol set operation succeeds (a `noError' response is returned). Otherwise, the management protocol set operation fails with an error of `inconsistentValue'. NOTE WELL A conceptual row having a status column with value `notInService' or `notReady' is unavailable to the managed device. As such, it is possible for the managed device to create its own instances during the time between the management protocol set operation which sets the status column to `createAndWait' and the management protocol set operation which sets the status column to `active'. In this case, when the management protocol set operation is issued to set the status column to `active', the values held in the agent supersede those used by the managed device. If the management station is prevented from setting the status column to `active' (e.g., due to management station or network failure) the conceptual row will be left in the `notInService' or `notReady' state, consuming resources indefinitely. The agent must detect conceptual rows that have been in either state for an abnormally long period of time and remove them. It is the responsibility of the DESCRIPTION clause of the status column to indicate what an abnormally long period of time would be. This period of time should be long enough to allow for human response time (including `think time') between the creation of the conceptual row and the setting of the status to `active'. In the absence of such information in the DESCRIPTION clause, it is suggested that this period be approximately 5 minutes in length. This removal action applies not only to newly-created rows, but also to previously active rows which are set to, and left in, the notInService state for a prolonged period exceeding that which is considered normal for such a conceptual row. Conceptual Row Suspension When a conceptual row is `active', the management station may issue a management protocol set operation which sets the instance of the status column to `notInService'. If the agent is unwilling to do so, the set operation fails with an error of `wrongValue' or `inconsistentValue'. Otherwise, the conceptual row is taken out of service, and a `noError' response is returned. It is the responsibility of the DESCRIPTION clause of the status column to indicate under what circumstances the status column should be taken out of service (e.g., in order for the value of some other column of the same conceptual row to be modified). Conceptual Row Deletion For deletion of conceptual rows, a management protocol set operation is issued which sets the instance of the status column to `destroy'. This request may be made regardless of the current value of the status column (e.g., it is possible to delete conceptual rows which are either `notReady', `notInService' or `active'.) If the operation succeeds, then all instances associated with the conceptual row are immediately removed. · Integer32

Controls the creation and deletion of a table entry. An entry may be created using the 'createAndGo' option. When the row is successfully created, the mgcRedundancyGrpProtocolRowStatus would be set to 'active' by the agent. An entry can be modified at any time while the mgcRedundancyGrpProtocolRowStatus is 'active'. An entry may be deleted by setting the mgcRedundancyGrpProtocolRowStatus to 'destroy'.

mgcRedGrpProtPersistEvtPolicy

1.3.6.1.4.1.351.150.22.1.3.1.2

INTEGER1 = quarantinePersistEvts2 = notQuarantinePersistEvts · Integer32

This object determines how the persistent events will be notified. Persistent events are events that call agent wants to be notified without explicitly requesting for it. A set of events can be provisioned on the Gateway as persistent events. Every event will have an action associated with it, which will determine, whether to be notified, ignored, accumulated etc.. MGC will specify the action when requesting the GW to notify the event. For persistent events the Action will be Notify. Call agent can change this by explicitly requesting the event associating an action with it. During the period where the Gateway has received a notification acknowledgement, and waiting for the next Request Notification, events could be observed. The Quarantine procedure determines what should be done with these events. This object is used to supercede the quarantine procedure, by enforcing loop, process as the quarantine procedure only for persistent events. During the period the Gateway has sent a Notification, and waiting for the acknowledgement all events including the persistent events will 'quarantinePersistEvts' - Quarantine Persistent events as in the case of non persistent events as determined by quarantine method. 'notQuarantinePersistEvts' - Don't quarantine Persistent events, and notify them. During the period the Gateway has sent a Notify and waiting for the acknowledgement, every event including persistent event will be quarantined. This value does not supercede that behaviour. This applies only during the period, where a Notify is acknowledged and waiting for the next RQNT where the quarantine method is 'step,process' or 'step,discard'. This object has no relevance when the protocol is SRCP.

mgcRedGrpProtQuarantinePolicy

1.3.6.1.4.1.351.150.22.1.3.1.3

INTEGER1 = stepProcess2 = stepDiscard3 = loopProcess4 = loopDiscard · Integer32

Reference: Media Gateway Control Protocol (MGCP), version 1.0 bis, May 10, 2001 : Sections 3.2.2.18, 3.3.1, 3.3.2.

This object determines the quarantine policy when MGC doesn't explicitly specify one. When a Request Notification is received from the MGC, the Gateway on observing the first event that qualifies to be notified will generate a Notify message with the list of observed events including the event which triggered the Notify. After the MGC acknowledges the Notify, if further events are observed and an event which qualifies to be notified, the Gateway may notify the event, or quarantine it until the next Request Notification, based on the quarantine policy set by the MGC. When the MGC doesn't explicitly specify the quarantine policy, the protocol defines the default behaviour. The default behaviour varies with different versions of the protocol. This object allows the user to configure the default quarantine policy per protocol per redundancy group. The default value for this object will be set based on the protocol. 'stepProcess' - Process the events in the quarantine list, and after one Notify quarantine events until next Request Notification 'stepDiscard' - Discard the events in the quarantine list, and after one Notify quarantine events until next Request Notification 'loopProcess' - Process the events in the quarantine list, and notify observed events as and when need arises 'loopDiscard' - Discard the events in the quarantine list, and notify observed events as and when need arises The default value for MGCP 1.0 will be stepProcess and stepDiscard for the rest. This object has no relevance when the protocol is SRCP.

mgcRedGrpProtSigEvtOnOffPolicy

1.3.6.1.4.1.351.150.22.1.3.1.4

INTEGER1 = deleteEventNotPresent2 = deleteOnlyNegatedEvent · Integer32

This object enables the user to provision the way signaled events from CA are handled by the gateway. This is configurable on a per MGC redundancy group, per protocol basis. If the protocol is MGCP 1.0 the default of this object is 'deleteOnlyNegatedEvent', else it is set to 'deleteEventNotPresent'. If this object is set to 'deleteOnlyNegatedEvent', then the signal currently active on a endpoint/connection can be turned OFF only by parameterizing it with a (-) for eg: S: T/co1(-) will turn off co1 event on an endpoint. And can be turned ON by just providing the signal name or by parameterizing the signal name with a (+) for eg: S:T/co1(+), L/hd will turn on co1 and hd events on the endpoint. If this object is set to 'deleteEventNotPresent', then the signal/s can be turned OFF by providing empty S: list. The signal can be turned ON by simply providing the signal name. for eg: S: will turn OFF all active signals on the endpoint S: T/co1 will turn ON co1 signal. The configuration of this object only applies to on/off signals and not for brief or timeout signals. MGCP 0.1 specification says if an empty signaled list is provided it is meant to turn off all the currently turned on signaled events. However in MGCP 1.0 specification, it says that unless specifically requested by the CA to turn off (signal is parameterized by a (-)) the signal cannot be turned off, in other words an empty signal list does imply that the currently active signals should be turned off. Although the behavior of the gateway is specified in the specs, some MGC may not follow the MGCP 1.0 spec. Hence this MIB serves as an interop knob. This object has no relevance when the protocol is SRCP.

mgcRedGrpProtProvisionalResponse

1.3.6.1.4.1.351.150.22.1.3.1.5

INTEGER1 = sendProvisionalResponse2 = notSendProvisionalResponse · Integer32

This object enables or disables sending provisional response to the CA when processing a request received from the CA. The provisional response to the CA indicates that the GW is processing the request and will send a final response once the processing is complete. For example, if a CRCX request from the CA using MGCP protocol, requires that resources be reserved along the bearer path using RSVP, GW would send a provisional response if this parameter was set to true. It would then wait for the RSVP procedure to complete before sending the final response. On the other hand, if the value of this parameter was set to false, the final response will be sent out without waiting for the RSVP procedure to complete. When the RSVP procedure does complete, a NTFY will be sent from the GW indicating if the RSVP procedure was successful or not. The GW will receive provisional responses from the CA. These messages will be parsed and ignored regardless of this object. If the protocol supported by the CA is MGCP1.0, the default value for this object is 'sendProvisionalResponse'. In all other cases, it is 'notSendProvisionalResponse'. This object has no relevance when the protocol is SRCP.

mgcRedGrpProtResponseAckAttr

1.3.6.1.4.1.351.150.22.1.3.1.6

INTEGER1 = sendResponseAckAttr2 = notSendResponseAckAttr · Integer32

Reference: Media Gateway Control Protocol (MGCP), version 1.0 bis, May 10, 2001 : Sections 3.2.2.18, 3.3.1, 3.3.2.

Every command from the MGC could contain Response Acknowledgement attribute. This attribute consists a list of transaction IDs which are acknowledged by the Call agent. The gateway on receiving this can free up the resources attached to this transaction ID. When this attribute is present in the Gateway response, it should contain an empty list of transaction ID. This attribute in the response from the Gateway is to invite a response acknowledgement message from the MGC for this response. This will be present in the final response sent by the gateway only when a provisional response had been sent prior to this final response for the same transaction. This object determines whether the Gateway should include response acknowledgement in the final response. This object does not determine the capability of the Gateway to receive response acknowledgement attribute as part of MGC commands. 'sendResponseAckAttr' - Gateway will include response acknowledgement attribute as part of final response when a provisional response had been sent earlier. 'notSendResponseAckAttr' - Gateway will not include response acknowledgement attribute as part of final response when a provisional response had been sent earlier. The default value will be 'sendResponseAckAttr' for MGCP 1.0 protocol and 'notSendResponseAckAttr' for every other protocol. This object has no relevance when the protocol is SRCP.

mgcRedGrpProtDisconnectProcedure

1.3.6.1.4.1.351.150.22.1.3.1.7

INTEGER1 = doDisconnectProcedure2 = notDoDisconnectProcedure · Integer32

Reference: Media Gateway Control Protocol (MGCP), version 1.0 bis, May 10, 2001 : Section 4.4.7.

This attribute describes whether disconnected procedure is enabled/disabled per protocol per MGC group configured. The endpoint becomes disconnected when a gateway initiated commands are sent to the MGC and has not received any response from the MGC. The disconnected endpoint initiates the disconnected procedure by sending Restart in Progress command with restart method RM:disconnected to the MGC. When the object is set to 'doDisconnectProcedure', then the endpoint will start the disconnected procedure and sends 'Restart In Progress' command with the restart method RM:disconnected to the MGC. By default, the object is set to 'doDisconnectProcedure' for MGCP 1.0 and 'notDoDisconnectProcedure' for all other protocols. This object has no relevance when the protocol is SRCP.

mgcRedGrpProtCancelGraceful

1.3.6.1.4.1.351.150.22.1.3.1.8

INTEGER1 = sendCancelGraceful2 = notSendCancelGraceful · Integer32

Reference: Media Gateway Control Protocol (MGCP), version 1.0 bis, May 10, 2001 : Section 4.4.7.

This attribute describes whether notification of RSIP cancel graceful is enabled/disabled per protocol per MGC group configured. The Restart in Progress command with the restart method of cancel graceful indicates that the gateway is canceling a previously issued 'graceful' restart in progress command. The endpoints are still in service. When the object is set to 'sendCancelGraceful', the gateway will send the Restart in Progress command with the restart method of cancel graceful indicating that it is canceling the previously sent 'graceful' Restart in Progress command. By default, the object is set to 'sendCancelGraceful' for MGCP 1.0 and 'notSendCancelGraceful' for all other protocols. This object has no relevance when the protocol is SRCP.

↑ To TOC