cmgwIndex
Integer32 (1..2147483647)
An index that uniquely identifies an entry in the cMediaGwTable.
2003-01-30
This MIB module is an extension to CISCO-XGCP-MIB. It defines the parameters related to the following aspects in xGCP protocols: * Default call control parameters in the local media gateway. * Provisioning specific call control profiles which can be associated with the circuits for the call establishment in the circuits.
Download CISCO-XGCP-EXT-MIB.txt Open CISCO-XGCP-EXT-MIB.txt in a new tab
| Name | OID |
|---|---|
| cxeCallCtrlConfigTable | 1.3.6.1.4.1.9.9.325.1.1.1 |
| cxeCallCtrlProfileTable | 1.3.6.1.4.1.9.9.325.1.1.2 |
END OF TOC
1.3.6.1.4.1.9.9.325.1.1.1
Index: cmgwIndex
This table contains objects used for configuring general parameters in call control default to the local media gateway in xGCP protocols.
Integer32 (1..2147483647)
An index that uniquely identifies an entry in the cMediaGwTable.
1.3.6.1.4.1.9.9.325.1.1.1.1.1
Integer32 (0..255)
This object identifies Type Of Service (TOS) field of IP header for the control packet in VoIP application.
1.3.6.1.4.1.9.9.325.1.1.1.1.2
Integer32 (0..255)
This object identifies Type Of Service (TOS) field of IP header for the voice payload packet in VoIP application.
1.3.6.1.4.1.9.9.325.1.1.1.1.3
DtmfRelayMode1 = dtmfRelayDisabled2 = dtmfRelayCisco3 = dtmfRelayNse4 = dtmfRelayOutOfBand5 = dtmfRelayNteGw6 = dtmfRelayNteCa7 = dtmfRelayInband8 = dtmfRelayType3This textual convention defines DTMF (Dual Tone Multi- Frequency) relay mode. There are a number of possible ways to relay DTMF digits over a VoIP/VoATM network: dtmfRelayDisabled - DTMF won't be detected and won't be specially treated. dtmfRelayCisco - DTMF will be sent as Cisco proprietary format in RTP (Real Time Protocol) packet. dtmfRelayNse - DTMF will be sent as NSE (Named Signalled Event) in-band (within RTP audio stream) dtmfRelayOutOfBand - DTMF detection is enabled, but the digits will not be sent on the bearer. dtmfRelayNteGw - DTMF will be sent as NTE (Named Telephony Event) configured in the local gateway. dtmfRelayNteCa - DTMF will be sent as NTE (Named Telephony Event) from the negotiation with call agent. dtmfRelayInband - DTMF will be detected and be transported over VoIP or VoATM network as voice packets. dtmfRelayType3 - DTMF digits will be detected and sent as Type 3 packets.Reference: RFC2833, Section 3: RTP Payload Format for Named Telephone Events · Integer32
This object defines whether the DTMF (Dual Tone, Multi-Frequency) digits need to be transported to the other endpoint via NSE packets in Voice Over IP. The value of this object will be utilized when the call agent does not specify this parameter.
1.3.6.1.4.1.9.9.325.1.1.1.1.4
DtmfCodecType1 = dtmfCodecAll2 = dtmfCodecLowRateDTMF (Dual Tone Multi-Frequency) will be specially handled under the specified codec rates. dtmfCodecAll - DTMF will be specially handled according to the type indicated in DtmfRelayMode under all codec rates. dtmfCodecLowRate - DTMF will be specially handled according to the type indicated in DtmfRelayMode only in lower codec rates (e.g., the rate of G.726, G.728 or G.729). · Integer32
This object identifies DTMF relay codec for VoIP. This object is not applicable if cxeCallCtrlVoIpDtmfRelay is DtmfRelayDisabled.
1.3.6.1.4.1.9.9.325.1.1.1.1.5
DtmfRelayMode1 = dtmfRelayDisabled2 = dtmfRelayCisco3 = dtmfRelayNse4 = dtmfRelayOutOfBand5 = dtmfRelayNteGw6 = dtmfRelayNteCa7 = dtmfRelayInband8 = dtmfRelayType3This textual convention defines DTMF (Dual Tone Multi- Frequency) relay mode. There are a number of possible ways to relay DTMF digits over a VoIP/VoATM network: dtmfRelayDisabled - DTMF won't be detected and won't be specially treated. dtmfRelayCisco - DTMF will be sent as Cisco proprietary format in RTP (Real Time Protocol) packet. dtmfRelayNse - DTMF will be sent as NSE (Named Signalled Event) in-band (within RTP audio stream) dtmfRelayOutOfBand - DTMF detection is enabled, but the digits will not be sent on the bearer. dtmfRelayNteGw - DTMF will be sent as NTE (Named Telephony Event) configured in the local gateway. dtmfRelayNteCa - DTMF will be sent as NTE (Named Telephony Event) from the negotiation with call agent. dtmfRelayInband - DTMF will be detected and be transported over VoIP or VoATM network as voice packets. dtmfRelayType3 - DTMF digits will be detected and sent as Type 3 packets.Reference: RFC2833, Section 3: RTP Payload Format for Named Telephone Events · Integer32
This object defines whether the DTMF (Dual Tone, Multi-Frequency) digits need to be transported to the other endpoint in Voice over AAL2 packets. The value of this object will be utilized when the call agent does not specify this parameter.
1.3.6.1.4.1.9.9.325.1.1.1.1.6
DtmfCodecType1 = dtmfCodecAll2 = dtmfCodecLowRateDTMF (Dual Tone Multi-Frequency) will be specially handled under the specified codec rates. dtmfCodecAll - DTMF will be specially handled according to the type indicated in DtmfRelayMode under all codec rates. dtmfCodecLowRate - DTMF will be specially handled according to the type indicated in DtmfRelayMode only in lower codec rates (e.g., the rate of G.726, G.728 or G.729). · Integer32
This object identifies DTMF relay CODEC for Voice over AAL2. This object is not applicable if cxeCallCtrlVoAal2DtmfRelay is DtmfRelayDisabled.
1.3.6.1.4.1.9.9.325.1.1.1.1.7
Integer32 (0..200)
Reference: RFC2833, 3. RTP Payload Format for Named Telephone Events
This object identifies TSE (Telephony Signaling Events) payload type.
1.3.6.1.4.1.9.9.325.1.1.1.1.8
Integer32 (250..10000) · milliseconds
This object identifies Network Signaling Event (NSE) timeout value.
1.3.6.1.4.1.9.9.325.1.1.1.1.9
Integer32 (1..10) · times
Reference: RFC1889
This object identifies the number of times of Real Time Control Transport (RTCP) report interval if the media gateway has not recieved any RTCP packets from another side. The media gateway will mark another side inactive, or delete it if no RTCP packet has been received for the value of this object times the RTCP report interval.
1.3.6.1.4.1.9.9.325.1.1.1.1.10
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object defines whether to ignore the AAL2 Local Connection Option (LCO) message from the call agent or not.
1.3.6.1.4.1.9.9.325.1.1.1.1.11
INTEGER1 = dmOrderShortest2 = dmOrderOrdered · Integer32
Reference: RFC2705, 2.1.5 Digit Maps
This object defines the type of digit map order. The MGC can advise and load the gateway with a digit map that correspond to the dial plan to collect the access codes, credit card numbers and other numbers requested by call control services.
1.3.6.1.4.1.9.9.325.1.1.1.1.12
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Reference: ITU-T T.38 Procedures for real-time Group 3 facsimile communicating over IP networks
This object defines whether T.38 is inhibited in the media gateway or not. T.38 is a Fax Relay Protocol defined by ITU for real-time protocol for Fax over IP networks.
1.3.6.1.4.1.9.9.325.1.1.1.1.13
Integer32 (250..10000) · milliseconds
This object defines a timeout value for a timer. This timer is started after sending a NSE 200 while waiting for the NSE 201 acknowledgement or NSE 202 negative acknowledgement. Expiration of the timer will indicate that the request for switch to T.38 has been rejected or discarded by the far end. The initial value is 1000 ms and this value can only be set in the increments of 250 ms. This object is not applicable if cxeCallCtrlT38Inhibited is set to 'true'.
1.3.6.1.4.1.9.9.325.1.1.1.1.14
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object is used to enable the Forward Error Correction (FEC) for UDP-based fax transport. This object is not applicable if cxeCallCtrlT38Inhibited is set to 'true'.
1.3.6.1.4.1.9.9.325.1.1.1.1.15
Integer32 (0..5)
Reference: ITU-T T.38 Procedures for real-time Group 3 facsimile communicating over IP networks
This object determines the extent of the Internet Fax Protocol (IFP) packet transmission redundancy for the low-speed control information exchanged during the first phase of a T.38 fax relay connection. Depending on whether Forward Error Correction (FEC) is enabled (cxeCallCtrlT38FecEnabled is set to 'true') or not, this object has different meanings. If FEC is disabled, then this object is the maximum number of prior IFP packets within a Unnumbered Datagram Protocol Transport Layer (UDPTL) packet carrying low speed information, not counting the primary or current IFP packet. If FEC is enabled, then this object is the maximum number of FEC messages within a UDPTL packet carrying low speed information. This object is not applicable if cxeCallCtrlT38Inhibited is set to 'true'.
1.3.6.1.4.1.9.9.325.1.1.1.1.16
Integer32 (0..2)
Reference: ITU-T T.38 Procedures for real-time Group 3 facsimile communicating over IP networks
This object determines the extent of the Internet Fax Protocol (IFP) packet transmission redundancy for the high-speed control and image information exchanged following the initial low-speed phase of a T.38 fax relay connection. Depending on whether forward error correction (FEC) is enabled (cxeCallCtrlT38FecEnabled is set to 'true') or not. If FEC is disabled, then this object is the maximum number of prior IFP packets within a UDPTL packet carrying high speed information, not counting the primary or current IFP packet. If FEC is enabled, then this object is the maximum number of FEC messages within a UDPTL packet carrying high speed information. This object is not applicable if cxeCallCtrlT38Inhibited is set to 'true'.
1.3.6.1.4.1.9.9.325.1.1.1.1.17
CountryCodeITUThis textual convention represents a country or area code for non-standard facilities in telematic services.Reference: ITU-T T.35 - Section 3.1 Country Code (0..255) · Unsigned32
This object specifies the country code for identifying the country where the media gateway with non-standard capabilities was manufactured. This object is not applicable if cxeCallCtrlT38Inhibited is set to 'true'.
1.3.6.1.4.1.9.9.325.1.1.1.1.18
CxeTerminalProviderCodeThis textual convention represents a Terminal Provider Code for non-standard facilities in telematic services. Unrecognized terminal providers are represented as empty string.Reference: ITU-T T.35 - Section 3.2 Terminal Provider Code SIZE (0 | 2) · OCTET STRING
Per its definition (ITU T.35), the Vendor Code (also called the Terminal Provider Code) in the Non-Standard Facilities (NSF) code is a two-byte field identifying the manufacturer of the media gateway with non-standard capabilities. This object is not applicable if cxeCallCtrlT38Inhibited is set to 'true'.
1.3.6.1.4.1.9.9.325.1.1.1.1.19
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object is used to enable or disable VSEL, DSEL and FSEL support. VSEL: Voice codec, packet length and packet times Selection DSEL: Data codec, packet length and packet times Selection FSEL: Fax codec, packet length and packet times Selection If cxeCallCtrlVselDselFselSupport is true, then the media gateway must indicate prefered codec, packet length and packet times for an ATM connection.
1.3.6.1.4.1.9.9.325.1.1.1.1.20
INTEGER1 = ipPvcAal52 = atmPvcAal23 = atmSvcAal24 = atmSvcAal1 · Integer32
This object specifies the combination of the network type (IP/ATM), virtual circuit type (PVC/SVC) and ATM adaptation layer type (AAL1/AAL2/AAL5) for the connection used in transporting bearer traffic. ipPvcAal5 (1) - The bearer traffic is transported in IP network, through Permanent Virtual Circuit(PVC) over AAL5 adaptation layer. atmPvcAal2 (2) - The bearer traffic is transported in ATM network, through Permanent Virtual Circuit(PVC) over AAL2 adaptation layer. atmSvcAal2 (3) - The bearer traffic is transported in ATM network, through Switching Virtual Circuit(SVC) over AAL2 adaptation layer. atmSvcAal1 (4) - The bearer traffic is transported in ATM network, through Switching Virtual Circuit(SVC) over AAL1 adaptation layer. If the call agent specifies the bear traffic type in the MGCP (Media Gateway Control Protocol) local connection options (CRCX request), then configuration of this object will have no effect, else the value of this object will be used when sending CRCX response.
1.3.6.1.4.1.9.9.325.1.1.1.1.21
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object indicates the address type, either IPv4 or IPv6, of cxeCallCtrlLastFailedMgcAddress.
1.3.6.1.4.1.9.9.325.1.1.1.1.22
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This object indicates the address of MGC (Media Gateway Controller) with which the media gateway had tried to communicate lastly but failed.
1.3.6.1.4.1.9.9.325.1.1.2
Index: cmgwIndex · cxeCcProfileIndex
This table defines the call control profiles. A call control profile contains the call control information that a call agent uses to establish a call. In the call control profile, it has the following configurations: (1) The information of call agent, such as its address, connecting port, service type and version. (2) The maximum retry parameters in the message exchange between the call agent and the media gateway. (3) The timeout settings in the call control. A call control profile can be associated with a voice interface (DS0 group in TDM side), so all the calls set up in the voice interface will use the call control parameters from the profile. A call control profile can be associated with a Media Gateway Controller(MGC)/call agent redundant group (cMgcGrpParamTable defined in CISCO-MGC-MIB). In this case, the call agent information for the profile will be determined by the MGC redundant group.
Integer32 (1..2147483647)
An index that uniquely identifies an entry in the cMediaGwTable.
1.3.6.1.4.1.9.9.325.1.1.2.1.1
CCallControlProfileIndexThis textual convention defines the type of index that is used for identifying a call control profile of XGCP and H.248 protocol. (1..65535) · Unsigned32
This object uniquely identifies the call control profile.
1.3.6.1.4.1.9.9.325.1.1.2.1.2
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (1..64) · OCTET STRING · hint 255a
A unique name for the profile. The name of the profile has to be unique among all entries of the table. This object is mandatory during the creation of the entry. This object can not be modified. If users want to modify the name of the call control profile, they have to delete the original entry and create another entry with the designated name.
1.3.6.1.4.1.9.9.325.1.1.2.1.3
Integer32 (0..1000)
This object reprsents the total number of voice interface (DS0 group) associated with this call control profile. The value of '0' means there is no voice interfaces associated with the profile. Before the call control profile can be deleted, this object should have the value of 0 (means all voice interfaces should be de-associated with the profile before the profile can be deleted).
1.3.6.1.4.1.9.9.325.1.1.2.1.4
Integer32 (0..128)
This object indicates which MGC Redundant group number that the call control profile will be used. The value is the index to MGC Redundant Group Table (cMgcGrpParamTable). There are two conditions for associating a MGC group with a profile: 1. At least one MGC is associated with the MGC group 2. At least one protocol is associated with the MGC group After a MGC Redundant Group is associated with the profile (cxeCcProfileMgcGrpNum > 0): In the call setup, the parameters of MGCs within the MGC Redundant Group will be sequentially tried according to its preference. The value of '0' means there is no MGC Redundant Group associated with the profile. This object takes the precedence of object cxeCcProfileMgcAddress of the profile. If users try to set a value to cxeCcProfileMgcAddress while the value of this object is non-zero, the set will be rejected. Before the call control profile can be deleted, this object should have the value of 0. Which means MGC Redundant Group should be de-associated with the profile before the profile can be deleted.
1.3.6.1.4.1.9.9.325.1.1.2.1.5
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object identifies the address type applicable to cxeCcProfileMgcAddress.
1.3.6.1.4.1.9.9.325.1.1.2.1.6
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This object specifies the address of Media Gateway Controller (MGC) configured in the profile. When cxeCcProfileMgcGrpNum is non-zero (which menas using MGC group), this object can not be set.
1.3.6.1.4.1.9.9.325.1.1.2.1.7
Integer32 (1..32)
This object specifies the protocol that the media gateway should communicate with MGC during call setup. It is the index of the protocol table(cMediaGwProtocolTable). If cxeCcProfileMgcGrpNum is non-zero, the value of this object will be ignored. The protocol will be determined by the MGC group.
1.3.6.1.4.1.9.9.325.1.1.2.1.8
CXgcpRetryMethod1 = neverResetTimer2 = resetTimerForNewMgc3 = resetTimerForNewAddr4 = resetTimerForEndpointMethod of resetting retry timer in XGCP. When media gateway re-try to communication to a call agent, the timeout for each re-try is doubled. Example: re-try time is 3 initial timeout is 2 (any unit) maximum possible retry time is 256 MGC group has 2 MGC and each MGC has two IP address timeout for neverResetTimer will be as: MGC 1 IP11: 2 4 8 MGC 1 IP12: 16 32 64 MGC 2 IP21: 128 256 512 MGC 1 IP22: 1024 2048 4096 timeout for resetTimerForNewMgc will be as: MGC 1 IP11: 2 4 8 MGC 1 IP12: 16 32 64 MGC 2 IP21: 2 4 8 MGC 1 IP22: 16 32 64 timeout for resetTimerForNewAddr will be as: MGC 1 IP11: 2 4 8 MGC 1 IP12: 2 4 8 MGC 2 IP21: 2 4 8 MGC 1 IP22: 2 4 8 timeout for resetTimerForEndpoint will be as: MGC 1 IP11: 2 4 8 MGC 1 IP12: 16 32 64 MGC 2 IP21: 128 256 256 MGC 1 IP22: 256 256 256 · Integer32
This object specifies the command/response retry method when the media gateway communicates with the MGC in xGCP protocols.
1.3.6.1.4.1.9.9.325.1.1.2.1.9
Integer32 (1..20)
Reference: Refer to PKT-SP-EC-MGCP-I04-011221 specification Section 3.4.2
This object contains the suspicious error threshold for signaling messages.
1.3.6.1.4.1.9.9.325.1.1.2.1.10
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object enables/disables the Max1 Domain Name Server (DNS) query operation when Max1 expires. This object is used when a gateway-initiated message is not acknowledged by the MGC. If the object is 'true', a DNS query is performed to re-resolve MGC's domain name after exhausting Max1 retries on any IP address associated with the MGC.
1.3.6.1.4.1.9.9.325.1.1.2.1.11
Integer32 (1..20)
Reference: Refer to PKT-SP-EC-MGCP-I04-011221 specification Section 3.4.2
This object contains the disconnect error threshold for signaling messages.
1.3.6.1.4.1.9.9.325.1.1.2.1.12
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object enables/disables the Max2 Domain Name Server (DNS) query operation when Max2 expires. This object is used when a gateway-initiated message is not acknowledged by the MGC. If the object is 'true', a DNS query is performed to re-resolve MGC's domain name after exhausting Max2 retries on the last IP address associated with the MGC.
1.3.6.1.4.1.9.9.325.1.1.2.1.13
Integer32 (1..50) · milliseconds
Reference: GR-506-CORE, section 17.2.3
The timeout value for the message waiting indicator tone. Message Waiting Indicator (MWI) tone is used with message waiting services, it indicates that the media gateway is ready to accept address information or other information from an access line.
1.3.6.1.4.1.9.9.325.1.1.2.1.14
Integer32 (1..1000) · seconds
The timeout value for retransmission removal. The gateway uses the value of this object to determine how long for the MGCP messages stored in the retransmission queue before they are discarded.
1.3.6.1.4.1.9.9.325.1.1.2.1.15
Integer32 (1..100) · seconds
Reference: RFC2705, Section 4.4.7
The voice interface (DS0 group) becomes disconnected when the media gateway tries to communicate with the call agent and the retransmission procedure times out after retrying. The voice interface (DS0 group) in disconnected state starts the disconnected timer initialised to the random value and uniformly distributed between 1 and initial waiting delay (Tdinit) in seconds. The gateway waits for either the expiration of the timer, or the reception of call agent command or the detection of local user activity for the voice interface (DS0 group). When the disconnected timer elapses, or when a command is received from the call agent or when there is a local user activity, the media gateway sends the Restart In Progress command with the restart method as RM:disconnected to the call agent.
1.3.6.1.4.1.9.9.325.1.1.2.1.17
Integer32 (1..100) · seconds
Reference: RFC2705, Section 4.4.7
The DS0 group (voice interface) becomes disconnected when it tries to communicate with the call agent and the retransmission procedure times out after retrying. The DS0 group (voice interface ) in disconnected state starts the disconnected timer initialised to the random value and uniformly distributed between 1 and initial waiting delay (Tdinit) in seconds. The gateway waits for either the end of this timer, or the reception of call agent command or the detection of local user activity for the DS0 group(voice interface). When the disconnected timer elapses, or when a command is received from the call agent or when there is a local user activity, the Voice Gateway sends the Restart In Progress command with the restart method as RM:disconnected to the call agent. In case of local user activity, a provisionable disconnected minimum waiting delay (Tdmin) must have been elapsed since the gateway became disconnected. The minimum waiting delay (Tdmin) timeout value used by the voice Gateway to send the Restart In Progress with the restart method as RM:disconnected to the call agent if there is any local user activity is defined by this object. Media gateway initiated delete connection (DLCX) or restart in progress (RSIP) commands are not considered as local user activity. The events observed on the TDM interface or on the network constitute the local user activity.
1.3.6.1.4.1.9.9.325.1.1.2.1.18
Integer32 (1..1000) · seconds
Reference: RFC2705, Section 4.4.7
The maximum waiting delay (Tdmax) timeout value used by the media gateway to send the Restart In Progress with the restart method as RM:disconnected to the call agent when the voice interface associated ds0-group disconnection condition occurs. The DS0 group (voice interface) becomes disconnected when it tries to communicate with the call agent and the retransmission procedure times out after retrying. The DS0 group (voice interface) in disconnected state starts the disconnected timer initialised to the random value and uniformly distributed between 1 and initial waiting delay (Tdinit) in seconds. The gateway waits for either the expiration of the timer, or the reception of call agent command or the detection of local user activity for the DS0 group (voice interface). When the disconnected timer elapses, or when a command is received from the call agent or when there is a local user activity, the media gateway sends the Restart In Progress command with the restart method as RM:disconnected to the call agent. If the disconnected procedure still left the DS0 group (voice interface) disconnected, the disconnected timer is doubled subject to a provisionable disconnected maximum waiting delay (Tdmax) in seconds and the gateway starts the new disconnected procedure again. Once the maximum value is reached, the subsequent disconnected Restart In Progress commands use the maximum waiting delay (Tdmax).
1.3.6.1.4.1.9.9.325.1.1.2.1.19
Integer32 (1..1000) · seconds
Reference: RFC2705, Section 4.4.7
This object represents the timeout value for the critical timer. If used along with a digit map, the timer is started when the last digit is received. i.e and when no more digits are required for a digit map match. After this timer expires, the digit map match is assumed to be complete. If used without a digit map, the timer is started immediately and cancelled (but not restarted) as soon as a digit is entered. This object is used by call processing when it processes mid-call DTMF digit reporting.
1.3.6.1.4.1.9.9.325.1.1.2.1.20
Integer32 (1..1000) · seconds
Reference: RFC2705, Section 4.4.7
This object represents the partial dial timeout and is used along with a digit map as the inter-digit timer. This object is used by call processing when it processes mid-call DTMF digit reporting. The timer is not started until the first digit is entered, and the timer is restarted after each new digit is entered untill either a digit map match or mismatch occurs.
1.3.6.1.4.1.9.9.325.1.1.2.1.21
Integer32 (1..1000) · seconds
Reference: RFC2705, Section 4.4.7
The MGCP protocol is organized as set of transactions, each of which is composed of a command and a resonse. The MGCP messages, being carried over UDP, may be subject to losses. In the absence of a timely response, commands are repeated. The media gateway must keep in memory a list of the responses that it sent to recent transactions, and a list of the transactions that are currently being executed. Recent is here defined by the value of cxeCcProfileThistTimeout that specifies the number of seconds that responses to old transactions must be kept for.
1.3.6.1.4.1.9.9.325.1.1.2.1.22
Integer32 (0..3600) · seconds
Reference: RFC2705, Section 6 Event Packages
This object specifies time for which the local ring back tone (towards the TDM) will be generated unless interrupted (e.g., by the answer from the called party or a delete connection command from the Call Agent). The value of '0' indicates that the tone will be generated indefinitely unless interrupted.
1.3.6.1.4.1.9.9.325.1.1.2.1.23
Integer32 (0..3600) · seconds
Reference: RFC2705, Section 6 Event Packages
This object specifies time for which the remote ring back tone (towards the packet network) will be generated unless interrupted (e.g., by the answer from the called party or a delete connection command from the Call Agent). The value of '0' indicates that the tone will be generated indefinitely unless interrupted.
1.3.6.1.4.1.9.9.325.1.1.2.1.24
Integer32 (0..3600) · seconds
Reference: RFC2705, Section 6 Event Packages
This object specifies time for network congestion tone will be generated. The network congestion tone will be generated when the network resources or bandwidth exceed their threholds. The value of '0' indicates that the tone will be generated indefinitely unless interrupted.
1.3.6.1.4.1.9.9.325.1.1.2.1.25
Integer32 (0..3600) · seconds
Reference: RFC2705, Section 6 Event Packages
This object specifies time for which the busy tone will be generated unless interrupted (e.g., by the hangup from the calling party). The value of '0' indicates that the tone will be generated indefinitely unless interrupted.
1.3.6.1.4.1.9.9.325.1.1.2.1.26
Integer32 (0..3600) · seconds
Reference: RFC2705, Section 6 Event Packages
This object specifies time for which the dial tone will be generated unless interrupted (e.g., by the first DTMF digit from the calling party). The value of '0' indicates that the tone will be generated indefinitely unless interrupted.
1.3.6.1.4.1.9.9.325.1.1.2.1.27
Integer32 (0..3600) · seconds
Reference: RFC2705, Section 6 Event Packages
This object specifies time for which the stutter dial tone or confirmation dial tone will be generated unless interrupted (e.g., by the first DTMF digit from the calling party). The value of '0' indicates that the tone will be generated indefinitely unless interrupted.
1.3.6.1.4.1.9.9.325.1.1.2.1.28
Integer32 (0..3600) · seconds
Reference: RFC2705, Section 6 Event Packages
This object specifies time for which the ringing cadence will be generated towards the basic PBX unless interrupted (e.g., by the answer from the called party or a delete connection command from the Call Agent). This is also the time for which remote inband ring back tone will be played towards the packet network. The value of '0' indicates that the cadence will be generated indefinitely unless interrupted.
1.3.6.1.4.1.9.9.325.1.1.2.1.29
Integer32 (0..3600) · seconds
Reference: RFC2705, Section 6 Event Packages
This object specifies time for which the reorder tone or fast busy tone will be generated unless interrupted (e.g., by the hangup from the called party). The value of '0' indicates that the cadence will be generated indefinitely unless interrupted.
1.3.6.1.4.1.9.9.325.1.1.2.1.30
Integer32 (0..100) · seconds
Reference: RFC2705, Section 6 Event Packages
This object specifies time for which the continuity test tone 1 will be generated unless interrupted. The value of '0' indicates that the cadence will be generated indefinitely unless interrupted.
1.3.6.1.4.1.9.9.325.1.1.2.1.31
Integer32 (0..100) · seconds
Reference: RFC2705, Section 6 Event Packages
This object specifies time for which the continuity test tone 2 will be generated unless interrupted. The value of '0' indicates that the cadence will be generated indefinitely unless interrupted.
1.3.6.1.4.1.9.9.325.1.1.2.1.32
RowStatus1 = active2 = notInService3 = notReady4 = createAndGo5 = createAndWait6 = destroyThe RowStatus textual convention is used to manage the creation and deletion of conceptual rows, and is used as the value of the SYNTAX clause for the status column of a conceptual row (as described in Section 7.7.1 of [2].) The status column has six defined values: - `active', which indicates that the conceptual row is available for use by the managed device; - `notInService', which indicates that the conceptual row exists in the agent, but is unavailable for use by the managed device (see NOTE below); 'notInService' has no implication regarding the internal consistency of the row, availability of resources, or consistency with the current state of the managed device; - `notReady', which indicates that the conceptual row exists in the agent, but is missing information necessary in order to be available for use by the managed device (i.e., one or more required columns in the conceptual row have not been instanciated); - `createAndGo', which is supplied by a management station wishing to create a new instance of a conceptual row and to have its status automatically set to active, making it available for use by the managed device; - `createAndWait', which is supplied by a management station wishing to create a new instance of a conceptual row (but not make it available for use by the managed device); and, - `destroy', which is supplied by a management station wishing to delete all of the instances associated with an existing conceptual row. Whereas five of the six values (all except `notReady') may be specified in a management protocol set operation, only three values will be returned in response to a management protocol retrieval operation: `notReady', `notInService' or `active'. That is, when queried, an existing conceptual row has only three states: it is either available for use by the managed device (the status column has value `active'); it is not available for use by the managed device, though the agent has sufficient information to attempt to make it so (the status column has value `notInService'); or, it is not available for use by the managed device, and an attempt to make it so would fail because the agent has insufficient information (the state column has value `notReady'). NOTE WELL This textual convention may be used for a MIB table, irrespective of whether the values of that table's conceptual rows are able to be modified while it is active, or whether its conceptual rows must be taken out of service in order to be modified. That is, it is the responsibility of the DESCRIPTION clause of the status column to specify whether the status column must not be `active' in order for the value of some other column of the same conceptual row to be modified. If such a specification is made, affected columns may be changed by an SNMP set PDU if the RowStatus would not be equal to `active' either immediately before or after processing the PDU. In other words, if the PDU also contained a varbind that would change the RowStatus value, the column in question may be changed if the RowStatus was not equal to `active' as the PDU was received, or if the varbind sets the status to a value other than 'active'. Also note that whenever any elements of a row exist, the RowStatus column must also exist. To summarize the effect of having a conceptual row with a status column having a SYNTAX clause value of RowStatus, consider the following state diagram: STATE +--------------+-----------+-------------+------------- | A | B | C | D | |status col.|status column| |status column | is | is |status column ACTION |does not exist| notReady | notInService| is active --------------+--------------+-----------+-------------+------------- set status |noError ->D|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndGo |inconsistent- | | | | Value| | | --------------+--------------+-----------+-------------+------------- set status |noError see 1|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndWait |wrongValue | | | --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError column to | Value| entValue| | active | | | | | | or | | | | | | | |see 2 ->D|see 8 ->D| ->D --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError ->C column to | Value| entValue| | notInService | | | | | | or | | or | | | | | |see 3 ->C| ->C|see 6 --------------+--------------+-----------+-------------+------------- set status |noError |noError |noError |noError ->A column to | | | | or destroy | ->A| ->A| ->A|see 7 --------------+--------------+-----------+-------------+------------- set any other |see 4 |noError |noError |see 5 column to some| | | | value | | see 1| ->C| ->D --------------+--------------+-----------+-------------+------------- (1) goto B or C, depending on information available to the agent. (2) if other variable bindings included in the same PDU, provide values for all columns which are missing but required, and all columns have acceptable values, then return noError and goto D. (3) if other variable bindings included in the same PDU, provide legal values for all columns which are missing but required, then return noError and goto C. (4) at the discretion of the agent, the return value may be either: inconsistentName: because the agent does not choose to create such an instance when the corresponding RowStatus instance does not exist, or inconsistentValue: if the supplied value is inconsistent with the state of some other MIB object's value, or noError: because the agent chooses to create the instance. If noError is returned, then the instance of the status column must also be created, and the new state is B or C, depending on the information available to the agent. If inconsistentName or inconsistentValue is returned, the row remains in state A. (5) depending on the MIB definition for the column/table, either noError or inconsistentValue may be returned. (6) the return value can indicate one of the following errors: wrongValue: because the agent does not support notInService (e.g., an agent which does not support createAndWait), or inconsistentValue: because the agent is unable to take the row out of service at this time, perhaps because it is in use and cannot be de-activated. (7) the return value can indicate the following error: inconsistentValue: because the agent is unable to remove the row at this time, perhaps because it is in use and cannot be de-activated. (8) the transition to D can fail, e.g., if the values of the conceptual row are inconsistent, then the error code would be inconsistentValue. NOTE: Other processing of (this and other varbinds of) the set request may result in a response other than noError being returned, e.g., wrongValue, noCreation, etc. Conceptual Row Creation There are four potential interactions when creating a conceptual row: selecting an instance-identifier which is not in use; creating the conceptual row; initializing any objects for which the agent does not supply a default; and, making the conceptual row available for use by the managed device. Interaction 1: Selecting an Instance-Identifier The algorithm used to select an instance-identifier varies for each conceptual row. In some cases, the instance- identifier is semantically significant, e.g., the destination address of a route, and a management station selects the instance-identifier according to the semantics. In other cases, the instance-identifier is used solely to distinguish conceptual rows, and a management station without specific knowledge of the conceptual row might examine the instances present in order to determine an unused instance-identifier. (This approach may be used, but it is often highly sub-optimal; however, it is also a questionable practice for a naive management station to attempt conceptual row creation.) Alternately, the MIB module which defines the conceptual row might provide one or more objects which provide assistance in determining an unused instance-identifier. For example, if the conceptual row is indexed by an integer-value, then an object having an integer-valued SYNTAX clause might be defined for such a purpose, allowing a management station to issue a management protocol retrieval operation. In order to avoid unnecessary collisions between competing management stations, `adjacent' retrievals of this object should be different. Finally, the management station could select a pseudo-random number to use as the index. In the event that this index was already in use and an inconsistentValue was returned in response to the management protocol set operation, the management station should simply select a new pseudo-random number and retry the operation. A MIB designer should choose between the two latter algorithms based on the size of the table (and therefore the efficiency of each algorithm). For tables in which a large number of entries are expected, it is recommended that a MIB object be defined that returns an acceptable index for creation. For tables with small numbers of entries, it is recommended that the latter pseudo-random index mechanism be used. Interaction 2: Creating the Conceptual Row Once an unused instance-identifier has been selected, the management station determines if it wishes to create and activate the conceptual row in one transaction or in a negotiated set of interactions. Interaction 2a: Creating and Activating the Conceptual Row The management station must first determine the column requirements, i.e., it must determine those columns for which it must or must not provide values. Depending on the complexity of the table and the management station's knowledge of the agent's capabilities, this determination can be made locally by the management station. Alternately, the management station issues a management protocol get operation to examine all columns in the conceptual row that it wishes to create. In response, for each column, there are three possible outcomes: - a value is returned, indicating that some other management station has already created this conceptual row. We return to interaction 1. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it should supply a value for this column when the conceptual row is to be created. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. Once the column requirements have been determined, a management protocol set operation is accordingly issued. This operation also sets the new instance of the status column to `createAndGo'. When the agent processes the set operation, it verifies that it has sufficient information to make the conceptual row available for use by the managed device. The information available to the agent is provided by two sources: the management protocol set operation which creates the conceptual row, and, implementation-specific defaults supplied by the agent (note that an agent must provide implementation-specific defaults for at least those objects which it implements as read-only). If there is sufficient information available, then the conceptual row is created, a `noError' response is returned, the status column is set to `active', and no further interactions are necessary (i.e., interactions 3 and 4 are skipped). If there is insufficient information, then the conceptual row is not created, and the set operation fails with an error of `inconsistentValue'. On this error, the management station can issue a management protocol retrieval operation to determine if this was because it failed to specify a value for a required column, or, because the selected instance of the status column already existed. In the latter case, we return to interaction 1. In the former case, the management station can re-issue the set operation with the additional information, or begin interaction 2 again using `createAndWait' in order to negotiate creation of the conceptual row. NOTE WELL Regardless of the method used to determine the column requirements, it is possible that the management station might deem a column necessary when, in fact, the agent will not allow that particular columnar instance to be created or written. In this case, the management protocol set operation will fail with an error such as `noCreation' or `notWritable'. In this case, the management station decides whether it needs to be able to set a value for that particular columnar instance. If not, the management station re-issues the management protocol set operation, but without setting a value for that particular columnar instance; otherwise, the management station aborts the row creation algorithm. Interaction 2b: Negotiating the Creation of the Conceptual Row The management station issues a management protocol set operation which sets the desired instance of the status column to `createAndWait'. If the agent is unwilling to process a request of this sort, the set operation fails with an error of `wrongValue'. (As a consequence, such an agent must be prepared to accept a single management protocol set operation, i.e., interaction 2a above, containing all of the columns indicated by its column requirements.) Otherwise, the conceptual row is created, a `noError' response is returned, and the status column is immediately set to either `notInService' or `notReady', depending on whether it has sufficient information to (attempt to) make the conceptual row available for use by the managed device. If there is sufficient information available, then the status column is set to `notInService'; otherwise, if there is insufficient information, then the status column is set to `notReady'. Regardless, we proceed to interaction 3. Interaction 3: Initializing non-defaulted Objects The management station must now determine the column requirements. It issues a management protocol get operation to examine all columns in the created conceptual row. In the response, for each column, there are three possible outcomes: - a value is returned, indicating that the agent implements the object-type associated with this column and had sufficient information to provide a value. For those columns to which the agent provides read-create access (and for which the agent allows their values to be changed after their creation), a value return tells the management station that it may issue additional management protocol set operations, if it desires, in order to change the value associated with this column. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. However, the agent does not have sufficient information to provide a value, and until a value is provided, the conceptual row may not be made available for use by the managed device. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it must issue additional management protocol set operations, in order to provide a value associated with this column. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. If the value associated with the status column is `notReady', then the management station must first deal with all `noSuchInstance' columns, if any. Having done so, the value of the status column becomes `notInService', and we proceed to interaction 4. Interaction 4: Making the Conceptual Row Available Once the management station is satisfied with the values associated with the columns of the conceptual row, it issues a management protocol set operation to set the status column to `active'. If the agent has sufficient information to make the conceptual row available for use by the managed device, the management protocol set operation succeeds (a `noError' response is returned). Otherwise, the management protocol set operation fails with an error of `inconsistentValue'. NOTE WELL A conceptual row having a status column with value `notInService' or `notReady' is unavailable to the managed device. As such, it is possible for the managed device to create its own instances during the time between the management protocol set operation which sets the status column to `createAndWait' and the management protocol set operation which sets the status column to `active'. In this case, when the management protocol set operation is issued to set the status column to `active', the values held in the agent supersede those used by the managed device. If the management station is prevented from setting the status column to `active' (e.g., due to management station or network failure) the conceptual row will be left in the `notInService' or `notReady' state, consuming resources indefinitely. The agent must detect conceptual rows that have been in either state for an abnormally long period of time and remove them. It is the responsibility of the DESCRIPTION clause of the status column to indicate what an abnormally long period of time would be. This period of time should be long enough to allow for human response time (including `think time') between the creation of the conceptual row and the setting of the status to `active'. In the absence of such information in the DESCRIPTION clause, it is suggested that this period be approximately 5 minutes in length. This removal action applies not only to newly-created rows, but also to previously active rows which are set to, and left in, the notInService state for a prolonged period exceeding that which is considered normal for such a conceptual row. Conceptual Row Suspension When a conceptual row is `active', the management station may issue a management protocol set operation which sets the instance of the status column to `notInService'. If the agent is unwilling to do so, the set operation fails with an error of `wrongValue' or `inconsistentValue'. Otherwise, the conceptual row is taken out of service, and a `noError' response is returned. It is the responsibility of the DESCRIPTION clause of the status column to indicate under what circumstances the status column should be taken out of service (e.g., in order for the value of some other column of the same conceptual row to be modified). Conceptual Row Deletion For deletion of conceptual rows, a management protocol set operation is issued which sets the instance of the status column to `destroy'. This request may be made regardless of the current value of the status column (e.g., it is possible to delete conceptual rows which are either `notReady', `notInService' or `active'.) If the operation succeeds, then all instances associated with the conceptual row are immediately removed. · Integer32
This object is used by users for adding/deleting an entry from the table. The entry can't be deleted if the value of cxeCcProfileNumVifs is greater than zero or the value of cxeCcProfileMgcGrpNum is greater than zero.