EZ5 MIB Catalog

CISCO-XGCP-MIB

2006-02-21

This MIB is an enhancement for existing XGCP-MIB. xGCP is a set of protocols, for example SGCP (Simple Gateway Control Protocol) and MGCP (Media Gateway Control Protocol), which are designed as a control protocol within a distributed system that appears to the outside as a single VoIP/VoATM gateway. This system is composed of a call agent (or MGC, Media Gateway Controller) and of a set of 'media gateways' that perform the conversion of media signals between circuits and packets. In the xGCP model, the gateways focus on the audio signal translation function, while the call agent handles the signaling and call processing functions. Examples of Gateway Control Protocols are: * Simple Gateway Control Protocol (SGCP) * Media Gateway Control Protocol (MGCP) xGCP assumes a connection model where the basic constructs are: Endpoints : sources or sinks of data that could be physical or virtual. Connections : an association between two or more endpoints with the purpose of transmitting data between these endpoints. Once this association is established for both endpoints, data transfer between these endpoints can take place. Connections are grouped in calls. One or more connections can belong to one call. Connections and calls are set up at the initiative of one or several call agents. Terminologies used: AAL : ATM Adaptation Layer AUCX : Audit Connection Command used by the MGC to find out the status of a given gateway connection. AUEP : Audit Endpoint Command used by the MGC to find out the status of a given endpoint. CCAPI : Call Control Application Program Interface. CID : Channel Identifier CRCX : Connection Command from a MGC to request the gateway MG : Media Gateway MGC : Media Gateway Controller DLCX : Delete Command. This command can be initiated by either the MGC or gateway. GSM : Global System for Mobile Communications GW : Gateway. HP : Hairpin MDCX : Modify Connection Command from a MGC to request the gateway NSE : Negative Stuffing Event NTFY : A Notify Command sent from a gateway to a MGC in response to a RQNT command. PSTN : Public Switched Telephone Network RQNT : Request To Nofity Command from a MGC to request the gateway to provide a notification for configuration changes. RSIP : Restart in Progress Command. This command can be initiated by either the MGC or gateway. SPRT : Simple Packet Relay Transport SSE : Silicon Switching Engine TDM : Time Division Multiplexing TGW : Target Gateway TWC : Three Way Calling VCCI : Virtual Circuit Connection Identifier VMG : Virtual Media Gateway. It is a logical representation of a module (or a set of modules) that has MG functionality. There could be multiple VMGs in a device. VoAAL2 : Voice over AAL2

Download CISCO-XGCP-MIB.txt Open CISCO-XGCP-MIB.txt in a new tab

TABLES (5)

Tables (5)

NameOID
cXgcpMgcConfigTable1.3.6.1.4.1.9.9.318.1.1.1
cXgcpMediaGwTable1.3.6.1.4.1.9.9.318.1.2.1
cXgcpMsgStatsTable1.3.6.1.4.1.9.9.318.1.3.1
cXgcpStatsTable1.3.6.1.4.1.9.9.318.1.3.2
cXgcpConnectionTable1.3.6.1.4.1.9.9.318.1.4.1

END OF TOC

Table details

cXgcpMgcConfigTable

1.3.6.1.4.1.9.9.318.1.1.1

Index: cmgwIndex

This is a table which is used to provision a MGC or MGC group for a MG. Each entry corresponds to a MGC or a MGC group for a single MG.

from CISCO-MEDIA-GATEWAY-MIB

cmgwIndex

Integer32 (1..2147483647)

An index that uniquely identifies an entry in the cMediaGwTable.

cXgcpMgcConfigMgcGrpNum

1.3.6.1.4.1.9.9.318.1.1.1.1.1

CMgcGroupIndexOrZeroThis textual convention is used to indicate association between profile or gateway and MGC group. The value, greater than zero which is used to identify index of MGC group (same as CMgcGroupIndex) which is associated with profile or gateway. The mapping between MGC group and profile or gateway is 1 to N. The value, equal to zero which means there is no association between profile or gateway and MGC group. (0..12) · Integer32 · hint d

This object specifies which MGC Redundant Group will be used in XGCP. The value of this object refers to the object cMgcGrpIndex from MGC Redundant Group Table, cMgcGrpParamTable. There are two conditions to associate a MGC group: 1. At least one MGC is associated with the MGC group 2. At least one protocol is associated with the MGC group If the value of the object is non-zero, it means the media gateway has a MGC Redundant Group. In the call setup, the parameters of call agents within the MGC Redundant Group will be sequentially tried according to its preference. This object cXgcpMgcConfigMgcGrpNum and object cXgcpMgcConfigAddress are mutually exclusive. The object cXgcpMgcConfigAddress can be set only when the object cXgcpMgcConfigMgcGrpNum is equal to 0. If the value of the object is 0, which means there is no MGC Redundant Group associated with the media gateway. It has only one call agent (in media gateway level) to communicate with. This call agent is indicated by cXgcpMgcConfigAddress and will be used in call setup (if call set-up on media gateway level).

cXgcpMgcConfigAddrType

1.3.6.1.4.1.9.9.318.1.1.1.1.2

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object specifies the address type of the MGC (object cXgcpMgcConfigAddress), either ipv4 or ipv6.

cXgcpMgcConfigAddress

1.3.6.1.4.1.9.9.318.1.1.1.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object specifies the address of the MGC the gateway used to communicate with in call setup. This object cXgcpMgcConfigAddress and object cXgcpMgcConfigMgcGrpNum are mutually exclusive. The object cXgcpMgcConfigAddress can be set only when the object cXgcpMgcConfigMgcGrpNum is equal to 0. Otherwise, the SET will be rejected with error.

cXgcpMgcConfigProtocolIndex

1.3.6.1.4.1.9.9.318.1.1.1.1.4

Integer32 (1..32)

This object specifies which protocol that the MG should use to communicate with the MGC when it try to set up the call. The value of this object is the same as the value of object cMediaGwProtocolIndex from protocol table (cMediaGwProtocolTable). If the value of cXgcpMgcConfigMgcGrpNum is non-zero, this object will be ignored because the protocol will be determined by the MGC group. The initial value is 1, means the system should have at least one default protocol between the gateway and the MGC created in the cMeidaGwProtocolTable when the system is initialized.

cXgcpMgcConfigGatewayUdpPort

1.3.6.1.4.1.9.9.318.1.1.1.1.5

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : Section 3.6 Transmission over UDP

The UDP port of the MG which is used to communicate with call agent in MGCP.

cXgcpMediaGwTable

1.3.6.1.4.1.9.9.318.1.2.1

Index: cmgwIndex

This table is used to provision xGCP configuration in a MG.

from CISCO-MEDIA-GATEWAY-MIB

cmgwIndex

Integer32 (1..2147483647)

An index that uniquely identifies an entry in the cMediaGwTable.

cXgcpMediaGwRequestTimeOut

1.3.6.1.4.1.9.9.318.1.2.1.1.1

Integer32 (1..10000) · milliseconds

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : Section 3.6.3 Computing retransmission timers

The request timeout is the period that the XGCP protocol waits before retransmitting an unacknowledged message. It is the responsibility of the requesting entity to provide suitable timeouts for all outstanding commands, and to retry commands when timeouts exceeded.

cXgcpMediaGwRequestRetries

1.3.6.1.4.1.9.9.318.1.2.1.1.2

Integer32 (0..10) · times

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : Section 2.1.4 Names of Call Agents and other entities

This object specifies the number of retries for a request that exceeds timeout without acknowledge before it tries to connect to another MGC.

cXgcpMediaGwRequestRetryMethod

1.3.6.1.4.1.9.9.318.1.2.1.1.3

CXgcpRetryMethod1 = neverResetTimer2 = resetTimerForNewMgc3 = resetTimerForNewAddr4 = resetTimerForEndpointMethod of resetting retry timer in XGCP. When media gateway re-try to communication to a call agent, the timeout for each re-try is doubled. Example: re-try time is 3 initial timeout is 2 (any unit) maximum possible retry time is 256 MGC group has 2 MGC and each MGC has two IP address timeout for neverResetTimer will be as: MGC 1 IP11: 2 4 8 MGC 1 IP12: 16 32 64 MGC 2 IP21: 128 256 512 MGC 1 IP22: 1024 2048 4096 timeout for resetTimerForNewMgc will be as: MGC 1 IP11: 2 4 8 MGC 1 IP12: 16 32 64 MGC 2 IP21: 2 4 8 MGC 1 IP22: 16 32 64 timeout for resetTimerForNewAddr will be as: MGC 1 IP11: 2 4 8 MGC 1 IP12: 2 4 8 MGC 2 IP21: 2 4 8 MGC 1 IP22: 2 4 8 timeout for resetTimerForEndpoint will be as: MGC 1 IP11: 2 4 8 MGC 1 IP12: 16 32 64 MGC 2 IP21: 128 256 256 MGC 1 IP22: 256 256 256 · Integer32

This object specifies command retry method.

cXgcpMediaGwMaxExpTimeout

1.3.6.1.4.1.9.9.318.1.2.1.1.4

Integer32 (1..60000) · milliseconds

This object specifies the maximum timeout for exponential command retry by the media gateway.

cXgcpMediaGwRestartMwd

1.3.6.1.4.1.9.9.318.1.2.1.1.5

Integer32 (0..600000) · milliseconds

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : Section 4.3.4 Fighting the restart avalanche

The maximum waiting delay (MWD) timeout value is used for the media gateway to send the first Restart In Progress to the MGC. When a gateway is powered on, it should initiate a restart timer to a random value, uniformly distributed between 0 and a maximum waiting delay (MWD). The gateway should send the first RSIP message when the timer expires. The initial value of this object is chosen in an implementation-dependent manner by the MGCP functionality based on the call volume of the system.

cXgcpMediaGwRestartDelay

1.3.6.1.4.1.9.9.318.1.2.1.1.6

Integer32 (0..600) · seconds

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : Section 4.3.4 Fighting the restart avalanche

This object specifies the Restart Delay Timeout for the restart process for a gateway to send out RestartInProgress when it is powered on or been reset. The purpose of setting the Restart Delay timer before sending the RestartInProgress notification to the media gateway controller is to avoid the network congestion during the critical period of service restoration.

cXgcpMediaGwDefaultPackage

1.3.6.1.4.1.9.9.318.1.2.1.1.7

INTEGER1 = packageDC2 = packageG3 = packageD4 = packageM5 = packageT6 = packageL7 = packageH8 = packageR9 = packageN10 = packageA11 = packageS12 = packageATM13 = packageMS14 = packageDT15 = packageMO16 = packageRES17 = packageSASDI18 = packageIT19 = packageMT20 = packageB21 = packageSST22 = packageMDR23 = packageFXR24 = packageBA25 = packageMD26 = packageNAS27 = packageMDSTE28 = packagePRE29 = packageLCS30 = packageSRTP31 = packageFM · Integer32

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : 6.1. Basic packages

This object represents the default capability package supported in the gateway. packageDC ( 1) - Don't Care package packageG ( 2) - Generic package packageD ( 3) - DTMF package packageM ( 4) - MF package packageT ( 5) - Trunk package packageL ( 6) - Line package packageH ( 7) - Handset package packageR ( 8) - RTP package packageN ( 9) - NAS package packageA (l0) - Announcement Server package packageS (11) - Script package packageATM (12) - ATM package packageMS (13) - MF CAS package packageDT (14) - DTMF CAS package packageMO (15) - MO package packageRES (16) - RES package packageSASDI(17) - ASDI package (S) NCS packageIT (18) - IT package (S) TGCP packageMT (19) - MT package packageB (20) - B package packageSST (21) - SST package packageMDR (22) - MDR package packageFXR (23) - FAX package packageBA (24) - Bulk Audit package packageMD (25) - MD package packageNAS (26) - Network Access Server package packageMDSTE(27) - Modem relay Secure Telephone Equipment package packagePRE (28) - PRE package packageLCS (29) - MGCP Line Control Signaling package packageSRTP (30) - Secure RTP package packageFM (31) - Media Format Package

cXgcpMediaGwSupportedPackages

1.3.6.1.4.1.9.9.318.1.2.1.1.8

BITS

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : 6.1. Basic packages

This object represents the bit map of MGCP supported packages. Bit 0 - Not Found Bit 1 - Package DC (Don't care package) Bit 2 - Package G (Generic package) Bit 3 - Package D (DTMF package) Bit 4 - Package M (MF package) Bit 5 - Package T (Trunk package) Bit 6 - Package L (Line package) Bit 7 - Package H (Handset package) Bit 8 - Package R (RTP package) Bit 9 - Package N (NAS package) Bit 10 - Package A (Announcement Server package) Bit 11 - Package S (Script package) Bit 12 - Package ATM (ATM package) Bit 13 - Package MS (MF CAS package) Bit 14 - Package DT (DTMF CAS package) Bit 15 - Package MO (MO package) Bit 16 - Package RES (RES package) Bit 17 - Package S_ASDI (ASDI package (S) NCS) Bit 18 - Package IT (IT package (S) TGCP) Bit 19 - Package MT (MT package) Bit 20 - Package B (B package) Bit 21 - Package SST (SST package) Bit 22 - Package MDR (MDR package) Bit 23 - Package FXR (FAX package) Bit 24 - Package BA (Bulk Audit package) Bit 25 - Package MD (MD package) Bit 26 - Package NAS (Network Access Server package) Bit 27 - Package MDSTE (Modem relay Secure Telephone Equipment package) Bit 28 - Package PRE (PRE package) Bit 29 - Package LCS (MGCP Line Control Signaling package) Bit 33 - Package SRTP (Secure RTP package) Bit 31 - Package FM (Media Format Package) The value 0 means there is no supported packages.

cXgcpMediaGwSimpleSdpEnabled

1.3.6.1.4.1.9.9.318.1.2.1.1.9

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object is used to enable/disable building of s, t, o lines in SDP message. where o field indicates the owner/creator and session identifier s field indicates the session name t field indicates the duration while a session is valid. If this object is set to 'true'(enabled), SDP will NOT include the fields s, t, and o. If this object is set to 'false', then it indicates that the o, s, t lines be built before sending SDP (Session Description Protocol).

cXgcpMediaGwAckSdpEnabled

1.3.6.1.4.1.9.9.318.1.2.1.1.10

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies the ACK SDP is enabled or not. If this object is set to 'true', then it sends ADP with ACK when CODEC or reportable NTE delta changed, or an attempt is made to change CODEC, VAD, Packet-period, echo cancellation during FAX/modem mode.

cXgcpMediaGwUndottedNotation

1.3.6.1.4.1.9.9.318.1.2.1.1.11

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object enables/disables the undotted notation for CODEC. This object is used to set CODEC notation to 'dotted' or 'undotted' in SDP between the gateway and the call agent. For example, 'G.726' is 'dotted', while 'G726' is 'undotted'. If it is set to 'true', then the 'undotted' notation for CODEC is enabled.

cXgcpMediaGwQuarantineProcess

1.3.6.1.4.1.9.9.318.1.2.1.1.12

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : Section 3.2.2.12. QuarantineHandling

This object is used to determine how to handle persistent events. If this object is set to 'true', the quarantined events should be processed, otherwise the quarantined events is discarded.

cXgcpMediaGwQuarantineLoop

1.3.6.1.4.1.9.9.318.1.2.1.1.13

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : Section 2.3.2. NotificationRequest

This object controls the default quarantine mode. If this object is set to 'true', the default quarantine mode is 'loop', not 'step'. When this object is set to 'true', the gateway is expected to generate multiple notifications (loop), not at most one notification (step by step), in response to quarantined events. This object will be ignored if the object cXgcpMediaGwQuarantineProcess is set to 'false'.

cXgcpMediaGwQuarantinePersist

1.3.6.1.4.1.9.9.318.1.2.1.1.14

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : Section 2.3.2. NotificationRequest

This object specifies how the persist events will be handled in quarantine processing. If this object is set to 'true', the persistent events bypass quarantine buffer. This object will be ignored if the object cXgcpMediaGwQuarantineProcess is set to 'false'.

cXgcpMediaGwPiggybackMsg

1.3.6.1.4.1.9.9.318.1.2.1.1.15

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : Section 3.6.4. Piggy backing

This object enables/disables the piggyback message generating. If the piggyback message generating is enabled, a call agent can send several MGCP messages in the same UDP packets to the gateway.

cXgcpMediaGwMaxMsgSize

1.3.6.1.4.1.9.9.318.1.2.1.1.16

Integer32 (0..65535) · bytes

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : Section 2.3.8 Audit Endpoint

This object specifies the maximum allowed xGCP message size which is used for checking if the size will be supported by the call agent via (AuditEndPoint) response. A value of 0 means that there is no limit to the size of the XGCP message.

cXgcpMediaGwLastFailMgcAddrType

1.3.6.1.4.1.9.9.318.1.2.1.1.17

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the address type, either IPv4 or IPv6, of cxeCallCtrlLastFailMgcAddr.

cXgcpMediaGwLastFailMgcAddr

1.3.6.1.4.1.9.9.318.1.2.1.1.18

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates the address of last MGC which the media gateway had tried to communicate with but failed.

cXgcpMediaGwDtmfRelay

1.3.6.1.4.1.9.9.318.1.2.1.1.19

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

When this object is set to 'true', the digits will be sent as peer-to-peer packet in the bearer. When this object is set to 'false', the digits will be sent as regular voice packets in the bearer. For low complexity CODECS (such as G.711), the preferred value for this object could be 'false'. For high complexity CODECS (such as G.729A), the preferred value for this object should be 'true', otherwise the digits may not get recognized properly at the remote end.

cXgcpMediaGwCaleaEnabled

1.3.6.1.4.1.9.9.318.1.2.1.1.20

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

CALEA, Communication Assistance for Law Enforcement Act, is a feature that allows for a lawful intercept of a call details and call contents originating or terminating on specific terminals. CALEA feature can be turned on or off. A value 'true' specifies CALEA enabled and a value 'false' specifies CALEA disabled.

cXgcpMediaGwConfiguredPackages

1.3.6.1.4.1.9.9.318.1.2.1.1.21

BITS

Reference: RFC2705 - Media Gateway Control Protocol (MGCP) version 1.0 : 6.1. Basic packages

This object represents the bit map of MGCP packages configured and supported in the gateway. Bit 0 - Not Found Bit 1 - Package DC (Don't care package) Bit 2 - Package G (Generic package) Bit 3 - Package D (DTMF package) Bit 4 - Package M (MF package) Bit 5 - Package T (Trunk package) Bit 6 - Package L (Line package) Bit 7 - Package H (Handset package) Bit 8 - Package R (RTP package) Bit 9 - Package N (NAS package) Bit 10 - Package A (Announcement Server package) Bit 11 - Package S (Script package) Bit 12 - Package ATM (ATM package) Bit 13 - Package MS (MF CAS package) Bit 14 - Package DT (DTMF CAS package) Bit 15 - Package MO (MO package) Bit 16 - Package RES (RES package) Bit 17 - Package S_ASDI (ASDI package (S) NCS) Bit 18 - Package IT (IT package (S) TGCP) Bit 19 - Package MT (MT package) Bit 20 - Package B (B package) Bit 21 - Package SST (SST package) Bit 22 - Package MDR (MDR package) Bit 23 - Package FXR (FAX package) Bit 24 - Package BA (Bulk Audit package) Bit 25 - Package MD (MD package) Bit 26 - Package NAS (Network Access Server package) Bit 27 - Package MDSTE (Modem relay Secure Telephone Equipment package) Bit 28 - Package PRE (PRE package) Bit 29 - Package LCS (MGCP Line Control Signaling package) Bit 33 - Package SRTP (Secure RTP package) Bit 31 - Package FM (Media Format Package) The value 0 means there is no supported packages.

cXgcpMediaGwConnOosRsipBehavior

1.3.6.1.4.1.9.9.318.1.2.1.1.22

INTEGER1 = sendDlcx2 = rsipOnly · Integer32

This object specifies the RSIP behavior of the endpoints with active calls (in connections) when they are forced to out-of-service. The following values can be set for this object: sendDlcx - The media gateway sends RSIP-graceful and then individual DLCX command to delete the endpoints of each connection and its children before it sends out RSIP-forced command when an endpoint goes into alarm or placed out-of-service forcefully through the user command if the endpoint or its children has any calls (in connections). rsipOnly - The media gateway sends out RSIP-forced command, and delete the connections without any DLCX or RSIP-graceful command. This object is applicable only if the endpoint or its children have any calls. If there are no calls on the endpoint, the media gateway sends RSIP-forced command when the endpoint is forced to out-of-service.

cXgcpMediaGwLongDurTimer

1.3.6.1.4.1.9.9.318.1.2.1.1.23

Integer32 (1..65536) · seconds

This object specifies the long duration timer. It is used to define the long duration of a connection. Once the timer expires, a notification will be sent to the MGC to indicate that a connection has established for the defined long duration.

cXgcpMediaGwProfile

1.3.6.1.4.1.9.9.318.1.2.1.1.24

CCallControlProfileIndexOrZeroThis textual convention is an extension of the CCallControlProfileIndex convention. The latter defines a greater than zero value used to identify a call control profile in a media gateway. This extension permits the additional value of zero. The value of '0' means the default call control profile of the media gateway. (0..65535) · Unsigned32

This object specifies the XGCP profile in the media gateway level. The value of 0 means the XGCP default profile is used in the media gateway level. If the value of ccasIfExtVoiceCfgCcntrlProfile is 0, then the endpoint uses the profile specified in this object.

cXgcpMediaGwAnnexabSdpEnabled

1.3.6.1.4.1.9.9.318.1.2.1.1.25

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies the format for parsing or generating G.723 or G.729 codec in SDP message for the media gateway. The value 'true' means using Annex A and B in fmtp line complying with RFC 3555. The value 'false' means using Annex A and B in SDP attribute codec string.

cXgcpMsgStatsTable

1.3.6.1.4.1.9.9.318.1.3.1

Index: cmgwIndex · cXgcpMsgStatsIndex

This table contains statistical information on the transmitted and received network messages between MG and MGC, since the MG reset. The entries in this table are uniquly identified by the VMG index and the MGC address. This table contains statistics of the most recently received 64 MGC addressess for every VMG present in the device. When a new address is received and the number of entries for this MGC exceeds 64, then a least recently received entry is deleted.

from CISCO-MEDIA-GATEWAY-MIB

cmgwIndex

Integer32 (1..2147483647)

An index that uniquely identifies an entry in the cMediaGwTable.

cXgcpMsgStatsIndex

1.3.6.1.4.1.9.9.318.1.3.1.1.1

Integer32 (1..64)

A unique index to identify a specific MGC address for tracking xGCP statistics between MGC and MG.

cXgcpMsgStatsMgcIPAddressType

1.3.6.1.4.1.9.9.318.1.3.1.1.2

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the address type of cXgcpMsgStatsMgcIPAddress.

cXgcpMsgStatsMgcIPAddress

1.3.6.1.4.1.9.9.318.1.3.1.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates IP address of the MGC. The IP address should be unique on the table.

cXgcpMsgStatsSuccessMessages

1.3.6.1.4.1.9.9.318.1.3.1.1.4

Counter32

This object indicates the number of successful messages that communicate with the MGC on that IP address. Successful messages apply to both transmit and receive messages. Transmit: Positive ACK received from the MGC. Receive : Positive ACK sent to the MGC. This implies that the format of the message is correct and the request can be fulfilled.

cXgcpMsgStatsFailMessages

1.3.6.1.4.1.9.9.318.1.3.1.1.5

Counter32

This object indicates the number of failed messages that communicate with the MGC on that IP address. Failed messages apply to both transmit and receive messages. Transmit: Either NAK has been received from the MGC or message times out waiting for ACK. Receive: Format of the received message is bad or the request was NAK'ed.

cXgcpMsgStatsIncompleteMessages

1.3.6.1.4.1.9.9.318.1.3.1.1.6

Counter32

This object indicates the number of transmit messages for which time out occurred while waiting for an ACK.

cXgcpStatsTable

1.3.6.1.4.1.9.9.318.1.3.2

Index: cmgwIndex

This table contains information on the received and transmitted network messages, based on each message type, for all the VMGs present in the device. The table will have one entry for every VMG present in the device. When a new MG is instantiated, the device creates an entry. The entry is destroyed if the associated VMG is terminated.

from CISCO-MEDIA-GATEWAY-MIB

cmgwIndex

Integer32 (1..2147483647)

An index that uniquely identifies an entry in the cMediaGwTable.

cXgcpStatsUdpRxPkts

1.3.6.1.4.1.9.9.318.1.3.2.1.1

Counter32

Number of UDP packets received from all the MGCs.

cXgcpStatsUdpTxPkts

1.3.6.1.4.1.9.9.318.1.3.2.1.2

Counter32

Number of UDP packets sent to all the MGCs.

cXgcpStatsUnRecRxPkts

1.3.6.1.4.1.9.9.318.1.3.2.1.3

Counter32

Number of unrecognized UDP packets received from all the MGCs.

cXgcpStatsMsgParsingErrors

1.3.6.1.4.1.9.9.318.1.3.2.1.4

Counter32

Number of messages with parsing errors received from all the MGCs.

cXgcpStatsDupAckTxMsgs

1.3.6.1.4.1.9.9.318.1.3.2.1.5

Counter32

Number of duplicate response messages sent to the MGCs.

cXgcpStatsInvalidVerCount

1.3.6.1.4.1.9.9.318.1.3.2.1.6

Counter32

Number of invalid protocol version messages received from all the MGCs.

cXgcpStatsUnknownMgcRxPkts

1.3.6.1.4.1.9.9.318.1.3.2.1.7

Counter32

Number of unknown message packets received from all the MGCs.

cXgcpStatsAckTxMsgs

1.3.6.1.4.1.9.9.318.1.3.2.1.8

Counter32

Number of acknowledgment messages sent by the MG.

cXgcpStatsNackTxMsgs

1.3.6.1.4.1.9.9.318.1.3.2.1.9

Counter32

Number of negative acknowledgment messages sent by the MG.

cXgcpStatsAckRxMsgs

1.3.6.1.4.1.9.9.318.1.3.2.1.10

Counter32

Number of acknowledgment messages received by the MG.

cXgcpStatsNackRxMsgs

1.3.6.1.4.1.9.9.318.1.3.2.1.11

Counter32

Number of negative acknowledgment messages received by the MG.

cXgcpStatsRxCrcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.12

Counter32

Number of CRCX messages received by the MG.

cXgcpStatsRxSuccCrcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.13

Counter32

Number of CRCX messages received, that were successful.

cXgcpStatsRxFailCrcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.14

Counter32

Number of CRCX messages received, that failed.

cXgcpStatsRxDlcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.15

Counter32

Number of DLCX messages received.

cXgcpStatsRxSuccDlcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.16

Counter32

Number of DLCX messages received, that were successful.

cXgcpStatsRxFailDlcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.17

Counter32

Number of DLCX messages received, that failed.

cXgcpStatsTxDlcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.18

Counter32

Number of DLCX messages sent.

cXgcpStatsTxSuccDlcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.19

Counter32

Number of DLCX messages sent, that were successful.

cXgcpStatsTxFailDlcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.20

Counter32

Number of DLCX messages sent, that failed.

cXgcpStatsRxMdcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.21

Counter32

Number of MDCX messages received.

cXgcpStatsRxSuccMdcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.22

Counter32

Number of MDCX messages received, that were successful.

cXgcpStatsRxFailMdcxs

1.3.6.1.4.1.9.9.318.1.3.2.1.23

Counter32

Number of MDCX messages received, that failed.

cXgcpStatsRxRqnts

1.3.6.1.4.1.9.9.318.1.3.2.1.24

Counter32

Number of RQNT messages received.

cXgcpStatsRxSuccRqnts

1.3.6.1.4.1.9.9.318.1.3.2.1.25

Counter32

Number of RQNT messages received, that were successful.

cXgcpStatsRxFailRqnts

1.3.6.1.4.1.9.9.318.1.3.2.1.26

Counter32

Number of RQNT messages received, that failed.

cXgcpStatsRxAucxs

1.3.6.1.4.1.9.9.318.1.3.2.1.27

Counter32

Number of AUCX messages received.

cXgcpStatsRxSuccAucxs

1.3.6.1.4.1.9.9.318.1.3.2.1.28

Counter32

Number of AUCX messages received, that were successful.

cXgcpStatsRxFailAucxs

1.3.6.1.4.1.9.9.318.1.3.2.1.29

Counter32

Number of AUCX messages received, that failed.

cXgcpStatsRxAueps

1.3.6.1.4.1.9.9.318.1.3.2.1.30

Counter32

Number of AUEP messages received.

cXgcpStatsRxSuccAueps

1.3.6.1.4.1.9.9.318.1.3.2.1.31

Counter32

Number of AUEP messages received, that were successful.

cXgcpStatsRxFailAueps

1.3.6.1.4.1.9.9.318.1.3.2.1.32

Counter32

Number of AUEP messages received, that failed.

cXgcpStatsTxRsips

1.3.6.1.4.1.9.9.318.1.3.2.1.33

Counter32

Number of RSIP messages sent.

cXgcpStatsTxSuccRsips

1.3.6.1.4.1.9.9.318.1.3.2.1.34

Counter32

Number of RSIP messages sent, that were successful.

cXgcpStatsTxFailRsips

1.3.6.1.4.1.9.9.318.1.3.2.1.35

Counter32

Number of RSIP messages sent, that failed.

cXgcpStatsTxNotifies

1.3.6.1.4.1.9.9.318.1.3.2.1.36

Counter32

Number of NTFY messages sent.

cXgcpStatsTxSuccNotifies

1.3.6.1.4.1.9.9.318.1.3.2.1.37

Counter32

Number of NTFY messages sent, that were successful.

cXgcpStatsTxFailNotifies

1.3.6.1.4.1.9.9.318.1.3.2.1.38

Counter32

Number of NTFY messages sent, that failed.

cXgcpConnectionTable

1.3.6.1.4.1.9.9.318.1.4.1

Index: cmgwIndex · cXgcpConnId

This table contains information on the active connections of all the VMGs present in the device. A MG may have zero or more number of calls at any given time. Each call consists of one or more connection. The table will have one entry per VMG per connection present in the device. When a new connection is established, the device creates an entry. The entry is destroyed if the associated connection is torn down.

from CISCO-MEDIA-GATEWAY-MIB

cmgwIndex

Integer32 (1..2147483647)

An index that uniquely identifies an entry in the cMediaGwTable.

cXgcpConnId

1.3.6.1.4.1.9.9.318.1.4.1.1.1

Unsigned32 (1..4294967295)

Connection ID generated by the gateway and sent in the ACK message.

cXgcpConnEndPoint

1.3.6.1.4.1.9.9.318.1.4.1.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The physical or virtual entity that acts as a source or sink of data in the MG is called an endpoint. Every end point in the MG is assigned a textual name by the MG.

cXgcpConnCallId

1.3.6.1.4.1.9.9.318.1.4.1.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Call ID associated with this connection. Call ID is a parameter that identifies the call to which this connection belongs to. A call ID is unique within a VMG instance.

cXgcpConnLocalUdpPort

1.3.6.1.4.1.9.9.318.1.4.1.1.4

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The local UDP port used for the connection.

cXgcpConnRemoteUdpPort

1.3.6.1.4.1.9.9.318.1.4.1.1.5

CiscoPortThe TCP or UDP port number range.Reference: Transmission Control Protocol. J. Postel. RFC793, User Datagram Protocol. J. Postel. RFC768 (0..65535) · Integer32

The remote UDP port used for the connection.

cXgcpConnMode

1.3.6.1.4.1.9.9.318.1.4.1.1.6

INTEGER0 = invalid1 = sendOnly2 = recvOnly3 = sendRecv4 = inActive5 = loopBack6 = contTest7 = data8 = netwLoop9 = netwTest10 = conference · Integer32

Represents possible MG connection modes. invalid - Invalid value for mode sendOnly - The GW should only send packets recvOnly - The GW should only receive packets sendRecv - The GW can send and receive packets inActive - The GW should neither send nor receive packets loopBack - The GW should place the circuit in loopback mode contTest - The GW should place the circuit in test mode data - The GW should use the circuit for network access for data netwLoop - The GW should place the connection in network loopback mode netwTest - The GW should place the connection in network continuity test mode conference - The GW should place the connection in conference mode.

cXgcpConnVccId

1.3.6.1.4.1.9.9.318.1.4.1.1.7

Unsigned32 (1..4294967295)

VCCI used for the VoAAL2 call. The object should have a non-zero value only if the associated call is of VoAAL2 type. For all other calls the value should be '0'.

cXgcpConnChannelId

1.3.6.1.4.1.9.9.318.1.4.1.1.8

Unsigned32 (1..4294967295)

CID used for the VoAAL2 call. The object should have a non-zero value only if the associated call is of VoAAL2 type. For all other calls the value should be '0'.

cXgcpConnCallState

1.3.6.1.4.1.9.9.318.1.4.1.1.9

INTEGER0 = idle1 = setting2 = connecting3 = conferencing4 = active5 = confDestroying6 = disconnecting7 = inactive8 = voiceConnecting9 = voiceActive10 = confDissociating11 = callLegsDissociated12 = hpConnecting13 = hpConnected14 = hpConferencing15 = hpActive16 = voipConfDestroy17 = erroState18 = connectingInactive19 = confDestroyingInactive20 = confTest21 = setupWait22 = waitNseSent23 = twcActive24 = waitState25 = handOver · Integer32

Represents possible MG call states. idle - Idle setting - Incoming call from PSTN connecting - CRCX message received conferencing - Call connected, await conf active - Conference created confDestroying - Destroying conference disconnecting - Conf destroyed, disconnect call inactive - call in inactive mode voiceConnecting - Creating telephony call leg only voiceActive - Telephony call leg created confDissociating - Destroying conf callLegsDissociated - Conf destroyed hpConnecting - connecting TDM hair-pin call leg hpConnected - one HP call leg connected hpConferencing - Conferencing TDM Hairpin call leg hpActive - TDM hair-pinning active state voipConfDestroy - Conf destroyed, make HP call erroState - call in error state connectingInactive - creating inactive connection confDestroyingInactive - conf destroy inactive conn confTest - AAL2/IP continuity test setupWait - Waiting for setup information waitNseSent - Wait for NSE event to be sent twcActive - TWC call active waitState - App is waiting for call control handOver - App is grabbing back the control

cXgcpConnCodec

1.3.6.1.4.1.9.9.318.1.4.1.1.10

INTEGER0 = notApplicable1 = g711ulaw2 = g711alaw3 = g726k324 = g726k245 = g726k166 = g7297 = g729a8 = g729b9 = g729bLowComp10 = g72811 = g72312 = g7231HighRate13 = g7231aHighRate14 = g7231LowRate15 = g7231aLowRate16 = gsmFullRate17 = gsmHalfRate18 = gsmEnhancedFullRate19 = gsmEnhancedHalfRate20 = g729ab128 = clearChannel129 = nse130 = xnse131 = nte132 = t38133 = modemRelay134 = mdsteModemRelay135 = sse200 = codecUnknown · Integer32

Reference: RFC-3551

Specifies the codec type to be used with the Call. The following codec types are defined: notApplicable - no Codec Type is defined g711ulaw - G.711 mu-law g711alaw - G.711 A-law g726k32 - G.726 32K g726k24 - G.726 24K g726k16 - G.726 16K g729 - G.729 g729a - G.729-A g729b - G.729-B g729bLowComp - G.729-B Low Complexity g728 - G.728 g723 - G.723 g7231HighRate - G.723.1 High Rate g7231aHighRate - G.723.1 Annex A High Rate g7231LowRate - G.723.1 Low Rate g7231aLowRate - G.723.1 Annex A Low Rate gsmFullRate - GSM full rate gsmHalfRate - GSM half rate gsmEnhancedFullRate - GSM enhanced full rate gsmEnhancedHalfRate - GSM enhanced half rate g729ab - G.729-A-B. clearChannel - Nx64 clear channel nse - For NSE xnse - For X-NSE nte - For telephone-event t38 - T-38 modemRelay - Modem Relay mdsteModemRelay - For X+mdste sse - For SSE codecUnknown - Unknown Codec

cXgcpConnLastSuccEvent

1.3.6.1.4.1.9.9.318.1.4.1.1.11

CXgcpCallEvent0 = ack1 = createConn2 = deleteConn3 = modifyConn4 = notifyReq5 = alert6 = callConnect7 = confReady8 = confDestroy9 = callDisconnect10 = callProceed11 = offHook12 = onHook13 = mediaEvent14 = intEven15 = dissocConf16 = assocConf17 = modifyDone18 = voiceModeDone19 = nse20 = callHandoff21 = babblerAuditRespRepresents possible Gateway Control Protocol Call Events. ack - Acknowledgement msg createConn - Create connection msg deleteConn - Delete connection msg modifyConn - Modify connection msg notifyReq - Notify request msg alert - CCAPI alert event callConnect - CCAPI call connect event confReady - CCAPI conference ready confDestroy - CCAPI conference destroyed callDisconnect - CCAPI call disconnect callProceed - CCAPI call proceeding offHook - CCAPI off-hook/call setup ind onHook - CCAPI on-hook/call disconnected mediaEvent - Media Events intEven - Internal Events dissocConf - Dissociate Conf assocConf - Associate Conf modifyDone - CCAPI Call modify done event voiceModeDone - Voice Cut-thru has happened nse - CCAPI NSE events callHandoff - Handoff Call to some other app babblerAuditResp - CCAPI babbler audit response · Integer32

A call event is defined as something that happens to a call at a given time. This object contains the latest MG call event that was successful.

cXgcpConnLastSuccIntEvent

1.3.6.1.4.1.9.9.318.1.4.1.1.12

CXgcpCallEvent0 = ack1 = createConn2 = deleteConn3 = modifyConn4 = notifyReq5 = alert6 = callConnect7 = confReady8 = confDestroy9 = callDisconnect10 = callProceed11 = offHook12 = onHook13 = mediaEvent14 = intEven15 = dissocConf16 = assocConf17 = modifyDone18 = voiceModeDone19 = nse20 = callHandoff21 = babblerAuditRespRepresents possible Gateway Control Protocol Call Events. ack - Acknowledgement msg createConn - Create connection msg deleteConn - Delete connection msg modifyConn - Modify connection msg notifyReq - Notify request msg alert - CCAPI alert event callConnect - CCAPI call connect event confReady - CCAPI conference ready confDestroy - CCAPI conference destroyed callDisconnect - CCAPI call disconnect callProceed - CCAPI call proceeding offHook - CCAPI off-hook/call setup ind onHook - CCAPI on-hook/call disconnected mediaEvent - Media Events intEven - Internal Events dissocConf - Dissociate Conf assocConf - Associate Conf modifyDone - CCAPI Call modify done event voiceModeDone - Voice Cut-thru has happened nse - CCAPI NSE events callHandoff - Handoff Call to some other app babblerAuditResp - CCAPI babbler audit response · Integer32

This object contains the latest MG internal call event that was successful.

cXgcpConnLastFailedEvent

1.3.6.1.4.1.9.9.318.1.4.1.1.13

CXgcpCallEvent0 = ack1 = createConn2 = deleteConn3 = modifyConn4 = notifyReq5 = alert6 = callConnect7 = confReady8 = confDestroy9 = callDisconnect10 = callProceed11 = offHook12 = onHook13 = mediaEvent14 = intEven15 = dissocConf16 = assocConf17 = modifyDone18 = voiceModeDone19 = nse20 = callHandoff21 = babblerAuditRespRepresents possible Gateway Control Protocol Call Events. ack - Acknowledgement msg createConn - Create connection msg deleteConn - Delete connection msg modifyConn - Modify connection msg notifyReq - Notify request msg alert - CCAPI alert event callConnect - CCAPI call connect event confReady - CCAPI conference ready confDestroy - CCAPI conference destroyed callDisconnect - CCAPI call disconnect callProceed - CCAPI call proceeding offHook - CCAPI off-hook/call setup ind onHook - CCAPI on-hook/call disconnected mediaEvent - Media Events intEven - Internal Events dissocConf - Dissociate Conf assocConf - Associate Conf modifyDone - CCAPI Call modify done event voiceModeDone - Voice Cut-thru has happened nse - CCAPI NSE events callHandoff - Handoff Call to some other app babblerAuditResp - CCAPI babbler audit response · Integer32

This object contains the latest MG call event that was failed.

cXgcpConnLastReqEvent

1.3.6.1.4.1.9.9.318.1.4.1.1.14

CXgcpCallEvent0 = ack1 = createConn2 = deleteConn3 = modifyConn4 = notifyReq5 = alert6 = callConnect7 = confReady8 = confDestroy9 = callDisconnect10 = callProceed11 = offHook12 = onHook13 = mediaEvent14 = intEven15 = dissocConf16 = assocConf17 = modifyDone18 = voiceModeDone19 = nse20 = callHandoff21 = babblerAuditRespRepresents possible Gateway Control Protocol Call Events. ack - Acknowledgement msg createConn - Create connection msg deleteConn - Delete connection msg modifyConn - Modify connection msg notifyReq - Notify request msg alert - CCAPI alert event callConnect - CCAPI call connect event confReady - CCAPI conference ready confDestroy - CCAPI conference destroyed callDisconnect - CCAPI call disconnect callProceed - CCAPI call proceeding offHook - CCAPI off-hook/call setup ind onHook - CCAPI on-hook/call disconnected mediaEvent - Media Events intEven - Internal Events dissocConf - Dissociate Conf assocConf - Associate Conf modifyDone - CCAPI Call modify done event voiceModeDone - Voice Cut-thru has happened nse - CCAPI NSE events callHandoff - Handoff Call to some other app babblerAuditResp - CCAPI babbler audit response · Integer32

This object contains the latest requested MG call event.

cXgcpConnEventResult

1.3.6.1.4.1.9.9.318.1.4.1.1.15

INTEGER0 = normalOk1 = invalidOk2 = callRecordReleased10 = invalidCallId11 = invalidConnId12 = duplicatedMsg13 = ackFailure14 = deleteFailure15 = createAckFailure16 = createAckMissing17 = deleteAckFailure18 = notifyFailure19 = invalidState20 = invalidProtocolVer30 = tgwDown31 = tgwNotReady32 = callVdbFailure33 = prevRtpPortLocked34 = connRecordMissing35 = endPointNotRdy36 = memResourceError37 = callCacFailure38 = confRsrcError39 = gwRsrcNotAvailable40 = reqEventFailure41 = invalidCcapiEvent42 = ignoreCcapiEvent50 = signalFailure51 = abnormalOnhook52 = invalidOffhook53 = invalidCot54 = cotFailure55 = cotDisableFailure60 = callSetupReqFailure61 = callSetupIndFailure62 = callContextFailure63 = callPeerFailure64 = callVoxCallFailure65 = callVoipCallFailure66 = callDiscFailure67 = callModifyFailure68 = callAlertFailure69 = callDeleteFailure70 = callUnknownFeature71 = upSupportedCodec72 = noDigitMap73 = ignoreDigit74 = digitsOverflow75 = digitsNotifyFailure76 = codecNotMatched77 = invalidConnMode78 = glare90 = peerMissing91 = peerNotReady92 = peerInWrongState93 = peerDisconnectFailure94 = noConferenceId95 = confCreateFailure96 = confDestroyFailure97 = unknownConnType98 = invalidEndpoint100 = invalidNseEvent101 = nseRcvdOnWrongLeg102 = sendNseFailure103 = playToneFailure104 = codecSpecInError105 = mediaSpecUpsupported106 = mediaChangeFail107 = invalidNsePayload108 = nsePayloadNotAvail109 = embMdcxError110 = mdcxLeg1Error111 = mdcxLeg2Error112 = deferMsg115 = transError120 = discOnWrongLeg130 = invalidNteEvent131 = notEnabledNteEvent132 = nteEventExecuteFail133 = sendNteFailure140 = invalidSsePayload141 = ssePayloadNotAvailable142 = invalidModemRelayParam143 = modemRelayNotSupported144 = invalidXcapXcpar145 = invalidSprtPayload146 = sprtPayloadNotAvailable · Integer32

Represents possible MG call event results. normalOk - Normal event processed OK invalidOk - Invalid event processed OK callRecordReleased - The call record is released invalidCallId - TGW find invalid call id invalidConnId - TGW find invalid connection id duplicatedMsg - TGW find duplicated sgcp msg ackFailure - TGW can't send sgcp ack msg deleteFailure - TGW can't send sgcp delete msg createAckFailure - TGW can't send create ack msg createAckMissing - TGW did't send sgcp ack msg deleteAckFailure - TGW can't send delete ack msg notifyFailure - TGW can't send sgcp notify msg invalidState - TGW find event in wrong state invalidProtocolVer - GW finds protocl ver. not supported tgwDown - TGW in graceful shutdown mode tgwNotReady - TGW not ready for the event callVdbFailure - TGW can't obtain the vdbptr prevRtpPortLocked - TGW find previous rtp port locked connRecordMissing - TGW can't find conn record endPointNotRdy - TGW not ready for the event memResourceError - TGW has transient mem alloc err callCacFailure - GW does not have the bandwidth confRsrcError - GW cannot get conf resource gwRsrcNotAvailable - GW does not have available resource reqEventFailure - TGW can't handle requested event invalidCcapiEvent - TGW can't handle the ccapi event ignoreCcapiEvent - TGW will ignore the ccapi event signalFailure - TGW can't handle the signal abnormalOnhook - TGW find abnormal onhook invalidOffhook - TGW find invalid offhook invalidCot - TGW find invalid cot cotFailure - TGW failed to do COT cotDisableFailure - TGW failed to disable COT callSetupReqFailure - TGW can't setup call request callSetupIndFailure - TGW can't handle call indication callContextFailure - TGW can't setup the context callPeerFailure - TGW can't setup the peer callVoxCallFailure - TGW can't setup the voip/voaal2 call callVoipCallFailure - TGW can't setup the voip call callDiscFailure - TGW can't disconnect the call callModifyFailure - TGW can't modify the call parm callAlertFailure - TGW can't alert the call callDeleteFailure - TGW can't delete the call callUnknownFeature - TGW can't handle unknow feature upSupportedCodec - TGW find unsupported codec noDigitMap - TGW can't find the digit map ignoreDigit - TGW can't process the digits digitsOverflow - TGW can't handle too many digits digitsNotifyFailure - TGW can't send the digits out codecNotMatched - TGW codec doesn't match rmt TGW invalidConnMode - TGW can't understand con mode glare - GW encountered a glare condition peerMissing - TGW find not find the peer peerNotReady - TGW find peer not ready peerInWrongState - TGW find the peer in wrong state peerDisconnectFailure - TGW can't disconnect the peer noConferenceId - TGW can't find the conference ID confCreateFailure - TGW can't create conference confDestroyFailure - TGW can't destroy conference unknownConnType - TGW can't handle the con type invalidEndpoint - TGW can't connect to endpoint invalidNseEvent - Invalid NSE event nseRcvdOnWrongLeg - The NSE events come to a wrong leg sendNseFailure - Cannot send an NSE event playToneFailure - Cannot play NSE-requested tone codecSpecInError - Codec list provided in error mediaSpecUpsupported - Media specified not supported mediaChangeFail - Media change failed invalidNsePayload - Invalid payload type in SDP nsePayloadNotAvail - Specified NSE payload not free embMdcxError - Emb modify connection error mdcxLeg1Error - Modify connection leg1 error mdcxLeg2Error - Modify connection leg2 error deferMsg - For deferring events transError - TGW endpoint in transition state discOnWrongLeg - Disconnection on wrong call leg invalidNteEvent - Invalid NTE event notEnabledNteEvent - The NTE event has not been enabled for use nteEventExecuteFail - NTE execution failed sendNteFailure - Cannot send an NTE event invalidSsePayload - Invalid SSE payload ssePayloadNotAvailable - SSE payload is not available invalidModemRelayParam - Invalid Modem Relay Param modemRelayNotSupported - Modem Relay not supported in endpt invalidXcapXcpar - Invalid X-Cap or X-Cpar in SDP invalidSprtPayload - Invalid SPRT payload sprtPayloadNotAvailable - SPRT payload is not available

cXgcpConnEncrSuite

1.3.6.1.4.1.9.9.318.1.4.1.1.16

INTEGER0 = none1 = aes128Cm · Integer32

Specifies what type of encryption suite is used to encode the information sent through this connection. none - No Encryption suite is used aes128Cm - AES-128 countermode encryption suite is used.

↑ To TOC