esSnmpServiceEnabled
1.3.6.1.4.1.171.17.2.1.1.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
A Boolean value represents the SNMP server is Enabled or Disabled.
2013-04-15
Download DLINKES-SNMP-MIB.txt Open DLINKES-SNMP-MIB.txt in a new tab
This MIB module defines objects for configuring SNMP ( Simple Network Management Protocol )
END OF TOC
1.3.6.1.4.1.171.17.2.1.1.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
A Boolean value represents the SNMP server is Enabled or Disabled.
1.3.6.1.4.1.171.17.2.1.1.2
Unsigned32
This object indicates the SNMP UDP port number. By default, the SNMP agent receives requests on UDP port 161.
1.3.6.1.4.1.171.17.2.1.1.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
A Boolean value represents whether response broadcast SNMP GetRequest packet.
1.3.6.1.4.1.171.17.2.1.1.4
SnmpEngineIDAn SNMP engine's administratively-unique identifier. Objects of this type are for identification, not for addressing, even though it is possible that an address may have been used in the generation of a specific value. SIZE (5..32) · OCTET STRING
This object indicates the agent's local engineID value. Changing this variable will affect the value of snmpEngineID. The special value of '00 00 00 00 00'H indicates the local engineID is not specified, and snmpEngineID will be automatically created based on the device basic MAC address. The SNMP engine ID is a unique string to identify the device. The string is generated by default. Check RFC3411 for further details on the SNMP engine ID.
1.3.6.1.4.1.171.17.2.1.2.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
A Boolean value to represent the global state of sending of trap packets.
1.3.6.1.4.1.171.17.2.1.2.2
BITS
This object indicates global state about whether a specified notification is enabled or not. If a bit corresponding to a notification is set to 1, then the specified notification can be generated. linkUp(0) - sending a standard linkUp notification (defined in IF-MIB). linkDown(1) - sending a standard linkDown notification (defined in IF-MIB). coldStart(2) - sending a standard coldStart notification (defined in SNMPv2-MIB). warmStart(3) - sending a standard warmStart notification (defined in SNMPv2-MIB). Note: please use snmpEnableAuthenTraps (defined in SNMPv2-MIB) to control the generation of authenticationFailure traps.
1.3.6.1.4.1.171.17.2.1.2.3
InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d
The ifIndex of the interface whose IP address is used as the source IP address for outbound SNMP traps. A special value of zero indicates the source interface is not specified, the IP address of the closest interface will be used.
1.3.6.1.4.1.171.17.2.1.2.5
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
A Boolean value to represent the global state of sending of RMON rising-alarm trap packets.
1.3.6.1.4.1.171.17.2.1.2.6
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
A Boolean value to represent the global state of sending of RMON falling-alarm trap packets.
1.3.6.1.4.1.171.17.2.1.2.4.1
Index: ifIndex
This table contains a list of interface-specific notification configuration.
from IF-MIB
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.
1.3.6.1.4.1.171.17.2.1.2.4.1.1.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates whether sending trap on the interface. If the state is disabled, then SNMP notification traps generated by the system are not allowed to transmit out of the port.
1.3.6.1.4.1.171.17.2.1.3.1
Index: esSnmpCommunityName
This table consists of a list of communities.
1.3.6.1.4.1.171.17.2.1.3.1.1.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This object indicates the name of the community.
1.3.6.1.4.1.171.17.2.1.3.1.1.3
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
This object indicates the name of a standard access list to control the user to use this community string to access to the SNMP agent. Specify the valid user in the source address field of the access list entry. A zero length string indicates the access list is not specified.
1.3.6.1.4.1.171.17.2.1.3.2
Index: esSnmpGroupName · esSnmpGroupVersion
This table consists of a list of groups.
1.3.6.1.4.1.171.17.2.1.3.2.1.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This object indicates the name of the group.
1.3.6.1.4.1.171.17.2.1.3.2.1.2
SnmpSecurityModelAn identifier that uniquely identifies a securityModel of the Security Subsystem within the SNMP Management Architecture. The values for securityModel are allocated as follows: (0..2147483647) · Integer32
This object indicates the version of the entry.
1.3.6.1.4.1.171.17.2.1.3.2.1.3
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
This object indicates the name of a standard access control list (ACL) to associate with the group. A zero length string indicates the access list is not specified.
1.3.6.1.4.1.171.17.2.1.3.3
Index: esSnmpHostAddrName
This table consists of a list of recipients for the SNMP notification.
1.3.6.1.4.1.171.17.2.1.3.3.1.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..32) · OCTET STRING · hint 255t
This object indicates the address name of the recipients.
1.3.6.1.4.1.171.17.2.1.3.3.1.2
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
This object indicates the name of the routing forwarding instance. A zero length string indicates the object is not specified.
1.3.6.1.4.1.171.17.2.1.3.3.1.3
Unsigned32
This object indicates trap UDP port number.
1.3.6.1.4.1.171.17.2.1.3.4
Index: esSnmpUserName
This table consists of a list of recipients for the SNMP notification.
1.3.6.1.4.1.171.17.2.1.3.4.1.1
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..32) · OCTET STRING · hint 255t
This object indicates the name of the user.
1.3.6.1.4.1.171.17.2.1.3.4.1.2
DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
This object indicates the name of a standard IP access control list (ACL) to associate with the user. A zero length string indicates the access list is not specified.