EZ5 MIB Catalog

ENTERASYS-CONFIGURATION-MANAGEMENT-MIB

2013-02-04

This MIB module defines a portion of the SNMP MIB under Enterasys Networks' enterprise OID pertaining to configuration management.

Download ENTERASYS-CONFIGURATION-MANAGEMENT-MIB.txt Open ENTERASYS-CONFIGURATION-MANAGEMENT-MIB.txt in a new tab

SCALARS (10) · TABLES (1) · TRAPS (1)

Scalars (10)

NameOID
etsysConfigMgmtCurrentImageURL1.3.6.1.4.1.5624.1.2.16.1.1
etsysConfigMgmtCurrentConfigURL1.3.6.1.4.1.5624.1.2.16.1.2
etsysConfigMgmtPersistentStorageStatus1.3.6.1.4.1.5624.1.2.16.1.3
etsysConfigMgmtPersistentStorageCkSum1.3.6.1.4.1.5624.1.2.16.1.4
etsysConfigMgmtChangeLimit1.3.6.1.4.1.5624.1.2.16.2.1
etsysConfigMgmtChangeCurrent1.3.6.1.4.1.5624.1.2.16.2.2
etsysConfigMgmtChangeCompleted1.3.6.1.4.1.5624.1.2.16.2.3
etsysConfigMgmtChangeSupportedURLs1.3.6.1.4.1.5624.1.2.16.2.4
etsysConfigMgmtChangeSupportedOperations1.3.6.1.4.1.5624.1.2.16.2.5
etsysConfigMgmtChangeNextAvailableIndex1.3.6.1.4.1.5624.1.2.16.2.6

Tables (1)

NameOID
etsysConfigMgmtChangeTable1.3.6.1.4.1.5624.1.2.16.2.7

Traps (1)

NameOID
etsysConfigMgmtReadyNotification1.3.6.1.4.1.5624.1.2.16.0.1

END OF TOC

Scalar details

etsysConfigMgmtCurrentImageURL

1.3.6.1.4.1.5624.1.2.16.1.1

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The URL of the last image to be successfully loaded into memory. Return an empty string if this feature is not supported or the information is unavailable.

etsysConfigMgmtCurrentConfigURL

1.3.6.1.4.1.5624.1.2.16.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The URL of the last configuration file to be successfully loaded into memory. Return an empty string if this feature is not supported or the information is unavailable.

etsysConfigMgmtPersistentStorageStatus

1.3.6.1.4.1.5624.1.2.16.1.3

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

A descriptive status of any current failures of any of the persistent storage facilities on this entity. When this information is unavailable return a null string. 'operational' should be returned if there are no problems. Transitional information MAY be reported as well.

etsysConfigMgmtPersistentStorageCkSum

1.3.6.1.4.1.5624.1.2.16.1.4

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The MD5 message digest, as specified in RFC1321, for the persistent configuration information. This object MAY be used by management applications to detect changes to the configuration of the managed entity. If it is not possible to compute this value return an empty string.

etsysConfigMgmtChangeLimit

1.3.6.1.4.1.5624.1.2.16.2.1

Unsigned32

The maximum number of configuration change requests this entity can hold in the etsysConfigMgmtChangeTable. A value of 0 indicates no configured limit.

etsysConfigMgmtChangeCurrent

1.3.6.1.4.1.5624.1.2.16.2.2

Gauge32

The number of configuration change requests currently in the etsysConfigMgmtChangeTable.

etsysConfigMgmtChangeCompleted

1.3.6.1.4.1.5624.1.2.16.2.3

Counter32

The number of configuration change requests that have completed successfully or otherwise. This object should be stored in persistent memory.

etsysConfigMgmtChangeSupportedURLs

1.3.6.1.4.1.5624.1.2.16.2.4

BITS

Reference: RFC 1738 - Uniform Resource Locators (URL), RFC 2396 - Uniform Resource Identifiers (URI): Generic Syntax

The URLs that this entity supports for transferring files. These define the transfer protocols and remote file names. etsysConfigMgmtFtp - As per rfc1738 ftp://<user>:<password>@<host>:<port>/<url-path> url-path: <cwd1>/<cwd2>/.../<cwdN>/<name>;type=<typecode> user defaults to anonymous, password to snmp@<domain-name>, port to 21, and type to ASCII. binary and image are both valid types which have the same meaning. domain-name would be the IP address or domain name of the managed entity. etsysConfigMgmtRcp - rcp://<user>@<host>:<port>/<cwd1>/<cwd2>/.../<cwdN>/<name> port defaults to 514. etsysConfigMgmtHttp - As per rfc1738 http://<host>:<port>/<path>?<searchpart> port defaults to 80. etsysConfigMgmtTftp - tftp://<host>:<port>/<cwd1>/<cwd2>/.../<cwdN>/<name> port defaults to 69. etsysConfigMgmtFile - As per rfc1738 file://<host>/<path> host can only be specified as localhost or the empty string. This will only be used to specify a file on the managed entity. This indicates that the managed entity supports some form of a user file system. etsysConfigMgmtBootP - bootp://<host> host specifies the default gateway, or bootp server that the bootp request should be directed to. etsysConfigMgmtScp - scp://<user>:<password>@<host>:<port>/<cwd1>/<cwd2>/.../<cwdN>/<name> host as defined in RFC1738. port defaults to 22.

etsysConfigMgmtChangeSupportedOperations

1.3.6.1.4.1.5624.1.2.16.2.5

ConfigMgmtOperationsOperations that can be used to effect the configuration of the managed entity. ------------------------------------------------------- -- Any or all of these operations MAY be supported on -- all devices. ------------------------------------------------------- resetHardware - Initiate a hardware reset. If this operation is requested in conjunction with other operations than this operation should be performed only after all of the other requested operations have completed successfully. resetSoftware - Initiate a software reset. If this operation is requested in conjunction with other operations than this operation should be performed only after all of the other requested operations have completed successfully. imageDownload - The managed entity will initiate an image download using the least disruptive method available to it given the specified protocol. The downloaded image WILL be stored in persistent storage. This operation MAY initiate a reset. bootPromDownload - The managed entity will initiate a boot PROM download using the least disruptive method available to it given the specified protocol. The downloaded boot PROM WILL be stored in persistent storage. This operation MAY initiate a reset. imageDownloadNonPersistent - The managed entity will initiate an image download using the least disruptive method available to it given the specified protocol. This operation WILL cause the managed entity to reset. The managed entity will not execute the new image on subsequent resets. configurationReset - Reset the configuration to the factory default state. This operation MAY initiate a reset. configurationUpload - The managed entity will transfer the currently active configuration to the specified destination. The destination may be a local file on entities that support a user file system. configurationDownload - The managed entity will initiate a configuration file download using the least disruptive method available to it given the specified protocol. The downloaded configuration WILL be stored in persistent storage. This operation MAY cause the managed entity to reset. validationMD5sum, - The system will calculate the MD5 message digest, as specified in RFC1321, for the file specified in etsysConfigMgmtChangeURL and compare that with the value of the etsysConfigMgmtChangeValidationString object. If this operation is requested in conjunction with other operations then this operation MUST be initiated as soon as practical and all operations MUST be terminated/aborted as soon as practical if the calculated value does not match the specified value. If the etsysConfigMgmtChangeValidationString is empty the calculate the MD5 message digest will be returned in that object. ------------------------------------------------------- -- Any or all of these operations MAY be supported on -- devices that have user file systems. ------------------------------------------------------- imageSetSelected - The file specified in etsysConfigMgmtChangeURL is selected as the boot image. Although a reset MAY be required to execute the selected boot image this operation WILL NOT initiate a reset. This operation will fail if the specified file is not a valid boot image. imageGetSelected - The file selected as the boot image is returned in etsysConfigMgmtChangeURL. This operation MUST NOT be used in conjunction with any other operations. configurationActivate - The configuration file specified in the etsysConfigMgmtChangeURL is applied to the factory default configuration and the result becomes the active configuration. If the entity does not support the configurationPersist operation the result also becomes the start-up configuration. This operation MAY initiate a reset operation. configurationAppend - The configuration file specified in the etsysConfigMgmtChangeURL is applied to the active configuration and the result becomes the active configuration. If the entity does not support the configurationPersist operation the result also becomes the start-up configuration. This operation SHOULD NOT initiate a reset operation. configurationPersist - The active configuration will be save to persistent storage and become the start-up configuration. This operation WILL NOT initiate a reset operation. configurationParse - The configuration file specified in the etsysConfigMgmtChangeURL is parsed for errors. This operation WILL NOT effect active configuration. This operation WILL NOT initiate a reset operation. · BITS

Configuration change operations that are supported on this managed entity. A managed entity should provide support only for the options that make sense given the capabilities of the entity and the desired level of manageability.

etsysConfigMgmtChangeNextAvailableIndex

1.3.6.1.4.1.5624.1.2.16.2.6

Unsigned32

This object indicates the numerically lowest available index within this entity, which may be used for the value of etsysConfigMgmtChangeIndex in the creation of a new entry in the etsysConfigMgmtChangeTable. An index is considered available if the index value falls within the range of 1 to etsysConfigMgmtChangeLimit and is not being used to index an existing entry in the etsysConfigMgmtChangeTable contained within this entity. A value of zero indicates that all of the entries in the etsysConfigMgmtChangeTable are currently in use. This value should only be considered a guideline for management creation of etsysConfigMgmtChangeTable entries, there is no requirement on management to create entries based upon this index value.

Table details

etsysConfigMgmtChangeTable

1.3.6.1.4.1.5624.1.2.16.2.7

Index: etsysConfigMgmtChangeIndex

A table that describes a single configuration change request.

etsysConfigMgmtChangeIndex

1.3.6.1.4.1.5624.1.2.16.2.7.1.1

Unsigned32 (1..4294967295)

The index for this configuration change request.

etsysConfigMgmtChangeURL

1.3.6.1.4.1.5624.1.2.16.2.7.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The URL of the image, configuration file, or server to use for the requested operation. Any password information MUST NOT be returned on a read. Any errors with the type or format of this object SHOULD be reported in the etsysConfigMgmtChangeErrorDescription object when the row is activated.

etsysConfigMgmtChangeOperation

1.3.6.1.4.1.5624.1.2.16.2.7.1.3

ConfigMgmtOperationsOperations that can be used to effect the configuration of the managed entity. ------------------------------------------------------- -- Any or all of these operations MAY be supported on -- all devices. ------------------------------------------------------- resetHardware - Initiate a hardware reset. If this operation is requested in conjunction with other operations than this operation should be performed only after all of the other requested operations have completed successfully. resetSoftware - Initiate a software reset. If this operation is requested in conjunction with other operations than this operation should be performed only after all of the other requested operations have completed successfully. imageDownload - The managed entity will initiate an image download using the least disruptive method available to it given the specified protocol. The downloaded image WILL be stored in persistent storage. This operation MAY initiate a reset. bootPromDownload - The managed entity will initiate a boot PROM download using the least disruptive method available to it given the specified protocol. The downloaded boot PROM WILL be stored in persistent storage. This operation MAY initiate a reset. imageDownloadNonPersistent - The managed entity will initiate an image download using the least disruptive method available to it given the specified protocol. This operation WILL cause the managed entity to reset. The managed entity will not execute the new image on subsequent resets. configurationReset - Reset the configuration to the factory default state. This operation MAY initiate a reset. configurationUpload - The managed entity will transfer the currently active configuration to the specified destination. The destination may be a local file on entities that support a user file system. configurationDownload - The managed entity will initiate a configuration file download using the least disruptive method available to it given the specified protocol. The downloaded configuration WILL be stored in persistent storage. This operation MAY cause the managed entity to reset. validationMD5sum, - The system will calculate the MD5 message digest, as specified in RFC1321, for the file specified in etsysConfigMgmtChangeURL and compare that with the value of the etsysConfigMgmtChangeValidationString object. If this operation is requested in conjunction with other operations then this operation MUST be initiated as soon as practical and all operations MUST be terminated/aborted as soon as practical if the calculated value does not match the specified value. If the etsysConfigMgmtChangeValidationString is empty the calculate the MD5 message digest will be returned in that object. ------------------------------------------------------- -- Any or all of these operations MAY be supported on -- devices that have user file systems. ------------------------------------------------------- imageSetSelected - The file specified in etsysConfigMgmtChangeURL is selected as the boot image. Although a reset MAY be required to execute the selected boot image this operation WILL NOT initiate a reset. This operation will fail if the specified file is not a valid boot image. imageGetSelected - The file selected as the boot image is returned in etsysConfigMgmtChangeURL. This operation MUST NOT be used in conjunction with any other operations. configurationActivate - The configuration file specified in the etsysConfigMgmtChangeURL is applied to the factory default configuration and the result becomes the active configuration. If the entity does not support the configurationPersist operation the result also becomes the start-up configuration. This operation MAY initiate a reset operation. configurationAppend - The configuration file specified in the etsysConfigMgmtChangeURL is applied to the active configuration and the result becomes the active configuration. If the entity does not support the configurationPersist operation the result also becomes the start-up configuration. This operation SHOULD NOT initiate a reset operation. configurationPersist - The active configuration will be save to persistent storage and become the start-up configuration. This operation WILL NOT initiate a reset operation. configurationParse - The configuration file specified in the etsysConfigMgmtChangeURL is parsed for errors. This operation WILL NOT effect active configuration. This operation WILL NOT initiate a reset operation. · BITS

The operation or operations requested. The specification of any unsupported operations SHOULD cause the entire operation to fail immediately and an appropriate error description to be generated.

etsysConfigMgmtChangeOperStatus

1.3.6.1.4.1.5624.1.2.16.2.7.1.4

INTEGER1 = inactive2 = pending3 = running4 = success5 = failure · Integer32

The operational state of the configuration request. inactive - Indicates that the RowStatus of this conceptual row is not in the `active` state. pending - Indicates that the configuration change described by this row is ready to run and waiting in a queue. running - Indicates that the configuration change described by this row is running. success - Indicates that the configuration change described by this row has successfully run to completion. failure - Indicates that the configuration change described by this row has failed to run to completion.

etsysConfigMgmtChangeDelayTime

1.3.6.1.4.1.5624.1.2.16.2.7.1.5

Unsigned32 · seconds

The number of seconds that should elapse between the time that the RowStatus of this conceptual row is set to active and the request is queued for execution. On a read this object should return the time remaining before the request is queued.

etsysConfigMgmtChangeEnqueuedTime

1.3.6.1.4.1.5624.1.2.16.2.7.1.6

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The date and time, in device local time, when this change request was last enqueued for execution. The value '0000000000000000'H is returned if this table entry has not yet been queued.

etsysConfigMgmtChangeCompletionTime

1.3.6.1.4.1.5624.1.2.16.2.7.1.7

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The date and time, in device local time, when this change request was last completed. It should be reset to the default value when the RowStatus of this conceptual row is set to active. The value '0000000000000000'H is returned if this table entry has not yet run to completion.

etsysConfigMgmtChangeBytesTransferred

1.3.6.1.4.1.5624.1.2.16.2.7.1.8

Integer32

The number of bytes currently transferred. A value of -1 indicates that this feature is not supported for the protocol currently selected. This value is reset to its initial state when the etsysConfigMgmtRowStatus object is set to the active state.

etsysConfigMgmtChangeValidationString

1.3.6.1.4.1.5624.1.2.16.2.7.1.9

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

A checksum, fingerprint, message-digest, or some other means to validate the integrity of the file.

etsysConfigMgmtChangeErrorDescription

1.3.6.1.4.1.5624.1.2.16.2.7.1.10

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains a descriptive error message if the requested transfer failed. Implementations must reset the error message to a zero-length string when the etsysConfigMgmtChangeRowStatus leaf is set to the active state.

etsysConfigMgmtChangeRowStatus

1.3.6.1.4.1.5624.1.2.16.2.7.1.11

RowStatus1 = active2 = notInService3 = notReady4 = createAndGo5 = createAndWait6 = destroyThe RowStatus textual convention is used to manage the creation and deletion of conceptual rows, and is used as the value of the SYNTAX clause for the status column of a conceptual row (as described in Section 7.7.1 of [2].) The status column has six defined values: - `active', which indicates that the conceptual row is available for use by the managed device; - `notInService', which indicates that the conceptual row exists in the agent, but is unavailable for use by the managed device (see NOTE below); 'notInService' has no implication regarding the internal consistency of the row, availability of resources, or consistency with the current state of the managed device; - `notReady', which indicates that the conceptual row exists in the agent, but is missing information necessary in order to be available for use by the managed device (i.e., one or more required columns in the conceptual row have not been instanciated); - `createAndGo', which is supplied by a management station wishing to create a new instance of a conceptual row and to have its status automatically set to active, making it available for use by the managed device; - `createAndWait', which is supplied by a management station wishing to create a new instance of a conceptual row (but not make it available for use by the managed device); and, - `destroy', which is supplied by a management station wishing to delete all of the instances associated with an existing conceptual row. Whereas five of the six values (all except `notReady') may be specified in a management protocol set operation, only three values will be returned in response to a management protocol retrieval operation: `notReady', `notInService' or `active'. That is, when queried, an existing conceptual row has only three states: it is either available for use by the managed device (the status column has value `active'); it is not available for use by the managed device, though the agent has sufficient information to attempt to make it so (the status column has value `notInService'); or, it is not available for use by the managed device, and an attempt to make it so would fail because the agent has insufficient information (the state column has value `notReady'). NOTE WELL This textual convention may be used for a MIB table, irrespective of whether the values of that table's conceptual rows are able to be modified while it is active, or whether its conceptual rows must be taken out of service in order to be modified. That is, it is the responsibility of the DESCRIPTION clause of the status column to specify whether the status column must not be `active' in order for the value of some other column of the same conceptual row to be modified. If such a specification is made, affected columns may be changed by an SNMP set PDU if the RowStatus would not be equal to `active' either immediately before or after processing the PDU. In other words, if the PDU also contained a varbind that would change the RowStatus value, the column in question may be changed if the RowStatus was not equal to `active' as the PDU was received, or if the varbind sets the status to a value other than 'active'. Also note that whenever any elements of a row exist, the RowStatus column must also exist. To summarize the effect of having a conceptual row with a status column having a SYNTAX clause value of RowStatus, consider the following state diagram: STATE +--------------+-----------+-------------+------------- | A | B | C | D | |status col.|status column| |status column | is | is |status column ACTION |does not exist| notReady | notInService| is active --------------+--------------+-----------+-------------+------------- set status |noError ->D|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndGo |inconsistent- | | | | Value| | | --------------+--------------+-----------+-------------+------------- set status |noError see 1|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndWait |wrongValue | | | --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError column to | Value| entValue| | active | | | | | | or | | | | | | | |see 2 ->D|see 8 ->D| ->D --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError ->C column to | Value| entValue| | notInService | | | | | | or | | or | | | | | |see 3 ->C| ->C|see 6 --------------+--------------+-----------+-------------+------------- set status |noError |noError |noError |noError ->A column to | | | | or destroy | ->A| ->A| ->A|see 7 --------------+--------------+-----------+-------------+------------- set any other |see 4 |noError |noError |see 5 column to some| | | | value | | see 1| ->C| ->D --------------+--------------+-----------+-------------+------------- (1) goto B or C, depending on information available to the agent. (2) if other variable bindings included in the same PDU, provide values for all columns which are missing but required, and all columns have acceptable values, then return noError and goto D. (3) if other variable bindings included in the same PDU, provide legal values for all columns which are missing but required, then return noError and goto C. (4) at the discretion of the agent, the return value may be either: inconsistentName: because the agent does not choose to create such an instance when the corresponding RowStatus instance does not exist, or inconsistentValue: if the supplied value is inconsistent with the state of some other MIB object's value, or noError: because the agent chooses to create the instance. If noError is returned, then the instance of the status column must also be created, and the new state is B or C, depending on the information available to the agent. If inconsistentName or inconsistentValue is returned, the row remains in state A. (5) depending on the MIB definition for the column/table, either noError or inconsistentValue may be returned. (6) the return value can indicate one of the following errors: wrongValue: because the agent does not support notInService (e.g., an agent which does not support createAndWait), or inconsistentValue: because the agent is unable to take the row out of service at this time, perhaps because it is in use and cannot be de-activated. (7) the return value can indicate the following error: inconsistentValue: because the agent is unable to remove the row at this time, perhaps because it is in use and cannot be de-activated. (8) the transition to D can fail, e.g., if the values of the conceptual row are inconsistent, then the error code would be inconsistentValue. NOTE: Other processing of (this and other varbinds of) the set request may result in a response other than noError being returned, e.g., wrongValue, noCreation, etc. Conceptual Row Creation There are four potential interactions when creating a conceptual row: selecting an instance-identifier which is not in use; creating the conceptual row; initializing any objects for which the agent does not supply a default; and, making the conceptual row available for use by the managed device. Interaction 1: Selecting an Instance-Identifier The algorithm used to select an instance-identifier varies for each conceptual row. In some cases, the instance- identifier is semantically significant, e.g., the destination address of a route, and a management station selects the instance-identifier according to the semantics. In other cases, the instance-identifier is used solely to distinguish conceptual rows, and a management station without specific knowledge of the conceptual row might examine the instances present in order to determine an unused instance-identifier. (This approach may be used, but it is often highly sub-optimal; however, it is also a questionable practice for a naive management station to attempt conceptual row creation.) Alternately, the MIB module which defines the conceptual row might provide one or more objects which provide assistance in determining an unused instance-identifier. For example, if the conceptual row is indexed by an integer-value, then an object having an integer-valued SYNTAX clause might be defined for such a purpose, allowing a management station to issue a management protocol retrieval operation. In order to avoid unnecessary collisions between competing management stations, `adjacent' retrievals of this object should be different. Finally, the management station could select a pseudo-random number to use as the index. In the event that this index was already in use and an inconsistentValue was returned in response to the management protocol set operation, the management station should simply select a new pseudo-random number and retry the operation. A MIB designer should choose between the two latter algorithms based on the size of the table (and therefore the efficiency of each algorithm). For tables in which a large number of entries are expected, it is recommended that a MIB object be defined that returns an acceptable index for creation. For tables with small numbers of entries, it is recommended that the latter pseudo-random index mechanism be used. Interaction 2: Creating the Conceptual Row Once an unused instance-identifier has been selected, the management station determines if it wishes to create and activate the conceptual row in one transaction or in a negotiated set of interactions. Interaction 2a: Creating and Activating the Conceptual Row The management station must first determine the column requirements, i.e., it must determine those columns for which it must or must not provide values. Depending on the complexity of the table and the management station's knowledge of the agent's capabilities, this determination can be made locally by the management station. Alternately, the management station issues a management protocol get operation to examine all columns in the conceptual row that it wishes to create. In response, for each column, there are three possible outcomes: - a value is returned, indicating that some other management station has already created this conceptual row. We return to interaction 1. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it should supply a value for this column when the conceptual row is to be created. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. Once the column requirements have been determined, a management protocol set operation is accordingly issued. This operation also sets the new instance of the status column to `createAndGo'. When the agent processes the set operation, it verifies that it has sufficient information to make the conceptual row available for use by the managed device. The information available to the agent is provided by two sources: the management protocol set operation which creates the conceptual row, and, implementation-specific defaults supplied by the agent (note that an agent must provide implementation-specific defaults for at least those objects which it implements as read-only). If there is sufficient information available, then the conceptual row is created, a `noError' response is returned, the status column is set to `active', and no further interactions are necessary (i.e., interactions 3 and 4 are skipped). If there is insufficient information, then the conceptual row is not created, and the set operation fails with an error of `inconsistentValue'. On this error, the management station can issue a management protocol retrieval operation to determine if this was because it failed to specify a value for a required column, or, because the selected instance of the status column already existed. In the latter case, we return to interaction 1. In the former case, the management station can re-issue the set operation with the additional information, or begin interaction 2 again using `createAndWait' in order to negotiate creation of the conceptual row. NOTE WELL Regardless of the method used to determine the column requirements, it is possible that the management station might deem a column necessary when, in fact, the agent will not allow that particular columnar instance to be created or written. In this case, the management protocol set operation will fail with an error such as `noCreation' or `notWritable'. In this case, the management station decides whether it needs to be able to set a value for that particular columnar instance. If not, the management station re-issues the management protocol set operation, but without setting a value for that particular columnar instance; otherwise, the management station aborts the row creation algorithm. Interaction 2b: Negotiating the Creation of the Conceptual Row The management station issues a management protocol set operation which sets the desired instance of the status column to `createAndWait'. If the agent is unwilling to process a request of this sort, the set operation fails with an error of `wrongValue'. (As a consequence, such an agent must be prepared to accept a single management protocol set operation, i.e., interaction 2a above, containing all of the columns indicated by its column requirements.) Otherwise, the conceptual row is created, a `noError' response is returned, and the status column is immediately set to either `notInService' or `notReady', depending on whether it has sufficient information to (attempt to) make the conceptual row available for use by the managed device. If there is sufficient information available, then the status column is set to `notInService'; otherwise, if there is insufficient information, then the status column is set to `notReady'. Regardless, we proceed to interaction 3. Interaction 3: Initializing non-defaulted Objects The management station must now determine the column requirements. It issues a management protocol get operation to examine all columns in the created conceptual row. In the response, for each column, there are three possible outcomes: - a value is returned, indicating that the agent implements the object-type associated with this column and had sufficient information to provide a value. For those columns to which the agent provides read-create access (and for which the agent allows their values to be changed after their creation), a value return tells the management station that it may issue additional management protocol set operations, if it desires, in order to change the value associated with this column. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. However, the agent does not have sufficient information to provide a value, and until a value is provided, the conceptual row may not be made available for use by the managed device. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it must issue additional management protocol set operations, in order to provide a value associated with this column. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. If the value associated with the status column is `notReady', then the management station must first deal with all `noSuchInstance' columns, if any. Having done so, the value of the status column becomes `notInService', and we proceed to interaction 4. Interaction 4: Making the Conceptual Row Available Once the management station is satisfied with the values associated with the columns of the conceptual row, it issues a management protocol set operation to set the status column to `active'. If the agent has sufficient information to make the conceptual row available for use by the managed device, the management protocol set operation succeeds (a `noError' response is returned). Otherwise, the management protocol set operation fails with an error of `inconsistentValue'. NOTE WELL A conceptual row having a status column with value `notInService' or `notReady' is unavailable to the managed device. As such, it is possible for the managed device to create its own instances during the time between the management protocol set operation which sets the status column to `createAndWait' and the management protocol set operation which sets the status column to `active'. In this case, when the management protocol set operation is issued to set the status column to `active', the values held in the agent supersede those used by the managed device. If the management station is prevented from setting the status column to `active' (e.g., due to management station or network failure) the conceptual row will be left in the `notInService' or `notReady' state, consuming resources indefinitely. The agent must detect conceptual rows that have been in either state for an abnormally long period of time and remove them. It is the responsibility of the DESCRIPTION clause of the status column to indicate what an abnormally long period of time would be. This period of time should be long enough to allow for human response time (including `think time') between the creation of the conceptual row and the setting of the status to `active'. In the absence of such information in the DESCRIPTION clause, it is suggested that this period be approximately 5 minutes in length. This removal action applies not only to newly-created rows, but also to previously active rows which are set to, and left in, the notInService state for a prolonged period exceeding that which is considered normal for such a conceptual row. Conceptual Row Suspension When a conceptual row is `active', the management station may issue a management protocol set operation which sets the instance of the status column to `notInService'. If the agent is unwilling to do so, the set operation fails with an error of `wrongValue' or `inconsistentValue'. Otherwise, the conceptual row is taken out of service, and a `noError' response is returned. It is the responsibility of the DESCRIPTION clause of the status column to indicate under what circumstances the status column should be taken out of service (e.g., in order for the value of some other column of the same conceptual row to be modified). Conceptual Row Deletion For deletion of conceptual rows, a management protocol set operation is issued which sets the instance of the status column to `destroy'. This request may be made regardless of the current value of the status column (e.g., it is possible to delete conceptual rows which are either `notReady', `notInService' or `active'.) If the operation succeeds, then all instances associated with the conceptual row are immediately removed. · Integer32

A control that will allow one entry to be added, activated, deactivated, and removed from this table. When the value of this object is 'active' none of the other objects in this conceptual row can be modified. Setting this object to the 'active' state from the 'notInService' state will cause the requested configuration operation to be initiated. Once the requested configuration operation has completed, successfully or otherwise, this leaf will be set to the 'notInService' state by the managed entity. Setting this object to any other valid state from the 'active' state SHOULD cause the managed entity to cancel the requested operation at its earliest most rational opportunity. Setting this object to the 'active' state from the 'active' state SHOULD NOT have any affect. Conceptual rows that have been in the 'notInService' state for more than a device specific time period MAY be destroyed by the managed entity.

Trap details

etsysConfigMgmtReadyNotification

1.3.6.1.4.1.5624.1.2.16.0.1

This notification indicates that the managed entity is running at defaults, has gotten network connectivity via DHCP and is ready to receive configuration.

↑ To TOC