EZ5 MIB Catalog

ENTERASYS-DIAGNOSTIC-MESSAGE-MIB

2003-04-25

This MIB module defines a portion of the SNMP enterprise MIBs under the Enterasys enterprise OID pertaining to the retrieval of diagnostic messages.

Download ENTERASYS-DIAGNOSTIC-MESSAGE-MIB.txt Open ENTERASYS-DIAGNOSTIC-MESSAGE-MIB.txt in a new tab

SCALARS (2) · TABLES (2)

Scalars (2)

NameOID
etsysDiagnosticMessageCount1.3.6.1.4.1.5624.1.2.13.1.1
etsysDiagnosticMessageChanges1.3.6.1.4.1.5624.1.2.13.1.2

Tables (2)

NameOID
etsysDiagnosticMessageTable1.3.6.1.4.1.5624.1.2.13.1.3
etsysDiagnosticMessageDetailsTable1.3.6.1.4.1.5624.1.2.13.2.1

END OF TOC

Scalar details

etsysDiagnosticMessageCount

1.3.6.1.4.1.5624.1.2.13.1.1

Counter32

The number of messages logged on this entity since the beginning of time. This value must be persistent. There should be no facility to clear this value.

etsysDiagnosticMessageChanges

1.3.6.1.4.1.5624.1.2.13.1.2

Counter32

The number of changes to the message log since the last reboot. Changes should include, clearing the message log, deleting a message, and the logging of new messages.

Table details

etsysDiagnosticMessageTable

1.3.6.1.4.1.5624.1.2.13.1.3

Index: etsysDiagnosticMessageIndex

This table lists a summary of the diagnostic messages stored on the managed entity.

etsysDiagnosticMessageIndex

1.3.6.1.4.1.5624.1.2.13.1.3.1.1

Unsigned32 (1..4294967295)

A unique arbitrary identifier for this message. For stateless message log implementations it may be valid only while etsysDiagnosticMessageChanges remains unchanged.

etsysDiagnosticMessageTime

1.3.6.1.4.1.5624.1.2.13.1.3.1.2

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The time and date that this message was stored.

etsysDiagnosticMessageType

1.3.6.1.4.1.5624.1.2.13.1.3.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..32) · OCTET STRING · hint 255t

A description of the type of message shown in this entry.

etsysDiagnosticMessageSummary

1.3.6.1.4.1.5624.1.2.13.1.3.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..64) · OCTET STRING · hint 255t

A brief summary of the diagnostic message.

etsysDiagnosticMessageFWRevision

1.3.6.1.4.1.5624.1.2.13.1.3.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..32) · OCTET STRING · hint 255t

The string representing the version of firmware running on the the managed entity at the time the message was stored.

etsysDiagnosticMessageStatus

1.3.6.1.4.1.5624.1.2.13.1.3.1.6

BITS

A list of attributes associated with this message. Generally these attributes would be considered exceptional, but could potentially be extended to indicate any number of conditions.

etsysDiagnosticMessageDetailsTable

1.3.6.1.4.1.5624.1.2.13.2.1

Index: etsysDiagnosticMessageIndex · etsysDiagnosticMessageDetailsIndex

This table contains the complete diagnostic messages for entries in the etsysDiagnosticMessageSummaryTable. This allows a message of virtually unlimited length to be accessible via SNMP.

etsysDiagnosticMessageDetailsIndex

1.3.6.1.4.1.5624.1.2.13.2.1.1.1

Unsigned32 (1..1024)

A unique arbitrary identifier for this message fragment. Ideally this index should have the values 1 - n, where 'n' is the number of message fragments. It, at a minimum, must be chosen such that the lexicographical ordering will allow the fragments to be assembled in the proper order.

etsysDiagnosticMessageDetailsText

1.3.6.1.4.1.5624.1.2.13.2.1.1.2

LongAdminStringA size extended version of an SnmpAdminString as defined in RFC2571.Reference: RFC2571 (An Architecture for Describing SNMP Management Frameworks) SIZE (0..1024) · OCTET STRING · hint 1024a

The text that makes up a fragment of a message.

etsysDiagnosticMessageDetailsStatus

1.3.6.1.4.1.5624.1.2.13.2.1.1.3

BITS

A list of attributes associated with this message segment.

↑ To TOC