EnabledStatus1 = enabled2 = disabledA simple status value for the object. · Integer32
The current state of the active part of the Flow Limiting feature.
enabled (1) - All aspects of Flow Limiting are operational.
disabled (2) - Flow Limiting is configurable but no actions are taken, no notifications are generated and no interfaces will be disabled. All statistical information is still gathered and available.
When this object is set to disabled the Flow Limiting feature MUST release its control on all interfaces. Any interfaces that had been operationally held in the 'down' state MUST be allowed to attain their currently correct operational state.
Any flows created by the Flow Limiting feature MUST be removed.
Maintaining the value of this object across agent reboots is REQUIRED.
etsysFlowLimitingSystemSnmpNotifications
1.3.6.1.4.1.5624.1.2.43.1.1.2
EnabledStatus1 = enabled2 = disabledA simple status value for the object. · Integer32
The current state of the SNMP Notification functionality in the Flow Limiting feature.
enabled (1) - Flow Limiting will generate SNMP Notifications
for flow counts and setup rates that exceed the configured limits. The Flow Limiting feature MUST be enabled for SNMP Notifications to be generated.
disabled (2) - Flow Limiting will not generate SNMP Notifications under any conditions.
A notification is generated when a value is first detected above its respective configured limit. That notification MUST NOT be generated again until the respective value has transitioned through its respective limit in both directions.
Agents are not required to generate SNMP Notifications for conditions that exist when this object is set to enabled. SNMP Notifications MAY only be generated after additional flow setups are detected that exceed the configured limits on that interface.
Maintaining the value of this object across agent reboots is REQUIRED.
etsysFlowLimitingSystemInterfaceShutdown
1.3.6.1.4.1.5624.1.2.43.1.1.3
EnabledStatus1 = enabled2 = disabledA simple status value for the object. · Integer32
The current state of the interface shutdown functionality in the Flow Limiting feature.
enabled (1) - Flow Limiting will shutdown an interface when
the conditions on that interface exceed the configured values, one of the specified actions is to disable the interface, and the Flow Limiting feature is enabled.
disabled (2) - Flow Limiting will not shutdown any interface under any conditions.
When this object is set to disabled the Flow Limiting feature MUST release its control on all interfaces. Any interfaces that had been operationally held in the 'down' state MUST be allowed to attain their currently correct operational state.
Agents are not required to shutdown interfaces for conditions that exist when this object is set to enabled. Interfaces MAY only be shutdown after additional flow setups are detected that exceed the configured limits on that interface.
Maintaining the value of this object across agent reboots is REQUIRED.
etsysFlowLimitingSystemNotificationInterval
1.3.6.1.4.1.5624.1.2.43.1.1.4
Unsigned32 (0 | 1..4294967295) · seconds
The number of seconds to wait before generating another notification of the same type for the same interface. This allows notification generation to be throttled in the case of a flow counter or rate that is repeatedly transitioning across a threshold. A value of zero indicates that the entity should not suppress any notifications related to the Flow Limiting feature. Maintaining the value of this object across agent reboots is REQUIRED.
etsysFlowLimitingSystemClearStats
1.3.6.1.4.1.5624.1.2.43.1.1.5
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
When set to true(1) the following objects in all rows of the etsysFlowLimitingInterfaceTable MUST be set to zero:
etsysFlowLimitingIntfFlowCountMaxTime etsysFlowLimitingIntfFlowCountEvents
etsysFlowLimitingIntfSetupRateMax etsysFlowLimitingIntfSetupRateMaxTime etsysFlowLimitingIntfSetupRateCurrent etsysFlowLimitingIntfSetupRateEvents
and the etsysFlowLimitingIntfFlowCountMax objects MUST be set to the value of their respective etsysFlowLimitingIntfFlowCountCurrent objects.
Setting this object to false(2) will have no effect. When read this object will always return false(2). Maintaining the value of this object across agent reboots is NOT RECOMMENDED.
etsysFlowLimitingSystemMaxSupportedFlowCount
1.3.6.1.4.1.5624.1.2.43.1.1.6
Unsigned32 · flows
The maximum number of flows supported on this entity.
etsysFlowLimitingSystemMaxSupportedSetupRate
1.3.6.1.4.1.5624.1.2.43.1.1.7
Unsigned32 · flows/second
The maximum flow setup rate supported on this entity.
Table details
etsysFlowLimitingClassTable
1.3.6.1.4.1.5624.1.2.43.1.2.1
Index: etsysFlowLimitingClassType
Provides for the configuration of the Flow Limiting features various interface classes.
Maintaining the value of the objects in this table across agent reboots is REQUIRED.
etsysFlowLimitingClassType
1.3.6.1.4.1.5624.1.2.43.1.2.1.1.1
FlowLmtIntfClass1 = userPort2 = serverPort3 = aggregatedUserPort4 = interSwitchLink5 = unspecifiedThe classes of interfaces, or ports, available under the Flow Limiting feature.
userPort A port with a single user (workstation, PC, etc.) attached to it.
serverPort A port with a server attached to it. This class may encompass a wide range of server types from a small workgroup print server to an enterprise exchange server. Alternately, an administrator may choose to configure an interface with a small print server as a userPort since their flow setup needs may be similar to that of a user port.
aggregatedUserPort A port likely to have multiple end stations attached either through a wireless access point or an unmanaged low cost hub or switch. It is expected that this class may also be used instead of interSwitchLink when switches are interconnected using a lower speed link.
interSwitchLink A port that is used as a high-speed interconnect between two intelligent switches or routers.
Unspecified A port in which nothing can be assumed about its intended use.
These classes are only guides. The classes can be configured with any limits, and any interface can associated with any class. · Integer32
The class of flow limiting controls that this row represents.
etsysFlowLimitingClassFlowCountActionLimit1
1.3.6.1.4.1.5624.1.2.43.1.2.1.1.2
Unsigned32 (0 | 1..4294967295) · flows
When the number of active flows on an associated interface reaches this level the Flow Limiting feature will invoke the action(s) specified by the etsysFlowLimitingClassFlowCountActionTaken1 object. A value of zero indicates that this limit is disabled. While this limit is disabled the associated action MUST NOT be taken.
etsysFlowLimitingClassFlowCountActionTaken1
1.3.6.1.4.1.5624.1.2.43.1.2.1.1.3
FlowLmtIntfActionThe possible actions that the Flow Limiting feature can take when flow activity exceeds the associated action limits.
generateNotification(0) - Generate the respective SNMP notification.
dropExcessFlows(1) - Drop flow setup requests in excess of the configured limit and discard the associated packets. The use of this option could cause the entity to repetitively process setup requests for the dropped flows. The process of dropping flow setup requests and their associated packets could cause end stations attached to this interface to behave in an indeterminate manner. The use of this option may also prevent the entity from being able to count additional flows and from reaching any additional configured limit.
createDiscardFlows(2) - Create discard flows and discard the associated packets. The use of this option could cause end stations attached to this interface to behave in an indeterminate manner.
disableInterface(3) - Operationally disable the interface, ifOperStatus for the interface MUST go into the 'down' state, and MUST remain in that state until the associated etsysFlowLimitingIntfStatus is set to operational, the Flow Limiting feature is disabled, or the entity is reset. - When applied to a user, as specified in etsysFlowLimitingUserTable, the individual user is disabled, while the interface that user is bound to remains operational.
The 'generateNotification(0)' will always be performed if it is a selected action, is globally enabled, and does not exceed the global rate limit for such notifications. It MUST be generated in such a way that the information in the notification indicates the condition on the interface after any other indicated action has been taken. If one or more other actions are selected only the one with the highest precedence will be taken. The order of precedence, from highest to lowest, of the actions are 'disableInterface', 'createDiscardFlows', and finally 'dropExcessFlows'. If etsysFlowLimitingSystemInterfaceShutdown is disabled the selected action with the next highest precedence will be taken. · BITS
The action(s) to be taken on an associated interface when the number of active flows on that interface reach the value of etsysFlowLimitingClassFlowCountActionLimit1.
etsysFlowLimitingClassFlowCountActionLimit2
1.3.6.1.4.1.5624.1.2.43.1.2.1.1.4
Unsigned32 (0 | 1..4294967295) · flows
When the number of active flows on an associated interface reaches this level the Flow Limiting feature will invoke the action(s) specified by the etsysFlowLimitingClassFlowCountActionTaken2 object. A value of zero indicates that this limit is disabled. While this limit is disabled the associated action MUST NOT be taken.
etsysFlowLimitingClassFlowCountActionTaken2
1.3.6.1.4.1.5624.1.2.43.1.2.1.1.5
FlowLmtIntfActionThe possible actions that the Flow Limiting feature can take when flow activity exceeds the associated action limits.
generateNotification(0) - Generate the respective SNMP notification.
dropExcessFlows(1) - Drop flow setup requests in excess of the configured limit and discard the associated packets. The use of this option could cause the entity to repetitively process setup requests for the dropped flows. The process of dropping flow setup requests and their associated packets could cause end stations attached to this interface to behave in an indeterminate manner. The use of this option may also prevent the entity from being able to count additional flows and from reaching any additional configured limit.
createDiscardFlows(2) - Create discard flows and discard the associated packets. The use of this option could cause end stations attached to this interface to behave in an indeterminate manner.
disableInterface(3) - Operationally disable the interface, ifOperStatus for the interface MUST go into the 'down' state, and MUST remain in that state until the associated etsysFlowLimitingIntfStatus is set to operational, the Flow Limiting feature is disabled, or the entity is reset. - When applied to a user, as specified in etsysFlowLimitingUserTable, the individual user is disabled, while the interface that user is bound to remains operational.
The 'generateNotification(0)' will always be performed if it is a selected action, is globally enabled, and does not exceed the global rate limit for such notifications. It MUST be generated in such a way that the information in the notification indicates the condition on the interface after any other indicated action has been taken. If one or more other actions are selected only the one with the highest precedence will be taken. The order of precedence, from highest to lowest, of the actions are 'disableInterface', 'createDiscardFlows', and finally 'dropExcessFlows'. If etsysFlowLimitingSystemInterfaceShutdown is disabled the selected action with the next highest precedence will be taken. · BITS
The action(s) to be taken on an associated interface when the number of active flows on that interface reach the value of etsysFlowLimitingClassFlowCountActionLimit2.
etsysFlowLimitingClassSetupRateNotifyLimit
1.3.6.1.4.1.5624.1.2.43.1.2.1.1.6
Unsigned32 (0 | 1..4294967295) · flows/second
The flow setup rate on an associated interface at which the Flow Limiting feature will generate an etsysFlowlimitingSetupRateNotifyLimit notification. A value of zero indicates that this limit is disabled. While this limit is disabled the associated notification MUST NOT be generated.
etsysFlowLimitingClassSetupRateActionLimit
1.3.6.1.4.1.5624.1.2.43.1.2.1.1.7
Unsigned32 (0 | 1..4294967295) · flows/second
The flow setup rate on an associated interface at which the Flow Limiting feature will invoke the action(s) specified by the etsysFlowLimitingClassSetupRateActionTaken object. A value of zero indicates that this limit is disabled. While this limit is disabled the associated action MUST NOT be taken.
etsysFlowLimitingClassSetupRateActionTaken
1.3.6.1.4.1.5624.1.2.43.1.2.1.1.8
FlowLmtIntfActionThe possible actions that the Flow Limiting feature can take when flow activity exceeds the associated action limits.
generateNotification(0) - Generate the respective SNMP notification.
dropExcessFlows(1) - Drop flow setup requests in excess of the configured limit and discard the associated packets. The use of this option could cause the entity to repetitively process setup requests for the dropped flows. The process of dropping flow setup requests and their associated packets could cause end stations attached to this interface to behave in an indeterminate manner. The use of this option may also prevent the entity from being able to count additional flows and from reaching any additional configured limit.
createDiscardFlows(2) - Create discard flows and discard the associated packets. The use of this option could cause end stations attached to this interface to behave in an indeterminate manner.
disableInterface(3) - Operationally disable the interface, ifOperStatus for the interface MUST go into the 'down' state, and MUST remain in that state until the associated etsysFlowLimitingIntfStatus is set to operational, the Flow Limiting feature is disabled, or the entity is reset. - When applied to a user, as specified in etsysFlowLimitingUserTable, the individual user is disabled, while the interface that user is bound to remains operational.
The 'generateNotification(0)' will always be performed if it is a selected action, is globally enabled, and does not exceed the global rate limit for such notifications. It MUST be generated in such a way that the information in the notification indicates the condition on the interface after any other indicated action has been taken. If one or more other actions are selected only the one with the highest precedence will be taken. The order of precedence, from highest to lowest, of the actions are 'disableInterface', 'createDiscardFlows', and finally 'dropExcessFlows'. If etsysFlowLimitingSystemInterfaceShutdown is disabled the selected action with the next highest precedence will be taken. · BITS
The action(s) to be taken on an associated interface when the flow setup rate on that interface reaches the value of the etsysFlowLimitingClassSetupRateActionLimit object.
etsysFlowLimitingInterfaceTable
1.3.6.1.4.1.5624.1.2.43.1.3.1
Index: ifIndex
A table that provides for the configuration, status, and statistics related to, the Flow Limiting feature on a per interface basis.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.
etsysFlowLimitingIntfClassType
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.1
FlowLmtIntfClass1 = userPort2 = serverPort3 = aggregatedUserPort4 = interSwitchLink5 = unspecifiedThe classes of interfaces, or ports, available under the Flow Limiting feature.
userPort A port with a single user (workstation, PC, etc.) attached to it.
serverPort A port with a server attached to it. This class may encompass a wide range of server types from a small workgroup print server to an enterprise exchange server. Alternately, an administrator may choose to configure an interface with a small print server as a userPort since their flow setup needs may be similar to that of a user port.
aggregatedUserPort A port likely to have multiple end stations attached either through a wireless access point or an unmanaged low cost hub or switch. It is expected that this class may also be used instead of interSwitchLink when switches are interconnected using a lower speed link.
interSwitchLink A port that is used as a high-speed interconnect between two intelligent switches or routers.
Unspecified A port in which nothing can be assumed about its intended use.
These classes are only guides. The classes can be configured with any limits, and any interface can associated with any class. · Integer32
The Flow Limiting interface class associated with this interface. The class defines the flow limits and actions to be taken when those limits are exceeded.
When the value of this object changes and flow limiting is currently enabled, both globally and on this interface, the agent MUST perform the following steps prior to enforcing the new limits:
1) If the interface had been operationally held in the 'down'
state due to prior flow conditions it MUST be allowed to attain its currently correct operational state.
2) Any flows created by the Flow Limiting feature for this
interface must be removed.
3) The respective etsysFlowLimitingIntfFlowCountEvents and
etsysFlowLimitingIntfSetupRateEvents objects MUST be set to zero.
4) etsysFlowLimitingIntfStatus and etsysFlowLimitingIntfReason
MUST be set to operational(1) and noAction(1) respectively.
Maintaining the value of this object across agent reboots is REQUIRED.
etsysFlowLimitingIntfFlowLimitingState
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.2
EnabledStatus1 = enabled2 = disabledA simple status value for the object. · Integer32
The enable state of Flow Limiting on this interface.
Setting this object to disabled(2) will disable the active part of the Flow Limiting feature as defined for the etsysFlowLimitingSystemState object on this interface.
When the value of this object changes from enabled(1) to disabled(2) the agent MUST:
1) Release its control on this interface. If it had
been operationally held in the 'down' state it MUST be allowed to attain its currently correct operational state.
2) Remove any flows created by the Flow Limiting feature
for this interface.
3) The respective etsysFlowLimitingIntfFlowCountEvents and
etsysFlowLimitingIntfSetupRateEvents objects MUST be set to zero.
4) etsysFlowLimitingIntfStatus and etsysFlowLimitingIntfReason
MUST be set to operational(1) and noAction(1) respectively.
Maintaining the value of this object across agent reboots is REQUIRED.
The current status of the interface with respect to Flow Limiting.
A read of operational(1) indicates that the Flow Limiting feature has not taken any action to operationally limit this interface.
A read of disabled(2) indicates that the Flow Limiting feature has taken action to operationally disable this interface due to exceeding the flow limits configured.
A read of droppingExcessFlows(3) indicates that this interface that no new flows will be created on this interface in excess of the of the flow limits specified.
A read of creatingDiscardFlows(4) indicates that this interface indicates that any flows in excess of the specified limits for this interface will be created as discard flows.
Setting this object to operational(1) when it is disabled(2) will cause Flow Limiting to release it's control that is keeping this interface operationally disabled. Any other write of this object will have no effect.
Maintaining the value of this object across agent reboots is NOT RECOMMENDED.
The reason the last action was taken on this interface by the Flow Limiting feature. Maintaining the value of this object across agent reboots is NOT RECOMMENDED.
etsysFlowLimitingIntfClearStats
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.5
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
When set to true(1) the following objects in this row MUST be set to zero:
etsysFlowLimitingIntfFlowCountMaxTime etsysFlowLimitingIntfFlowCountEvents
etsysFlowLimitingIntfSetupRateMax etsysFlowLimitingIntfSetupRateMaxTime etsysFlowLimitingIntfSetupRateCurrent etsysFlowLimitingIntfSetupRateEvents
and the etsysFlowLimitingIntfFlowCountMax object MUST be set to the value of the etsysFlowLimitingIntfFlowCountCurrent object.
Setting this object to false(2) will have no effect. When read this object will always return false(2).
etsysFlowLimitingIntfFlowCountCurrent
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.6
Gauge32 · flows
The current number of flows active on this interface. This information is always available and current.
etsysFlowLimitingIntfFlowCountMax
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.7
Gauge32 · flows
The maximum number of flows that have been active on this interface since the last agent reset. This information is always available and current.
etsysFlowLimitingIntfFlowCountMaxTime
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.8
TimeTicks
The TimeTicks since the maximum number of flows was recorded. This information is always available and current.
etsysFlowLimitingIntfFlowCountEvents
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.9
Gauge32
The number of times that the number of flows on this interface exceeded any associated limit.
etsysFlowLimitingIntfSetupRateCurrent
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.10
Gauge32 · flows/second
The current flow setup rate on this interface. This information is always available and current.
etsysFlowLimitingIntfSetupRateMax
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.11
Gauge32 · flows/second
The maximum flow setup rate on this interface since the last agent reset. This information is always available and current.
etsysFlowLimitingIntfSetupRateMaxTime
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.12
TimeTicks
The TimeTicks since the maximum flow setup rate was recorded. This information is always available and current.
etsysFlowLimitingIntfSetupRateEvents
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.13
Gauge32
The number of times that the setup rate on this interface exceeded any associated limit.
etsysFlowLimitingIntfFlowProcessingLayer
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.14
FlowLmtIntfLayer1 = none2 = l23 = l34 = l4A shorthand listing of OSI layers that may be used in processing flows on an interface. · Integer32
The highest OSI layer at which flows are processed. This is used to give an indication of how much detail is contained in the flows created on the interface. An interface reporting that flows being processed at L4 will create flows that have information from L2, L3, and L4. In general, interfaces reporting processing at L4 would be expected to have a higher number of flows than interfaces reporting processing at L2 assuming all else equal.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.
StationAddressType0 = unknown1 = ipv42 = ipv63 = mac16 = dnsA value representing a network address that can be used to identify a station on the network.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding StationAddress object is a zero-length string. It may also be used to indicate an station address which is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention as defined in RFC3291.
ipv6(2) An IPv6 address as defined by the
StationAddressIPv6 textual convention below.
mac(3) An 802.3 MAC layer address, i.e. an
Ethernet address, defined by the MacAddress textual convention as defined in RFC2579.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention as defined in RFC3291.
Each definition of a concrete StationAddressType value must be accompanied by a definition of a textual convention for use with that StationAddressType.
The StationAddressType textual convention SHOULD NOT be subtyped in object type definitions to support future extensions. It MAY be subtyped in compliance statements in order to require only a subset of these address types for a compliant implementation.Reference: STD0058 (RFC2579), Textual Conventions for SMIv2. RFC3291, Textual Conventions for Internet Network Addresses. · Integer32
The type of station represented by etsysMultiAuthStationAddr.
etsysMultiAuthStationAddr
StationAddressDenotes a generic Internet address.
An StationAddress value is always interpreted within the context of an StationAddressType value. Every usage of the StationAddress textual convention is required to specify the StationAddressType object which provides the context. It is suggested that the StationAddressType object is logically registered before the object(s) which use the StationAddress textual convention if they appear in the same logical row.
The value of an StationAddress object must always be consistent with the value of the associated StationAddressType object. Attempts to set an StationAddress object to a value which is inconsistent with the associated StationAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers. SIZE (0..255) · OCTET STRING
The station address for the authenticated user.
etsysFlowLimitingUserClassType
1.3.6.1.4.1.5624.1.2.43.1.4.1.1.1
FlowLmtIntfClass1 = userPort2 = serverPort3 = aggregatedUserPort4 = interSwitchLink5 = unspecifiedThe classes of interfaces, or ports, available under the Flow Limiting feature.
userPort A port with a single user (workstation, PC, etc.) attached to it.
serverPort A port with a server attached to it. This class may encompass a wide range of server types from a small workgroup print server to an enterprise exchange server. Alternately, an administrator may choose to configure an interface with a small print server as a userPort since their flow setup needs may be similar to that of a user port.
aggregatedUserPort A port likely to have multiple end stations attached either through a wireless access point or an unmanaged low cost hub or switch. It is expected that this class may also be used instead of interSwitchLink when switches are interconnected using a lower speed link.
interSwitchLink A port that is used as a high-speed interconnect between two intelligent switches or routers.
Unspecified A port in which nothing can be assumed about its intended use.
These classes are only guides. The classes can be configured with any limits, and any interface can associated with any class. · Integer32
The Flow Limiting interface class associated with this interface. The class defines the flow limits and actions to be taken when those limits are exceeded.
The current status of the user with respect to Flow Limiting.
A value of operational(1) indicates that the Flow Limiting feature has not taken any action to operationally limit this user's creation of new flows.
A value of disabled(2) indicates that the Flow Limiting feature has taken action to operationally disable this user as a result of exceeding the flow limits configured.
A value of droppingExcessFlows(3) indicates that no new flows for this user will be created in excess of the of the flow limits specified.
A read of creatingDiscardFlows(4) indicates that any flows in excess of the specified limits for this user will be created as discard flows.
The reason the last action was taken on this interface by the Flow Limiting feature. Maintaining the value of this object across agent reboots is NOT RECOMMENDED.
etsysFlowLimitingUserFlowCountCurrent
1.3.6.1.4.1.5624.1.2.43.1.4.1.1.4
Gauge32 · flows
The current number of flows active for this user. This information is always available and current.
etsysFlowLimitingUserFlowCountMax
1.3.6.1.4.1.5624.1.2.43.1.4.1.1.5
Gauge32 · flows
The greatest number of of simultaneous flows that have been active on this interface since the user authenticated. This information is always available and current.
etsysFlowLimitingUserFlowCountMaxTime
1.3.6.1.4.1.5624.1.2.43.1.4.1.1.6
TimeTicks
The TimeTicks since the etsysFlowLimitingUserFlowCountMax was recorded. This information is always available and current.
etsysFlowLimitingUserFlowCountEvents
1.3.6.1.4.1.5624.1.2.43.1.4.1.1.7
Gauge32
The number of times that the number of flows on this interface exceeded any associated limit.
Trap details
etsysFlowlimitingFlowCountActionLimit1
1.3.6.1.4.1.5624.1.2.43.1.0.1
An etsysFlowlimitingFlowCountActionLimit1 notification indicates that the number of flows on the interface has exceeded the currently configured limit in the associated etsysFlowLimitingClassFlowCountActionLimit1 for the interface.
The current status of the interface with respect to Flow Limiting.
A read of operational(1) indicates that the Flow Limiting feature has not taken any action to operationally limit this interface.
A read of disabled(2) indicates that the Flow Limiting feature has taken action to operationally disable this interface due to exceeding the flow limits configured.
A read of droppingExcessFlows(3) indicates that this interface that no new flows will be created on this interface in excess of the of the flow limits specified.
A read of creatingDiscardFlows(4) indicates that this interface indicates that any flows in excess of the specified limits for this interface will be created as discard flows.
Setting this object to operational(1) when it is disabled(2) will cause Flow Limiting to release it's control that is keeping this interface operationally disabled. Any other write of this object will have no effect.
Maintaining the value of this object across agent reboots is NOT RECOMMENDED.
etsysFlowLimitingIntfFlowCountCurrent
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.6
Gauge32 · flows
The current number of flows active on this interface. This information is always available and current.
etsysFlowlimitingFlowCountActionLimit2
1.3.6.1.4.1.5624.1.2.43.1.0.2
An etsysFlowlimitingFlowCountActionLimit2 notification indicates that the number of flows on the interface has exceeded the currently configured limit in the associated etsysFlowLimitingClassFlowCountActionLimit2 for the interface.
The current status of the interface with respect to Flow Limiting.
A read of operational(1) indicates that the Flow Limiting feature has not taken any action to operationally limit this interface.
A read of disabled(2) indicates that the Flow Limiting feature has taken action to operationally disable this interface due to exceeding the flow limits configured.
A read of droppingExcessFlows(3) indicates that this interface that no new flows will be created on this interface in excess of the of the flow limits specified.
A read of creatingDiscardFlows(4) indicates that this interface indicates that any flows in excess of the specified limits for this interface will be created as discard flows.
Setting this object to operational(1) when it is disabled(2) will cause Flow Limiting to release it's control that is keeping this interface operationally disabled. Any other write of this object will have no effect.
Maintaining the value of this object across agent reboots is NOT RECOMMENDED.
etsysFlowLimitingIntfFlowCountCurrent
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.6
Gauge32 · flows
The current number of flows active on this interface. This information is always available and current.
etsysFlowLimitingSetupRateNotifyLimit
1.3.6.1.4.1.5624.1.2.43.1.0.3
An etsysFlowLimitingSetupRateNotifyLimit notification indicates that the flow setup rate on the interface has exceeded the currently configured limit for generating a notification.
etsysFlowLimitingIntfSetupRateCurrent
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.10
Gauge32 · flows/second
The current flow setup rate on this interface. This information is always available and current.
etsysFlowLimitingSetupRateActionLimit
1.3.6.1.4.1.5624.1.2.43.1.0.4
An etsysFlowLimitingSetupRateExceeded notification indicates that the flow setup rate on the interface has exceeded the currently configured limit for taking an action.
The current status of the interface with respect to Flow Limiting.
A read of operational(1) indicates that the Flow Limiting feature has not taken any action to operationally limit this interface.
A read of disabled(2) indicates that the Flow Limiting feature has taken action to operationally disable this interface due to exceeding the flow limits configured.
A read of droppingExcessFlows(3) indicates that this interface that no new flows will be created on this interface in excess of the of the flow limits specified.
A read of creatingDiscardFlows(4) indicates that this interface indicates that any flows in excess of the specified limits for this interface will be created as discard flows.
Setting this object to operational(1) when it is disabled(2) will cause Flow Limiting to release it's control that is keeping this interface operationally disabled. Any other write of this object will have no effect.
Maintaining the value of this object across agent reboots is NOT RECOMMENDED.
etsysFlowLimitingIntfSetupRateCurrent
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.10
Gauge32 · flows/second
The current flow setup rate on this interface. This information is always available and current.
etsysFlowlimitingFlowCountActionLimit1V2
1.3.6.1.4.1.5624.1.2.43.1.0.5
An etsysFlowlimitingFlowCountActionLimit1 notification indicates that the number of flows on the interface has exceeded the currently configured limit in the associated etsysFlowLimitingClassFlowCountActionLimit1 for the interface.
ifName
1.3.6.1.2.1.31.1.1.1.1
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The textual name of the interface. The value of this object should be the name of the interface as assigned by the local device and should be suitable for use in commands entered at the device's `console'. This might be a text name, such as `le0' or a simple port number, such as `1', depending on the interface naming syntax of the device. If several entries in the ifTable together represent a single interface as named by the device, then each will have the same value of ifName. Note that for an agent which responds to SNMP queries concerning an interface on some other (proxied) device, then the value of ifName for such an interface is the proxied device's local name for it.
If there is no local name, or this object is otherwise not applicable, then this object contains a zero-length string.
The current status of the interface with respect to Flow Limiting.
A read of operational(1) indicates that the Flow Limiting feature has not taken any action to operationally limit this interface.
A read of disabled(2) indicates that the Flow Limiting feature has taken action to operationally disable this interface due to exceeding the flow limits configured.
A read of droppingExcessFlows(3) indicates that this interface that no new flows will be created on this interface in excess of the of the flow limits specified.
A read of creatingDiscardFlows(4) indicates that this interface indicates that any flows in excess of the specified limits for this interface will be created as discard flows.
Setting this object to operational(1) when it is disabled(2) will cause Flow Limiting to release it's control that is keeping this interface operationally disabled. Any other write of this object will have no effect.
Maintaining the value of this object across agent reboots is NOT RECOMMENDED.
etsysFlowLimitingIntfFlowCountCurrent
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.6
Gauge32 · flows
The current number of flows active on this interface. This information is always available and current.
etsysFlowlimitingFlowCountActionLimit2V2
1.3.6.1.4.1.5624.1.2.43.1.0.6
An etsysFlowlimitingFlowCountActionLimit2 notification indicates that the number of flows on the interface has exceeded the currently configured limit in the associated etsysFlowLimitingClassFlowCountActionLimit2 for the interface.
ifName
1.3.6.1.2.1.31.1.1.1.1
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The textual name of the interface. The value of this object should be the name of the interface as assigned by the local device and should be suitable for use in commands entered at the device's `console'. This might be a text name, such as `le0' or a simple port number, such as `1', depending on the interface naming syntax of the device. If several entries in the ifTable together represent a single interface as named by the device, then each will have the same value of ifName. Note that for an agent which responds to SNMP queries concerning an interface on some other (proxied) device, then the value of ifName for such an interface is the proxied device's local name for it.
If there is no local name, or this object is otherwise not applicable, then this object contains a zero-length string.
The current status of the interface with respect to Flow Limiting.
A read of operational(1) indicates that the Flow Limiting feature has not taken any action to operationally limit this interface.
A read of disabled(2) indicates that the Flow Limiting feature has taken action to operationally disable this interface due to exceeding the flow limits configured.
A read of droppingExcessFlows(3) indicates that this interface that no new flows will be created on this interface in excess of the of the flow limits specified.
A read of creatingDiscardFlows(4) indicates that this interface indicates that any flows in excess of the specified limits for this interface will be created as discard flows.
Setting this object to operational(1) when it is disabled(2) will cause Flow Limiting to release it's control that is keeping this interface operationally disabled. Any other write of this object will have no effect.
Maintaining the value of this object across agent reboots is NOT RECOMMENDED.
etsysFlowLimitingIntfFlowCountCurrent
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.6
Gauge32 · flows
The current number of flows active on this interface. This information is always available and current.
etsysFlowLimitingSetupRateNotifyLimitV2
1.3.6.1.4.1.5624.1.2.43.1.0.7
An etsysFlowLimitingSetupRateNotifyLimit notification indicates that the flow setup rate on the interface has exceeded the currently configured limit for generating a notification.
ifName
1.3.6.1.2.1.31.1.1.1.1
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The textual name of the interface. The value of this object should be the name of the interface as assigned by the local device and should be suitable for use in commands entered at the device's `console'. This might be a text name, such as `le0' or a simple port number, such as `1', depending on the interface naming syntax of the device. If several entries in the ifTable together represent a single interface as named by the device, then each will have the same value of ifName. Note that for an agent which responds to SNMP queries concerning an interface on some other (proxied) device, then the value of ifName for such an interface is the proxied device's local name for it.
If there is no local name, or this object is otherwise not applicable, then this object contains a zero-length string.
etsysFlowLimitingIntfSetupRateCurrent
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.10
Gauge32 · flows/second
The current flow setup rate on this interface. This information is always available and current.
etsysFlowLimitingSetupRateActionLimitV2
1.3.6.1.4.1.5624.1.2.43.1.0.8
An etsysFlowLimitingSetupRateExceeded notification indicates that the flow setup rate on the interface has exceeded the currently configured limit for taking an action.
ifName
1.3.6.1.2.1.31.1.1.1.1
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The textual name of the interface. The value of this object should be the name of the interface as assigned by the local device and should be suitable for use in commands entered at the device's `console'. This might be a text name, such as `le0' or a simple port number, such as `1', depending on the interface naming syntax of the device. If several entries in the ifTable together represent a single interface as named by the device, then each will have the same value of ifName. Note that for an agent which responds to SNMP queries concerning an interface on some other (proxied) device, then the value of ifName for such an interface is the proxied device's local name for it.
If there is no local name, or this object is otherwise not applicable, then this object contains a zero-length string.
The current status of the interface with respect to Flow Limiting.
A read of operational(1) indicates that the Flow Limiting feature has not taken any action to operationally limit this interface.
A read of disabled(2) indicates that the Flow Limiting feature has taken action to operationally disable this interface due to exceeding the flow limits configured.
A read of droppingExcessFlows(3) indicates that this interface that no new flows will be created on this interface in excess of the of the flow limits specified.
A read of creatingDiscardFlows(4) indicates that this interface indicates that any flows in excess of the specified limits for this interface will be created as discard flows.
Setting this object to operational(1) when it is disabled(2) will cause Flow Limiting to release it's control that is keeping this interface operationally disabled. Any other write of this object will have no effect.
Maintaining the value of this object across agent reboots is NOT RECOMMENDED.
etsysFlowLimitingIntfSetupRateCurrent
1.3.6.1.4.1.5624.1.2.43.1.3.1.1.10
Gauge32 · flows/second
The current flow setup rate on this interface. This information is always available and current.
etsysFlowlimitingFlowCountLimit1User
1.3.6.1.4.1.5624.1.2.43.1.0.9
An etsysFlowlimitingFlowCountLimit1User notification indicates that the number of flows for the user has exceeded the currently configured limit in the associated etsysFlowLimitingClassFlowCountActionLimit1 for the user.
ifName
1.3.6.1.2.1.31.1.1.1.1
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The textual name of the interface. The value of this object should be the name of the interface as assigned by the local device and should be suitable for use in commands entered at the device's `console'. This might be a text name, such as `le0' or a simple port number, such as `1', depending on the interface naming syntax of the device. If several entries in the ifTable together represent a single interface as named by the device, then each will have the same value of ifName. Note that for an agent which responds to SNMP queries concerning an interface on some other (proxied) device, then the value of ifName for such an interface is the proxied device's local name for it.
If there is no local name, or this object is otherwise not applicable, then this object contains a zero-length string.
etsysMultiAuthStationAddrType
1.3.6.1.4.1.5624.1.2.46.1.3.1.1.1
StationAddressType0 = unknown1 = ipv42 = ipv63 = mac16 = dnsA value representing a network address that can be used to identify a station on the network.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding StationAddress object is a zero-length string. It may also be used to indicate an station address which is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention as defined in RFC3291.
ipv6(2) An IPv6 address as defined by the
StationAddressIPv6 textual convention below.
mac(3) An 802.3 MAC layer address, i.e. an
Ethernet address, defined by the MacAddress textual convention as defined in RFC2579.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention as defined in RFC3291.
Each definition of a concrete StationAddressType value must be accompanied by a definition of a textual convention for use with that StationAddressType.
The StationAddressType textual convention SHOULD NOT be subtyped in object type definitions to support future extensions. It MAY be subtyped in compliance statements in order to require only a subset of these address types for a compliant implementation.Reference: STD0058 (RFC2579), Textual Conventions for SMIv2. RFC3291, Textual Conventions for Internet Network Addresses. · Integer32
The type of station represented by etsysMultiAuthStationAddr.
etsysMultiAuthStationAddr
1.3.6.1.4.1.5624.1.2.46.1.3.1.1.2
StationAddressDenotes a generic Internet address.
An StationAddress value is always interpreted within the context of an StationAddressType value. Every usage of the StationAddress textual convention is required to specify the StationAddressType object which provides the context. It is suggested that the StationAddressType object is logically registered before the object(s) which use the StationAddress textual convention if they appear in the same logical row.
The value of an StationAddress object must always be consistent with the value of the associated StationAddressType object. Attempts to set an StationAddress object to a value which is inconsistent with the associated StationAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers. SIZE (0..255) · OCTET STRING
The current status of the user with respect to Flow Limiting.
A value of operational(1) indicates that the Flow Limiting feature has not taken any action to operationally limit this user's creation of new flows.
A value of disabled(2) indicates that the Flow Limiting feature has taken action to operationally disable this user as a result of exceeding the flow limits configured.
A value of droppingExcessFlows(3) indicates that no new flows for this user will be created in excess of the of the flow limits specified.
A read of creatingDiscardFlows(4) indicates that any flows in excess of the specified limits for this user will be created as discard flows.
etsysFlowLimitingUserFlowCountCurrent
1.3.6.1.4.1.5624.1.2.43.1.4.1.1.4
Gauge32 · flows
The current number of flows active for this user. This information is always available and current.
etsysFlowlimitingFlowCountLimit2User
1.3.6.1.4.1.5624.1.2.43.1.0.10
An etsysFlowlimitingFlowCountLimit2User notification indicates that the number of flows for the user has exceeded the currently configured limit in the associated etsysFlowLimitingClassFlowCountActionLimit2 for the user.
ifName
1.3.6.1.2.1.31.1.1.1.1
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The textual name of the interface. The value of this object should be the name of the interface as assigned by the local device and should be suitable for use in commands entered at the device's `console'. This might be a text name, such as `le0' or a simple port number, such as `1', depending on the interface naming syntax of the device. If several entries in the ifTable together represent a single interface as named by the device, then each will have the same value of ifName. Note that for an agent which responds to SNMP queries concerning an interface on some other (proxied) device, then the value of ifName for such an interface is the proxied device's local name for it.
If there is no local name, or this object is otherwise not applicable, then this object contains a zero-length string.
etsysMultiAuthStationAddrType
1.3.6.1.4.1.5624.1.2.46.1.3.1.1.1
StationAddressType0 = unknown1 = ipv42 = ipv63 = mac16 = dnsA value representing a network address that can be used to identify a station on the network.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding StationAddress object is a zero-length string. It may also be used to indicate an station address which is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention as defined in RFC3291.
ipv6(2) An IPv6 address as defined by the
StationAddressIPv6 textual convention below.
mac(3) An 802.3 MAC layer address, i.e. an
Ethernet address, defined by the MacAddress textual convention as defined in RFC2579.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention as defined in RFC3291.
Each definition of a concrete StationAddressType value must be accompanied by a definition of a textual convention for use with that StationAddressType.
The StationAddressType textual convention SHOULD NOT be subtyped in object type definitions to support future extensions. It MAY be subtyped in compliance statements in order to require only a subset of these address types for a compliant implementation.Reference: STD0058 (RFC2579), Textual Conventions for SMIv2. RFC3291, Textual Conventions for Internet Network Addresses. · Integer32
The type of station represented by etsysMultiAuthStationAddr.
etsysMultiAuthStationAddr
1.3.6.1.4.1.5624.1.2.46.1.3.1.1.2
StationAddressDenotes a generic Internet address.
An StationAddress value is always interpreted within the context of an StationAddressType value. Every usage of the StationAddress textual convention is required to specify the StationAddressType object which provides the context. It is suggested that the StationAddressType object is logically registered before the object(s) which use the StationAddress textual convention if they appear in the same logical row.
The value of an StationAddress object must always be consistent with the value of the associated StationAddressType object. Attempts to set an StationAddress object to a value which is inconsistent with the associated StationAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers. SIZE (0..255) · OCTET STRING
The current status of the user with respect to Flow Limiting.
A value of operational(1) indicates that the Flow Limiting feature has not taken any action to operationally limit this user's creation of new flows.
A value of disabled(2) indicates that the Flow Limiting feature has taken action to operationally disable this user as a result of exceeding the flow limits configured.
A value of droppingExcessFlows(3) indicates that no new flows for this user will be created in excess of the of the flow limits specified.
A read of creatingDiscardFlows(4) indicates that any flows in excess of the specified limits for this user will be created as discard flows.
etsysFlowLimitingUserFlowCountCurrent
1.3.6.1.4.1.5624.1.2.43.1.4.1.1.4
Gauge32 · flows
The current number of flows active for this user. This information is always available and current.