This MIB module defines a portion of the SNMP MIB under the Enterasys Networks enterprise OID pertaining to the PIM configuration.
This MIB was designed to be used in conjunction with the PIM-MIB (RFC 5060) for configuring the PIM protocol parameters. Additional statistical tables are provided for monitoring the PIM protocol.
This table provides additional information pertaining to PIM interfaces for Enterasys PIM systems. This table augments the pimInterfaceTable from RFC 5060.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The ifIndex value of this PIM interface.
pimInterfaceIPVersion
InetVersion0 = unknown1 = ipv42 = ipv6A value representing a version of the IP protocol.
unknown(0) An unknown or unspecified version of the IP
protocol.
ipv4(1) The IPv4 protocol as defined in RFC 791 (STD 5).
ipv6(2) The IPv6 protocol as defined in RFC 2460.
Note that this textual convention SHOULD NOT be used to distinguish different address types associated with IP protocols. The InetAddressType has been designed for this purpose.Reference: RFC 791, RFC 2460 · Integer32
The IP version of this PIM interface. A physical interface may be configured in multiple modes concurrently, e.g., IPv4 and IPv6; however, the traffic is considered to be logically separate.
The administrative state of PIM on this interface.
When the status of this object is set to 'adminStatusDown', no PIM messages will be sent or received on this interface. The TIB state pertaining to this interface is cleared, resulting in the removal of the associated routes from the MFIB.
When the status of this object is set to 'adminStatusUp', normal PIM operation will proceed, and multicast state is stored in the TIB when it is learned.
The current operational state of PIM on this interface.
etsysPimExtIfP2PNoHellos
1.3.6.1.4.1.5624.1.2.67.1.2.1.1.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Indicates whether this interface is a point-to-point interface.
If the value of this object is 'true', neighbors are not required to send PIM-Hello messages. This is provided for backward-compatibility with some older implementations that do not send PIM-Hellos on point-to-point links.
Changing the value of this object while the interface is operationally active MAY cause the interface to be deactivated and then reactivated.
etsysPimExtIfNeighborCount
1.3.6.1.4.1.5624.1.2.67.1.2.1.1.4
Gauge32
The number of PIM neighbors on this interface.
etsysPimExtIfStarGStateLimit
1.3.6.1.4.1.5624.1.2.67.1.2.1.1.5
Unsigned32
The maximum number of groups for which the PIM TIB Manager is allowed to store (*,G,I) state specific to this interface. A value of zero means that there is no limit.
etsysPimExtIfStarGStateWarnThold
1.3.6.1.4.1.5624.1.2.67.1.2.1.1.6
Unsigned32
The PIM TIB Manager logs an exception if the number of groups for which it is storing (*,G,I) state specific to this interface exceeds this value. A value of zero means that there is no warning threshold.
etsysPimExtIfStarGStateStored
1.3.6.1.4.1.5624.1.2.67.1.2.1.1.7
Gauge32
The number of groups for which the PIM TIB Manager is storing (*,G,I) state specific to this interface.
etsysPimExtIfSGStateLimit
1.3.6.1.4.1.5624.1.2.67.1.2.1.1.8
Unsigned32
The maximum number of {source, group} pairs for which the PIM TIB Manager is allowed to store (S,G,I) state specific to this interface. A value of zero means that there is no limit.
etsysPimExtIfSGStateWarnThold
1.3.6.1.4.1.5624.1.2.67.1.2.1.1.9
Unsigned32
The PIM TIB Manager logs an exception if the number of {source, group} pairs for which it is storing (S,G,I) state specific to this interface exceeds this value. A value of zero means that there is no warning threshold.
etsysPimExtIfSGStateStored
1.3.6.1.4.1.5624.1.2.67.1.2.1.1.10
Gauge32
The number of {source, group} pairs for which the PIM TIB Manager is storing (S,G,I) state specific to this interface.
etsysPimExtIfAssertInterval
1.3.6.1.4.1.5624.1.2.67.1.2.1.1.11
Unsigned32 (0..65535) · seconds
The frequency at which this router sends PIM Assert messages on this interface when it is the assert winner.
This object corresponds to the 'Assert_Time' (180 seconds) minus the 'Assert_Override_Interval' (3 seconds) defined in PIM-SM [RFC 4601].
This value MUST be less than etsysPimExtIfAssertHoldtime.
etsysPimExtIfAssertHoldtime
1.3.6.1.4.1.5624.1.2.67.1.2.1.1.12
Unsigned32 (0..65535) · seconds
The interval before this router leaves assert loser state on this interface, unless it receives a PIM Assert message that refreshes this state.
This object corresponds to the 'Assert_Time' timer value defined in PIM-SM [RFC 4601].
Note: Configuring different values for this object for
different routers on the same interface may lead to incorrect protocol operation.
This table provides additional information pertaining to PIM static rendezvous points for Enterasys PIM systems. This table augments the pimStaticRPTable from RFC 5060.
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The address type of this entry.
pimStaticRPGrpAddress
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 8 | 16 | 20) · OCTET STRING
The multicast group address that, when combined with pimStaticRPGrpPrefixLength, gives the group prefix for this entry. The InetAddressType is given by the pimStaticRPAddressType object.
This address object is only significant up to pimStaticRPGrpPrefixLength bits. The remainder of the address bits are zero. This is especially important for this index field, which is part of the index of this entry. Any non-zero bits would signify an entirely different entry.
pimStaticRPGrpPrefixLength
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0.
An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row.
InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply.
The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (4..128) · Unsigned32 · hint d
The multicast group prefix length that, when combined with pimStaticRPGrpAddress, gives the group prefix for this entry. The InetAddressType is given by the pimStaticRPAddressType object. If pimStaticRPAddressType is 'ipv4' or 'ipv4z', this object must be in the range 4..32.
If pimStaticRPGrpAddressType is 'ipv6' or 'ipv6z', this object must be in the range 8..128.
The administrative state of this entry.
When the status of this object is set to 'adminStatusDown', the static rendezvous point will no longer accept PIM messages and is removed from the pimGroupMappingTable. This MAY cause the TIB to be updated.
When the status of this object is set to 'adminStatusUp', this static rendezvous point is added to the pimGroupMappingTable and will start accepting PIM messages. This MAY cause the TIB to be updated.
This table provides additional information pertaining to PIM anycast rendezvous point sets for Enterasys PIM systems. This table augments the pimAnycastRPSetTable from RFC 5060.
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The address type of the Anycast-RP address and router address.
pimAnycastRPSetAnycastAddress
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 8 | 16 | 20) · OCTET STRING
The Anycast-RP address. The InetAddressType is given by the pimAnycastRPSetAddressType object.
pimAnycastRPSetRouterAddress
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 8 | 16 | 20) · OCTET STRING
The address of a router that is a member of the Anycast-RP set. The InetAddressType is given by the pimAnycastRPSetAddressType object.
This address differs from pimAnycastRPSetAnycastAddress. Equal values for these two addresses in a single entry are not permitted. That would cause a Register loop.
The administrative state of this entry.
When the status of this object is set to 'adminStatusDown', the router is removed from the corresponding anycast rendezvous point set. This MAY cause the TIB to be updated.
When the status of this object is set to 'adminStatusUp', the router is added to the anycast rendezvous point and will start handling PIM messages. This MAY cause the TIB to be updated.
Note: If the status is set to 'adminStatusDown' and the
pimAnycastRPSetLocalRouter object is 'true' (this entry corresponds to the local router), the entire set is invalidated. The Anycast-RP Set is only valid if the local router is a member of the set.
This table provides additional information pertaining to PIM group mapping for Enterasys PIM systems. This table augments the pimGroupMappingTable from RFC 5060.
PimGroupMappingOriginType1 = fixed2 = configRp3 = configSsm4 = bsr5 = autoRP6 = embedded7 = otherThe mechanism by which a PIM group mapping was learned.
fixed(1) Link-local or unroutable group mappings.
configRp(2) Local static RP configuration.
configSsm(3) Local SSM Group configuration.
bsr(4) The PIM Bootstrap Router (BSR) mechanism.
autoRP(5) Cisco's Auto-RP mechanism.
embedded(6) The Embedded-RP mechanism where the RP address
is embedded in the multicast group address.
other(7) Any other mechanism.Reference: RFC 3569, RFC 3956, and RFC 5059 · Integer32
The mechanism by which this group mapping was learned.
pimGroupMappingAddressType
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The address type of the IP multicast group prefix.
pimGroupMappingGrpAddress
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 8 | 16 | 20) · OCTET STRING
The IP multicast group address that, when combined with pimGroupMappingGrpPrefixLength, gives the group prefix for this mapping. The InetAddressType is given by the pimGroupMappingAddressType object.
This address object is only significant up to pimGroupMappingGrpPrefixLength bits. The remainder of the address bits are zero. This is especially important for this index field, which is part of the index of this entry. Any non-zero bits would signify an entirely different entry.
pimGroupMappingGrpPrefixLength
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0.
An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row.
InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply.
The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (4..128) · Unsigned32 · hint d
The multicast group prefix length that, when combined with pimGroupMappingGrpAddress, gives the group prefix for this mapping. The InetAddressType is given by the pimGroupMappingAddressType object. If pimGroupMappingAddressType is 'ipv4' or 'ipv4z', this object must be in the range 4..32. If pimGroupMappingAddressType is 'ipv6' or 'ipv6z', this object must be in the range 8..128.
pimGroupMappingRPAddressType
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The address type of the RP to be used for groups within this group prefix, or unknown(0) if no RP is to be used or if the RP address is unknown. This object must be unknown(0) if pimGroupMappingPimMode is ssm(2), or if pimGroupMappingOrigin is embedded(6).
pimGroupMappingRPAddress
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0 | 4 | 8 | 16 | 20) · OCTET STRING
The IP address of the RP to be used for groups within this group prefix. The InetAddressType is given by the pimGroupMappingRPAddressType object.
etsysPimExtGroupMappingIsInactive
1.3.6.1.4.1.5624.1.2.67.1.2.4.1.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Indicates whether this Group Mapping is currently inactive.
If this flag is set to 'true' then this group mapping is currently not in use. In other words, no group addresses will be matched to this Group Mapping.
This table provides additional information pertaining to PIM neighbor statistics for Enterasys PIM systems. This table augments the pimNeighborTable.
Note: If a Neighbor expires and is removed from the
pimNeighborTable and is reconnected shortly thereafter, these statistics are reset due to the row deletion. The statistics MAY also reset on receipt of a PIM Hello message with a zero holdtime.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The value of ifIndex for the interface used to reach this PIM neighbor.
pimNeighborAddressType
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The address type of this PIM neighbor.
pimNeighborAddress
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 8 | 16 | 20) · OCTET STRING
The primary IP address of this PIM neighbor. The InetAddressType is given by the pimNeighborAddressType object.
etsysPimExtNbrStatsNumRecvHello
1.3.6.1.4.1.5624.1.2.67.1.2.5.1.1
Counter32
The number of valid PIM Hello messages that have been received from this neighbor.
etsysPimExtNbrStatsNumRecvJoinPrune
1.3.6.1.4.1.5624.1.2.67.1.2.5.1.2
Counter32
The number of valid PIM Join/Prune messages that have been received from this neighbor.
etsysPimExtNbrStatsNumRecvAssert
1.3.6.1.4.1.5624.1.2.67.1.2.5.1.3
Counter32
The number of valid PIM Assert messages that have been received from this neighbor.
etsysPimExtNbrStatsNumRecvBSM
1.3.6.1.4.1.5624.1.2.67.1.2.5.1.4
Counter32
The number of valid PIM Bootstrap messages that have been received from this neighbor.
etsysPimExtNbrStatsNumErrJoinPrune
1.3.6.1.4.1.5624.1.2.67.1.2.5.1.5
Counter32
The number of PIM Join/Prune messages that have been received from this neighbor that have contained errors.
Note: This does not include messages for which the RP in the message differs from the RP known by the local router, nor does it include (*,G) messages received for SSM groups.
etsysPimExtNbrStatsNumErrAssert
1.3.6.1.4.1.5624.1.2.67.1.2.5.1.6
Counter32
The number of PIM Assert messages that have been received from this neighbor that have contained errors.
etsysPimExtNbrStatsNumErrBSM
1.3.6.1.4.1.5624.1.2.67.1.2.5.1.7
Counter32
The number of PIM Bootstrap messages that have been received from this neighbor that have contained errors.
This table provides additional information pertaining to PIM interface statistics for Enterasys PIM systems. This table augments the pimInterfaceTable.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The ifIndex value of this PIM interface.
pimInterfaceIPVersion
InetVersion0 = unknown1 = ipv42 = ipv6A value representing a version of the IP protocol.
unknown(0) An unknown or unspecified version of the IP
protocol.
ipv4(1) The IPv4 protocol as defined in RFC 791 (STD 5).
ipv6(2) The IPv6 protocol as defined in RFC 2460.
Note that this textual convention SHOULD NOT be used to distinguish different address types associated with IP protocols. The InetAddressType has been designed for this purpose.Reference: RFC 791, RFC 2460 · Integer32
The IP version of this PIM interface. A physical interface may be configured in multiple modes concurrently, e.g., IPv4 and IPv6; however, the traffic is considered to be logically separate.
etsysPimExtIfStatsNumSentHello
1.3.6.1.4.1.5624.1.2.67.1.2.6.1.1
Counter32
The number of PIM Hello messages that have been sent out this interface.
etsysPimExtIfStatsNumSentJoinPrune
1.3.6.1.4.1.5624.1.2.67.1.2.6.1.2
Counter32
The number of PIM Join/Prune messages that have been sent out this interface.
etsysPimExtIfStatsNumSentAssert
1.3.6.1.4.1.5624.1.2.67.1.2.6.1.3
Counter32
The number of PIM Assert messages that have been sent out this interface.
etsysPimExtIfStatsNumSentBsm
1.3.6.1.4.1.5624.1.2.67.1.2.6.1.4
Counter32
The number of PIM Bootstrap Router messages that have been sent out this interface. PIM always multicasts this type of message.
etsysPimExtIfStatsNumErrHello
1.3.6.1.4.1.5624.1.2.67.1.2.6.1.5
Counter32
The number of PIM Hello messages that have been received on this interface that have contained errors.
etsysPimExtIfStatsNumRecvUnknownNbr
1.3.6.1.4.1.5624.1.2.67.1.2.6.1.6
Counter32
The number of PIM Join/Prune, Assert and multicast Bootstrap Router messages that have been received on this interface from a neighbor in which we had not previously received a valid PIM Hello message (and for which etsysPimExtIfP2PNoHellos was 'false').
Bootstrap Router messages which are sent to a unicast address are not included in this count.
etsysPimExtIfStatsNumUnknownHelloOpt
1.3.6.1.4.1.5624.1.2.67.1.2.6.1.7
Counter32
The number of unknown options that have been received in PIM Hello messages on this interface.
etsysPimExtNbrMgrTable
1.3.6.1.4.1.5624.1.2.67.1.2.7
Index: etsysPimExtNbrMgrIndex
This table provides objects that manipulate the operation of PIM in order to accept additional types of messages. Statistical objects are provided as well.
etsysPimExtNbrMgrIndex
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.1
InetVersion0 = unknown1 = ipv42 = ipv6A value representing a version of the IP protocol.
unknown(0) An unknown or unspecified version of the IP
protocol.
ipv4(1) The IPv4 protocol as defined in RFC 791 (STD 5).
ipv6(2) The IPv6 protocol as defined in RFC 2460.
Note that this textual convention SHOULD NOT be used to distinguish different address types associated with IP protocols. The InetAddressType has been designed for this purpose.Reference: RFC 791, RFC 2460 · Integer32
The Internet address version of this Neighbor Manager.
etsysPimExtNbrMgrEnableUnicastMessages
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Indicates whether the PIM Neighbor Manager sends and receives unicast PIM messages.
This object MUST only be set to 'false' if the local router will never be an RP for any multicast group, and it will never be the downstream router for any connected source that sends data to any ASM group. This will always be the case if the local router only performs the SSM subset of PIM-SM.
etsysPimExtNbrMgrAcceptUnicastBsms
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
Indicates whether the PIM Neighbor manager accepts PIM Boostrap Messages (BSMs) which are sent as unicast messages.
Setting the value of this object to 'false' means that BSMs are ignored if they are sent as unicast messages.
This object can only be set to 'true' if the etsysPimExtNbrMgrEnableUnicastMessages object is 'true'.
etsysPimExtNbrMgrNumSentCRPAdvert
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.4
Counter32
The number of PIM Candidate-RP-Advertisement messages that have been sent.
etsysPimExtNbrMgrNumSentRegister
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.5
Counter32
The number of PIM Register messages that have been sent
Note: This only includes PIM Register messages forwarded to
other members of Anycast-RP sets, and Null-Register messages. It does not include Register-encapsulated data packets sent from the downstream router to the RP.
etsysPimExtNbrMgrNumSentRegisterStop
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.6
Counter32
The number of PIM Register-Stop messages that have been sent.
etsysPimExtNbrMgrNumRecvCRPAdvert
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.7
Counter32
The number of valid PIM Candidate-RP Advertisement messages that have been received.
etsysPimExtNbrMgrNumRecvRegister
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.8
Counter32
The number of valid PIM Register messages that have been received.
etsysPimExtNbrMgrNumRecvRegisterStop
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.9
Counter32
The number of valid PIM Register-Stop messages that have been received.
etsysPimExtNbrMgrNumErrCRPAdvert
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.10
Counter32
The number of received PIM Candidate-RP Advertisement messages that have contained errors.
etsysPimExtNbrMgrNumErrRegister
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.11
Counter32
The number of received PIM Register messages that have contained errors.
etsysPimExtNbrMgrNumErrRegisterStop
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.12
Counter32
The number of received PIM Register-Stop messages that have contained errors.
etsysPimExtNbrMgrNumRecvIgnoredType
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.13
Counter32
The number of received PIM messages with a known but unsupported PIM message type.
etsysPimExtNbrMgrNumRecvUnknownType
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.14
Counter32
The number of received PIM messages with an unknown PIM message type.
etsysPimExtNbrMgrNumRecvUnknownVer
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.15
Counter32
The number of received PIM messages with an unknown PIM version.
etsysPimExtNbrMgrNumRecvBadChecksum
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.16
Counter32
The number of received PIM messages with an incorrect PIM checksum that.
etsysPimExtNbrMgrNumRecvBadLength
1.3.6.1.4.1.5624.1.2.67.1.2.7.1.17
Counter32
The number of received PIM messages with a length too short to contain a common PIM header.
etsysPimExtTibMgrTable
1.3.6.1.4.1.5624.1.2.67.1.2.8
Index: etsysPimExtTibMgrIndex
This table provides objects that manipulate the operation of the PIM Tree Information Base (TIB) Manager in order control the acceptable limits for the TIB.
etsysPimExtTibMgrIndex
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.1
InetVersion0 = unknown1 = ipv42 = ipv6A value representing a version of the IP protocol.
unknown(0) An unknown or unspecified version of the IP
protocol.
ipv4(1) The IPv4 protocol as defined in RFC 791 (STD 5).
ipv6(2) The IPv6 protocol as defined in RFC 2460.
Note that this textual convention SHOULD NOT be used to distinguish different address types associated with IP protocols. The InetAddressType has been designed for this purpose.Reference: RFC 791, RFC 2460 · Integer32
The Internet address version of this PIM TIB Manager.
etsysPimExtTibMgrGStateLimit
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.2
Unsigned32
The maximum number of groups for which the PIM TIB Manager is allowed to store non-interface specific (*,G) and/or (S,G) state. A value of zero means that there is no limit.
etsysPimExtTibMgrGStateWarnThold
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.3
Unsigned32
The PIM TIB Manager logs an exception if the number of groups for which it is storing non-interface specific (*,G) and/or (S,G) state exceeds this value. A value of zero means that there is no warning threshold.
etsysPimExtTibMgrGStateStored
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.4
Gauge32
The number of groups for which the PIM TIB Manager is storing non-interface specific (*,G) and/or (S,G) state.
etsysPimExtTibMgrSGStateLimit
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.5
Unsigned32
The maximum number of {source, group} pairs for which the PIM TIB Manager is allowed to store non-interface specific (S,G) state. A value of zero means that there is no limit.
etsysPimExtTibMgrSGStateWarnThold
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.6
Unsigned32
The PIM TIB Manager logs an exception if the number of {source, group} pairs for which it is storing non-interface specific (S,G) state exceeds this value. A value of zero means that there is no warning threshold.
etsysPimExtTibMgrSGStateStored
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.7
Gauge32
The number of {source, group} pairs for which the PIM TIB Manager is storing non-interface specific (S,G) state.
etsysPimExtTibMgrStarGIStateLimit
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.8
Unsigned32
The maximum number of {group, interface} pairs for which the PIM TIB Manager is allowed to store (*,G,I) state. A value of zero means that there is no limit.
etsysPimExtTibMgrStarGIStateWarnThold
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.9
Unsigned32
The PIM TIB Manager logs an exception if the number of {group, interface} pairs for which it is storing (*,G,I) state exceeds this value. A value of zero means that there is no warning threshold.
etsysPimExtTibMgrStarGIStateStored
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.10
Gauge32
The number of {group, interface} pairs for which the PIM TIB Manager is storing (*,G,I) state.
etsysPimExtTibMgrSGIStateLimit
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.11
Unsigned32
The maximum number of {source, group, interface} triplets for which the PIM TIB Manager is allowed to store (S,G,I) state. A value of zero means that there is no limit.
etsysPimExtTibMgrSGIStateWarnThold
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.12
Unsigned32
The PIM TIB Manager logs an exception if the number of {source, group, interface} triplets for which it is storing (S,G,I) state exceeds this value. A value of zero means that there is no warning threshold.
etsysPimExtTibMgrSGIStateStored
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.13
Gauge32
The number of {source, group, interface} triplets for which the PIM TIB Manager is storing (S,G,I) state.
etsysPimExtTibMgrRegSuppressionTime
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.14
Unsigned32 (0..65535) · seconds
The mean value of the randomized interval during which a downstream router stops Register-encapsulation after receiving a PIM Register-Stop message.
This object corresponds to the 'Register_Suppression_Time' defined in PIM-SM [RFC 4601].
Note: Configuring different values for this object for
different routers in the PIM domain may lead to incorrect protocol operation.
etsysPimExtTibMgrRegProbeTime
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.15
Unsigned32 (0..65535) · seconds
The time to wait for a PIM Register-Stop message after sending a PIM Null-Register message, before resuming Register-encapsulation at a downstream router.
This object corresponds to the 'Register_Probe_Time' defined in PIM-SM [RFC 4601].
etsysPimExtTibMgrKeepalivePeriod
1.3.6.1.4.1.5624.1.2.67.1.2.8.1.16
Unsigned32 (0..65535) · seconds
The amount of time to keep (S,G) state alive in the absence of PIM (S,G) Join messages, (S,G) local membership or (S,G) data packets.
This object corresponds to the 'Keepalive_Period' defined in PIM-SM [RFC 4601].
Note: Configuring different values for this object for
different routers in the PIM domain may lead to incorrect protocol operation.