This MIB module provides the ability to configure the Port Web Authentication (PWA) component in a switch. PWA provides a way of authenticating a user on a switch port before allowing the user general access to the network. Only the essential protocols and services required by the authentication process are allowed on the segment between the end-station and the switch port. All other traffic will be discarded. When a user is in the unauthenticated state, any traffic generated by the end-station will not go beyond the switch port that they are connected to.
The PWA/login process from the user standpoint is simple. The user makes a request via their favorite web browser for the 'secureharbour' web page. Depending upon the authenticated state of the port, a login page is provided so that the user can enter their username and password, or a logout page is presented to the user. When they submit their login page, the switch will then authenticate them via a preconfigured radius server. If the login is successful, then the port that the end-station is connected to will be turned on and full network access will be granted according to the users port configuration on the switch.
This MIB module also provides status about the PWA component and statistics about all current users who are logged into the switch.
EnabledStatus1 = enabled2 = disabledA simple status value for the object. · Integer32
Reference: Port Web Authentication Architectural Specification
The administrative enable/disable state for Port Web Authentication Control in a System. Enabling this object turns on the PWA system.
etsysPwaSystemAuthHostName
1.3.6.1.4.1.5624.1.2.8.1.2
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..32) · OCTET STRING · hint 255a
This is the hostname part the Uniform Resource Locator (URL). This object is a DNS/WINS name and is considered to be bound to the etsysPwaSystemAuthIPAddress. This object must not contain the protocol portion of the URL nor any directory or filenames. Changing this objects value changes the default name of the http server located at the local switch. An administrator can change this objects value to whatever name is appropriate for their network.
etsysPwaSystemAuthBanner
1.3.6.1.4.1.5624.1.2.8.1.3
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
The banner that will be displayed on the web login page of the Port Web Authentication Control in a System. This banner is a courtesy introduction to the network, which the user sees on the login page.
etsysPwaSystemPwaNameServicesEnable
1.3.6.1.4.1.5624.1.2.8.1.4
EnabledStatus1 = enabled2 = disabledA simple status value for the object. · Integer32
The enable state of the name services application. Enabling this object turns on the Domain Name Service (DNS) and the Windows Internet Naming Services (WINS) clients. These clients will resolve only requests for the etsysPwaSystemAuthHostName. Disabling this object would require users in the network to know and use the etsysPwaSystemAuthIPAddress of this system.
etsysPwaSystemAuthIPAddressType
1.3.6.1.4.1.5624.1.2.8.1.5
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This object has been deprecated. Refer to etsysPwaSystemAuthIPAddress for the reason. The textual convention for InetAddressType states that this object must be registered immediately before the InetAddress that it defines. etsysPwaSystemAuthInetAddressType MUST be used for all future implementations of this MIB.
etsysPwaSystemAuthIPAddress
1.3.6.1.4.1.5624.1.2.8.1.6
IpAddress SIZE (4)
This object has been deprecated due to an incorrect initial implementation of this MIB. This object was originally an InetAddress but some versions of the E7 firmware implemented it as an IpAddress. The syntax of this object was changed to allow management of the existing products. The etsysPwaSystemAuthInetAddress object MUST be used for all future implementations of this MIB.
etsysPwaSystemAuthProtocol
1.3.6.1.4.1.5624.1.2.8.1.7
INTEGER1 = chap2 = pap · Integer32
The authentication protocol used for this switch module. When set to a chap(1), the authentication scheme used will be the 'PPP Challenge Handshake Authentication Protocol (CHAP)', when set to a pap(2), the scheme will be 'Password Authentication Protocol (PAP)'.
When using the CHAP protocol, the username and password utilize the CHAP protocol method of encryption to encrypt the users password in the http transmission of the submitted form on the segment between the end-station and the switch port.
The PAP protocol is less secure than CHAP and does not provide any encryption on the segment between the end-station the switch port. The username and password go over this segment in the http transmission of the submitted form in plain text format.
etsysPwaSystemAuthDomain
1.3.6.1.4.1.5624.1.2.8.1.8
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
The domain name for which this module resides in.
etsysPwaSystemAuthInetAddressType
1.3.6.1.4.1.5624.1.2.8.1.9
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
A value that represents a type of etsysPwaSystemAuthInetAddress.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address which is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
etsysPwaSystemAuthInetAddress
1.3.6.1.4.1.5624.1.2.8.1.10
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The IP address bound to the etsysPwaSystemAuthHostName. The format of this object is defined in the etsysPwaSystemAuthInetAddressType object. This address MUST be supplied for authentication to work. This is a globally unique address and must be the same value configured into every authenticating switch in the domain. Each switch terminates any IP traffic destined to this etsysPwaSystemAuthInetAddress. If the port is in either promiscousAuto(4) or auto(2) mode, described in the etsysPwaControlledPortControl object, then the local switch in question responds to http requests with a login page. If the port is in any other mode, then all traffic destined for etsysPwaSystemAuthInetAddress is discarded. Please note that neither the etsysPwaSystemAuthHostName object nor this object refer to any specific machine in the network. These objects are always relative to the connection between an end station and a switch. Traffic destined for this IP is never seen over interswitch links.
etsysPwaSystemAuthEnhancedMode
1.3.6.1.4.1.5624.1.2.8.1.11
EnabledStatus1 = enabled2 = disabledA simple status value for the object. · Integer32
The enable state of the PWA enhanced mode. When this feature is enabled users on unauthenticated ports will be presented the login page on their initial web access. The etsysPwaControlledPortControl object MUST be set to auto(2) for this feature to function correctly. If etsysPwaControlledPortControl is not set to auto(2), or if this feature is disabled, users must enter the value of etsysPwaSystemAuthHostName in order to get the login page.
etsysPwaLogoDisplayStatus
1.3.6.1.4.1.5624.1.2.8.1.12
EnabledStatus1 = enabled2 = disabledA simple status value for the object. · Integer32
When this object is set to enabled, the secureharbour logo will be displayed on the PWA login web pages. When it is set to disabled, the logo will not be displayed.
etsysPwaSystemGuestUsername
1.3.6.1.4.1.5624.1.2.8.1.13
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..32) · OCTET STRING · hint 255a
The username that the Guest Networking feature will use to authenticate users that do not override this value in the login page.
etsysPwaSystemGuestPassword
1.3.6.1.4.1.5624.1.2.8.1.14
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..32) · OCTET STRING · hint 255a
The password that the Guest Networking feature will use to authenticate users that do not override the guest username. On a read this object will always return an empty string.
etsysPwaSystemGuestPasswordValid
1.3.6.1.4.1.5624.1.2.8.1.15
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
true(1) - indicates that etsysPwaGuestPassword was last set
with some value other than the empty string.
false(2) - indicates that etsysPwaGuestPassword has never been set, or was last set to the empty string.
Guest Networking is a feature that allows a user to get default policy access to the network without having to know a username or password. When this feature is not disabled(1), the username on the login page will be populated with the value from the object etsysPwaGuestUsername and the password will be mask out with asterisks. The password in the login page should never be populated with the value from etsysPwaGuestPassword. When Guest Networking is enabled, and a user submits a request for authentication, and the username is the same as the value from etsysPwaGuestUsername, PWA will use the value from etsysPwaGuestPassword as the password for authentication.
When this object is set to disabled(1), Guest Networking will be unavailable.
When set to authNone(2) Guest Networking will be enabled and it will not authenticate the guest user using any authentication method. Once the user submits the login page with the username that matches the value from etsysPwaGuestUsername, the default policy of that port will become the active policy.
When set to authRadius(3) Guest Networking will be enabled and it will authenticate the guest user using RADIUS authentication Upon a successful authentication from RADIUS, this port will apply the policy returned from RADIUS to that port.
etsysPwaSystemEnhancedModeRefreshTime
1.3.6.1.4.1.5624.1.2.8.1.17
Integer32 (0..120) · seconds
This is the value that is displayed on the PWA login success page as the redirect time.
If a user, using PWA enhanced mode, enters a URL of 'http://enterasys.com' prior to being presented with the PWA login page and then successfully authenticates into the network they would be presented with a login success page that displays 'Welcome to the Network. Completing network connections. You will be redirected to http://enterasys.com in approximately 30 seconds'.
An end-station that is utilizing the Dynamic Host Configuration Protocol (DHCP) as a means of obtaining an IP address will take some time to transition from the temporary IP address issued by PWA, as part of the authentication process, to the official IP address issued by the network.
etsysPwaSystemEnhancedModeRefreshTime provides a configurable time period for the end-stations on a given switch to complete the process of obtaining their official IP addresses and to begin using them. The default value of 30 seconds has been shown to be adequate in most environments. In some networks this time period may need to be longer, and in other networks it could be shorter.
In networks that only use static IP addresses a time period on the order of 5 to 10 seconds may be sufficient. A period of less than 5 seconds is not recommended as there is a slight delay after a successful login before the switch transitions the port to forwarding.
etsysPwaSystemAccountEnable
1.3.6.1.4.1.5624.1.2.8.1.18
EnabledStatus1 = enabled2 = disabledA simple status value for the object. · Integer32
When enabled(1), RADIUS accounting start, interim and stop frames are sent to the configured RADIUS server(s).
When disabled(2), accounting packets are not sent to the RADIUS server.
Table details
etsysPwaPortConfigurationTable
1.3.6.1.4.1.5624.1.2.8.2.1
Index: etsysPwaPortNumber
A table of configuration objects for each port that are supported by the Port Web Authentication Entity. An entry appears in this table for each port in this system. All objects/instances in this table are stored persistent memory.
etsysPwaPortNumber
1.3.6.1.4.1.5624.1.2.8.2.1.1.1
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The ifIndex number associated with this port.
etsysPwaInitializePort
1.3.6.1.4.1.5624.1.2.8.2.1.1.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The initialization control for this ifIndex. This object can be used to unauthenticate a user on a port or to return the port to its initial default state due to some unknown condition. Setting this attribute to true(1) causes the Port to be initialized. The attribute value reverts to false(2) once initialization has completed. Initializing a port returns the etsysPwaAuthPwaState to disconnected(1) and if the etsysPwaControlledPortControl setting is either promiscousAuto(4) or auto(2), and the etsysPwaAuthPwaState was authenticated(3), then the current session is terminated, and the user is forced off the network.
etsysPwaAuthQuietPeriod
1.3.6.1.4.1.5624.1.2.8.2.1.1.3
Integer32 (0..2147483647) · seconds
The value, in seconds, of the quietPeriod constant currently in use by the Port Web Authenticator state machine. After the user attempts unsuccessfully to login a number of times equal to the etsysPwaAuthMaxReq constant, then the ifIndex is locked for a time period equal to the value of this MIB entry.
In the initial released version of this MIB this object was an Unsigned32. The initial implementation on the E7 returned an Integer32. The syntax of this object was changed to reflect the existing product in the field. All future implementations of this object should return an Integer32.
etsysPwaAuthMaxReq
1.3.6.1.4.1.5624.1.2.8.2.1.1.4
Integer32 (0..2147483647)
The value of the maxReq constant currently in use by the Port Web Authenticator state machine. This represents the maximum number of failed retry attempts before preventing any further attempts for a time period equal to the value of etsysPwaAuthQuietPeriod.
In the initial released version of this MIB this object was an Unsigned32. The initial implementation on the E7 returned an Integer32. The syntax of this object was changed to reflect the existing product in the field. All future implementations of this object should return an Integer32.
The authentication method of the ifIndex. A value of forceUnauthorized(1) indicates that the port is always unauthenticated. When set to this value the ifindex is essentially disabled.
A value of auto(2) indicates that the ifindex will authenticate users using PWA process. In this mode the switch will provide all the services the end-station will need to complete the login. These services include a Dynamic Host Configuration Protocol (DHCP) server, a Windows Internet Naming Server (WINS), and a Domain Name Service (DNS) Server.
A value of forceAuthorized(3) indicates the port is always authorized. When set to this value, the ifindex will always be authenticated.
When set to promiscousAuto(4) the services that are required to complete the network login are not provided by the switch. These services must be provided on a back-end network that the end-station can communicate with. These services might be specific to the particular Operating System of the end-station and could also include the same services as provided in auto mode.
etsysPwaAuthStatusTable
1.3.6.1.4.1.5624.1.2.8.3.1
Index: etsysPwaPortNumber
A table that contains the status objects for the Port Web Authenticator associated with each ifIndex. An entry appears in this table for each ifIndex that may authenticate access to itself. All objects/instances in this table are stored in persistent memory.
The current value of the Port Web Authenticator state machine. When set to disconnected(1) no user is logged in. When set to authenticating(2), it indicates that a login is in process and has not yet completed. A value of authenticated(3) indicates a user has successfully logged in. When the value is held(4) it indicates that the port is locked down because the number of failed login attempts is greater than etsysPwaAuthMaxReq.The port will be locked until the etsysPwaAuthQuietPeriod has expired.
etsysPwaMaxFailedAttempts
1.3.6.1.4.1.5624.1.2.8.3.1.1.2
ZeroBasedCounter32This TC describes an object that counts events with the following semantics: objects of this type will be set to zero(0) on creation and will thereafter count appropriate events, wrapping back to zero(0) when the value 2^32 is reached.
Provided that an application discovers the new object within the minimum time to wrap, it can use the initial value as a delta since it last polled the table of which this object is part. It is important for a management station to be aware of this minimum time and the actual time between polls, and to discard data if the actual time is too long or there is no defined minimum time.
Typically, this TC is used in tables where the INDEX space is constantly changing and/or the TimeFilter mechanism is in use. · Gauge32
The total number of failed logon attempts on this ifIndex.
etsysPwaFailedAttemptsSinceLogon
1.3.6.1.4.1.5624.1.2.8.3.1.1.3
ZeroBasedCounter32This TC describes an object that counts events with the following semantics: objects of this type will be set to zero(0) on creation and will thereafter count appropriate events, wrapping back to zero(0) when the value 2^32 is reached.
Provided that an application discovers the new object within the minimum time to wrap, it can use the initial value as a delta since it last polled the table of which this object is part. It is important for a management station to be aware of this minimum time and the actual time between polls, and to discard data if the actual time is too long or there is no defined minimum time.
Typically, this TC is used in tables where the INDEX space is constantly changing and/or the TimeFilter mechanism is in use. · Gauge32
The total number of failed logon attempts since the last successful logon on this ifIndex.
etsysPwaLastLogonResult
1.3.6.1.4.1.5624.1.2.8.3.1.1.4
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This ASCII string provides an unstructured way for the web based auth agent to communicate detailed error and status indications to a network administrator.
etsysPwaAuthSessionStatsTable
1.3.6.1.4.1.5624.1.2.8.4.1
Index: etsysPwaPortNumber · etsysPwaAuthSessionID
A table that contains the session statistics objects for the Authenticator PWA associated with each ifIndex. An entry appears in this table for each ifIndex that may authenticate access to itself. Session entries are collected for each ifIndex. All objects/instances in this table are stored in non-persistent memory. The instancing in this table and the etsysPwaAuthSessionStatsHCTable are dependent upon the switch port configuration and will always be identical in any given switch.
etsysPwaAuthSessionID
1.3.6.1.4.1.5624.1.2.8.4.1.1.1
Integer32
A unique ID that identifies the session on this ifindex.
etsysPwaAuthSessionOctetsRx
1.3.6.1.4.1.5624.1.2.8.4.1.1.2
Counter32
The number of octets received in user data frames on this ifIndex during the session.
etsysPwaAuthSessionOctetsRxOverflow
1.3.6.1.4.1.5624.1.2.8.4.1.1.3
Counter32
The number of times the associated etsysPwaAuthSessionOctetsRx counter has overflowed.
etsysPwaAuthSessionOctetsTx
1.3.6.1.4.1.5624.1.2.8.4.1.1.4
Counter32
The number of octets transmitted in user data frames on this ifIndex during the session.
etsysPwaAuthSessionOctetsTxOverflow
1.3.6.1.4.1.5624.1.2.8.4.1.1.5
Counter32
The number of times the associated etsysPwaAuthSessionOctetsTx counter has overflowed.
etsysPwaAuthSessionFramesRx
1.3.6.1.4.1.5624.1.2.8.4.1.1.6
Counter32
The number of user data frames received on this ifIndex during the session.
etsysPwaAuthSessionFramesTx
1.3.6.1.4.1.5624.1.2.8.4.1.1.7
Counter32
The number of user data frames transmitted on this ifIndex during the session.
etsysPwaAuthSessionStartTime
1.3.6.1.4.1.5624.1.2.8.4.1.1.8
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The start time of the session in hundredths of seconds since reset.
etsysPwaAuthSessionDuration
1.3.6.1.4.1.5624.1.2.8.4.1.1.9
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32
The duration of the session in hundredths of seconds.
The reason for the session termination. When set to linkDown(1), the ifindex has no link. When set to logoff(2), a user has successfully logged off the network on this ifindex. When set to authControlForceUnauth(3) an administrator has terminated the user session on this ifindex by setting etsysPwaControlledPortControl to forceUnauthorized(1). When set to portReInit(4) the ifindex has been re-initialized by setting the object etsysPwaInitializePort. When set to portDisabled(5) the ifindex has been disabled. When set notTerminatedYet(999) the ifindex has an active session.
etsysPwaAuthSessionMacAddress
1.3.6.1.4.1.5624.1.2.8.4.1.1.11
MacAddressRepresents an 802 MAC address represented in the `canonical' order defined by IEEE 802.1a, i.e., as if it were transmitted least significant bit first, even though 802.5 (in contrast to other 802.x protocols) requires MAC addresses to be transmitted most significant bit first. SIZE (6) · OCTET STRING · hint 1x:
The mac address of the remote user of this session entry stored for this ifIndex.
etsysPwaAuthSessionIPAddressType
1.3.6.1.4.1.5624.1.2.8.4.1.1.12
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
A value that represents a type of etsysPwaAuthSessionIPAddress.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address which is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
etsysPwaAuthSessionIPAddress
1.3.6.1.4.1.5624.1.2.8.4.1.1.13
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The ip address of the remote user of this session entry stored for this ifIndex. The format of this object is defined in the etsysPwaAuthSessionIPAddressType object.
etsysPwaAuthSessionUserName
1.3.6.1.4.1.5624.1.2.8.4.1.1.14
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
A table that contains the session statistics objects for the Authenticator PWA associated with each ifIndex. An entry appears in this table for each ifIndex that may authenticate access to itself. Session entries are collected for each ifIndex up to the maximum allowed. When the maximum number of allowed sessions has been reached, the oldest session entries will be replaced with newer ones as necessary. All objects/instances in this table are stored in non-persistent memory.
etsysPwaAuthSessionHCID
1.3.6.1.4.1.5624.1.2.8.4.2.1.1
Integer32
A unique ID that identifies the session on this ifindex.
etsysPwaAuthSessionOctetsRxHc
1.3.6.1.4.1.5624.1.2.8.4.2.1.2
Counter64 (0..18446744073709551615)
The number of octets received in user data frames on this ifIndex during the session.
etsysPwaAuthSessionOctetsTxHc
1.3.6.1.4.1.5624.1.2.8.4.2.1.3
Counter64 (0..18446744073709551615)
The number of octets transmitted in user data frames on this ifIndex during the session.