EZ5 MIB Catalog

GMPLS-LSR-STD-MIB

2007-02-27

Copyright (C) The IETF Trust (2007). This version of this MIB module is part of RFC 4803; see the RFC itself for full legal notices. This MIB module contains managed object definitions for the Generalized Multiprotocol (GMPLS) Label Switching Router as defined in Generalized Multi-Protocol Label Switching (GMPLS) Architecture, Mannie et al., RFC 3945, October 2004.

Download GMPLS-LSR-STD-MIB.txt Open GMPLS-LSR-STD-MIB.txt in a new tab

TABLES (3)

Tables (3)

NameOID
gmplsInterfaceTable1.3.6.1.2.1.10.166.15.1.1
gmplsInSegmentTable1.3.6.1.2.1.10.166.15.1.2
gmplsOutSegmentTable1.3.6.1.2.1.10.166.15.1.3

END OF TOC

Table details

gmplsInterfaceTable

1.3.6.1.2.1.10.166.15.1.1

Index: mplsInterfaceIndex

Reference: 1. Multiprotocol Label Switching (MPLS) Label Switching Router (LSR) Management Information Base (MIB), RFC 3813.

This table specifies per-interface GMPLS capability and associated information. It extends the information in the mplsInterfaceTable of MPLS-LSR-STD-MIB through a sparse augmentation relationship.

from MPLS-LSR-STD-MIB

mplsInterfaceIndex

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

Reference: RFC 2863 - The Interfaces Group MIB, McCloghrie, K., and F. Kastenholtz, June 2000

This is a unique index for an entry in the MplsInterfaceTable. A non-zero index for an entry indicates the ifIndex for the corresponding interface entry of the MPLS-layer in the ifTable. The entry with index 0 represents the per-platform label space and contains parameters that apply to all interfaces that participate in the per-platform label space. Other entries defined in this table represent additional MPLS interfaces that may participate in either the per-platform or per-interface label spaces, or both.

gmplsInterfaceSignalingCaps

1.3.6.1.2.1.10.166.15.1.1.1.1

BITS

Reference: 1. Generalized MPLS Signaling - CR-LDP Extensions, RFC 3472. 2. The Multiprotocol Label Switching (MPLS) Working Group decision on MPLS signaling protocols, RFC 3468. 3. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473.

Defines the signaling capabilities on this interface. Multiple bits may legitimately be set at once, but if 'unknown' is set then no other bit may be set. Setting no bits implies that GMPLS signaling cannot be performed on this interface and all LSPs must be manually provisioned or that this table entry is only present to supplement an entry in the mplsInterfaceTable by providing the information carried in other objects in this row.

gmplsInterfaceRsvpHelloPeriod

1.3.6.1.2.1.10.166.15.1.1.1.2

Unsigned32 · milliseconds

Reference: 1. RSVP-TE: Extensions to RSVP for LSP Tunnels, RFC 3209, section 5. 2. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473, section 9.3.

Period, in milliseconds, between sending Resource Reservation Protocol (RSVP) Hello messages on this interface. A value of 0 indicates that no Hello messages should be sent on this interface. This object is only valid if gmplsInterfaceSignalingCaps has no bits set or includes the rsvpGmpls bit.

gmplsInSegmentTable

1.3.6.1.2.1.10.166.15.1.2

Index: mplsInSegmentIndex

Reference: 1. Multiprotocol Label Switching (MPLS) Label Switching Router (LSR) Management Information Base (MIB), RFC 3813.

This table sparse augments the mplsInSegmentTable of MPLS-LSR-STD-MIB to provide GMPLS-specific information about incoming segments to an LSR.

from MPLS-LSR-STD-MIB

mplsInSegmentIndex

MplsIndexTypeThis is an octet string that can be used as a table index in cases where a large addressable space is required such as on an LSR where many applications may be provisioning labels. Note that the string containing the single octet with the value 0x00 is a reserved value used to represent special cases. When this TEXTUAL-CONVENTION is used as the SYNTAX of an object, the DESCRIPTION clause MUST specify if this special value is valid and if so what the special meaning is. In systems that provide write access to the MPLS-LSR-STD MIB, mplsIndexType SHOULD be used as a simple multi-digit integer encoded as an octet string. No further overloading of the meaning of an index SHOULD be made. In systems that do not offer write access to the MPLS-LSR-STD MIB, the mplsIndexType may contain implicit formatting that is specific to the implementation to convey additional information such as interface index, physical card or device, or application id. The interpretation of this additional formatting is implementation dependent and not covered in this document. Such formatting MUST NOT impact the basic functionality of read-only access to the MPLS-LSR-STD MIB by management applications that are not aware of the formatting rules. SIZE (1..24) · OCTET STRING

The index for this in-segment. The string containing the single octet 0x00 MUST not be used as an index.

gmplsInSegmentDirection

1.3.6.1.2.1.10.166.15.1.2.1.1

GmplsSegmentDirectionTC1 = forward2 = reverseThe direction of data flow on an Label Switched Path (LSP) segment with respect to the head of the LSP. Where an LSP is signaled using a conventional signaling protocol, the 'head' of the LSP is the source of the signaling (also known as the ingress) and the 'tail' is the destination (also known as the egress). For unidirectional LSPs, this usually matches the direction of flow of data. For manually configured unidirectional LSPs, the direction of the LSP segment matches the direction of flow of data. For manually configured bidirectional LSPs, an arbitrary decision must be made about which LER is the 'head'. · Integer32

Reference: 1. Multiprotocol Label Switching (MPLS) Label Switching Router (LSR) Management Information Base (MIB), RFC 3813.

This object indicates the direction of data flow on this segment. This object cannot be modified if mplsInSegmentRowStatus for the corresponding entry in the mplsInSegmentTable is active(1).

gmplsInSegmentExtraParamsPtr

1.3.6.1.2.1.10.166.15.1.2.1.2

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

Some tunnels will run over transports that can usefully support technology-specific additional parameters (for example, Synchronous Optical Network (SONET) resource usage). Such can be supplied from an external table and referenced from here. A value of zeroDotZero in this attribute indicates that there is no such additional information.

gmplsOutSegmentTable

1.3.6.1.2.1.10.166.15.1.3

Index: mplsOutSegmentIndex

Reference: 1. Multiprotocol Label Switching (MPLS) Label Switching Router (LSR) Management Information Base (MIB), RFC 3813.

This table sparse augments the mplsOutSegmentTable of MPLS-LSR-STD-MIB to provide GMPLS-specific information about outgoing segments from an LSR.

from MPLS-LSR-STD-MIB

mplsOutSegmentIndex

MplsIndexTypeThis is an octet string that can be used as a table index in cases where a large addressable space is required such as on an LSR where many applications may be provisioning labels. Note that the string containing the single octet with the value 0x00 is a reserved value used to represent special cases. When this TEXTUAL-CONVENTION is used as the SYNTAX of an object, the DESCRIPTION clause MUST specify if this special value is valid and if so what the special meaning is. In systems that provide write access to the MPLS-LSR-STD MIB, mplsIndexType SHOULD be used as a simple multi-digit integer encoded as an octet string. No further overloading of the meaning of an index SHOULD be made. In systems that do not offer write access to the MPLS-LSR-STD MIB, the mplsIndexType may contain implicit formatting that is specific to the implementation to convey additional information such as interface index, physical card or device, or application id. The interpretation of this additional formatting is implementation dependent and not covered in this document. Such formatting MUST NOT impact the basic functionality of read-only access to the MPLS-LSR-STD MIB by management applications that are not aware of the formatting rules. SIZE (1..24) · OCTET STRING

This value contains a unique index for this row. While a value of a string containing the single octet 0x00 is not valid as an index for entries in this table, it can be supplied as a valid value to index the mplsXCTable to represent entries for which no out-segment has been configured or exists.

gmplsOutSegmentDirection

1.3.6.1.2.1.10.166.15.1.3.1.1

GmplsSegmentDirectionTC1 = forward2 = reverseThe direction of data flow on an Label Switched Path (LSP) segment with respect to the head of the LSP. Where an LSP is signaled using a conventional signaling protocol, the 'head' of the LSP is the source of the signaling (also known as the ingress) and the 'tail' is the destination (also known as the egress). For unidirectional LSPs, this usually matches the direction of flow of data. For manually configured unidirectional LSPs, the direction of the LSP segment matches the direction of flow of data. For manually configured bidirectional LSPs, an arbitrary decision must be made about which LER is the 'head'. · Integer32

Reference: 1. Multiprotocol Label Switching (MPLS) Label Switching Router (LSR) Management Information Base (MIB), RFC 3813.

This object indicates the direction of data flow on this segment. This object cannot be modified if mplsOutSegmentRowStatus for the corresponding entry in the mplsOutSegmentTable is active(1).

gmplsOutSegmentTTLDecrement

1.3.6.1.2.1.10.166.15.1.3.1.2

Unsigned32

Reference: 1. Time To Live (TTL) Processing in Multi-Protocol Label Switching (MPLS) Networks, RFC 3443. 2. Generalized Multiprotocol Label Switching (GMPLS) Traffic Engineering Management Information Base, RFC 4802.

This object indicates the amount by which to decrement the Time to Live (TTL) of any payload packets forwarded on this segment if per-hop decrementing is being done. A value of zero indicates that no decrement should be made or that per-hop decrementing is not in use. See the gmplsTunnelTTLDecrement object in the gmplsTunnelTable of GMPLS-TE-STD-MIB for a value by which to decrement the TTL for the whole of a tunnel. This object cannot be modified if mplsOutSegmentRowStatus for the associated entry in the mplsOutSegmentTable is active(1).

gmplsOutSegmentExtraParamsPtr

1.3.6.1.2.1.10.166.15.1.3.1.3

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

Some tunnels will run over transports that can usefully support technology-specific additional parameters (for example, SONET resource usage). Such can be supplied from an external table and referenced from here. A value of zeroDotZero in this attribute indicates that there is no such additional information.

↑ To TOC