EZ5 MIB Catalog

GMPLS-TE-STD-MIB

2007-02-27

Copyright (C) The IETF Trust (2007). This version of this MIB module is part of RFC 4802; see the RFC itself for full legal notices. This MIB module contains managed object definitions for GMPLS Traffic Engineering (TE) as defined in: 1. Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description, Berger, L. (Editor), RFC 3471, January 2003. 2. Generalized MPLS Signaling - RSVP-TE Extensions, Berger, L. (Editor), RFC 3473, January 2003.

Download GMPLS-TE-STD-MIB.txt Open GMPLS-TE-STD-MIB.txt in a new tab

SCALARS (2) · TABLES (6) · TRAPS (1)

Scalars (2)

NameOID
gmplsTunnelsConfigured1.3.6.1.2.1.10.166.13.1.1
gmplsTunnelsActive1.3.6.1.2.1.10.166.13.1.2

Tables (6)

NameOID
gmplsTunnelTable1.3.6.1.2.1.10.166.13.2.1
gmplsTunnelHopTable1.3.6.1.2.1.10.166.13.2.2
gmplsTunnelARHopTable1.3.6.1.2.1.10.166.13.2.3
gmplsTunnelCHopTable1.3.6.1.2.1.10.166.13.2.4
gmplsTunnelReversePerfTableaugments gmplsTunnelTable1.3.6.1.2.1.10.166.13.2.5
gmplsTunnelErrorTableaugments mplsTunnelTable (MPLS-TE-STD-MIB)1.3.6.1.2.1.10.166.13.2.6

Traps (1)

NameOID
gmplsTunnelDown1.3.6.1.2.1.10.166.13.0.1

END OF TOC

Scalar details

gmplsTunnelsConfigured

1.3.6.1.2.1.10.166.13.1.1

Gauge32

The number of GMPLS tunnels configured on this device. A GMPLS tunnel is considered configured if an entry for the tunnel exists in the gmplsTunnelTable and the associated mplsTunnelRowStatus is active(1).

gmplsTunnelsActive

1.3.6.1.2.1.10.166.13.1.2

Gauge32

The number of GMPLS tunnels active on this device. A GMPLS tunnel is considered active if there is an entry in the gmplsTunnelTable and the associated mplsTunnelOperStatus for the tunnel is up(1).

Table details

gmplsTunnelTable

1.3.6.1.2.1.10.166.13.2.1

Index: mplsTunnelIndex · mplsTunnelInstance · mplsTunnelIngressLSRId · mplsTunnelEgressLSRId

Reference: 1. Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB), RFC 3812.

The gmplsTunnelTable sparsely extends the mplsTunnelTable of MPLS-TE-STD-MIB. It allows GMPLS tunnels to be created between an LSR and a remote endpoint, and existing tunnels to be reconfigured or removed. Note that only point-to-point tunnel segments are supported, although multipoint-to-point and point-to-multipoint connections are supported by an LSR acting as a cross-connect. Each tunnel can thus have one out-segment originating at this LSR and/or one in-segment terminating at this LSR. The row status of an entry in this table is controlled by the mplsTunnelRowStatus in the corresponding entry in the mplsTunnelTable. When the corresponding mplsTunnelRowStatus has value active(1), a row in this table may not be created or modified. The exception to this rule is the gmplsTunnelAdminStatusInformation object, which can be modified while the tunnel is active.

from MPLS-TE-STD-MIB

mplsTunnelIndex

MplsTunnelIndexA unique index into mplsTunnelTable. For tunnels signaled using RSVP, this value should correspond to the RSVP Tunnel ID used for the RSVP-TE session. (0..65535) · Unsigned32

Uniquely identifies a set of tunnel instances between a pair of ingress and egress LSRs. Managers should obtain new values for row creation in this table by reading mplsTunnelIndexNext. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the value signaled in the Tunnel Id of the Session object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the value signaled in the LSP ID.

mplsTunnelInstance

MplsTunnelInstanceIndexThe tunnel entry with instance index 0 should refer to the configured tunnel interface (if one exists). Values greater than 0, but less than or equal to 65535, should be used to indicate signaled (or backup) tunnel LSP instances. For tunnel LSPs signaled using RSVP, this value should correspond to the RSVP LSP ID used for the RSVP-TE LSP. Values greater than 65535 apply to FRR detour instances. (0 | 1..65535 | 65536..4294967295) · Unsigned32

Uniquely identifies a particular instance of a tunnel between a pair of ingress and egress LSRs. It is useful to identify multiple instances of tunnels for the purposes of backup and parallel tunnels. When the MPLS signaling protocol is rsvp(2) this value SHOULD be equal to the LSP Id of the Sender Template object. When the signaling protocol is crldp(3) there is no equivalent signaling object.

mplsTunnelIngressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Reference: 1. RSVP-TE: Extensions to RSVP for LSP Tunnels, Awduche et al, RFC 3209, December 2001 2. Constraint-Based LSP Setup using LDP, Jamoussi (Editor), RFC 3212, January 2002

Identity of the ingress LSR associated with this tunnel instance. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the Tunnel Sender Address in the Sender Template object and MAY be equal to the Extended Tunnel Id field in the SESSION object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the Ingress LSR Router ID field in the LSPID TLV object.

mplsTunnelEgressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Identity of the egress LSR associated with this tunnel instance.

gmplsTunnelUnnumIf

1.3.6.1.2.1.10.166.13.2.1.1.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Reference: 1. Signalling Unnumbered Links in RSVP-TE, RFC 3477.

Denotes whether or not this tunnel corresponds to an unnumbered interface represented by an entry in the interfaces group table (the ifTable) with ifType set to mpls(166). This object is only used if mplsTunnelIsIf is set to 'true'. If both this object and the mplsTunnelIsIf object are set to 'true', the originating LSR adds an LSP_TUNNEL_INTERFACE_ID object to the outgoing Path message. This object contains information that is only used by the terminating LSR.

gmplsTunnelAttributes

1.3.6.1.2.1.10.166.13.2.1.1.2

BITS

Reference: 1. RSVP-TE: Extensions to RSVP for LSP Tunnels, RFC 3209, sections 4.4.3, 4.7.1, and 4.7.2.

This bitmask indicates optional parameters for this tunnel. These bits should be taken in addition to those defined in mplsTunnelSessionAttributes in order to determine the full set of options to be signaled (for example SESSION_ATTRIBUTES flags in RSVP-TE). The following describes these bitfields: labelRecordingDesired This flag is set to indicate that label information should be included when doing a route record. This bit is not valid unless the recordRoute bit is set.

gmplsTunnelLSPEncoding

1.3.6.1.2.1.10.166.13.2.1.1.3

IANAGmplsLSPEncodingTypeTC0 = tunnelLspNotGmpls1 = tunnelLspPacket2 = tunnelLspEthernet3 = tunnelLspAnsiEtsiPdh5 = tunnelLspSdhSonet7 = tunnelLspDigitalWrapper8 = tunnelLspLambda9 = tunnelLspFiber11 = tunnelLspFiberChannel12 = tunnelDigitalPath13 = tunnelOpticalChannelThis type is used to represent and control the LSP encoding type of an LSP signaled by a GMPLS signaling protocol. This textual convention is strongly tied to the LSP Encoding Types sub-registry of the GMPLS Signaling Parameters registry managed by IANA. Values should be assigned by IANA in step with the LSP Encoding Types sub-registry and using the same registry management rules. However, the actual values used in this textual convention are solely within the purview of IANA and do not necessarily match the values in the LSP Encoding Types sub-registry. The definition of this textual convention with the addition of newly assigned values is published periodically by the IANA, in either the Assigned Numbers RFC, or some derivative of it specific to Internet Network Management number assignments. (The latest arrangements can be obtained by contacting the IANA.) Requests for new values should be made to IANA via email (iana@iana.org).Reference: 1. Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description, RFC 3471, section 3.1.1. 2. Generalized MPLS Signalling Extensions for G.709 Optical Transport Networks Control, RFC 4328, section 3.1.1. · Integer32

This object indicates the encoding of the LSP being requested. A value of 'tunnelLspNotGmpls' indicates that GMPLS signaling is not in use. Some objects in this MIB module may be of use for MPLS signaling extensions that do not use GMPLS signaling. By setting this object to 'tunnelLspNotGmpls', an application may indicate that only those objects meaningful in MPLS should be examined. The values to use are defined in the TEXTUAL-CONVENTION IANAGmplsLSPEncodingTypeTC found in the IANA-GMPLS-TC-MIB module.

gmplsTunnelSwitchingType

1.3.6.1.2.1.10.166.13.2.1.1.4

IANAGmplsSwitchingTypeTC0 = unknown1 = psc12 = psc23 = psc34 = psc451 = l2sc100 = tdm150 = lsc200 = fscThis type is used to represent and control the LSP switching type of an LSP signaled by a GMPLS signaling protocol. This textual convention is strongly tied to the Switching Types sub-registry of the GMPLS Signaling Parameters registry managed by IANA. Values should be assigned by IANA in step with the Switching Types sub-registry and using the same registry management rules. However, the actual values used in this textual convention are solely within the purview of IANA and do not necessarily match the values in the Switching Types sub-registry. The definition of this textual convention with the addition of newly assigned values is published periodically by the IANA, in either the Assigned Numbers RFC, or some derivative of it specific to Internet Network Management number assignments. (The latest arrangements can be obtained by contacting the IANA.) Requests for new values should be made to IANA via email (iana@iana.org).Reference: 1. Routing Extensions in Support of Generalized Multi-Protocol Label Switching, RFC 4202, section 2.4. 2. Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description, RFC 3471, section 3.1.1. · Integer32

Indicates the type of switching that should be performed on a particular link. This field is needed for links that advertise more than one type of switching capability. The values to use are defined in the TEXTUAL-CONVENTION IANAGmplsSwitchingTypeTC found in the IANA-GMPLS-TC-MIB module. This object is only meaningful if gmplsTunnelLSPEncodingType is not set to 'tunnelLspNotGmpls'.

gmplsTunnelLinkProtection

1.3.6.1.2.1.10.166.13.2.1.1.5

BITS

Reference: 1. Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description, RFC 3471, section 7.1.

This bitmask indicates the level of link protection required. A value of zero (no bits set) indicates that any protection may be used. The following describes these bitfields: extraTraffic This flag is set to indicate that the LSP should use links that are protecting other (primary) traffic. Such LSPs may be preempted when the links carrying the (primary) traffic being protected fail. unprotected This flag is set to indicate that the LSP should not use any link layer protection. shared This flag is set to indicate that a shared link layer protection scheme, such as 1:N protection, should be used to support the LSP. dedicatedOneToOne This flag is set to indicate that a dedicated link layer protection scheme, i.e., 1:1 protection, should be used to support the LSP. dedicatedOnePlusOne This flag is set to indicate that a dedicated link layer protection scheme, i.e., 1+1 protection, should be used to support the LSP. enhanced This flag is set to indicate that a protection scheme that is more reliable than Dedicated 1+1 should be used, e.g., 4 fiber BLSR/MS-SPRING. This object is only meaningful if gmplsTunnelLSPEncoding is not set to 'tunnelLspNotGmpls'.

gmplsTunnelGPid

1.3.6.1.2.1.10.166.13.2.1.1.6

IANAGmplsGeneralizedPidTC0 = unknown5 = asynchE46 = asynchDS3T37 = asynchE38 = bitsynchE39 = bytesynchE310 = asynchDS2T211 = bitsynchDS2T212 = reservedByRFC3471first13 = asynchE114 = bytesynchE115 = bytesynch31ByDS016 = asynchDS1T117 = bitsynchDS1T118 = bytesynchDS1T119 = vc1vc1220 = reservedByRFC3471second21 = reservedByRFC3471third22 = ds1SFAsynch23 = ds1ESFAsynch24 = ds3M23Asynch25 = ds3CBitParityAsynch26 = vtLovc27 = stsSpeHovc28 = posNoScramble16BitCrc29 = posNoScramble32BitCrc30 = posScramble16BitCrc31 = posScramble32BitCrc32 = atm33 = ethernet34 = sdhSonet36 = digitalwrapper37 = lambda38 = ansiEtsiPdh40 = lapsSdh41 = fddi42 = dqdb43 = fiberChannel344 = hdlc45 = ethernetV2DixOnly46 = ethernet802dot3Only47 = g709ODUj48 = g709OTUk49 = g709CBRorCBRa50 = g709CBRb51 = g709BSOT52 = g709BSNT53 = gfpIPorPPP54 = gfpEthernetMAC55 = gfpEthernetPHY56 = g709ESCON57 = g709FICON58 = g709FiberChannelThis data type is used to represent and control the LSP Generalized Protocol Identifier (G-PID) of an LSP signaled by a GMPLS signaling protocol. This textual convention is strongly tied to the Generalized PIDs (G-PID) sub-registry of the GMPLS Signaling Parameters registry managed by IANA. Values should be assigned by IANA in step with the Generalized PIDs (G-PID) sub-registry and using the same registry management rules. However, the actual values used in this textual convention are solely within the purview of IANA and do not necessarily match the values in the Generalized PIDs (G-PID) sub-registry. The definition of this textual convention with the addition of newly assigned values is published periodically by the IANA, in either the Assigned Numbers RFC, or some derivative of it specific to Internet Network Management number assignments. (The latest arrangements can be obtained by contacting the IANA.) Requests for new values should be made to IANA via email (iana@iana.org).Reference: 1. Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description, RFC 3471, section 3.1.1. 2. Generalized MPLS Signalling Extensions for G.709 Optical Transport Networks Control, RFC 4328, section 3.1.3. · Integer32

This object indicates the payload carried by the LSP. It is only required when GMPLS will be used for this LSP. The values to use are defined in the TEXTUAL-CONVENTION IANAGmplsGeneralizedPidTC found in the IANA-GMPLS-TC-MIB module. This object is only meaningful if gmplsTunnelLSPEncoding is not set to 'tunnelLspNotGmpls'.

gmplsTunnelSecondary

1.3.6.1.2.1.10.166.13.2.1.1.7

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Reference: 1. Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description, RFC 3471, section 7.1.

Indicates that the requested LSP is a secondary LSP. This object is only meaningful if gmplsTunnelLSPEncoding is not set to 'tunnelLspNotGmpls'.

gmplsTunnelDirection

1.3.6.1.2.1.10.166.13.2.1.1.8

INTEGER0 = forward1 = bidirectional · Integer32

Whether this tunnel carries forward data only (is unidirectional) or is bidirectional. Values of this object other than 'forward' are meaningful only if gmplsTunnelLSPEncoding is not set to 'tunnelLspNotGmpls'.

gmplsTunnelPathComp

1.3.6.1.2.1.10.166.13.2.1.1.9

INTEGER1 = dynamicFull2 = explicit3 = dynamicPartial · Integer32

Reference: 1. Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB), RFC 3812.

This value instructs the source node on how to perform path computation on the explicit route specified by the associated entries in the gmplsTunnelHopTable. dynamicFull The user specifies at least the source and destination of the path and expects that the Constrained Shortest Path First (CSPF) will calculate the remainder of the path. explicit The user specifies the entire path for the tunnel to take. This path may contain strict or loose hops. Evaluation of the explicit route will be performed hop by hop through the network. dynamicPartial The user specifies at least the source and destination of the path and expects that the CSPF will calculate the remainder of the path. The path computed by CSPF is allowed to be only partially computed allowing the remainder of the path to be filled in across the network. When an entry is present in the gmplsTunnelTable for a tunnel, gmplsTunnelPathComp MUST be used and any corresponding mplsTunnelHopEntryPathComp object in the mplsTunnelHopTable MUST be ignored and SHOULD not be set. mplsTunnelHopTable and mplsTunnelHopEntryPathComp are part of MPLS-TE-STD-MIB. This object should be ignored if the value of gmplsTunnelLSPEncoding is 'tunnelLspNotGmpls'.

gmplsTunnelUpstreamNotifyRecipientType

1.3.6.1.2.1.10.166.13.2.1.1.10

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object is used to aid in interpretation of gmplsTunnelUpstreamNotifyRecipient.

gmplsTunnelUpstreamNotifyRecipient

1.3.6.1.2.1.10.166.13.2.1.1.11

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Reference: 1. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473, section 4.2.

Indicates the address of the upstream recipient for Notify messages relating to this tunnel and issued by this LSR. This information is typically received from an upstream LSR in a Path message. This object is only valid when signaling a tunnel using RSVP. It is also not valid at the head end of a tunnel since there are no upstream LSRs to which to send a Notify message. This object is interpreted in the context of the value of gmplsTunnelUpstreamNotifyRecipientType. If this object is set to 0, the value of gmplsTunnelUpstreamNotifyRecipientType MUST be set to unknown(0).

gmplsTunnelSendResvNotifyRecipientType

1.3.6.1.2.1.10.166.13.2.1.1.12

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object is used to aid in interpretation of gmplsTunnelSendResvNotifyRecipient.

gmplsTunnelSendResvNotifyRecipient

1.3.6.1.2.1.10.166.13.2.1.1.13

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Reference: 1. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473, section 4.2.

Indicates to an upstream LSR the address to which it should send downstream Notify messages relating to this tunnel. This object is only valid when signaling a tunnel using RSVP. It is also not valid at the head end of the tunnel since no Resv messages are sent from that LSR for this tunnel. If set to 0, no Notify Request object will be included in the outgoing Resv messages. This object is interpreted in the context of the value of gmplsTunnelSendResvNotifyRecipientType. If this object is set to 0, the value of gmplsTunnelSendResvNotifyRecipientType MUST be set to unknown(0).

gmplsTunnelDownstreamNotifyRecipientType

1.3.6.1.2.1.10.166.13.2.1.1.14

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object is used to aid in interpretation of gmplsTunnelDownstreamNotifyRecipient.

gmplsTunnelDownstreamNotifyRecipient

1.3.6.1.2.1.10.166.13.2.1.1.15

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Reference: 1. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473, section 4.2.

Indicates the address of the downstream recipient for Notify messages relating to this tunnel and issued by this LSR. This information is typically received from an upstream LSR in a Resv message. This object is only valid when signaling a tunnel using RSVP. It is also not valid at the tail end of a tunnel since there are no downstream LSRs to which to send a Notify message. This object is interpreted in the context of the value of gmplsTunnelDownstreamNotifyRecipientType. If this object is set to 0, the value of gmplsTunnelDownstreamNotifyRecipientType MUST be set to unknown(0).

gmplsTunnelSendPathNotifyRecipientType

1.3.6.1.2.1.10.166.13.2.1.1.16

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object is used to aid in interpretation of gmplsTunnelSendPathNotifyRecipient.

gmplsTunnelSendPathNotifyRecipient

1.3.6.1.2.1.10.166.13.2.1.1.17

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Reference: 1. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473, section 4.2.

Indicates to a downstream LSR the address to which it should send upstream Notify messages relating to this tunnel. This object is only valid when signaling a tunnel using RSVP. It is also not valid at the tail end of the tunnel since no Path messages are sent from that LSR for this tunnel. If set to 0, no Notify Request object will be included in the outgoing Path messages. This object is interpreted in the context of the value of gmplsTunnelSendPathNotifyRecipientType. If this object is set to 0, the value of gmplsTunnelSendPathNotifyRecipientType MUST be set to unknown(0).

gmplsTunnelAdminStatusFlags

1.3.6.1.2.1.10.166.13.2.1.1.18

IANAGmplsAdminStatusInformationTCThis data type determines the setting of the Admin Status flags in the Admin Status object or TLV, as described in RFC 3471. Setting this object to a non-zero value will result in the inclusion of the Admin Status object or TLV on signaling messages. This textual convention is strongly tied to the Administrative Status Information Flags sub-registry of the GMPLS Signaling Parameters registry managed by IANA. Values should be assigned by IANA in step with the Administrative Status Flags sub-registry and using the same registry management rules. However, the actual values used in this textual convention are solely within the purview of IANA and do not necessarily match the values in the Administrative Status Information Flags sub-registry. The definition of this textual convention with the addition of newly assigned values is published periodically by the IANA, in either the Assigned Numbers RFC, or some derivative of it specific to Internet Network Management number assignments. (The latest arrangements can be obtained by contacting the IANA.) Requests for new values should be made to IANA via email (iana@iana.org).Reference: 1. Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description, RFC 3471, section 8. 2. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473, section 7. 3. GMPLS - Communication of Alarm Information, RFC 4783, section 3.2.1. · BITS

Reference: 1. Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description, RFC 3471, section 8.

Determines the setting of the Admin Status flags in the Admin Status object or TLV, as described in RFC 3471. Setting this field to a non-zero value will result in the inclusion of the Admin Status object on signaling messages. The values to use are defined in the TEXTUAL-CONVENTION IANAGmplsAdminStatusInformationTC found in the IANA-GMPLS-TC-MIB module. This value of this object can be modified when the corresponding mplsTunnelRowStatus and mplsTunnelAdminStatus is active(1). By doing so, a new signaling message will be triggered including the requested Admin Status object or TLV.

gmplsTunnelExtraParamsPtr

1.3.6.1.2.1.10.166.13.2.1.1.19

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

Some tunnels will run over transports that can usefully support technology-specific additional parameters (for example, Synchronous Optical Network (SONET) resource usage). Such parameters can be supplied in an external table and referenced from here. A value of zeroDotzero in this attribute indicates that there is no such additional information.

gmplsTunnelHopTable

1.3.6.1.2.1.10.166.13.2.2

Index: mplsTunnelHopListIndex · mplsTunnelHopPathOptionIndex · mplsTunnelHopIndex

Reference: 1. Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB), RFC 3812. 2. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473.

The gmplsTunnelHopTable sparsely extends the mplsTunnelHopTable of MPLS-TE-STD-MIB. It is used to indicate the Explicit Labels to be used in an explicit path for a GMPLS tunnel defined in the mplsTunnelTable and gmplsTunnelTable, when it is established using signaling. It does not insert new hops, but does define new values for hops defined in the mplsTunnelHopTable. Each row in this table is indexed by the same indexes as in the mplsTunnelHopTable. It is acceptable for some rows in the mplsTunnelHopTable to have corresponding entries in this table and some to have no corresponding entry in this table. The storage type for this entry is given by the value of mplsTunnelHopStorageType in the corresponding entry in the mplsTunnelHopTable. The row status of an entry in this table is controlled by mplsTunnelHopRowStatus in the corresponding entry in the mplsTunnelHopTable. That is, it is not permitted to create a row in this table, or to modify an existing row, when the corresponding mplsTunnelHopRowStatus has the value active(1).

from MPLS-TE-STD-MIB

mplsTunnelHopListIndex

MplsPathIndexA unique value to index (by Path number) an entry in a table. (1..4294967295) · Unsigned32

Primary index into this table identifying a particular explicit route object.

mplsTunnelHopPathOptionIndex

MplsPathIndexA unique value to index (by Path number) an entry in a table. (1..4294967295) · Unsigned32

Secondary index into this table identifying a particular group of hops representing a particular configured path. This is otherwise known as a path option.

mplsTunnelHopIndex

MplsPathIndexA unique value to index (by Path number) an entry in a table. (1..4294967295) · Unsigned32

Tertiary index into this table identifying a particular hop.

gmplsTunnelHopLabelStatuses

1.3.6.1.2.1.10.166.13.2.2.1.1

BITS

This bitmask indicates the presence of labels indicated by the gmplsTunnelHopExplicitForwardLabel or gmplsTunnelHopExplicitForwardLabelPtr, and gmplsTunnelHopExplicitReverseLabel or gmplsTunnelHopExplicitReverseLabelPtr objects. For the Present bits, a set bit indicates that a label is present for this hop in the route. This allows zero to be a valid label value.

gmplsTunnelHopExplicitForwardLabel

1.3.6.1.2.1.10.166.13.2.2.1.2

Unsigned32

If gmplsTunnelHopLabelStatuses object indicates that a Forward Label is present and gmplsTunnelHopExplicitForwardLabelPtr contains the value zeroDotZero, then the label to use on this hop is represented by the value of this object.

gmplsTunnelHopExplicitForwardLabelPtr

1.3.6.1.2.1.10.166.13.2.2.1.3

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

If the gmplsTunnelHopLabelStatuses object indicates that a Forward Label is present, this object contains a pointer to a row in another MIB table (such as the gmplsLabelTable of GMPLS-LABEL-STD-MIB) that contains the label to use on this hop in the forward direction. If the gmplsTunnelHopLabelStatuses object indicates that a Forward Label is present and this object contains the value zeroDotZero, then the label to use on this hop is found in the gmplsTunnelHopExplicitForwardLabel object.

gmplsTunnelHopExplicitReverseLabel

1.3.6.1.2.1.10.166.13.2.2.1.4

Unsigned32

If the gmplsTunnelHopLabelStatuses object indicates that a Reverse Label is present and gmplsTunnelHopExplicitReverseLabelPtr contains the value zeroDotZero, then the label to use on this hop is found in this object encoded as a 32-bit integer.

gmplsTunnelHopExplicitReverseLabelPtr

1.3.6.1.2.1.10.166.13.2.2.1.5

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

If the gmplsTunnelHopLabelStatuses object indicates that a Reverse Label is present, this object contains a pointer to a row in another MIB table (such as the gmplsLabelTable of GMPLS-LABEL-STD-MIB) that contains the label to use on this hop in the reverse direction. If the gmplsTunnelHopLabelStatuses object indicates that a Reverse Label is present and this object contains the value zeroDotZero, then the label to use on this hop is found in the gmplsTunnelHopExplicitReverseLabel object.

gmplsTunnelARHopTable

1.3.6.1.2.1.10.166.13.2.3

Index: mplsTunnelARHopListIndex · mplsTunnelARHopIndex

Reference: 1. Extensions to RSVP for LSP Tunnels, RFC 3209. 2. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473. 3. Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB), RFC 3812.

The gmplsTunnelARHopTable sparsely extends the mplsTunnelARHopTable of MPLS-TE-STD-MIB. It is used to indicate the labels currently in use for a GMPLS tunnel defined in the mplsTunnelTable and gmplsTunnelTable, as reported by the signaling protocol. It does not insert new hops, but does define new values for hops defined in the mplsTunnelARHopTable. Each row in this table is indexed by the same indexes as in the mplsTunnelARHopTable. It is acceptable for some rows in the mplsTunnelARHopTable to have corresponding entries in this table and some to have no corresponding entry in this table. Note that since the information necessary to build entries within this table is not provided by some signaling protocols and might not be returned in all cases of other signaling protocols, implementation of this table and the mplsTunnelARHopTable is optional. Furthermore, since the information in this table is actually provided by the signaling protocol after the path has been set up, the entries in this table are provided only for observation, and hence, all variables in this table are accessible exclusively as read-only.

from MPLS-TE-STD-MIB

mplsTunnelARHopListIndex

MplsPathIndexA unique value to index (by Path number) an entry in a table. (1..4294967295) · Unsigned32

Primary index into this table identifying a particular recorded hop list.

mplsTunnelARHopIndex

MplsPathIndexA unique value to index (by Path number) an entry in a table. (1..4294967295) · Unsigned32

Secondary index into this table identifying the particular hop.

gmplsTunnelARHopLabelStatuses

1.3.6.1.2.1.10.166.13.2.3.1.1

BITS

This bitmask indicates the presence and status of labels indicated by the gmplsTunnelARHopExplicitForwardLabel or gmplsTunnelARHopExplicitForwardLabelPtr, and gmplsTunnelARHopExplicitReverseLabel or gmplsTunnelARHopExplicitReverseLabelPtr objects. For the Present bits, a set bit indicates that a label is present for this hop in the route. For the Global bits, a set bit indicates that the label comes from the Global Label Space; a clear bit indicates that this is a Per-Interface label. A Global bit only has meaning if the corresponding Present bit is set.

gmplsTunnelARHopExplicitForwardLabel

1.3.6.1.2.1.10.166.13.2.3.1.2

Unsigned32

If the gmplsTunnelARHopLabelStatuses object indicates that a Forward Label is present and gmplsTunnelARHopExplicitForwardLabelPtr contains the value zeroDotZero, then the label in use on this hop is found in this object encoded as a 32-bit integer.

gmplsTunnelARHopExplicitForwardLabelPtr

1.3.6.1.2.1.10.166.13.2.3.1.3

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

If the gmplsTunnelARHopLabelStatuses object indicates that a Forward Label is present, this object contains a pointer to a row in another MIB table (such as the gmplsLabelTable of GMPLS-LABEL-STD-MIB) that contains the label in use on this hop in the forward direction. If the gmplsTunnelARHopLabelStatuses object indicates that a Forward Label is present and this object contains the value zeroDotZero, then the label in use on this hop is found in the gmplsTunnelARHopExplicitForwardLabel object.

gmplsTunnelARHopExplicitReverseLabel

1.3.6.1.2.1.10.166.13.2.3.1.4

Unsigned32

If the gmplsTunnelARHopLabelStatuses object indicates that a Reverse Label is present and gmplsTunnelARHopExplicitReverseLabelPtr contains the value zeroDotZero, then the label in use on this hop is found in this object encoded as a 32-bit integer.

gmplsTunnelARHopExplicitReverseLabelPtr

1.3.6.1.2.1.10.166.13.2.3.1.5

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

If the gmplsTunnelARHopLabelStatuses object indicates that a Reverse Label is present, this object contains a pointer to a row in another MIB table (such as the gmplsLabelTable of GMPLS-LABEL-STD-MIB) that contains the label in use on this hop in the reverse direction. If the gmplsTunnelARHopLabelStatuses object indicates that a Reverse Label is present and this object contains the value zeroDotZero, then the label in use on this hop is found in the gmplsTunnelARHopExplicitReverseLabel object.

gmplsTunnelARHopProtection

1.3.6.1.2.1.10.166.13.2.3.1.6

BITS

Reference: 1. RSVP-TE: Extensions to RSVP for LSP Tunnels, RFC 3209, section 4.4.1.

Availability and usage of protection on the reported link. localAvailable This flag is set to indicate that the link downstream of this node is protected via a local repair mechanism. localInUse This flag is set to indicate that a local repair mechanism is in use to maintain this tunnel (usually in the face of an outage of the link it was previously routed over).

gmplsTunnelCHopTable

1.3.6.1.2.1.10.166.13.2.4

Index: mplsTunnelCHopListIndex · mplsTunnelCHopIndex

Reference: 1. Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB), RFC 3812. 2. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473.

The gmplsTunnelCHopTable sparsely extends the mplsTunnelCHopTable of MPLS-TE-STD-MIB. It is used to indicate additional information about the hops of a GMPLS tunnel defined in the mplsTunnelTable and gmplsTunnelTable, as computed by a constraint-based routing protocol, based on the mplsTunnelHopTable and the gmplsTunnelHopTable. Each row in this table is indexed by the same indexes as in the mplsTunnelCHopTable. It is acceptable for some rows in the mplsTunnelCHopTable to have corresponding entries in this table and some to have no corresponding entry in this table. Please note that since the information necessary to build entries within this table may not be supported by some LSRs, implementation of this table is optional. Furthermore, since the information in this table is actually provided by a path computation component after the path has been computed, the entries in this table are provided only for observation, and hence, all objects in this table are accessible exclusively as read-only.

from MPLS-TE-STD-MIB

mplsTunnelCHopListIndex

MplsPathIndexA unique value to index (by Path number) an entry in a table. (1..4294967295) · Unsigned32

Primary index into this table identifying a particular computed hop list.

mplsTunnelCHopIndex

MplsPathIndexA unique value to index (by Path number) an entry in a table. (1..4294967295) · Unsigned32

Secondary index into this table identifying the particular hop.

gmplsTunnelCHopLabelStatuses

1.3.6.1.2.1.10.166.13.2.4.1.1

BITS

This bitmask indicates the presence of labels indicated by the gmplsTunnelCHopExplicitForwardLabel or gmplsTunnelCHopExplicitForwardLabelPtr and gmplsTunnelCHopExplicitReverseLabel or gmplsTunnelCHopExplicitReverseLabelPtr objects. A set bit indicates that a label is present for this hop in the route, thus allowing zero to be a valid label value.

gmplsTunnelCHopExplicitForwardLabel

1.3.6.1.2.1.10.166.13.2.4.1.2

Unsigned32

If the gmplsTunnelCHopLabelStatuses object indicates that a Forward Label is present and gmplsTunnelCHopExplicitForwardLabelPtr contains the value zeroDotZero, then the label to use on this hop is found in this object encoded as a 32-bit integer.

gmplsTunnelCHopExplicitForwardLabelPtr

1.3.6.1.2.1.10.166.13.2.4.1.3

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

If the gmplsTunnelCHopLabelStatuses object indicates that a Forward Label is present, this object contains a pointer to a row in another MIB table (such as the gmplsLabelTable of GMPLS-LABEL-STD-MIB) that contains the label to use on this hop in the forward direction. If the gmplsTunnelCHopLabelStatuses object indicates that a Forward Label is present and this object contains the value zeroDotZero, then the label to use on this hop is found in the gmplsTunnelCHopExplicitForwardLabel object.

gmplsTunnelCHopExplicitReverseLabel

1.3.6.1.2.1.10.166.13.2.4.1.4

Unsigned32

If the gmplsTunnelCHopLabelStatuses object indicates that a Reverse Label is present and gmplsTunnelCHopExplicitReverseLabelPtr contains the value zeroDotZero, then the label to use on this hop is found in this object encoded as a 32-bit integer.

gmplsTunnelCHopExplicitReverseLabelPtr

1.3.6.1.2.1.10.166.13.2.4.1.5

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

If the gmplsTunnelCHopLabelStatuses object indicates that a Reverse Label is present, this object contains a pointer to a row in another MIB table (such as the gmplsLabelTable of GMPLS-LABEL-STD-MIB) that contains the label to use on this hop in the reverse direction. If the gmplsTunnelCHopLabelStatuses object indicates that a Reverse Label is present and this object contains the value zeroDotZero, then the label to use on this hop is found in the gmplsTunnelCHopExplicitReverseLabel object.

gmplsTunnelReversePerfTable

1.3.6.1.2.1.10.166.13.2.5

augments gmplsTunnelTable

Index: mplsTunnelIndex · mplsTunnelInstance · mplsTunnelIngressLSRId · mplsTunnelEgressLSRId

Reference: 1. Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB), RFC 3812.

This table augments the gmplsTunnelTable to provide per-tunnel packet performance information for the reverse direction of a bidirectional tunnel. It can be seen as supplementing the mplsTunnelPerfTable, which augments the mplsTunnelTable. For links that do not transport packets, these packet counters cannot be maintained. For such links, attempts to read the objects in this table will return noSuchInstance. A tunnel can be known to be bidirectional by inspecting the gmplsTunnelDirection object.

from MPLS-TE-STD-MIB

mplsTunnelIndex

MplsTunnelIndexA unique index into mplsTunnelTable. For tunnels signaled using RSVP, this value should correspond to the RSVP Tunnel ID used for the RSVP-TE session. (0..65535) · Unsigned32

Uniquely identifies a set of tunnel instances between a pair of ingress and egress LSRs. Managers should obtain new values for row creation in this table by reading mplsTunnelIndexNext. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the value signaled in the Tunnel Id of the Session object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the value signaled in the LSP ID.

mplsTunnelInstance

MplsTunnelInstanceIndexThe tunnel entry with instance index 0 should refer to the configured tunnel interface (if one exists). Values greater than 0, but less than or equal to 65535, should be used to indicate signaled (or backup) tunnel LSP instances. For tunnel LSPs signaled using RSVP, this value should correspond to the RSVP LSP ID used for the RSVP-TE LSP. Values greater than 65535 apply to FRR detour instances. (0 | 1..65535 | 65536..4294967295) · Unsigned32

Uniquely identifies a particular instance of a tunnel between a pair of ingress and egress LSRs. It is useful to identify multiple instances of tunnels for the purposes of backup and parallel tunnels. When the MPLS signaling protocol is rsvp(2) this value SHOULD be equal to the LSP Id of the Sender Template object. When the signaling protocol is crldp(3) there is no equivalent signaling object.

mplsTunnelIngressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Reference: 1. RSVP-TE: Extensions to RSVP for LSP Tunnels, Awduche et al, RFC 3209, December 2001 2. Constraint-Based LSP Setup using LDP, Jamoussi (Editor), RFC 3212, January 2002

Identity of the ingress LSR associated with this tunnel instance. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the Tunnel Sender Address in the Sender Template object and MAY be equal to the Extended Tunnel Id field in the SESSION object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the Ingress LSR Router ID field in the LSPID TLV object.

mplsTunnelEgressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Identity of the egress LSR associated with this tunnel instance.

gmplsTunnelReversePerfPackets

1.3.6.1.2.1.10.166.13.2.5.1.1

Counter32

Number of packets forwarded on the tunnel in the reverse direction if it is bidirectional. This object represents the 32-bit value of the least significant part of the 64-bit value if both gmplsTunnelReversePerfHCPackets and this object are returned. For links that do not transport packets, this packet counter cannot be maintained. For such links, this value will return noSuchInstance.

gmplsTunnelReversePerfHCPackets

1.3.6.1.2.1.10.166.13.2.5.1.2

Counter64 (0..18446744073709551615)

High-capacity counter for number of packets forwarded on the tunnel in the reverse direction if it is bidirectional. For links that do not transport packets, this packet counter cannot be maintained. For such links, this value will return noSuchInstance.

gmplsTunnelReversePerfErrors

1.3.6.1.2.1.10.166.13.2.5.1.3

Counter32

Number of errored packets received on the tunnel in the reverse direction if it is bidirectional. For links that do not transport packets, this packet counter cannot be maintained. For such links, this value will return noSuchInstance.

gmplsTunnelReversePerfBytes

1.3.6.1.2.1.10.166.13.2.5.1.4

Counter32

Number of bytes forwarded on the tunnel in the reverse direction if it is bidirectional. This object represents the 32-bit value of the least significant part of the 64-bit value if both gmplsTunnelReversePerfHCBytes and this object are returned. For links that do not transport packets, this packet counter cannot be maintained. For such links, this value will return noSuchInstance.

gmplsTunnelReversePerfHCBytes

1.3.6.1.2.1.10.166.13.2.5.1.5

Counter64 (0..18446744073709551615)

High-capacity counter for number of bytes forwarded on the tunnel in the reverse direction if it is bidirectional. For links that do not transport packets, this packet counter cannot be maintained. For such links, this value will return noSuchInstance.

gmplsTunnelErrorTable

1.3.6.1.2.1.10.166.13.2.6

augments mplsTunnelTable (MPLS-TE-STD-MIB)

Index: mplsTunnelIndex · mplsTunnelInstance · mplsTunnelIngressLSRId · mplsTunnelEgressLSRId

Reference: 1. Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB), RFC 3812.

This table augments the mplsTunnelTable. This table provides per-tunnel information about errors. Errors may be detected locally or reported through the signaling protocol. Error reporting is not exclusive to GMPLS, and this table may be applied in MPLS systems. Entries in this table are not persistent over system resets or re-initializations of the management system.

from MPLS-TE-STD-MIB

mplsTunnelIndex

MplsTunnelIndexA unique index into mplsTunnelTable. For tunnels signaled using RSVP, this value should correspond to the RSVP Tunnel ID used for the RSVP-TE session. (0..65535) · Unsigned32

Uniquely identifies a set of tunnel instances between a pair of ingress and egress LSRs. Managers should obtain new values for row creation in this table by reading mplsTunnelIndexNext. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the value signaled in the Tunnel Id of the Session object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the value signaled in the LSP ID.

mplsTunnelInstance

MplsTunnelInstanceIndexThe tunnel entry with instance index 0 should refer to the configured tunnel interface (if one exists). Values greater than 0, but less than or equal to 65535, should be used to indicate signaled (or backup) tunnel LSP instances. For tunnel LSPs signaled using RSVP, this value should correspond to the RSVP LSP ID used for the RSVP-TE LSP. Values greater than 65535 apply to FRR detour instances. (0 | 1..65535 | 65536..4294967295) · Unsigned32

Uniquely identifies a particular instance of a tunnel between a pair of ingress and egress LSRs. It is useful to identify multiple instances of tunnels for the purposes of backup and parallel tunnels. When the MPLS signaling protocol is rsvp(2) this value SHOULD be equal to the LSP Id of the Sender Template object. When the signaling protocol is crldp(3) there is no equivalent signaling object.

mplsTunnelIngressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Reference: 1. RSVP-TE: Extensions to RSVP for LSP Tunnels, Awduche et al, RFC 3209, December 2001 2. Constraint-Based LSP Setup using LDP, Jamoussi (Editor), RFC 3212, January 2002

Identity of the ingress LSR associated with this tunnel instance. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the Tunnel Sender Address in the Sender Template object and MAY be equal to the Extended Tunnel Id field in the SESSION object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the Ingress LSR Router ID field in the LSPID TLV object.

mplsTunnelEgressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Identity of the egress LSR associated with this tunnel instance.

gmplsTunnelErrorLastErrorType

1.3.6.1.2.1.10.166.13.2.6.1.1

INTEGER0 = noError1 = unknown2 = protocol3 = pathComputation4 = localConfiguration5 = localResources6 = localOther · Integer32

The nature of the last error. Provides interpretation context for gmplsTunnelErrorProtocolCode and gmplsTunnelErrorProtocolSubcode. A value of noError(0) shows that there is no error associated with this tunnel and means that the other objects in this table entry (conceptual row) have no meaning. A value of unknown(1) shows that there is an error but that no additional information about the cause is known. The error may have been received in a signaled message or generated locally. A value of protocol(2) or pathComputation(3) indicates the cause of an error and identifies an error that has been received through signaling or will itself be signaled. A value of localConfiguration(4), localResources(5) or localOther(6) identifies an error that has been detected by the local node but that will not be reported through signaling.

gmplsTunnelErrorLastTime

1.3.6.1.2.1.10.166.13.2.6.1.2

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The time at which the last error occurred. This is presented as the value of SysUpTime when the error occurred or was reported to this node. If gmplsTunnelErrorLastErrorType has the value noError(0), then this object is not valid and should be ignored. Note that entries in this table are not persistent over system resets or re-initializations of the management system.

gmplsTunnelErrorReporterType

1.3.6.1.2.1.10.166.13.2.6.1.3

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The address type of the error reported. This object is used to aid in interpretation of gmplsTunnelErrorReporter.

gmplsTunnelErrorReporter

1.3.6.1.2.1.10.166.13.2.6.1.4

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Reference: 1. Textual Conventions for Internet Network Addresses, RFC 4001, section 4, Usage Hints.

The address of the node reporting the last error, or the address of the resource (such as an interface) associated with the error. If gmplsTunnelErrorLastErrorType has the value noError(0), then this object is not valid and should be ignored. If gmplsTunnelErrorLastErrorType has the value unknown(1), localConfiguration(4), localResources(5), or localOther(6), this object MAY contain a zero value. This object should be interpreted in the context of the value of the object gmplsTunnelErrorReporterType.

gmplsTunnelErrorCode

1.3.6.1.2.1.10.166.13.2.6.1.5

Unsigned32

Reference: 1. Resource ReserVation Protocol -- Version 1 Functional Specification, RFC 2205, section B. 2. RSVP-TE: Extensions to RSVP for LSP Tunnels, RFC 3209, section 7.3. 3. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473, section 13.1.

The primary error code associated with the last error. The interpretation of this error code depends on the value of gmplsTunnelErrorLastErrorType. If the value of gmplsTunnelErrorLastErrorType is noError(0), the value of this object should be 0 and should be ignored. If the value of gmplsTunnelErrorLastErrorType is protocol(2), the error should be interpreted in the context of the signaling protocol identified by the mplsTunnelSignallingProto object.

gmplsTunnelErrorSubcode

1.3.6.1.2.1.10.166.13.2.6.1.6

Unsigned32

Reference: 1. Resource ReserVation Protocol -- Version 1 Functional Specification, RFC 2205, section B. 2. RSVP-TE: Extensions to RSVP for LSP Tunnels, RFC 3209, section 7.3. 3. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473, section 13.1.

The secondary error code associated with the last error and the protocol used to signal this tunnel. This value is interpreted in the context of the value of gmplsTunnelErrorCode. If the value of gmplsTunnelErrorLastErrorType is noError(0), the value of this object should be 0 and should be ignored.

gmplsTunnelErrorTLVs

1.3.6.1.2.1.10.166.13.2.6.1.7

OCTET STRING SIZE (0..65535)

Reference: 1. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473, section 8.2.

The sequence of interface identifier TLVs reported with the error by the protocol code. The interpretation of the TLVs and the encoding within the protocol are described in the references. A value of zero in the first octet indicates that no TLVs are present.

gmplsTunnelErrorHelpString

1.3.6.1.2.1.10.166.13.2.6.1.8

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

A textual string containing information about the last error, recovery actions, and support advice. If there is no help string, this object contains a zero length string. If the value of gmplsTunnelErrorLastErrorType is noError(0), this object should contain a zero length string, but may contain a help string indicating that there is no error.

Trap details

gmplsTunnelDown

1.3.6.1.2.1.10.166.13.0.1

Reference: 1. Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB), RFC 3812.

This notification is generated when an mplsTunnelOperStatus object for a tunnel in the gmplsTunnelTable is about to enter the down state from some other state (but not from the notPresent state). This other state is indicated by the included value of mplsTunnelOperStatus. The objects in this notification provide additional error information that indicates the reason why the tunnel has transitioned to down(2). Note that an implementation MUST only issue one of mplsTunnelDown and gmplsTunnelDown for any single event on a single tunnel. If the tunnel has an entry in the gmplsTunnelTable, an implementation SHOULD use gmplsTunnelDown for all tunnel-down events and SHOULD NOT use mplsTunnelDown. This notification is subject to the control of mplsTunnelNotificationEnable. When that object is set to false(2), then the notification must not be issued. Further, this notification is also subject to mplsTunnelNotificationMaxRate. That object indicates the maximum number of notifications issued per second. If events occur more rapidly, the implementation may simply fail to emit some notifications during that period, or may queue them until an appropriate time. The notification rate applies to the sum of all notifications in the MPLS-TE-STD-MIB and GMPLS-TE-STD-MIB modules applied across the whole of the reporting device. mplsTunnelOperStatus, mplsTunnelAdminStatus, mplsTunnelDown, mplsTunnelNotificationEnable, and mplsTunnelNotificationMaxRate objects are found in MPLS-TE-STD-MIB.

mplsTunnelAdminStatus

1.3.6.1.2.1.10.166.3.2.2.1.34

INTEGER1 = up2 = down3 = testing · Integer32

Indicates the desired operational status of this tunnel.

mplsTunnelOperStatus

1.3.6.1.2.1.10.166.3.2.2.1.35

INTEGER1 = up2 = down3 = testing4 = unknown5 = dormant6 = notPresent7 = lowerLayerDown · Integer32

Indicates the actual operational status of this tunnel, which is typically but not limited to, a function of the state of individual segments of this tunnel.

gmplsTunnelErrorLastErrorType

1.3.6.1.2.1.10.166.13.2.6.1.1

INTEGER0 = noError1 = unknown2 = protocol3 = pathComputation4 = localConfiguration5 = localResources6 = localOther · Integer32

The nature of the last error. Provides interpretation context for gmplsTunnelErrorProtocolCode and gmplsTunnelErrorProtocolSubcode. A value of noError(0) shows that there is no error associated with this tunnel and means that the other objects in this table entry (conceptual row) have no meaning. A value of unknown(1) shows that there is an error but that no additional information about the cause is known. The error may have been received in a signaled message or generated locally. A value of protocol(2) or pathComputation(3) indicates the cause of an error and identifies an error that has been received through signaling or will itself be signaled. A value of localConfiguration(4), localResources(5) or localOther(6) identifies an error that has been detected by the local node but that will not be reported through signaling.

gmplsTunnelErrorReporterType

1.3.6.1.2.1.10.166.13.2.6.1.3

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The address type of the error reported. This object is used to aid in interpretation of gmplsTunnelErrorReporter.

gmplsTunnelErrorReporter

1.3.6.1.2.1.10.166.13.2.6.1.4

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Reference: 1. Textual Conventions for Internet Network Addresses, RFC 4001, section 4, Usage Hints.

The address of the node reporting the last error, or the address of the resource (such as an interface) associated with the error. If gmplsTunnelErrorLastErrorType has the value noError(0), then this object is not valid and should be ignored. If gmplsTunnelErrorLastErrorType has the value unknown(1), localConfiguration(4), localResources(5), or localOther(6), this object MAY contain a zero value. This object should be interpreted in the context of the value of the object gmplsTunnelErrorReporterType.

gmplsTunnelErrorCode

1.3.6.1.2.1.10.166.13.2.6.1.5

Unsigned32

Reference: 1. Resource ReserVation Protocol -- Version 1 Functional Specification, RFC 2205, section B. 2. RSVP-TE: Extensions to RSVP for LSP Tunnels, RFC 3209, section 7.3. 3. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473, section 13.1.

The primary error code associated with the last error. The interpretation of this error code depends on the value of gmplsTunnelErrorLastErrorType. If the value of gmplsTunnelErrorLastErrorType is noError(0), the value of this object should be 0 and should be ignored. If the value of gmplsTunnelErrorLastErrorType is protocol(2), the error should be interpreted in the context of the signaling protocol identified by the mplsTunnelSignallingProto object.

gmplsTunnelErrorSubcode

1.3.6.1.2.1.10.166.13.2.6.1.6

Unsigned32

Reference: 1. Resource ReserVation Protocol -- Version 1 Functional Specification, RFC 2205, section B. 2. RSVP-TE: Extensions to RSVP for LSP Tunnels, RFC 3209, section 7.3. 3. Generalized MPLS Signaling - RSVP-TE Extensions, RFC 3473, section 13.1.

The secondary error code associated with the last error and the protocol used to signal this tunnel. This value is interpreted in the context of the value of gmplsTunnelErrorCode. If the value of gmplsTunnelErrorLastErrorType is noError(0), the value of this object should be 0 and should be ignored.

↑ To TOC