EZ5 MIB Catalog

ITU-ALARM-MIB

2004-09-09

Download ITU-ALARM-MIB.txt Open ITU-ALARM-MIB.txt in a new tab

The MIB module describes ITU Alarm information as defined in ITU Recommendation M.3100 [M.3100], X.733 [X.733] and X.736 [X.736]. Copyright (C) The Internet Society (2004). The initial version of this MIB module was published in RFC 3877. For full legal notices see the RFC itself. Supplementary information may be available on: http://www.ietf.org/copyrights/ianamib.html

TABLES (3)

Tables (3)

NameOID
ituAlarmTable1.3.6.1.2.1.121.1.1.1
ituAlarmActiveTable1.3.6.1.2.1.121.1.2.1
ituAlarmActiveStatsTable1.3.6.1.2.1.121.1.2.2

END OF TOC

Table details

ituAlarmTable

1.3.6.1.2.1.121.1.1.1

Index: alarmListName · alarmModelIndex · ituAlarmPerceivedSeverity

A table of ITU Alarm information for possible alarms on the system.

from ALARM-MIB

alarmListName

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

The name of the list of alarms. This SHOULD be the same as nlmLogName if the Notification Log MIB [RFC3014] is supported. This SHOULD be the same as, or contain as a prefix, the applicable snmpNotifyFilterProfileName if the SNMP-NOTIFICATION-MIB DEFINITIONS [RFC3413] is supported. An implementation may allow multiple named alarm lists, up to some implementation-specific limit (which may be none). A zero-length list name is reserved for creation and deletion by the managed system, and MUST be used as the default log name by systems that do not support named alarm lists.

alarmModelIndex

Unsigned32 (1..4294967295)

An integer that acts as an alarm Id to uniquely identify each alarm within the named alarm list.

ituAlarmPerceivedSeverity

1.3.6.1.2.1.121.1.1.1.1.1

ItuPerceivedSeverity1 = cleared2 = indeterminate3 = critical4 = major5 = minor6 = warningITU perceived severity valuesReference: ITU Recommendation M.3100, 'Generic Network Information Model', 1995 ITU Recommendation X.733, 'Information Technology - Open Systems Interconnection - System Management: Alarm Reporting Function', 1992 · Integer32

ITU perceived severity values.

ituAlarmEventType

1.3.6.1.2.1.121.1.1.1.1.2

IANAItuEventType1 = other2 = communicationsAlarm3 = qualityOfServiceAlarm4 = processingErrorAlarm5 = equipmentAlarm6 = environmentalAlarm7 = integrityViolation8 = operationalViolation9 = physicalViolation10 = securityServiceOrMechanismViolation11 = timeDomainViolationThe ITU event Type values. The Internet Assigned Number Authority (IANA) is responsible for the assignment of the enumerations in this TC. Request should come in the form of well-formed SMI [RFC2578] for enumeration names that are unique and sufficiently descriptive. See http://www.iana.orgReference: ITU Recommendation X.736, 'Information Technology - Open Systems Interconnection - System Management: Security Alarm Reporting Function', 1992 · Integer32

Represents the event type values for the alarms

ituAlarmProbableCause

1.3.6.1.2.1.121.1.1.1.1.3

IANAItuProbableCause1 = aIS2 = callSetUpFailure3 = degradedSignal4 = farEndReceiverFailure5 = framingError6 = lossOfFrame7 = lossOfPointer8 = lossOfSignal9 = payloadTypeMismatch10 = transmissionError11 = remoteAlarmInterface12 = excessiveBER13 = pathTraceMismatch14 = unavailable15 = signalLabelMismatch16 = lossOfMultiFrame17 = receiveFailure18 = transmitFailure19 = modulationFailure20 = demodulationFailure21 = broadcastChannelFailure22 = connectionEstablishmentError23 = invalidMessageReceived24 = localNodeTransmissionError25 = remoteNodeTransmissionError26 = routingFailure51 = backplaneFailure52 = dataSetProblem53 = equipmentIdentifierDuplication54 = externalIFDeviceProblem55 = lineCardProblem56 = multiplexerProblem57 = nEIdentifierDuplication58 = powerProblem59 = processorProblem60 = protectionPathFailure61 = receiverFailure62 = replaceableUnitMissing63 = replaceableUnitTypeMismatch64 = synchronizationSourceMismatch65 = terminalProblem66 = timingProblem67 = transmitterFailure68 = trunkCardProblem69 = replaceableUnitProblem70 = realTimeClockFailure71 = antennaFailure72 = batteryChargingFailure73 = diskFailure74 = frequencyHoppingFailure75 = iODeviceError76 = lossOfSynchronisation77 = lossOfRedundancy78 = powerSupplyFailure79 = signalQualityEvaluationFailure80 = tranceiverFailure81 = protectionMechanismFailure82 = protectingResourceFailure101 = airCompressorFailure102 = airConditioningFailure103 = airDryerFailure104 = batteryDischarging105 = batteryFailure106 = commercialPowerFailure107 = coolingFanFailure108 = engineFailure109 = fireDetectorFailure110 = fuseFailure111 = generatorFailure112 = lowBatteryThreshold113 = pumpFailure114 = rectifierFailure115 = rectifierHighVoltage116 = rectifierLowFVoltage117 = ventilationsSystemFailure118 = enclosureDoorOpen119 = explosiveGas120 = fire121 = flood122 = highHumidity123 = highTemperature124 = highWind125 = iceBuildUp126 = intrusionDetection127 = lowFuel128 = lowHumidity129 = lowCablePressure130 = lowTemperatue131 = lowWater132 = smoke133 = toxicGas134 = coolingSystemFailure135 = externalEquipmentFailure136 = externalPointFailure151 = storageCapacityProblem152 = memoryMismatch153 = corruptData154 = outOfCPUCycles155 = sfwrEnvironmentProblem156 = sfwrDownloadFailure157 = lossOfRealTimel158 = applicationSubsystemFailure159 = configurationOrCustomisationError160 = databaseInconsistency161 = fileError162 = outOfMemory163 = softwareError164 = timeoutExpired165 = underlayingResourceUnavailable166 = versionMismatch201 = bandwidthReduced202 = congestion203 = excessiveErrorRate204 = excessiveResponseTime205 = excessiveRetransmissionRate206 = reducedLoggingCapability207 = systemResourcesOverload500 = adapterError501 = applicationSubsystemFailture502 = bandwidthReducedX733503 = callEstablishmentError504 = communicationsProtocolError505 = communicationsSubsystemFailure506 = configurationOrCustomizationError507 = congestionX733508 = coruptData509 = cpuCyclesLimitExceeded510 = dataSetOrModemError511 = degradedSignalX733512 = dteDceInterfaceError513 = enclosureDoorOpenX733514 = equipmentMalfunction515 = excessiveVibration516 = fileErrorX733517 = fireDetected518 = framingErrorX733519 = heatingVentCoolingSystemProblem520 = humidityUnacceptable521 = inputOutputDeviceError522 = inputDeviceError523 = lanError524 = leakDetected525 = localNodeTransmissionErrorX733526 = lossOfFrameX733527 = lossOfSignalX733528 = materialSupplyExhausted529 = multiplexerProblemX733530 = outOfMemoryX733531 = ouputDeviceError532 = performanceDegraded533 = powerProblems534 = pressureUnacceptable535 = processorProblems536 = pumpFailureX733537 = queueSizeExceeded538 = receiveFailureX733539 = receiverFailureX733540 = remoteNodeTransmissionErrorX733541 = resourceAtOrNearingCapacity542 = responseTimeExecessive543 = retransmissionRateExcessive544 = softwareErrorX733545 = softwareProgramAbnormallyTerminated546 = softwareProgramError547 = storageCapacityProblemX733548 = temperatureUnacceptable549 = thresholdCrossed550 = timingProblemX733551 = toxicLeakDetected552 = transmitFailureX733553 = transmiterFailure554 = underlyingResourceUnavailable555 = versionMismatchX733600 = authenticationFailure601 = breachOfConfidentiality602 = cableTamper603 = delayedInformation604 = denialOfService605 = duplicateInformation606 = informationMissing607 = informationModificationDetected608 = informationOutOfSequence609 = keyExpired610 = nonRepudiationFailure611 = outOfHoursActivity612 = outOfService613 = proceduralError614 = unauthorizedAccessAttempt615 = unexpectedInformation1024 = otherITU-T probable cause values. Duplicate values defined in X.733 are appended with X733 to ensure syntactic uniqueness. Probable cause value 0 is reserved for special purposes. The Internet Assigned Number Authority (IANA) is responsible for the assignment of the enumerations in this TC. IANAItuProbableCause value of 0 is reserved for special purposes and MUST NOT be assigned. Values of IANAItuProbableCause in the range 1 to 1023 are reserved for causes that correspond to ITU-T probable cause. All other requests for new causes will be handled on a first-come, first served basis and will be assigned enumeration values starting with 1025. Request should come in the form of well-formed SMI [RFC2578] for enumeration names that are unique and sufficiently descriptive. While some effort will be taken to ensure that new probable causes do not conceptually duplicate existing probable causes it is acknowledged that the existence of conceptual duplicates in the starting probable cause list is an known industry reality. To aid IANA in the administration of probable cause names and values, the OPS Area Director will appoint one or more experts to help review requests. See http://www.iana.orgReference: ITU Recommendation M.3100, 'Generic Network Information Model', 1995 ITU Recommendation X.733, 'Information Technology - Open Systems Interconnection - System Management: Alarm Reporting Function', 1992 ITU Recommendation X.736, 'Information Technology - Open Systems Interconnection - System Management: Security Alarm Reporting Function', 1992 · Integer32

ITU probable cause values.

ituAlarmAdditionalText

1.3.6.1.2.1.121.1.1.1.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Represents the additional text field for the alarm.

ituAlarmGenericModel

1.3.6.1.2.1.121.1.1.1.1.5

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

This object points to the corresponding row in the alarmModelTable for this alarm severity. This corresponding entry to alarmModelTable could also be derived by performing the reverse of the mapping from alarmModelState to ituAlarmPerceivedSeverity defined in the description of ituAlarmEntry to determine the appropriate { alarmListName, alarmModelIndex, alarmModelState } for this { alarmListName, alarmModelIndex, ituAlarmPerceivedSeverity }.

ituAlarmActiveTable

1.3.6.1.2.1.121.1.2.1

Index: alarmListName · alarmActiveDateAndTime · alarmActiveIndex

A table of ITU information for active alarms entries.

from ALARM-MIB

alarmListName

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

The name of the list of alarms. This SHOULD be the same as nlmLogName if the Notification Log MIB [RFC3014] is supported. This SHOULD be the same as, or contain as a prefix, the applicable snmpNotifyFilterProfileName if the SNMP-NOTIFICATION-MIB DEFINITIONS [RFC3413] is supported. An implementation may allow multiple named alarm lists, up to some implementation-specific limit (which may be none). A zero-length list name is reserved for creation and deletion by the managed system, and MUST be used as the default log name by systems that do not support named alarm lists.

alarmActiveDateAndTime

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

The local date and time when the error occurred. This object facilitates retrieving all instances of alarms that have been raised or have changed state since a given point in time. Implementations MUST include the offset from UTC, if available. Implementation in environments in which the UTC offset is not available is NOT RECOMMENDED.

alarmActiveIndex

Unsigned32 (1..4294967295)

A strictly monotonically increasing integer which acts as the index of entries within the named alarm list. It wraps back to 1 after it reaches its maximum value.

ituAlarmActiveTrendIndication

1.3.6.1.2.1.121.1.2.1.1.1

ItuTrendIndication1 = moreSevere2 = noChange3 = lessSevereITU trend indication values for alarms.Reference: ITU Recommendation M.3100, 'Generic Network Information Model', 1995 ITU Recommendation X.733, 'Information Technology - Open Systems Interconnection - System Management: Alarm Reporting Function', 1992 · Integer32

Represents the trend indication values for the alarms.

ituAlarmActiveDetector

1.3.6.1.2.1.121.1.2.1.1.2

AutonomousTypeRepresents an independently extensible type identification value. It may, for example, indicate a particular sub-tree with further MIB definitions, or define a particular type of protocol or hardware. · OBJECT IDENTIFIER

Represents the SecurityAlarmDetector object.

ituAlarmActiveServiceProvider

1.3.6.1.2.1.121.1.2.1.1.3

AutonomousTypeRepresents an independently extensible type identification value. It may, for example, indicate a particular sub-tree with further MIB definitions, or define a particular type of protocol or hardware. · OBJECT IDENTIFIER

Represents the ServiceProvider object.

ituAlarmActiveServiceUser

1.3.6.1.2.1.121.1.2.1.1.4

AutonomousTypeRepresents an independently extensible type identification value. It may, for example, indicate a particular sub-tree with further MIB definitions, or define a particular type of protocol or hardware. · OBJECT IDENTIFIER

Represents the ServiceUser object.

ituAlarmActiveStatsTable

1.3.6.1.2.1.121.1.2.2

Index: alarmListName

This table represents the ITU alarm statistics information.

from ALARM-MIB

alarmListName

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

The name of the list of alarms. This SHOULD be the same as nlmLogName if the Notification Log MIB [RFC3014] is supported. This SHOULD be the same as, or contain as a prefix, the applicable snmpNotifyFilterProfileName if the SNMP-NOTIFICATION-MIB DEFINITIONS [RFC3413] is supported. An implementation may allow multiple named alarm lists, up to some implementation-specific limit (which may be none). A zero-length list name is reserved for creation and deletion by the managed system, and MUST be used as the default log name by systems that do not support named alarm lists.

ituAlarmActiveStatsIndeterminateCurrent

1.3.6.1.2.1.121.1.2.2.1.1

Gauge32

A count of the current number of active alarms with a ituAlarmPerceivedSeverity of indeterminate.

ituAlarmActiveStatsCriticalCurrent

1.3.6.1.2.1.121.1.2.2.1.2

Gauge32

A count of the current number of active alarms with a ituAlarmPerceivedSeverity of critical.

ituAlarmActiveStatsMajorCurrent

1.3.6.1.2.1.121.1.2.2.1.3

Gauge32

A count of the current number of active alarms with a ituAlarmPerceivedSeverity of major.

ituAlarmActiveStatsMinorCurrent

1.3.6.1.2.1.121.1.2.2.1.4

Gauge32

A count of the current number of active alarms with a ituAlarmPerceivedSeverity of minor.

ituAlarmActiveStatsWarningCurrent

1.3.6.1.2.1.121.1.2.2.1.5

Gauge32

A count of the current number of active alarms with a ituAlarmPerceivedSeverity of warning.

ituAlarmActiveStatsIndeterminates

1.3.6.1.2.1.121.1.2.2.1.6

ZeroBasedCounter32This TC describes an object that counts events with the following semantics: objects of this type will be set to zero(0) on creation and will thereafter count appropriate events, wrapping back to zero(0) when the value 2^32 is reached. Provided that an application discovers the new object within the minimum time to wrap, it can use the initial value as a delta since it last polled the table of which this object is part. It is important for a management station to be aware of this minimum time and the actual time between polls, and to discard data if the actual time is too long or there is no defined minimum time. Typically, this TC is used in tables where the INDEX space is constantly changing and/or the TimeFilter mechanism is in use. · Gauge32

A count of the total number of active alarms with a ituAlarmPerceivedSeverity of indeterminate since system restart.

ituAlarmActiveStatsCriticals

1.3.6.1.2.1.121.1.2.2.1.7

ZeroBasedCounter32This TC describes an object that counts events with the following semantics: objects of this type will be set to zero(0) on creation and will thereafter count appropriate events, wrapping back to zero(0) when the value 2^32 is reached. Provided that an application discovers the new object within the minimum time to wrap, it can use the initial value as a delta since it last polled the table of which this object is part. It is important for a management station to be aware of this minimum time and the actual time between polls, and to discard data if the actual time is too long or there is no defined minimum time. Typically, this TC is used in tables where the INDEX space is constantly changing and/or the TimeFilter mechanism is in use. · Gauge32

A count of the total number of active alarms with a ituAlarmPerceivedSeverity of critical since system restart.

ituAlarmActiveStatsMajors

1.3.6.1.2.1.121.1.2.2.1.8

ZeroBasedCounter32This TC describes an object that counts events with the following semantics: objects of this type will be set to zero(0) on creation and will thereafter count appropriate events, wrapping back to zero(0) when the value 2^32 is reached. Provided that an application discovers the new object within the minimum time to wrap, it can use the initial value as a delta since it last polled the table of which this object is part. It is important for a management station to be aware of this minimum time and the actual time between polls, and to discard data if the actual time is too long or there is no defined minimum time. Typically, this TC is used in tables where the INDEX space is constantly changing and/or the TimeFilter mechanism is in use. · Gauge32

A count of the total number of active alarms with a ituAlarmPerceivedSeverity of major since system restart.

ituAlarmActiveStatsMinors

1.3.6.1.2.1.121.1.2.2.1.9

ZeroBasedCounter32This TC describes an object that counts events with the following semantics: objects of this type will be set to zero(0) on creation and will thereafter count appropriate events, wrapping back to zero(0) when the value 2^32 is reached. Provided that an application discovers the new object within the minimum time to wrap, it can use the initial value as a delta since it last polled the table of which this object is part. It is important for a management station to be aware of this minimum time and the actual time between polls, and to discard data if the actual time is too long or there is no defined minimum time. Typically, this TC is used in tables where the INDEX space is constantly changing and/or the TimeFilter mechanism is in use. · Gauge32

A count of the total number of active alarms with a ituAlarmPerceivedSeverity of minor since system restart.

ituAlarmActiveStatsWarnings

1.3.6.1.2.1.121.1.2.2.1.10

ZeroBasedCounter32This TC describes an object that counts events with the following semantics: objects of this type will be set to zero(0) on creation and will thereafter count appropriate events, wrapping back to zero(0) when the value 2^32 is reached. Provided that an application discovers the new object within the minimum time to wrap, it can use the initial value as a delta since it last polled the table of which this object is part. It is important for a management station to be aware of this minimum time and the actual time between polls, and to discard data if the actual time is too long or there is no defined minimum time. Typically, this TC is used in tables where the INDEX space is constantly changing and/or the TimeFilter mechanism is in use. · Gauge32

A count of the total number of active alarms with a ituAlarmPerceivedSeverity of warning since system restart.

↑ To TOC